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What's new 

What's new for FlexiPDF 2019? 

Features: 

• Create interactive forms – now you can edit and create interactive forms using FlexiPDF 

•   Side-by-side comparisons of any two PDFs 

•  New Snapshot tool for quick access to the image snapshot function. 

• New Image > Edit option to allow images to be edited in an external editor then automatically reloaded into the 

PDF page. 

• Bates Numbering for documents and portfolios 

• Find & Replace Colours throughout a document 

• Split documents into new PDFs each with a given number of pages. 

• Ability to save PDF in the older PDF 1.4 format for better compatibility with older PDF viewers 

• New, simpler Text Fitting dialog and fitting engine to give better looking text. 

• New Text Spacing palette for faster access to letter, space, line and paragraph settings. 

• The Font Remapping dialog now repairs bad mappings enabling other PDF applications to correctly operate 

with the PDF. 

User interface improvements: 

• All toolbar icons have been redesigned from scratch. 
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• New toolbar customisation options offering toolbar labels and large icons. 

• One unified work mode instead of the three modes "View", "Comment" and "Edit" 

• More user-friendly structured menus 

• New zoom icons: 

o  – Fit page into window 

o  – Zoom to the full page width 

•  New Line-spacing quick-access button to simplify the toolbar 

•  New Save As button on the toolbar 

• New Font Browser to make choosing fonts easier and faster 

• New, easier to use Preferences dialog box 

• New Page Operations toolbar and menu for common page operations – rotate , add, extract and delete. 

• Auto Fix button on Problem Report dialog to quickly fix overflowing text problems 

• Improved Problem Report  with support for auto-fit size changes (handy for translation) 

• New Swatches tab in the colour picker dialog 

 

System requirements 

• Windows 10, 8, 7 or Vista 

• 4 GB RAM 
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1.  Quick Start 

 

Activate your software 

FlexiPDF adds watermarks to saved PDFs unless you unlock the software using the product key supplied when 

purchased. 

Product keys are usually provided as part of a purchase receipt email. If you cannot find your product key, please 

contact us using the SoftMaker Customer Center. 

How to unlock your software 
1. Choose Help > Buy/Activate from the menu bar to display the Buy/Activate FlexiPDF dialog box. 

2. If you have your activation key code to hand, press Activate. 

3. If you have not yet purchased FlexiPDF, press Purchase. 

This will open the FlexiPDF web-page in your web browser. From there you will be able to purchase the 

software. 

4. Once you have bought a license and have the product key emailed to you, press the Activate button. 

 

 
 

5. In the edit control Keycode, enter the product key you received when you purchased the software. 

6. Press Activate. You should receive confirmation that your software has been activated and details of when your 

license will expire. 

 

Basic text editing 

FlexiPDF enables you to edit text in a PDF document as if you were using a word processor.  

1. Open the PDF to be edited. 

2. In this example, there is an "r" missing from "you". 

3. From the toolbar select the Text tool  – the Text tool is the default tool when FlexiPDF starts, so it may 

already be selected. 

4. Click the mouse on the text to be edited, and you can begin editing. You will notice some pink marks on the 

page – the pink dots represent spaces, and each paragraph ends in the ¶ symbol. These pink shapes appear only 

during editing and will not be visible in any other PDF viewer. 

 

http://softmaker.com/go/cc
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5. Edit the text. For this example, we will enter "r" to make "your". 

As soon as you do this, you may see the overset text warning: 

 

 
 

This is because there is now too much text for the original text box. This warning only appears once just to get 

people used to the idea of overflowing ("overset") text. 

6. To resize the text box and make room for the text, drag the left and right handles outwards to make the box 

wider. You should eventually be able to get the text to fit. If you can't, you could try using the automatic text 
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fitting features. 

 

 
 

In this example, the new ‘r’ is displayed in red because Show changes is enabled in the Preferences dialog. 

This change highlighting is only visible in FlexiPDF and not in any other PDF viewer. 

7. Once you have finished resizing, save the changes you have made to your PDF by choosing File > Save As. 

If you you use FlexiPDF in trial mode, you will see this dialog box. 
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You now have two choices: 

1. Save with Watermark 

Save your PDF with a watermark added to edited pages. The watermarks can be safely removed at a 

later date, if you purchase a license. This means you will not lose any changes you make – they can all 

be recovered after purchasing a license. 

2. Activate 

Unlock your copy of FlexiPDF using the product key supplied when you purchase the software. After 

activation, watermarks are no longer added to PDFs, and you can remove any watermarks already 

added to edited PDFs by opening the PDF and saving it again from the unlocked copy of FlexiPDF. 

 

Join PDF files 

Available in FlexiPDF Standard, Professional, NX Home, NX Universal 

FlexiPDF can quickly join multiple PDF documents into a single document. 

1. Drag and drop any number of PDF files onto an open but empty FlexiPDF window, or choose File > Join. 

2. Add further files or entire folders full of files using the Add Files and Add Folder buttons. When adding 

folders, any PDF found in the folder or its sub-folders will be added to the list. There is no limit on the number 

of files that can be added. 

3. To change the order in which they will be joined together, select a file, then press Up or Down to move it 

higher or lower in the list. 

4. Press Join to begin the process of merging the documents together. FlexiPDF will prompt for a file name for 

the new merged document. 

5. Once the process is complete, FlexiPDF will ask if you wish to open the new file. 

Notes 

• To add page numbers to a document after merging, see Numbering. 

• FlexiPDF will reject encrypted PDFs. Remove any passwords and encryption from all files before trying to join. 

See Security. 

 

Convert from PDF 

To convert a PDF into HTML, text or RTF or to export the images within a PDF, use the File > Export command. 

FlexiPDF can export a document on a page-by-page basis or an article-by-article basis. 

Exporting a range of pages 
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• Choose File > Export > Pages as. 

• Choose the range you wish to export. 

• Near the bottom of the dialog box is a summary of the output format that will be used for the export. To change 

the output format, press Format. The output options available are detailed in General export settings. 

Exporting by article thread 

 
 

• Choose File > Export > Articles as. 

If your document contains no article threads, you can create new articles. 

• Choose to export just the articles beginning on the current page, or all articles in the document. If no articles 

begin on the current page, only one option will be available. 

• Near the bottom of the dialog box is a summary of the output format that will be used for the export. To change 

the output format, press Format. 

The output options available are detailed in General export settings. 

 

Convert to PDF 

To convert any document to PDF, print it using the FlexiPDF printer driver. 

• Open the document in the application you normally use to view it. 

• Print the document and choose FlexiPDF as the printer to use. 

• If you do not see FlexiPDF listed as an available printer it may be that you did not choose to install it when you 

installed FlexiPDF – it is an optional feature. See “Re-installing the FlexiPDF printer” below. 

• To change the paper size used for the final PDF, press Preferences then Advanced 

• After printing has finished, FlexiPDF will open showing the new PDF created. The new PDF may be edited and 

saved as normal. 

Re-installing the FlexiPDF printer 
Make sure FlexiPDF is not running, then run the FlexiPDF installer again. 

If you need to download a copy, it will be available on the support page of SoftMaker’s web site at 

http://www.softmaker.com 

Make sure you choose to install the FlexiPDF printer by ticking the checkbox on the 5th screen of the installer. 

 

http://www.softmaker.com/
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Side-by-side comparisons 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

The side-by-side comparison feature places two PDF side-by-side. As you move around, zoom in and out of one 

PDF, the other keeps in-step, ensuring you see the same view of each PDF. 

To begin a comparison, either: 

• Drag and drop two PDFs onto an empty FlexiPDF window. 

The order in which you select the files prior to dropping dictates the layout. The second file selected will be the 

left hand side of the comparison and will be read-only. 

• Drag and drop a PDF onto an FlexiPDF window in which a PDF is already open. 

The file that was originally open will appear on the right-hand side of the comparison. 

In each case FlexiPDF will only offer the comparison if both documents have the same number of pages. 

Horizontal / Vertical Layout 

Choose Translate > Compare Vertical or press  on the Translation toolbar (View > Toolbars > Translation) 

to switch to having one PDF on top of the other. 
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In vertical mode, the editable PDF is at the bottom of the window. 

Choose Translate > Compare Horizontal or press  on the Translation toolbar (View > Toolbars > 

Translation) to switch to a side-by-side comparison. 

 

 
 

In horizontal mode, the translated PDF is on the right-hand-side of the screen. 

Exiting comparison mode 
To exit comparison mode, choose the current comparison layout menu item again.  

For example, if you are in Compare Horizontal mode, choose Translate > Compare Horizontal again. 

 

Create and fill forms 

FlexiPDF can be used to fill in both interactive and non-interactive forms. 

Interactive Forms 
An interactive form is a specially prepared PDF which contains interactive elements like text boxes, buttons and 

lists. You can interact with these, supplying text and making selections. You can then save, print or send this filled-

in PDF to others via email. See Interactive forms. 

Traditional Paper Forms (Non-interactive forms) 
A non-interactive form is simply a PDF version of a traditional paper form. Normally this would have to be printed 

out then filled-in by hand. With FlexiPDF, you can use the Text+ tool to fill in text fields and check boxes, speeding 

up the entire process while keeping the form entirely digital and available to print or attach to an email. 

1. Select the Text+ tool . 

As you move the mouse over the form, FlexiPDF will try to highlight the areas to be filled in. FlexiPDF makes 

a guess at the shape and location of editable areas. Sometimes it may guess incorrectly. In those cases, hold 

down Control as you click to ignore the guess. 

2. Click on a highlighted area to begin typing into it. 

Hold the Ctrl key when you click to ignore FlexiPDF’s guess and create a small, single-line text box. 

3. If FlexiPDF determines that the item under the mouse looks like a check-box, it changes the cursor to a pointing 

hand. Click to mark the box with an X. Click again to remove the X. 

Hold the Ctrll key and click to ignore the check-box and create a small, single-line text box. 

Hold Ctrl+Shift to force FlexiPDF to create an X even when it doesn’t recognise the area as being a checkbox. 

Notes 

• Use the Text+ tool  to create new text boxes in any kind of PDF, not just form-style documents. 

• The Text+ tool  does not edit existing text – only text created by the tool either during this session or from 

when the PDF was last edited. 

• Since FlexiPDF is making a guess at the shape and location of editable areas, it may sometimes arrive at an 

incorrect decision. In this case, hold down Ctrl as you click to ignore the guess. 
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• Filled-in forms are normal PDFs that can be viewed and printed by any PDF viewing application. 

 

Photo albums 

Available in FlexiPDF Standard, Professional, NX Home, NX Universal 

Drag and drop any number of images onto FlexiPDF, and it will create a new PDF in which each page shows one of 

the images dropped. 

1. Ensure no documents are open in FlexiPDF. 

2. Drag and drop a number of JPEG, TIFF, PNG or BMP images onto FlexiPDF. 

3. FlexiPDF will construct a new PDF, in which each page contains one of the dropped images. 

 

Snapshots 

Available in FlexiPDF Standard, Professional, NX Home, NX Universal 

If you need to export a particular photograph or image to a file, see Extracting images. 

If you need to export whole pages of your file to image files, see Image Output. 

To take a snapshot of part of a page and save it to a file: 

1. Click on the Snapshot tool . 

2. Drag out a rectangle around the area you want to snapshot. 

As soon as you stop dragging, the box is fixed, and the Save Snapshot dialog box opens. 

 

 
 

3. Choose the resolution for rendering the snapshot. The higher the value, the larger and more detailed the saved 

image will be. 

4. Choose the colour-depth for the snapshot.  

RGB (red/green/blue) is full colour, all the other options are variations of black and white. 

5. If you want a transparent background to the snapshot, click on Retain Transparency.  

This option is only available when PNG format and RGB are chosen. 

6. Press OK and choose a file name for your saved image. 
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2.  Editing text 

 

Add new text 

Adding a single-line text box 
A new, single-line text box can be added at any time. 

1. Select the Text+ tool  from the toolbar. 

2. Click to create a new fixed-size text box. As you type into this box, it will stretch horizontally. 

3. If the font size is too large to fit and you see the red overset box on the right-hand size of the text box, resize 

the box by dragging on the North, South, East, West resize handles. 

Using the Text tool 
New text can be added at any time by dragging out a new text box of the required size. 

1. Select the Text tool  from the toolbar. 

2. Click and drag to create a new text box. 

3. Choose the required font and size from the Formatting toolbar before editing. 

4. A new text box will grow downwards if there is too much text to fit into it. If you resize the box by dragging 

one of its handles, it will then retain that shape and no longer grow to accommodate more text. 

5. If you see the red overset box in the bottom right-hand side of the text box, it means there is too much text to fit 

into the box. Resize the box by dragging on the North, South, East, West resize handles. 

Choosing the correct language 
When editing PDFs written in various different languages, please remember the following: 

• Hyphenation will only work if the correct language is chosen using the File > Preferences command. If the 

correct language is not available, it may be better to disable hyphenation. 

• Spell check requires the correct language to be specified using the File > Preferences command. 

• FlexiPDF only supports editing of text read left-to-right. This means editing of Arabic and Hebrew texts is not 

supported. 

Unicode support 
FlexiPDF fully supports copy/paste of double-byte characters. 

On a Windows PC, a double-byte character can be typed directly by holding down Alt while entering the decimal 

value of the character using the numeric keypad (ensure that NumLock is lit on your keyboard). The character will 

be inserted when you release the Alt key. 

For example: Alt 0190 = ¾ 

The character codes can be found by using the Character Map utility available in Microsoft Windows. 

 

Edit existing text 

To edit existing text: 

1. Select the Text tool  from the toolbar. 

2. Click on a block of text to begin editing. 

The Formatting toolbar and ruler will activate and a text box will be drawn around the text block being edited. 
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3. When you begin editing, spaces, paragraph marks and line-breaks will show up in pink. These will become 

invisible again when you finish editing. Choose View > Text > Non-Printing Characters to disable this 

behaviour. 

4. To see the outline of all text boxes on a page, choose View > Text > Boundaries. 

5. To insert a line break without starting a new paragraph, press Shift+Return. 

6. The ruler above the page shows the width of the page and the left, first-line and right indents for the current 

paragraph. 

 

 
 

Drag the margin markers shown above, to change the left, right and first-line indents. 

Notes 

• See also Basic Text Editing. 

 

Edit across columns & pages 

If you link text boxes together, you can edit text seamlessly across them all. The text boxes will remain linked 

together even after you close and re-open the PDF, provided that Store layout in PDF is enabled. 

1. Select the Linked text tool  from the toolbar. 

2. Click the mouse in the middle of each column you wish to link together. The text box will highlight and a 

number will be displayed in the middle. This number shows the order in which text will flow between the 

boxes. 

3. Click the same box twice to remove it from the flow. 

4. Keep adding further boxes by clicking the mouse. You can change pages and add text from different pages to 

the flow. 

5. To start a new, separate chain of boxes, click (with the Linked text tool  active) in a non-text or empty area 

of the page. Currently linked text boxes will be re-drawn with no numbering. Then repeat from step 2 onwards. 

6. When you are ready to begin editing, select the Text tool  from the toolbar. 

Notes 

• Prior to linking text boxes, every box ends with a paragraph break. When linked together, FlexiPDF looks to see 

if those breaks are necessary or a consequence of the text breaking across boxes, and removes those it thinks are 
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not required. This is only an educated guess, so you may find a lingering paragraph break where none is needed. 

After reflow, this paragraph break may end up somewhere in the middle of an adjacent text box. Remove them 

to restore the original flow. 

• When linking text boxes, the text is not immediately reflowed and should look no different. However, when you 

reload a document with linked boxes and begin to edit, those boxes are reflowed prior to your first edit. It is at 

this point that you may see reflow issues for the first time. 

 

Overset text 

When you type too much text, any text that overflows the text box will be hidden. A small overset icon will appear 

in the bottom right-hand corner of the text box to warn you that some text cannot be seen. 

 

 
 

Reshape the text box 
To reveal the hidden text, make the text box larger by dragging the resize handles located on its edges using the 

Text tool  or the Object tool . 

You can link multiple text boxes together, so that text flows between them. See Editing across columns & pages. 

Other ways of avoiding overset text 

• Reduce the size of the text by: 

o changing the font size of the text 

o changing the spacing between lines using the line-spacing button in the toolbar 

o changing other spacing parameters such as tracking (spacing between letters). 

• Use the auto-fit feature to automatically squeeze the text into the text box. 

Notes 

• When saving a PDF, FlexiPDF will check for overset text and report the first instance found. 

• The red boxes are aids only and will not appear when the PDF is viewed in any other PDF viewer. 

• Why is it called "overset"? In the past, those responsible for preparing the text on a printed page were known 

as typesetters. When setting the type, if they found there was too much to fit in the space provided, the page 

was said to be over-set. Similarly, too little type was known as under-set. 

 

Spelling check 

After editing, it is useful to check the spelling of any new text added. You can check the spelling of words in three 

ways: 

• Check the words in a text selection 

• Check words in active text blocks 

• Check the whole document (if there is no active text block) 
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Start the spell check by choosing Edit > Check Spelling or pressing F7. As each suspect word is displayed in the 

dialog box, FlexiPDF will also highlight it on the page. 

The Spelling dialog box 
 

 
 

• Double-click on a suggestion to make the change or single-click, then press Change All. 

• Press Add to add the suspect word to your dictionary. 

• If the language used for spell check does not match the language of the document, click on the Language 

hyperlink to choose the correct language. 

Notes 

• Be careful when changing text in paragraphs with unusual shapes (such as those that flow around graphics). 

When the paragraphs are reflowed, their layout may be lost. See Flowing text around shapes for methods of 

dealing with this. 

• If the words shown in the Suspect field seem garbled or include strange characters it indicates that the text 

cannot be extracted correctly from the PDF. This is caused by improper encoding of the PDF’s fonts and cannot 

be remedied with FlexiPDF. 

• You can edit the contents of the spelling dictionary – see Custom Spelling Dictionaries. 

• FlexiPDF will warn you if the replacement text cannot be rendered in the font used by the misspelled text. In 

this case, you may have to choose a different font for the text. 

• Words that include numbers cannot be learnt by the spell checker. You can however, skip checking such words 

using the Ignore All button. 

 

Custom dictionaries 

When you press the Add button during spell check, FlexiPDF records the word you are adding in a custom 

dictionary file. 

If you add a word by mistake you can edit the custom dictionary by hand using any standard text editor (such as 

Notepad). 

If you already have a custom dictionary you want FlexiPDF to use, you can add its contents to FlexiPDF’s existing 

dictionary using a text editor. 

Locating the custom dictionary 
All of the custom dictionary files for each language are stored in the same folder. A *.pws file is only created if you 

have added words during a spell check,. 
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On Windows XP, the default installation path would be: 

C:\Documents and Settings\<username>\Application Data\Aspell\personal 

On Windows Vista, 7, 8 and 10: 

C:\Users\<username>\AppData\Roaming\Aspell\personal 

or 

C:\Users\<username>\AppData\Local\Aspell\personal 

Format of custom dictionary 
The *.pws dictionary files are simple lists of words, each on a new line. An example is shown below: 

 
personal_ws-1.1 es 7 

Adstract 

Technology 

SoftMaker 

Ltd 

Bushnell 

Norwich 

Guy 

 

The number at the end of the first line is the count of words in the list. The language code is prior to that – in this 

case ‘es’ for Spanish. 

Changes to the custom dictionary will take effect the next time FlexiPDF is launched. 

 

 

 

Character palette / Special characters 

Use the Character Palette dialog to insert characters that are difficult to enter directly from the keyboard or to 

inspect the selection of characters offered by a specific font. 

1. Click on some text to begin editing using the Text tool . 

2. Choose Text > Character Palette. 
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3. Use the font menu at the top of the dialog box to choose the required font from the PDF’s fonts or from your 

computer’s system fonts.  

4. Click on a glyph (character shape) to select it and view its properties: 

o Glyph: name as used in the PDF (not always available) 

o Character: official Unicode description 

o Font: type of the font from which it comes 

5. Double-click to insert it into the PDF. 

6. Press Remap to re-define the meaning of badly mapped glyphs. 

 

Text alignment (vertical) 

FlexiPDF can align text inside a text box so that it sits at the top, middle or bottom of a text box.  

It can also make text automatically fit its text box by altering various aspects of the text formatting. 

1. Select the Text tool  from the toolbar. 

2. Click in the text box you wish to edit. 

3. Choose an alignment from Text > Alignment. 

Notes 

• For linked text boxes, the alignment reverts to "Top". 

 

Text fitting 

FlexiPDF can automatically fit text in a text box by stretching or shrinking various aspects of it in a way that leaves 

the text looking good. The degree of adjustment can be tailored to your needs. For example, translators could 

employ all options to ensure translated text fits in all cases, no matter how verbose. 
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When there is too much text... 

1. Select the Text tool  from the toolbar. 

2. Click in the text box you want to change. 

3. Choose Text > Fitting. 

 

 
 

4. Click on Try to shrink to fit. This will reduce the letter spacing of text to get it to fit. This is a subtle 

adjustment (the equivalent of -35 in the letter spacing palette), so will not be enough when there is far too much 

text to fit. 

5. Click Reduce Font Size to reduce the font size in order to get the text to fit. This works in tandem with the 

letter-spacing adjustments of step 4 and is a more noticeable effect though it may not always succeed in 

producing a fit.  

o Choose the maximum amount of size reduction to apply. 

 A value of 30% is a reasonable amount to begin. Choose a higher value if the text still doesn't fit. If 

you feel the font-size is getting too small, try the next step. 

6. Click Reduce Line Spacing to adjust the space between lines and paragraphs. This works in tandem with letter-

spacing adjustment (step 4) and font-size adjustment (step 5) to produce a very noticeable effect. If you find you 

are having to reduce the font size by too much, enabling this option should improve things. Use only when you 

don't need to maintain alignment with the original baseline grid of the page. 

When there is too little text... 

1. Select the Text tool  from the toolbar. 

2. Click in the text box you want to change. 

3. Choose Text > Fitting. 
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4. Click Try to stretch to fit to expand the letter spacing of text to get it to fit. This is a subtle adjustment, so will 

not be enough when there is far too little text to fill the text box. 

5. Tick Increase Font Size to gently increase the font size in order to get the text to fit. This works in tandem with 

the letter-spacing adjustments of step 4 and is a more noticeable effect though it may not always succeed in 

producing a fit. 

6. Tick Increase Line Spacing to adjust the space between lines and paragraphs. This works in tandem with 

letter-spacing adjustment (step 4) and the optional font-size adjustment (step 5) to produce a very noticeable 

effect. Use this only when there is no need to maintain alignment with the original baseline grid of the page 

design. 

Notes 

• Fitting is a complex process which can slow down editing. Only enable fitting when you have completed most 

of your text editing. 

• The chosen fitting is remembered the next time you load the PDF if you have Store layout in PDF enabled. 

• When editing auto-fit text, the font size drop-down in the toolbar is disabled and will show the percentage 

change in font size. For example, if auto-fit has reduced the font-size by 30%, "(70%)" will be shown instead of 

the actual font size. 

 

Flow text around shapes 

Sometimes the text in a text box needs to flow around another shape, such as an image or diagram. 

You could do this by adjusting the left/right margins of each paragraph in the text box – see Margins & Indents. 

A faster approach is to adjust the line width of just those lines affected. 

Manual Line Width Adjustment 
1. The text below needs to run around the blue rectangle. 
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2. Using the Text tool , select the lines that need to move. 

 

 
 

3. Choose Text > Line Width > Manual. 

4. A border is drawn around all the lines affected and the ruler changes to a blue background. 

5. Select the lines again, then drag the right-margin marker on the ruler left, until you are clear of the blue 

rectangle. 

 

 
 

6. The text box will reflow but the lines you adjusted will remain shorter than the other lines thus avoiding the 

blue rectangle. 
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Notes 

• The fact that a line of text is in manual adjustment mode is not recorded when you save the PDF. If you reload 

and edit text that was previously reflowed in this way, it will revert to the original paragraph margins and (in 

this example) overwrite the blue rectangle again. 

 

Rebuild a text box 

FlexiPDF can grab the text from an area of the page, sort it and build a new text box from it. This is useful for 

documents that have many disjoint text blocks making editing difficult.  

This technique may also be useful for translators when a few paragraphs are exported in the wrong order. 

Regrouping them with this approach can remedy some of those issues. 

Example 
Owing to the way in which this example PDF was produced, FlexiPDF has created many overlapping text blocks 

which make editing difficult. 

 

 
 

In some cases, lines from two distinct columns of text have been grouped into a single, wide text block. (View > 

Text > Boundaries has been enabled to show the outline of each text box.) 

1. Select the Text tool  from the toolbar. 

2. Drag out a new text box large enough to enclose all of the text you wish to include in your new text box. 
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3. Choose Text > Text Box > Rebuild 

Any text enclosed by the new text box will be removed from the existing text boxes then sorted and placed into 

the new text box. Any text boxes that become empty as a result will be deleted. Usually, the text placed in the 

new text box will have a more accurate paragraph structure and be easier to edit. 

 

 
 

 

Merge text boxes 

Vertically aligned text boxes can be merged together into a single box. This is an alternative to linking text boxes 

together which is handy for reflowing across columns or pages. See Editing across columns & pages. 

Example 
In this example, FlexiPDF has split the text into three boxes. 
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This will produce the wrong results when the text is reflowed since the text should really all be in a single text box. 

1. Select the Object tool  from the toolbar. 

2. Click on each of the text boxes you want joined. Make sure you start at the topmost box first. 

3. Click on each additional box while holding the Shift key. This will add each new text block to the selection. 

4. Once all are selected, choose Text > Text Box > Merge Vertically to join the separate boxes into one. Only 

boxes in the same vertical row running from top to bottom will be joined. 

5. Once joined, text will flow as a single column and should look better. 

 

 
 

 

Split text boxes 

Text blocks can be split at paragraph boundaries. This can make editing large blocks of text faster and helps to avoid 

reflowing text that does not need it. 

1. Select the Object tool  from the toolbar. 

2. Click on each of the text box you want to split. 

3. Choose Text > Text Box > Split Paragraphs. 

 

Remap fonts 

Every font in a PDF file includes a mapping from the glyph shapes to their meaning. Without this mapping, editing 

would not be possible nor would content export. In some PDF documents, these mappings are incorrect or 

corrupted. 

Previous versions of FlexiPDF could apply a partial fix, so that the PDF could be edited or exported. FlexiPDF 2019 

goes further and can repair the mapping so that it and other PDF editors can edit and export the text correctly. 
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Manually correcting the font mapping 
 

1. Choose Text > Remap Fonts to open the font mapping dialog box. The dialog box is similar to the Character 

Palette dialog. 

2. Click on a glyph that has an incorrect mapping. 

 

 
 

In this example, glyph shape '6' is incorrectly mapped to '&'. This means that if you were to convert this PDF to 

HTML for example, all occurrences of 6 would export as &. 

3. Press 6 on your keyboard to fix the mapping. 

4. The glyph display will change, showing the shape 6 and the mapping 6 in the bottom right corner with a yellow 

background. 

5. The next glyph in the table will be selected automatically. 

6. Keep pressing keys on the keyboard to remap each glyph in turn.  

7. Press OK to repair the PDF using the mapping you just made. 

Automatically correcting the font mapping 
FlexiPDF 2019 also offers automated repair. Press the Auto Correct button, and FlexiPDF will use optical character 

recognition (OCR) to identify every glyph in the selected font. 

The process is much faster than correcting by hand. However, in some cases the OCR may make a mistake. In this 

case, just correct it as detailed above. 

The Auto Correct feature is limited to Latin characters and a few accented glyphs. It is best used on fonts with 

basic Latin glyphs. 

 

Convert text to outlines 

If you experience problems printing certain PDFs (symptom: wrong fonts or glyphs), you can convert text to vector 

outlines. 

1. To convert text to outlines, choose Text > Create Outlines. 

2. Choose a file name for the new PDF that will be created. 

Notes 

• Converted text will no longer be editable or searchable by FlexiPDF or any other application. 

• Outlined characters will not benefit from font hinting which improves display of characters at low resolutions. 

However, at the kind of resolutions used by printers, font hinting is not necessary. 

• After conversion, you are guaranteed to avoid all font related printing problems, since fonts will no longer play 

a part in the PDF (it will just be pages of vector art). 

• The conversion encompasses all text across all pages of the PDF and cannot be undone. 

 

Edit tables 

To make it easier to edit text in tables without disturbing the layout, mark-up the tabular region with a FlexiPDF 

Table Box. For maximum effect, it is best to mark up tables before you begin editing on the page. 

FlexiPDF will try to make each cell into a separate paragraph. Though this will assist with editing, it is not a full 

table editor, but just a collection of text boxes.  
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Notes 

• If you need to add or move rows, use the Object tool  to select and move and duplicate columns or rows of 

text boxes and lines. 
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3.  Formatting text 

 

Font browser 

Use the Font Browser window to look through and choose new fonts.  

Changing the font used for text 

1. Choose the Text tool  from the toolbar and select the text you wish to change. 

Alternatively, choose the Object tool  and click on the text box you wish to change. 

2. Click on the font selector shown circled below: 

 

 
 

3. The Font Browser window will open, showing the font for the selected text. 
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Fonts used in the PDF are shown above the dividing line '-------', fonts available on your computer are shown 

below. 

 

4. If the selected text contains more than one font, no current font is shown and the Font Preview panel will 

initially be empty. 

5. Click on a font in the Family list. Next to each entry is a small preview. By default this previews ABfg27. 

However if a font does not have those characters (such as Zapf Dingbats), then the first characters found in the 

font are shown instead.  

6. Click items in the Variation list on the right hand side to choose different versions of the same font. 

7. The Font Preview panel at the bottom of the window will show how your selected text will look using the font. 

8. If your chosen font does not include all the character shapes required for your selected text, the window 

displays the message "This font does not contain all the characters required." and the missing characters will 

show as white rectangles in the Preview panel. 

9. You can search for fonts using the Filter text box. As you type into the box, the Family list will be filtered to 

show only family names containing your filter text. Remove the filter by pressing the Reset button. 

 

 
 

Notes 

• The browser shows all fonts used in the PDF plus all TrueType and OpenType fonts installed in the 

Windows\Fonts folder of your computer. These are the most common types of font used on Windows 

computers. 

• FlexiPDF looks for fonts only in the Windows font folder. If you use third-part font management software, 

those managed fonts may not be available to FlexiPDF. 

 

Colour 

All text has two colours associated with it: 
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• stroke (outline) colour 

• fill (interior) colour 

Either colour, but not both, may be invisible. 

 

   

Stroked, no fill Filled, no stroke Stroked and filled 

 

To change the colour used for text: 

1. Choose the Text tool  from the toolbar and select the text you wish to change. 

Or choose the Object tool  and click on the text box you wish to change. 

2. From this point, the colours are set in the same way as for graphics. See Changing Colour. 

 

Bold & italic 

FlexiPDF includes buttons to switch between normal, bold and italic versions of a font. FlexiPDF can, in some 

cases, simulate the effect required if the appropriate font is not available. 

Actual Bold 

1. Choose the Text tool  from the toolbar and select the text you wish to change. 

 Alternatively, choose the Object tool  and click on the text box you wish to change. 

2. Press the Bold button  or (if using the Text tool only), press Ctrl+B on your keyboard. 

If an actual bold version of the font is available in the PDF or on your computer's system, FlexiPDF switches 

fonts. For example, Arial becomes Arial Bold. 

Simulated Bold 
If bold versions of the selected characters are not available in the PDF or in your computer's system, FlexiPDF will 

simulate bold by overprinting the characters. 

The simulated bold text below is written using Juice ITC which has no bold equivalent in the PDF or on disc. 

 

 
 

It is clear to see in this example that FlexiPDF overprints the text to simulate the bold effect.  
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The font name will not change in the toolbar despite the fact that the bold button will be depressed. This is indicative 

of a simulated bold effect. 

Simulated bold is never as good as the real thing. But depending on the style of the font, it can be effective when 

there is no other choice. 

Italic 
FlexiPDF cannot simulate italic text in the way that it can bold text. If the italic version of the selected text is not 

available in the PDF or on disc, then FlexiPDF will show this warning: 

 

 
 

Notes 

• When editing starts, FlexiPDF scans for overprinted text and classifies it as bold. This behaviour can be 

disabled if it is taking too long or wrongly classifying text – see Advanced Settings. 

• Bold text cannot be undone if the plain font is not available, unless it was previously simulated bold. 

 

Underline & strike-through 

You can decorate text with an underline or strike-through using the Underline and Strike-through buttons 

available on the Formatting toolbar. 

1. Choose the Text tool  from the toolbar and select the text you wish to change. 

Alternatively, choose the Object tool  and click on the text box you wish to change. 

2. Press the Underline button  or the Strike-through button . 

3. For more control over the width, colour and position of the decoration choose:  

o Text > Underline Options 

o Text > Strikethrough Options 

Underline/Strikethrough Options 
Using the Options dialog box, you can change the colour, thickness and position of the decorations. 

Example effects: 

 

Offset to -6 

points 

 

 

Offset +6 

points on 12 

point text 
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Weight of 0 

points 

(hairline) 

 
 

Adding a 

background to 

text 

 

 

 

Colour 
By default, the underline and strikethrough colours will use the same colour as the text. To give it a contrasting 

colour, uncheck the Same as text checkbox and click on the Colour button to choose a new colour.  

Notes 

• Text is always drawn after its underline decoration. 

• Text is always drawn before its strike-through decoration. 

 

Margins & indents 

You can control the left, right and first-line indents of paragraph text. These indents apply to the entire paragraph. 

1. Select the Text tool  from the toolbar. 

2. Click on a paragraph or select a block of text spanning multiple paragraphs. 

3. To change a margin, drag the margin triangle in the ruler to the position required. 

 

 
 

 

The picture shows the first-line indent triangle being 

dragged. As you drag the margin, a dotted line allows 

you to line up the margin with other objects on the 

page. 

 

The first-line indent has been changed so that the 

paragraph starts with an indent. 
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To create a hanging indent, move the left-margin (the 

lower triangle on the left hand side) inward without 

moving the first-line indent. 

 

If you drag the little rectangle underneath the left 

margin arrow, then both the first-line indent and left 

margin will move. 

 

 

Notes 
• For finer control of indents especially for text that flows around shapes, see Flowing text around shapes. 

 

Ruler units 

You can change the ruler’s unit of measurement. Choose from centimetres, inches, points and picas via the 

Preferences dialog box. Changing the units affects all palettes and dialog boxes that show some form of 

measurement. 

1. Choose File > Preferences. 

2. Switch to the Editing tab. 

3. Select a unit from the Unit of measurement drop-down menu. 

 

 
 

 

Background colour 

A text block can have a white, black or transparent background colour. This can be useful when you want new text 

to obscure existing background text. 

In this example, we want to obscure the name Wilhelm Korte on the scanned page with a new name Hans Keppler. 

• The new text is shown in red due to the setting of Show Changed Text In. 
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• When placed on top of the existing scanned name, both names are visible: 

 

 
 

• Choose Text > Text Box > Background Colour > White to give the text box a white background. 
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For simplicity, FlexiPDF only offers black, white or clear backgrounds. For other colours, create a coloured 

rectangle shape using the drawing tools and place it between the new and old text. 

 

Highlight properties 

Once text has been highlighted you can adjust some of the properties of the highlight annotation it represents. 

1. Select the Text tool  from the toolbar. 

2. Select some highlighted text or place the caret in the middle of a highlighted span of words. 

3. Choose Text > Highlight Properties. 
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4. Click on Fill colour to choose a new colour for the highlight. 

5. Adjust the Opacity of the colour by dragging the slider nub. 100% is solid, 0% invisible. 

6. You can change the name in the Author field but cannot alter the date modified. Both will be visible when you 

double click on a highlight to display the associated sticky note. 

 

Tabs 

Use tab stops to create sophisticated text layouts. Choose from left, centre and right justified tabs with or without 

leader dots. 

 

 
 

Above, the ruler bar showing a left, centre and right justified tab-stop. 

 

 
 

Tab characters are shown as pink arrows in the text during editing. 

Creating/deleting tabs 
1. Click on the ruler at the position you want to create a new tab. 

2. Click and drag an existing tab stop to move it to a new position. 

3. Click and drag an existing tab right off the ruler bar to delete it. 

4. Right-click on a tab stop in the ruler bar to choose between left/centre/right alignment. 

Notes 

• Tab stops are remembered even after closing and re-opening a PDF. 

• As you add or move tabs, their x position is shown in the status bar at the bottom of the window. 

• Tab stops may be positioned beyond the left and right margins of the text box. 
 

Leaders 

Once you have added a tabstop to the ruler, you can set the leader character used for the tab stop. 

1. Position the mouse cursor over the relevant tab stop in the ruler at the top of the window. 

2. Press the right mouse button to display the tab menu and choose Tab Options. 

3. To add leader dots to your tab-stop, type a single ‘.’ (period) into the Leader Character text box. 

 

 
 

You can type any single character into this box for use as a tab leader. 
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Trailing leaders 

Use the Tab Options dialog to control the way tab leaders are drawn for wrapped lines. 

1. Position the mouse cursor over the tab stop you want to modify. 

2. Press the right mouse button to display the tab menu and choose Tab Options. 

3. Click the Trailing Leaders checkbox. FlexiPDF will then add leader dots to the end of a line which wraps due 

to a tab stop. 

 

 
 

Notes 

• Trailing leaders cannot be selected or edited with the text or object select tools. The caret will skip over them 

when moving through text. 

• Trailing tab leaders extend up to the right edge of the text box. 

• Can be part of text field is only for use with templates destined for processing by Infix Server. 
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4.  Spacing 

Use the Text > Spacing palette to control: 

• Letter spacing 

• Line spacing 

• Paragraph spacing 

 

 
 

Press  to reset both letter and word spacing to 0. 

You can also use the line-spacing button on the toolbar to change the current line spacing. 

 

 
 

 

Line 

Line Spacing Toolbar Buttons 
When the text cursor is in a paragraph with more than a single line of text, the Line Spacing buttons become active. 

The icon shown indicates the current spacing of the paragraph being edited. 

 

 
 

If you press the button you will see 4 icons pop-up: 

 

  
 

which in order mean single space, 1.5 space, double space and other indicated by a small 'N' in the icon. 

If you choose N (other spacing) then the Text Spacing palette will appear, and you can change the line spacing to 

any value you wish – see below. 
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Text Spacing Palette 
Use the Spacing dialog box to set the line spacing to any value, not just the 1x, 1.5x and 2x spacing available with 

the toolbar buttons. 

1. Select the Text tool  from the toolbar. 

2. Choose Text > Spacing to open the Spacing palette. 

 

 
 

3. Choose the mode of line spacing: At Least, Exactly or Multiple. 

 

Multiple 
Use Multiple mode to specify gaps such as “2.5 lines” meaning that 

the gap will be at least 2.5 times the line height. 

Setting multiples of 1, 1.5 or 2 is the same as pressing the single, 

1.5 or 2x spacing buttons on the Formatting toolbar. 

 

At Least 
This paragraph shows the effect of the At Least mode in which you 

tell FlexiPDF the minimum gap between lines (measured in points). 

To stop the wheels line from colliding with the previous line, 

FlexiPDF has automatically increased its line spacing. 
 

Exactly 
This paragraph shows the effect of the Exactly setting in which you 

tell FlexiPDF the exact gap size between lines (measured in points). 

FlexiPDF has used exactly the same spacing for each line 

regardless of whether or not they collide. 
 

 

 

Paragraph 

You can create a gap between paragraphs in two ways: 

• Use the Text tool  to insert blank lines between paragraphs by pressing Return or Shift+Return. 

• Choose Text > Spacing to open the Spacing palette. 

 

The Spacing dialog box enables you to dictate the exact size of gap in units of your choice – mm, inch, pt. 
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There is no gap between any of the paragraphs 

shown right. 

 

Here the spacing has been changed to 6 points. 

Select multiple paragraphs to alter the spacing of 

them all at once. 

 

 

 

Letter 

The space between individual letters can be controlled to an accuracy of 1/1000 em. This is useful for achieving 

layout effects such as fitting text into a particular area by reducing or expanding the spacing. 

 

 

Letter spacing is measured in ‘ems’ with 1 em being 

the width of a capital letter ‘M’ in any font. 

 

Letter space vs. word space 
Due to the nature of PDF documents, you can control the gap between words caused by space characters though this 

is generally not as widely used as letter spacing. 
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Adjust Letter Spacing 
To adjust the spacing between letters or words: 

1. Select the Text tool  from the toolbar. 

2. Select the text you wish to alter. 

3. Choose Text > Spacing to open the Spacing palette. 

 

 
 

4. You can control the gaps between letters and words by entering positive or negative values (to bring letters 

closer together). 

5. Press  to quickly set letter and word spacing to 0. 

Notes 

• Increase/decrease the letter spacing of selected text using the keyboard shortcuts Ctrl+Shift+] and Ctrl+Shift+[ 

• The word-spacing value is ignored when text is fully justified. 
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5.  Editing objects 

 

Change the colour 

You can change the fill and stroke (outline) colours of selected objects.  

1. Click on the Colour Picker button in the toolbar to open the colour picker dialog box.  

 

 
 

The button changes colour to show the current fill and outline colours of the selected objects. 

2. The Colour Picker dialog shows the current fill and outline colour of the selected objects.  

 

 
 

When multiple objects with different colours are selected, the fill and/or stroke colour will display '??' as shown 

below: 
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The Colour Tabs 

• Grey-scale – shows just shades of grey from 0 (black) to 100 (white) 

• HSB – Hue / Saturation / Brightness is a simpler way of choosing colours 

• RGB – Red / Green / Blue – choose colours based upon three primary, additive colours. 

• CMYK – Cyan / Magenta / Yellow / Black – choose colours based on 4 subtractive colours corresponding to 

the inks used in printing. 

• Swatches – Choose from colours already present in the document. This is very handy for named process 

colours or spot colours. 

Choosing stroke or fill colour 
Click on the stroke/fill boxes to toggle between fill and stroke colours. The box that comes to the font reflects the 

colour (fill or stroke) that is being changed. 

 

  

Click on the stroke colour box 

(shown green here) to bring it to 

the front and change the stroke 

colour. 

Click on the fill box (shown 

blue here) to bring it to the front 

and change the fill colour. 

 

Removing fill or stroke colour (make invisible) 

To remove the fill or stroke colour completely, press the the white square with a red line through it – . The 

adjacent squares of white and black act as a shortcut to setting those colours. 
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Swapping fill colour with stroke colour 

To swap the fill and stroke colours around, press the Switch button . 

Original Colour Space 
The original colour space of the selected object(s) is shown in the bottom right of the dialog: 

 

 
 

In this example, the Stroke colour space is None (invisible), Fill is RGB. 

When changing colours, the highest fidelity will be gained using the tab corresponding to the original colour space. 

In this case, choosing a colour with the CMYK tab will require no adjustments afterwards since the fill colour space 

is CMYK. If you used the RGB tab, the colour values would be converted to CMYK giving an approximation of the 

colour you chose. 

Changing all colours in the document 
To change all occurrences of a colour to a different one, choose the new colour then press Change All. See Find & 

Replace Colours for more details. 

Notes 

• The colour picker will try not to alter the underlying colour space of the original selection but will do so in 

those cases where it would otherwise be impossible to achieve the chosen colour. 

• You cannot change the colour of an image but you can edit images with an external editor. 
 

Swatches 

The Swatches tab in the colour picker shows all the colours used in a PDF. It has the advantage of showing the 

names of spot and process colours when they are present in the PDF. 

1. Press the Colour button to open the colour picker dialog box. The button can be found in the Edit toolbar at 

the top of the window. 

 

 
 

The button changes colour to show the current fill and outline colours of whatever object is selected.  

2. Switch to the Swatches tab. The component values of each colour and if available, the names of process colours 

are displayed in the list. CMYK, Gray and Separation colour values are shown as a percentages from 0 to 100, 

RGB values range from 0 to 255 
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3. If you only want to see the colours used for text in the document, click the Restrict to text colours checkbox. 

Otherwise all colours used are shown. 

4. Click on a colour to change fill or stroke colour of the objects in the current selection. To switch between fill or 

stroke colours, see Changing Colour. 

Notes 

• There may be an initial delay the first time you view the swatches tab as it needs to be populated by examining 

all objects in the PDF. 

• Unlike all other tabs on the colour picker, choosing a colour from the swatches catalogue does change the 

underlying colour space of the selection. 
 

Copying colours between objects 

The Pipette tool can be used to copy the colour from one object to another. 

1. Using the Object tool , select the objects whose colour you wish to change. 

2. Choose the Pipette tool  from the toolbar. 

3. Click the Pipette on an object whose colour you want to copy. The fill colour, line colour and line width of the 

object will be copied to the selected objects. The colour space of the objects will also be changed to match the 

source colour. 

 

Select objects 

To select and manipulate objects (text, shapes, images), choose the Object tool  from the toolbar. 

Select a single object 
1. Click on a single object to select it. 
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2. When objects overlap, the top-most object is selected. 

Hold Ctrl+Shift while you click to select the next object underneath the current object. Each time you press 

Ctrl+Shift, the next object down is selected. 

Selecting Multiple Objects 

Method 1: Dragging a rectangle 

Click and drag out a rectangle. 

 

 
 

When you let go, any objects inside or touching the rectangle will be selected. 

 

 
 

In this case, all three circles were selected. 

Method 2: Shift Clicking 

Hold Shift when clicking on objects to add them all to the current selection. This is a handy when method 1 above 

would end up selecting unwanted objects. 
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Circles 1 and 3 have been selected by clicking on each while holding the Shift key. 

Notes 

• Press Backspace or Delete on your keyboard to delete selected objects. 

• Click and drag to move the object or selection of objects to a new position. 

• Use the cursor keys to move selected objects by 1 point (1/72 inch). Hold the Shift key as well to move by 10 

points. 

• Copy/paste of graphics from FlexiPDF to another other applications is not supported. You can export images to 

a standard format for import into another application. See Extracting Images, snapshots and Editing in other 

applications. 

• Some pages are littered with invisible objects making selections difficult. These objects can usually be safely 

removed without altering the appearance of the page. To see invisible objects, choose View > Outlines or 

double-click on Preview in the status bar at the bottom of the main FlexiPDF window. 

• Cut/copy/paste may be used on single objects or groups of objects. 

 

Stretch objects 

Stretch objects by dragging the handles on the sides or corners of the selection box.  

Alternatively, choose Object > Scale or use the Transform palette. 

1. Select the object(s) to be stretched using the Object tool . 

2. Drag one of the eight handles to stretch. 
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3. The selected objects will be stretched to fit the box you dragged out. 
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Note that the stretch hasn't distorted the text. If you need to stretch or scale text as well, use the Scaling dialog 

or the Transform palette. 

4. To retain the aspect ratio of as you stretch, hold down the Shift key while dragging. Doing so in this example 

would result in a larger circle, not a large oval. 

Notes 

• Using the Object tool to stretch a text box will resize the text box without altering the size of the text within it. 

• Line widths are not affected when stretching in this way. To scale these too, use the Object > Scale command. 

 

Scale objects 

1. Select the objects to be scaled using the Object tool . 

2. Choose Object > Scale. 
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1. Uniform – scale the selected objects so they retain their aspect ratio. 

2. Non-Uniform – scale X and Y values independently to stretch objects. 

3. Scale line width – if checked, the width of the outline around an object will be affected by the scaling. 

This has no effect when scaling images. 

4. Press the Copy button to scale a new copy of the selected objects and leave the original object(s) 

unchanged. 

Notes 

• Objects and selection may also be scaled using Object > Transform. 

 

Rotate objects 

Selected objects can be freely rotated by any angle. 

1. Select the object(s) to be rotated using the Object tool . 

2. Choose the the Rotate tool . 

3. Drag the selection’s outline to the desired orientation. 

4. Hold down the Shift key while dragging to constrain rotation to 45˚ angles (0, 45˚, 90˚, 135˚, etc.) 

5. Stop dragging to complete the rotation. 

Changing the rotation origin 
Objects can be rotated around an arbitrary point. 

1. Select the object(s) to be rotated using the Object tool . 

2. Choose the the Rotate tool . 

3. Click the left mouse button to reposition the origin, show by blue cross-hairs ( ).  

Each time you click, the origin will be re-positioned. 

Notes 

• To shear the selection, use Object > Transform. 

• To rotate the selection by a specific angle, choose Object > Rotate. 

 

Images 
 

Add images 

To add JPEG, PNG, TIFF or BMP images to a page: 
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• Drag and drop one or more image files onto an open document 

or 

1. Select the Object tool . 

2. Choose Object > Image > Insert then choose a single image from the file selector. 

New images are pasted on top of each other. Use the Object tool  to move and stretch them to the correct size. 

Notes 

• FlexiPDF supports colour resolutions of up to 8 bits per channel 
 

Replace images 

You can substitute an existing image for another loaded from disc. Supported image formats are JPEG, TIFF, PNG, 

BMP and PDF. 

1. Choose the Object tool  from the toolbar. 

2. Select the image to be replaced, then choose Object > Image > Replace Existing. 

You can also right-click the mouse button and choose Image > Replace. 

3. Choose the new image from your computer's hard drive. 

4. The new image will be scaled and placed inside the clipping mask (pink outline) used by the old image. 

5. Scale the new image by dragging one of the resize handles outwards. Hold the Shift key at the same time to 

ensure it is not stretched out of shape. 

Notes 

• FlexiPDF supports colour resolutions of up to 8-bits per channel. 
 

Resample images 

Available in FlexiPDF Standard, Professional, NX Home, NX Universal 

FlexiPDF can resample images to make PDF files smaller and quicker to load. 

• To resample multiple images, choose Object > Image > Resample. 

• To resample specific images: 

1. Select the images using the Object tool . 

2. Right-click the mouse and choose Image > Resample. 

The Resample Images dialog offers a similar set of options for the three classes of images – colour, greyscale and 

monochrome. 
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• Converting colour images to greyscale will reduce the overall size of the PDF file. 

• JPEG compression is a “lossy” format well suited to colour and greyscale photographs. When choosing JPEG, 

you can set the quality of the compressed image anywhere from 1% (worst quality / smallest image size) to 

100% (best quality / largest image size). 

• PNG is a lossless compression method better suited to colour and greyscale diagrams, charts and line drawings. 

• Remove all hidden (clipped) image data 

Removes the hidden parts of images that are painted through a clipping mask. Depending upon how the PDF 

was made, this can reduce the overall size of the PDF quite dramatically. 
 

Edit images in other applications 

FlexiPDF can send an image to another application (such as Photoshop or GIMP) to be edited. When that 

application is finished, FlexiPDF will put the modified image back into the PDF. This is handy if you need to do a 

quickly change things like the brightness or contrast of an image. 

1. Select the Object tool  from the toolbar. 

2. Click on the image to be edited. 

3. Choose Object > Image > Edit. 

The image will open in the default image editing application on your computer. 

4. To open the image in a specific application, choose Object > Image > Edit With. 

5. When you finish editing, allow the application to save the changes back to the image file. 

6. FlexiPDF will detect the changes and ask if you want to reload the image. 
 

Redact images 

Redacting Images – See Redacting Images 
 

Image properties 

To see the properties of an image such as its resolution and colour depth: 

1. Select the Object tool  from the toolbar. 

2. Click on an image to select it. 

3. Choose Object > Image > Properties. 
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Extract images 

To extract images to files: 

1. Choose the Object tool . 

2. Click on the images you wish to extract. 

3. Choose Object > Image > Extract to file. 

4. Choose a file name for the extracted images 

5. Choose the format for extraction from the pop-up: 

o PNG 

o JPEG 

o TIFF 

o BMP 

Notes 

• If you are not sure if something is an image or is drawn using lines and vectors, choose View > Outlines. In 

outline mode, images are hidden and artwork made from line is shown as wire frames.  

Choose View > Outlines again to return to normal mode. 

 

Line width 

You can change the line width used to draw the outline around a shape or text. 

1. Press the Colour button in the Edit toolbar to open the colour picker dialog box. 

 

 
 

The button changes its colour to show the current fill and outline colours of whatever object is selected.  

2. The Colour Picker dialog shows the current fill and outline colour of the selected objects. When multiple 

objects with different colours are selected, the fill and/or outline colour will display '??'. 
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3. Press the up/down arrows on the Line Width control to change the width, or type in a new value. 

A line width of 0 creates the thinnest line possible – it does not remove it. 

4. To remove an outline altogether, set the stroke colour to 'invisible' by pressing – . 

See Changing Colour for details. 

Notes 

• All objects (except clipping paths and images) can have a line or stroke colour and a fill colour. 

• Images are unaffected by colour and line width. 

• To add an outline to an image, select it using the Object tool , then choose Object > Border. 

 

Alignment 

Objects may be aligned relative to others. You can also align objects relative to page guides. 

1. Choose the Object tool  from the toolbar. 

2. Select the objects to be aligned. 

3. Choose one of the alignments available in the Object > Align submenu. 

4. The order in which you select the objects does not affect how they are aligned. Instead, objects are left-aligned 

to the left-most object in the selection, right-aligned to the right-most, top-aligned to the top-most, etc. 

Displaying the Alignment Toolbar 
All alignment and distribute functions are available in the Object Alignment toolbar. 

 

To show this toolbar, choose View > Toolbars > Object Alignment. 

Notes 

• Aligning text blocks does not affect the paragraph alignment (justification) within the text blocks. 
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Distribute objects 

Distribute Objects  
To ensure even horizontal or vertical spacing between 3 or more objects: 

1. Choose the Object tool  from the toolbar. 

2. Select the objects to be aligned. 

3. Choose Objects > Distribute > Across/Down or press  or  on the Alignment toolbar (View > 

Toolbars > Object Alignment). 

 

Borders 

Simple borders may be added around objects. Though they can be applied to any object, they are most effective 

around images. 

1. Choose the Object tool . 

2. Select the objects which are to have a border around them. 

3. Choose Object > Border > 2 pt or press  on the Drawing toolbar (View > Toolbars > Drawing). 

4. The border width can be changed by choosing another point size from the Object > Border submenu. 

5. To remove the borders, press the border button again or choose Object > Border > No Border. 

Notes 
Borders are always black. 

 

Lock objects 

Objects can be locked to stop accidental modification during editing. This is helpful for complex pages with many 

overlapping objects. 

Locking Objects 

1. Using the Object tool , select the object(s) to be locked. 

2. Choose Object > Lock, or right-click with the mouse and choose Lock Selection. 

Objects remain locked even after the PDF is saved and re-opened, provided layout information is written to the 

PDF). 

Unlocking Individual Objects 

Using the Object tool , click on the locked object. 
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Unlocking All Objects 
Choose Object > Unlock All. 

 

Hide objects 

To make editing your artwork easier, objects can be temporarily hidden. 

Hiding: 

1. Using the Object tool , select the object to be hidden 

2. Choose Object > Hide. 

Revealing: 
1. Choose Object > Show All. 

Notes 

• Hidden objects will become visible again the next time the PDF is loaded. 

• Hiding objects has no effect when viewed in other PDF viewers. 

 

Group objects 

Objects may be grouped together to make editing easier. 

Grouping 

1. Using the Object tool , select the objects to be grouped 

2. Choose Object > Group, or right-click with the mouse and choose Group Selection. 

Ungrouping 

1. Using the Object tool , select the group(s) to be ungrouped. 

2. Choose Object > Ungroup, or right-click with the mouse and choose Ungroup Selection. 

Notes 
Groupings remain even after the PDF has been saved and reopened, provided layout is preserved in the PDF – see 

Saving – Store Layout). 

 

Grid 

You can use a grid to help when aligning objects on a page. When displayed, this grid makes your pages look like 

graph paper. 

You can also make objects "snap" to the lines of the grid when you move them. 

Show the grid 
Choose View > Grid & Guides > Show Grid to display the grid. 

Snap to the grid 
To make objects “snap” to the grid lines when creating, moving or resizing, choose View > Grid & Guides > Snap 

to Grid. 
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Grid Spacing 
Choose View > Grid & Guides > Grid Spacing. 

 

 
 

• Spacing is the distance between the major (darker) grid lines. 

• Control the number of minor (lighter) grid-lines by specifying a value for Divided into. 

Notes 

• The visibility and spacing of the grid are stored in the PDF and will be used by FlexiPDF the next time the PDF 

is opened. Other PDF viewers ignore the grid. 

• If visible, grids will be included when printing a document. 

• To change the units used for the grid, choose File > Preferences and switch to the Editing tab. 

 

Guides 

You can create multiple horizontal and vertical guides to help with layout and positioning on a page. 

Objects "snap" to guides when moved close to them, thereby making it simpler to align objects. 

Horizontal guides 
To create a horizontal guide, make sure rulers are visible (View > Rulers), then click in the horizontal ruler at the 

top of the window and drag down to position the resulting guide. 
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As you drag, the position of the guide is shown in status bar at the bottom of the window. 

Vertical guides 
To create a vertical guide, make sure rulers are visible (View > Rulers), then click in the vertical ruler at the left 

hand side of the window and drag across to position the resulting guide. 
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As you drag, the position of the guide is shown in status bar at the bottom of the window. 

Notes 

• Guides are stored in the PDF (if Store layout in PDF is enabled) for use next time the document is edited by 

FlexiPDF. 

• Once guides have been created, they can be moved and deleted using the Object tool  as if they were 

normal objects. 

• To temporarily hide all guides (or stop them from printing), toggle View > Grid & Guides > Hide Guides. 

 

Arrows (on lines) 

FlexiPDF can add various kinds of arrow heads to either the start or end of lines and polygonal shapes. 

 

 
 

1. Choose View > Toolbars > Drawing to view the drawing tools. 
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2. Use the Line tool  or the Polygon tool  to draw. 

3. Click on the start/end arrows menus to change the arrows of the current selection. 

 

 
 

The start and end arrow menus display the currently chosen arrow type for the selected object(s). 

4. Tear off either menu to convert it into a floating toolbar. 

 

 
 

Notes 

• Lines and their arrows always have the same colour. 

• The size of the arrow head is proportional to the line width. 

 

Layers 

FlexiPDF offers a simple way of editing documents which include layers. 

Using the Layers panel, you can show and hide individual layers in a document to make editing easier. Since 

FlexiPDF ignores objects in hidden layers, it can make editing more responsive if you hide all irrelevant objects 

before you begin to edit. 

You can also move objects between layers. 

• Choose View > Layers to open the Layers panel. 
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You may drag the title bar of the Layers panel to make it into a floating window. 

• Click on the check box next to each layer to show or hide it from view. 

• Click on the layer name to rename it. Any name change is stored in the PDF when it is next saved. 

• When you click on an object during editing, the containing layer is highlighted. 

Moving objects between layers 

1. Select the objects to be moved with the Object tool . 

2. In the Layers panel, select the layer to which you wish to send the objects. 

3. Choose Object > Arrange > Send To ‘Layer 1’ (the menu title will change to reflect the name of the selected 

layer). 

The object will be marked as belonging to the selected layer. This change will be stored in the PDF next time it 

is saved. 

Notes 

• FlexiPDF cannot create or delete layers. 

• Changing the visibility of layers affects only the way it is displayed in FlexiPDF. No permanent change is made 

to the PDF. 

 

Delete objects across pages 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can automatically delete objects in the same location across a range of pages. This is very handy for 
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removing unwanted logos, header, footers or other page furniture. 

You are strongly advised to make a backup of your document before using this facility. 

1. Select the Object tool  from the toolbar. 

2. Select the object(s) to be deleted (see Selecting Objects). 

FlexiPDF will draw a selection box large enough to include all the objects you've selected. Any objects inside 

the box will be removed. 

3. Choose Edit > Delete Across Pages. 

 

 
 

4. Choose the page range you wish to affect and whether you want to limit the process to just even or odd pages. 

5. Press Delete. 

6. You can halt the process part way through by pressing Stop. 

Notes 

• In order to reduce the amount of memory used when deleting across more that 200 pages, FlexiPDF will save 

the document to a new file and then perform the next 200 operations. 

 

Copy objects across pages 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can replicate a selection of objects across a range of pages. The objects are placed at the same position on 

each page in the range, on top of any existing contents. This facility can be used for adding repeating page furniture 

such as logos, headers, footers and page numbers. 

1. Select the Object tool  from the toolbar. 

2. Select the object(s) you wish to copy. See Selecting Objects. 

3. Choose Edit > Copy Across Pages. 
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4. Choose the page range you wish to copy into. 

5. If you want different objects for even and odd pages, perform the clone operation twice: once with the odd-page 

objects and restrict the page range to Odd pages only then again with the even-page objects with the page range 

restricted to Even pages only. 

6. Click Delete existing objects before cloning if you need to remove any pre-existing objects at the same 

position as the newly copied objects on each page.  

Notes 

• Hyperlinks and annotations are excluded from the cloning process. 

• In order to reduce the amount of memory used when cloning across more that 200 pages, FlexiPDF will save 

the document to a new file and then perform the next 200 operations. 

 

Transformations 

Use the Transform palette to move, resize, rotate and sheer objects. 

To display the palette, choose Object > Transform. 

 

 
 

The commands in this palette window are only available if you have selected the Object tool . 
 

Scaling 
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• Use the horizontal  and vertical  scale pop-up menus to choose a percentage change in scale. 

• Click on the chain-link icon  to maintain the same horizontal and vertical scaling.  

• Click again  to break the link between the two values and allow independent scales. 
 

Rotation 

 

 
 

Enter an exact value or use the rotation pop-up menu to choose an angle (in degrees) for rotation of the selection. 

Objects are rotated about their mid-points. 
 

Sheer 

 

 
 

Enter an exact value or use the Sheer pop-up menu to choose an angle (in degrees) of sheer for the selection.  
 

Origin 

The grid of squares in the top left of the palette represents the sides and corners of the bounding box of the selection.  

Click on one of the squares to select it (it turns black). The X and Y values will change to show the coordinates of 

that corner, side or centre of the bounding box. 
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Enter a new value into the X or Y boxes to change the currently active coordinate. The selected object(s) will move 

in relation to the change. 

 
 

Width and height 

The grid of squares in the top left of the palette represents the sides and corners of the bounding box of the selected 

object(s).  

Click on one of the squares to select it (it turns black). The X and Y values will change to show the coordinates of 

that corner, side or centre of the bounding box. 

 

 
 

Enter new values for Width or Height, and the size of the selected object(s) will change relative to the currently 

active grid square. 

 

Clipping 
 

Add a clipping mask 

Any object or group of objects can have a clipping mask applied. The mask ensures only parts of the object are 

visible. This is often useful for images where you may want to hide the background for example. 

Example 
In this example, we want to apply a clipping mask to the image of the car. 

 

 
 

1. Choose View > Toolbars > Drawing to view the drawing tools. 
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2. Use the tools to draw a shape – in this example, an oval. This shape will be used to make the clipping mask. 

Any path may be used as clipping path, not just those created using the built-in drawing tools. 

 

 
 

3. With the new shape selected, choose Object > Clipping Mask > Convert To Clip. 

The shape will then become a pink outline. 

 

 
 

4. Select the Object tool  from the toolbar. 

5. Select both the clip path and the image – see Selecting Objects. 

6. Choose Object > Clipping Mask > Add To Clip. 

7. The image has now been added to the clipping mask. The parts of the image that are "outside" the mask are not 

displayed. 

 

  
 

Notes 

• Any empty clipping masks are automatically removed when a PDF is opened. 

• Clip paths have no line width, fill or stroke colour and will only be visible when the Object tool  is selected. 

• Clip paths can be moved independently of the objects being clipped. To stop them moving independently of 

each other, group them together. See Grouping. 

• To add multiple objects to the clipping path, group them first – see Grouping. 
 

Remove a clipping mask 

Clipped objects can be moved independently of their clip masks. Objects can also be "popped" from their clip masks 

revealing the entire object. 

1. Select the Object tool  from the toolbar. 

2. Click on the object you wish to "pop" from its clipping mask. 

3. Choose Object > Clipping Mask > Remove From Clip. 

The image should now fully visible. 

The clipping mask should still exists and will be shown in pink behind the image. 
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Note 

• Clip masks only become visible (outlined in pink) when the Object tool  is active. 
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6.  Find and replace 

The Find and Replace facilities in FlexiPDF are extensive and cover the different components of a PDF: 

• Styled text 

• Fonts 

• Bookmarks 

• Hyperlinks 

• Comments 

• Colours 

You can also: 

• Find and Redact text to hide sensitive information. 

• Find and replace across multiple files. 

 

Find styled text 

1. Choose Edit > Find & Replace > Find. 

2. Enter the search phrase into the Find box.  

3. To restrict the search to a page range, click on the hyperlink shown below:  

 

 
 

You can also restrict the search to a specific area. 

4. Choose a page range to search across. If you are currently editing text with the Text tool , you can choose 

Current story to limit the search to just the active text boxes. 

5. Click on Whole words if you need to match complete words and not fragments. If not checked, rainbow will 

match rainbows as well as rainbowPhotos.com.  

6. Click on Match case if you want capitalisation to be taken into account. 

7. Click on Use wildcards to use simple wildcard characters in your search: 

o ? matches a single character e.g. Hole? would match Hole9 

o * matches any number of characters e.g. ice* would match ice, iced, iceland 

o + matches one or more characters e.g. ice+ would match iced, iceland but not ice. 

8. To find text in a specific font, style or colour, press the Character formatting hyperlink.  

9. If you only want to find text in a specific font, colour or size and don't care what the text is, uncheck the Find 

checkbox. 
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When unchecked, any text matching the Character formatting will be found. Until you specified some character 

formatting restrictions, the Find Next button will remain inactive in this case. 

10. Press Find Next to show the next occurrence of the search text from the current place. Each time you press 

Find Next, FlexiPDF will zoom in on and select the text found if Zoom-in on results is checked. 

11. Press Find All to show the Results list which will display all the locations where the search text is found. 

 

 
 

Double-click on an entry to view that entry in the document. 

If you are searching through a portfolio, the third column in the results table will show the name of the 

document within the portfolio in which the text was found. 

12. Hit Replace >> if you decide you want to replace as well as find the target text. 

 

Find formatting 

You can restrict Find & Replace to text written using a specific font, colour or size. 

1. To find text in a specific font, style or colour, press the Character formatting hyperlink. 
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2. The Find Format dialog shows the font, size and colours that will be matched.  

 

 
 

If you select some text using the Text tool  prior to opening the dialog, the dialog is pre-populated with the 

attributes of that text when it opens. If it is not opened, no matching restrictions are applied even if text is 

currently selected. 

3. If the Font drop-down is set to Any, then any and all fonts may be matched. 

4. If the Size edit box contains Any, then any font size may be matched. Otherwise choose a pre-set size or enter 

the exact size you wish to match. 

5. If Fill is checked, only text filled with the chosen colour will match. Click on the colour button next to the 

checkbox to choose a colour. 

6. If Stroke is checked, only text outlined with the chosen colour will match. Otherwise all text, outlined or not is 

eligible. 

 

Replace formatting 

The Replace Format dialog can be used to set both the format used for the replacement text and the way it is 

reflowed and aligned after replacement.  

1. To apply formatting to your text as it is replaced, tick the Apply Style checkbox. 

Then set the required attributes of Font, Size and Colour as you do in the Find Format dialog box. Leaving a 

value unchecked or as Unchanged means that attribute will not be altered in the replacement text. 

2. Set up how you would like the text to reflow after replacement. This is important even in the case when you are 

not altering the text since changing font or font size will require a reflow. This part of the dialog is the same as 

that described in Reflow & Alignment. 
 

Replace styled text 

1. Choose Edit > Find & Replace. 

2. Specify the text you want find as described in Finding Styled Text 

3. Enter the text you want to replace in the Replace box. 
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Uncheck Replace to leave the text as is, changing only its font, size or colour and alignment. In this case, the 

Replace and Replace All buttons will be disabled until you choose a Font, Size or Colour change to make. 

4. To set the Font, Size or Colour you wish to use for the replacement text, click on the reflow line, align auto 

hyperlink. 

Notes 

• To do font replacement with this dialog (rather than using the Replace Fonts dialog), uncheck both the Find and 

Replace checkboxes and set up character formatting for both the find and replacement. 

 

Within a specific area 

When doing a Find and Replace you can limit the scope of the search to a specific area. This is done by adding a 

temporary crop to the relevant pages then removing it after the search has completed. 

1. Crop the relevant pages using the crop tool . This will not delete anything from the PDF but simply hides 

text and graphics outside the cropped area. 

2. Choose File > Preferences and in the Editing tab, ensure Include cropped text when editing is off. 

3. Do the Find and Replace as normal. By default FlexiPDF will not search for text outside the crop. However, 

there is a preference option which can change this behaviour.  

4. Remove the crop by choosing Pages > Remove Crop. 

 

Reflow & alignment 

It is important to correctly set the reflow and alignment of your text during replace operations with the Replace 

Format dialog box. Failure to do so can result in lots of tidy-up work. 

1. While in the Find and Replace dialog box, click on the reflow line, align auto hyperlink. 
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2. The reflow and alignment controls are in the After Replacement section of the dialog. Here you control how 

the new text is reflowed and its alignment. 

3. First choose the Reflow value. There are three options: 

o Containing Paragraph 

Reflow the entire paragraph in which your replacement text sits. Do this only when you are confident 

that the paragraphs are well-formed in your PDF. For very complex PDFs with text that can flow 

around shapes, this can cause unwanted results if FlexiPDF is unable to determine the correct structure 

of paragraphs. 

o Containing Line 

Reflow just the line of text in which your replacement text sits. This has less potential for disruption 

than the previous option. If your replacement text is of similar width to the original, this option should 

work well producing less change to each page as it progresses. The drawback is that if your new text is 

longer than the old, it may run off the end of the line. 

o New Text Only 

Fits the replacement text into the space occupied by the old text and does no other reflowing. If your 

replacement text is the same width as the original, this option causes the least amount of the change to 

the page possible. The drawback is that if the new text is longer than the old, it will overwrite any 

content following. 

4. Choose the Alignment. The choices are Left, Centre, Right and Auto. If for example, you are replacing the 

text in a header which abuts the right side of each page, Right would be the best option. If your text may occur 

anywhere throughout the document then choose Auto. 

5. If Reset Letter Spacing is checked, FlexiPDF will ignore any existing letter spacing and set both letter and 

word spacing to zero in the replaced text. 

 

Find and replace fonts 

FlexiPDF can change the fonts used throughout a document using the Find and Replace Font dialog box. This 

presents a simplified interface to the more sophisticated facilities offered by the Find and Replace. 

1. Before doing a font replacement, ensure that you have a recent backup of your document, since the operation is 

potentially disruptive. 

2. Choose Edit > Find & Replace > Fonts 

or choose Document > Fonts then select a particular font and press Replace. 
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3. Choose the target font from any of those currently used in the document from the drop-down menu labelled 

Replace document font. 

Alternatively, you can enter a wildcard expression in order to match a family of fonts. For example, Times* will 

match all fonts whose names start with Times such as Times-Roman, Times-Roman Italic, etc. 

F? would match all two-letter font names such as F0, F1, etc. 

4. Choose the replacement font from the drop-down list. You may choose any font currently used in the document 

or any system font on your computer. 

Whatever font you choose, especially if it is one currently used in your document, be aware that it may not have 

all the characters (glyphs) needed. FlexiPDF will warn you during the replacement if this occurs. 

5. Click Replace All to begin the operation. 

FlexiPDF will process the entire document, examining all text. If you want to restrict the process to a specific 

page range, text box or text selection, use the advanced features of the Find and Replace dialog Available in 

FlexiPDF Professional, FlexiPDF NX Universal. 

6. In some cases, a warning may appear: 

 

 
 

This indicates that the font you intend to use for replacement does not contain all the glyph shapes needed for 

the text.  

You can skip this replacement and carry on or stop and try to remedy the situation by changing the font of the 

original text. 

7. Hit the Stop button at any time to abort the process. 
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8. Once finished, FlexiPDF will report the number of times the font was replaced. 

9. Save the finished document. 

Notes 

• If more than 200 pages are processed, FlexiPDF will save the document as it proceeds along, renaming it each 

time. This is done in order to limit memory consumption. 

 

Find and replace in bookmarks 

To search through or replace bookmark titles in the current document: 

1. Choose View > Bookmarks to display the Bookmarks panel. 

2. Click on the Magnifying glass icon  in the small toolbar inside the Bookmarks panel. 

 

 
 

3. Enter the search phrase into the Find box.  

If text is selected in the current document using the Text tool  prior to pressing the Magnifying glass icon, 

it will be copied into the Find text box for you. 

4. Click on Whole words if you need to match complete words and not fragments. If not ticked, rainbow will 

match rainbows as well as rainbowPhotos.com.  

5. Click on Match case if you want capitalisation to be taken in to account. 

6. Click on Use wildcards to use simple wildcard characters in your search: 

o ? matches a single character e.g. Hole? would match Hole9 

o * matches any number of characters e.g. ice* would match ice, iced, iceland 

o + matches one or more characters e.g. ice+ would match iced, iceland but not ice. 

7. Find Next will jump to the next occurrence of the text in the bookmarks tree. 

8. Replace will jump to the next occurrence of the text in the bookmarks tree. Press it again to do the replacement 

and move onto the next. 

9. Replace All will do all the replacement automatically. 

Notes 

• Editing the text of a bookmark does not affect the page to which it refers. 

 

Find and replace in comments 

To search through or replace comment annotations in the current document: 

1. Choose View > Comments to display the Comments panel. 

2. Click on the Magnifying glass icon  in the small toolbar inside the Comments panel. 
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3. Enter the search phrase into the Find box.  

If text is selected in the current document using the Text tool  prior to pressing the Magnifying glass icon, 

it will be copied into the Find text box for you. 

4. Click on Whole words if you need to match complete words and not fragments. If not ticked, rainbow will 

match rainbows as well as rainbowPhotos.com.  

5. Click on Match case if you want capitalisation to be taken in to account. 

6. Click on Use wildcards to use simple wildcard characters in your search: 

o ? matches a single character e.g. Hole? would match Hole9 

o * matches any number of characters e.g. ice* would match ice, iced, iceland 

o + matches one or more characters e.g. ice+ would match iced, iceland but not ice. 

7. Find Next will jump to the next occurrence of the text in the comments tree. 

8. Replace will jump to the next occurrence of the text in the comments tree. Press it again to do the replacement 

and move onto the next. 

9. Replace All will do all the replacement automatically. 

 

Find and replace hyperlinks 

You can perform find and replace operations on the content of hyperlinks in the current document. This can be 

useful for changing the web address of hyperlinks. For example http://example.com could be changed to an email 

link mailto:info@example.com. 

You can also perform hyperlink replacement across files – see Find and replace across files. 

1. Choose Edit > Find & Replace > Hyperlinks. 

2. Enter the search text in the Find edit box. 

For example, entering http: into would match all web-based hyperlinks if Whole words is unchecked. 

3. If doing a replacement (rather than just a find), enter the replacement text in to the Replace box. 

4. Click on the all pages in current document hyperlink shown below to restrict the operation to a page-range.  

 

 
 

5. Click on Whole words if you need to match complete words and not fragments. If not ticked, http:// will match 

http://softmaker.com as well as http://freefont.de 
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6. Click on Match Case if you want capitalisation to be taken in to account. 

7. Press Find Next to highlight the next occurrence of the hyperlink matching the Find text. 

8. Click Find All to list all occurrences of hyperlinks matching the Find text. 

 

 
 

9. Double-click on an entry to view that hyperlink in the document. 

If you are searching through a portfolio, the third column in the results table will show the name of the 

document within the portfolio in which the hyperlink was found. 

10. Each time you hit Replace FlexiPDF will show and select the hyperlink to be replaced. If you agree, pressing 

Replace will do the replacement and move to the next occurrence. 

11. Pressing Replace All will do all the replacements throughout the page range you chose. 

Notes 

• The replace operation does not affect the pages in a PDF or the way a hyperlink looks. It only affects the 

internal data used to store the address of the hyperlink. 

 

Find and replace across files 

FlexiPDF can perform a find & replace operation on multiple files. When doing a replace operation, you have the 

option of making copies of all edited files to ensure the integrity of your original PDFs. 

1. Choose Edit > Find & Replace > In Files. 

2. The dialoge is split into two halves: 

o The top half is similar to the Find and Replace dialog offered by FlexiPDF Professional.  

o The lower half is where you add the files that are to be processed. 

3. The checkboxes available in the top half include all those in the Find and Replace dialog plus: 

1. Hyperlinks: When checked, the search & replace will apply to the contents of hyperlink annotations 

in the same way as using the Find and replace hyperlinks dialog. 

2. Ignore errors: Check this box to continue with the process even if some kind of error is raised while 

processing one of the documents.  

4. Add files to the list to be processed: 

1. Click Add to add a single file or a selection of files 

2. Click Add Folder to add all the files in a folder and any of its subfolders. 



FlexiPDF 2019 

81 / 154 

3. There is no limit on the number of files that can be added. 

4. Click Delete or Delete All to remove one or all files from the list. This will not delete a file on your 

disc but just drop it from the list. 

5. Click View to open the selected file in FlexiPDF. This useful for opening files which were skipped 

during processing due to errors. 

5. Press Find All if you wish to search only. 

The result window will open listing all the occurrences found. 

 

 
 

Double-click on a result to open that file and display the found item. 

Resize the columns in the list by dragging the dividing line between column labels. 

6. Press Replace All and FlexiPDF will prompt you to specify a folder for the edited files and one for those PDFs 

that cannot be processed due to some error condition. It is strongly recommended that you choose folders for 

each of these to protect your original PDFs.  

7. To stop processing press and hold the Stop button on the main dialog. It may take a while to respond so please 

keep holding until it does. 

 

Find and replace colours 

FlexiPDF can find and replace colours throughout a document. This can be colours of text or shapes and graphics or 

both. You can replace with any colour or use existing colours via the Swatches palette. 

Example 
We're going to change the green panels to another colour throughout the document. 

1. Using the Object tool , click on the green panel to select it. 
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2. Click on the Colour Picker button in the toolbar. 

 

 
 

3. Choose another colour. To choose a colour already used in the document, switch to the Swatches tab. 
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For a detailed explanation of the colour-picker dialog, see Changing colour. 

4. When you've chosen the new colour, press Change All to open the Find/Replace Colours dialog. 

 

 
 

5. You can click on either of the coloured rectangles to make further adjustments to the Find or Replace colours. 

6. Choose which colours you want to alter – fill, stroke (outline) or both. Text is usually filled, so if you are 

searching for text ensure Fill is chosen. 

7. Choose which kind of object you want to include in the search – text, graphics or both.  

Graphics does not include images or photos – their colours cannot be changed in this way. 

8. Specify the range of pages over which to search. You can also choose to search odd or even pages. 
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9. Press Replace All to start. 
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7.  Redact text and images 

 

Find and redact 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can redact all occurrences of words and phrases throughout a document. This redaction is deep and also 

occurs in bookmarks, comments and any other meta-data contained within the document. 

1. Choose: 

1. Edit > Find & Redact 

2. or press Ctrl+Alt+R 

3. or press  on the toolbar (View > Toolbars > Redact). 

2. Enter the text you wish to redact: 

 

 
 

If text is selected using the Text tool  when you open the dialog, it text will be copied into the Redact box 

for you. 

3. Click on Whole words if you need to match complete words and not fragments. If not ticked, rainbow will 

match rainbows as well as rainbowPhotos.com.  

4. Click on Use wildcards to use simple wildcard characters in your search: 

1. ? matches a single character e.g. Hole? would match Hole9 

2. * matches any number of characters e.g. ice* would match ice, iced, iceland 

3. + matches one or more characters e.g. ice+ would match iced, iceland but not ice. 

5. Press Style to change the way the redaction will look. See Redaction style. 

6. Press Redact Next to do one redaction at a time. This enables you to check each one. 

7. Press Redact All to perform all redactions automatically. 

Notes 

• The redaction becomes permanent only after the document is saved. 

 

Redaction style 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

Change the way new redactions look using the Redact Style dialog. 

1. There are two ways of getting to the dialog: 

1. From the Edit > Find & Redact dialog, press Style. 

2. Select some text with the Text tool , then choose Text > Redact Style. 

Be aware that this approach will actually redact the selected text once you press OK on the style 

dialog. 
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2. Choose the colour used for the redaction from the Colour pop-up menu. 

 

 
 

3. Choose an optional text label that will be printed on top of the redaction colour. This can be any text you like 

and will be repeated on the redaction in order to fill up the space available. 

 

 
 

An example of using a label together with a colour. 

 

 

Redacting images 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can permanently redact images, removing sections that needs to be obscured and making it impossible to 

retrieve the original data while leaving the remainder of the image intact. 

1. Ensure the Redact toolbar is visible (View > Toolbars > Redact). 

 

 
 

2. Select Redact Image  and drag out a rectangular area to be redacted. 

Once drawn, the Object tool  becomes selected. 

3. You can move, resize and rotate the rectangular area just like any other graphic object. 

4. Continue adding further redaction areas in the same way to images in your document. 

5. The redaction only becomes permanent when the PDF is saved. 

Notes 

• The redaction becomes permanent only after the document is saved. 

• FlexiPDF modifies the data of images covered by redaction rectangles, permanently obscuring those parts of the 

image. 

 

Redact text 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can be used to reliably redact text of a sensitive nature. A block of text can be rendered illegible to the 
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extent that its original content no longer forms part of the page-marking stream. 

Any text you redact will also be redacted within the document’s metadata. This includes any bookmarks or text 

within comments as well as hidden, non-user accessible metadata. 

1. Using the Text tool , select the span of text to be redacted. This can be anything from a single word to an 

entire story. 

2. Then choose Text > Redact. Alternatively, press Ctrl+Shift+R or choose View > Toolbars > Redact and 

press Redact Text  on the toolbar. 

3. The selected text will be obscured by a solid box. This is the way the text will appear when the PDF is opened 

in any other PDF viewer. 

4. You can undo this change whilst editing, but once you save the document, the redaction becomes permanent 

and cannot be undone. 

5. To change the colour of future redactions or to add a label to the redacted text, choose Text > Redact Style. See 

Redaction style. 
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8.  Page operations 

Commonly required operations are available on the Pages Toolbar (View > Toolbars > Page operations). 

•  Rotate Pages 

•  Insert New Pages 

•  Extract Pages 

•  Delete Pages 

Additional, less commonly used operations are available in the Pages menu. 

 

Insert pages 

FlexiPDF can insert: 

• new, blank pages 

• pages from a scanner 

• pages from other PDFs 
 

Blank pages 

You can insert any number of blank pages into a PDF document. 

1. Choose Pages > Insert New 

or press the Insert New Pages button  on the Page operations toolbar (View > Toolbars > Page 

operations). 

 

 
 

2. Enter the number of new pages you want to add into the Create edit box. 

3. Specify where you want to insert the new pages by choosing Before or After, then choose First page or Last 

page, or enter a page number into the Page edit box. 
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4. Choose a page size: 

1. Use Current Size makes the new pages the same size as the currently displayed page. 

2. Standard Size lets you choose from a list of standard page sizes – A4, US Letter, etc. 

3. Custom size lets you choose an arbitrary size. 
 

From scanner 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

If your computer has access to a scanner, you can scan new pages into the currently open PDF. 

1. Choose Pages > Insert From Scanner. 

 

 
 

2. Choose your scanner from the Device list of available scanners. 

3. If your device is an automated document scanner capable of scanning many pages unattended, change Source 

to Automatic Document Feeder. 

4. Choose the Placement – where the new pages should be placed in the current document. 

5. To convert the words in the scanned document into text rather than just a photograph of text, make sure 

Recognise Text (OCR) is checked. If you are scanning a photograph with no text, do not check this option and 

skip the remaining steps. 

6. Choose the language of the text in the scanned pages. This helps FlexiPDF recognise words correctly. 

7. Choose the PDF Style you require: 

o Choose Editable Text if you want to be able to edit the text in your scanned page. 

This will give a document with no graphics or photos, just text that can be edited as normal. 

o Choose Searchable Image if you are interested in preserving the appearance of the scanned pages. 

The recognised text will be available for searching, but not for editing. 

If there are mistakes made by the recognition process which could causes searches to be inaccurate, 

you can correct these using the OCR corrections facility. 
 

Inserting from other PDFs 

Pages from another document can be imported into the current PDF.  

1. Drag and drop a PDF file onto your open document. 

or: 
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1. With your destination PDF already open, choose Pages > Insert From Document. 

2. Choose the PDF you wish to insert using the file selection dialog 

2. Select the pages to insert: All pages or a range of pages. 

 

 
 

3. In Placement, choose where the new pages should be placed in the current document. 

4. To renumber the pages of your document, see Number pages. 

 

Rotate pages 

1. Press the Rotate Pages button  on the Page operations toolbar (View > Toolbars > Page operations). 

 

 
 

2. Choose the rotation and page range to which it should be applied. 

3. The dialog displays the current page rotation below the 180 degrees radio button. 

 

Extract pages 

FlexiPDF can make a new PDF from a range of pages in an original PDF. This can be handy if you need to email 

just a few pages from a larger PDF. 
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The original PDF is not modified by this function – the new PDF(s) will contain copies of the original pages. 

1. Press the Extract Pages button  on the Page operations toolbar (View > Toolbars > Page operations) or 

choose Pages > Extract. 

 

 
 

2. Choose the page range you wish to extract. 

3. Click Save each page as new PDF if you want each extracted page to be saved to its own file. Otherwise a 

single PDF will be saved with the specified pages. 

4. Press OK and choose where to save the new PDF(s). 

5. If you opted to extract to a single file, it will open in a new window once the operation is complete. 

 

Delete pages 

1. Press the Delete Pages button  on the Page operations toolbar (View > Toolbars > Page operations) or 

choose Pages > Delete. 

 

 
 

2. Choose the range of pages you wish to delete. 

3. You can restrict the deletion to even, odd or even and odd pages. 

4. There is no undo for this operation. Please make sure you have a backup of the PDF before proceeding. 

 

Replace pages 

FlexiPDF can replace pages of the current PDF with pages from any other PDF document.  

1. Open a document in which you you want to replace a page. 

2. Choose Pages > Replace. 

3. Choose the document supplying the new page. 
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4. Choose the page from the donor document.  

The donor document is unaffected by this operation. A copy of the page is made before insertion into the 

current document. 

5. Choose the page to be replaced in the current document.  

The chosen page will be permanently deleted.  

Make sure you have a backup of the document in case something goes wrong. 

 

Re-order pages 

A page or group of pages may be moved from one part of a PDF to another.  

Moving A single page 
1. Choose View > Thumbnails to make the Thumbnail pane visible. 

2. Click and drag a thumbnail to its new position in the thumbnail list. 

Moving multiple pages 
1. Choose Pages > Re-order. 

 

 
 

2. Choose the range of pages you wish to relocate by entering the start and end page into the Current Location 
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edit boxes. 

3. Choose where you want the pages moved. 

Notes 

• After relocating, you may have to alter page numbers printed on the pages. See Number pages for details of 

renumbering the affected pages.. 

 

Resize pages 

A page or group of pages can be resized. This (optionally) scales all objects on the page, then adjusts the media box 

(paper size). 

1. Choose Pages > Resize. 

 

 
 

2. Choose the Page range you wish to resize. 

3. Choose the New size for the pages: 

o Standard: Choose from a list of standard page sizes e.g. A4, US Letter, etc. 

o Custom: Create your own page size.  

▪ The Units pop-up can be set to percent to apply a scale, or a distance unit to set an explicit 

size. 

▪ Set Width and Height independently or click  to maintain the aspect ratio 

4. Uncheck Apply to page contents to resize the page only; objects on the page will not be altered. 

 

Crop pages 

Cropping sets the visible part of a page to a given rectangle.  
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You can crop a PDF in two ways: 

• manually by drawing a crop box 

• automatically by letting FlexiPDF discard empty parts of the page 

Notes 

• Anything outside the rectangle is hidden but still present in the PDF. Another user could change the crop to 

reveal information previously hidden. 
 

Manually 

Manually trim the size of a range of pages using the Crop tool. 

1. Choose the Crop tool  from the toolbar. 

2. Drag out a box to represent the area that will remain after cropping. You do not need to drag out exactly the 

right shape since you can resize the box after the initial drag. 

When you are happy with the area covered, press Return on the keyboard. 

3. Specify the range of pages you want cropped. 

4. If the Set Page Media Box checkbox is checked, the /MediaBox value will changed to reflect the new crop. 

This is not required for most users. 

5. Press OK to perform the crop. 

6. You can undo a crop by choosing Pages > Remove Crop. 

Notes 

• Cropping does not remove anything from a PDF, it just limits what is displayed by PDF viewers and printers. 
 

Automatic 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

Auto-cropping reduces the visible area of a page leaving just enough for its contents. For example, if a page 

contained only a photograph and a caption with a large empty border, after auto-cropping the empty space would be 

trimmed away, leaving just the image and its caption. 

1. Choose Pages > Auto Crop. 

2. Choose a page range over which to apply the crop. 

3. Press OK. 

4. You can undo a crop by choosing Pages > Remove Crop. 

Notes 

• Cropping does not remove anything from a PDF, it just limits what is displayed by PDF viewers and printers. 

 

Place pages from other PDFs 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can place the contents of an entire page from another PDF onto the current page of your PDF. 

1. Choose File > Place PDF. 

2. Alternatively, drag and drop a PDF file onto your open document to place a page. Choose the option Place a 

page in the window that appears. 
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3. If the document being placed has only 1 page, it is placed immediately. Otherwise, choose the page from the 

PDF you want to place. 

4. As the page is placed, its contents are grouped together to make it easier to select and move a group using the 

Object tool . Ungroup the page if you need to access objects within it. 

 

Page margins 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can add margins to a range of pages to make editing easier. These margins act as fixed guides. See Guides for 

an explanation of how guides work. 

1. Choose Pages > Margins. 

 

 
 

2. Enter the desired margins in the edit fields. 

3. Checking Tie values together ensures that all edit fields have the same value. This works when you move from 

one box to the next by pressing Tab or clicking the mouse. 

4. Choose the page range for the new margins. You can have different margins on odd and even pages by applying 
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margins twice – once for odd pages, once for even. 

Notes 

• To change the units used (cm in this case), close the dialog, choose File > Preferences and switch to the 

Editing tab. 

• After adding margins, they will become visible on all pages. Choose View > Guides > Hide Guides to hide 

them. 

• Margins, like other guides, are retained in the PDF for FlexiPDF to use next time you edit the document. They 

will have no effect on and will not be visible in any other PDF viewer. 

 

Watermarks 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF lets you apply a fixed watermark to the foreground or background of the pages in a document. The 

watermark itself is defined in another PDF and can contain anything you like, such as a logo or text. 

1. Open the PDF to be watermarked. 

2. Choose Document > Watermark > Add. 

 

 
 

3. Choose your watermark: 

o Press Built in to show the selection of predefined watermarks. 

o Press Browse to select a PDF which contains a suitable watermark. 

If the chosen PDF has multiple pages, FlexiPDF will use only the first as the watermark. 

4. Choose whether you want the watermark to appear in the Background or Foreground of the existing page 

contents. 

5. Check Scale to fit to resize the watermark so that it fits the pages it is being applied to.  

When resizing, FlexiPDF scales the watermark so that its crop box matches the destination page. 

6. Select the Opacity of the watermark – how visible you want it to be on the page from very faint to solid. 

7. Choose the page range over which you wish to apply the watermark. You may want different watermarks for 
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different parts of your document. 

8. Press Apply. 

9. Watermarks can be removed by choosing Pages > Watermarks > Remove. 

Notes 

• Watermarks behave like locked objects. If unlocked, a watermark can be edited as a normal object. 

• A page may contain only one watermark at a time. When adding a new watermark to a page FlexiPDF first 

removes any existing watermark. 

 

Labels 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

A page label is an optional number or phrase displayed along with each page in FlexiPDF or other PDF viewers. It is 

independent of, though often related to, the physical page number printed on each page. 

FlexiPDF displays page labels in the status bar. 

 

 
 

FlexiPDF status bar showing page label Preface VI 

Creating & Editing Labels 
1. Choose Pages > Labels or double-click the page label in the status bar. 

 

 
 

2. The Page Labels dialog box is split into two parts: 

o The top part shows a list of the current labels in the document. 

o The bottom part is for editing or adding labels. 

3. To edit an existing label, click on its entry in the list to copy its details into the edit boxes beneath the lower part 

of the dialog box.  
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Skip this step if you just want to create a new label. 

4. The Start Page is the first physical page to which the label applies. 

A label remains in effect until the start page for another label is reached. 

5. The optional Prefix will be added to each page label. e.g. Appendix: 

6. The Start Number is the start point for the label's numbering. This number is always decimal, no matter what 

numbering format is chosen in the next step. 

For example, to number the first page of an Appendix as A even though it begins on page 250 of a PDF: Start 

Page = 250, Start Number = 1, numbering style = Upper Case Letters 

7. Choose the numbering format for the labelled pages using the pop-up list. 

8. Press Add to put any changes you have made back into the list of labels and the PDF. 

If the Start Number clashes with an existing label, the new details will overwrite the existing label. Otherwise 

a new label with that start number will be added to the list. 

 

Numbering 

Page numbering can be done in two ways: 

• Copying a page number field onto each page.  

This approach gives you the flexibility to copy a selection of objects (such as graphics, images, text) at the same 

time as the page number.  

• Applying a text header and footer to each page in a range.  

You can specify the text style but cannot include graphics or non-text items – see Bates Numbering. 
 

Bates 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

Bates numbering is used in the legal and medical fields to place consecutive page numbers, unique identification 

numbers or date and time stamps on documents. 

Numbering Your Documents 
1. Choose the files to which you wish to apply Bates numbering. 

2. Configure the format, layout and range of the numbering. 

Layout 
FlexiPDF applies Bates numbering in any of 6 fixed areas – 3 in the header and 3 in the footer area of each page. 

You can fine-tune the positions of the header/footer by adjusting the margins used during the process. 
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A header and footer region is super-imposed onto each page during numbering. 

 

Choosing PDFs 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

1. Choose File > Bates Numbering 

 

 
 

2. Press Add Files and Add Folders to add the PDFs you want to number.  

There is no limit on the number of PDFs that can be numbered. 

3. Once you have added the files to be numbered, press OK. 

4. Choose the folder where you want the numbered PDFs to be saved.  

Choose a different folder so that your original PDFs are not overwritten by the newly numbered versions. 

5. You can configure the format of the numbering using the next dialog. 
 

Formatting 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

1. After selecting the PDFs to be numbered, the Header & Footer dialog appears.  
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2. In the Header section, enter text into one or more of the 3 text boxes. Your text text will be stamped onto the 

left, centre and right of the top of each page. 

You can enter any text into the boxes or press the Bates Number, Page Number or Date buttons to enter a 

special keyword.  

3. Repeat the same process for the Footer section. 

The example below shows how the header/footer boxes can be used: 

 

 
 

4. Press Options beneath the: 

o Bates Number button to change the number of digits used for the number and the starting number. 

o Page Number button to change the numbering format and starting number used. 

o Date button to change the date format used. 

5. Click on the hyper link next to Page Range: to change the range of pages over which to apply the 

header/footer. For example you may wish to alternate text between even and odd pages. 
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6. Click on the hyper-link next to Font and Colour: to change the style of text used in the header/footer. 

7. Control the position of both headers and footers by clicking on the Page Margin: hyper-link. 

 

 
 

Click Tie values together if you want changes to one value to be reflected in the other 3. 

To change the units used for measurement in this dialog, see Preferences: Editing. 

8. Press OK to begin processing. This operation may take some time depending upon the size and number of 

PDFs in the list. 
 

Using "Copy across pages" 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

This method of page numbering makes use of the Copy objects across pages function,  

1. Remove existing page numbers, leaving one to use as a model for the new numbers.  

See Delete objects across pages. 

2. Select the Text tool  from the toolbar. 

3. Click in an existing page-number text box or create a new text box (see Adding new text). 

4. Choose Text > Insert Page Number. 

 

 
 

5. Choose the Numbering Style for the number. 

Whatever format is chosen, the font used must include all the characters that will be required as the number 



FlexiPDF 2019 

102 / 154 

changes across the page range. You can verify this by looking at the font using the character palette – see 

Character palette / Special characters. 

6. Specify the Numbering Offset. 

For example, if you are on page 1 and want the numbering to start at 1, leave this value as 0. If you are on page 

5 and want the numbering to start from 1, the offset would be -4. 

7. Press OK. 

8. Copy the text box containing the page number across all pages you want to renumber. See Copy objects across 

pages. 

Notes 

• Page number fields do not update when pages are added or removed from a PDF. Instead you should repeat the 

numbering process on the affected pages. 

 

Clone across pages 

See Copy objects across pages 

 

Delete across pages 

See Delete objects across pages 
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9.  Scanning & OCR 

 

OCR (Optical Character Recognition) 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

To edit the text in a PDF that is just a scanned image or vector-based artwork, you need to perform OCR on the 

page(s) first. 

1. Choose Document > Recognise Text (OCR). 

 

 
 

2. Choose the range of pages you want to process. 

3. Choose the language in which the text in the scan is written. 

4. Choose the desired PDF Style: 

o Choose Editable Text if you want to be able to view and edit the text in your scanned page. 

This will give a document with no graphics or photos, just text that can be edited as normal. 

o Choose Searchable Image if you are interested in preserving the appearance of the scanned pages 

while being able to search within them. The recognised text will remain hidden from view but 

available for searching. 

If there are mistakes made by the recognition process, you can correct these using the OCR corrections 

facility.  

Notes 

• The OCR process will not run on pages which already have editable text on them to avoid losing that text. 

• If you need to perform OCR on part of a page, copy that part only to a new document or page and perform OCR 

on that. Then copy/paste the results back into the original page. 

 

Create a new PDF 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

If your computer has access to a scanner, you can use it to create a new PDF from a paper document. 

1. Choose File > New, then click on Import from scanner. 
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2. Choose your scanner from the Device list of available scanners.  

The list of devices shown will depend on your particular computer setup. 

3. If your device is an automated document scanner capable of scanning many pages unattended, change Source 

to Automatic Document Feeder. 

4. To convert any words in the scanned document into editable or searchable text rather than remaining as just a 

photograph, make sure Recognise Text (OCR) is checked. If you are scanning a photograph with no text, do 

not check this option and skip the remaining steps. 

5. Choose the language of the text in the scanned document. This helps FlexiPDF recognise words correctly. 

6. Choose the desired PDF Style: 

o Choose Editable Text if you want to be able to view and edit the text in your scanned page. 

This will give a document with no graphics or photos, just text that can be edited as normal. 

o Choose Searchable Image if you are interested in preserving the appearance of the scanned pages 

while being able to search within them. The recognised text will remain hidden from view but 

available for searching. 

If there are mistakes made by the recognition process, you can correct these using the OCR corrections 

facility.  

 

 

OCR corrections 

Some scanner applications place scans as images in PDF files, but invisibly add their textual content behind the 

images. This results in the scanned pages keeping their original layout, but making them at the same time 

searchable. 

You can create such a hybrid file with FlexiPDF, too, by choosing a “searchable image” when performing OCR. 

In order to correct errors in this hidden text, you can make the text visible in FlexiPDF. 

1. Open the PDF to be corrected. 

2. Choose Document > OCR Corrections > Start. 

Since OCR mode could cause a PDF to be substantially changed, you will be asked to confirm your choice. 

Always make sure you have a backup of the PDF before you start this mode. 
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3. Choose Start OCR mode to begin. 

The hidden text becomes visible, the scanned image faded and locked to make editing easier. 

4. You can now edit the text while making reference to the original content in the image. 

5. After all corrections have been done, choose Document > OCR Corrections > Finish. 

The OCR text, including any edits you made will become invisible again and the scanned image will be restored 

to its normal density. 

If OCR text remains visible 
If you find some unwanted text remains visible in your document, choose Document > OCR Corrections > Hide 

all text which will make all text invisible even if it wasn't originally hidden. Since this operation cannot be undone, 

please ensure you save a copy of your document first. 

Notes 

• If your document happened to contain any non-ocr text added after the scanning process, this too will be hidden 

at the end of the correction process. 

• Choose View > Text > Boundaries to see the boundaries between different blocks of text. 

• Changing the colour of the OCR text can make it easier to distinguish from the background image. This will not 

affect the finished PDF. 

• Some OCR packages create many small text blocks that are difficult to edit. See Merging text boxes. 
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10. Document operations 

 

Create a file 

FlexiPDF can create: 

• new, blank PDFs,  

• PDF portfolios,  

• PDFs from a scanner. 

To create a new, blank PDF document: 
1. Choose File > New, then choose Blank. 

 

 
 

2. Choose the Number of pages in the new document. 

3. Choose the Page size to be used throughout the new document.  

Use the list of Built in sizes or define a Custom size. 

4. If you want to keep the current document open, check Open in new window.  

This is handy if you want to copy objects from the current document to the new one. 

 

Join files 

See Joining PDF files 

 

Split a file into sub-documents 

FlexiPDF can split a PDF into new documents, each with a given number of pages. 

1. Choose Document > Split. 
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2. Enter the number of pages for each new document. 

3. Choose a folder for the new PDFs. 

 

Drag and drop 

Dropping a single PDF 
When you drag and drop a single PDF onto an open PDF document, you can: 

• Open the file, closing the current document. 

• Open the file in a new window, leaving the currently open document as it is. 

• Insert pages from the PDF into the current document 

• Place a page from the PDF onto a page in the current document 

• Do a side-by-side comparison of both PDFs, but only if they have the same number of pages 

Dropping multiple files 
When you drag and drop multiple files onto the program window of FlexiPDF, you can: 

• Join the files into a single PDF, if the files are all PDFs. 

• Create a new portfolio document which is a single PDF containing other files (not just PDFs) inside it. 

• Place images on the current page – if the files are all images. 

• Create a new photo album with one image per page, if the files being dropped are all images and there is no 

document currently open in FlexiPDF. 

• Do a side-by-side comparison, but only if you drop two PDFs with the same number of pages and there is no 

document currently open in FlexiPDF. 

 

Properties 

A summary of the settings, dates, author and other information about the current PDF can be viewed by choosing 

Document > Properties. 
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This data is stored in a non-human readable form inside the PDF. 

• Click on the Modified hyperlink to open the PDF’s Change Log. 

• Click on the Security hyperlink to open the Document Security dialog box. 

• Resource Page indicates if the PDF has an embedded resource page. 

• The Creator and Producer labels are read-only and cannot be edited by the user. If a document has been edited 

by FlexiPDF it will have "(FlexiPDF)" appended to the Creator label. 

Notes 

• If the current document is part of a portfolio, the dialog will display the properties of the containing PDF. To 

see the properties of individual documents within the portfolio, click on the Properties button  in the 

Portfolio panel’s toolbar (View > Portfolio). 

• When the selected element within a portfolio is not a PDF, the Properties dialog is truncated to show just the 

basic properties of the file. 

 

Security 

Using PDF security settings you can limit what other people can do with your PDF. For example, you can stop other 

people editing or printing your PDF. 

To check the security settings for a PDF, choose Document > Security. 
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If the document has been secured, the security dialog box will display with most controls inactive. However the 

controls still show the current security settings such as whether or not editing is allowed. 

• If enabled, click Unlock to change the security settings. 

If the PDF has an existing Master password, you will have to enter it now. 

If you do not know the password, you will not be able to alter any of the security settings. 

Passwords 

• User: (required to open a document) 

If set, a password must be supplied, before the PDF can be viewed or printed. If this password is required and 

not known, the PDF will be unusable in any PDF viewer. 

• Master: (required to change security settings) 

If set, a password must be supplied before changes can be made to security settings. Without the password, 

users will still be able to view and perform the operations allowed by the security settings. Note that some PDF 

viewers may not correctly enforce these restrictions, meaning the PDF could be modified against the author's 

wishes. 

 

Track changes 

FlexiPDF can highlight text that has been modified during previous editing sessions. It also records the date, author 

and page number of all changes made to PDFs. This information is listed in the Change log. 

 
 

Highlight changes 

1. Choose File > Preferences 

2. Switch to the Editing tab. 

3. Ensure Show changed text in is checked and choose your preferred colour from the drop down list. 
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Change log 

The change log records the date, user name and pages modified.  

Modifications made by other PDF editors are not recorded. 

1. Choose Document > Change Log. 

 

 

 

 

Font catalogue 

FlexiPDF can list all of the fonts used in a PDF plus additional information about the nature of each font. 

1. Choose Document > Fonts to view the font catalogue. 
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Fonts introduced during the current editing session will not appear until the PDF is saved. 

The columns shown are: 

1. Font name 

Names prefixed with XXXXXX+ represent subset fonts (embedded with only a subset of their full 

character set). 

2. Type 

The format of the font. There are many formats that may be used within a PDF – TrueType, Type1, 

Type3, OpenType, etc. 

3. Actual Font 

Embedded indicates that the characters required by the PDF are included inside the PDF. 

To save space, PDF producers sometime choose not to include the fonts required in a PDF. If not 

embedded, FlexiPDF will choose a font from your computer's system fonts to display the text. This can 

result in a loss of fidelity. The name of the chosen replacement font will then be shown in the column 

instead. 

4. Unicode 

The encoding format of the font. Most fonts are encoded as Unicode nowadays. 

5. No. of Glyphs 

The number of characters shapes defined by the font. To save space, some PDF producers only include 

definitions for the character shapes actually used in a PDF.  

2. Select a font, then click Replace to open the Find and Replace Font dialog box. 

3. Press Remap to change the characters mappings of the font. See Remapping fonts. 

Notes 

• When editing text, choose Text > Character Palette to view all of the glyphs contained in a font. 

 

Problem report 

FlexiPDF can check for two types of problem in your edited PDFs: 

1. Overset text: when there is too much text to fit in a text box and the overflowing text has been hidden from 

view.  

2. Auto-fit size change: when automatic text fitting has been used on a text box and the size of that text has been 

altered by more than 10% as a result. 

FlexiPDF always checks for problem 1 when you save a PDF. 

Otherwise, you can perform the checks at any time by choosing File > Problem Report. 

Problem report on save 
You may see a warning when saving your edited PDF: 
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Press Save anyway to ignore the problems and save the PDF, or View the problems to display the issues in the 

Problem Report Results window. 

Problem Report Results 
 

 
 

• Double-click on a problem to view it in the PDF. 

• Click the filters checkboxes to show or hide the different kind of errors: 

o Overset text: when there is too much text to fit in an existing text box. 

o Auto-fit Size Change (>10%): when the text size has been automatically adjusted by more than 10% 

in order to make it fit into a box.  

• If you make a change in the PDF (to resolve an issue), press Refresh to update the list of problems. 

Resolving Problem Report Issues 
To fix problems, double-click on the item (or press View), then do any or all of the following: 
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1. Resize the text box in question to make it bigger. 

2. Edit the text to change its length. 

3. Click the Auto Fix button which will enable text fitting on the selected text. This will make a slight adjustment 

to size in order to get a fit. If the button is disabled it means that auto-fitting is already enabled on the text. In 

this case, press Text Fitting. 

4. Click the Text Fitting button and alter the auto-fit controls to better fit the text. 

 

Reduce the file size 

See Resampling Images / Reducing PDF Size 

 

Resource document 

To ensure portability and ease of editing, templates should include embedded font definitions for all the character 

shapes likely to be used. 

For templates with a restricted colour palette it may be necessary to define optional colours not yet used in the 

template but that may be used in future. 

Both of these requirements can be met by including a “resource page” in your template. 

1. Choose Document > Resource Document > Add to embed the resource page within the currently open PDF. 

2. Choose the resource document which should itself be a normal PDF. 

Resource Documents 
There is no particular format for a resource document. Any fonts and colours it contains will be made available in 

the main PDF to which it is attached. 

 

 
 

A simple resource document containing characters taken from 2 fonts and 4 colour swatches. 

Notes 

• Resource documents are invisible to other PDF viewers and will not be affected by them. 
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11. Portfolios 

A portfolio (in PDF terms) is a convenient way of bundling a collection of related documents into a single container 

document. The documents in a portfolio need not be PDFs but can be movies, audio, images, .doc or .txt files. 

Portfolios are a fairly recent addition to the PDF specification and are generally only supported by the latest PDF 

viewers. 

 

Create a portfolio 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

To create a new portfolio document: 

1. Choose File > New, then choose New Portfolio. 

2. Create a list of files to add to the new portfolio. 

The controls on this dialog are the same as those on the Join Files dialog. 

3. Click Create, then select a file name for the new portfolio document. 

Notes 

• You can change the order of items in an existing portfolio by picking up and dragging the thumbnails within the 

Portfolio panel. 

 

Add files to a portfolio 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can add files to existing portfolios. 

1. Open an existing portfolio document open in FlexiPDF. 

2. Show the Portfolio panel by choosing View > Portfolio. 

3. Then either: 

o Drag and drop one or more files onto the Portfolio panel. Once added, you can change the ordering of 

the documents by dragging them around within the Portfolio panel. 

o Click the Add icon  on the small toolbar at the top of the Portfolio panel. 

 

Delete files from a portfolio 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can delete files from an existing portfolio: 

1. Open the portfolio document in FlexiPDF. 

2. Show the Portfolio panel by choosing View > Portfolio. 

3. Click on the item to be deleted. 

4. Press the Delete key on your keyboard or click the Delete icon  in the Portfolio panel’s toolbar. 

 

Extract files from a portfolio 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can extract an item from a portfolio so that it becomes a stand-alone file. 



FlexiPDF 2019 

115 / 154 

1. Open the portfolio document in FlexiPDF. 

2. Show the Portfolio panel by choosing View > Portfolio. 

3. Click on the item to be extracted. 

4. Click the Extract Item icon  in the panel’s toolbar.  

5. Put a tick next to the items you wish to export. 

6. Specify a file name for the copy of the item. The original item will not be removed from the portfolio. 

 

Properties of files in a portfolio 

To get additional information about a file stored in a portfolio: 

1. Click on an item in the current portfolio in the Portfolio panel (View > Portfolio). 

2. Click on Properties  in the toolbar at the top of the Portfolio panel. 

3. If the document is a PDF, the Document Properties dialog will be displayed. 

If the document is not a PDF, a smaller information dialog will show some basic information about the file. 

 

 
 

4. To view the item itself, click on the Open Media button which appears in the main viewer. 

5. To extract the file from the portfolio as a stand-alone document, see Extracting Items. 
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12. Commenting 

 

Comments catalogue 

FlexiPDF offers a summary of all comments found in a PDF. 

• Choose View > Comments to show the comments catalogue. 

This catalogue is divided into three sections each containing the same 

information but sorted by: 

o Page 

o Comment type 

o Author 

• Click on a comment in the catalogue to go to the page on which it 

occurs. 

• Click on a comment, then click the Delete icon  to remove it from 

the document. 

• When you edit the contents of the pop-up note window, the comments 

catalogue updates at the same time. 

• Drag and dock the comments panel to any side of the main FlexiPDF 

window to make it easier to read. 

• Drag the panel away from the main window to convert it into a 

floating window. 

 

Sticky notes 

You can create new or edit existing “sticky note” annotations in PDFs. These are small pop-up windows designed to 

contain short messages such as approval or editorial comments. 

A sticky consists of: 

1. An icon which defaults to though there are a number of alternative icons available – see Sticky note 

properties for details. Double-click the icon to toggle the associated note window open or closed. 

2. A pop-up note window which displays any attached message as well as the date the note was created and the 

name of the author. The icon and the pop-up window can be moved around independently of each other. 

3. An entry in the Comments catalogue. 

Notes 

• If you cannot see the sticky-note window after double-clicking on the sticky note icon, try scrolling the page or 

zooming out. It may be off the screen somewhere. 

• To change the user name assigned to new notes, choose File > Preferences, switch to the Saving tab and enter 

the new name in the User Name edit field. 

• Sticky notes are not included when printing PDFs even if Print annotations is checcked in the Print dialog 

box. 
 

Add a sticky note 

1. Ensure the Commenting toolbar is visible (View > Toolbars > Commenting). 

2. Click on the Sticky Note icon  on the Commenting toolbar. 

3. Drag out a box to denote the size of the new sticky note. Alternatively, single-click the left mouse button to 
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create a standard-sized sticky note window. 

4. If you have not already set up a user name using File > Preferences > Saving, FlexiPDF will now ask you to 

supply one: 

 

 
 

This user name will be recorded in each comment you make. 
 

Delete a sticky note 

Sticky notes can be deleted using the Comments catalogue which will also remove them from the document. 

Alternatively: 

1. Select the Hand tool  on the Edit toolbar 

or the Sticky Note icon  on the Commenting toolbar (View > Toolbars > Commenting). 

2. Click on the sticky note icon to select it. 

3. Press Backspace or Delete on the keyboard. Alternatively, right-click on the sticky note icon and choose 

Delete. 
 

Sticky note properties 

Change the attributes of a sticky note using the Note Properties dialog box. 

1. Select the Hand tool  on the Edit toolbar. 

or the Sticky Note icon  on the Commenting toolbar (View > Toolbars > Commenting). 

2. Right-click on the sticky note's icon and choose Properties. 

3. All attributes of the note can be modified besides the creation date. 

 

Graphical notes 

As well as simple Sticky Notes, FlexiPDF offers a selection of graphical notations. These pair a simple shape with a 

pop-up note and can be used to draw attention to particular items on a page. 

A graphical note consists of: 

1. An outline rectangle, circle, polygon, freehand shape or line. 

2. A pop-up note window which displays any attached message as well as the date the note was created and the 

name of the author. The outline shape and the pop-up window can be moved around independently of each 

other. 

3. An entry in the Comments catalogue. 

Notes 

• If you cannot see the pop-up note window after double-clicking on the outline shape, try scrolling the page or 

zooming out. It may be off the screen somewhere. 

• To change the user-name assigned to new notes, choose File > Preferences, switch to the Saving tab and enter 

the new name in the User Name edit field. 

• Graphical notes are included when printing PDFs if Print Annotations is ticked in the Print dialog box. 
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Add a graphical notes 

1. Ensure the Commenting toolbar is visible (View > Toolbars > Commenting). 

2. Click on one of the graphical note tools      on the Commenting toolbar. 

3. If you have not already set up a user name using File > Preferences > Saving, FlexiPDF will now ask you to 

supply one. 

 

 
 

This user name will be recorded in each sticky note (or other comment) you make. 

4. Draw the shape: 

o ,  – Drag out a box depicting the final size of the shape. Hold down the Shift key while 

dragging to create a perfect circle or square. 

o  – Click on the page to start a new line segment connected to the previous one. Double-click to 

finish the polygon. 

o  – While holding down the left mouse button, draw your freehand shape on the page. 

o  – Click on the page and drag out a straight line. Hold Shift while dragging to limit the line angle 

to multiples of 45 degrees. 

5. Double-click on the outline just created to open the associated note window. 
 

Properties of graphical notes 

Change the attributes of a sticky note using the Note Properties dialog box. 

1. Select the Hand tool  on the Edit toolbar or any graphical tool      on the Commenting 

toolbar (View > Toolbars > Commenting). 

2. Right-click on the shape's border and choose Properties. 

3. A graphical comment has an (optional) fill colour, line colour and a line width. 

You can also vary the opacity of the comment to allow the contents of the page underneath to show through. 
 

Delete a graphical note 

Graphical notes can be deleted using the Comments catalogue which will also remove them from the document. 

Alternatively: 

1. Select the Hand tool  on the Edit toolbar or any graphical tool      on the Commenting 

toolbar (View > Toolbars > Commenting). 

2. Click on the outline of the shape to be deleted. 

3. Press Backspace or Delete on the keyboard. Alternatively, right-click on the outline and choose Delete. 

 

Stamps 

FlexiPDF offers a selection of predefined stamps – graphical labels – that can be placed, resized and coupled with a 

pop-up note window.  

You can add, delete, modify and create your own user-defined stamps. 
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An example of a Sign Here stamp and its associated pop-up note window. 

 
 

Add a stamp 

1. Ensure the Commenting toolbar is visible (View > Toolbars > Commenting). 

2. Click the Stamp tool  in the toolbar. 

3. Click anywhere on a page to add a stamp of default size or click+drag to create a stamp of a custom size. 

4. To choose a different stamp: 

1. Click and hold the black triangle on the Stamp tool  to reveal the menu of available stamps. 

2. Choose Built In to see the selection of pre-defined stamps. 

5. Double-click a stamp placed in your document to open its associated note window. 
 

Delete a stamp 

Stamps notes can be deleted using the Comments catalogue which will remove them from the document. 

Alternatively: 

1. Select the Hand tool  on the Edit toolbar 

or the Stamp tool  on the Commenting toolbar (View > Toolbars > Commenting). 

2. Click on the stamp to be deleted. 

3. Press Backspace or Delete on the keyboard. Alternatively, right-click on the outline and choose Delete. 
 

Properties of a stamp 

To review and change the properties of a stamp: 

1. Select the Hand tool  on the Edit toolbar 

or the Stamp tool  on the Commenting toolbar (View > Toolbars > Commenting). 

2. Right-click on the stamp and choose Properties. 

Change the appearance of the stamp as well as its opacity – handy if you want the page's contents to show 

through. The Appearance drop-down menu will only show built-in stamps, but no user-defined stamps. 
 

User-defined stamps 

You can tell FlexiPDF to load any number of user-defined stamps from a specific folder on your computer. 

Your stamps should be single-page PDFs and can be created in any application that produces PDFs, including 

FlexiPDF. 

1. Create a folder for storing all of your stamp PDF files.  

In the next step, FlexiPDF will load all PDFs it finds in that folder and treat them as user-defined stamps. 

2. Choose File > Preferences and switch to the Editing tab. 
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3. Enter the location of your stamps folder in the User-defined stamps folder edit field, or press the browse 

button  to choose a location. 

4. When you press OK, the folder with be scanned for PDFs and any found will be listed in the User-defined sub-

menu of the Stamp tool  in the toolbar.  

The file name given to each stamp you create is used as the menu title in the User-defined stamps, sub-menu. 

Notes 

• Use the Drawing toolbar (View > Toolbars > Drawing) to create the artwork for stamps, not the commenting 

tools. You can’t create a stamp using annotations or other stamps! 

• The user defined stamps folder is re-scanned every time FlexiPDF starts. 

 

Text highlights 

Use the Text highlight tool  to add a coloured, semi-transparent highlight around selected text. Like other 

annotations, the highlight has an associated pop-up note window. 

1. Select the Text tool  from the toolbar. 

2. Select the text you wish to highlight. 

3. Click  in the Formatting toolbar to highlight the selected text  

or press Ctrl+G. 

4. To open the associated pop-up note window, activate either the Text tool  or Hand tool  and double-

click the text. 

Notes 

• Text highlights are annotations that sit on top of the PDF page like other annotations. They do not track the text 
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to which they apply which means that if you edit the text on the page after highlighting, the text may move with 

respect to the highlight. 

• A similar result can be achieved using the underline facility – this will track edited text but does not have an 

associated pop-up note window. See Underline & Strike-through. 



FlexiPDF 2019 

122 / 154 

13. Bates numbering 

See Bates Numbering 
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14. Signatures 

If you have scanned a copy of your signature, it can be quickly stamped onto a document – avoiding the need to 

print the document and sign it. 

In fact, you can define any number of different signatures for this purpose, “his and hers” for example. 

A signature definition can be constructed from an image or PDF file or from the contents of the current selection. 

 

Create a signature 

1. To define a new signature, choose Edit > Signature > Define. 

2. Choose an image file to use as your signature. This can be any JPEG, PNG, Tiff or BMP image. FlexiPDF will 

make a copy of this file and use it in future. 

3. Then enter a name for this signature. This is the name that will appear in the Signature menu. 

4. Your signature will now be available for use in the Edit > Signature > Insert submenu. 

 

Add a signature 

1. To insert a signature in a PDF, choose Edit > Signature > Insert > Your signature name 

2. FlexiPDF places the image so that its white background remains transparent. 

3. After initial placement, the signature image will need to be resized. 

While holding down the Shift key, drag one of the resize handles to scale the image, retaining its original aspect 

ratio. 

If you do not hold Shift while scaling, you may stretch the signature out of shape. 

4. The finished size of the signature image is recorded so that next time the signature is used, you should not need 

to resize it. 

Notes 

• Signatures placed in this way are not annotations in the same way as sticky notes etc. They do not have 

associated pop-up note windows, do not appear in the Comments panel and are always included during 

printing. They form part of the page unlike annotations which float in a layer above the page. 

 

Delete a signature 

To delete a signature from a PDF document: 

1. Select the Object tool  on the Edit toolbar. 

2. Click on the signature to be deleted. 

3. Press Backspace or Delete on the keyboard. Alternatively, right-click on the signature and choose Delete 

Selection. 

Notes 

• The process described above only removes the signature object itself. Choose Edit > Signature > Delete to 

delete signatures from the signatures menu. This does not delete any files from your computer. 
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15. Hyperlinks 

Use hyperlink annotations to create interactive boxes which, when activated by the user, will jump to another part of 

the same PDF, a different PDF or internet URL. 

• To activate a hyperlink, click on it with the Hand tool . 

• After clicking on a page-to-page hyperlink, use the history button  on the Navigation toolbar (View > 

Toolbars > Navigation) to go back to the previous view – just like the "Back" button in a web browser. 

• To find out where hyperlinks exist on the page, choose the Link tool  on the Edit toolbar, and all 

hyperlinks on the page will be outlined. 

Notes 

• Hyperlinks are annotations that float above the page in their own layer. They do not track page contents which 

means that if you edit the text or move the objects on the page the position of the hyperlink may then be 

incorrect and require adjustment. 

 

Internet URLs 

1. Click the Link tool  on the Edit toolbar. 

2. Drag out a box around the area you wish to become a hyperlink. You can resize this box after its initial creation, 

so you don't need to get it right first time. 

3. After drawing the hyperlink box, the Link Properties dialog box is displayed. 

 

 
 

4. Change the Link Type to World Wide Web Link. 

5. Enter the destination URL in the URL edit field. 

For a web page, use the http:// prefix, for a mailto link, use mailto: etc. 
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Page-to-page 

A page-to-page hyperlink takes the viewer to a different part of the document with (optionally) a different zoom 

factor. 

1. Click the Link tool  on the Edit toolbar. 

2. Drag out a box around the area you wish to become a hyperlink. You can resize this box after its initial creation, 

so you don't need to get it right first time. 

3. After drawing the hyperlink box, the Link Properties dialog box is displayed. 

 

 
 

4. Change the Link Type to Go To View. 

5. Check Link is always visible if you want the link to show as a outlined rectangle at all times.  

6. Move the dialog box out of the way (but don't close it), so that you can once again see the document. 

7. Navigate to the destination location within the document by scrolling, zooming and changing pages. 

8. Once at your chosen location, choose the appropriate Zoom. 

9. Press OK.  

 

File-to-file 

1. Click the Link tool  on the Edit toolbar. 

2. Drag out a box around the area you wish to become a hyperlink. You can resize this box after its initial creation, 

so you don't need to get it right first time. 

3. After drawing the hyperlink box, the Link Properties dialog box is displayed. 

4. Change the Link Type to Open File. 

5. Enter the file name in the File edit box or press the Browse button. 

6. Choose if you want way you want the file to be opened with the Open In pop-up. This preference is not used by 

FlexiPDF but may be by other PDF viewers. 
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16. Bookmarks 

Bookmarks allow readers to quickly navigate to specific places in a PDF and are especially helpful in long PDFs. 

Using FlexiPDF, you can automatically add bookmarks to a PDF as well as modify and delete existing bookmarks. 

On-screen display 
To see a PDF’s bookmarks, choose View > Bookmarks or press the F9 key. 

 

 
 

Double-click on a bookmark to go to the relevant page in the PDF. 

Notes 

• Drag a bookmark on the title of another to nest the bookmark within the other. 

• Drag a bookmark on the icon of another to move without nesting within the other. 

 

Create bookmarks manually 

A bookmark records the page number, location and zoom setting used to view the page at the time the bookmark 

was created. 

1. Choose View > Bookmarks to ensure that the bookmark catalogue is visible. 

2. Navigate through your PDF to the page you want to bookmark, zooming and scrolling to the exact position you 

want to record. 

3. Press New bookmark  on the Bookmark panel’s toolbar to create a new bookmark. 

4. The new bookmark will be created and named New Bookmark. 

5. Click on the new bookmark. After a short pause, you can enter a new title for the bookmark. 

 

Create bookmarks automatically 

FlexiPDF can create bookmarks automatically. This is especially useful for long PDFs that have no bookmarks. 
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You can also limit the process so that only text written using specific fonts is eligible for inclusion in the resulting 

bookmark tree. 

1. Choose View > Bookmarks to make the bookmark catalogue visible. 

2. Navigate to the page from where you wish bookmark creation to begin. 

For example, if you wanted to omit the document’s table of contents from the bookmarks, go to the first page 

after it. 

3. Press Automatic Bookmarks  on the Bookmark panel’s toolbar. 

4. If the PDF already has bookmarks, FlexiPDF will prompt you to proceed. If you do, all existing bookmarks will 

be removed before the new ones are added. Press Yes to begin bookmark creation. 

5. You can cancel the process at any time by pressing Stop, though this may leave the document’s bookmark 

catalogue in an incomplete state. 

6. If you find unwanted items get added to the bookmarks tree, you may be able to filter these out by adding some 

font filters. 
 

Font filters 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

To avoid adding unwanted items to the bookmark tree during automatic bookmark creation, you can instruct 

FlexiPDF to consider only text written in specific fonts. 

1. Select the Text tool  from the toolbar. 

2. Select some text of the kind you wish to include in the bookmark tree. 

3. Press the Font filters button  on the Bookmark panel’s toolbar. 

4. The Bookmark Font Filters dialog shows a list of all the fonts that FlexiPDF will consider during automatic 

bookmark creation. 

5. The font of the selected text is shown at the top of the dialog.  

 

 
 

6. Press Add To Filters to add this font to the list of active filters.  

Any font not mentioned in the list will be ignored during automatic bookmark creation. 

7. Repeat steps 2 to 6 for all the fonts you want to be eligible for automatic bookmark creation. 

8. To delete a font from the list, select it and press Delete. 

9. Re-create the bookmarks tree with your new filters in place. 

Notes 

• The list of font filters is not stored by FlexiPDF and will need to be re-created if you close the document. 
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Rename a bookmark 

1. Click on an existing bookmark to select it. 

2. After a short delay, click again to start renaming. The name of the bookmark will become selected, ready for 

editing. 

 

Delete a bookmark 

1. Click to select the bookmark item to be deleted. 

2. Press the Delete or Backspace key on your keyboard or  on the Bookmarks toolbar. 

Notes 

• If you delete a bookmark item that has sub-items, the sub-items will also be deleted. 

 

Rearrange bookmarks 

To move a bookmark title to a different place in the bookmark tree: 

• Click and drag a bookmark to a new position in the bookmark tree.  

• Drop a bookmark on the icon  of another to place it after that bookmark. 

• Drop a bookmark on the label of another to place it within (as a child of) that bookmark. 

 

Search in bookmarks 

See Find & Replace in Bookmarks 
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17. Article threads 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

Articles threads are invisible, linked boxes used to aid the reader in following the flow of a story through a PDF. 

When a viewing application such as Adobe Reader detects an article thread, it is able to present the text boxes in 

turn for easier reading of the complete article. 

Some applications can use articles to reflow the PDF or convert and export stories into other formats such as HTML. 

 

Create an article thread 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

1. Open the page containing the start of the story you wish to annotate 

2. Select the Article tool  from the toolbar. 

3. Carefully drag out a box around the first column of text in the article.  

Article boxes can be moved and resized after drawing as long as the Article tool remains selected. 

4. Continue dragging out boxes around subsequent columns, changing pages as needed to follow the story’s flow. 

5. When the last box has been drawn, press Escape on your keyboard to finish. 

6. Click on one of the new article boxes and choose Edit > Article Thread > Properties to display the Article 

Properties dialog box. You can also display this dialog by double-clicking on an article box. 

 

 
 

7. The information you supply here is used by some PDF viewers to present an article catalogue to users, so they 

may choose an article to read.  

FlexiPDF makes use of Title during export of article threads into other formats such as HTML. 

8. Press Duplicate to copy the article box just created across other pages. This is handy for documents with a 

predicable layout, having text in the same place across a contiguous range of pages. 

 

Extend an article thread 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can add or insert a new article box in an existing chain of boxes. 

1. Open the page containing the article box you want to link to 
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2. Select the Article tool  from the toolbar. 

3. Click on the article box you want to link to – we will call this box A. 

4. Click on the + symbol in the bottom right hand corner of box A. 

5. Drag out your new article box. It will be added to the chain between box A and whatever it used to link to. 

 

Delete an article thread 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can delete an article box, a range of boxes or an entire article thread. The text in the PDF itself is unaffected. 

1. Select the Article tool  from the toolbar. 

2. Select the article box to be deleted. 

3. Choose Edit > Article Thread > Delete or press the Delete key on your keyboard. 

 

 
 

4. If there are multiple boxes in your article thread, the Delete Article dialog box gives you the option of deleting 

the entire article thread, the currently selected article bead (in this case bead 1), all beads in a range of IDs or all 

beads across a range of pages. 

 

Properties of article threads 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

1. Select the Article tool  from the toolbar. 

2. Double-click on a bead (article box) belonging to the article thread whose properties you wish to alter. 

 

Export an article thread 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

You can convert the text in an article thread to other formats such as HTML. This approach has the advantage that 

only the text in a particular article gets exported. Also text split across article beads (text boxes) will be reflowed 

better since FlexiPDF knows that the boxes contain related paragraphs.  

1. Create articles for the story you wish to export. 

2. Supply a meaningful title for each article using the Article Properties dialog box. These titles will be used as 

headings during the export. 

3. Choose File > Export > Articles As. 
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4. The dialog gives you option of exporting all articles, or just those which start on the current page. 

5. Press Format to change the output format for the text. 
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18. Interactive forms 

FlexiPDF not only enables you to fill-in interactive forms embedded in PDFs, but also lets you create new forms 

with buttons, checkboxes and other form elements (only FlexiPDF Professional, FlexiPDF NX Universal). These 

can be filled in using FlexiPDF or any other PDF viewer and the data held within them exported to XML format for 

further processing. 

 

 
 

To fill in an existing form, switch to the Hand tool , then click on the fields in the form. 

You can show all the form fields in blue to make them easier to see. To do so choose View > Interactive Form 

Fields. If the option is unavailable, it indicates there are no form elements on the page. 

Making your own forms (Available in FlexiPDF Professional, FlexiPDF NX 
Universal, FlexiPDF NX Universal) 

• Forms toolbar 

• Adding form fields 

• List and Combo field properties 

 

Forms toolbar 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

In order to create or edit interactive forms, choose View > Toolbars > Form Editing. 
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Available form field widgets 

•  Text field  

Used for entering one or more lines of text. The text can be a password, in which case its contents are obscured 

as they are entered. 

•  Button field 

A button with any label. The button can perform various different actions, including sending the forms answers 

to a web site or resetting certain other form fields. 

 

If the form data is transferred to a website, the HTTP POST method is used. Parameter pairs are generated from 

the form objects. The key of a parameter is always the name of the respective form object, the value of a 

parameter corresponds to the current content of the form object. If, for example, the word "softmaker" is entered 

in a text field with the name "company", the corresponding parameter "company=softmaker" is generated 

during transmission. 

•  Checkbox 

Checkboxes are appropriate for yes/no entries. If the user clicks on a checkbox, a check mark is displayed in it. 

If he clicks on it again, the check mark is removed. 

•  Combo-box 

Presents a list of choices. You can also allow the user to enter their own choice if not shown in the list. 

•  Choice (radio) button 

Allows the user to press one button from a number of button choices. Radio buttons are automatically grouped – 

only one button may be active in any group. To change the group of a radio-button, double-click the button and 

select a different group in the General tab. 

•  List box 

Like a combo box, but doesn't allow the user to enter their own choice. 

Additional toolbar buttons 

•  Export form data 

Writes the answers and button states in the form to file as either XML or FDF format data. These format can be 

read by third-party programs that need to make use of the form data. 

•  Input form data 

Reads answers and button states from a standard FDF format data file. 

 

 

Add form fields 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

In order to work with forms, choose View > Toolbars > Form Editing. 

Adding a field 
To add a new form field, select a field type from the toolbar (see Forms toolbar) then drag-out the shape of the new 

field. 

Moving & resizing fields 
To move or re-shape a form field, first press any of the form toolbar buttons then click on the field to select it. Use 

the handles in the corners of the field to resize it or drag it with the mouse pointer to move it to another position. 

Field labels 

To add a label to a field, use the Text tool  from the main editing toolbar (not the forms toolbar) and drag-out a 

new text box. 
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Field options 
To configure a form-field, ensure one of the field-type tools is active in the forms toolbar then double-click on the 

form field. Alternatively hover over a field with either the Hand tool , Object tool  or any field-type tool 

selected, right-click and choose Properties 

Tip 
To help get consistent sizing and layout of form elements, use the "snap-to-grid" feature.  

Choose View > Grids & Guides > Snap to Grid and View > Grids & Guides > Show Grid.  

Grids only appear in FlexiPDF and will not be visible in other PDF viewers. 

 

List and combo field properties 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

Most field item property pages are easy to understand, but the list and combo options are a little more complicated.  

Adding items to list/combo boxes 
Open the field properties dialog (see Field options) and switch to the Options tab. 

Enter the item's label in the Label text box. This will be displayed to the user as part of the field's drop-down list.  

Enter any text or number in the Export value text box. This does not get displayed, but is stored inside the form to 

represent the value chosen if the user picks this item. 

Press Add, and the item label will be added to the Items list below. 

Setting a default item 
Click on an item in the Items list and press Set.  

Moving items within the list 
To change the order of items in the list, select a label in the Items list, then press Up or Down to move it by one 

position. If you just want the entire list to appear sorted alphabetically, put a tick in the Sort items check box. The 

list will then be sorted when it pops up in front of a user. 
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19. Convert to other formats 

FlexiPDF can convert an entire PDF or range of pages to other formats such as HTML and ePub. It can also export 

XML as part of the local translation process. 

 

Export pages 

You can export by page range or by article thread. 

1. Open the document you intend to export. 

2. Choose File > Export > Pages As to reveal the Export Pages dialog box. 

 

 
 

3. Specify the range of pages you wish to export. 

4. At the bottom of the dialog there is a summary of the current export options. 

5. Press the Format button to change the format of the export or to choose whether to export text only, images 

only or both. 

Notes 

• FlexiPDF analyses the pages to be exported and ranks fonts by size to work out what should correspond to the 

various levels of heading (H1, H2, etc.) available in the output format. For the export formats that rely on this 

ranking, the results can differ if you export a subset of pages to when you export the entire document. 

• Use the Crop tool prior to export to exclude parts of the page (for example to stop headers & footers being 

exported). 

 

Export images 

FlexiPDF can export images stored in a PDF into various popular image formats. 

1. Select the Object tool  from the toolbar. 

2. Click on the image to be exported. 

3. Choose Object > Image > Extract to file. 

4. Choose the output format for the new image from the Save as type pop-up menu: 

o PNG – best for graphics and diagrams with clean lines 

o JPEG – best for photographs 

o TIFF – best for retaining complex colour spaces 

5. Images are exported at the resolution they are stored within the PDF. This may result in a larger image than you 
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expect, since images rendered on a PDF page are subject to scaling. 

Note 

• To export a portion of a page as an image, use the Snapshot tool . 

• To export all images across a range of pages, see Exporting pages. 

 

Export graphics 

When it comes to exporting pages with graphics made from line-drawings, FlexiPDF needs to be told which parts of 

the page form the illustration. That is because there is no universal means of determining which parts of a page are 

an illustration and which parts are just normal page contents. For example, is the rectangle in the header on this page 

an illustration to be exported or just page furniture? 

How to tell graphics from photographs 
1. Choose View > Outlines. 

All images will be replaced by rectangles and graphics will be shown in outline only. It should then be more 

obvious what was an image and what was vector-based artwork. 

2. Choose View > Outlines again to switch back to normal (preview) mode. 

3. You can quickly switch between the two views by double-clicking on the Preview label in the status bar. 

 

 
 

Double-click the circled area of the status bar to toggle between outline and preview mode. 
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Marking up an image for inclusion in exports 

1. Click the Link tool  on the Edit toolbar. 

2. Carefully drag out a box around the area to be exported. 

Everything included within the rectangle you make will be rendered by FlexiPDF and included in the export. 

3. After marking out the image, the Link Properties dialog box will appear. 

 

 
 

4. Change the Type pop-up to Image Box. 

5. Enter a title for the image in the Label box. This is used during export to HTML-based formats. 

6. You can now choose to repeat this markup across a range of pages. This is useful if your document contains a 

similar image, repeated across several pages. 

7. Press OK. 

8. The area is displayed by FlexiPDF together with its label. 
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Example of an illustration marked-up and named with an image box. 

9. When you next export the document or page, the illustration will be converted to an image and output along 

with the rest of the page. 

 

Export options 

Control the way a PDF is exported using the four tabs available in the Export Format dialog. This is available by 

pressing the Format button in the File > Export > Pages dialog.  
 

General 

Press the Format button in the File > Export > Pages dialog to get to the general export options: 

 

 
 

Click on the General tab. 

 



FlexiPDF 2019 

139 / 154 

 
 

Use this panel to select the main text and image output options to be used when exporting a PDF. 
 

Text output 

Check this item to export the text content of your PDF. Either Text Output or Image Output (or both) must always 

be enabled. 

• Format pop-up menu 

FlexiPDF supports a varied range of text output formats, including a set of HTML-based formats, plain text and 

RTF for use with Microsoft Word and other applications. 

FlexiPDF can also export table data in SYLK format but only when clicking on a table that has been marked up 

with a Table Box annotation (see Exporting in isolation). 

o Plain Text 

ASCII text, readable with any text editor or word processor. When layout is retained using this format, 

spaces are inserted to ensure words and paragraphs are placed into the right location. 

o RTF 

Microsoft’s Rich Text Format, readable by virtually every word processor. An ideal input format for 

Microsoft Office. FlexiPDF can embed all document images in a single RTF file. 

When exporting to RTF with Retain Layout, you may encounter difficulties if your original 

document’s page size is larger then 55cm (width or height). Some versions of Microsoft Word cannot 

deal with such large page sizes. 

o Simple HTML 

HTML using only a few simple tags. This is readable by all web browsers, but some formatting may 

not be preserved. Images are linked from the document rather than shown inline. 

A list of document bookmarks will be output at the top of the first page. If Create file for every 

page/article is active, a cover page, a bookmarks page and individual contents pages will be produced, 

each hyperlinked together. 

When Try to preserve layout is active, this format inserts spaces making use of the <PRE> tag in 

HTML to force the browser to honour every space character. 

o HTML 3.2 

More complex HTML allowing for a wider range of styling. Inline images are used. Meta tags are 

added to the document using the creator, author and title information stored in the PDF. Different 

character sizes are rendered using the tags <H1>, <H2>, etc. 

If Create file for every page/article is active, a bookmarks page (if bookmark output is enabled) and 

several data pages will be output. When frames are enabled, the index page uses frames to show the 
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bookmarks on the left while viewing each page on the right. 

When Try to preserve layout is active, this format uses a complex HTML table for each page. Font 

sizes in layout mode are selected using the FONT SIZE+/- technique rather than <H1>, <H2>, etc. 

since this gives better results. 

o HTML 4 

Like HTML 3, but CSS (Cascading Style Sheet) tags are used to render fonts and sizes. This is 

compatible with most modern web browsers. 

If Create file for every page/article is active, a separate file is output containing all of the CSS style 

elements used by the rest of the output pages. Edit this style sheet file to quickly alter the look of the 

rest of the document. 

When Try to preserve layout is active, this format uses a complex HTML table in the same way as 

HTML 3.2. However, fonts and sizes still use CSS1 markup for better results. 

o HTML 4 CSS 

Using HTML with Cascading Style Sheets (v2) provides the most accurate depiction of PDF content 

for the web. When preserving layout, all fonts and positioning are closely replicated. 

When Try to preserve layout is active, a separate CSS file is produced which describes the styles of 

all fonts used. Edit this CSS style sheet if any adjustments need to be made to the look of the converted 

document. 

o ePub (only FlexiPDF Standard, Professional, NX Home, NX Universal) 

Exports a single .epub file with no digital rights management, with or without images using basic 

formatting. 

o ePub CSS (only FlexiPDF Standard, Professional, NX Home, NX Universal) 

Similar to ePub except that the formatting is specified in a separate .css file held inside the ePub 

package. 

• Right-to-left reading order 

When enabled, FlexiPDF assumes the contents of the PDF are to be read right-to-left (as is the case in Hebrew). 

It attempts to replicate this reading order in the output produced. 
 

Image output 

Check this item to export the image content of your PDF including those marked with Image Box annotations. 

Either Text Output or Image Output (or both) must always be enabled. 

• Format pop-up menu 

FlexiPDF supports a range of image formats: JPEG, TIFF, BMP and PNG. Each of these formats has different 

properties and is suitable for a different purpose. 

o PNG – best for graphics and diagrams with clean lines 

o JPEG – best for photographs 

o TIFF – supports CMYK which may give improved colour fidelity when converting magazine and 

newspaper pictures. 

o TIFF (multi-page) – will place all images within the same file. You will need a TIFF viewer capable of 

handling multi-image files in order to view these correctly. 

• Convert each page into an image 

Check this option to render the contents of each page. When checked, text output is disabled since the entire 

contents of each page will be contained in the image file(s) produced. 

• Place images in sub-folders 

This option causes images files to be stored in a sub folder named images. This also affects the path used in 

the IMG tag for HTML output. 

 

Text 

Press the Format button when exporting PDF content and switch to the Text tab. 

Use the settings on this panel to control the way text is output in all formats. Additional settings which affect only 

HTML output are grouped separately in the HTML settings panel. 

The options in the this tab are placed into two sub-groups named Text Flow and Text Appearance. This is simply 

to make the panel a little easier to read. 
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Text Flow 

• Identify image captions 

Selecting this option will cause FlexiPDF to identify image captions and output them along with images, rather 

than in the main body of text. If image output is selected and the image format supports it (TIFF, JPEG, PNG), 

captions will also be embedded within the image data. 

• Try to preserve layout 

In all text formats except ePub, this option causes FlexiPDF to position words as closely as possible to the 

original page layout. The way in which the positioning is achieved depends upon the output format used. 

o Plain text with the layout retained should be viewed without line wrapping in a mono-spaced font 

(such as Courier). Simple HTML will be formatted as with plain text using letter spacing to position 

page elements. 

o HTML 3 and 4 use tables to position page elements. HTML 4 CSS uses the absolute positioning 

functionality available with CSS2. 

With all output formats there may be some deviation from the original document layout requiring a degree of 

manual adjustment. 

• Render text in vector artwork 

When enabled, text will be included in rendered artwork, but not in the normal text output stream. When not 

selected, the converse is true. That is, text will not appear in rendered artwork but will appear in the text output 

stream. 

If you find that some text you expected to see in your output is missing, check to see if this options is enabled. 

• Recognize Speech Marks 

When Preserve Line Break is off, FlexiPDF attempts to reflow text into paragraphs. The process is fairly 

reliable but may occasionally make mistakes.  

However, when it comes to reported speech of the kind that may be found in a conversation in a novel, it is vital 

that the correct line breaks are retained; in speech, the line break is the reader’s main indication of a change in 

speaker. 

When this option is on, FlexiPDF pays particular attention to quotation marks, especially those at the beginning 

of a line or paragraph. The result is that it is much more successful in retaining these important line breaks. 

When processing documents unlikely to contain any reported speech, it is best to disable this option. 

• Preserve line breaks 

Selecting this option will ensure that FlexiPDF honours all line breaks in the original document. Furthermore, it 

will stop FlexiPDF from removing hyphenation. 

Enabling this option can make editing the output more difficult since lines of text will not reflow after insertions 

or deletions. However, it may improve the appearance if layout is important. 

• De-hyphenate Words 

When enabled, FlexiPDF will rejoin words split by a hyphen at the end of a line. Words with hard hyphens such 

as “442-squadron” are not altered. 

To help in making the decision to leave or remove hyphens, FlexiPDF consults the language dictionary 

currently selected for spell checking (see “Spelling preferences”). However, should a particular word be 

unknown in the dictionary or be in a different language, it is possible the software may take a wrong decision. 

When disabled, FlexiPDF does not remove any hyphens, and words will remain split as they are in the original 

document. 

When Try to preserve layout or Preserve Line Breaks is enabled, word de-hyphenation is automatically 

disabled. 

Text Appearance 

• Create file for every page / article 

Causes FlexiPDF to output each page to a separate file. When outputting to HTML output files will be 

hyperlinked together. It is not applicable to ePub output which always produces a single file. 

When outputting article threads, FlexiPDF will place each article in a separate file. 

• Hyperlinks 

If FlexiPDF detects any embedded hypertext links within a PDF, it will try to retain these in the output. This is 

not possible for plain-text output. 

• Bookmarks 

When enabled, FlexiPDF will retain a document’s bookmarks as hypertext destinations in all but plain text 

output modes. 
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When disabled, no bookmarks will be output. 

• Page Breaks 

When enabled, FlexiPDF will output the given text at the end of each page produced. For HTML for example, 

<HR> may be used as a simple page break. 

 

Image 

Press the Format button when exporting PDF content and switch to the Image tab. 

When image output is enabled in the General format tab, FlexiPDF produces copies of all images stored in the PDF. 

The options in this tab are mainly concerned with the scaling or size of the images output. 

FlexiPDF can deal with two types of image in PDF: vector illustrations consisting of lines, curves, filled areas and 

bitmap images or photographs made up of many coloured pixels. 

FlexiPDF cannot output vector formats directly but will instead convert any such illustrations into a bitmap format 

by a process called rasterization. 

• Auto-identify vector artwork 

Many PDF documents may contain vector artwork or line art. However, due to the nature of PDF, it is not 

always possible for a computer program to determine where on a page such artwork occurs since each page is 

stored as a general mix of text, images and line art. 

FlexiPDF is capable, to an extent, of identifying such artwork on a page. Selecting this option will cause 

FlexiPDF to automatically convert vector artwork in the original into images in the output format selected. 

If you are unsure if an graphic is an image or vector artwork, see Exporting graphics. 

If you encounter problems with illustrations not being correctly identified, use the Link tool to mark them up 

with Image Box links. See Exporting images. 

FlexiPDF can only output images in bitmap formats, not vector graphics formats. If images do not appear in 

your final output documents, try turning this option on or placing an image box around the missing images. 

• Use original OPI name if available 

If your PDF contains OPI placement information for the images within it, FlexiPDF will use the original 

filename for images it exports. 

You can check if an image has associated OPI information by selecting the image with the Object tool, then 

clicking the right mouse button and choosing Image Properties. 

Image Scaling 
This set of options allows you to set the output scaling of the images that FlexiPDF extracts from a PDF. 

When disabled, images are output as they are found in the PDF. This may give very large images since many PDF 

documents contain high-resolution versions of an image which are then scaled by the PDF viewer to the correct size. 

• Fix image resolution at 

This option scales output images so that they are all at the same resolution in dpi (dots per inch). Resolutions 

available are: 72, 100, 150, 300, 400, 600, 720, 800 and 1200 dpi. 

This setting is particularly important when rendering vector artwork. 

• Advanced Scaling pop-up 

Three types of advanced scaling can be selected from the drop down menu. For each kind of scaling, if either 

width or height is set to zero, then an image’s aspect ratio is maintained. 

o Set image size 

Enables exact image sizes to be specified in pixels. Images will be sub-sampled or expanded 

accordingly. 

o Maximum size 

Enables a maximum image size to be specified. If an image is smaller than the width and height values 

given, then the scaling is unchanged. When Max scaling occurs, the aspect ratio is maintained. So, for 

example an image which is 800 by 400 when output at a Max of 200 by 200 will be rendered as 200 by 

100 – the shape of the image is maintained. 

o Scale 

Will resize images according to a percentage value. 

• Colour depth to use when rendering 

This pop-up tells FlexiPDF how to render any marked up regions during export. It also controls how pages are 

rendered if the Convert each page into an image option is enabled in the General tab. It has no affect on the 

export of non-rendered images such as photos – these are, in most cases, output with the colour depth at which 
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they are stored in the PDF. 

You can determine the colour depth of images stored in a PDF by clicking on an image using the Object tool 

, then choosing Object > Image > Properties. 
 

HTML 

Press the Format button when exporting PDF content and switch to the HTML tab. 

This tab contains options for tailoring the way FlexiPDF produces HTML output. 

Background 
This group of options allows a background colour or image to be specified for each page output in HTML. 

• Colour 

Whatever is entered in the Colour: box is included in the <COLOR> attribute of the <BODY> tag of each page 

output. Colour could be a word such as yellow or a colour definition such as #FFFFFF. 

• Image: 

Used to enter a file name of a image. This name is placed into the BACKGROUND attribute of the <BODY> tag 

for each page. Be careful about the name entered here, since it will be included exactly as typed. 

The image name need not refer to an actual image on your hard disc but may for example, refer to an image 

which is or will be stored on the computer used to host the web pages once they are complete. 

Header and footer files 
The header and footer file boxes are used to specify files on disc whose contents will be merged into each page of 

HTML output by FlexiPDF. For example, you may wish to add your company’s own corporate graphics to the top 

and bottom of each page output. 

The contents of the header file will be output just after the <BODY> tag of a page but before any extracted text or 

images. Similarly, the contents of the footer file are output just before the closing </BODY> tag of each page. 

You cannot type into the text boxes directly, so instead use the browse buttons  to select existing files. 

Page / Article Navigation 
When FlexiPDF is processing in File-per-Page mode as set in the Text settings tab, each page of a document is 

stored in a new file and navigation links to the previous, first and next pages are placed on each page for 

convenience. 

The controls in this group allow the appearance of these navigation links to be changed. Whatever is entered into 

either of the Previous, First or Next boxes will be output instead of the words Previous, First and Next. 

This facility may be useful when converting documents for a non-English speaking audience or if navigation images 

are required rather than text. 

Miscellaneous 

• Image Border 

When enabled, images will have a border around them generated using the border attribute of the HTML 

<IMG> tag 

• Frames 

This setting only takes effect when bookmark output is enabled in the Text tab. 

When enabled, FlexiPDF creates a two-frame frameset definition which places the bookmarks frame on the left 

hand side of the screen and the extracted content on the right hand side. Clicking on a bookmark changes the 

page in the right hand side. 

 

Export tables 

Due to the way PDF works, FlexiPDF can't tell what's a table and what's normal text without help. 

You help it by drawing a special box around areas that it should treat as tabular. 
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To export a table 

1. Draw a box around the table (called "marking-up" the table). 

2. Export the table as part of a page. 

3. Export the table on its own. 
 

Marking-up 

To obtain the best results when exporting tabular information, FlexiPDF needs to be told which areas to treat as 

tables. Without this information, table are treated as normal paragraphs and columns resulting in poor output. 

Marking up a table 
1. Navigate to the table to be marked up. 

2. Click the Link tool  on the Edit toolbar. 

3. Carefully drag out a box around the table. Exclude any non-essential text (such as captions) that could confuse 

the analysis process. 

After marking out the table, the Link Properties dialog box will appear. 

4. Change the Link Type to Table Box. 

5. Enter a title for the table in the Label edit field. This may be included in the output, depending upon the format 

you choose. 

6. Change the Pages option to repeat this mark-up across a range of pages. This is useful if your document 

contains similar tables in the same location across several pages. 

7. FlexiPDF will look at the appearance of the tabular area, including any borders used to delineate rows and 

columns. In some cases, it may be best to ignore these lines and analyse only the non-graphical content in order 

to discern the structure of the table. In this case, check Ignore borders. 

8. Press OK. 

FlexiPDF will then display the table link box together with its label (if there is room). 

When you next export the document, this markup-up area will be treated as a table which should improve the output. 

The blue table boxes are only visible in FlexiPDF when the Hyperlink tool is selected. 
 

Export with pages 

Tables that have been marked-up will be specially treated to try to preserve their layout in whatever output format 

you choose to export the document. 
 

Export in isolation 

To export a table, it must first have been marked-up as a table. Once a table has been marked-up, it can be exported 

immediately and in isolation - without exporting the rest of the page or document. 

1. Select the Hand tool  from the Edit toolbar. 

2. Click on the table to be exported.  

3. Choose a name for the file into which the table will be exported. 

4. Choose the format for the export from the Save as type pop-up menu. 

 

Exclude unwanted objects 

To exclude parts of a page from exporting then you can use the Crop tool  to temporarily crop a range of pages 

in your document. Anything outside of the crop box will be ignored during the export. 

1. Use the Crop tool  to drag out a box. 

2. Once the export has been done, the crop can be removed by choosing: Document > Pages > Remove Crop. 
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20. Translate PDFs 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can export the content within a PDF to a format suitable for translation using popular translation tools 

such as SDL Trados Studio, MemSource and MemoQ. 

After translation, the text can be re-imported back into the PDF. FlexiPDF places the translated text exactly where 

the original text used to be. 

 

Export 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

FlexiPDF can export the text of a document, automatically tagging each paragraph with its original location. You 

can export a range of pages, individual stories or specific marked text boxes (see Mark text for translation). 

This text can then be translated using any other software (e.g. Trados, Across TM, Déjà Vu, Google) and re-

imported back into the document by FlexiPDF. As FlexiPDF imports the translated text, it uses tags embedded in the 

PDF during export to determine both the correct location and basic text styles of text being imported. 

If translated text is too long to fit into the original text boxes, FlexiPDF can subtly adjust its spacing to make it fit. 

It is very important to ensure the current spell-check language matches that of the text being exported. If it does not, 

soft-hyphens will not be correctly removed during export. 

1. Open the PDF you want to translate, choose Translate > Export. 

2. Choose the extent of the text you want to include in the export. You may prefer to work on a few pages or a 

single story at a time rather than the entire document. 

3. Check Limit to marked content only to export only those text boxes which you have already marked for 

export. See Mark text blocks for translation. 

4. Select Current story to export only the active text box and any box linked to it as a single story. Current 

Story is only available if you were editing text when you chose to begin the export. 

Use the Link text tool  to link text blocks together to form stories, prior to beginning the export. 

5. Choose the format of the exported text. 

Simple XML is recommended since can encapsulate more text style information and can be used within most 

popular CAT tool. 

6. Once exported, FlexiPDF will remind you to save the document. This is crucial since the export process will 

have added tags not only to the text output but to the PDF itself. 

You cannot import the translated text back into the PDF unless this tagging information exists. 

Saving a copy of the tagged PDF now ensures that you will be able to import the translated text back into it in 

future. 

7. After exporting, the eported paragraphs are highlighted. This will only be visible in FlexiPDF and does not 

affect the PDF. 

You can hide this highlighting by choosing View > Text > Field Shading. 

 

Mark text for translation 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

Rather than exporting whole pages or stories, you can limit the export to only those text boxes that have been 

marked for export. This maybe useful in a catalogue for example where product names can be left out of the export 

to ensure they do not get modified during translation. 

Marking up for export has been designed to offer a very rapid workflow for the translator who does not want all of a 

document to be translated. 

All of the following operations require that marking mode is active. 
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Marking whole text boxes for export 
1. Switch into marking mode, by choosing Translate > Mark Text Boxes For Export. 

On switching into this mode, the boundaries of text boxes will become visible and the Object tool  will be 

selected, though you are free to switch between the other tools. 

2. To avoid accidental changes to the document during markup, you cannot change the position or size of objects 

when in this mode. 

3. Click on a text block to mark it for export. Click again to unmark it. 

Drag out a selection to mark a number of boxes at once. Mark text boxes across any number of pages. 

Partially marking text boxes 
When you want to export only part of a text box, you can rapidly split the text box, marking one part and leaving the 

remainder unmarked. 

There are two ways to do this while in markup-up mode: 

Method 1: Splitting by rectangle 

Use this method when you want to grab and mark all the text in a rectangular area. 

1. With the Object tool  active, Ctrl+Shift drag around the text to be marked. 

When you release the mouse button, FlexiPDF will rebuild the text boxes covered by the drag and then mark 

the resulting box for export. 

2. When you are ready to export for translation, be sure to check Limit to marked content only in the CAT 

Export dialog box. 

Method 2: Splitting by text selection 

Use this method when the content to be marked cannot be isolated by a rectangle but needs an exact character 

selection. 

1. Using the Object tool , Ctrl+drag the text you want to markup. 

Only the selected text will be marked. 

It will be removed from its original text box and placed into a new box. 

2. When you are ready to export for translation, be sure to check Limit to marked content only in the CAT 

Export dialog box. 

 

To un-mark all text blocks throughout the document, choose Translate > Unmark All Text Boxes. 

Notes 

• If you split text boxes, do not make edits to the resulting unmarked text boxes. The split may leave gaps were 

the marked text was located (as in (2) above). Reflowing will shuffle up the remaining text, eliminating these 

gaps. 

• The order in which you mark boxes, does not effect the export order. 

 

 

Import 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

To complete the translation of a PDF, you need to import the new, translated text back into the document. FlexiPDF 

will place each translated paragraph into the correct location in the document, reflowing, fitting and substituting 

fonts as required. 

1. Open the PDF into which you will import your new text. This should be one saved immediately after your 

initial export. FlexiPDF will have embedded tagging information in that PDF which will now be used to 

relocate the text you are about to import. 

2. Choose Translate > Import to display the import dialog. 

3. Press Browse to choose the text or XML file to be imported. 

4. Make sure the current spell-check language matches the text being imported. If it does not, press Language to 

change the setting. 
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When the spell-check language does not match, words may not be correctly hyphenated during reflow. 

5. Select Automatically fit text where needed to have FlexiPDF adjust the new text so that it fits the original text 

boxes. This may slow down the import considerably since the fitting process is quite complex. Text that it is 

shorter than the original is unaffected by this setting. 

Press Fitting to adjust the fitting behaviour. 

6. Selecting Reset letter spacing will cause FlexiPDF to set all word and letter spacing to zero on imported text. 

Otherwise imported text will use the spacings of the original text. 

It is recommended that this option be selected. 

7. Press Fonts to load, examine and modify these substitutions rules. See Managing Font Substitutions. 

8. Press OK to begin the import. 

 

Font problems 

Available in FlexiPDF Professional, FlexiPDF NX Universal 

If the imported text requires some characters that are missing from the fonts used for the original text, the Font 

Problems dialog box will appear. 

 

 
 

1. The problem font (in this case FrutigerBold) is shown together with a list of required characters. These may be 

missing because the font is a subset or that the font just does not cater for those characters. 

2. Choose to substitute another font or ignore the problem. 

In some case, especially with symbol or decorative fonts, it is best to ignore the problem by pressing Ignore.  

3. If you do not wish to ignore it, choose an alternative font from the Substitute Font drop down list. This list 

includes all fonts in the document plus those loaded from your computer. 

Should the substitute font not contain all the required characters, FlexiPDF will prompt you to choose again. 

It is best to choose a font from your computer’s font library rather than one from the PDF. These are the ones 

listed after the dividing line in the drop-down list. 

4. Each time you Ignore or Change a font, you will be presented with the next font problem. 

5. Once all font issues have been resolved, the second phase of the import starts. 

FlexiPDF scans the new text for changes with respect to the existing content of the PDF. When a modified 

paragraph is found, it is imported. 

 

 

Manage font substitutions 

Available in FlexiPDF Professional, FlexiPDF NX Universal 
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FlexiPDF remembers the font substitutions made during CAT import and uses them for subsequent imports. You 

can view, edit, export and load the complete set of substitutions. 

1. Choose Translate > Font Substitutions or press Fonts in the Import Translation dialog box. 

2. The Font Substitutions dialog displays all the current font substitutions. 

These will apply to any document and not just the last one on which an import was performed. 

3. To change an existing substitution, select it in the list. 

The details of the selected entry are then displayed in the two pop-up menus below the list. 

4. Choose a different Original Font or Replacement Font and then press Change to store the new settings back 

in the list above.  

5. Load and Save enable you to save a permanent copy of the font substitutions to disc for use later. 

The plain text format file can be edited by hand and passed onto others that may need the same set of 

substitutions. 

Is is useful to save the current set after working on a document so that it can be loaded prior to the next time 

you need work with the import function. 

 

Tips 

• Where text flows across columns or pages, use the Linked text tool  to connect the text blocks. 

Once connected, remove any unwanted paragraph breaks at the end of each block (which will have been added 

before the blocks were connected.) 

• Reflowing the text during import is slower when the text is fully justified. 

To avoid this when dealing with long stories (such as a chapter of a novel) change the text justification to Left 

justified prior to import. The import will be faster and the justification can be changed back once it is complete. 

• Using Auto fit on long stories can be slower. Do the auto-fitting after the import has been done by choosing 

Text > Fitting on text boxes that need it. 

• When translating a long document, deal with a section/chapter at a time. 

Since the export process requires a large amount of computer effort and memory, keeping exports to no more 

than 100 pages at a time will improve throughput considerably. 

• Enable View > Text > Boundaries to make it easier to see the shape of text boxes. 

• Ensure the spelling language matches the language used in the PDF – this has a big effect on hyphenation and 

thus reflow. 

• Some text boxes may need merging. E.g. FlexiPDF may split a column of text into separate boxes for headline, 

body, headline, body, etc. In this case, use the Object tool  to drag a box around these boxes, then choose 

Text > Text Box > Merge Vertically to ensure they become one single box. 

• Unless you have already reshaped a text box, FlexiPDF will automatically extend the final text box in a 

sequence to avoid losing text. If you reshape that box, it will remember that new shape and no longer alter it. 

• FlexiPDF sometimes doesn’t correctly guess paragraph alignment. It may for example assume text is left 

aligned when it should be fully-justified. Unless you check by looking at the alignment buttons in the toolbar, 

this will only become apparent after a reflow. Left justification typically uses more space than full justification, 

which means such text may overflow. 

To correct this, just click in the paragraph and press the correct alignment button on the toolbar. 

• The text in a document may be generally squeezed a little to achieve a certain layout. Although FlexiPDF 

attempts to calculate the actually global adjustment used, it may not exactly match and the text may tend to 

overflow. To remedy this, click on one of the text boxes in a linked chain using the Text tool , then choose 

Text > Fitting. 

• Exclude headers and footers: Use the Crop tool  to hide the parts of the page you don't want to translate. 

Export, translate then remove the crop to restore the original page size. 
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21. Preferences 

To modify FlexiPDF’s global preferences, use the File > Preferences menu command. These settings apply to all 

documents. 

 

Editing 

Access this pane from File > Preferences  on the Editing tab. 

• Unit of measurement 

Choose from inches, centimetres, millimetres, points and picas. This setting affects the ruler display and the 

units used in most dialog boxes when a distance or size value is required. 

• Default Editing Tool 

When a document is first opened, FlexiPDF switches to the Text tool by default. You can change this 

behaviour and have it select another tool instead. 

• Show changed text in: 

When enabled (checked) FlexiPDF will highlight edited text in the chosen colour. This highlighting will only be 

visible when the PDF is viewed or printed from FlexiPDF and will not show in any other PDF viewer. 

• Insert smart quotes 

When enabled, FlexiPDF will try to convert plain quotation marks as typed from the keyboard into “curly 

quotes”. This may not be possible if the font used does not contain either the opening or closing curly quotation 

mark. 

• Paste text with formatting 

When pasting text into a PDF from another application FlexiPDF can ignore or take notice of the formatting of 

the text. If this option is checked, FlexiPDF will try to replicate the format (font, colour, size) of the text as it is 

pasted. 

When not checked, text is always pasted using the current selected font, size and colour. 

• User-defined stamps folder 

The location of a folder containing user-defined stamps. By default, this edit box is empty. See Stamps. 

Advanced Settings 

• Detect bold / overprint text 

Some documents simulate bold text by overprinting text rather than using a bold version of a font. Normally 

FlexiPDF identifies overprinted characters on each page and converts those found into single bold characters. 

This check can be disabled to improve speed on complex pages or if FlexiPDF is incorrectly identifying 

overprinted characters. 

• Detect tabs and Leader dots 

Prior to editing, FlexiPDF searches for sequences of dots used as spacers in tabular layouts such as the table of 

contents in a book. These leader-dot sequences are then converted into a leader tab. This means that during 

editing, the leader dots will grow/shrink correctly. 

FlexiPDF also searches for large gaps between words and inserts equivalent tab stops instead, which also makes 

it easier to edit tabular data and bullet lists. 

Occasionally this may adversely affect the layout of a page. It may also cause an initial delay on some more 

complex pages. 

• Detect underlined / strike-through text 

Prior to editing, FlexiPDF searches for all text close to a graphic line of similar length. It then removes the line 

and assumes the text was either underlines or strike-through depending upon the position of the line relative to 

the text. 

Occasionally this may yield undesirable results or cause an initial delay and may be disabled for this reason. 

• Include cropped text when editing 

When editing begins, FlexiPDF normally grabs all text on a page and converts it into a form ready for 

interactive editing. When this option is enabled, it will grab all text, even that hidden from view by a page crop. 

This is useful for searching text that would otherwise be missed. 

When disabled, you can use a page crop to limit the amount of text on a page that FlexiPDF will ‘see’. This is 
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useful for narrowing the affect of a search and replace or for reducing unwanted layout changes at the start of 

editing. 

For example, doing a search and replace on a document’s page headers is difficult if the page header uses the 

same font and size as the rest of the document. How do you tell FlexiPDF to only search in the header and 

ignore the rest of the page contents? 

The answer is to disable this feature, place a crop around the header area using the Crop tool , then do the 

search and replace operation. 

FlexiPDF will not only limit the search to text within the crop, it will also leave all other text unaltered. After 

the search has finished, the crop can be removed by choosing Pages > Remove Crop to reveal the complete 

page text. 

• Diagnostic editing mode 

This option is included for diagnostic use only. It stops FlexiPDF from converting the text on a page into an 

editable form. Objects may still be manipulated but no text editing can be performed whilst this option is 

enabled. The option is turned off each time FlexiPDF is started. 

 

Saving 

Access this pane from File > Preferences on the Saving tab. 

• User name 

This is the name that will be stored in the change log generated whenever edits are made to a PDF. It is also 

used to name any sticky notes, stamps or other annotations you place on the document. 

• Always make a backup on save 

When using File > Save, FlexiPDF can make a backup of the original file named Backup of myfile.pdf. 

This can be disabled for improved performance with large files or when saving over networks. 

• Autosave every 

When active, FlexiPDF saves a recovery backup of the current PDF every few minutes. A gap of around 10 

minutes is reasonable. You may wish to increase the interval or disable autosave for large files or when saving 

over slow networks. 

If you need to recover changes to a document after a crash, open the document you were editing. FlexiPDF will 

detect any autosave file that exists and ask you if you want to open that instead. 

• Check for overset text on save 

Normally FlexiPDF checks to see if any text box has too much text in it meaning some has become overset. If it 

finds any, it tells you where and asks if you want to fix it before saving. If you don't, that text will be invisible 

when viewed in other PDF viewers. 

This check can be slow for very long documents in which case it may be better to disable this feature. It is best 

to re-enable as soon as appropriate since you may cause text to go overset and not discover it. 

• Save documents in PDF version 1.4 if possible 

Normally FlexiPDF saves with PDF version 1.5 and above. When checked, it will try to save the edited file in 

PDF 1.4 format – an older format required by some older PDF viewers. This may not always be possible, since 

some later aspects of PDF cannot be expressed in the old format. 

• Batch save number of pages 

When performing long find/replace operations, FlexiPDF saves the PDF every 150 pages to lower memory 

consumption. Making it larger will improve speed at the cost of memory. Making it smaller will reduce speed 

and also reduce memory usage. 

• Store layout info in PDF 

When saving an edited PDF, FlexiPDF stores additional information such as tab-stop positions, paragraph 

alignments, indents and margins, etc. This makes it easier to edit the PDF using FlexiPDF but also increases the 

size of the PDF file. 

o Choose Never if you want to keep the PDF file as small as possible and do not need to keep the 

information. 

o Choose Always if the increase in file size is less important than ease of editing. 

o Choose Sometimes to let FlexiPDF decide. 
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Loading 

Access this pane from File > Preferences on the Loading tab. 

• Default zoom 

This is the zoom level used when a document is opened. It does not alter the PDF in any way. 

• Override initial zoom 

When enabled, FlexiPDF will ignore any initial-zoom suggestion contained within the PDF and use the Default 

zoom specified above. 

• Initial View/Zoom/Page 

Use these options to affect the way the current PDF is displayed when opened in FlexiPDF or any other PDF 

viewer. You will need to save the PDF again in order for any changes made here to become permanent. 

 

Spelling 

Access this pane from File > Preferences on the Spelling tab. 

• Language 

This specifies the language to use for spell-checking and hyphenation. 

It is important that this setting always matches the language in your PDF document. If it does not, the spell 

checker will be ineffective and the reflow of your text will not work correctly. 

FlexiPDF ships with only UK and U.S. English language spelling dictionaries but does include all hyphenation 

dictionaries. If you choose a non-English language, FlexiPDF will ask you if you wish to download the 

dictionary from SoftMaker’s web site. 

Though checked by SoftMaker, these installers are prepared by third parties and install the spelling data 

required by the ASpell system used by FlexiPDF. If you have access to more up-to-date spelling dictionaries, 

then these can be used instead of the ones hosted on SoftMaker’s web site. 

• Ignore words in UPPERCASE 

Instructs the spell-checker system to skip words consisting of all-uppercase letters. 

• Ignore words with numbers 

Instructs the spell-checker system to skip words that contain numbers such as “HT4”. 

• Hyphenate words 

To better fit text within their text boxes, FlexiPDF will hyphenate certain words according to language-specific 

hyphenation rules. This is mainly used on fully-justified paragraphs but can also affect normally justified text. 

Disabling this feature will have a document-wide effect. 

To disable hyphenation on a per-paragraph basis, press the right-mouse button when editing the paragraph and 

choose Disable hyphenation. 

• User Interface language 

FlexiPDF is available in a number of different languages. If this drop-down menu does not list the language you 

require, please re-install the software. During installation, you will be prompted to choose the user interface 

language to be installed. 

If you do not have a copy of the installer, please download the latest version of FlexiPDF from SoftMaker’s 

web site. 

English Spelling Dictionaries 
English UK and US are always included when FlexiPDF installs.  

If you cannot select either of these languages without FlexiPDF prompting you to download the dictionary, you will 

have to re-install FlexiPDF. To do this, download a copy of the latest version from our web site and install. 

 

Toolbar customisation 

Apart from being able to hide/show (View > Toolbars) and move toolbars, you can also: 

• Add / remove buttons 

• Display large icons 

http://www.softmaker.com/
http://www.softmaker.com/
https://www.softmaker.com/en/downloads
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• Show / hide text labels 
 

Add / remove buttons 

To add or remove buttons from a toolbar: 

1. Click on a toolbar menu button at the bottom-right hand side of every toolbar. 

 

 
 

2. Choose the Add or Remove Buttons > Toolbar Name menu item. 

Then check / uncheck each button in the pop-up menu that appears until you have just the buttons you use. 
 

Show text labels 

To show / hide text labels on toolbars: 

1. Click on a toolbar menu button at the bottom-right hand side of every toolbar. 

 

 
 

2. Choose the Add or Remove Buttons > Customise menu item. 

 

 
 

3. Select the toolbar you want to modify (Page operations in this example). 

4. Click on Show Text Labels to show or hide the button labels on the toolbar. 

5. The toolbars will get bigger as a result so you may need to resize your window or move the toolbars around to 

better organise them. 
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Large icons 

To switch between normal and large icon sizes on all toolbars: 

1. Click on a toolbar menu button at the bottom-right hand side of every toolbar. 

 

 
 

2. Choose Add or Remove Buttons > Customise menu item, then switch to the Options tab. 
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3. Click on Large Icons and your toolbars should then look something like this: 

 

 
 


