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Welcome!
Note: Up until now, the manual contains only basic information on how to operate the software using the
new ribbon interface. More detailed instructions will be added in a later edition.
Tip: A table showing which ribbon command corresponds to each menu command can be found here: Menu
commands and corresponding ribbon commands.
Welcome to PlanMaker, the powerful and easy-to-use spreadsheet application.
We have made every effort in the development of PlanMaker to ensure its functions provide the maximum
benefits while minimizing user time and effort.

Some of PlanMaker's features
¡ Available for Windows, Mac, Linux, and Android
¡ Well-designed, ergonomic user interface - either with modern "ribbons" or classic menus and toolbars
¡ More than 330 built-in arithmetic functions
¡ Makes creating attractive worksheets easy through numerous formatting options. Long, boring columns of
numbers can be turned into appealing tables with the AutoFormat command. With cell styles and
character styles, you apply frequently needed formatting with just a key press.
¡ Integrated charting module that lets you present numbers vividly in charts
¡ ... and much more!
PlanMaker is in continuing development, and we welcome comments and suggestions from our users. If, in the
course of your work, you encounter a need for a feature that isn't present, or you have other suggestions, write
to us – we want PlanMaker to measure up to the users' wishes!

Android version
PlanMaker is also available for Android devices and contains practically all features of the Windows version.

Welcome!
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Technical support
If you have any questions, our technical support team will be glad to assist you. You can reach us as follows:

Website
Our website provides program updates, tips and tricks, free downloads, and much more.
Visit us at: www.softmaker.com

Support forums
Feel free to communicate with our technical support team, as well as other users, in our support forums.
You find them at: forum.softmaker.com

Inquiries to our support
If you have a problem with our software, we will gladly help you.
You can post your questions here: www.softmaker.com/en/support-assistant

About this manual
PlanMaker has been developed with an understanding that there is a broad range of user experience. While it
has many functions and customization options for the advanced user, it is designed to be an extremely useful
tool for the novice as well.
The chapters of this manual are organized as follows:
¡ Chapter Installation and program startup Describes how to install and start PlanMaker.
¡ Chapter Screen elements: Describes the individual components of PlanMaker's application window.
¡ Chapter PlanMaker basics: Acquaints you with PlanMaker's basic functions and explains basic spreadsheet
terminology.
¡ Chapter The PlanMaker Tour Introduces you to the operation of PlanMaker with some practical examples.
¡ Chapters Editing worksheets and following are the reference part of the manual. These chapters are
organized by subject, like a reference book, and describe all the functions of the program in detail.

Welcome!

System requirements
In order to run this software, the following hardware and software is required:

Windows version
¡ Windows 10, Windows 8/8.1, or Windows 7 (32 or 64 bit)

Mac version
¡ macOS or OS X version 10.10 ("Mavericks") or better

Linux version
¡ Any x86 Linux (32 or 64 bit)

Android-Version
¡ Android 5.0 or better
¡ ARM compatible CPU
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Installation and program startup
This chapter covers information on installing and starting PlanMaker.
It is divided into the following sections:
¡ Installing under Windows
¡ Installing under macOS
¡ Installing under Linux
¡ Installing on an Android device
Please go directly to the section that covers your operating system.

Installing under Windows
Download
If you obtained the software by download from our website, you will find installation instructions included in
the e-mail that you received after purchasing the software.

CD-ROM
If you obtained the software on CD-ROM, please launch the installation program provided in the root folder of
the CD.
Then, follow the installation program's instructions to install the software.

Starting
To start the installed programs, use the Start menu at the lower left corner of the screen. You will find your
SoftMaker Office applications in a sub-folder called SoftMaker Office.
Note: When you start PlanMaker for the first time, you will be asked to enter your name and address. This information is not for the purpose of
registering the program, but allows you to insert your name, mailing address, etc., in documents through the USERFIELD function You can always
change this information later (see section Preferences, General tab)
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Installing under macOS
You will find information about installing the software in the e-mail that you received after purchasing it.

Error message appears when launching the installation program?
Depending on your system settings, you may receive the following error message when you try to start the
installation program:

This happens when your system's security settings specify that only programs that have been downloaded from
the App Store should be allowed to run.
Clicking on the question mark in the lower left corner of the message reveals how you can launch the
installation program anyway. A help window appears, recommending the following procedure:
1.

Close the error message.

2.

Hold down the Ctrl key and click on the installation program.

3.

A context menu appears. Select the Open command.

4.

A message appears asking if you really want to open this application. Confirm this by clicking on the Open
button.

The installation program will now start.

Starting
After the installation is complete, icons for each of the installed applications will appear in both the Launchpad
and the Dock at the bottom of the screen. To start one of the apps, click on its icon.

Installation and program startup
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Installing under Linux
You will find information about installing the software in the e-mail that you received after purchasing it.

Starting
In most Linux distributions, the installer automatically creates shortcut icons for all SoftMaker Office
applications in the menu. To start any of the applications, click on the corresponding icon.
Alternatively, the following shell scripts are available for launching the programs:
¡ textmaker18 launches TextMaker
¡ planmaker18 launches PlanMaker
¡ presentations18 launches Presentations
You can execute these scripts in a shell, for example.
Note: When you start PlanMaker for the first time, you will be asked to enter your name and address. This information is not for the purpose of
registering the program, but allows you to insert your name, mailing address, etc., in documents through the USERFIELD function You can always
change this information later (see section Preferences, General tab)

Installing on an Android device
Purchased in Google Play Store
When you purchase an app using the Google Play Store on your Android device, there is nothing you have to
do: The app will be downloaded and installed automatically, right after you bought it.

Screen elements

Screen elements
On the following pages, the individual components of PlanMaker's user interface are described in detail.

PlanMaker's application window (Windows version)

Note: Most of the illustrations in this manual were prepared with the Windows version of PlanMaker. On
other operating systems, some of the controls have a slightly different appearance, but their modes of
operation are identical.

Title bar
At the top of the application window, you will find the title bar.
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The title bar indicates the name of the application and the name of the current document.
If this document contains changes that have not been saved yet, a little asterisk is displayed behind its name.

Menu bar
The menu bar is found directly under the title bar.

It contains all of PlanMaker's commands in the form of clearly arranged menus. Click on a menu item to open a
menu and invoke a command.

Context menu
In addition, a menu called context menu is also available.
This menu contains different commands depending on the current situation. For example, when you select some
text and open the context menu, it will offer commands for cutting, copying, or formatting that text.

To open the context menu, you usually first select something in your document and then click on that selection
with the right mouse button.
Android: In the Android version, you can also open the context menu with your finger: Just tap on the screen and
hold your finger there for about a second.

Standard toolbar
The Standard toolbar is shown below the menu bar. It contains icons for the most commonly used commands.

Toolbars, such as the Standard toolbar, allow fast access to a program's functions. Each icon represents a
specific command. If you click on it, the corresponding command is invoked.
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Tip: If you point the mouse cursor at an icon (without clicking) and hold it there, a text box called a "tooltip"
is shown. The tooltip describes the icon's function.
There are additional toolbars in PlanMaker that you can turn on and off as you choose. To do this, either invoke
the menu command View > Toolbars or click with the right mouse button on one of the displayed toolbars. A
menu appears, from which you can select toolbars that you would like displayed.
Customizing toolbars: You can customize the built-in toolbars to your liking and even create your own toolbars.
For more information, see the section Customizing toolbars.

Formatting toolbar
The Formatting toolbar, which appears beneath the Standard toolbar, allows you to format text by choosing the
desired font and style, such as bold, italics, underline, etc.

To choose, for example, a different font, click on the little arrow to the right of the font name to open a list, and
then select a font.
Other icons in the Formatting toolbar are switches that you can turn on and off by clicking, for example, the B
for bold.

Edit toolbar
Below the Standard and the Formatting toolbar is the Edit toolbar.

The Edit toolbar contains the following control elements:

Cell address
The address of the currently active cell is displayed at the very left.

Symbols and input field for editing cell contents
To the right of the cell address are four icons and an input field.
Click into the input field to edit the content of the current cell. Or, to edit the cell directly, simply click in the
cell and begin typing. For detailed information on entering and editing cells, see section Entering data in cells.
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The Edit toolbar icons have the following functions:
Icon

Function
Invokes the Insert > Function menu command
Accepts the user input in the input field (identical to pressing the Enter ¿ key)
Cancels the user input in the input field (identical to pressing the Esc key)

For more information on entering formulas, see section Entering formulas.

Ribbon
If you have selected in the settings that you would prefer to use a ribbon interface instead of classic menus and
toolbars, the uppermost area of the program window will look like this on your device:

The ribbon and the Quick Access Toolbar (at the bottom)

Ribbons are a modern type of user interface supposed to replace menus and toolbars (by combining them) in
order to simplify the handling of the software.
As you can see, the ribbon has several tabs that are displayed at its top (File, Home, Insert, etc.). You can
switch between them with the click of a mouse. Each tab contains icons for a specific topic.
Tip: You can also switch between the ribbon tabs using the keyboard: Use Ctrl+F12 to move to the next tab
and Ctrl+Shift+F12 to the previous tab.
The Quick Access Toolbar is displayed below the ribbon. It provides a selection of the most frequently used
commands.
Note: Up until now, the manual contains only basic information on how to operate the software using the
ribbon. More detailed instructions will be added in a later edition.
Tip 1: A table showing which ribbon command corresponds to each menu command can be found here:
Menu commands and corresponding ribbon commands.

Screen elements
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Tip 3: You can switch the user interface between ribbon and classic menus and toolbars at any time. To do
this, invoke the menu command Tools > Options (or, in the ribbon, the command File > Options). In the
dialog, switch to the Appearance tab and click on the User Interface button. A dialog box appears in which
you can select the type of user interface you prefer.

Document tabs
A bar with document tabs can be found below the Edit toolbar. It displays one tab for each open document.

The document tabs bar

The following actions can be performed here:
¡ To make a document become the active document, click on its tab with the left mouse button. This allows
you to switch between the currently open documents quickly.
¡ To close a document, click on its tab with the middle mouse button. (Alternatively, left-click on the x icon
displayed on the right of the tab).
Documents can also be opened in a new program window if desired. For details on working with multiple
documents at the same time, see the chapter Working with multiple documents.

Document
The document itself takes up the largest area of the program window. This is the work area where you enter
data, carry out calculations, etc.
Detailed information on editing the document and entering data can be found throughout this manual; in
particular, in the chapter Editing worksheets.

Worksheet register
Below the document is the worksheet register.
A PlanMaker document can consist of multiple worksheets, which are layered like a stack of paper sheets, one
on top of another. With the worksheet register, you can switch between the individual worksheets in a
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document (by clicking on its tab), create new sheets, and manage the existing ones. For details, see the section
Working with multiple worksheets).

In the illustration above, the document consists of three worksheets, with "Sheet1" as the active worksheet.

Status bar
The Status bar is found at the bottom of the program window.
Hint: If you do not see the status bar, you have to change the settings as described in the section Preferences,
Appearance tab.

When you point to an icon or other control in the user interface with your mouse, a short explanation of its
function is displayed in the status bar.
Apart from that, the following information is provided in the status bar (from left to right):
Example

Explanation
On the very left, information is displayed about the toolbar icon or menu entry that the mouse is
currently pointing at.

Sheet1

The name of the current worksheet is displayed here.

Sum=6

If just a single cell is selected, its content is shown here. If multiple cells are selected, the sum of their
cell contents is indicated. (You can change the type of calculation displayed here with the Calculation
in status bar option in the dialog box of the Tools > Options menu command).
This icon lights up if the worksheet contains circular references. This usually indicates an erroneously
written formula – for example, a formula in cell A1 that refers to cell A1 itself.
If you click this icon, PlanMaker selects the cell with the circular reference. If you click again, it
jumps to the next such cell (if more of them exist).

Ins

Shows whether Insert Mode (Ins) or Overstrike Mode (Ovr) is active.
Ins: Insert mode is active – newly entered text will be inserted into existing text.
Ovr: Overwrite mode is active – newly entered text will be written over existing text.
The default setting is Insert Mode. You switch between these modes by pressing the Ins key.

AUTO

Indicates the current input mode:
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AUTO: Normal input mode – numbers are automatically recognized as numbers, and formulas as
formulas. This is the standard setting.
TEXT: Text input mode – everything you enter is interpreted as text, including formulas and numbers.
To switch between these two modes, either click on the text "AUTO" in the status bar or press the key
combination Ctrl+Shift+F4.
Note: If you switch to TEXT input mode, a single quotation mark (') is automatically placed before all
numbers and formulas that you enter, converting them into text – which can not be used for
calculations anymore. (In order to turn text into numbers or formulas again, switch back to AUTO
mode and simply remove the leading quotation mark.)

Additionally, a zoom slider can be found in the status bar:

To change the zoom level, either drag the slider with your mouse, or click on the minus or plus icon. (See also
section Zoom level.)

PlanMaker basics

PlanMaker basics
This chapter gives you a brief description of basic PlanMaker functions and terminology.
Topics covered in this chapter:
¡ The structure of a spreadsheet
¡ Moving around in a worksheet
¡ Entering data and Deleting data
¡ Undoing changes
¡ Beginning a new document
¡ Opening a document, Printing a document and Saving a document
¡ Exiting PlanMaker

The structure of a spreadsheet
First, let's have a look at how spreadsheets are organized.
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Spreadsheets are divided into lines and columns. Each spreadsheet can contain up to 1 million rows and 16384
columns, labeled as follows:
¡ The rows are numbered.
¡ The columns are labeled with alphabetic characters: A to Z, then AA to AZ, then BA to BZ, etc.
The matrix of rows and columns results in a cell grid. Each of the cells has its individual coordinates: B5, for
example, describes the cell in the fifth line of column B (the second column). A3 would be the cell in the third
row of column A (the first column), etc. These coordinates are referred to as the cell address.
The cell address is very important because calculations often refer to other cells: If, for example, you want to
put twice the value of cell A1 in cell A2, you would enter in cell A2: =A1*2.
Twice the value of A1 is now displayed in A2. If you change the value in A1, the resulting calculation of cell
A2 is automatically updated.

Moving around in a worksheet
If you enter data in PlanMaker, it is always inserted into the active cell. A thin dark frame, known as the cell
frame, indicates the active cell:
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You can move the cell frame to another cell as follows:
Mouse: Click on the desired cell.
Keyboard: Use the arrow keys of the keyboard to move the cell frame.
Via keyboard is also possible: Use the Tab key to get to the next right cell and Shift+Tab to the next left cell.
Press the Enter¿ key to move down and Shift+Enter to move up.
A list of available keystroke commands can be found in the section Keyboard shortcuts.

Entering data
In order to enter data into a cell, move to the desired cell using the arrow keys or the mouse, and begin typing.
To complete your input, press the Enter ¿ key.
To undo an input error, press the Esc key. PlanMaker restores the previous cell content.
Alternatively, use the following buttons of the Edit toolbar:
¡ To accept the input, click the

button (identical to pressing the Enter ¿ key).

¡ To cancel the input, click the

button (identical to pressing the Esc key).

To edit the content of an already populated cell, double-click it, or navigate to the cell and press the F2 key.
For detailed information on this topic, see section Entering data in cells.

Deleting data
There are several ways to delete data from a document:
¡ Deleting the content of a cell
In order to delete the content of a cell, navigate to the cell and press the Del key – or choose the Edit >
Delete menu command.
¡ Deleting only parts of the cell content
In order to delete only a part of the contents of a cell, double-click it. Alternatively, navigate to the cell and
press the F2 key. This allows you to edit the cell content and, for example, delete parts of it.
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¡ Deleting the contents of multiple cells
To delete multiple cells at once, select them before you press the Del key or choose the Edit > Delete menu
command. For information on how to select cells, see section Selecting cells and cell contents.
More detailed information on this topic can be found in the section Deleting cells and cell contents.

Undoing changes
The Edit > Undo menu command reverses changes made to a document, one by one, in reverse order. The
Undo command can be used repeatedly, as desired.

Reversing the undo command
There is also an opposite to the Undo command, the menu command Edit > Redo. It restores the action last
undone and can also be used repeatedly.
For detailed information on this topic, see section Undoing changes.

Beginning a new document
To begin a new document, invoke the menu command File > New.
In the resulting dialog box, select a document template for the new document. To create a document without
any additional formatting, select the standard document template normal.pmvx.
Press Enter ¿ or click OK to create the new document.

Using document templates
Template: Apart from the standard template Normal.pmvx you will also see some folders that can be opened
with a double-click. These folders contain prepared document templates.
Language: Select the language for which you want to have document templates displayed.
Set default: Change the default template by clicking a template and using the Set default button.
For detailed information on using document templates, see section Document templates.

"New program window" option
The New program window checkbox in this dialog has the following meaning: If it is switched on, the new
document will be opened in a new program window. If it is switched off, the new document will appear in the
existing window with an additional tab. (Note: This option is not available in the Android version.)
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Opening a document
To open an existing document, use the File > Open menu command.
A dialog box appears that can look, for example, as follows:

The most recently accessed folder will display with all existing documents listed (based on the listed file types).
To choose the file to be opened, type its name in manually or simply select a file from the list.
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"New program window" option
The New program window checkbox has the following meaning: If it is switched on, the new document will
be opened in a new program window. If it is switched off, the new document will appear in the existing
window. (Note: This option is not available in the Android version.)

Previewing a document
When the Preview option is activated, a little box displaying a preview of the currently selected document is
displayed alongside the dialog.

Opening other file formats
In addition to opening files created in PlanMaker's default file format, you can also open files created within
other software, such as Microsoft Excel. To open a file from another application, choose the format of the file
you want to open from the file types list box. This will display all matches to that software's file extensions in
the dialog.
You will find more information about this in chapter Working with other file formats.

Using Quick Paths
With the Quick Path button, you can create quick paths in order to quickly move to a specified folder when
opening or saving files. This allows you to create a list of your most frequently used folders, permitting much
faster navigation.
You will find more information about this in section Quick paths.

Using the File manager
The File manager button opens the integrated file manager. This shows a list of your documents, and allows
you to open, print, view, or delete them, as well as perform searches.
You will find more information about this in section The file manager.

Using the list of recently opened files
Tip: At the bottom of the File menu you will find a list of recently opened files. Simply click on one of these
files to open it again.

Printing a document
To print the active document, choose the File > Print menu command.
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A dialog box appears, in which you can specify which parts of the document will be printed.
For more information on outputting documents (printing, e-mailing, etc.), see the chapter Outputting
documents.

Saving a document
To save a document, choose the File > Save menu command. If the document has not been saved before,
PlanMaker will request a document name before saving.

Saving under a different name or in a different place
To save a document under a new name or location on your computer, use the menu command File > Save as.
This saves your document too, but you can first give it another name or select another folder in which to save it.

Saving in a different file format
With the File > Save as menu command, you can also save a document in another file format. To do so, simply
choose the desired format from the Save as type list before clicking the Save button. See also chapter Working
with other file formats.

Saving all open documents
If you have multiple documents open at the same time, you can use the menu command File > Save all to save
all documents open in all the windows. PlanMaker checks which of the documents have been altered since the
last save and saves only those that have been changed.

Exiting PlanMaker
To exit PlanMaker, use the File > Exit menu command.
If any of the open documents have been altered since they were last saved, PlanMaker automatically asks
whether you would like to save them first.
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The PlanMaker Tour
Welcome to the PlanMaker Tour!
On the next few pages, we will introduce you to some of PlanMaker's most important functions using some
practical examples. Users unfamiliar with spreadsheets should read this chapter thoroughly.
More advanced users are encouraged to browse through this section as needed.
Note: Most of the illustrations in this manual were prepared with the Windows version of PlanMaker. On
other operating systems, some of the controls have a slightly different appearance, but their modes of
operation are identical.

Five minutes of theory …
If, for example, you plan a computer purchase, you need to compare various systems, based on their hardware
components: you will need a PC, a monitor, and a printer. One vendor may offer a competitively priced
computer; another one might offer an inexpensive monitor, etc. Which is the best option?
To determine this, you have to add up the prices. So, you grab your pocket calculator, type in the numbers one
by one, jot down the result – and become frustrated: With every new offer, the game begins anew, even though
the method of calculation never changes, only the values do.
Such calculations can be carried out much easier with the help of a spreadsheet application.
The first technique you will learn when using PlanMaker, is to make use of "variables." Variables help you to
generate abstract formulas, without the use of actual number (or dollar) values. For instance:
computer + monitor + printer = total price
Abstracted:
a+b+c=d
Without spreadsheets, such a formula has only practical benefit if you use a programmable calculator – you can
enter the formula once, and then execute it many times. The calculator asks for the values one by one, and then
shows the total value. This is not much of an improvement over repeated individual calculations...
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First steps with PlanMaker
With these preliminary thoughts in mind, let's look at how such problems can be solved with PlanMaker.
When you start PlanMaker, the following screen will appear (Windows version):

Most of the application window is taken up by your new worksheet. On the top, it is bordered by a row of
alphabetic characters, on the left by a column of numbers.
Let's have a closer look at the worksheet.

The basic structure of a worksheet
As you already know from chapter PlanMaker basics, a worksheet is divided into rows and columns. This is
also visible through the gray lines that are displayed in the worksheet.
A dark frame that we call the cell frame surrounds the cell in the upper left corner. The cell frame indicates
which cell is currently active:

When entering data, it is always placed in the active cell.
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You can use the arrow keys on your keyboard, e.g. â and à, to move the cell frame from one cell to another.
While you do that, take a look at the Edit toolbar above the worksheet: at the very left, PlanMaker displays the
address of the currently active cell. The address always consists of one or two alphabetic characters and a
number:
A1 means column 1, row 1.
A5 means column 1, row 5.
D5 means column 4, row 5, etc.
The fact that every cell has a unique address is the key to all functions of a spreadsheet. Remember the
variables a, b, c we talked about before? In PlanMaker, the cells are used as variables. Therefore, you can enter
calculations in a cell that refer to other cells in your worksheet – and, for example, calculate the sum of several
cells in another cell.

Entering values and formulas
Enough theory for now! Let's create our first calculation.
First we type in the price for the personal computer; under that, the price for the monitor; and under that, the
price for the printer. Suppose the prices are $799, $425, and $199, respectively.
Use the arrow keys to go to cell B2, and enter the value 799. The value appears both in the chosen cell and in
the Edit toolbar above the table.
Note: Do not make the mistake of typing the letter "O" or "o" instead of the numerical digit "0". Computers
make a clear distinction between letters and numbers. PlanMaker would accept the input but interpret it as
text. When attempting to calculate with it, PlanMaker will generate an error message.
Press the Enter ¿ key now to finish your input. The cell frame moves down one row to cell B3. Type the value
425 here, and in the row below that type the value 199.
Hint: If you entered a wrong value and have already pressed the Enter ¿ key, you can still correct your
mistake. Move the cell frame to the cell with the error, and enter the correct value. As soon as you press the
Enter ¿ key, the old content is overwritten by the new input. You can also edit the content of already filledout cells by pressing the F2 key.

Entering formulas
Let's enter our first formula.
In order to calculate the total cost of our computer equipment, we have to add up the unit prices. This is simple
to do:
Go to cell B5 and type an = (equal sign). The equal sign shows PlanMaker that you would like to begin entering
a formula.
Now enter the formula. For this purpose, you use the cell addresses as "variables". Type in:
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=B2+B3+B4

Note: Cell addresses are not case-sensitive, i.e., you can enter them in either upper or lower case.
When you press the Enter ¿ key, you will see the result of your first formula:

Let's see what happens if you change the numbers in the cells. Replace 425 by 300, or some other value. As
soon as you press the Enter ¿ key, the result of the calculation is updated immediately.
Regardless of what cells B2, B3 and B4 contain, PlanMaker will always sum them up. If you get a quote for a
computer system in which only the price for only one component has changed, you only need to update that one
value, and the new total price will be displayed in cell B5.

The SUM function
The example above is one method of adding up several numbers. But while this method is adequate for a few
numbers, it is clearly too cumbersome for adding 50 numbers - that would be one long formula! However, there
are better ways to achieve this: the arithmetic functions of PlanMaker.
Let's find out more about them! First, make cell B5 the current cell; it contains the formula you entered
previously.
Next, delete the old formula by pressing the Del key, or by simply overwriting the existing cell content. Now
enter the following formula:
=SUM(B2:B4)

After you press the Enter ¿ key, you can see the result in the cell: the sum of the cells B2 through B4.
PlanMaker has over 330 built-in arithmetic functions, and one of them is SUM. The SUM function calculates
the sum of the values that your formula references. The expression in parentheses after the function name tells
PlanMaker where to start and stop totaling.
You have directed PlanMaker to start adding in cell B2 and stop in cell B4. Between cell B2 and cell B4 sits
one cell, B3, and it is included in the summing as well. You could easily have specified a larger range, such as
B2:B123.
The notation StartingCell:EndingCell can also be used when both row and column changes. If, for example,
you enter B2 as the starting cell and C4 as the ending cell, these two coordinates form the corners of a
rectangle. The formula =SUM(B2:C4) would sum all numbers contained within this rectangle.

Using the Insert > Function dialog
To get an impression of the large number of arithmetic functions PlanMaker supports, choose the Insert >
Function menu command. A dialog box will appear that displays all the functions PlanMaker supports.
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Hint: In the Windows version of PlanMaker, you can retrieve a help page for each function by selecting the
function in the dialog and then pressing the F1 key.
Let's try another function. Let's calculate the average value of our three numbers in the table. Proceed as
follows:
Close the dialog box to return to the worksheet, and delete the contents of cell B5 again.
Choose the Insert > Function menu command. Select the category All functions in the left list. Now scroll
through the list on the right, down to the "Average" function. Double-click the Average function.
PlanMaker now places the Average function into the input field of the dialog box:
Average()

In order to complete the formula, enter the cell range B2:B4 between the parentheses.
Alternatively, you can select the cell range right in the worksheet: left-click on cell B2, then drag down the
mouse to cell B4 (as you did in a previous example). If the dialog box covers the cells you want to select,
simply drag the dialog box out of the way.
The completed formula should look like this:
=Average(B2:B4)

If you click the Insert button now, this formula is placed into cell B5 and calculated immediately.
You have now learned about two of the more than 330 arithmetic functions of PlanMaker. A comprehensive list
of all functions can be found in section Functions from A to Z.
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Going three-dimensional
PlanMaker documents are not limited to single worksheets. If required, you can stack several worksheets on top
of each other – just like a stack of papers. PlanMaker documents are therefore also called workbooks. Each
workbook can contain up to 256 worksheets.
The main advantage of this is that calculations in one worksheet can also refer to cells in other worksheets of a
workbook, in essence, letting you create "three-dimensional" calculations.
As an example, if you maintain the financial records of three branches of a company on three worksheets, you
can create a fourth worksheet that sums the financial results of the three branches, giving you an integrated
view of the company finances.
To add a new worksheet to a workbook, use the Worksheet > Worksheet > Insert menu command. To switch
between the individual sheets, use the worksheet tabs on the worksheet register.

Simply click on the desired worksheet tab to switch the currently active worksheet.
For detailed information on this topic, see section Working with multiple worksheets.

Changing the layout of worksheets
Let's return to our first sample worksheet and improve the visual layout. PlanMaker has many formatting
functions that let you fine-tune how the worksheets look.

Adding a headline
What is missing from our worksheet is a headline. Let's enter one and increase the font size to make it stand out.
Click on cell B1 to make it the active cell. Then, for example, type the following text:
My first worksheet¿

Changing character formatting
Next, let's choose a different font for the heading – and make it a lot bigger.
For this purpose, first move the cell frame back to the cell B1 again. Open the font list in the Formatting toolbar
by clicking the small triangle to the right of the font name.
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PlanMaker now displays a list of all fonts installed on your computer. Select the Tahoma font (or any other font
you like). Then open the list with the font sizes (at the right of the font list). Select a font size of 24 point.
The remaining elements of the Formatting toolbar allow you to change the color of text, and to apply various
formatting attributes: B turns on bold printing, I switches to italics, U underlines the text, etc.

Changing number formatting
When it comes to formatting numbers, PlanMaker not only allows you to change the character format of
numbers (font face, font size, etc.), but you can also modify their number format.
Let's try this out: To display the values in the cells B2 through B5 with a currency symbol, proceed as follows:
First, select the cells of interest. To do so, click on the cell B2 and then – with the mouse button still held down
– move the mouse pointer to the cell B5.
Android: Please note that in the Android version, selecting cells is done in a quite different way. For details,
see the section Selecting cells and cell contents.
When you have selected the cells to be changed, invoke the Format > Cell menu command. A dialog with
numerous options opens. We are only interested in the tab named Number format: On this tab, simply choose
the entry Currency from the list and confirm with OK.
Result: A currency symbol is now displayed with values in the selected cells. Also, the values are displayed
with two digits after the decimal point.
There are many more number format options at your disposal, for example, you can make values display as
percentages, change their number of decimal places, etc. Important: Applying a different number format to a
value only changes its display – not the value itself.
You have now met a tiny part of PlanMaker's options for improving the visual display of worksheets – many
more are to be discovered. For more information on this, see the chapter Formatting worksheets.
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Charts
Before we end this tour, let's have a quick look at charts.
In spreadsheets consisting of nothing but long columns of numbers, it is often hard to interpret their meaning.
PlanMaker provides easy ways to turn raw numbers into charts that get the point across.
To insert a chart in a worksheet, select the values you want to base your chart on and choose the menu
command Object > New chart frame. A dialog box will open where you specify the type (pie chart, column
chart, etc.) and the graphical options (colors, headline, legend, etc.) of the chart. When done, the chart is
inserted into the worksheet.

For more information on charts, see chapter Charts.

Outlook
The introductory part of the manual ends here. You now know everything about the basic functions of
PlanMaker. Next comes the reference section of the manual, which contains detailed instructions on working
with PlanMaker's functions. Jump to any chapter you want or just read on.
Enjoy!
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Editing worksheets
This chapter begins the reference section of the manual. This part of the manual contains detailed descriptions
of all features of PlanMaker, and is arranged by topic.
In this first chapter you will find out how to enter data and how to edit worksheets. The following topics are
covered in this chapter:
¡ Entering data in cells
In the first section of this chapter, you will learn everything you need to know about entering text, numbers,
dates, calculations, etc. in cells.
¡ Undoing changes
If you make an error, you can reverse it with the help of the Edit > Undo menu command. The Edit > Redo
command is the counterpart to this, and reverses the Undo command.
¡ Repeating commands
The Edit > Repeat menu command repeats the last command that you have used with exactly the same
settings.
¡ Selecting cells and cell contents
This section describes how to select cells using e.g. mouse or keyboard.
¡ Deleting cells and cell contents
You can use the menu command Edit > Delete to delete just the contents of cells, or Worksheet > Delete
cells to remove cells completely.
¡ Inserting new cells
The Worksheet > Insert cells menu command inserts new cells in your worksheet and pushes the existing
cells down.
¡ Moving and copying cells
Cells can be moved or copied by selecting them and either using the commands in the Edit menu or
dragging them using the mouse. Formulas that reference cells are automatically updated when you move or
copy cells.
¡ Pasting cells selectively
The Edit > Paste special menu command lets you insert the content of the clipboard. You can specify
exactly what to be pasted; for example, just the values or just the formatting.
¡ Filling cells automatically
The Edit > Fill menu command allows you to fill ranges of cells with identical values or a series of values.
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¡ Working with multiple worksheets
You can create multiple worksheets in a single document and stack them like a pile of paper. Formulas in
one worksheet can reference cells in other worksheets, enabling you to do "three-dimensional" calculations.
¡ Naming cell ranges
With the Worksheet > Names menu command, you can assign a name to a range of cells and use this name
in formulas; for example, =SUM(Sales) instead of =SUM(A1:A5).
¡ Sorting cells
The Worksheet > Sort menu command sorts ranges of cells according to one or more criteria.
¡ Transposing cells
The Worksheet > Transpose menu command exchanges the row and column orientation of a selected cell
range.
¡ Distributing text into multiple columns
The Worksheet > Text to columns menu command allows you to distribute text entered in one table cell
into multiple columns.
¡ Filtering cells by their contents
The Worksheet > Filter menu command filters ranges of cells so that only cells that meet certain criteria
are displayed.
¡ Analyzing tables
This section covers tools that can be helpful for analyzing tables and detecting errors, including a command
for displaying formulas instead of results, syntax highlighting, a watch window for cell contents, and several
commands for auditing the formulas in a table.
¡ Updating tables
The calculations in a table are kept up-to-date automatically. Whenever you change the content of a cell,
PlanMaker recalculates the entire workbook. If required, you can turn this behavior off and use the Tools >
Recalculate menu command to update the table manually.
¡ Inserting comments
With the Insert > Comment menu command, you can attach comments to a cell. If you move the mouse
over such a cell, the comment will be displayed.
¡ Goal-seeking
With the Tools > Goal seek menu command, you can "reverse" the order of a calculation (using an
approximation method). The Goal Seeker is able to determine what value a certain portion of a calculation
must meet to extract a predefined result from the calculation.
¡ Scenarios
The Tools > Scenarios menu command allows you to create and display "scenarios". Scenarios can be used
to observe how the calculations in a worksheet change when the values in specific cells are altered. This
enables you to perform all kinds of "what-if" analysis.
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¡ Consolidating data
The Worksheet > Data consolidation menu command allows you to evaluate data from multiple cell
ranges, for example, in order to calculate their total sums.
¡ Tables in worksheets
When you can select a cell range and then invoke the Worksheet > New table menu command, PlanMaker
will create a "table in a worksheet" from it.
This has the following effects: The cell range is automatically formatted with a so-called table style. You
can switch to a different table style anytime in order to change the appearance of the entire cell range at
once. Apart from that, an AutoFilter is applied to the "table" automatically. Additionally, special tools like
adding a total row are available.
¡ Pivot tables
Huge and complex amounts of data can be summarized to certain criteria very clearly with pivot tables.
Select an existing data area and use the menu command Worksheet > New pivot table to create meaningful
presentations of your data with little effort. With exercises in the section.
¡ Freezing rows and columns
With the View > Freeze menu command, you can freeze the top rows and/or columns of a worksheet on the
screen. This will cause them to stay in place when you scroll the worksheet – ideal for row or column
headings.
¡ Inserting special characters
The Insert > Symbol menu command can be used to enter special characters that are not readily available
from the keyboard.
See the following pages for detailed information.

Entering data in cells
In order to enter data into a cell, navigate to the desired cell with the arrow keys or mouse, and begin typing.
Press the Enter ¿ key to complete the input.
If you made an error during input, press the Esc key instead of the Enter ¿ key. PlanMaker discards what you
just typed and restores the original cell content.
Alternatively, use the following buttons of the Edit toolbar:
¡ To accept the input, click the

button (identical to pressing the Enter ¿ key).

¡ To cancel the input, click the

button (identical to pressing the Esc key).

To modify the contents of a cell, navigate to the cell and press the function key F2, or simply double-click on
the cell.
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Notes on entering numbers
¡ Always enter numbers using the decimal separator specified in the regional settings of your computer (either
decimal point or decimal comma).
¡ Numbers can also be entered in scientific (exponential) notation. 4E03, for example, corresponds to 4 *
10^3, which equals 4000. 4E-03 corresponds to 4 * 10^-3, which equals 0.004.
¡ Numbers can also be entered as fractions; for example, 2 1/2 corresponds to 2.5.
¡ Numbers can also be entered as percentages; for example, 70% corresponds to 0.7.
Note: You can change the format of numbers using the Format > Cell menu command. See section Number
format.

Notes on entering dates
¡ Dates can be entered in various formats; for example, 09/25/18 or 9/25/2018 etc.
¡ You can enter dates between January 1st, 1900 and December 31st, 2500.
¡ If you enter the year with only the last two digits, it is interpreted as follows:
00 to 29 -> 2000 to 2029
30 to 99 -> 1930 to 1999
Examples:
1/1/29 is treated as 1/1/2029.
1/1/30 is treated as 1/1/1930.
¡ Times can be entered in numerous formats, for example:
9:30
09:30
09:30:00
09:30:00 AM
etc.
¡ You can combine a date and a time in a single cell by typing the date, a space, and the time. For example,
when you type in 9/25/18 6:00, PlanMaker knows that you mean the 25th of September 2018 at 6:00 am.
Note: Spreadsheets store dates and times internally as numbers (so that calculations can be carried out with
them). The number 0 represents 1/1/1900, the number 1 stands for 1/2/1900, etc. The time is stored in the
fractional part of the number.
However, you don't have to worry about this. Simply enter dates and times in your preferred way. PlanMaker
automatically converts your input into a number but will display it formatted in date/time format.
To learn more about changing the format of dates and times, see section Number format.
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Notes on entering logical values (Boolean values)
¡ To enter a logical value in a cell, type in either TRUE or FALSE.

Notes on entering formulas
¡ Formulas must always begin with an equal sign; e.g., =2+5.
¡ The Insert > Function menu command lets you easily compose formulas by picking PlanMaker's arithmetic
functions from a list. Of course you can also input formulas manually.
¡ Detailed information on creating formulas is available in the chapter Formulas and functions.
¡ For descriptions of all arithmetic functions, see section Functions from A to Z.

Notes on entering text
¡ To input text in a cell, simply type it in.
¡ In some rare cases, you may want to "force" PlanMaker to consider a number as text. This can be achieved
by putting a single quotation mark in front of the number. For example, when you enter '42 (including the
single quotation mark), PlanMaker will treat this as text, not as a number.
¡ Hint: When you have entered several text entries in a column (one on top of each other), you can open a
selection list of these entries by pressing the key combination Alt+Shift+â in a cell directly above or below
the entries.
A list of all text entries directly above and below this cell will open. You can now select one of these entries
and press the Enter ¿ key to paste it into the cell. This can save you a lot of time when you have to enter a
large number of identical text entries.
Note: This feature works only with text entries – not with numbers, dates, or formulas.
¡ Another hint: In addition, while you type text in a cell, PlanMaker automatically makes suggestions from
the existing text entries found in the cells above and below this cell.
Example: You have entered the values "New York", "Rio", and "Tokyo" in a column. If you now go to the
cell below these entries and type the letter "N", the program will automatically suggest "New York". If you
type the letter "T", "Tokyo" is suggested, etc.

To accept the suggestion, press the Enter ¿ key. To reject it, simply continue typing or press the Del key.
Note: In case you do not want PlanMaker to make suggestions while you are typing, you can always turn this
feature off. Choose the menu command Tools > Options, switch to the Edit tab and deactivate the
Autocomplete Cells option.
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Undoing changes
With the menu command Edit > Undo you can cancel recently completed modifications to a document. For
example, if you format text in another font, you need only invoke the Undo command and the new formatting
will be removed.
This works not only with formatting, but also with practically all kinds of changes – so you can also, for
example, undo the entry or deletion of text.
The Undo command can be applied repeatedly as needed. For example, invoke it five times to cancel the last
five changes.

Redoing undone actions
There is also an opposite to the Undo command, the menu command Edit > Redo. It restores the effect of your
most recently canceled action. So you can undo the cancellation of a change.
This command can also be invoked repeatedly. For example, if you invoke the Undo command five times, the
last five changes are canceled. If you then invoke the command Redo five times, you get back the original text.

Repeating commands
The Edit > Repeat menu command repeats the last command that you have used with exactly the same settings.
This is very useful especially when formatting a document. For example, when you have just changed the font
of a cell using the Format > Character menu command, you can navigate to other cells and choose the menu
command Edit > Repeat. This will apply the font change to the other cells as well – as if you had invoked the
Format > Character command once again, with the same settings.
There are many other commands that can be repeated as well.

Selecting cells and cell contents
Some PlanMaker commands allow you to first select the range of cells to which you want the command to
apply.
For example, when you select some cells and then invoke the Edit > Delete menu command, all of these cells
will be deleted.
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You can even select non-contiguous cell ranges (using the Ctrl key)

Depending on the operating system in use, the way you proceed when selecting something is a bit different. For
that reason, this section is split into two parts:
¡ Selecting in the Windows, Mac, and Linux version
¡ Selecting in the Android version

Selecting in the Windows, Mac, and Linux version
In the Windows, Mac, and Linux version of PlanMaker, you can select cells and cell contents as follows:

Using the mouse for selection
To select something with your mouse, proceed as follows:
¡ Selecting cell ranges
You can select arbitrary cell ranges by pressing and holding the left mouse button while you drag the mouse
pointer over the cells to be selected.
¡ Selecting whole rows and columns
An entire column can be selected by clicking on its column header. Column headers are buttons displayed
above the table, labeled A, B, C, and so on.
There are also row headers for each row. They are located at the left of the table and labeled 1, 2, 3, etc. If
you click on a row header, the entire row is selected.
If you left-click and drag the mouse over several column or row headers, you can conveniently select
multiple columns or rows at the same time.
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¡ Selecting the entire worksheet
The command button in the top left of the worksheet window (above the "1" and left of the "A") will select
the entire worksheet, as will the Edit > Select all menu command.
¡ Selecting a single cell
To select a single cell, click on that cell, drag the mouse pointer to a neighboring cell, and drag it back again
(while keeping the left mouse button pressed).
¡ Selecting non-contiguous cell ranges
You can also select non-contiguous (not connected) ranges of cells. For this purpose, hold down the Ctrl
key and use the mouse to select a range of cells as described above.
¡ Selecting just a part of a cell content
To select just a part of a cell content, proceed as follows:
First, double-click on the cell (in order to edit it). Then, drag the mouse cursor over the characters that you
want to select (while keeping the left mouse button pressed).
¡ Selecting objects
To select an object (e.g. a picture, a drawing, etc.), simply click on it with the mouse. A frame appears
around the object to indicate that it is selected.

Using the keyboard for selection
With the keyboard, ranges of cells can be selected as follows:
¡ Selecting cell ranges
To select a range of connected cells, navigate to the cell to start with, hold down the Shiftñ key, and select
the cells by navigating with the arrow keys.
For example, if you navigate to cell B5, hold down the Shiftñ key, and press â five times, the cells B5 to
B10 will be selected. You can find a list of all key combinations suitable for navigating in a table in the
section Keyboard shortcuts.
¡ Selecting a single cell
To select a single cell, navigate to that cell, hold down the Shiftñ key, use any arrow key to select a
neighboring cell, and then go back to the original cell. (For example, press Shift+à and then Shift+ß).
¡ Selecting non-contiguous cell ranges
Non-contiguous cell ranges can only be selected with the mouse (see above).
¡ Selecting just a part of a cell content
To select just a part of a cell content, proceed as follows:
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Navigate to the cell of interest and press the F2 key (in order to edit the cell). Then, use the arrow keys
together with the Shiftñ key to select text in the usual manner.
¡ Selecting objects
Objects can be selected only with the mouse (see above).

Selecting in the Android version
In the Android version, the procedure for selecting something is a bit different. You can use either your finger
or a mouse. Proceed as follows:
¡ Selecting cell ranges
On Android devices, you can select cell ranges as follows:
Tap on the starting cell once. (You should not see a blinking text cursor in the cell now.)
Wait a little moment, then tap on the same cell once more, and drag your finger to the cell where you want
the selection to end.
¡ Selecting just a part of a cell content
To select just a part of a cell content, proceed as follows:
Double-tap on the cell in order to edit it. (The text cursor should start blinking in the cell.)
Inside the cell, double-tap on the word that you want to start your selection with. The word has now been
selected. Large "handles" appear before and after it:

These two handles represent start and end of the selection. They allow you to extend the selection easily:
Simply drag these handles to the desired positions.
¡ Selecting objects
To select an object (picture, drawing, etc.), tap on it. A frame appears around the object to indicate that it is
selected.

Deleting cells and cell contents
There are two methods for deleting data in a worksheet:
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¡ Deleting the contents of cells
If you use the Edit > Delete menu command, only the contents of the selected cells are removed.
¡ Deleting whole cells
If you use the Worksheet > Delete cells menu command, the selected cells will be removed completely and
the other cells move up to take their space.
In addition, PlanMaker offers two commands especially for deleting empty rows and duplicate rows:
¡ Deleting empty rows
To delete all empty rows in a certain range of rows, select the rows of interest and invoke the menu
command Worksheet > Remove > Empty rows.
¡ Deleting duplicate rows
To delete all duplicate rows in a certain range of rows, select the rows of interest and invoke the menu
command Worksheet > Remove > Duplicate rows.
See the following pages for detailed information.

Deleting the contents of cells
To delete the contents of cells, proceed as follows:
1.

Select the cells of interest.
(For information on how to select cells, see section Selecting cells and cell contents.)

2.

Invoke the Edit > Delete menu command – or simply press Del, the keyboard shortcut for this command.

This will remove only the contents of the cells, not the cells themselves.

Selective deletion
If you use the menu command Edit > Delete special instead of Edit > Delete, you can determine exactly what
will be deleted.
PlanMaker will show a sub-menu with the following options:
¡ All
Delete everything – cell contents as well as formatting, comments, conditional formatting and input
validation.
¡ Formatting
Remove only the formatting (number format, character format, background shading, borders, etc.).
¡ Contents
Delete only the contents, keep everything else (formatting, comments, etc.).
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¡ Comments
Remove only comments that have been added to the selected cells, leaving both content and formatting
intact (see section Inserting comments).
¡ Conditional formatting
Remove only the conditional formatting (see section Conditional formatting).
¡ Input validation
Remove only the input validation (see section Input validation).

Deleting whole cells
The Worksheet > Delete cells menu command not only deletes the content of the selected cells but also
removes them from the worksheet completely.
A dialog box will appear in which you can determine how the other cells will move after the deletion.

Options available:
¡ Move cells up
The selected cells are removed, and the cells below move up.
¡ Move cells to the left
The selected cells are removed, and the cells to the right of them move to the left.
¡ Remove complete rows
The entire row(s) including the selected cells are removed, and the rows below move up.
¡ Remove complete columns
The entire column(s) including the selected cells are removed, and the columns right of them move to the
left.
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Deleting empty rows
To delete all empty rows in a certain range of rows, select the rows of interest and invoke the menu command
Worksheet > Remove > Empty rows.
PlanMaker scans this range for rows that are completely empty, (i.e. where none of its cells is filled with a
value) and deletes all matching rows.

Note
Normally, you use this command with a range of entire rows selected. However, you can also select a cell range
that doesn't consist of entire rows. In that case, PlanMaker will first ask you if you want it to delete matching
rows entirely:
¡ If your answer is Yes, the entire row will be deleted for all matching rows.
¡ If your answer is No, only cells inside the selection will be deleted. The cells left and right of the selection
are not affected.

Deleting duplicate rows
To delete all duplicate rows in a certain range of rows, select the rows of interest and invoke the menu
command Worksheet > Remove > Duplicate rows.
PlanMaker scans this range for rows that are completely identical, (i.e. where the contents of all cells in one
row are identical to another row) and deletes these duplicate rows.

Note
Normally, you use this command with a range of entire rows selected. However, you can also select a cell range
that doesn't consist of entire rows. In that case, PlanMaker will first ask you if you want it to delete matching
rows entirely:
¡ If your answer is Yes, the entire row will be deleted for all matching rows.
¡ If your answer is No, only cells inside the selection will be deleted. The cells left and right of the selection
are not affected.

Inserting new cells
The Worksheet > Insert cells menu command inserts new cells, rows or columns in a worksheet.
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A dialog window appears where you can choose in which way the cells should be inserted. Options available:
¡ Move cells down
PlanMaker will insert as many cells as were selected before executing this command. If nothing was selected
before, just one cell will be inserted.
The cells below the insertion are moved down.
¡ Move cells to the right
Same as above, but the cells to the right of the insertion are moved to the right.
¡ Insert complete rows
PlanMaker will insert as many complete rows as were selected before executing this command. If nothing
was selected before, just one row will be inserted.
The rows below the insertion are moved down.
¡ Insert complete columns
PlanMaker will insert as many complete columns as were selected before executing this command. If
nothing was selected before, just one column will be inserted.
The columns to the right of the insertion are moved to the right.

Inserting copied cells
It happens from time to time that you want to place copied cells at a position where values already exist. If you
do not want to overwrite these values, but move them when pasting something from the clipboard, the following
option is available.
The Worksheet > Insert copied cells menu command inserts cells, rows or columns from the clipboard into a
worksheet.
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A dialog window appears where you can choose in which way the cells should be inserted. Options available:
¡ Move cells down
The copied cells from the clipboard are inserted at the selected position.
The cells below the insertion are moved down.
¡ Move cells to the right
Same as above, but the cells to the right of the insertion are moved to the right.
¡ Insert complete rows
The copied rows from the clipboard are inserted at the selected position.
The rows below the insertion are moved down.
¡ Insert complete columns
The copied columns from the clipboard are inserted at the selected position.
The columns to the right of the insertion are moved to the right.

Moving and copying cells
All operating systems supported by PlanMaker have a built-in clipboard.
Using the clipboard allows the user to select worksheet content, and put it on the clipboard, either by copying it
from the worksheet or by cutting it from the worksheet. Once in the clipboard, it can be pasted elsewhere in the
worksheet. In this way, cells (and also objects) can be deleted, duplicated or moved.
You will find all the necessary commands in the Edit menu:
Command

Explanation

Cut

The Edit > Cut menu command removes the selection and places it on the clipboard.

Copy

The Edit > Copy menu command copies the selection to the clipboard.
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The Edit > Paste menu command inserts the contents of the clipboard to the active cell. You can
paste the content of the clipboard repeatedly.

* How to paste from the clipboard without overwriting the existing values of the active cell, see chapter Inserting copied cells.

These commands can also be used with objects (pictures, charts, etc.)

Pasting into a selected cell range
When you copy cells to the clipboard and select a range of cells before inserting them with the Paste command,
the pasted cells will be fit into the selection, as follows:
¡ If the selected cell range is smaller than the cell range to be pasted, all cells which do not fit are omitted.
¡ If the selection is larger than the cell range to be pasted, the cells are repeated until the selected range is
completely filled.
¡ There's one exception:
If the selected cell range consists of just one row, PlanMaker will still paste all columns of the source cells.
The same applies when the selected cell range contains only one column.

Moving and copying using the mouse ("Drag and Drop")
Note: This feature is not available in the Android version.
To move or copy cells using the mouse: Select the cells, drag them to a different place, and drop them there.
This technique, called "Drag and Drop", provides a particularly quick method for moving and copying.
Proceed as follows:
1.

Select the cells that you want to drag to another location.

2.

Point at the selection with your mouse.

3.

Press and hold the left mouse button.

4.

Drag the mouse, with the left mouse button still held down, to the desired location.

5.

When you release the mouse button, the cells will be moved to the target location.
If you hold the Ctrl key down while releasing the mouse button, the cells will instead be copied to the new
location.
If you hold the Alt key down while releasing the mouse button, a dialog appears where you can choose if
you want the cells to be copied or moved. When you choose "Copy", you can also specify if just the cell
contents should be copied or also their formattings.

Hint: To move or copy a single cell, you can also use the following method: Click on the cell once to make it
the active cell. Click on it again and hold the left mouse button. After about one second, the mouse cursor
changes, indicating that you can now drag the cell around (as described above).
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Moving and copying formulas containing relative coordinates
If you copy cells that contain formulas, the cell addresses in the formulas are automatically updated to the new
location.
For example:
Suppose you have a formula in cell A7 that adds up the values from the four cells above:
=SUM(A3:A6)
If you copy this formula to cell B7, PlanMaker will automatically update the formula so that it will work again
with the four cells above the new position. Cell B7 will therefore contain the following formula:
=SUM(B3:B6)
If you do not want this to happen, use absolute cell addressing instead of the usual relative cell addressing (see
section Relative vs. absolute cell references).

Pasting cells selectively
In addition to common clipboard operations like Cut, Copy, and Paste, PlanMaker offers the Edit > Paste
special menu command which gives you more control over how the clipboard content is pasted into your
document.
In detail:
When you place information in the clipboard using the Cut or the Edit command, this information is saved
there in several formats. For example, if you cut or copy text, the text is saved both in formatted form and in
unformatted form.
Normally, you don't need to be concerned about this, because PlanMaker automatically selects the most
appropriate format when it inserts the content of the clipboard in response to a Paste command. However, if
you need to, you can select the format in which the content is to be inserted yourself. You use the menu
command Edit > Paste special to do this.
When you invoke this command, a dialog box appears and presents you with a list of all the formats in which
the information currently residing in the clipboard is saved. When you select a format from the Paste as list and
then confirm with OK, the content of the clipboard is inserted in the selected format.
If you have copied cells to the clipboard, the dialog offers some additional options, as follows:
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Options available:

Paste content
These options allow you to control how the content of the cells in the clipboard should be inserted when they
are pasted.
Options available:
¡ Paste cell contents
If this option is checked, the content of the copied cells is pasted. If it is not checked, just their formatting is
pasted.
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¡ Convert formulas to values
If this option is checked, PlanMaker will paste the results of formulas in the copied cells – rather than the
formulas themselves. For example, if the clipboard contains a cell with the calculation "=A1*2", PlanMaker
will calculate its current value and paste the result as a fixed number.
¡ Ignore comments
If this option is checked, comments attached to the cells in the clipboard will not be pasted.

Paste formatting
These options allow you to control if the formatting of the copied cells should be retained when they are pasted.
Options available:
¡ All
The cells in the clipboard retain their entire formatting when they are pasted. (Choosing this option activates
all the other options listed below.)
¡ Number format
The cells retain their number format when they are pasted.
¡ Cell format
The cells retain their cell format when they are pasted.
¡ Input validation
The cells retain their input validation settings when they are pasted.
¡ Conditional formatting
The cells retain their conditional formatting settings when they are pasted.
¡ Borders, Shading
The cells retain their borders/shading when they are pasted.
¡ Column width, Row height
The cells retain their column width/row height when they are pasted.

Paste cell dimensions
These options allow you to control if the cell sizes of the copied cells should also be transferred to the target
cells on pasting.
Options available:
¡ Column width
The cells retain their column width when they are pasted.
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¡ Row height
The cells retain their row height when they are pasted.

Options
This section contains the following additional options:
¡ Transpose
If this option is checked, the row and column order of the cells will be exchanged when they are pasted.
Rows become columns, and columns become rows.
¡ Skip empty cells
If this option is checked, empty cells amongst the cells in the clipboard will be skipped when they are
pasted. Accordingly, if you paste an empty cell over an existing cell, the existing cell will keep its current
content and formatting.
¡ Operation
This option can be useful when you paste cells over existing cells. It allows you to combine the existing
values with the values to be pasted by performing basic arithmetic operations.
Options available:
None: Do not combine the existing values with the values in the clipboard. Just overwrite the existing
values. This is the default setting.
Add to destination: Add the values in the clipboard to the existing values.
Subtract from destination: Subtract the values in the clipboard from the existing values.
Multiply with destination: Multiply the existing values by the values in the clipboard.
Divide the destination: Divide the existing values by the values in the clipboard.
Example: Copy a cell that contains the value 2 to the clipboard. Go to a cell that contains the value 8 and
invoke the Insert > Paste special menu command. If you choose the option Add to destination, the cell
will contain the value 10 now (8+2=10).

"Paste reference" button
This button ignores any settings made in this dialog, since it has the following special function:
When you copy cells to the clipboard, invoke the Edit > Paste special menu command and click on the Paste
references button, cell references to these cells are inserted rather than their content.
For example, when you copy the cell B15 to the clipboard, using this button will insert the cell reference =B15.
Hint: This even works when cells have been copied to the clipboard from within a different document. In
this case, PlanMaker will insert an external cell reference (see section External cell references for details).
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Filling cells automatically
You can use PlanMaker's Fill function to quickly copy the content of one cell to other cells – or to create an
increasing or decreasing number series across cells.
There are two ways to use this function:

Filling with the mouse
To fill cells automatically using the mouse:
1.

Enter the initial value in a cell.

2.

Click on that cell (to make it the currently selected cell).

3.

With your mouse, point to the small rectangle in the bottom-right corner of the cell frame (marked in red
color in the illustration below):

4.

Drag this rectangle, while holding the mouse button down, to cover the desired range of cells. Release the
mouse button when the target position has been reached.

All cells in the selection you created have now been automatically filled.
What the cells are filled with depends on the content of the initial cell:
¡ If the initial cell contains text, PlanMaker fills all cells with this text.
¡ If the initial cell contains a number (e.g., 42), PlanMaker fills successive cells with incrementing values (in
this case, 43, 44, 45, etc.).
Hint: If you do not want PlanMaker to fill the cells with a series of numbers but, instead, duplicate the value
42 in all cells, press and hold the Ctrl key while you are dragging with the mouse.
To control the fill function precisely, press and hold the Alt key while dragging. A dialog box (described
below) will appear, providing full control over how the cells are filled.

Filling with the keyboard
To fill cells automatically using the keyboard:
1.

Enter the initial value in a cell.

2.

Select this cell and all cells you want to be filled.

3.

Choose the menu command Edit > Fill.

4.

Select a fill direction from the sub-menu (left, right, up or down).

5.

In the resulting dialog box, you can precisely define the way the cells will be filled (see below).
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When you're done, click OK to confirm.

The dialog box appearing during this procedure looks as follows:

The dialog offers the following options:
¡ Series in
Select here if you want to fill in the direction of the rows (right) or in the direction of the columns (down).
¡ Source
Activate the Contents option if you want the cells to be filled with values.
Activate the Format option if you also want the formatting of the source cells to be continued in the new
cells.
By default, both options are checked.
¡ Action
This option is equivalent to pressing the Ctrl key during filling with the mouse. It lets you determine
whether to copy values or to increment them from cell to cell:
If the initial cell contains the number 42 and you select Copy, all cells will be filled with the value 42.
If you choose Increment, successive cells will be filled with a series of numbers (in this case, 43, 44, 45,
etc.).
The numerical increment can be specified using the other options in this dialog:
¡ Series type
Lets you specify how the series of values is continued:
Auto:
Arithmetic series with automatic increment. Here, each new value will be increased by an increment that is
determined by PlanMaker automatically.
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For example, if you continue two cells containing the values 10 and 20, the new cells will be filled with 30,
40, 50, etc. (see also tips and tricks in the next section).
Arithmetic:
Arithmetic series. Here, each new value will be increased by the value entered in the Increment input box.
For example, if the initial cell contains the value 1 and you specify an increment of 2, the new cells will be
filled with 3, 5, 7, 9, 11, etc.
Geometric:
Geometrical series. Here, each new value will be multiplied by the value entered in the Increment input
box.
For example, if the initial cell contains the value 1 and you specify an increment of 2, the new cells will be
filled with 2, 4, 8, 16, 32, etc.
Date:
Date series. Here, each new value will be increased by the specified increment in the chosen date unit (see
below). Note: This type of series only works correctly if the initial cell contains a date.
For example, if the initial cell contains the date 1/1/2018, the increment is set to 1, and the Date unit is set
to "Months", the new cells will be filled with 2/1/2018, 3/1/2018, 4/1/2018, etc.
¡ Date unit
This option is only available if the Series type is set to "Date".
It allows you to specify the unit of the increment:
Days: increment by days
Workdays: increment by days, excluding Saturdays and Sundays. For example, if the initial value is a
Friday, the next value would be the Monday (not Saturday).
Months: increment by months
Years: increment by years
¡ Increment
Lets you specify the amount by which each value will increase from cell to cell. For examples, see above.
Positive or negative increment values can be used.
This option is not available if the Series type is set to "Auto".
¡ Increment each cell separately
When this option is turned on, the specified increment will be added to each of the currently selected cells
individually.
Example: Let's assume you have selected three cells containing the values 1, 2, and 3, and try to fill the cells
below them.
When this option is turned off, the sequence from the source cells is simply continued, and the cells are
filled as follows:
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4, 5, 6, 7, 8, 9, 10, 11, 12, etc.
When you turn it on, the cells are filled as follows:
2, 3, 4, then 3, 4, 5, then 4, 5, 6, etc.
¡ Edit lists button
You can create custom lists for the Fill command.
For example, if you create a list with the content "Red", "Green", and "Blue", and later start a fill operation
from a cell that contains the text "Red", PlanMaker will continue the series and fill with Green, Blue, Red,
Green, Blue, etc.
This button invokes the Tools > Edit lists menu command that allows you to create such lists. See section
Customizing AutoFill lists.

Tips and tricks for automatic filling
As described on the last pages, PlanMaker provides many options for filling cells automatically. This section
offers some tips and tricks to help you effectively use this very useful feature.
Hint: The quickest way to fill a range of cells is to drag the small rectangle in the bottom-right corner of a
cell with the mouse in the appropriate direction. PlanMaker then sets the series type to "Auto", which means
that it will automatically figure which values to use to fill the cells.
¡ Filling with text
To fill cells with text, simply enter the desired text in the first cell. Then, drag the small rectangle in the
bottom-right corner of the cell over the cells you want to fill.
¡ Filling with numbers
If you use the mouse to fill cells with numbers, PlanMaker will automatically determine the increment.
For example, if you drag the small rectangle from a cell with the value 42, the other cells will be filled with
the values 43, 44, 45, etc.
If the initial cell value is 10, and the next cell value is 20, and you select both cells and drag the small
rectangle down, PlanMaker automatically recognizes how to continue this series and fills the other cells with
30, 40, 50, etc.
¡ Filling with formulas
If you use the mouse to fill cells with formulas, PlanMaker automatically attempts to update the formulas in
the new cells with incremented cell addresses.
For example, the formula =A1*2 in the initial cell will be updated to =A2*2, =A3*2, etc., in the other cells.
¡ Filling with dates
Filling with dates is identical to filling with numbers:
Enter the starting date in the initial cell and drag the small rectangle over the desired cells. PlanMaker will
add one day in every new cell.
If desired, use the Edit > Fill menu command to define whether to increment by days, months, or years.
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¡ Filling with structures
As you have already learned, it is possible to select multiple initial cells before starting the filling operation.
If the initial cells contain both text and numbers, PlanMaker will attempt to find a pattern in these values.
For example, if you enter the values 1, 2, text, PlanMaker will continue the series with 3, 4, text; 5, 6, text;
7, 8, text; etc.
If the initial cells contain just text, PlanMaker will simply repeat the text. For example, the series Red,
Green, Blue will be repeated as Red, Green, Blue, Red, Green, Blue, etc.
¡ Filling with custom lists
The Tools > Edit lists menu command allows you to create your own lists for the Fill command.
For example, if you create a list with the content "Red", "Green", and "Blue", and later start a fill operation
from a cell that contains the text "Red", PlanMaker will continue the series and fill with Green, Blue, Red,
Green, Blue, etc.
For additional information on creating such lists, see section Customizing AutoFill lists.

Working with multiple worksheets
PlanMaker documents are not limited to single worksheets. As needed, you can stack several worksheets on top
of each other – just like a stack of papers. PlanMaker documents are therefore also called workbooks. Each
workbook can contain up to 256 worksheets.
The main advantage of this is that calculations in one worksheet can also refer to cells in other worksheets of a
workbook, in essence, letting you create "three-dimensional" calculations (see section Calculating in three
dimensions).
In this section, you will learn everything you need to know about working with multiple worksheets in a
document. The following topics are covered:
¡ Creating new worksheets
To create a new worksheet, use the Worksheet > Worksheet > Insert menu command.
¡ Working with the worksheet register
The worksheet register displayed at the bottom of the document window allows you to switch between your
worksheets with a single mouse click. You can also use it to create, move and manage worksheets.
¡ Managing worksheets
To manage the worksheets in a document, use the context menu of the worksheet register or the sub-menu of
the Worksheet > Worksheet menu command. Both contain commands for renaming, copying, moving
sheets, etc.
¡ Calculating in three dimensions
In the last section, you will learn how to create calculations that refer to cells in other worksheets.
See the following pages for detailed information on these topics.
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Creating new worksheets
To create a new worksheet, use the Worksheet > Worksheet menu command. Select Insert from the sub-menu
and provide a name for the new worksheet.
Click OK and the new worksheet is created.

Working with the worksheet register
The worksheet register at the bottom of the document window displays tabs for each worksheet in the
document.
The active worksheet is highlighted.

With the worksheet register, the following actions can be performed:
¡ Switching between worksheets
To switch to a different worksheet, click on its tab in the worksheet register.
Note: If there are more worksheet tabs than can be displayed at the same time, you can scroll through the list
with the arrows displayed left of the register.
Tip: You can also switch between the worksheets using the keyboard: Use Ctrl+Tab to move to the next
worksheet and Ctrl+Shift+Tab to the previous worksheet.
¡ Changing the order of worksheets
The worksheet register can also be used to move worksheets, allowing you to change their order. Simply
click the desired worksheet tab and drag it to the desired location within the other worksheet tabs.
¡ Editing multiple worksheets at the same time
You can select multiple worksheets in the worksheet register and edit them simultaneously. To select
multiple worksheets, press and hold the Ctrl key while you click on their tabs in the register.
When multiple worksheets are selected, changes made to one of the worksheets affect all of the other
selected worksheets in exactly the same way.
Examples:
When you change the formatting of cells, your changes are also applied to the same cells on the other
selected worksheets.
When you edit or delete the content of a cell, the same cell on the other selected worksheets will be changed
the same way.
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Changes made with the menu commands Worksheet > Row and Worksheet > Column also affect all
selected worksheets.
¡ Managing worksheets
When you click on one of the tabs in the worksheet register with the right mouse button, a context menu will
appear, showing commands for creating and managing worksheets. See the next section for details.
¡ Creating a new worksheet
The tab labeled with an asterisk (*) at the very right serves as a "shortcut" for creating new worksheets:
When you click on it, a new worksheet is generated instantaneously.

Managing worksheets
To manage worksheets, choose the Worksheet > Worksheet menu command. A sub-menu will appear.
Tip: This menu can also be invoked by clicking on the desired tab in the worksheet register with the right
mouse button.
The menu contains the following commands:
¡ The Insert command creates a new worksheet.
¡ The Copy command creates a copy of a worksheet. A sub-menu will appear where you can choose the
position of the copy (within the other worksheets).
If you want to place the copy in a different (currently opened) document or in a new document, choose the
To another document option.
¡ The Move command moves a worksheet to a different location. Like with the Copy command, a dialog
where you can choose the position will appear.
¡ The Delete command removes a worksheet along with its contents.
¡ The Rename command lets you change the name of a worksheet.
¡ The Show command makes hidden worksheets (see Hide command) visible again.
A sub-menu will appear, listing all hidden worksheets. Click on the desired worksheet to make it reappear.
The Show all command makes all hidden worksheets visible at once.
¡ The Hide command hides a worksheet.
Hidden worksheets are invisible. They cannot be displayed or edited, and they do not even appear in the
worksheet register. However, they are still used as a source for calculations.
¡ The commands Select all sheets and Deselect sheets (available in the context menu only) select or unselect
all worksheet tabs in the worksheet register.
¡ The Page setup command in the context menu is identical to the File > Page setup menu command in the
main menu. It allows you to change page layout options like paper format, page margins, etc. for a
worksheet. See section Page setup.
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¡ The Copy page setup command in the context menu enables you to transfer the entire page setup (i.e. all
settings made with the File > Page setup menu command) from one worksheet to another. It opens a submenu with the following entries:
To all sheets: Copies the page setup from the current worksheet to all other sheets.
From...: Copies the page setup from any other worksheet to the current worksheet.
¡ The Properties command in the context menu is identical to the Worksheet > Properties menu command
in the main menu. It allows you to alter common properties of a worksheet. See section Worksheet
properties.
Hint: As described in the section Working with the worksheet register, you can select multiple worksheets in
the worksheet register before you invoke one of these commands. The command will then be applied to all
selected sheets at once.
Note: If you activate workbook protection for a document, PlanMaker disables the Worksheet > Worksheet
menu command as well as the context menu of the worksheet register. For additional information, see section
Workbook protection.

Calculating in three dimensions
In a multi-worksheet document, you can create calculations in one worksheet that refer to cells in other
worksheets, allowing you to perform "three-dimensional" calculations.
To enter such calculations, place the name of the desired worksheet before the cell address, and separate it with
an exclamation point. For example, "Sheet1!B2" refers to cell B2 on worksheet "Sheet1".

An example
Assume you want to create a profit/loss statement. For this purpose, you have created three worksheets named
"Sales", "Costs", and "Profit".

Now you want the value in cell D2 of the "Costs" worksheet to be deducted from the value in cell A8 of the
"Sales" worksheet and to appear in cell C9 of the "Profit" worksheet.
To do this, switch to the "Profit" worksheet, navigate to the cell C9 and enter the following formula:
=Sales!A8 - Costs!D2
After hitting the Enter ¿ key, cell C9 on the worksheet "Profit" will contain the result of your calculation.
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Naming cell ranges
Use the Worksheet > Names menu command to assign names to cell ranges.
For example, if your worksheet has four columns with the sales figures for spring, summer, fall and winter,
name these ranges accordingly. After that, a calculation like the following is possible:
=SUM(Spring)
When you invoke the Worksheet > Names menu command, a sub-menu opens. It contains all commands
needed to work with named cell ranges.
Note: The Worksheet > Names menu command will not be available if at least one worksheet in your
workbook has worksheet protection turned on (see also section Sheet protection).
Detailed information on working with named ranges is provided on the next pages. The following topics are
covered:
¡ Assigning and editing names to cell ranges
¡ Defining names automatically from the selection
¡ Creating a list of all named ranges
¡ Putting named ranges to use
¡ Applying names in existing formulas

Assigning and editing names to cell ranges
Assigning names
To assign a name to a range of cells:
1.

Select the cell range that you want to name.

2.

Choose the menu command Worksheet > Names > Edit.

3.

Input a name for the cell range in the Name edit control.

4.

Click the Add button.

You have now assigned the specified name to the selected cell range.
From now on, this name can be used in formulas instead of the original cell addresses. If you assign the name
"January" to the cell range from A2 to A10, the formula =SUM(January) is equivalent to =SUM(A2:A10).
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Note: Names may only consist of alphanumeric characters, underscores and periods. The first character must
be a letter or an underscore.
Names that look like a cell address must not be used. For example, the name "A2" is not valid because
PlanMaker wouldn't be able to distinguish it from the cell address A2.

Hint: A faster method
There is a faster method for assigning names to cell addresses:
In the top left corner of the worksheet is an editable dropdown list that normally displays the current cell
address.

Use this dropdown list to quickly set up a new named range, as follows:
1.

Select the cell range that you want to name.

2.

Click inside this dropdown list.

3.

Enter the new name for the selected cell range.

4.

Press the Enter ¿ key.

You have now assigned the specified name to the selected cell range.

Deleting and renaming names
To delete or rename the name of a named cell range:
1.

Choose the menu command Worksheet > Names > Edit.

2.

In the list of names, select the desired name.

3.

To delete the name, click the Delete button. To rename it, click the Rename button.

The name has now been deleted/renamed.
Note: When you delete a name, all formulas that use this name will now return a #NAME? error value
instead of a result. For example, if a cell range was named "January", all references to this named range, such
as =SUM(January), will display a #NAME? error value.
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Defining names automatically from the selection
If you select cells that contain values as well as row or column headings, you can let PlanMaker generate named
ranges automatically from these cells. PlanMaker then picks up the names from the headings.
To define names automatically:
1.

Select the desired cell range. It must contain both the values and the headings that will be used to create the
named ranges.

2.

Choose the menu command Worksheet > Names > Import.

3.

In the displayed dialog box, you can select which row and/or column contains the headings that will be used
for naming the ranges (see example below).

When you're done, click OK to confirm.
The names will now be created from the selected headings.

An example
To generate names automatically from the following table:

Select all values and all headings. Invoke the Worksheet > Names > Import menu command. Select which
row and/or column headings to use:
¡ If you select Top row, PlanMaker assigns the names "January", "February", and "March" to the cells below
them.
¡ If you select Left Column, PlanMaker names the cells to the right of "London", "Paris", and "Madrid" with
the corresponding name.
¡ If both options are selected, PlanMaker will create all six names.

Creating a list of all named ranges
PlanMaker can insert a list into the worksheet of all named ranges. This is useful if you want an overview of all
named ranges in the workbook and the corresponding cell addresses.
To insert a list of all named ranges defined:
1.

Select the cell where the list is to be inserted.
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Choose the menu command Worksheet > Names > Insert list.

A list of all named ranges will now be inserted in the table.

Putting named ranges to use
After creating named ranges with the Worksheet > Names menu command, the following very useful functions
become available:

Quickly selecting a named range
In the top-left corner of the worksheet window, you can see a dropdown list that displays the address of the
currently selected cell.

When you open this dropdown list, it will display a list of all named ranges. Clicking on one of these names
will select the corresponding cell range.

Using names in formulas
In formulas, range names can be used instead of the cell addresses they represent. This saves time and makes
formulas more coherent.
For example:
You have entered sales figures for January in cells A2 to A10. You have also assigned the name "January" to
this range of cells.
To sum up the sales, you simply type:
=SUM(January)
This method is also considerably more understandable than the default naming convention of =SUM(A2:A10).
Hint: The dialog box for the Insert > Function menu command has a Category list. One of the categories is
"Named ranges". Click on this category and you can quickly pick named ranges and insert them in formulas.
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Applying names in existing formulas
The Apply command in the sub-menu of the Worksheet > Names menu command is a useful helper for
applying named ranges: It scans all formulas within the selected cells and replaces every cell reference that has
a name assigned to it by the corresponding name.
You use this command as follows:
1.

Select the range of cells whose formulas you want to update. If you do not select anything, the entire table
will be affected.

2.

Choose the menu command Worksheet > Names > Apply.

3.

In the Names list, select all names you want to apply to the selected cells. Alternatively, click Select all to
select all names.

When you're done, click OK to confirm.
PlanMaker now updates all cell references within the selection. Any cell reference that has a name assigned to
it will be replaced by the corresponding name.
An example:
The name "January" is assigned to cells A2 to A10. One of the cells in the worksheet contains the formula
=SUM(A2:A10). Using the Worksheet > Names > Apply menu command, this formula will be automatically
updated to read as =SUM(January).

The "Also apply to relative references" option
In the dialog discussed above, you will find an option named Also apply to relative references. This option
should remain checked in most cases.
Some background information:
In PlanMaker, names always refer to cell ranges with absolute addressing (like $A$1:$A$10). But in most
calculations, users will be using relative addressing (like A1:A10).
If this option is checked, PlanMaker will convert relative cell references as well.
If it is not checked, PlanMaker will only convert absolute cell references.
For example:
Assume the range from A1 to A10 (more precisely: $A$1:$A$10) was named "January". If you apply the
Apply function to the formula =SUM($A$1:$A$10), this formula will always be converted to =SUM(January).
But if you apply it to the formula =SUM(A1:A10), the formula will be converted only if the option Also apply
to relative references is turned on.
For more information on absolute and relative cell addresses, see section Relative vs. absolute cell references.
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Sorting cells
The Worksheet > Sort menu command allows you to sort a cell range.

Proceed as follows:
1.

Select the cell range to be sorted.

2.

Choose the menu command Worksheet > Sort.

3.

At 1:, choose the Column you wish to sort on.

4.

Next to the column, you can choose the Order of the sorting: Ascending (A to Z) or Descending (Z to A).

5.

If required, you can choose additional columns to sort on at 2: and 3:.
For example, if you choose a column containing family names at 1: and a column with first names at 2:, the
cell range will be sorted by the family name – and then, in groups of identical family names, by the first
name.

6.

Make any further settings as required, see below.

When you confirm with OK, the cell range will be sorted accordingly.

Dialog options
The dialog box for this command has the following options:
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¡ Column and Order
Here, select the desired column(s) to determine the sorting sequence.
You also specify the sorting direction for each column: Ascending goes from A to Z, and Descending goes
from Z to A.
By default, up to 3 columns can be specified. If needed, you can even add additional columns – up to 64
columns. Proceed as follows:
Adding a column: Click the Plus icon to add an additional column at the respective position.
Appending a column: Click the Append button (below the list) to append a column at the bottom.
Removing a column: Click the Minus icon to remove the respective column.
¡ Sort row by row or Sort column by column
Determines whether PlanMaker sorts by row or by column.
¡ First row contains headings
If the first row or column of the selected cells contains a heading, enable this option. PlanMaker omits it
from the sorting.
Example: You have selected a list of postal addresses that you want to sort by row. The first line of your
selection contains headings such as "Name", "Street", "City", etc. The actual addresses are in the rows
below. If you turn on this option, the first row is not sorted along with the addresses, but stays on top.
¡ Case sensitive
If you check this option, sort terms that begin with lowercase letters will be placed above terms beginning
with uppercase letters. Otherwise, all sort terms that begin with the same letter will be grouped together,
regardless of the cases of the first letters.
Example:
Off: Apples, bananas, Cherries. On: bananas, Apples, Cherries.
¡ Sort including borders/shading
If this option is checked, cells moved by the sorting operation take their assigned border lines and shading
with them.
If not, the selected cell range keeps its original layout as far as borders and shading is regarded.

Transposing cells
The Worksheet > Transpose menu command exchanges the row and column order of the selected cells. Rows
become columns, and columns become rows.
Select the desired cells before you use this command.
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Important! Please note that transposing does not adapt any formulas or range names to the changes made to
cell addresses by transposing, neither inside nor outside the transposed range!

Distributing text into multiple columns
The Worksheet > Text to columns menu command allows you to distribute text entered in one table cell into
multiple columns. For example, if a cell contains a sentence, this command will move each single word into its
own column.
You apply this command as follows:
1.

Navigate to the cell containing the text to be distributed.
(If you want to distribute the text in multiple cells at once, select those cells.)

2.

Invoke the Worksheet > Text to columns menu command.

3.

A dialog box with several options is displayed (see below).
Normally, PlanMaker determines appropriate settings for this dialog automatically, so you don't have to care
about it.

4.

Click OK to confirm.

The text in the cell is distributed into multiple cells in the adjacent columns.

Dialog options
Hint: The best settings for this dialog are determined from the given cell content automatically. Normally, no
manual changes are required.
The dialog window for this command has the following options:
¡ Target range
If desired, you can enter a different target range here. If you do so, the distributed text will not be placed at
its original position, but at the specified target position.
It is sufficient to enter just the address of the cell in the top left corner of the target position.
¡ Separator
If required, you can specify which character PlanMaker should consider as a text separator here. For
example, if the cell contains the sentence "This is a test", PlanMaker automatically chooses blanks as
separators, which will move each word of the sentence into one column.
¡ Text marker
If the text in the cell contains text marker characters, use this option to specify which character has been
used (e.g. quotation marks).
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(Background info: The text export feature of some programs surrounds each data field with such a character,
in order to make it easy to determine where a data field begins and ends.)

Filtering cells by their contents
You can select a range of cells and filter this data based on a filtering condition. PlanMaker will hide all rows
that do not match the condition.
There are four commands for filtering data available in the sub-menu of the Worksheet > Filter menu
command:
¡ The AutoFilter command offers you different options to filter rows: When you select a cell range and
invoke this command, from now on, an arrow will appear on top of each column in this cell range. Clicking
on one of these arrows opens a dropdown menu where you can easily choose between the values contained
in the corresponding column – and other predefined filter conditions.
¡ The Special filter command opens a dialog box where you can formulate one or more filter conditions.
After clicking OK, the filter activates and hides all rows in the selected cell range that do not match the
chosen filter conditions.
¡ The Show all command makes all hidden rows visible again, rendering the effect of the Special filter as well
as the AutoFilter inactive.
¡ The Reapply filter command allows you to update also subsequently added values in the cell range of an
active AutoFilter (not possible for Special filter).
Detailed information on these three commands is provided on the following pages.

AutoFilter
Use the AutoFilter menu command to filter the rows of a table:
When you select a cell range and invoke the command Worksheet > Filter > AutoFilter, from now on, an
arrow will appear on top of each column in this range. Clicking on one of these arrows opens a dropdown menu
where you can easily choose between the values contained in the corresponding column – and various
predefined conditions that allow you to apply a filter to the cell range.
Hint1: The AutoFilter can only be inserted once per worksheet; two separate filters cannot be inserted on
one worksheet. Otherwise, you cancel the previously applied filter by selecting the AutoFilter menu
command again. However, on different worksheets it is quite possible to apply a separate AutoFilter.
Hint2: Newly added or updated values are not automatically sorted by the previously set filter conditions. To
integrate changed data into existing AutoFilter, use the menu command Reapply filter.
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Proceed as follows to apply the AutoFilter:
1.

Select the desired range of cells. Important: The first row of this range must contain headings for the data
below.

2.

Invoke the Worksheet > Filter menu command. In the resulting sub-menu, choose the AutoFilter
command.

The AutoFilter function is now enabled. Note the downward arrows in the first row of every column in the
selected range.
Clicking on one of these arrows will open a dropdown menu listing the contents of the current column, as well
as some other options. By default, all values in the list are selected, meaning that currently no filtering is taking
place.
To filter the data in the cell range, use this menu as follows:
¡ Sort ascending: Sorts the filter results of the applied AutoFilter area in ascending order.
¡ Sort descending: Sorts the filter results of the applied AutoFilter area in descending order.
¡ More filters: Text filters, Number filters and Date filters open a submenu with additional filters (see
below).
¡ (All): This menu entry is a useful placeholder: It allows you to add/remove all values the column contains
with just a single click.
A checkmark is displayed to the left of this entry to indicate that currently all cell contents are contained in
the filter.
When you click on the (All) entry now, all cell contents are removed from the filter (and the checkmark
disappears). When you click it again, all cell contents will be added to the filter again (and the checkmark
reappears).
If not all cell contents are included in the filter, but at least one cell content, a gray area is displayed instead
of the checkmark.
¡ (Blank): If you have empty cell contents in your column, you can use this selection to show/hide all empty
rows.
¡ List of the cell contents: The most important part: This part of the menu lists all cell contents that the
column contains. You can add/remove a value to the filter by clicking on it. A checkmark is displayed to the
left of all entries that are currently contained in the filter.
Note: For the last 3 described options (All), (Blank) and List of cell contents please always be aware: To
confirm your selection, you have to press OK.

Example
For example, to filter a cell range in a way that it shows only rows that contain the name "Smith" in a column
with the heading "Name", proceed as follows:
Select the cell range of interest (including the headings) and invoke the Worksheet > Filter > AutoFilter menu
command to activate the AutoFilter.
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A dropdown arrow will now appear next to each column heading. Click on the arrow for the column "Name" to
open the AutoFilter menu for this column.
First, click on the (All) entry in this menu in order to remove all cell contents from the filter. Then, choose the
menu entry "Smith" and press OK. Effectively, you have now created a filter condition "Name equals Smith"
using the AutoFilter function. All rows that do not match this condition will be hidden.
If, in addition, you would also like to have all rows with the name "Miller" listed, simply choose the menu entry
"Miller" as well. To remove the Millers again, click on the "Miller" entry once more to deselect it. Press OK to
confirm in each case.
As you can see, the entries in the AutoFilter menu can be combined in any possible way. Just click on an entry
to add it to the filter – or remove it.

More filters: Text filters, Number filters, Date filters
Depending on the format category of the filtered columns, PlanMaker automatically sets more filter options for
Text filter, Number filter, or Date filter in the AutoFilter menu. The Text filter is offered for text-only values
and the Date filter for date-only values. If the formats are mixed, the Number filter is applied.
Use the offered filter to obtain specialized filter conditions, for example:
Text filters:
¡ Equals... Display only rows with exact matches.
¡ Does not equal... Rows with exact matches are hidden.
¡ Greater than... Display rows with values that are alphabetically behind the entered filter value.
¡ Greater than or equal to... see above, but including the entered value.
¡ Less than... Display rows with values that are alphabetically before the entered filter value.
¡ Less than or equal to... see above, but including the entered value.
¡ Starts with... Display only rows with specific word beginnings.
¡ Doesn't start with... Rows with specific word beginnings are hidden.
¡ Ends with... Display only rows with specific word endings.
¡ Doesn't end with... Rows with specific word endings are hidden.
¡ Contains... Display only rows that contain specific strings as part of the text.
¡ Doesn't contain... Rows that contain specific strings as part of the text are hidden.
Number filters:
¡ Greater than... Works like the operator > . Display rows with values that are greater than the filter value
entered.
¡ Greater than or equal to...
equal to the filter value entered.
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¡ Less than... Works like the operator < . Display rows with values that are smaller than the filter value
entered.
¡ Less than or equal to...
to the filter value entered.
¡ Between... Display values of the rows which are defined in a number range.
¡ Not between... Hide values of the rows which are defined in a number range.
¡ Top 10... Display only rows where the value in this column is amongst e.g. the 10 highest (or lowest) values.
You can customize this selection when the Top 10... dialog box has opened: In the field on the left, choose
between Top or Bottom values. In the middle field, you can set the number of top/bottom values. In the righthand field, you can choose between absolute values (Items) and relative values (Percent).
An example: If you want to get 50% of the lowest values from 60 values given, then set the following:
Left field: Bottom Middle field: 50

Right field: Percent

¡ Only empty: Display only rows where the value in this column is empty.
¡ Non-empty: Display only rows where the value in this column is not empty.
¡ Above average: Display only rows where the value in this column is larger than the average value (of this
column).
¡ Below average: Display only rows where the value in this column is smaller than the average value (of this
column).
Date filters:
¡ Equals... Display only rows with exact date matches.
¡ Does not equal... Rows with exact date matches are hidden.
¡ Before... Display only rows in which the date values are earlier than the entered date value.
¡ Before or equal... see above, but including the entered value.
¡ After... Display only rows in which the date values are later than the entered date value.
¡ After or equal... see above, but including the entered value.
¡ Between... Display rows where the date values are within a defined date range.
¡ Not between... Hide rows where the date values are within a defined date range.
¡ Day, Week, Month, Quarter, Year: Here you can make further selections to quickly narrow down the
desired date ranges.
Note: If you have applied the AutoFilter to date values, you will notice in the dropdown list of the AutoFilter that the single days have already been
sorted at year and month level. Click on the plus sign in front of the year/month level to expand it and view the associated single values. If you have
now expanded the date "tree" and, for example, selected only single day values from a certain date level, in front of the associated date level
(month/year) a gray area appears instead of a checkmark. Only if all available values of a date level are selected, also a checkmark for this level
appears. If no value of a date level is selected, you will see a white area in front of it. This allows you to see at a glance whether all, none or single
values of a date level have been selected.

In addition, there are the following options for each of the offered filter methods Text filters, Number filters or
Date filters:
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¡ Custom filter: Open a dialog where you can define individual filter conditions.
¡ Delete filter: This option is only activated if criteria have been set via the Text filter, Number filter or Date
filter selection. Press Delete filter to remove exactly these filters.

Making all filtered rows visible again
To make all rows hidden by the AutoFilter visible again, invoke the Worksheet > Filter > Show all menu
command.

Reapply filter
If values in the cell range set by AutoFilter have changed, you can use the menu command Worksheet > Filter
> Reapply filter to update the selection you have already defined.
For example, you have specified that all rows with the name "Smith" should not be displayed and further entries
with this name were added afterwards. With the menu command Reapply filter you can filter out such
subsequently created entries again and you don't have to define the terms of the filter again from the beginning.
Of course, this function is especially helpful for dynamic formula and date values.

Deactivating the AutoFilter
To completely deactivate the AutoFilter, invoke the Worksheet > Filter > AutoFilter menu command once
again. The downward arrows displayed at the top of the cell range disappear, and all filtered rows will become
visible again.

Special filter
In addition to the AutoFilter introduced in the previous section, there are further options to filter the data in a
cell range by one or more combinable conditions much more complex: with the menu command Worksheet >
Filter > Special Filter.
Proceed as follows:
1.

Select the desired range of cells.

2.

Invoke the Worksheet > Filter menu command. Choose the Special filter command from the resulting submenu.

3.

A dialog box is displayed in which you can define one or more filter conditions (see below).

When you're done, click OK to confirm.
All rows that do match the filter conditions will now be hidden.
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Setting up filter conditions
To select one or more filter conditions in the dialog box of the Special filter menu command:
In the 1st condition group box, select the column to apply to the filter condition. In the middle dropdown list,
select the arithmetic operator. On the right, enter the value to compare against.
Some examples:
¡ The condition "Column D equals Los Angeles" only shows entries where column D contains the text "Los
Angeles".
¡ The condition "Column E greater than 100000" only shows entries where column E contains a value greater
than 100000.
If one condition is not sufficient for formulating your filters, you can set up to three filter conditions in the
Special filter dialog by filling out the group boxes 2nd condition and 3rd condition as well.
Using "wildcard characters": In conditions, the characters * and ? can be used as "wildcards": * represents any
number of arbitrary characters, and ? represents a single arbitrary character. For example, "M*er" would call
out "Mister", "Miller", "Mary's mother", etc., whereas "?ouse" would call out "mouse", "house", "rouse", etc.

Dialog options
The dialog box for the Special filter command offers the following options:
¡ Range contains headings
If the first row and/or column of the selected cell range contains headings, turn on this option. PlanMaker
will ignore this line or column while filtering.
¡ Case sensitive
If this option is checked, PlanMaker will distinguish between uppercase and lowercase letters in conditions.
For a condition such as "COLUMN A equals Smith", the condition will match only if the cell contains the
text "Smith". "SMITH" and "smith" will not be included in the filtering results.
¡ Mode
Determines whether rows or columns will be filtered.
Selecting Filter row by row, all rows will be filtered out that do not satisfy the filter condition.
Selecting Filter column by column, all columns will be filtered out that do not satisfy the filter condition.
¡ Results
Determines whether the filter will be applied to the actual data or a copy of it:
Filter at current position – Select this option and the original data will be filtered. Rows/columns that do
not satisfy the filter condition will be hidden at exactly that point where you set the filter.
Copy to position – If you choose this option instead, PlanMaker creates a copy of the original cells at a cell
address you specify. This copy contains only the filtered data and the original data remains unchanged in its
place.
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In the latter case, enter the cell address of the destination cell in the input field. You can either specify a
single cell address (which will be the starting point of the output range) or a cell range where the copy of the
data shall be placed. Copying to other worksheets is also possible. Caution: If the copy of the data is larger
than the cell range entered, cells will be cut off (exception: you enter a single cell address as the starting
point).

Making all filtered rows visible again
To make all rows hidden by a filter visible again, invoke the Worksheet > Filter > Show all menu command.

Analyzing tables
PlanMaker provides several tools that can be very useful for analyzing tables and detecting errors, including the
following:
¡ Displaying formulas instead of results
If the View > Show formulas menu command is activated, cells containing a calculation will display the
formula rather than the result.
¡ Syntax highlighting
If the View > Syntax highlighting menu command is activated, cells will be colorized according to their
content.
¡ Watch window for cell contents
The View > Watch window menu command displays a watch window for cell contents. It allows you to
observe the current values in the specified cells.
¡ Formula auditing
The Tools > Formula auditing menu command provides tools for displaying the relationships between cells
graphically. For example, if the current cell contains a formula that refers to other cells, you can let
PlanMaker display arrows pointing to these cells.
Apart from that, you can use this command to find errors in your table easily or to mark all invalid data with
red circles.
For detailed information, see the following pages.

Displaying formulas instead of results
If the View > Show formulas menu command is activated, cells containing a calculation will display the
formula rather than the result.
Invoke again to deactivate.
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Syntax highlighting
If Syntax highlighting is activated, cells will be colorized according to their content. For example, cells
containing an error are displayed in red; cells containing a formula are displayed in green, etc.
This is useful for visualizing which cells contain formulas, fixed values, etc., and where errors occur.

Activating and deactivating syntax highlighting
Choose the menu command View > Syntax highlighting to activate.
Choose again to deactivate.

What the foreground color indicates
When syntax highlighting is activated, cell contents are displayed in the following foreground colors:
Cell content

Foreground color

Error value

Red

Formula

Green

Fixed positive number

Dark blue

Fixed negative number

Light blue

Fixed logical value

Brown

Fixed text string

Black

What the background color indicates
Cells containing an error are displayed in red foreground color and shaded in one of the following background
colors:
Background color

Error type

White

Formula returns an error value. The calculation in this cell returns an error value (caused, for
example, by a division by zero).
Hint: If you click the cell, an error message is displayed in the status bar. Correct the formula
accordingly. For more information on error values, see section Error values.

Cyan

Syntax error in formula. The calculation in this cell has a syntax error (caused, for example, by a
missing parenthesis or missing arguments).
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Hint: If you click the cell, an error message is displayed in the status bar. Correct the formula
accordingly. If you don't correct the formula, it will be replaced by the text string #NULL! when
the document is saved!
Light gray

Function not exportable. The calculation in this cell uses an arithmetic function that cannot be
saved in the currently chosen file format.
Hint: Replace the function by a function that is compatible with the chosen file format. For more
information, see the corresponding function description in this manual.

Magenta

Function possibly imported erroneously. The calculation in this cell uses a PlanMaker 97
arithmetic function whose syntax or function might be incompatible with recent versions of
PlanMaker. This error only occurs when importing documents created with PlanMaker 97 (an
older version of PlanMaker).
Hint: See corresponding function description in this manual.

Yellow

Function unknown. The calculation in this cell uses an arithmetic function unknown to
PlanMaker. This error might occur when importing documents created with other applications (e.g.
Microsoft Excel).
Hint: Replace the function with a corresponding PlanMaker function. For a list of all PlanMaker
functions, see section Functions from A to Z, or this manual's index.

Watch window for cell contents
PlanMaker has an option to display a watch window for cell contents. It allows you to observe the current
values in the specified cells.

Activating and deactivating the watch window
Choose the menu command View > Watch window to activate the watch window.
Choose again to deactivate.

Editing worksheets

93

Adding cells to the watch window
To keep track of the value in a cell, add it to the watch window as follows:
1.

In the watch window, click on the Add cell button.

2.

Enter the address of the desired cell and confirm with OK.
Hint: You can also enter an entire cell range here. For example, if you enter A1:A3, the cells A1, A2, and
A3 will be added.

The content of the specified cells is now displayed in the watch window. Whenever the table is recalculated, the
watch window will be updated as well.

Removing cells from the watch window
To remove a cell from the watch window, select it in the watch window and click on the Remove cell button.
To remove all cells at once, use the Remove all button.

Formula auditing
The Tools > Formula auditing menu command provides tools for displaying the relationships between cells
graphically. For example, if the current cell contains a formula that refers to other cells, you can let PlanMaker
display arrows pointing to these cells.
Apart from that, you can use this command to find errors in your table easily or to mark all invalid data with red
circles.
When you invoke this menu command, a submenu with several commands opens. Broken down by subjects, the
following functions are available in this menu:
¡ Displaying the relationships between cells
Amongst others, the Tools > Formula auditing menu command provides commands that display the
relationships between cells graphically. For example, PlanMaker can display arrows to all cells that the
calculation in the current cell refers to. Thus, if a cell contains the formula =A1*A2, arrows to the cells A1
and A2 will appear.
¡ Selecting the cells related to a cell
There are also commands that allow you to select all cells the calculation in the current cell refers to. Or,
vice versa, all cells that depend on the current cell.
¡ Detecting errors in calculations
Furthermore, you can jump to the previous or next cell that contains an error value, and display arrows to the
sources of the error.
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¡ Detecting invalid data in cells
Finally, you can find cells whose content violates the input validation settings for the cell.
For detailed information on these topics, see the following pages.

Tip: Using the Formula auditing toolbar
The easiest way to access the functions provided by this command is to use the Formula auditing toolbar.

You can enable or disable this toolbar anytime by choosing the menu command Tools > Formula auditing >
Show "Formula audition" toolbar.
The icons in this toolbar represent the following functions (from left to right):
¡
¡
¡
¡
¡
¡

Trace predecessors
Remove traces to predecessors
Trace successors
Remove traces to successors
Remove all traces
Trace to error

¡ Mark invalid data
¡ Remove invalid data marks
¡
¡
¡
¡

Go to previous error
Go to next error
Go to previous invalid cell
Go to next invalid cell

Detailed information about the individual function of each icon is given on the following pages.

Displaying the relationships between cells
Amongst others, the Tools > Formula auditing menu command provides commands that can be used to
display the relationships between cells graphically.

To do this, navigate to the cell of interest and invoke one the following commands from the submenu of this
command:
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¡ Trace predecessors
This command displays an arrow to each cell that the calculation in the current cell refers to.
Example: If the current cell contains the formula =A1*A2, this command will display arrows pointing to the
cells A1 and A2.
¡ Remove traces to predecessors
Removes the arrows added with the above command for the current cell.
¡ Trace successors
Displays an arrow to each cell that refers to the current cell.
Example: If a cell contains the formula =B5*2, this command will display an arrow pointing to this cell
when you invoke it in cell B5.
¡ Remove traces to successors
Removes the arrows added with the above command for the current cell.
¡ Remove all traces
Removes all arrows added with the commands Trace predecessors or Trace successors for the entire
workbook.

Notes and tips
¡ If desired, you can invoke the commands Trace predecessors or Trace successors multiple times in a cell.
Another level of relationships will be displayed every time you do that.
¡ The tracer arrows displayed by the above commands are clickable. When you click such an arrow,
PlanMaker jumps to the cell at the other end of the arrow.
¡ If the current cell is referring to a cell located on a different worksheet, just a small arrow will be displayed
in the top left corner of the cell. Again, you can click this arrow to jump to the related cell.
¡ All tracer arrows pointing to a cell will be removed when you edit, move, or delete the cell.
¡ Tracer arrows also appear in the printout.
¡ However, the arrows are not stored in the document. Thus, when you save a document, close it, and open it
again, all arrows are removed.

Selecting the cells related to a cell
The Tools > Formula auditing menu command also provides commands that can be used to select the cells
related to the current cell.
To do this, navigate to the cell of interest and invoke one the following commands from the submenu of this
command:
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¡ Select predecessors
This command selects all cells that the calculation in the current cell refers to.
Example: If the current cell contains the formula =A1*A2, this command will select the cells A1 and A2.
¡ Select successors
Selects all cells that refer to the current cell.
Example: If any cell contains e.g. the formula =B5*2, this cell will be selected when you invoke the
command in cell B5.

Detecting errors in calculations
The Tools > Formula auditing menu command also provides commands that can be used to find and analyze
cells that return an error value.
Note: A cell returns an error value when the calculation it performs gives an illegal result. For example, if a
cell tries to perform a division by zero, the error value #DIV/0 will be displayed in the cell. (For more
information on error values, see the section Error values.)
To find and analyze such errors, use the following commands in the submenu of the Tools > Formula auditing
menu command:
¡ Trace to error
If the current cell contains an error value, this command will display arrows to the cells that cause the error
(if applicable).
Example: If a cell returns a #DIV/0 error value and you invoke the above command in this cell, arrows to the
cells that perform the division by zero will appear.
¡ Go to previous error
Jumps to the previous cell that contains an error value.
¡ Go to next error
Jumps to the next cell that contains an error value.

Detecting invalid data in cells
The Tools > Formula auditing menu command also provides commands that can be used to find cells that
contain invalid data.
Note: A cell contains invalid data if the Format > Input validation menu command has been used to specify
which values should be allowed in the cell, and the current cell content violates any of these rules.
To find such errors, use the following commands in the submenu of the Tools > Formula auditing menu
command:
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¡ Mark invalid data
This command paints a red circle around each cell (on the current worksheet) that contains an invalid value.
¡ Remove invalid data marks
Removes all circles added with the above command (from the current worksheet).
¡ Go to previous invalid cell
Jumps to the previous cell that contains an invalid value.
¡ Go to next invalid cell
Jumps to the next cell that contains an invalid value.

Notes
¡ The marks for invalid data also appear in the printout.
¡ However, the marks are not stored in the document. Thus, when you save a document, close it, and open it
again, all circles are removed.

Updating tables
The calculations in a document are kept up-to-date automatically. Whenever you change the content of a cell,
PlanMaker recalculates the entire workbook.
So usually you don't have to care about this.

Deactivating automatic updating
As needed, you can turn the automatic updating of calculations off. This can be useful when, for example, you
want to edit a complex workbook on a slow device.
For this purpose, change the setting of the Recalculation option in the document properties accordingly. See
section Document properties, Calculate tab for details.
When automatic updating is disabled, the calculations in the table have to be updated manually. You can use
the following key strokes or menu commands for this:
¡ To update the calculations on all worksheets, hit the F9 key or choose the command Tools > Recalculate
from the menu.
¡ To update the calculations only on the current worksheet, hit the Shift+F9 key combination.
Note: The latter can return outdated results in case the current worksheet contains calculations that refer
to cells on other worksheets.
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Updating external cell references
Please note that external cell references are not updated when a workbook is recalculated.
(External cell references are cell references that refer to cells located in a different workbook – for example
='C:\My Folder\[My Workbook.pmdx]Sheet1'!A1.)
Such cell references are updated automatically only once, when you open the document that contains them.
Apart from that, you can update them manually whenever needed.
For detailed information on this working with external references, see the section External cell references.

Inserting comments
Using the Insert > Comment menu command, you can attach a comment to the current cell, for example,
"Don't forget to update this value!".

Adding comments to cells
To add a comment, select the cell to which you want the comment to be attached and choose the menu
command Insert > Comment. A yellow box will appear allowing you to type in the applicable comment. When
done typing, click outside the yellow box or press the Esc key.
Comments are stored in the document and will be saved with the worksheet data.

Viewing comments
Cells with an attached comment have a yellow triangle in their top-right corner. When you point with the mouse
to such a cell, the comment will be displayed. To make it disappear, move the mouse outside the cell.

Editing comments
To modify a comment, go to the cell that contains the comment, choose the menu command Insert >
Comment, and apply your changes.
Hint: Alternatively, double-click the yellow triangle in the cell or press the keyboard shortcut Shift+F2 to
edit a comment.

Deleting comments
To remove a comment from a cell, go to the cell use the Edit > Delete special menu command. Choosing the
Comments option from the sub-menu will remove the comments from the selected cells.
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Goal-seeking
The Tools > Goal seek menu command can help you determine what value a certain portion of a calculation
must meet to extract a predefined result from the calculation.
Note: This is done by mathematical approximation, and as with all approximation methods, the result cannot be
guaranteed completely accurate.
Before executing this command, navigate to the cell that contains the calculation.

Upon executing the Tools > Goal seek menu command, a dialog box will open with the following options:
¡ In Formula cell, enter the address of the cell that contains the formula. (Generally this is preset by
PlanMaker.)
¡ In Target value, enter the desired result of the calculation.
¡ In Variable cell, enter the cell address of the cell in which PlanMaker will test different values until the
formula cell returns the desired result.
¡ In Accuracy, you can specify how close the result must match the desired target value. PlanMaker will
attempt to approximate values until the difference to the target value is smaller than Accuracy.
If PlanMaker is unable to find a sufficiently close result after some seconds, it will determine that the value
cannot be calculated through approximation and will abort the search.

An example
In the worksheet shown below, the SUM function has been used in cell A5 to add the numbers 1, 2, and 3 in the
cells A2, A3, and A4. The result in cell A5 is 6. The intent is to determine to which value cell A3 must be
changed so that the result of the addition is 7.
For this purpose, move the cell frame to the cell with the calculation whose result is to be modified; in this case,
cell A5 with the SUM formula. Then, choose the menu command Tools > Goal seek.
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Notice in the screenshot how to fill in the values in the dialog box. When you click OK, PlanMaker starts the
approximation process and displays the result 3 in a dialog box.
This means that the content of cell A3 must be changed from 2 to 3 so that the calculation has the result 7. If
you click the Use button, the found result will be copied into cell A3.

Scenarios
The Tools > Scenarios menu command allows you to create and display "scenarios".
Scenarios can be used to observe how the calculations in a worksheet change when the values in specific cells
are altered. This enables you to perform all kinds of "what-if" analysis.
Example: What effect on the total costs of a loan will it have when the duration is varied between 24, 36, and
96 months?
In this section you will learn everything you need to know about scenarios. The following topics are covered:
¡ Creating scenarios
¡ Viewing scenarios
¡ Managing scenarios
¡ Merging scenarios
¡ Creating a scenario summary
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Read the following pages for detailed information.

Creating scenarios
To create scenarios, first create a worksheet with the calculations that you want to analyze.
Then, proceed as follows:
1.

Invoke the menu command Tools > Scenarios.

2.

Click the Add button.

3.

Under Scenario name, enter a name that describes the purpose of the scenario.

4.

Under Changing cells, enter the address of the cell whose content is to be altered in the scenario.
You can also specify multiple cells by separating their addresses with semicolons – for example:
A2;A4;A10. Cell ranges (like B5:B10) are allowed as well.

5.

Click the Next button to continue.

6.

Another dialog appears. There, enter the value that is to be inserted into the "changing cell" in this scenario.
If multiple changing cells are defined in the scenario, the dialog displays a list of these cells. Click on each
list entry and enter the desired value for it.

7.

Click the Finish button to finalize this scenario.

8.

Repeat the steps 2. through 7. for all further scenarios that you want to add.

9.

When done, close the dialog with the Close button.

The scenarios have now been created. To learn how to display them, please read the next section.

Dialog options
In the dialog for adding scenarios, the following additional options are available:
¡ Comment
Allows you to enter a comment for the scenario.
¡ Prevent changes
When this option is enabled, the scenario can no longer be modified or deleted when you activate worksheet
protection.
¡ Hide
When this option is enabled, the scenario is no longer displayed in the list of scenarios when you activate
worksheet protection.
Hint: For general information on working with worksheet protection, see section Sheet protection.
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Viewing scenarios
When you have created scenarios, as described in the previous section, you can view them as follows:
1.

Invoke the menu command Tools > Scenarios.

2.

Select the desired scenario in the list.

3.

Click on the Show button.
Hint: Alternatively, simply double-click the scenario to display.

The chosen scenario will now be displayed.
By switching between the different scenarios that you have created, you can watch how the changes to the cells
specified in the scenario affect the calculations referring to those cells.
Note: When you display a scenario, the values in the given "changing cells" are physically replaced by the
values specified in the scenario. The old cell contents will be lost.

Managing scenarios
The Tools > Scenarios menu command can also be used to manage the scenarios defined in the current
worksheet.
For that purpose, the following buttons are available in the dialog for this command:
¡ Add
Adds a new scenario.
For details, see section Creating scenarios.
¡ Delete
Deletes the scenario selected in the list.
¡ Edit
Opens a dialog where you can edit the selected scenario. When you click on Next, another dialog appears
where you can edit the values for the changing cells.
¡ Merge
Merges scenarios that have been defined on other worksheets (or workbooks) into the current worksheet.
For details, see the section Merging scenarios.
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¡ Summary
Creates a scenario summary for all scenarios, where you can directly compare the values in the changing
cells as well as any "result cells" you define.
For details, see the section Creating a scenario summary.

Merging scenarios
The Tools > Scenarios menu command can also be used to merge scenarios that have been defined on other
worksheets (or workbooks) into the current worksheet.
Note: When using this function, make sure that all workbooks whose scenarios are to be merged have
exactly the same layout and use the same changing cells in their scenarios.
To merge scenarios, proceed as follows:
1.

Open the workbooks that contain the scenarios to be merged.

2.

Switch to the workbook and worksheet into which you want to merge the scenarios.

3.

Invoke the menu command Tools > Scenarios.

4.

Click the Merge button.

5.

Select the workbook and worksheet that contains the scenario(s) to be merged.

6.

Click OK to confirm.

7.

Repeat the steps 4. through 6. for all further scenarios that you want to merge.

The selected scenarios are now available in the current worksheet.

Creating a scenario summary
The Tools > Scenarios menu command can also be used to create a scenario summary for all scenarios defined
in the current worksheet.
A scenario summary is a table listing all scenarios well arranged side by side. For each scenario, the "changing
cells" are displayed alongside with any "result cells" that you specify (containing the calculations to be
observed).
Scenario summaries allow you to compare the changing values and the results of scenarios at a glance.
To create a scenario summary, proceed as follows.
1.

Create the desired scenarios (as described in the section Creating scenarios).

2.

Invoke the menu command Tools > Scenarios.
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3.

Click the Summary button.

4.

Enter the address of the desired "result cell". That is the cell that contains the calculation that you want to
observe in your scenarios.
You can also specify multiple cells by separating their addresses with semicolons – for example:
A2;A4;A10. Cell ranges (like B5:B10) are allowed as well.

5.

Click OK to confirm.

PlanMaker will now create a new worksheet and generate the scenario summary on it.
Note: Scenario summaries are not updated automatically when cell contents or scenario settings are changed.
To update a scenario summary manually, delete the worksheet containing the summary and create the
summary once again.

Consolidating data
The Worksheet > Data consolidation menu command allows you to evaluate data from multiple cell ranges,
for example, in order to calculate their total sums.
To do so, first you specify one or more "source ranges" for the consolidation. This can be any cell ranges
containing the data to evaluate. They can be located in just one worksheets altogether, or be spread over
multiple worksheets or even multiple files. For the evaluation, several statistical functions are available to
choose from: sum, minimum, average, etc.
The results of the consolidation are inserted – as fixed values – into the "target range" (which can be any cell
range). Note: The results will not be updated when you modify the values in any of the source ranges. This
command's main purpose is to evaluate the current state of data, not regarding any changes made to them later
(useful e.g. for monthly reports).
In this section, you will learn everything you need to know about working with consolidations. The following
topics are covered:
¡ Consolidating data by position
In the simplest case, data is consolidated by its position, as follows:
You have entered the data into e.g. three source ranges. They should be identical in size and structure. In all
three of them, each piece of data should have the same (relative) position.
When you let PlanMaker consolidate these cell ranges, it begins with calculating the sum of the first cell
(top left) in the first range, second range, and third range. Then, the same is done with all other cells in each
of the cell ranges.
¡ Consolidating data by labels
Alternatively, this command can consolidate data by its labels, as follows:
You have entered the data into one or more source ranges. All of them have one thing in common: a label
has been added to each value, for example in the cell left of the value.
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When you start a consolidation with such source ranges and activate the option Labels in left column,
PlanMaker calculates the sum of all values that have the same label on their left.
It doesn't matter in which order and how often each label appears within the source ranges. The size of the
source ranges is irrelevant as well. PlanMaker solely uses the labels to determine which values to sum up.
¡ Modifying and updating consolidations
Whenever you perform a consolidation with the Worksheet > Data consolidation menu command,
PlanMaker remembers each setting that you made in the corresponding dialog (separately for each
worksheet).
This allows you to invoke this command again anytime, change some settings if required, and run the
consolidation again.
For detailed information on these topics, see the pages that follow.

Consolidating data by position
As mentioned in the introduction of the section Consolidating data, the Worksheet > Data consolidation menu
command allows you to consolidate data from one or more cell ranges, for example, in order to calculate their
total sums.
In the simplest case, data is consolidated by its position, as follows:
You have entered the data into e.g. three "source ranges". They should be identical in size and structure. In all
three of them, each piece of data should have the same (relative) position.
When you let PlanMaker consolidate these cell ranges, it begins with calculating the sum of the first cell (top
left) in the first range, second range, and third range. Then, the same is done with all other cells in each of the
cell ranges.

Performing a consolidation by position
To consolidate data by position, proceed as follows:
1.

Enter the data to evaluate into one or more cell ranges of exactly the same size and structure. (The order of
the individual pieces of data must be identical in each range.)
The cell ranges can be located in just one worksheets altogether, or be spread over multiple worksheets or
even multiple files.

2.

Invoke the Worksheet > Data consolidation menu command.

3.

Click into the edit field below Source ranges. There, enter the address of the first cell range containing the
data to evaluate. (See also notes below.)
Hint: Alternatively, with the dialog still open, simply click into the table and select the cell range with your
mouse.

4.

Click on the Add button.

5.

To add additional source ranges, repeat the steps 3. through 4.
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At Target range, enter the address of the cell range where you want the results of the consolidation to be
inserted.
Hint: It is sufficient to specify just the address of the cell in the top left corner of the target range.
PlanMaker will then determine its size automatically.
Hint: You can simply click on the desired cell in the table to transfer its address into the dialog.

7.

At Function, choose the arithmetic function to be used for the consolidation.

8.

The options Labels in ... must be turned off for this kind of consolidation. (For more information, see
section Consolidating data by labels.)

9.

Click on Apply to start the consolidation.

The data from the source ranges is now consolidated using the chosen arithmetic function. The result is inserted
in the target range.
Note: The result of a consolidation is inserted into the table as fixed numbers. These numbers will not be
updated when you modify the values in any of the source ranges.
Accordingly, this command's main purpose is to evaluate the current state of data, not regarding any changes
made to them later (useful e.g. for monthly reports). See also section Modifying and updating consolidations.

Notes on specifying the source ranges
In the dialog of the Worksheet > Data consolidation menu command, the Source ranges control can be used
to add a source range in the following ways:
¡ Source range from the current worksheet
To add a cell range that is located in the current worksheet to the source ranges, simply enter its address or
name.
Example: D2:G5
Hint: Alternatively, with the dialog still open, you can click into the table and select the cell range with your
mouse.
¡ Source range from a different worksheet
To add a cell range that is located in a different worksheet, enter its address preceded with the other
worksheet's name and an exclamation mark.
Example: Table3!D2:G5
Hint: You can also select the cell range directly in the table with your mouse. Make sure that you have
clicked on the desired worksheet in the worksheet register first.
¡ Source range from a different document
To add a cell range that is located in a different document, enter its address the same way that external
references are entered (see section External cell references).
Example: 'C:\My Folder\[My Workbook.pmdx]Table3'!D2:G5
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Hint: You don't have to enter the first part of the address (folder and file name) by hand. When you click on
the Browse button in the dialog, a file dialog appears, allowing you to choose the desired file.
Don't forget to click on the Add button every time you have completed entering the address of a source range.

Consolidating data by labels
As mentioned in the introduction of the section Consolidating data, the Worksheet > Data consolidation menu
command allows you to consolidate data from one or more cell ranges, for example, in order to calculate their
total sums.
Apart from consolidating data by position (see previous section), data can also be consolidated by its labels, as
follows:
You have entered the data into one or more "source ranges". All of them have one thing in common: a label has
been added to each value, for example into the cell left of the value.
When you start a consolidation with such source ranges and activate the option Labels in left column,
PlanMaker calculates the sum of all values that have the same label on their left.
It doesn't matter in which order and how often each label appears within the source ranges. The size of the
source ranges is irrelevant as well. PlanMaker solely uses the labels to determine which values to sum up.

Performing a consolidation by labels
To consolidate data by its labels, proceed as follows:
1.

Enter the data into one or more cell ranges. Size and structure of these cell ranges don't matter. However,
each of the values to be consolidated should have a label – either in the column left of them, or in the row on
top of them.
The cell ranges can be located in just one worksheets altogether, or be spread over multiple worksheets or
even multiple files.

2.

Invoke the Worksheet > Data consolidation menu command.

3.

Click into the edit field below Source ranges. There, enter the address of the first cell range containing the
data to evaluate. (See also notes at the end of the previous section.)
Hint: Alternatively, with the dialog still open, simply click into the table and select the cell range with your
mouse.
Important: Each source range must contain both the values itself and their labels. The labels must be
placed in the leftmost column or in the top row.

4.

Click on the Add button.

5.

To add additional source ranges, repeat the steps 3. through 4.

6.

At Target range, enter the address of the cell range where you want the results of the consolidation to be
inserted.
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Hint: It is sufficient to specify just the address of the cell in the top left corner of the target range.
PlanMaker will then determine its size automatically.
Hint: You can simply click on the desired cell in the table to transfer its address into the dialog.
7.

At Function, choose the arithmetic function to be used for the consolidation.

8.

Under Options, specify the position of the labels in the source ranges:
Labels in left column: The labels are stored in the leftmost column of each source range. (In that case, the
corresponding values must be stored directly at the right of the labels.)
Labels in top row: The labels are stored in the top row of each source range. (In that case, the
corresponding values must be stored directly below the labels.)
You can also check both options, in case you want to evaluate source ranges that have labels in their
leftmost column and in their top row.
When you activate the Sort labels option, the results of the consolidation in the target range will be sorted
according to the labels.

9.

Click on Apply to start the consolidation.

The data from the source ranges is now consolidated using the chosen arithmetic function. The result is inserted
in the target range.
Note: The result of a consolidation is inserted into the table as fixed numbers. These numbers will not be
updated when you modify the values in any of the source ranges.
Accordingly, this command's main purpose is to evaluate the current state of data, not regarding any changes
made to them later (useful e.g. for monthly reports). See also section Modifying and updating consolidations.

Modifying and updating consolidations
Whenever you perform a consolidation with the Worksheet > Data consolidation menu command, PlanMaker
remembers each setting that you made in the corresponding dialog (separately for each worksheet).
This allows you to invoke this command again anytime, change some settings if required, and run the
consolidation again.
Hint: The settings are even stored in the document, so that PlanMaker remembers them the next time you
open the document.
(There's one little limitation: The Target range is not stored in xls files, since the file format doesn't support
it. It is only stored in xlsx files, pmd files, and pmdx files.)

Modifying the settings of a consolidation and executing it again
To change the settings of a consolidation and then insert its updated results again, proceed as follows:
1.

Invoke the Worksheet > Data consolidation menu command.
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2.

Modify the settings of the consolidation at will. You can even add new source ranges or remove existing
ones.

3.

Click on Apply to confirm your changes and update the results.

The consolidation in the current worksheet is now performed again, and its updated results are inserted into the
target range. Existing data will be overwritten.

Updating the results of a consolidation
If you just want to update the results of a consolidation (without changing any settings), proceed as follows:
1.

Invoke the Worksheet > Data consolidation menu command.

2.

Click on Apply to confirm your changes and update the results.

The consolidation in the current worksheet is now performed again, with the same settings as before.

Tables in worksheets
The Worksheet > New table menu command allows you to create a "table" in a worksheet.
Note: The fact that this feature is named "table" may be a bit confusing, since the term "table" is often used
to represent the content of a worksheet in general. However, since Microsoft has called this feature a "table"
in Excel, we decided to keep this term in PlanMaker for compatibility reasons.
So, how exactly does this feature work?
When you can select a cell range and invoke the Worksheet > New table menu command, PlanMaker will
create a "table" from it.
This has the following effects on the cell range:
¡ Automatic formatting with a "table style"
The selected cell range is reformatted automatically with a so-called table style. The default table style
changes the background color of the table's rows to blue/white color. You can switch to a different table
style anytime in order to change the appearance of the entire "table" at once.
¡ AutoFilter applied automatically
Apart from that, an AutoFilter is applied to the cell range that was used to create the "table". The AutoFilter
adds little arrows to the right of each of the column headings in the table. When you click on one of these
arrows, a menu opens, allowing you to set a filter on the cell contents living in the corresponding column.
¡ Total row
In "tables", you can easily activate a total row displayed below the table. The total row can display
calculations summing up the values contained in the table (e.g. the sum of each column).
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¡ Special cell references
When you have created a "table" in a worksheet, you can make use of special types of cell references. For
example, the cells in a certain table column can be addressed via its column heading – as in:
=SUM(Table3[Spring])
More information on the "table" feature can be found on the next pages. The following topics are covered:
¡ Creating tables in worksheets
¡ Removing tables in worksheets
¡ Editing tables in worksheets
¡ Formatting tables in worksheets
¡ Using the total row of tables in worksheets
¡ Tables in worksheets and cell references
See the next pages for details.

Creating tables in worksheets
As described in the introduction of the section Tables in worksheets, the menu command Worksheet > New
table allows you to have "Tables in worksheets". Below you will learn how to create such a table.
To create a "table in a worksheet", proceed as follows:
1.

Optional: In a range of adjacent cells, enter the data that you want to create a table from.
Hint: It is recommended to add column headings for each column in the first row of that cell range. (If
there are no column headings, PlanMaker will generate automatic headings named Column1, Column2,
etc.)

2.

Select the cell range (including the column headings).

3.

Invoke the Worksheet > New table menu command.

4.

A dialog box with the following options opens:
Source range: The cell range that the table is created from. The currently selected cells are suggested by
default – so, unless you want to specify a different cell range, all you have to do is confirm this.
Source range contains titles: Here you can specify if the first row in the source range contains column
headings, as recommended above. When you turn this option off, PlanMaker will generate automatic column
headings named Column1, Column2, etc.

As soon as you confirm, a "table" is created from the specified source range. In detail, the following actions are
performed:
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¡ No changes are made to the table cells and their contents
Nothing special happens to the cells living inside the source range. They remain ordinary table cells after
creating the table – you can edit them, format them, etc. just like before.
¡ Automatic formatting with a "table style"
However, you can easily spot a change in the format of the cells contained in the source range: By default,
the first row (containing the column headings) is shaded in a medium blue, and the cells below are shaded in
light blue and white.
A so-called table style is responsible for this. Whenever you create a table, it is automatically reformatted
with the default table style. However, there are a lot of other table styles available to choose from. To apply
a different table style, choose it in the dialog of the Worksheet > Table > Table settings menu command.
¡ AutoFilter applied automatically
Apart from that, you can see that a small arrow is now displayed to the right of each cell in the first table
row. These arrows indicate the presence of an AutoFilter that has been added to the table cells
automatically.
By default, the filter is off and all data in the table is shown. When you click on one of the little arrows, the
menu of the AutoFilter for the current column opens. In this menu, you can apply different kinds of filters –
and even sort the table data.
Detailed information on AutoFilters can be found in the section AutoFilter.

Removing tables in worksheets
As described in the introduction of the section Tables in worksheets, the menu command Worksheet > New
table allows you to create "Tables in worksheets". Below you will learn how to remove such a table.
There are two options for this:

A) Converting a table back to a normal cell range
To convert a table back to an "ordinary" range of cells, move the cell frame to any cell inside the table and
invoke the menu command Worksheet > Table > Convert to range. In the following dialog click on the
checkbox Remove all formatting from the cells.
This will remove the "magic" of the table features from all cells that were part of the table – including the
automatic formatting and the AutoFilter.

B) Deleting a table with its entire content
To delete a table, including its entire content, move the cell frame to any cell inside the table and invoke the
menu command Worksheet > Table > Delete table.
This will delete the entire table, including the content of all cells that were part of it.
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Editing tables in worksheets
As described in the introduction of the section Tables in worksheets, the menu command Worksheet > New
table allows you to create "Tables in worksheets". Below you will learn how to edit such a table.
The following procedures can be performed with tables:

Adding another row or column
"Tables in worksheets" can easily be extended by another row or column, as follows:
¡ When you enter a value into a cell that is located directly to the right of a table, the table is extended by
another column automatically.
¡ When you enter a value into a cell that is located directly below a table, the table is extended by another row
automatically.
(Note: This only works when the total row for the table is turned off.)
Hint: The above two methods for expanding tables can be disabled in case they are not wanted. To do so,
disable the option Expand tables automatically in the dialog of the Tools > Options menu command,
Edit tab.
¡ When you press the Tab key in the last cell of a table (i.e. the cell at its bottom right), another row is added
to the table automatically. This works here even if the total row is turned on, it is automatically moved by
one row.

Changing the size of a table
The size of a table can be changed in either of the following ways:
¡ A little arrow is displayed in the bottom right corner of tables. When you drag this arrow around with your
mouse, the table is resized accordingly.
¡ When you invoke the menu command Worksheet > Table > Table range, a dialog opens, allowing you to
edit the cell range covered by the table.
¡ You can also invoke the context menu by right-clicking in the table and edit the cell range using the menu
command Modify table area.

Inserting rows or columns
To insert an additional row inside (and only inside) a table, proceed as follows:
1.

Move the cell frame to a cell within the table.

2.

Invoke the menu command Worksheet > Table > Insert > Insert rows above or Insert rows below.

This will add a new row above – or below – the current table cell.
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Note: The new row will be added only inside the table – the cells outside the table are not affected.
Adding a new column can be achieved with the same procedure (using the menu commands Worksheet >
Table > Insert > Insert columns at left or Insert columns at right respectively).

Deleting rows or columns
To delete a row inside (and only inside) a table, proceed as follows:
1.

Move the cell frame to any cell within the table row to be deleted.

2.

Invoke the menu command Worksheet > Table > Delete > Delete rows.

This will delete the corresponding row (including its content) from the table.
Note: The row will be deleted only inside the table – the cells outside the table are not affected.
Deleting a column can be achieved with the same procedure (using the menu command Worksheet > Table >
Delete > Delete column).

Selecting cells in a table
Cells living in a table can be selected like all other cells, using either keyboard or mouse.
Apart from that, there is a menu command provided to make selecting cells inside a table easier: the command
Worksheet > Table > Select. It has a sub-menu with the following commands:
¡ Select rows: Selects the current table row.
¡ Select columns: Selects the current table column.
¡ Select column data: Selects just the cells containing data in the current table column – column headings
and cells located in the total row will not be included in the selection.
¡ Select table: Selects the entire table.

Formatting tables in worksheets
As described in the introduction of the section Tables in worksheets, the menu command Worksheet > New
table allows you to create "Tables in worksheets". Below you will learn how to modify the formatting and other
properties of such a table.
First of all, the cells in a table can be formatted just like any other cell, using the entire palette of commands
and options that PlanMaker provides for this.
Apart from that, there is a command offering additional formatting options exclusive for tables: the command
Worksheet > Table > Table settings.
This command can be applied as follows:
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Move the cell frame to any cell within the table.

2.

Invoke the menu command Worksheet > Table > Table settings.

3.

A dialog box with the options described below opens. Make the desired changes and confirm with OK.
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The following settings can be modified in the dialog:

Applying a different table style
The first tab of the dialog contains a listbox named Style where you can choose a table style for the table.
Applying a different table style changes the entire appearance of a table. Primarily, table styles modify the
background colors of the table's rows and columns. The little preview images shown in the list give you an
impression which colors each of the styles will apply.

Showing/hiding header row and total row
Below the Style list, there are more options for customizing the appearance of a table. The first two options
have the following function:
¡ Header row
This option turns the header row (displayed above the table) on/off. The header row displays a column title
for each of the columns.
In the header row, you can also see a small arrow displayed to the right of each of the column titles. These
arrows indicate the presence of the AutoFilter that is applied automatically to each table. To filter data, click
on one of these little arrows. A menu opens, allowing you to choose from different kinds of filters for the
values in the corresponding column. Detailed information on AutoFilters can be found in the section
AutoFilter.
¡ Total row
This option turns the total row (displayed below the table) on/off. The total row displays calculations
summing up the values contained in the table columns.
By default, the total row calculates just the sum of the values in the rightmost column of the table. However,
when you click on one of the cells in the total row, a little arrow appears to its right. This arrow opens a
menu where you can choose which kind of calculation the cell should perform. This allows you to calculate
the sum, average, and other calculations for any given table column. For details, see section Using the total
row of tables in worksheets.

Additional formatting options for table styles
The other options on the Style tab have the following purpose:
¡ Banded rows and Banded columns
This option turns the alternating background colors for the table's rows and columns on/off. (Hint: To
change the colors, pick a different table style, as described above.)
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¡ First column and Last column
When you activate this option, the first/last column in the table will be emphasized.
With most table styles, this option will turn on boldface for the text in the respective column. However,
some table styles additionally change the background color – this depends on the table style definition.

Extended properties on the "Properties" tab
The Properties tab in the dialog box contains extended properties for tables, as follows:
¡ Name
Here you can change the name of the table.
The name of a table can be used in cell references (see section Tables in worksheets and cell references).
Please note that the following rules apply for table names:
1. Table names must be unique.
2. Table names must always begin with a letter or an underscore.
3. Table names must not contain blank spaces or other invalid characters. (For maximum compatibility, it is
recommended to use solely letters, numbers, and underscores.)
4. Table names must not be structured like cell references (e.g. A1).
¡ Title and Description
Here you can specify a title and a short description for the table.
This makes it easier to process your worksheet for people who are blind or have low vision and therefore use
tools like a screen reader.

Using the total row of tables in worksheets
As described in the introduction of the section Tables in worksheets, the menu command Worksheet > New
table allows you to create "Tables in worksheets". Below you will learn how to make use of the "Total row" in
tables.
Tables are able to display a so-called Total row below its content. It displays calculations summing up the
values contained in the table columns. The Total row can be activated/deactivated anytime.
By default, the Total row displays the text "Total" and the sum of the values in the right-most column.
However, you can always edit the total row in order to perform different/additional calculations, as described
below.

Turning the total row on or off
To activate the total row for a table, proceed as follows:
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Move the cell frame to any cell within the table.

2.

Invoke the menu command Worksheet > Table > Table settings.

3.

Activate the option Total row on the Style tab and confirm with OK.
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The total row is now displayed below the table.
To turn the Total row off again, deactivate this option.

Customizing total rows
By default, the total row displays the text "Total" and the sum of the values in the right-most column.
However, you can edit the cells in a total row just like any other cell in a worksheet, and thus enter your own
formulas or text.
A little helper is available for adding calculations that total the values in a column: When you move the cell
frame to any cell in the total row, a little arrow appears to its right. Clicking on this arrow opens a menu
offering different types of statistical functions (sum, average, etc.). When you pick e.g. the "Sum" entry,
PlanMaker inserts a formula that calculates the sum of the corresponding column.

Tables in worksheets and cell references
As described in the introduction of the section Tables in worksheets, the menu command Worksheet > New
table allows you to create "Tables in worksheets". Below you will learn more about the special types of cell
references that are available with cells that live in a table.
Namely, apart from the usual types of cell references, the cells inside a table can also be addressed using names
and special specifiers, as detailed below:

Using names
Names can be used in cell references to cells in a table as follows:
¡ Addressing tables by their name
When you use the name of a table in a cell reference, it represents the entire table (with all of its cells,
except for the header row and the total row).
Example:
=SUM(Table3) returns the sum of all cells in the table named "Table3".
Hint: The name of a table can be changed in the dialog of the Worksheet > Table > Table settings menu
command (Properties tab).
¡ Addressing table columns by their column heading
To address a single table column in a cell reference, enter the name of the table, followed by the column
heading enclosed in brackets.
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Example:
=SUM(Table3[Spring]) returns the sum of all cells living in the column with a column heading "Spring" in
a table named "Table3".
¡ Addressing adjacent table columns
To address a series of adjacent table columns, use the notation [[FirstColumn]:[LastColumn]].
Example:
=SUM(Table3[[Spring]:[Autumn]]) returns the sum of all cells living in the columns "Spring" through
"Autumn" in the table.
¡ Addressing non-adjacent table columns
To address multiple non-adjacent table columns, separate them with a comma instead of a colon.
Example:
=SUM(Table3[Summer],Table3[Winter]) returns the sum of the columns "Summer" and "Winter".
Note that in this case the name of the table has to be specified for each column.

Using specifiers
Apart from names, special specifiers that represent a certain component of a table can be used in cell references
with tables.
Specifiers must be entered behind the table name, enclosed in brackets. For example, the cell reference
Table3[#Totals] represents all cells in the total row of the table named "Table3".
The following specifiers are available:
¡ #All: Represents the entire table – including header row and total row, for example: Table3[#All].
¡ #Data: Represents the cells in a table that contain actual data, i.e. all cells except header row and total row.
¡ #Headers: Represents all cells in the header row (the row containing the column headers).
¡ #Totals: Represents all cells in the total row. (Note: If the total row is deactivated, the cell reference will
return a #REF! error value.)
¡ @[ColumnName]: Represents the cell that is in the same row of the specified column. This is useful
especially for calculations within a table.
For example, a cell reference like [@Spring] used in a table stands for the cell that is located is the same
row of the column with the title "Spring".
Example:
=SUM([@[Spring]:[Winter]]) returns the sum of those values in the columns "Spring" through "Winter"
that are in the same row as the cell where this calculation was entered.
Note: PlanMaker does not distinguish between uppercase and lowercase letters in specifiers.
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Pivot tables
Besides the normal tables (see chapter Tables in worksheets), there are also Pivot tables. You can create a pivot
table using the menu command Worksheet > New pivot table based on your existing source data.

What exactly is a pivot table?
A pivot table is an optimal tool for displaying large amounts of data in a meaningful form. The generated pivot
data can be structured, summarized, filtered and analyzed according to different perspectives. The source data
remains unaffected.
Reports using pivot tables are particularly suitable for data sets with many different elements and criteria,
which are predominantly similar and interdependent, such as sales reporting.
In addition to clarity, pivot tables are much better suited for data analysis than "normal" tables. If you would
like to ask complex questions about extensive data, e.g. "How many sales did an employee make for which
articles at what time," it will be quite laborious if you would extract this information directly from a normal
table. You would have to sort the data records first, then filter them, use commands and finally prepare them.
Pivot tables save you many work steps and give you a much better presentation of the desired information.
Data resources can be edited both directly from your PlanMaker worksheet and also via import from external
PlanMaker and Microsoft Excel files.

Pivot tables illustrated by an example
The modes of operation of pivot tables are illustrated here with a simplified example, which is used throughout
the chapter for description purposes.
Here you can see sample data records in PlanMaker from which a pivot table has to be created. The company
employees had various expenses for their breakroom supplies throughout the year. Some employees, as well as
some orders, appear several times in the respective columns.

Source data for the pivot table
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Hint: Number formatting of the source data is not applied to pivot tables. For information on formatting
values in the created pivot table, see section Value settings (Values area).
Following an example for a pivot table: Here, the Employees are clearly listed with the sums of their orders and
the Grand total of all expenses.

Variant 1 of a pivot table (view of the employees)

But this pivot table can also be created: Here the Orders are arranged in a totaled overview.

Variant 2 of a pivot table (view of the orders)

Above all, the possibility of grouped arrangement shows the great advantages of pivot tables: Here, Employees
and Orders are displayed together and nested in one overview. overview.

Variant 3 of a pivot table (view of employees with grouped orders)

It can be seen from these examples that, depending on the question addressed to the existing data, different
statements can be made with pivot tables.
The following sections clarify how to get different perspectives on pivot data and what settings you can make to
obtain a suitable presentation of your results:
¡ Creating a new pivot table
¡ Starting with the pivot table field list
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¡ Configuring pivot tables with the field list
¡ Sorting and filtering pivot tables
¡ Updating pivot tables and changing data area
¡ Deleting, copying, moving pivot tables

Creating a new pivot table
To create a pivot table, you must have data records to which a pivot table can be applied.
Using the menu command Worksheet > New pivot table you can generate a pivot table from any given source
data.
Please note a few important rules for the existing source data. Some of the requirements are not mandatory, but
they are helpful for practical use:

Requirements for source data
¡ The columns of the source data must have headings.
¡ Headings must appear in one single row, not one under the other.
¡ Headings must be unique, duplicate names for the headings must not occur.
¡ There must be no empty rows or columns and no merged cells in the source data.
¡ The data under the respective column headings must be of the same data type (number, text, or date – not
mixed).
¡ If possible, the data should be available in its raw form; no formulas, summarizations, subtotals, or other
prepared data should have been applied to them previously.
You can either use existing records in the current workbook as source data or import data records from another
file (possible formats: PlanMaker and Excel).
Please read the next two sections:
¡ Creating a pivot table with existing data
¡ Creating a pivot table with imported data

Tip: Pivot tables can also be generated from Tables in worksheets. To do this, select a cell of the table and
select Worksheet > Table > Create pivot table, or right-click in the table to open the context menu and use
the menu command Summarize as pivot table. After that, proceed with the next steps to create a pivot table
as described in the next section.
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Creating a pivot table with existing data
If the source data is already in the current workbook, proceed as follows:
1.

Select the entire data area. You can also select only one cell from the source data. PlanMaker automatically
extends the selection to the entire corresponding area.

2.

Select Worksheet > New pivot-table. The following dialog box appears:

3.

Source range: The cell area with the existing data from which the pivot table has to be generated. Here, the
source range is already defined by your previous selection and can therefore be adopted. If you still want to
change the source range, you can enter the correct cell range in the input field or simply select the correct
cell range directly in the worksheet with the mouse.
Tip: If you have previously given the data area a name (see Named ranges), you can simply enter this
name in the input field. An advantage of this procedure is that you only have to customize the Named
range if the source data changes.
With the Browse... button you can also import external data. For more information, see the section Creating
a Pivot table with imported data.
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Target range: Here you can decide where the pivot table should be created. Now choose between the
following options:
New worksheet: The pivot table will be created in a new worksheet that is automatically generated by
PlanMaker. You can adjust the proposed target in the lower input field.
Existing worksheet: The pivot table will be created in an existing worksheet. This can be the worksheet
containing the source data or another existing worksheet. Please make sure that you first activate the
Existing worksheet button and then click with the mouse on a cell in a free area in the desired worksheet. Or
type the target range into the lower input field.
Tip: For pivot tables with large amounts of data, it is recommended to use a new worksheet rather than the
worksheet with the source data, as it can quickly lead to a lack of space. If there is only a small amount of
data - as in our example - it is useful to display the pivot table in the same worksheet next to or below the
source data.

5.

Confirm with the Insert button to create the pivot table.

If you created the pivot table in the same worksheet as the source data, the result should look like this:

On the left side you can still see the Source data, next to it on the right the (still blank) Pivot table report, and
rightmost in the sidebar the Pivot table field list or just Field list. It is the central control of the pivot table. By
selecting the elements from the field list, you fill the blank pivot table with content according to your
requirements.
Read more about the structure and handling of the field list in the section Starting with the Pivot Table field list.

Creating a pivot table with imported data
You can also import data records from other PlanMaker files or Microsoft Excel files to create a pivot table. To
do this, proceed as follows:
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Select Worksheet > New pivot-table. The following dialog box appears:

2.

Source range
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In the file browser, locate the file with your source data and confirm with Open.
The input field below Source range displays the file path with the file name and a proposed worksheet with
a cell area.
Here you have to adjust the desired cell range precisely. PlanMaker does not automatically extend the cell
range to corresponding data records when importing from external files.
Example: Your source data is in the file Pivot.pmdx in the worksheet Sheet1, and the cell range of your
source data records is from A1 to D11.
The syntax in the input field is then: 'filepath\[Pivot.pmdx]Sheet1'!$A$1:$D$11
Tip: If you have previously named the range of source data in your external file (see Named ranges), you
can avoid entering the cell range exactly. A further advantage of this procedure is that you have to adjust
the named range only when making changes to the data records. Call up the name of the named range in
the input field using the following syntax: 'filepath\[filename]'!name
3.

Target range: Here you can decide where the pivot table should be created:
New worksheet: The pivot table is created in a new worksheet that is automatically generated by
PlanMaker. You can adjust the proposed target in the lower input field.
Existing worksheet: The pivot table will be created in an existing worksheet. This can be the worksheet
containing the source data or another existing worksheet. Please make sure that you first activate the
Existing worksheet button and then click with the mouse on a cell in a free area in the desired worksheet. Or
type the target range into the lower input field.

4.

Confirm with the Insert button to create the pivot table.

You should now see a (still blank) Pivot table report in the worksheet and the Pivot table field list or simply
Field list on the right in the sidebar. It is the dialog and the central control of the pivot table. By selecting the
elements from the field list, you fill the blank pivot table with content according to your requirements.
The following sections explain the structure and handling of the pivot table field list.

Editing worksheets

124

Starting with the pivot table field list
Once you have created a pivot table, the Field list appears on the right side of the sidebar with the upper Fields
section and the lower Areas section. It is the central element of a pivot table because here you control which
data is displayed in the target range of the pivot table (the Pivot table report) and how the data is arranged.
Hint: The field list is displayed only when you place the mouse pointer in the pivot table report.

Structure of the field list

On the left the still blank pivot table report; on the right the field list with the "Fields" section above and the "Areas" section below.

Fields section: In the upper part of the field list, the headings from the columns of the source data are grouped
in their original sort order. The order of the columns from left to right in the source data corresponds to the
order from top to bottom in the fields section. These elements are not called "Columns" here, but "Fields."
Areas section: In the lower part of the field list, you can drag the fields from the upper fields section.
Depending on how these fields are arranged, you can define the structure of the pivot table. As soon as you
have placed at least one field in one of the 4 areas of the areas section, results appear in the pivot table report.
The areas section is divided into the following 4 individual areas:
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¡ Row Labels
If you drag a field into this area, the data from this field is grouped by rows in the pivot table report. In this
context, grouping means that identical elements from a column of the source table appear only once and are
totaled. You can also drag several fields into this area; the added fields then also form further subgroups line
by line. The field that appears at the top of the row labels is the higher-level sort criterion. Fields further
down are treated as lower-level and are displayed in the pivot table report according to this structure.
¡ Column Labels
Same procedure as for row labels, but grouping is by columns.
¡ Values
This is the most important area: The data records of the field dragged here are summarized in the pivot table
report, for example, amount totals. This is why fields with numbers usually appear here.
¡ Report filter
Allows you to show and hide selected data records in the pivot table report, based on the field that is
inserted in the report filter (see also Sorting and filtering pivot tables).
Tips for displaying the field list: Adjust the width of the field list according to your requirements by
dragging the mouse pointer at the inner edge of the sidebar. To show or hide the field list, click on the
narrow vertical button with the small arrow at the edge of the sidebar. Select View > Pivot table sidebar >
Show at left/Show at right to change the display side of the field list.
In the next sections you will find practical information on how to use the field list.

Exercises using the field list
You have already created a pivot table using the menu command Worksheet > New pivot table. The field list
with the fields section and the areas section is on the right-hand side, but the target range of the pivot table (the
pivot table report) is still blank.
This section explains step-by-step how to drag items from the fields section to the areas section in the field list,
in order to display significant results with different characteristics in the pivot table report.
If you are already familiar with the structure of a pivot table, you can skip this section.
Tip 1: You can drag the fields to the desired area with the mouse. It is also possible to place a checkmark in
front of the relevant field in the fields section. PlanMaker then automatically assigns the field to an area in
the areas section. Fields with numbers are placed in the values area; all other formats, such as text and date,
are placed in the row labels area.
Tip 2: Fields can be dragged back and forth not only between the fields section and the areas section, but
also between the individual areas of the areas section and within the areas themselves, so you can easily
swap the position of the fields.
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Exercise 1: Adding a field to the "Values" area
In the fields section, place a checkmark in front of the Amount field, or drag the field with the left mouse button
down directly to the Values area of the areas section.

On the left the unchanged source data, in the middle the result of the pivot table, and on the right the field list with the selection of the fields for
Exercise 1

¡ The field element "Sum of Amount" appears in the Values area of the field list.
¡ In the pivot table report, the value field with the header "Sum of Amount" now appears instead of the blank
report.
¡ All items from the Values field are summed up to a grand total in the pivot table report.

Exercise 2: Adding a field to the "Row labels" area
Now place an additional checkmark in front of the Employee field in the fields section or drag the field with the
left mouse button down directly to the Row labels area.

On the left the result of the pivot table, and on the right the field list with the selected fields for Exercise 2
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¡ The field element "Employee" appears in the Row labels area of the field list.
¡ In the pivot table report, a row field with the header "Row labels" is displayed and the employees are
arranged by rows. Each name appears only once here.
¡ The value field with the header "Sum of Amount" in the pivot table report displays the expenses summed up
and broken down by employee.

Exercise 3: Adding a field to the "Column labels" area
You can also display the result by columns instead of by rows. To do this, drag the same Employee field to the
Column labels area.

On the left the result of the pivot table, and on the right the field list with the selected fields for Exercise 3

¡ The field element "Employee" appears in the Column labels area of the field list.
¡ In the pivot table report, a column field with the header "Column labels" is displayed and the employees are
arranged by columns. Each name appears only once.
¡ The expenses are summed in the pivot table report in the value field "Sum of Amount" and broken down by
employee.

Exercise 4: Adding a second field to the "Row labels" area
Drag the Employee field back into the Row labels area, and now place an additional checkmark in front of the
Order field.
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On the left the result of the pivot table, and on the right the field list with the selected fields for Exercise 4

¡ In the pivot table report, employees are grouped with their totaled order types under "Row labels". Since the
Employee field is at the top of the row labels area, it is the primary criterion and is therefore displayed as the
higher-level field in the pivot table report.
¡ The amounts for purchased orders are broken down by employee in the "Sum of Amount" value field in the
pivot table report and partial results are displayed as subtotals per employee.
Note: It could be that the orders in the pivot table report are grouped as an indented column to the right of
the employees. The structure of the results shown here is based on the PlanMaker default settings. See
section Configuring pivot tables: Field settings to find useful information on how to customize the form.

Exercise 5: Using "Column labels" and "Row labels" together
Drag the Order field to the Column labels area, the Employee field remains in the Row labels area.

On the left the result of the pivot table, and on the right the field list with the selected fields for Exercise 5
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¡ You will see the same results as in Exercise 4, but shown as a cross-classified table. The intersecting fields
without existing values (e.g. Anna did not buy sweetener) are displayed as empty cells.

Exercise 6: Using "Column labels" and "Row labels" together with multiple fields
Now also drag the Date field to the Row labels area below the Employee field.

On the left the result of the pivot table, and on the right the field list with the selected fields for Exercise 6

¡ The date of the orders purchased by employees is also displayed in the pivot table report, in this example
grouped directly below the employees. A grouping of the orders as an indented column to the right of the
employees could also appear, depending on the settings in PlanMaker.
Note 1: You can drag multiple fields into the row and/or column labels for reporting purposes, but you
will also quickly reach the limits of clarity.
Note 2: If there are several fields in one area, the order of the fields determines the structure of the outline
levels displayed in the pivot table report. You can change this order at any time by dragging the field up or
down within the area.

Exercise 7: Adding a field to the "Report Filter" area
Drag the Date field from the Row labels area to the Report filter area and the Order field back to the Row
labels area.

Editing worksheets

130

On the left the result of the pivot table with the Report Filter above, and on the right the field list with the selected fields for Exercise 7

¡ A Report filter has been added for the Date field, which is integrated as a new row above the pivot report.
¡ Above the pivot report you can open a dropdown menu to the right of (All items) and filter by date values
displayed in the list. Initially, all date values are selected, indicated by the checkmark in front of them. You
can filter out the date items from the pivot report that you do not want to be displayed by removing the
checkmarks.

Working with the field list: Fields section
The fields section in the upper part of the field list displays the headings of the columns of your source data.
You can make the following changes to the fields section:
¡ Display field names alphabetically in the fields section
The field names are first automatically sorted according to the order of the columns from your source data.
You can also display the fields in alphabetical order to find specific field names more quickly. To do this,
click the Pivot table settings button below the areas section. In the Filter tab, Field list group box, select
the Sort A to Z option and confirm with OK.
Note: The alphabetical order you enter here does not affect the appearance in the pivot table report. To
sort the elements alphabetically directly in the pivot table report, see Sorting and filtering Pivot Tables.
¡ Rename field names in the fields section
Open the dropdown menu to the right of the field name, and select the Field settings. In the associated
dialog you can assign a Custom name.
You can also rename a field if it is in the Values area or Row labels/Column labels area of the areas section.
For more information, see Working with the field list: Areas section
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¡ Move fields from the fields section to the areas section
To move a field from the fields section to the areas section, you have the following options:
1. Click the checkbox to the left of the field name in the fields section. PlanMaker automatically assigns
the field to an area of the areas section according to its format: Numbers are placed in the Values area,
text and date formats in the Row labels area.
2. Drag the field with the left mouse button to the desired area below.
3. Click the dropdown menu to the right of the field name. Here you can select the area in which you want
to move the field directly.

Working with the field list: Areas section
After creating a pivot table, you will see first of all a blank pivot table report in your worksheet and the field list
in the sidebar on the right. By adding the fields from the upper fields section to the 4 individual areas of the
lower areas section, you can observe how the assignments in the field list affect the previously blank pivot
report.
Tip: It is best to first drag the field with the amounts into the values area of the areas section. This way you
can best follow the further steps in structuring the pivot table.

Adding, moving, removing fields
Adding fields to the areas section
To move a field from the fields section to the areas section, you have the following options:
1. Place the checkmark to the left of the field name in the fields section. PlanMaker automatically assigns the
field to an area of the areas section according to its format: Numbers are placed in the values area, text and
date in the row labels area.
2. Drag the field with the left mouse button to the desired area below.
3. Click the dropdown menu to the right of the field name. Here you can select the area you want to move the
field directly into.
Moving fields within the areas section
To move fields from one area to another area within the areas section, you have the following options:
1. Drag the field from one area to another with the left mouse button.
2. Click the dropdown menu to the right of the field name (either in the fields section above or in the areas
section below). Here you can select the area you want to move the field directly into.
3. Use the left mouse button to drag the field again from the upper fields section to the desired new area of the
areas section. This will automatically remove it from the previous area (except for the Values area, where
copies of a field are possible).
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Removing fields from the areas section
To remove fields from the areas section at any time, you have the following options:
1. Use the left mouse button to drag the field back up into the fields section.
2. Remove the checkmark to the left of the field name in the fields section.
3. To the right of the field name, click the dropdown menu (either in the fields section above or in the areas
section below) and select Remove field.
Please note: Removing fields from the areas section or moving fields between the areas will undo any
changes made to the field (exception: renaming in the row labels/column labels area).

Tips and rules for using the areas section
Using fields more than once in the areas section
¡ To the Row labels, Column labels and Report filter areas the following applies: A field can be dragged only
once into one of these areas. If you also want to insert it into another area, it is removed from the area where
it was before.
¡ This does not apply to the Values area: here you can drag a field again, even if it already exists in another
area. The same field can even be inserted several times as a copy. What could this be good for? You can
display a field item both as a sum and a second time in a different format (e.g. average). An additional
element Values appears automatically in the column labels, which you can also move to the row labels area
(the format is retained), but not to the report filter area.
Note: If you drag the field Values back into the fields section, all fields in the values area will be
automatically removed, and all changes made to these fields will be discarded.
Changing the order of the fields within an area of the areas section
¡ The order of the fields within an area can be changed by using the mouse to drag the field to the correct
position within the area.
¡ Alternatively, click the dropdown menu to the right of the field name. Here you can select where you want
to move the field (up, down, to the beginning or to the end).
Renaming a field name in the areas section
A field name can be renamed in the areas section so that it appears in the pivot table with a different name.
¡ Custom name in the Row labels or Column labels area:
If the field is in the row labels or column labels area, click the dropdown menu to the right of the field name
and select Field settings. In the Field tab, enter a custom name.
¡ Custom name in the Values area:
If the field is in the values area, select Value settings from the dropdown menu to the right of the field and
enter a custom name in the Summarize values tab.
Note: For renaming in the values area, the following applies: The new name is discarded when the field is
removed from its area. However, you can also rename the field in the fields section (see Working with the
field list: Fields section); the renaming made here remains.
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¡ In the Report filter area it is not possible to rename fields. However, you can also rename the field at the
fields section.

Further options in the field list
In the field list you will find further control elements not described here. These are explained more closely in
the following sections:
¡ Pivot table settings button:
Section Pivot table settings
¡ Refresh data button:
Section Updating pivot tables and changing data area
¡ Defer layout update along with the Update button:
Section Defer layout update
¡ Field settings (via dropdown menu of fields in the row labels/column labels area):
Section Field settings (Row/Column labels area)
¡ Filter labels (via dropdown menu of fields in the row labels/column labels area):
Section Sorting and filtering pivot tables
¡ Filter values (via dropdown menu of fields in the report filter area):
Section Sorting and filtering pivot tables
¡ Value settings (via dropdown menu of fields in the value area):
Section Value settings (Values area)
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Configuring pivot tables with the field list
In the field list, you have various options to change the structure and appearance of your pivot table, which are
explained in this section:
¡ Field settings
The Field settings can be found in the areas section of the field list in the Row labels or Column labels
areas; use the dropdown menu to the right of each field. In the field settings, you can define if and how
partial results are displayed and in which form the layout appears (outline form or tabular form). You can
also change the field name.
¡ Value settings
Fields in the Values area have different setting components from the field settings in the row/column labels.
They can also be opened via the dropdown menu of the respective field and are called Value settings here.
In the value settings you will find a selection of summary functions and calculations as well as the required
number format for the displayed results. The field name can also be renamed here.
¡ Pivot table settings
In the Pivot table settings, you can make advanced layout adjustments, define filter methods, select styles,
set data usage, and assign a name to the pivot table. You will find the pivot table settings located as a button
below the areas section.
¡ Defer layout update
You will find the Defer layout update option along with the Update button at the bottom of the field list. It
allows you to "freeze" the continuous recalculation. You can rearrange the fields between the areas without
time-consuming calculation.
Note: Changes to Field settings and Value settings are discarded when a field is removed from its area
(back to the fields section or to another area of the areas section). Changes to Pivot table settings are
retained.
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Field settings (Row/Column labels area)
If you open the dropdown menu for a field in the Row labels or Column labels in the areas section of the field
list, you will find the Field settings option. Alternatively, right-click directly in the Pivot table report for the
context menu (select a cell of the desired field below the header Row labels/Column labels).
This section describes the adjustments you can make with the field settings.
This is illustrated based on the known example data shown in the figure below: The Amount field is dragged
into the Value area of the areas section, and the Employee and Order fields are dragged into the Row labels
area.

The pivot table report at default values for field settings; highlighted in blue: selecting the field settings

Note: For the sake of simplicity, the descriptions given in this section refer to the arrangement of the fields in
the Row labels area. If you drag the fields to the Column labels area instead, the results are basically the
same. But they are displayed transposed (from left to right instead of top to bottom).

Field settings, "Subtotals" tab
If you have arranged several fields in a row labels or column labels area, you get partial results for the higherlevel field item (Employee) in the pivot table report, as shown in the figure above (for Anna, Maria, Toni).
These subtotals are automatically calculated as sums if a number field has been identified in the values area. In
the Subtotals tab you can also change the display of the subtotals to other summary functions (e.g. count,
average, etc. instead of sums) or hide the display of subtotals completely.
Note: The field settings have an effect for the pivot table only on the field selected in the row/column labels
area.
Click on the dropdown menu to the right of the field (Employee) in the Row labels area (areas section of the
field list) and select the Field settings. In the dialog that appears, choose the Subtotals tab.
Here you have the following options:
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¡ Auto (default): Sums are displayed for the Subtotals (Employee, as in the figure above). If the value field
(Amount) does not contain numbers, but values with other formats, the Count function is automatically used
for the subtotals.
¡ None: The subtotals (Employee) are not displayed.

The Pivot table report without subtotals

¡ Custom
You can choose from various summary functions for displaying subtotals using the Custom option:
Sum: The subtotals are displayed as the sum of the single values.
Count: Returns the number of single values that occur. Works the same as the COUNTA function.
Average: Returns the average value of the occurring single values.
Maximum: Returns the largest occurring single value.
Minimum: Returns the smallest occurring single value.
Product: Returns the multiplied value of the occurring single values.
Count numbers: Returns the count of values that are numbers. Works the same as the COUNT function.
Standard deviation (sample): Returns the estimated value for the standard deviation of a population based
on a sample. Works the same as the STDEV.S function.
Standard deviation (population): Returns the standard deviation of an entire population. Works the same
as the STDEV.P function.
Variance (sample): Returns the estimated value for the variance of a population based on a sample. Works
the same as the VAR.S function.
Variance (population): Returns the variance of an entire population. Works the same as the VAR.P
function.
Tip 1: It is also possible to combine several custom functions. Each of them is then displayed as a separate
row for the subtotal.
Tip 2: If you want to change not only the subtotals but also the other values to a certain display, you can
make the required changes in the Values area with the Value settings option; see section Value settings
(Values area). If, on the other hand, you want to show or hide the Grand totals for columns/rows, you will
find the options available under Pivot table settings.
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Field settings, "Form" tab
In the example figure at the beginning of the section, you can see the pivot table report displayed in the outline
view. You can use the Form options to customize this view.
Note: The displayed Form can only be customized for fields in the Row labels area. For fields in the Column
labels area, the structure formats cannot be set.
In the Row labels area (in the areas section of the field list), click the dropdown menu to the right of the
Employee field and select Field settings. In the dialog that appears, choose the Form tab.

The Field settings dialog with the default values in the Form tab

Form group box
Here you can choose between the view in Outline form or in Tabular form:
¡ In the Outline form - with additionally activated Compact form - several fields are displayed together in
one column, and the lower-level elements are indented into the column. You can also select here whether the
subtotals should appear above or below the grouping.
The following figures illustrate the different presentation variants, depending on the activated options:
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Outline form: Compact form activated; Subtotals at top activated

Outline form: Compact form deactivated; Subtotals at top activated

Outline form: Compact form deactivated; Subtotals at top deactivated
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¡ The Tabular form generally displays a separate column for each field, with the respective field heading:

Further options in the "Form" tab
There are three more options in the lower section of the form tab that you can use as needed to give the pivot
table report a better structure.
Note: The options Repeat item labels and Insert blank lines after subtotals affect only higher-level field
items (Employee). The option Show items without data, however, affect only lower-level field items (Order).
¡ Repeat item labels
The item labels of the elements are displayed repeatedly in each row. This option only works for the Tabular
form and for the Outline form only if you deactivate the compact form.

Enabled option "Repeat item labels" for Tabular form

¡ Insert blank lines after subtotals
It can be helpful for the clarity of the pivot table report if a blank line appears after each group of subtotals.
Activate the option for this purpose (not available for fields in the column labels area).
¡ Show items without data
Enable this option to also display those elements that did not contain associated data.
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Example: Toni did not buy any Coffee. Activating this option, however will display that item with an empty
cell in "Sum of Amount".

Field settings, "Field" tab
You can give the field a Custom name here so that it appears in the pivot table with a different name. Activate
the checkbox and type the new name into the input field (see also Working with the field list: Areas section).

Value settings (Values area)
If you open the dropdown menu to the right of a field in the Values area in the lower section of the field list,
you will find the Value settings option. Alternatively, right-click directly in the pivot table report for the
context menu (select a cell below the header title Sum of...).
The value settings dialog contains the tabs Summarize values and Show values as, which give you various
summary functions and calculation options to choose from.

Value settings, "Summarize values" tab
The results in the pivot table report are automatically displayed as a sum if a number field was identified in the
Values area. If the field has values other than numbers, the results are calculated as a count.
You can customize the display of the results. The specified selection applies to the subtotals of the higher-level
field and also to the subgrouped fields.
To do this, click the dropdown menu of the desired field in the Values area (in the areas section), and select the
Value settings option. In the dialog that appears, select the Summarize values tab.
In the upper section of the dialog, you will find "Summarize values by" with the following options for
displaying the values:
¡ Sum: The subtotals are displayed as the sum of the single values.
¡ Count: Returns the number of single values that occur. Works the same as the COUNTA function.
¡ Average: Returns the average value of the occurring single values.
¡ Maximum: Returns the largest occurring single value.
¡ Minimum: Returns the smallest occurring single value.
¡ Product: Returns the multiplied value of the occurring single values.
¡ Count numbers: Returns the count of values that are numbers. Works the same as the COUNT function.
¡ Standard deviation (sample): Returns the estimated value for the standard deviation of a population based
on a sample. Works the same as the STDEV.S function.
¡ Standard deviation (population): Returns the standard deviation of an entire population. Works the same
as the STDEV.P function.
¡ Variance (sample): Returns the estimated value for the variance of a population based on a sample. Works
the same as the VAR.S function.
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¡ Variance (population): Returns the variance of an entire population. Works the same as the VAR.P
function.
Tip: If you only want to change the subtotals to a certain display, you can make the required changes in the
Row/Column labels area with the Field settings option, see section Field settings (Row/Column labels area).
If, on the other hand, you want to show or hide the grand totals for columns/rows, then you will find the
options available under Pivot table settings.

Furthermore, you will find the Custom name option in the tab. Here you can rename the field so that it appears
in the pivot table with a different name. See also section Working with the field list: Areas section.

Value settings, "Show values as" tab
In the Show values as tab you will find various options how to display the results of the pivot table, for
example, as percentage values.
Tip: You can also drag the same field several times into the Values area. If you then apply different output
settings to the copy of the field using Show values as (e.g. for one field standard values and for the other
field percentage values), you can clearly compare the different output values in the pivot report.
In the upper section of the dialog you will find the section Show values as with choices for calculating the
values. Depending on the calculation type, additional entries appear in the Base field and Base item lists below.
¡ Standard (no calculation): Displays the value as usual.
¡ % of grand total: Each item is displayed as a percentage of the grand total.
¡ % of column total: For each column, the total is set as a 100% reference, and each item in the column is
shown as a percentage of that total.
¡ % of row total: For each row, the total is set as a 100% reference, and each item in the row is shown as a
percentage of that total.
¡ % of: A column or row field is set as a 100% reference, and all other values are displayed as a percentage of
this reference value. The required entries must be selected from the base field list and base item list.
¡ % of parent row total: Displays the percentage of an item relative to the higher-level item (= parent) in the
row structure.
¡ % of parent column total: Displays the percentage of an item relative to the higher-level item (= parent) in
the column structure.
¡ % of parent total: Displays the percentage of an item relative to any (selectable) higher-level item in the
structure. The required entry must be selected from the base field list.
¡ Difference from: Displays the absolute difference of the values from the selected reference value. The
required entries must be selected from the base field list and base item list.
¡ % difference from: Displays the percentage difference of the values from the selected reference value. The
required entries must be selected from the base field list and base item list.
¡ Running total in: Displays the cumulative absolute values of the successive items. The required entry must
be selected from the base field list.
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¡ % running total in: Displays the cumulative percentage values of the successive items. The required entry
must be selected from the base field list.
¡ Rank smallest to largest: Displays the rank of selected values in a specific field. The smallest item in the
field is ranked 1. The required entry must be selected from the base field list.
¡ Rank largest to smallest: As above, but the largest element in the field is ranked 1.
¡ Index: Displays the weighting of the values in relation to the grand row total and grand column total. The
higher the index value, the greater the weighting of the value on the grand row/column total. For the index
value, this formula applies:
value in cell x grand total of the pivot table
grand row total x grand column total
You can use the Number format button in the tab to permanently adjust the display of the desired number
format. For details on the various number formats, see section List of all number formats available.
Hint: The changes to the number format that you make here are permanently applied. If you change the
number format using the cell formatting only, the changes are discarded when the data is refreshed. The
number formatting of the source range also is not adopted in the pivot table.

Pivot table settings
In the field list below the areas section with the 4 areas, you will find the Pivot table settings button. You can
also access the command by right-clicking directly in the pivot table report for the context menu.
You can make further adjustments to the structure of your pivot table here, which you cannot find in the field
settings or value settings, since Pivot table settings are of a general nature. Unlike the field and value settings,
the changed options in the pivot table settings will remain in effect when you remove the fields from the areas
section.

"Layout" tab
¡ Show totals for rows/columns: Shows or hides grand totals for rows/columns.
¡ Indent row labels: If you have arranged several fields in the row labels area and the outline form with
compact format is set in the Field settings, the field of the lower-level is displayed indented below it.
....character(s): Here you can now define the extent of the indentation from the left edge of the column by
typing an appropriate number in the input field (default is 1 character).
¡ Autofit column width: If this option is enabled, the column width of the pivot table automatically fits to the
text of the columns so that the text is not cut off by the next column. This has advantages, but the downside
is that manually made column width adjustments may be discarded when changes are made to the fields.
Deactivate this option to keep the column width you set manually.
¡ Preserve cell formatting: If this option is disabled, the formatting you have made in the pivot table (e.g.
using a different font) will be discarded as soon as you update the pivot table or reopen the workbook. If the
option is enabled, formatting changes are retained.
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¡ Classic pivot table format: If you are confused about the header titles "Row labels" and "Column labels" in
the pivot table report and prefer to see the real names of the fields instead, enable this option for a classic
appearance (known from older versions of Microsoft Excel up to 2003).
¡ Show the values row: Activate the checkbox to insert an additional row with the heading "Values" above
the pivot table report. Note: The value row is displayed only if there are at least two fields in the values area
and cannot be activated for the classic pivot table format.

"Filter" tab
¡ Report filter group box: You can combine the following options Display fields and Fields per row to
rearrange the placement of report filters in the pivot table report.
Display fields - If there are at least two fields in the report filter area, you use this option to specify how the
fields in the report filter area are arranged in the pivot table report. You can choose between First down,
then right or First right, then down.
Fields per row - Here you can also specify for the report filters of the pivot table report how many fields are
displayed per column before a new column starts.
¡ Field list group box:
Sort A-Z/Sort in data source order - The field names in the field list are sorted according to the order of
the columns from your source data. You can also display the fields in alphabetical order to find specific field
names in the fields section more quickly.
Note: The order specified here does not affect the display in the pivot table report. To sort the items
alphabetically directly in the pivot table report, see Sorting and filtering pivot tables.
¡ Display group box:
Show field captions and filter dropdowns - The field names and filter symbols for row labels and column
labels are displayed/hidden in the pivot table report.

"Style" tab
You can adjust the visual appearance of the pivot table report in various ways, just as you do with normal table
styles. Select a style source (Excel 2007, Excel 2003, Excel 97) from the upper left list in the Style group box
and choose one of the pivot styles with different formatting from the list below. For the Excel 2007 style
templates, the selection light/dark/medium is also available in the upper right list.
The options Banded rows, Banded columns, Row headers and Column headers are displayed automatically
adapted to the style template. For the Excel 2007 style templates, you can manually modify these options to
your preferences.
Activating the option Banded rows/Banded columns causes alternating background colors of the
rows/columns, activating the option Row headers/Column headers emphasizes the first row/column of the
pivot table.
The design change is displayed directly in the pivot table report as a preview and has to be confirmed with OK
for finally applying it.
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"Data" tab
¡ Special values group box:
For error values show - Cells with incorrect calculations return the known error values also in the pivot
table report (for example, #NV; see section Error values). Activate this option and enter an individual text in
the right input field to display self-defined output values representing the error values.
For empty cells show - If no data can be assigned to an item (this usually occurs with combinations of row
and column labels for cross-classified tables), an empty cell is displayed in the pivot table report. If you
deactivate the checkbox, a 0 is displayed instead of empty cells. If the checkbox is activated, you can also
enter an individual text in the input field next to it to display a self-defined output value instead of an empty
cell or the 0.
¡ Pivot table data group box:
Save source data with file - If this option is enabled, the source data is stored in an internal cache and is
available from the cache for the pivot table independently of your source data. In a way, a copy of the source
table is created. This is particularly useful for external source data: If it no longer exists, you can still work
on your pivot table with the data from the pivot cache.
If you disable this option, your data will not be stored in the pivot cache. When you re-open the file, you
have to click the Refresh data button (see section Updating Pivot tables and changing data area) to initialize
the pivot cache for the pivot table with the source data. For external source data, if they no longer exist,
your pivot table can also not be updated.
Refresh when opening the file - If this option is enabled, the pivot table data is automatically updated to
current source data when you open the file. If you disable this option, you can continue working with your
old pivot data until you trigger the Refresh data button (see section Updating Pivot tables and changing data
area).
Please note: Updating the data with the Refresh when opening the file option or with the Refresh data
button will replace the pivot cache with updated source data, overwriting the previous data in your pivot
table.

"Text" tab
In the Text tab you can enter a custom Name, a Title and a Description for your pivot table. The name is
automatically generated by PlanMaker in sequence (Pivot table 1, Pivot table 2, etc.) and is shown as a heading
in the blank pivot table report. An entry is also created in Named ranges, but it cannot be renamed there.
Moreover, the assigned Name cannot be used to identify the pivot table from the GETPIVOTDATA function;
therefore, you must explicitly create a new entry for the pivot table in the Named ranges.
Apart from that, the entries from the Text tab do not appear anywhere in the pivot table. Title and Description
can be useful as internal information. To rename the fields that effectively appear in the pivot table, please read
the section Working with the field list: Fields section.
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Defer layout update
At the bottom of the field list you will find the option Defer layout update. It is combined with the Update
button on the right, but is not related to the Refresh data option (see section Updating pivot tables and
changing data area).
When you are repositioning fields in the field list, for example, add/remove/move fields in the areas section, the
pivot table report is recalculated each time. This can take quite some time with large reports. Therefore, if you
want to temporarily disable continuous recalculation, please proceed as follows:
1.

Place a checkmark in the Defer layout update checkbox. You can then rearrange the fields of your pivot
table, but you will not see the resulting changes in the pivot table report. In addition, all other editing options
for this state are disabled.

2.

Once you have finished repositioning the fields, click the Update button to see the result of the change.

3.

Remove the checkmark from the Defer layout update checkbox.

Note: If you deactivate the Defer layout update option again without pressing Update, all arrangements of
the fields that you have made since the option was activated will be discarded.
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Sorting and filtering pivot tables
Too much data makes it difficult to see the relevant content. Therefore, there are various options for sorting and
filtering table fields in pivot tables:
¡ Sorting field items alphabetically in the pivot table report
¡ Filtering in the areas section with the Filter labels (Filter values) option
¡ Filtering by adding Report filters
¡ Set additional special filters directly in the pivot table report via the dropdown menu
Please note: For all presented options of sorting and filtering, the changes will be discarded as soon as you
have removed the field from the areas section or moved it from one to another area.

Sorting field items alphabetically in the Pivot table report

You can sort the field items of a pivot table report alphabetically by opening the dropdown menu at the header
row/column labels in the report itself and choosing from the list:
¡ Sort from A to Z (alphabetical order)
¡ Sort from Z-A (reverse alphabetical order)
If there are several fields in the row/column labels area (as in the figure above), you can sort each field
separately. To do this, move in the dropdown menu of the pivot report to the next menu level on the right of the
field you want to sort, to access the sort options for this field.
Hint: For the alphabetical display of the fields only in the field list, please read the section Working with the
field list: Fields section.
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Filtering in the areas section with the option Filter labels (Filter values)
In the Row labels/Column labels areas of the field list, go to the desired field whose items you want to filter.
Open the dropdown menu to the right of the field and select the Filter labels option (for fields in the Report
filter area, do the same, but here the option is called Filter values). You can also select the option directly from
the pivot table report by right-clicking on the desired field opening the context menu.
You can choose from the Filter dialog box that appears:
¡ Choose single list items that you want to show/hide by placing/removing a checkmark in front of them.
¡ The Show all button selects all items.
¡ The Hide all button deselects all items.
Confirm your selection by pressing OK.
In the pivot table report, the black dropdown arrow next to the header changes to a red arrow, indicating that a
filter is active. The filtered out values are no longer displayed in the pivot table report.

Filtering by adding report filters
The Report filter is located in the lower areas section of the field list and offers you a particularly simple and
clear option for filtering data.
Drag the fields you want to filter by to the report filter area. A cell with the field name is then inserted above
the pivot table report and another cell (All items) with a dropdown arrow is integrated to the right of it. The
items of the field can be filtered via the dropdown menu. You can choose single list items here or select/
deselect the complete list of items with Show all/Hide all.
The red dropdown arrow to the right of the cell indicates that a filter is active. The filtered out values are no
longer displayed in the pivot table report.
You can drag several fields from the field list to the report filter area and filter any combinations of single items
from the various fields for the pivot table report.
Tip: Changing the positioning of the report filter fields in the pivot table report is possible using the Pivot
table settings, Filter tab.

Set additional special filters directly in the pivot table report via the dropdown menu
In the Pivot Table report, open the dropdown menu next to the Row labels/Column labels header. If there is
only one field in the Row labels/Column labels area, the filter choice is displayed directly for the selected field.
If there are several fields in the row/column labels area, separate filters can be applied for each field. To do this,
move in the dropdown menu of the pivot report to the next menu level on the right of the field to get its filter
selections.
¡ You can choose single list items or select/deselect the entire list of items with Show all/Hide all.
Note: If the list has too many entries, it is shortened and the entry More appears at the end of the list.
Clicking on this More entry takes you to the Filter dialog box. Here, the complete list of items is
displayed for selection.
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Furthermore, additional special filter conditions are available in the dropdown list. You can find detailed
descriptions of the individual filter conditions in the AutoFilter section.
¡ Label filter or Date filter: Depending on whether you have selected a field with numbers/text or date
values, one of the two filters is automatically offered. According to the filter, you will find certain filter
conditions for numbers/text or date values.
¡ Result filter: The result filter has special filter conditions that you can use to narrow down the amounts in
the value fields.
Note: Please pay attention when applying filters to several fields in which order you set the filters. The
next filter that is applied refers only to the remaining results of the previously set filter.
¡ Multiple Filters: The filters in pivot table reports can be applied additively, that is, you can place another
filter on the currently effective filter of the same field. To do this, however, you must activate the Multiple
filters option to combine filters for single list items, label/date filters and result filters for the same field. If
this Multiple filters option is not activated, a newly applied filter replaces the old one.
¡ Clear Filter: If you want to remove the used filters from the label filter/date filter or result filter, choose
Clear filter from the dropdown list of the filter in question.
Tip: If you want to remove all filters at once, deactivate the Multiple filters entry. A dialog box Clear all
filters? appears. Confirm with OK to remove all filters.
In the pivot table report, the red dropdown arrow next to the header indicates that a filter is set. The filtered out
values are no longer displayed in the pivot table report.

Updating pivot tables and changing data area
The following generally applies for pivot tables: If you subsequently add new data to the source table, this has
no effect on the pivot table. Due to PlanMaker's default values for pivot table settings (see section Pivot table
settings, Data tab), the data of the original source table is stored in an internal pivot cache after creating the
initial pivot table. The pivot table accesses the data from the cache.
Only when you Refresh data will the pivot cache be overwritten and the pivot table updated.
In the Pivot table settings, Data tab, you can also find the option Refresh when opening the file. If you
activate this option, the pivot cache is regularly overwritten with the current data of the source range when you
open the file. If you want to continue working with your old pivot data after opening the file, leave this option
deactivated.
You can manually update your pivot table at any time by clicking the Refresh data button.
Please note: By updating the data with Refresh data button or with Refresh when opening the file option, the
pivot cache will be replaced by updated source data and the previous data in your pivot table will be
overwritten.
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"Refresh data" button
You will find the Refresh data button below the areas section in the field list.
Depending on which place in the source data area you have added new data to, this has different effects on the
pivot table:
¡ If you overwrite data within the source data area, the changed data is used in the refreshed pivot table.
¡ When you insert a new row/column within the source data area, the data area is automatically extended and
reflected in the refreshed pivot table.
¡ But if you add a new row or column at the end of the source data area, the changed data is not reflected in
the refreshed pivot table report at first. To do this, you must re-adjust the source data area (see below
"Changing the source data area").

Refresh all pivot tables
If you want to refresh all existing pivot tables – even those with different source areas – select Tools > Refresh
all pivot tables.

Changing the source data area
If your source data has changed in such a way that it no longer is in accordance with the original source range
of the pivot table (new records have been appended / file with imported data has been moved), the referenced
data area for the source data must be changed.
Proceed as follows:
1.

Place the mouse pointer in the pivot table report.

2.

Go to the menu command Worksheet > Modify pivot table area or right-click in the pivot table report to
open the context menu and select the menu command with the same name.

3.

A dialog box appears that is similar to the one for creating a new pivot table, with one difference: The Insert
button is called Change here. In addition, the originally referenced source range is marked in blue color
directly in the worksheet with the source data.

4.

In the dialog box, enter the new data area in the input field (source range); the previous source range is the
default. Alternatively, it is possible to mark the desired source range with the mouse if you have the
worksheet with the source data in front of you. Use the left mouse button to grab the blue mark at the bottom
right corner.
Note: For external data, the adjustment is possible only in the input field (source range).

5.

Confirm with the Change button. Before you do this, you can enter in the lower input field whether you also
want to move the target range to another position; the previous target range is the default.
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Deleting, copying, moving pivot tables
You can also delete, copy, and move your created pivot tables. The following paragraphs explain exactly how
to do this.
Tip: To delete, copy, or move, it is always necessary to precisely mark the entire area of the pivot table
report. The easiest way to do this is to place the mouse in a cell of the report and use the key combination
Ctrl+A or the menu command Edit > Select all to select it.

Deleting pivot tables
Deleting pivot tables works similarly to the standard procedures for Deleting data. Note, however, that the pivot
table report must be selected as a whole; individual cells cannot be deleted separately.
Select the entire pivot table report to delete and use one of the following methods:
¡ Press the Del key on the keyboard
¡ Use the menu command Worksheet > Delete cells... or right-click on the pivot table report to open the
context menu and choose here Delete cells...
¡ Use the menu command Edit > Delete
¡ Use the menu command Edit > Delete special or right-click on the pivot table report to open the context
menu and select here Delete special. In the next menu level, click All or Contents to completely delete the
pivot table. Select the Formats entry if you only want to remove the applied formats from the pivot table.

Copying pivot tables
You can copy pivot tables anytime and duplicate them in the same worksheet to a different position or in a new
worksheet. The copied pivot table will have the same values as the original. Even after you click the Refresh
data button, the copied pivot table adopts changed data from the source table.
In the copied pivot table, however, you still have the opportunity to configure it independently of the copied
original with regard to field arrangement, formatting, and so on. This gives you different views of the reports
for the same source data.
Select the entire pivot table report to copy it and proceed according to one of the following methods:
¡ Use the menu command Edit > Copy and then Edit > Paste
¡ Right-click on the pivot table report to open the context menu and choose Copy and subsequently Paste
¡ Drag the pivot table report with the mouse to the desired position and press the Ctrl key to drop it before
releasing the mouse.
¡ Use the key combination Ctrl+C and Ctrl+V
You can now decide which report you want to work on by moving the mouse pointer into a cell of the relevant
pivot table report. The field list appears corresponding to the selected report.
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Moving pivot tables
Select the entire pivot table report, and use the left mouse button to drag the selected range to a free position on
the worksheet. Make sure that you do not overlap the source data range.
If you want to move the pivot table report to another worksheet, use one of these options:
¡ Select Modify pivot table areas, either via the context menu with the right mouse button or via the menu
command Worksheet > Modify pivot table areas, and enter the desired target range in the dialog. (see
section Updating pivot tables and changing data area)
¡ Copy the pivot table report as described above, switch to the desired worksheet in an empty space, and paste
the copy from the clipboard. Then remove the remaining pivot table report from the former place.

Some restrictive notes on copying and moving source/target range
Copying and moving data ranges - both the source range and the target range (the pivot table report) - is not
fully possible in the same way as you are familiar with from normal tables. The following rules should be
considered:
¡ Copy & paste of source range/target range: It is possible to first copy the source range of your data and
paste it to another position, but the pivot table is still referenced to the position of the original source range
and not to the new position. This means that the former cell range is still addressed when the data is
refreshed, and if it has been removed, an error message appears. This restriction also applies if you copy and
paste the source area together with the target area. Copying and pasting only the target range to another
position is possible without any problems.
¡ Drag & drop the source range/target range: If you drag the selected source range to another position with
the mouse, the restriction described above does not apply. The pivot data will be referenced to the new cell
range and will be correct addressed when updating the data. Dragging and dropping only the target range or
together with the source range is also possible without any problems.
¡ Cut & paste the source range/target range: Cutting is neither possible for the source range nor for the target
range. An error message appears when using the command.
In the following table you can see the options once again clearly summarized:
Activity

Source range

Target range

Copy & paste

û

ü

Drag & drop

ü

ü

Cut & paste

û

û
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Freezing rows and columns
Use the View > Freeze menu command to "freeze" the first rows and/or columns of a worksheet on screen. As
a result, the frozen rows or columns do not move when you scroll through the worksheet, but permanently stay
in place.
This is particularly useful if you have put headings into rows or columns of a worksheet, and want these
headers to stay visible all the time.

Activating freezing
To freeze rows or columns:
1.

Determine which rows and/or columns to freeze:
Freezing rows: To freeze the first rows of a worksheet, select the row directly below the rows you want to
freeze.
Freezing columns: To freeze the first columns of a worksheet, select the column to the right of these columns.
Freezing rows and columns: To freeze both rows and columns, navigate to the cell to the right and below the
area to be frozen.

2.

Select the View > Freeze menu command.

The rows and/or columns are now frozen and remain in their original location when you scroll through the
worksheet.
Hint: You can also use the icon in the bottom-right corner of the document window to freeze rows or
columns. Simply click this icon and then drag it to the desired location.

Deactivating freezing
To deactivate freezing, select the View > Freeze menu command once again. This removes the checkmark at
the View > Freeze menu command, and the rows/columns are no longer frozen.
Hint: A single mouse click the
freezing.

icon in the bottom-right corner of the document window will also turn off

An example
Assume you have the following worksheet:

Editing worksheets

153

Note that both the columns and the rows are labeled. To freeze the labels:
¡ The column labels (High, Low, etc.) are in the first row of the table.
To freeze them, select the second row by clicking its row header (the button left of the row, labeled with
"2"). Then select the View > Freeze menu command.
¡ The row labels (10/24, 10/25, etc.) are in the first column of the worksheet.
To freeze them, select the second column (column B) by clicking on its column header (the button above the
column, labeled with "B"). Then select the View > Freeze menu command.
¡ To freeze both rows and columns, click cell B2 and select the View > Freeze menu command.
To deactivate the freezing function, select the View > Freeze menu command once more.

Inserting special characters
Some characters, such as the copyright sign, the degree sign, and the accented characters used in some
languages, cannot be entered into text directly with the keyboard. Instead, PlanMaker's built-in character table
provides a convenient means for inserting symbols and other special characters.
You insert special characters as follows:
1.

Invoke the menu command Insert > Symbol.

2.

A dialog box appears, giving you access to every character that is available in the selected font. If you need
a character from a different font, select it from the Font list at the top of the dialog.

3.

A font's characters are organized into sets. If the character you want to use is not in the set immediately in
view when you can jump to the set in which it is likely to be found by selecting it from the Set list. For
example, you can select Cyrillic to view the font's Cyrillic characters (provided the font contains such
characters).
Note: Many fonts contain only a few of the character sets that are available. However, the fonts that are
supplied with your operating system usually constitute a huge reservoir of characters. These include, for
example, the Arial, Tahoma and Times New Roman fonts supplied with Windows.
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4.

Select the desired character by clicking on it. Then press the Enter ¿ key or click on the Insert button to
insert the character into the text. Alternatively, you can double-click on a character to select and
immediately insert it.

5.

You can repeat the above described procedure to insert additional characters, as required. When you are
finished, exit the dialog with the Close button.

Tip for Windows users: Most Windows versions come with two symbol fonts (Symbol and Wingdings) that
include numerous useful symbols (phone symbols, bullets, etc.) and special characters.

Using keyboard shortcuts
If you need to insert a special character frequently, you can always give it a keyboard shortcut. The advantage
of doing that is that you can then apply the character very quickly, using a single key press.
To assign a keyboard shortcut to a special character, proceed as follows:
1.

Invoke the menu command Insert > Symbol.

2.

Select the character that you want to assign a keyboard shortcut to.

3.

Click on the Change button next to the Shortcut key option.

4.

Another dialog opens. There, press the desired keyboard shortcut in the Please press accelerator input box.
We recommend using key combinations that include the keys Ctrl and Shift, since these are normally not
assigned.
Hint: If you make a typing mistake, you can always press the BackspaceÕ key to remove the keyboard
shortcut you entered.

5.

Don't forget: Click on Add to assign this shortcut to the character.

6.

Confirm with OK and exit the main dialog box with Close.

From now on, you can insert this special character into text by pressing the selected key combination.
Note: The keyboard shortcut remembers only the selected character; the selected font is not remembered.
For more information on changing the keyboard layout, see the section Customizing keyboard shortcuts. Hint:
The keyboard shortcuts for special character can be edited by opening the dialog for editing the keyboard
mapping and choosing the entry Characters in the left list.

Inserting special characters via their character code
There is another method for inserting special characters: by typing in its hexadecimal character code (Unicode)
and then pressing the key combination Ctrl+Alt+Shift+X.
For example, when you type in 20AC and press this key combination, you will receive a Euro sign, since the
euro sign's character code is 20AC in the Unicode character set table.
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Inserting special characters via Alt + numeric keypad
And here is yet another method for inserting a special character, using its ASCII code: Hold down the Alt key
and enter the respective sequence of numbers (only possible via the numeric keypad!). Please also make sure
that the numeric keypad is activated by pressing the Num key.
For example, if you type Alt+0128, you will receive a Euro sign as soon as you release the Alt key.
Mac/Linux: On some systems (including macOS and several Linux distributions), these keyboard shortcuts
might be not available.
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Formatting worksheets
You can apply a variety of fonts, colors, shades, borders, and other format options to improve the appearance
and readability of worksheets.
This chapter covers the format options available in PlanMaker, as follows:
¡ Cell size
To change the size of cells, either use the commands in the sub-menu of the menu command Worksheet >
Row (or Worksheet > Column), or simply drag the row header (or column header) using the mouse.
¡ Number format
PlanMaker can display numbers in many different number formats: as plain numbers, rounded to 2 decimal
places, as a percentage, with a currency symbol, as a date or time, in a user-defined format, etc. Use the
Format > Cell menu command to select the appropriate number format.
¡ Borders and lines
The Format > Borders menu command lets you add borders and lines to cells.
¡ Shading
The Format > Shading menu command lets you apply a variety of colors, shades, and patterns to the
background of cells.
¡ Alignment
The Format > Cell menu command lets you change the cell format, including the alignment (left-aligned,
centered, right-aligned, etc.) of the cell contents.
¡ Protection
The Format > Cell menu command can also be used to protect cells against changes (see also section Sheet
protection).
¡ Character format
The Format > Character menu command lets you modify the character format of cells (font, font size, font
style, font color, etc.).
¡ Paragraph format (text frames only)
The Format > Paragraph menu command is available only in text frames. It lets you modify the paragraph
format (spacing, indents, etc.) of the included text.
¡ Character styles
You can create character styles that store your favorite character formats. Character styles can be applied to
cells at the push of a button.
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¡ Cell styles
Additionally, you can create cell styles that store your favorite character formats (font etc.) and cell formats
(number format, borders, shading, alignment, and protection settings).
¡ Document templates
PlanMaker even lets you create your own document templates. Document templates can include your own
character styles, your own cell styles, and any kind of content.
¡ AutoFormat
The Format > AutoFormat menu command allows you to format a range of cells by applying predefined
format schemes.
¡ Conditional formatting
When you add conditional formattings to cells, these cells will automatically change their appearance when
a certain condition is met. Example: "If the cell content is greater than 1000, display it in red color."
¡ Input validation
When you add input validation to cells, only the specified types of values (e.g. only numbers) within the
specified limits (e.g. only values between 10 and 20) will be considered valid in these cells.
¡ Transfer formatting
Using the Format > Transfer formatting menu command, you can transfer the formatting of one cell to
other cells.
¡ Page setup
The page setup command allows the user to set print options. It includes settings such as paper size and
orientation, margins, headers and footers, and other options. Use the File > Page setup menu command to
change these settings.
See the following pages for detailed information.

Cell size
On the next pages you will learn how to change the size of cells.
Note: If a cell displays hashes (e.g., ########) instead of the cell content, the column is too narrow to
display the cell content. If this happens, simply widen the corresponding column.
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Changing cell sizes using the mouse
Across the top of the table are buttons labeled A, B, C, etc. To the left of the table are buttons labeled 1, 2, 3,
etc.
These so-called column headers and row headers allow you to change the column width or row height using the
mouse:
¡ To change the width of a column, move the mouse pointer to the right border of the corresponding column
header. The mouse pointer will change to a double arrow. Press and hold the left mouse button and move the
mouse to change the column width.
¡ To change the height of a row, use the row headers in the same manner.

Changing cell sizes using menu commands
Another way to change the size of rows/columns is by using the menu commands Worksheet > Column and
Worksheet > Row.
If you choose one of these menu commands, a sub-menu with the following commands will appear:

Width (or Height)
Lets you enter a numerical value for the column width (or row height, respectively).

Optimum width (or Optimum height)
The Worksheet > Column > Optimum width menu command sets the width of a column automatically,
corresponding to the space required by the cell contents.
The command can be used in different ways:
¡ When you select an entire column and invoke this command, the width of the column will be adapted to the
cell that needs the most space.
Hint: The same can be achieved much faster: by simply double-clicking on the column header.
¡ When you select some cells within a column and invoke this command, only these cells will be used for the
calculation of the optimum width.
¡ When you select nothing and invoke this command, the column width will be adapted to the content of the
current cell.
The height of rows can be changed the same way, using the menu command Worksheet > Row > Optimum
height.
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Hiding rows or columns
You can hide rows/columns, so they become invisible.
Note: If sheet protection is activated for a worksheet, users will not be able to unhide hidden row/columns in
the worksheet. See also section Sheet protection.
To hide rows/columns:

Using the row header to hide rows
The quickest way to hide rows is using row headers. (Row headers are the buttons labeled with the row
number, located left of the worksheet.)
For example, to hide row 14:
1.

With the mouse, point to the lower border of the row header labeled "14".

2.

Press and hold the mouse button, and drag the border upwards until the row disappears.

Row 14 is now hidden. Instead of a row header, a small triangle is displayed:

To make row 14 visible again, click this triangle.

Using the Worksheet > Row command to hide rows
Alternatively, rows can be hidden with the Worksheet > Row menu command:
1.

Select the row(s) to hide.

2.

Invoke the menu command Worksheet > Row > Hide.

The selected rows will be hidden.
To make them reappear:
1.

Select any cell range that includes the hidden rows.

2.

Invoke the menu command Worksheet > Row > Show.

Hiding columns
Hiding and unhiding columns works just the same way, except that you use the column headers or the menu
commands Worksheet > Column > Hide and Worksheet > Column > Show, accordingly.
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Number format
To change the number format of cells, choose the menu command Format > Cell, and switch to the Number
Format tab.
The number format determines how numbers are represented in these cells. For example, if you enter 12.3456
in a cell and then apply one of the Currency number formats to it, it will be displayed with the chosen currency
symbol and rounded to two decimal places (for example, as $12.35).
Note: When you apply a number format that has a fixed number of decimal places, the number will only be
displayed as a rounded value, but still keeps all of its decimal places. To actually round numbers, use
arithmetic functions like the ROUND function
To change the number format of cells:
1.

Select the cells whose number format you want to change.

2.

Choose the menu command Format > Cell.

3.

Switch to the Number format tab.

4.

Specify the desired number format (as described below).
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Click OK to confirm.

Options available in the dialog box:
¡ Category
Here you can select the desired type of number format. See section List of all number formats available.
¡ Format
Some number formats also have several subtypes to choose from. Select the desired subtype in this list.
¡ Decimal places
Some formats allow you to specify the number of decimal places to be displayed.
Note: Numbers will only be displayed rounded, but they actually keep all of their decimal places.
¡ Thousands separator
Some formats allow you to specify if numbers should be displayed with thousands separators (e.g.,
5,000,000) or without (e.g., 5000000).
¡ Negative numbers in red
Some formats allow you to specify if negative numbers should be displayed in red color.
¡ Suppress minus sign
Some formats allow you to specify if the minus sign of negative numbers should be suppressed.
¡ Don't show zero
Some formats allow you to specify if the content of cells containing the number zero should be suppressed.
When you confirm with OK, the numbers in the selected cells will be displayed in the chosen formatting.

List of all number formats available
As described in the previous section, you can use the Format > Cell menu command to choose the number
format of a cell, allowing you to specify exactly how numbers entered in this cell should look like.
The following number formats are available:

Default
Displays the number just the way it was entered.
More precisely: The number is displayed right-aligned. Apart from that, no further reformatting takes places.
Right of the decimal point, all decimal places that have been entered are shown (with a maximum of five
decimal places).
Example:

42
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Number
Same as the Default number format, except that you can specify several formatting options (see previous
section). For example, you can set the number of decimal places to be displayed.
Example:

42.00

Note: When you apply a number format that has a fixed number of decimal places, the number will only be
displayed as a rounded value, but still keeps all of its decimal places. To actually round numbers, use
arithmetic functions like the ROUND function

Currency
Displays the number with a currency symbol and two decimal places.
To specify the desired currency symbol, select it in the Currency list box.
Example:

$42.00

Accounting
Same as Currency (see above), except that numbers are displayed in accounting format (with minus signs and
currency symbols aligned).
Example:

-$

42.00

Date/Time
Displays the number as date and/or time.
Depending on your system regional settings, various different date and time formats to choose from are offered
in the Format list box.

Percentage
Displays the number as a percentage.
Apart from adding a percent sign (%) to the number, the number will also be displayed multiplied by 100. For
example, 0.5 will be displayed as 50%.
Example:

42%

Scientific
Displays the number in scientific notation.
Examples: 5E+03 (equals 5 * 10^3, which is 5000)
4.2E-01 (equals 4.2 * 10^-1, which is 0.42)
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Fraction
Displays the number as a fraction.
There are several different formats available.
Note: The number will be displayed as a rounded value, if necessary. For example, if you choose the format
As Halves, and enter the number 2.3, it will be displayed as 2 1/2.
Examples: 2 1/2
5 9/10

Boolean
Displays the number as a Boolean value (logical value).
If the number is zero, FALSE will be displayed. If it is any other value, TRUE will be displayed.
Examples: TRUE
FALSE

Text
This number format presents a special case: It forces PlanMaker to treat a number as text, not as a number.
The number will be left-aligned and displayed exactly the way it was entered. As opposed to any other number
format, numbers will not be reformatted on input by any means. Leading zeros will not be removed; dates will
not be reformatted automatically, etc.
This can be useful, for example, when entering numbers with leading zeros (e.g. serial numbers). Normally,
when you enter a number like "00043682" into a cell, PlanMaker will automatically remove the three leading
zeros. If you apply the Text number format to the cell, the leading zeros will persist.
Warning: For compatibility reasons, this number format has been implemented exactly the same way as in
Microsoft Excel. Therefore, it will lead to the same unexpected results in calculations:
When you apply this format e.g. to the cells A1 and A2, the result of the calculation A1+A2 will be the sum
of these two cells. However, the calculation SUM (A1:A2) will return zero. The reason is that, for most
arithmetic functions, text always has the "value" zero!

Custom
Displays the number in a user-defined format.
For details, see the next section.
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Working with user-defined number formats
Whenever required, you can also define and apply your own number formats with the Format > Cell menu
command.

Defining and applying a new number format
To create a new user-defined number format, proceed as follows:
1.

Select the table cells that you want to apply the new number format to.

2.

Invoke the Format > Cell menu command, and switch to the Number Format tab.

3.

In the Category list, choose Custom.

4.

Click into the edit control below Format.

5.

Enter a text string that specifies the desired number format.
For a list of available format codes, see the section Structure of a user-defined format.

6.

Click on OK.

The number format is created (and also applied to the currently selected cells).
Hint: If you want to create a new number format that is similar to one of the built-in number formats, the
following tip can save you a lot of work: After opening the dialog, first click on the desired built-in number
format in the Categories list. This will transfer the corresponding format codes into the edit control for the
format codes (step 5.). All you have to do is make your desired changes, and you're done.

Applying a user-defined number format
Once created, a user-defined number format can be applied to as many other cells as you like. Proceed as
follows:
1.

Select the desired table cells.

2.

Invoke the Format > Cell menu command, and switch to the Number Format tab.

3.

In the Category list, choose Custom.

4.

In the Format list, all user-defined number formats for the current document are displayed. Choose the
desired format.

5.

Click on OK.

The number format will now be applied to the selected cells.

Deleting a user-defined number format
If there's a number format that you don't want to keep anymore, you can delete it anytime. Proceed as follows:
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1.

Invoke the Format > Cell menu command, and switch to the Number Format tab.

2.

In the Category list, choose Custom.

3.

In the Format list, choose the format to be deleted.

4.

Click on the Delete button.

5.

Close the dialog (preferably using the Cancel button, since clicking OK would apply the currently selected
format to the current cell).

Note: The Delete button is available only for user-defined number formats. You cannot delete any of the builtin number formats.

Structure of a user-defined format
When you create a new number format (as described in the previous section), you have to enter a text string
containing format codes. These codes specify how numbers are displayed.
An example:
#.00
These codes will cause numbers to be displayed as follows: All digits left of the decimal point, then a decimal
point, then exactly two digits right of the decimal point.
In detail, the following format codes are available:

Format codes for numbers and text
For formatting numbers and text, the following format codes can be used:
Code

Result

#

Display a single digit of the number – or nothing (in case there is no digit at this position).
Example: #.## applied to the number 1.2 returns 1.2.

0

Display a single digit of the number – or a zero (in case there is no digit at this position).
Example: #.00 applied to the number 1.2 returns 1.20.

?

Display a single digit of the number – or a blank (in case there is no digit at this position).
Example: #.?? applied to the number 1.2 returns 1.2 (with a blank behind the 2).
Important: If any of the above codes is placed to the left of the decimal point, all digits left of the
decimal point will be displayed. Example: 0.00 applied to the number 123.456 will not return 3.46,
but 123.46.

. (period)

Display a decimal separator at this position.
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Note: If your system utilizes a decimal separator other than a period (e.g. a comma), use the
corresponding character instead of a period.
, (comma)

Display the number with thousands separators. This code can be placed at an arbitrary position in the
format string. Example: ,0.00 applied to the number 5000000 returns 5,000,000.00.
Note: If your system utilizes a thousands separator other than a comma, use the corresponding
character instead of a comma.

%

Display a percent sign at this position, and multiply the number by 100.
Example: 0% applied to the number 0.5 returns 50%.

E+ or e+

Display the number in scientific notation.
Example: 0E+00 applied to the number 50000 returns 5E+04.
Note: Engineering notation (using only exponents that can be divided by 3) is also available. For
example, #00E+00 applied to the number 50000 does not return 5E+04 but 50E+03.

E- or e-

Same as E+, except that the exponent's sign is only displayed if it is negative.
Example 1: 0E-00 applied to the number 5000 returns 5E03.
Example 2: 0E-00 applied to the number 0.005 returns 5E-03.

Standard

Placeholder for the entire cell content (formatted with the number format "Standard").

@

Placeholder for the entire cell content as text.

\

Do not try to interpret the following character, just display it.
Example: To output a # character, use the code \# (since the # sign is a valid format code).

"Text"

Do not interpret the text between the quotation marks, just display it.
Example: "MyText"

* (asterisk)

Repeat the following character. For example, *x fills the entire cell with the character "x".
Example: The format codes "Total:"* 0.00 display the text "Total:" at the left of the cell and the
number (with two decimal places) at the right. The space in-between is filled with blanks.

_ (underscore)

Display a blank space that is as wide as the following character.
Example: _- returns a blank space that is exactly as wide as a minus sign.

[Red]

Display the cell content in red color. Other color codes available:
[Black] [White] [Red] [Green] [Blue] [Cyan] [Magenta] [Yellow]
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Format codes for dates and times
For dates/times, only the following format codes are valid:
Note: The format codes listed below are case-sensitive!
Code

Result

D

Day (1-31)

DD

Day, with 2 digits (01-31)

DDD

Name of day, abbreviated ("Su" to "Mo")

DDDD

Name of day ("Sunday" to "Monday")

M

Month (1-12)

MM

Month, with 2 digits (01-12)

MMM

Name of month, abbreviated ("Jan" to "Dec")

MMMM

Name of month ("January" to "December")

MMMMM

Name of month, first letter only ("J" for January to "D" for December)

YY

Year, with 2 digits (e.g., 18)

YYYY

Year, with 4 digits (e.g., 2018)

Q

Quarter (1-4)

QQ

The word "quarter" in the language set in the system's regional settings

h

Hour (0-23)

hh

Hour, with 2 digits (00-23)

m

Minute (0-59)

mm

Minute, with 2 digits (00-59)

s

Second (0-59)

ss

Second, with 2 digits (00-59)

0

Tenths of a second (e.g., hh:mm:ss.0)

00

Hundredths of a second (e.g., hh:mm:ss.00)

000

Thousandths of a second (e.g., hh:mm:ss.000)
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Display times in 12-hour format (with AM or PM). Has to be placed at the end of the format codes!
Example: h:mm:ss AM/PM

am/pm

Same as AM/PM, but with am or pm (lower case)

a/p

Same as AM/PM, but with a or p

[h]

Number of hours in "endless" time format*

[m]

Number of minutes in "endless" time format*

[mm]

Same as [m], but with 2 digits*

[s]

Number of seconds in "endless" time format*

[ss]

Same as [s], but with 2 digits*

[$-n]

Optional: Allows you to specify the regional code of the language to be used for day and month
names. If no regional code is given, PlanMaker uses the system's default language. Example: [$-409]
represents English (US).

* The "endless" time format distinguishes itself from other time formats by its feature of not setting the time back to 0:00 after 24 hours. This is useful for
calculations with times. For example, when you add 20:00 and 5:00, the result would normally be 1:00. But if you format this calculation as [h]:mm,
the result will be 25:00.
The endless time format also supports negative time values. For example, 7:00 - 10:00 does not result in 21:00, but in -3:00.
The same applies to minutes and seconds, which are also not reset after 60 minutes/seconds. You can even use the endless time format to convert times
to minutes or seconds. For example, when you format 02:00:00 as [mm]:ss, 120:00 will be displayed. When you format it as [s], 7200 (the number of
seconds) will be displayed.

Defining separate sections for positive numbers, negative numbers, zero, and text
You can split the text string that defines a number format into up to four sections (separated by semicolons).
This allows you to define different formats for positive numbers, negative numbers, the number zero, and text –
as follows:
Positive; Negative; Zero; Text
The number of sections that you include has the following effect:
Number of sections

Effect

Just 1 section:

The format codes apply to all values.

2 sections:

The codes in the 1st section apply to positive values.
The codes in the 2nd section apply to negative values.

3 sections:

The codes in the 1st section apply to positive values.
The codes in the 2nd section apply to negative values.
The codes in the 3rd section apply to the number zero.
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The codes in the 1st section apply to positive values.
The codes in the 2nd section apply to negative values.
The codes in the 3rd section apply to the number zero.
The codes in the 4th section apply to text.

Example (with two sections):
0.00; -0.00[Red]
This number format has the following effect:
1st section: 0.00 causes positive numbers to be displayed with two digits after the decimal point.
2nd section: -0.00[Red] causes negative numbers to be displayed with two digits after the decimal point as well.
A minus sign is displayed in front of the number (see note!). Additionally, the number is colored in red.
Note: When you define a number format with two (or more) sections, and you want negative values to be
displayed with a minus sign, you must include a minus sign in the section for negative numbers.
The reason is that, as opposed to number formats with just one section, minus signs will not be displayed
automatically for number formats with multiple sections.

Defining separate sections using conditions
Alternatively, you can split the text string that defines a number format into multiple sections by specifying a
condition for each section.
The individual sections must by separated by semicolons. To specify the condition for a section, simply type in
the desired comparison, enclosed in square brackets – for example comparisons like [>0] or [>=100] or [=42].
You can define up to two sections that contain a condition. After these sections, an additional section that
defines the number format for those values that don't match the condition should be specified.
An example:
[<=0][Blue]0.00; [>30][Red]0.00; 0.00
These format codes display all values smaller than or equal to zero in blue. Values larger that 30 are displayed
in red. Values not matching any of these two criteria are not colorized; they are displayed in black.
Hint: "Conditional formatting" provides a much more convenient and powerful way to perform such tasks.
See section Conditional formatting.

Borders and lines
To add border lines to cells, choose the menu command Format > Cell and switch to the Borders tab.
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Alternatively, use the Format > Borders menu command, which is doing exactly the same.
You can add border lines at the left, right, top or bottom of cells, and you can create borders that completely
surround cells. Also, you can add gutter lines (the lines between the cells) in this dialog.

A similar dialog box appears for all types of objects that allow you to add border lines (e.g. text frames or table
cells).
Essentially, you operate this dialog as follows:
1.

First you specify what kind of border lines you want (by selecting a line style, thickness, and color).

2.

Then you pick where to apply the specified border lines – by clicking on the respective lines in the preview
box displayed in the right half of the dialog (or on the buttons surrounding it).

Let's have a look at the entire procedure in detail:
For example, to add borders to cells, you do the following:
1.

Select the cells of interest.

2.

Invoke the menu command Format > Borders.

3.

First, choose what kind of border lines who want – by specifying the following options:
Line style (single, double, or dashed lines)
Thickness of the line
Color of the line
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Then, specify where to apply this line (top, bottom, left, right, etc.).
For this purpose, a preview box surrounded by a set of buttons is available in the right half of the dialog. Use
it as follows:
A) When you click on one of the lines in this preview, the selected type of border line is applied to the
corresponding border.
B) Alternatively, you can click on the buttons displayed to the left and below the preview. Each button
represents one border (indicated by the symbol displayed on the icon).
C) The buttons shown above the preview provide some shortcuts:
The Outline button applies the currently set up border line to all outer borders.
The Inside button does the same for all inner lines (the gutter lines).
The None button removes all lines at once.

5.

Add as many lines as you like – by simply repeating step 4.
Of course you can always modify the line settings (step 3) before you apply the line (step 4).

6.

When done, confirm with OK.

The lines are now added to the selected cells.

Changing or removing existing border lines
You can change the style, thickness or color of existing border lines anytime – and of course you can also
remove border lines. To do so, invoke the Format > Borders menu command again and proceed as follows:
¡ Modifying: To modify the appearance of a line, first choose the desired settings (style, thickness, color).
Then, click on the line of interest in the preview (or on its button) in order to apply the line there.
¡ Removing: To remove a border line, click on it in the preview (or on its button) twice. Clicking once applies
a line to a border, clicking once more removes it again.
Hint: The None button displayed above the preview removes all lines at once.

Tip: Using the Formatting toolbar
Alternatively, you can use the

icon at the very right of the Formatting toolbar to apply border lines.

Proceed as follows:
1.

Select the desired cells.

2.

Click the arrow right of the icon (not the icon itself). A menu with several predefined border styles will
open. Click on the desired style.

The border lines are now applied.
Tip: If you want to apply the same border style to other cell ranges thereafter, simply select them and click
the icon itself (not the arrow). PlanMaker will apply the last chosen border style once more.
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Shading
To apply a shade or fill pattern to cells, choose the menu command Format > Cell and switch to the Shading
tab.
Alternatively, use the Format > Shading menu command, which does exactly the same.

To change a single cell, navigate to it without selecting. To change multiple cells, select them before executing
this command. Then proceed as follows:
¡ Applying a shade
You can add a color shade mixed from a specific foreground color and background color to the selected
paragraphs.
To add a shade, set the Type to Shading and specify the following settings:
First, choose a Foreground and a Background color. (The background color is set to white by default.)
In the Shades section, several mixtures of these two colors are now offered. Click on one of these
suggestions to choose it. Alternatively, you can enter an exact percentage for the shade in the edit box below
Shading (in the Type section). Values between 0 (100% background color) and 100 (100% foreground
color) are allowed.
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¡ Applying a fill pattern
To add a pattern, click on one of the patterns in the Pattern section.
You can also select a different Foreground and Background color for the pattern.
¡ Removing shades or pattern
To remove any shade or pattern applied, select None in the Type list.
Then confirm with OK.

Tip: Using the Formatting toolbar
Alternatively, you can use the

icon at the very right of the Formatting toolbar to apply color shades.

Proceed as follows:
1.

Select the desired cells.

2.

Click the arrow right of the icon (not the icon itself). A menu with predefined colors will open. Click on the
desired color.

The shade is now applied.
Tip: If you want to apply the same shading color to other cell ranges thereafter, simply select them and click
the icon itself (not the arrow). PlanMaker will apply the last chosen color once more.

Alignment
To change the alignment of cells, choose the menu command Format > Cell and switch to the Alignment tab.
To change a single cell, navigate to it without selecting. To change multiple cells, select them before executing
this command.
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Options available:

Horizontal alignment
Determines the horizontal alignment of the cell content within the cell boundaries:
Default: Text left-aligned, numbers right-aligned, and logical values and error values centered
Left: Left-aligned
Centered: Centered
Right: Right-aligned
Justified: Fully justified (evenly distributed between left and right cell border). This affects only cells that
contain multiple lines of content and have the Wrap text option (see below) activated.
Center across columns: Content of one cell centered across multiple columns. Select the cell with the content
and an arbitrary number of cells right of it beforehand (these cells have to be empty!).

Vertical alignment
Determines the vertical alignment of the cell content within the cell boundaries:
Bottom: Aligned to the bottom
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Centered: Aligned to the center
Top: Aligned to the top
Justified: Vertically justified (evenly distributed between top and bottom cell border). Only affects cells that
contain multiple lines of content and have the Wrap text option (see below) activated.

Rotate by...
Rotates the cell content by the specified angle.

Text direction
For text in Arabic script, you can change the text direction of the cell to right-to-left here.
Tip: If you choose the default setting Context sensitive, PlanMaker determines the correct writing direction
automatically.
See also chapter Working with Arabic text.

Inner margins
Lets you modify the inner margins of cells.

Wrap text
If this option is checked, the cell content will automatically be wrapped to multiple lines, if it does not fit into a
single line.
Hint: To wrap parts of the cell content to the next line manually, press Ctrl+¿.
By default, this option is switched off, so that text that does not fit is continued right of the cell.

Vertical text
If this option is checked, the cell content will be displayed vertically (top to bottom instead of left to right).

Merge cells
Lets you merge a cell with neighboring cells. Merged cells are treated as if they were one single cell.
To merge cells, select them and activate this dialog option.
Note: Whenever you merge cells, the content of all selected cells is automatically deleted – except for the cell
in the upper left corner of the selected range.
To disconnect merged cells, select them again and turn this option off.
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Protection
The Protection tab in the dialog of the Format > Cell menu command can be used to prevent cells from being
changed, to hide the cell content or formula, or to disable printing.
For more information, see section Sheet protection.

Character format
Use the menu command Format > Character to change the character format of text. The character format
includes settings like font, font size, font style (bold, italic, etc.), font color, etc.
Before invoking this command, you can select the text that you want to change, as follows:
¡ To change the character format of a single table cell, simply navigate to it – without selecting.
¡ To change multiple cells, select them before executing this command.
¡ If you press F2 and select just parts of the cell content, only the selected characters will be changed.
The options in the dialog of this command are distributed over several "index cards". You can switch between
them by clicking on one of the tabs along the top of the dialog.
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The following format options are available:
¡ Font tab
Typeface and font size, text style (bold, italic, etc.), text color
¡ Spacing tab
Superscript and subscript, letter spacing and character pitch, kerning
¡ Hyperlink tab
For inserting and editing hyperlinks (e.g., to web pages). You will find information about this topic in
section Working with links.
See the following pages for detailed information.

Typeface and font size
To change the typeface and/or font size of text, do the following:
1.

Select the cells or the text segment to be modified.

2.

Invoke the menu command Format > Character.
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In the associated dialog, switch to the Font tab (if necessary).

Now you can set the desired typeface and font size:
¡ To change the typeface, open the Typeface dropdown list box by clicking on the small arrow to its right and
select the desired typeface.
¡ The most useful font sizes are presented in the Size dropdown list box. You can select one of these sizes or
enter a different size manually. Type sizes can be given with a precision of a tenth of a point – thus a size
such as 12.7 is allowed.

Using the Formatting toolbar
You can also change the typeface and font size with the Formatting toolbar.

This is done by selecting the text you want to format, opening the dropdown list box containing typefaces, or
the one containing type sizes, and selecting the desired format from the list with a mouse click.

Text styles
Text styles are formattings like bold, italic, underline, etc.
PlanMaker supports the following text styles:
¡ Italic: A slanted variant of the typeface.
¡ Bold: A heavier ("thicker") variant of the typeface.
¡ Underline: The text is underlined (single, double, words only single, words only double, etc.).
¡ SMALL CAPS: Lowercase letters are replaced with small uppercase letters.
¡ ALL CAPS: All letters are rendered in uppercase.
¡ Strike out: The text is struck through.
¡ Superscript (e.g. r2 ) and subscript (e.g. H2O): These text styles are found on the next tab (see Superscript
and subscript).

Applying text styles
To apply text styles, invoke the menu command Format > Character and switch to the dialog's Font tab.
To turn on bold or italic, open the Style list (to the right of font size option) and select the desired style from
the list: Regular, Italic, Bold or Bold-Italic.
To apply other text styles, turn them on or off by clicking on the corresponding checkbox in the Styles section
of the dialog.
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You are not limited to just one style; rather, you can apply combinations of the styles to text (although not all
combinations are possible).

Using the Formatting toolbar
The most commonly used text styles can also be applied using the Formatting toolbar.

Click on the icon for the text style you want to apply or remove: The B stands for bold, the I for italic, and the
U for single underline.

Keyboard shortcuts
There are also keyboard shortcuts for the application of text styles:
Command

Windows/Linux

Mac

Bold

Ctrl+B

Cmd+B

Italic

Ctrl+I

Cmd+I

Underline

Ctrl+U

Cmd+U

Text color
You can specify the color for both text itself and for its background.
To do this:
1.

Select the cells or the text segment to be modified.

2.

Invoke the menu command Format > Character.

3.

In the associated dialog, switch to the Font tab (if necessary).

You can now select the desired color for the text from the Text color list.
You can also specify a background color for the text using the Background color list. By default, the
background color is set to Transparent. If you choose a different color for the background, the text will appear
against this color.
Note: Changing the background color of cell contents does not shade the entire cell but only the content. To
shade whole cells, use the Format > Shading menu command.
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Notes
¡ If none of the existing colors offered in the color list suits you, you can always compose your own colors. To
do this, click on "Define color...", which is the last item in the color list (see also section Document
properties, Colors tab.
¡ The text color can also be changed using the

icon in the Formatting toolbar:

To do so, select the text (or cells) of interest and click on the little arrow right of this icon (not on the icon
itself). Then, choose the desired color from the list that opens.
Tip: To apply to same color to another piece of text, select the text and simply click on the icon itself.

Superscript and subscript
To activate superscript (e.g., r2 ) or subscript (e.g., H20) for characters:
1.

Select the cells or the text segment to be modified.
If you press F2 and select just parts of the cell content, only the selected characters are changed.

2.

Invoke the menu command Format > Character.

3.

Switch to the Spacing tab.

4.

Check the Superscript or the Subscript checkbox.

If you wish, you can specify the amount of offset above or below the baseline by entering a percentage in the
Position edit box. In addition, you can specify the size reduction to be applied to the superscripted or
subscripted text by entering a percentage in the Size edit box. For example, if you want a subscript to be the
same size as adjoining normal text, you can specify 100 percent.

Letter spacing and character pitch
To change the spacing or the pitch of text:
1.

Select the cells or the text segment to be modified.

2.

Invoke the menu command Format > Character.

3.

Switch to the Spacing tab.

4.

Enter the desired values at Spacing between characters or Character pitch.

Spacing is the horizontal distance between characters. If you make the value smaller than 100%, the characters
appear closer together than normal, and if you make the value larger than 100%, the characters appear farther
apart.
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If you change the character pitch, the width of the characters themselves, rather than the spacing between
them, is affected.
Note: For some printers, changing the pitch of characters formatted in one of the printer's internal fonts is
ignored in the printout.

Kerning
Certain pairs of letters look better when the spacing between these letters is reduced or increased a bit. Such
adjustments, called Kerning, can be made automatically by PlanMaker.
A picture illustrates best what kerning is about:

Top: without kerning, bottom: with kerning

The upper half of the picture (without kerning) shows that the letters "V" and "A" are too far apart when no
kerning is applied. In the lower half (with kerning), this has been corrected.
To activate kerning, select the cells (or the text segment) of interest, choose the Format > Character menu
command, switch to the Spacing tab and activate the option Use kerning.
PlanMaker now automatically adjusts the spacing between all letters where this would improve the text
appearance.
Note: Not all typefaces provide kerning information in their font data, which is required to determine which
letter pairs to adjust and how. Almost all font collections published by SoftMaker include extensive kerning
information.

Removing character formatting
In case you need to remove character formatting, PlanMaker lets you do this easily.
Proceed as follows:
1.

Select the cells or the text segment to be modified.

2.

Invoke the menu command Format > Standard.
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PlanMaker now removes any character formatting that you have applied to the selected text.

Paragraph format (text frames only)
When you have placed text in a text frame, you can modify its paragraph format using the Format >
Paragraph menu command.
Note: This command is available only in text frames. To learn more about text frames, see the section Text
frames.
Paragraph formats include:
¡ Paragraph indents
¡ Line spacing
¡ Paragraph alignment
¡ Spacing above/below a paragraph
¡ Hyphenation frequency (see section Hyphenation)
For detailed information, see the pages that follow.

Paragraph indents (text frames only)
Note: Paragraph indents can be applied only to text placed in a text frame. To indent cell contents, modify
the cell's inner margins in the dialog of the Format > Cell menu command (Alignment tab).
To indent text in a text frame, choose the menu command Format > Paragraph. There are independent
settings for Left, Right, and First. The first line indent can be either positive or negative, and is used as an
offset from the left indent of the paragraph.

Line spacing (text frames only)
Note: Line spacing can be applied only to text placed in a text frame.
Line spacing is the distance between lines of a paragraph.
To change the line spacing of text in a text frame:
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1.

In the text frame, place the text cursor in the paragraph of interest (or select multiple paragraphs to be
modified).

2.

Invoke the command Format > Paragraph menu command.
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You will find the options for line spacing in the Line spacing group box:
3.

First, select the method you want to use to specify the line spacing (see below) from the dropdown list box.

4.

Then enter the spacing in the edit box to its right.

When you confirm with OK, the line spacing will be changed according to your settings.

Methods of specifying the line spacing
You can specify the line spacing in different ways. The Line spacing dropdown list allows you to choose from
the following methods:
¡ Single
Automatic single line spacing.
Determines the optimum line spacing automatically:
If you increase the font size in the paragraph, the line spacing will be increased accordingly.
If you decrease the font size, the line spacing is reduced accordingly.
¡ Multiple
Multiple of automatic single line spacing.
Just like the Single option, this option determines the optimum line spacing automatically. However,
whenever required, you can increase or decrease the line spacing easily: Simply enter the desired number of
lines into the edit box right of this option.
Some examples:
When you enter "1.5" in the Lines edit box, the automatically determined spacing is multiplied by 1.5
(giving you automatic one and a half line spacing).
When you enter "2", the automatically determined spacing is multiplied by 2 (giving you automatic double
line spacing).
Entering "1" corresponds to choosing the option Single (giving you automatic single line spacing).
¡ Exactly
Fixed line spacing.
If you choose this option, you can enter the exact line spacing manually in points. Here, the line spacing will
not be adapted to the font size.
¡ At least
Automatic line spacing with a given minimum.
Just like the Single option, this option also provides automatic single line spacing – but prevents any
reduction below the specified minimum value.
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So, if you enter e.g. 12 points as a minimum value, normally automatic single line spacing is applied.
However, if the automatic line spacing becomes smaller than 12 points (for example, because you used a
very small font size), a fixed line spacing of 12 points is applied instead.
By default, the line spacing is set to Single.

Paragraph alignment (text frames only)
Note: Paragraph alignment can be applied only to text placed in a text frame. To change the alignment of cell
contents, use the Format > Cell menu command (Alignment tab).
To change the alignment of text in a text frame, choose the menu command Format > Paragraph and select an
alignment in the Alignment dropdown list.
Available alignment types:
¡
¡
¡
¡

Left
Centered
Right
Justified (evenly distributed between left and right margin)

Changing the text direction (for Arabic text)
For text in Arabic script, there's an additional option named Text direction where you can set the writing
direction of the paragraph to right-to-left. See also chapter Working with Arabic text.

Spacing above/below a paragraph (text frames only)
Note: Paragraph spacing can be modified only for text placed in a text frame. To change the spacing between
cells, simply change their row height.
In text frames, you can add extra spacing above and/or below paragraphs.
For this purpose, select the desired paragraphs in the text frame, choose the menu command Format >
Paragraph, and enter the desired values for the following options:
Option

Function

Before

Here you can set the amount of spacing to be added between the end of the previous paragraph and the
beginning of the current paragraph.

After

Here you can set the amount of spacing that PlanMaker should reserve between the end of the current
paragraph and the beginning of the next paragraph.
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Note: These values do not affect the amount of space between lines within a paragraph (see section "Line
spacing").

Character styles
Use the menu command Format > Character style to select from a list of defined character styles, or to create
and modify character styles.
Character styles are a collection of character attributes (font, size, style, etc.) that you can name, save, and later
apply to cells. For example, you can create one character style for cells containing values (using e.g. 10 point
Times New Roman), and another style for headings (using 14 point Arial bold).
When you choose a character style, all the attributes stored in that style are applied to the selected cells (or the
selected characters) at once.
Annotation: PlanMaker also supports cell styles (see section Cell styles). The difference between these two
features is that character styles store the character format only, whereas cell styles store both character format
and cell format (number format, alignment, etc.). Apart from that, character styles can be applied to single
characters within a cell, whereas cell styles can only be applied to entire cells.
See the next pages for detailed information.

Creating character styles
To create a new character style:
1.

Invoke the menu command Format > Character style.

2.

Click on the New button.

3.

Enter a name for the new character style and click OK.

4.

A dialog box similar to the one of the Format > Character menu command (see section Character format)
pops up. Here, you can specify the desired character format for this style.

5.

Click OK.

6.

Click Close.

The new character style is now defined and ready to use. To learn how to apply character styles, see the next
section.

Assigning a keyboard shortcut to a character style
If you use a character style frequently, it might be useful to assign a keyboard shortcut to it, allowing you to
apply it with a single keystroke.
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For this purpose, choose the menu command Format > Character style, select a style, click Edit, and switch
to the Style tab. Place the cursor in the Shortcut key input box and press the desired key combination.
Note: If you enter a key combination that is already in use, its current assignment will be displayed below the
Shortcut key box. To prevent overwriting the keyboard shortcut for another style or menu command, press
the BackspaceÕ key and assign a different key combination.
Applying keyboard shortcuts utilizing Ctrl and Shift is suggested, as these shortcuts are usually available.

Applying character styles
To apply a character style:
1.

Select the desired cells. (Or, press F2 and select partial cell content, if applying to selected characters.)

2.

Choose the menu command Format > Character style.

3.

Click one of the character styles listed.

4.

Click the Apply button.

The character format of the selected cells/characters will change to the character format defined in the character
style.
Tip: Character styles can also be applied by selecting them from the font list in the Formatting toolbar.
Even faster: If you have assigned a keyboard shortcut to a character style, the style can be applied by
pressing the corresponding key combination.
To remove a style, apply the "Normal" character style. Keep in mind that text to which a character style has
been applied can always be given additional formatting with e.g. the menu command Format > Character.

Modifying character styles
Note: When you change the formats stored in a character style, all cells using this style are changed
accordingly.
To modify a character style:
1.

Choose the menu command Format > Character style.

2.

Select the style you want to modify.

3.

Click Edit.
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4.

A dialog box similar to the one of the Format > Character menu command (see section Character format)
pops up. Modify the character format as desired.

5.

Click OK.

6.

Click Close.

Deleting or renaming character styles
To delete a character style, choose the menu command Format > Character style, select a style, and click the
Delete button. To rename it, click the Rename button.

The character style Normal
Every document you create contains a character style named "Normal". This is the default character style.
As long as you do not apply other character styles, every cell in a document uses the "Normal" character style.
Additionally, every character style you create is based on this style.
In other words: The "Normal" character style defines the default character format in a document. For example,
if you change the font in this style, all cells (except the ones manually formatted with a different font) will be
formatted in that font.

Creating linked character styles
If you create new character styles as described at the beginning of this chapter, they will always be based on the
character style "Normal". If you later change, for example, the font of the "Normal" style, the font of all derived
styles changes as well – unless you explicitly chose a different font there.
Note: By default, all character styles are based on the character style "Normal". You can however base them
on any other character style by selecting the base style in Based on.
To create a style and base it on another style, proceed as follows:
1.

Choose the menu command Format > Character style.

2.

Click New.

3.

Enter a name for the new character style.

4.

On the Style tab, choose the character style on which the new style should be based using the Based on
option.

5.

You can now apply the desired formatting to the character style.
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Scaled font size
If you base a style on another, you can optionally define a relative font size. You can, for example, set the font
size of style X to be always 80% of the font size of style Y.
To do this, proceed as follows:
1.

Choose the menu command Format > Character style.

2.

Select one of the styles and click on Edit.

3.

Switch to the Style tab.

4.

Enable the option Scale.

5.

Enter the desired scaling factor as a percent value – for example, 80.

6.

Confirm with OK.

The font size of such a style will now always be 80% of the font size of the style it is based on.

Cell styles
Use the menu command Format > Cell style to select from a list of defined cell styles, or to create and modify
cell styles.
Cell styles are a combination of cell attributes (number format, orientation, borders, etc. as well as the character
format) that you can name, save, and later apply to cells. Whenever you choose a cell style, all the attributes
stored in that style are applied to the selected cells at once.
For example, if you want to frequently format cells with the number format "Percent", red background and bold
font, simply create a corresponding cell style and apply it to as many cells as desired.
Annotation: PlanMaker also supports character styles (see section Character styles). The difference between
these two features is that character styles store the character format (font etc.) only, whereas cell styles store
both character format and cell format. Apart from that, character styles can be applied to single characters
within a cell, whereas cell styles can only be applied to entire cells.
See the next pages for detailed information.

Applying cell styles
To apply a cell style:
1.

Navigate to the cell of interest. Alternatively, you can select multiple cells to change them altogether.

2.

Choose the menu command Format > Cell style.
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A dialog appears with a list of all cell styles.
Tip: You can use the Show option to determine whether all available styles should be displayed in the list –
or only those already used in the current document.
3.

Select the desired style in the Styles list.

4.

Click the Apply button.

The cell format and character format of the selected cells will be changed to the format defined in the cell style.
Tip: Cell styles can also be applied by selecting them from the dropdown list displayed on the left side of the
Formatting toolbar.
In detail, a cell style can contain the following formatting options:
¡ Number format
¡ Font (font face, size, style, etc.)
¡ Cell alignment
¡ Shading
¡ Border
¡ Cell protection
In the section Format includes of the above dialog, you can (optionally) specify exactly which of these
formatting options should be used when you apply the selected cell style (see also next section).

Creating cell styles
To create a new cell style:
1.

Choose the menu command Format > Cell style.

2.

Optional: In the Styles list, choose the cell style on which to base your new style (or simply select the
default style called "Normal").

3.

Click the New button.

4.

Enter a name for the new cell style and click OK.

5.

The new cell style has now been created, and you can modify it as follows:
To change the character format, click the Character button. A dialog box similar to the one of the Format
> Character menu command pops up (see section Character format). Make the desired modifications and
click OK.
To change the cell format, click the Cell button. A dialog box similar to the one of the Format > Cell menu
command pops up (see section Number format). Make the desired modifications and click OK.
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Click Close (or the Apply button first if you want to see the result of the cell style directly for the selected
cells).

The new cell style is now defined and ready to use.
You can create a different set of cell styles for each document; the styles are stored inside the document.

The selection "Based on"
If you select Based on, you can create new cell styles using previously created cell styles, copy their formatting
and adjust them. You thus build on the format properties of a style predecessor that you have already created.
In addition, subsequent changes to the formatting of the style predecessor are also "inherited" to its successors
for all other cell styles that you have set as based on this predecessor.
Please Note: If you want to create a new cell style Based on another cell style and you have not yet created
your own cell style, then this option is initially grayed out (i.e. cannot be selected), because only the standard
styles are available so far, for example the "Normal" style. In this case, the formatting of the "Normal" style
is used by default for a new cell style. Once you have self-defined your own new cell style and then select it
from the styles list, you will be able to use the option Based on.
An example to explain the "inheritance" of formatting:
Create your first cell style as described in the chapter above using the New button. Name it maybe "Cell
style1". This style initially has the formatting of the standard "Normal" style and can be modified to your own
requirements via cell format and character format. For example, apply a pattern for the cell format in the
Shading tab.
Now create a second cell style based on Cell style1 and press the New button again. Name this next style
maybe "Cell style2".
The result looks like this:
1.

The Cell style2 has adopted the formatting from Cell style1.

2.

You can further customize the formatting of Cell style2.

But what's important: Subsequent changes to the formatting of Cell style1 will also lead to be adopted in Cell
style2. Unless it concerns formatting options that have already been changed individually in Cell style2: these
are kept there.

The "Format includes" section
In the Format includes section of the dialog, you can specify exactly which of the formatting options to
include when you apply the cell style.
For example, cell styles such as "Currency" should solely provide the cells with the number format "Currency"
– and nothing else. That's why all options except for "Number format" are deactivated in this style.
The setting in this section can be made for each template individually.
Please note: Just like "Based on", you cannot use these options until you have created your own new cell
style. Otherwise the fields are grayed out and not selectable.
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Assigning a keyboard shortcut to a cell style
If you use a cell style frequently, it might be useful to assign a keyboard shortcut to it, allowing you to apply it
with a single keystroke.
To assign a keyboard shortcut to a style, invoke the Format > Cell style menu command and select the style of
interest. Then, click into the Shortcut input box and press the desired key combination.
Note: If you enter a key combination that is already in use, its current assignment will be displayed below the
Shortcut key box. To prevent overwriting the keyboard shortcut for another style or menu command, press
the BackspaceÕ key and assign a different key combination.
Applying keyboard shortcuts utilizing Ctrl and Shift is suggested, as these shortcuts are usually available.

Modifying cell styles
Note: When you change the formatting options stored in a cell style, all cells using this style are changed
accordingly.
To modify a cell style:
1.

Choose the menu command Format > Cell style.

2.

Select the style to be modified.

3.

To modify the cell format, click on the Cell button. To modify the character format, click on the Character
button.

4.

Click on the Close button when done.

Deleting or renaming cell styles
To delete a cell style, choose the menu command Format > Cell style, select a style, and click the Delete
button. To rename it, click the Rename button.
Note: Some of the cell styles are predefined and cannot be deleted or renamed.

The cell style Normal
Every document you create contains a cell style named "Normal". This is the default cell style.
As long as you do not apply other cell styles, every cell in a document uses the "Normal" cell style.
Additionally, every cell style you create is based on this style.
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In other words: The "Normal" cell style defines the default cell format in a document. For example, if you
change the number format in this style, all cells (except the ones manually formatted with a different number
format) will be formatted in that number format.

Document templates
Character styles and cell styles (see previous sections) are stored in the document they were created in. To reuse
styles in other documents, store them in a document template.
When you use the File > New menu command to create a new document, PlanMaker requires that you choose
the document template the new file will be based on. Choosing a document template that contains user-defined
character and cell styles will make these styles available in the new document.
Note: Document templates can not only contain your favorite character and cell styles, but also text, values,
calculations, etc. This enables you to create a set of templates for invoices, annual reports, balance sheets, or
other frequently used documents.

Creating document templates
To create a new document template:
1.

Start a new document or open the document to base the document template on.

2.

Create the desired character and cell styles (and text, values, calculations, etc.) to be stored within the
template.

3.

Choose the menu command File > Save as.

4.

In the Save as Type list, select PlanMaker template.

5.

PlanMaker automatically switches to the document template folder.

6.

Enter a filename for the template.

7.

Click OK to confirm.

The new template will now be stored.

Using document templates
To use a user-created document template, start a new document. PlanMaker will display a dialog to let you
select the document template:
1.

Choose the menu command File > New.
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Click one of the document templates listed.

3.

Click OK to confirm.
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PlanMaker will create a new document based on the selected template. It will contain all character and cell
styles stored in the document template, as well as all the text, values, calculations, etc., stored in the template.

Modifying document templates
To modify a document template, proceed as you would modify a normal document: Open it, make your
changes, and save it:
1.

Choose the menu command File > Open.

2.

In the file types list box, select PlanMaker template.

3.

Select the template to modify. Click OK.

4.

Modify the content and/or the styles of the template as desired.

5.

Choose the menu command File > Save to save the template.

The document template Normal.pmvx
The document template named normal.pmvx is the default template for new documents. When using the File
> New menu command, this template is selected by default. Please keep this in mind when modifying this
template.
By default, normal.pmvx is completely empty. All it contains is the standard character style "Normal" and
standard cell style "Normal". Therefore, this template is an ideal basis for creating new documents or document
templates from the scratch.
Hint: To use a different document template as your default template, choose the menu command File > New,
select a template, and click the Set default button. From now on, this template will be selected by default when
creating a new document.

AutoFormat
The Format > AutoFormat menu command lets you apply a predefined scheme of formattings to an entire cell
range.

Formatting worksheets

194

For this purpose, select the desired cell range and choose the menu command Format > AutoFormat. A dialog
displaying a list of predefined AutoFormats pops up. Select the desired format and click OK. The cell range
will be reformatted accordingly.
Note: The options in the Apply group box of the dialog let you choose which formatting options to apply. For
example, if you deselect all options except Borders, only the border lines will be applied; all other formatting
options will remain unchanged.

Conditional formatting
The menu command Format > Conditional formatting allows you to add conditional formatting to cells.
Conditional formatting will only be applied when a certain condition is met. This way you can achieve that, for
example, a cell is displayed in red color whenever its content is greater than 1000.
Detailed information is provided on the next pages. Topics covered:
¡ Creating a new conditional formatting rule
To add conditional formatting to cells, you select those cells and create a so-called formatting rule for them.
Example: "If the cell content is greater than 1000, display it in red color."
You can create as many formatting rules for a cell (or cell range) as you like. For example, you can add a
second rule that formats the cell in boldface if it contains a value below zero etc. etc.
¡ Types of conditional formatting rules
This section details the different types of formatting rules available.
¡ Managing conditional formatting rules
The Manage rules command gives you access to a dialog where you can manage all conditional formatting
in a document. For example, you can edit conditional formatting rules, delete rules, etc.
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¡ Removing conditional formatting
The last section covers the removal of conditional formatting.

Creating a new conditional formatting rule
To add conditional formatting to cells, you select those cells and create a so-called formatting rule for them.
Formatting rules always consist of two parts:
¡ a condition
¡ ... and the formatting to be applied when this condition is met
Example: "If the cell content is greater than 1000, display it in red color."
To define (and apply) a formatting rule like this, proceed as follows:
1.

Navigate to the cell of interest (or select a range of cells).

2.

Choose the menu command Format > Conditional formatting > New rule.

3.

At Type, choose what kind of condition you want to use.
In our example, you would select Format only cells that contain.
(For detailed information on each type of condition, see the section Types of conditional formatting rules).

4.

Next, specify the desired condition.
In our example, this would be the condition "cell value is larger than 1000". Accordingly, select the options
Cell value and greater than. In the edit control at the right, type in the value 1000.

5.

In the last step, click on the Format button and specify the formatting options to be applied whenever the
condition is met.
In our example, switch to the Font tab in the dialog that pops up. There, set the Text color to red color and
click on OK.

6.

Click OK to confirm and create the new rule.

7.

Close the dialog by clicking on Close.

The new formatting rule is now created – and at the same time applied to the selected cells. This has the
following effect:
¡ If the cell content is smaller than or equal to 1000, the cell will be displayed in its original format.
¡ If the cell content is greater than 1000, the cell will be displayed in the conditional format, that is, in red
color.
Hint: You can create as many formatting rules for a cell (or cell range) as you like. For example, you can add
a second rule that formats the cell in boldface if it contains a value below zero etc. etc.
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Types of conditional formatting rules
In the dialog for creating new conditional formatting rules (see previous section), you can choose between the
following types of rules:

Format all cells based on their values
This type of conditional formatting rule actually does not utilize a condition at all. It rather reformats all of the
selected cells – based on the values they contain.
For example, if you choose a 2-color scale from red to green, the lowest value will be highlighted in red color,
and the highest value in green color. The colors for the values in-between will be calculated automatically. The
result is a color gradient like e.g. the following:

There are several sub-types available for this type of formatting rule. They can be selected using the Format
Style control, which contains the following entries:
¡ 2-color scale
As described in the example above.
¡ 3-color scale
Same as the 2-color scale, with an additional option to specify the color of the medium value.
¡ Data bars
Displays a bar in the background of each cell, representing the relative size of the value – similar to a bar
chart:
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¡ Icons sets
Displays an icon in each cell, indicating the size of the respective value – for example a red signal light for
the lower third of the values, a yellow one for the medium third, and a green light for the upper third:

Format only cells that contain ...
This type of rule reformats only those cells within the current selection that meet the specified condition.
Proceed as follows:
First, specify the desired condition, using the controls and input boxes in the dialog.
Then, click on the Format button and specify the formatting options to be applied for all cells that meet the
condition.
An example can be found in the previous section – where we created a formatting rule that paints the cell
content in red color if it is larger than 1000.

Format only upper and lower values
This type of rule reformats only those cells that contain the highest or lowest values within the current
selection.
First, specify which values to reformat – for example, the top 3 values or the top 10% of the values.
Then, click on the Format button and specify the formatting options to be applied for the corresponding cells.

Format values above or below average
This type of rule reformats only those cells that contain values above or below the average of the current
selection.
First, specify which values to reformat – for example, all values above the average.
Then, click on the Format button and specify the formatting options to be applied for the corresponding cells.

Format unique or double values
This type of rule reformats all unique values (or double values) within the currently selected cells.
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First, specify which values to reformat:
¡ all unique values (values that occur just once)
¡ or all duplicate values (values that occur twice or more often)
Then, click on the Format button and specify the formatting options to be applied for the corresponding cells.

Use a formula to determine which cells to format
This type of rule reformats only those cells within the selection where the specified formula returns TRUE.
First, enter the desired formula in the dialog. Note that only formulas that return a logical value (i.e. TRUE or
FALSE) are allowed. See also notes below.
Then, click on the Format button and specify the formatting options to be applied for all cells where this
formula returns TRUE.
Some notes:
¡ Creating suitable formulas
You can enter any kind of formula – as long as it returns a logical value (i.e. TRUE or FALSE).
Examples:
If you enter the formula "SUM($A$1:$C$3) > 42", the conditional format will be applied if the sum of the
cells A1:C3 is greater than 42.
If you enter the formula "ISEVEN(ROW())", the conditional format will be applied if the current cell is
located in a row with an even row number.
¡ Using absolute and relative cell addresses
You can use absolute cell addresses as well as relative cell addresses in such formulas:
Absolute cell addresses like $A$1 always refer to the cell A1.
Relative cell addresses like A1 refer to the cell in the upper left corner of the selection, as follows:
If you have not selected a cell range, A1 refers to the current cell.
If you have selected a cell range, A1 refers to the cell in the upper left corner of that range, A2 to the cell
below it, etc.

Managing conditional formatting rules
The Format > Conditional formatting > Manage rules menu command gives you access to a dialog where
you can manage all conditional formatting in a document. For example, you can edit conditional formatting
rules, delete rules, etc.
You use this command as follows:
1.

Navigate to the cell of interest (or select a range of cells).
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Choose the menu command Format > Conditional formatting > Manage rules.

3.

A dialog pops up.
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Note: By default, this dialog displays only the rules for the current cell (or selection). If you want to see all
rules created in the entire worksheet instead, set the Source option to Current worksheet. (See below for
details.)
4.

Edit the formatting rules to your liking. (See below for details.)

5.

Close the dialog using the Close button.

Operating the dialog
The dialog window for this command has the following controls:
¡ Source
Here you can choose which formatting rules the dialog should display:
Only selected cells: Show only rules that affect the currently selected cells (or, if no cells are selected,
the current cell)
Current worksheet: Show all rules for the current worksheet
Sheet <name>: Show all rules for a different worksheet (if available)
¡ Rules list
The Rules list displays all rules for the current selection or the entire worksheet (depending on what you
have chosen at the Source option).
Rules that affect the currently selected cells are displayed in boldface.
Stop: The checkboxes in the Stop column are something you normally don't have to care about. They are
needed only for compatibility reasons with older documents. (Background info: In older versions of
PlanMaker and Excel, conditional formatting for a cell that had multiple formatting rules was "stopped" as
soon as and any of these rules applied. All further rules for this cell were then ignored. With current versions
of PlanMaker and Excel, this is no longer the case: Here, all rules defined for a cell are respected.)
¡ Arrow buttons next to the Rules list
The arrow buttons next to the Rules list allow you to modify the ranking order of the formatting rules in the
list.
To change the ranking of a rule, select it in the list and then click on the up button (=increase ranking) or
down button (=decrease ranking).
This may be necessary when competing rules have been defined for a cell range – for example, one rule that
wants to color the cell green, and another that wants to color it red.
The higher a rule is placed in the list, the higher its ranking is.
Note: Please note that the list does not reflect the order in which the rules are processed – on the contrary:
The list is processed from bottom to top, so that the rules with the highest ranking are applied last.
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¡ Applies to
Here you can change the target range for a rule.
To do so, select the rule in the Rules list and enter the desired cell range here.
¡ New button
Creates a new conditional formatting rule for the cells currently selected in the worksheet, just like the
Format > Conditional formatting > New rule menu command.
For details on the dialog appearing when you invoke this button, see the section Creating a new conditional
formatting rule.
¡ Edit button
Lets you edit the conditional formatting rule currently selected in the Rules list.
Note: Changes on a rule will affect all cells it was defined for (no matter which cells currently are selected
in the worksheet).
For details on the dialog appearing when you invoke this button, see the section Creating a new conditional
formatting rule.
¡ Delete button
Deletes the rule currently selected in the Rules list.
Note: This will remove the rule from all cells it was defined for (no matter which cells currently are selected
in the worksheet).
For more information on the topic Removing conditional formatting, see the next section.
¡ Go to button
Closes the dialog and jumps to the target area for the rule currently selected in the Rules list.

Removing conditional formatting
Conditional formatting can be removed in two different ways:

A) Deleting formatting rules
When you delete a conditional formatting rule, it will be removed from all cells it was defined for – no matter if
you have currently selected cells in the worksheet or not.
Proceed as follows:
1.

Choose the menu command Format > Conditional formatting > Manage rules.

2.

A dialog pops up.
Note: By default, this dialog displays only the rules for the current cell (or selection). If you want to see all
rules created in the entire worksheet instead, set the Source option to Current worksheet.
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3.

Select the rule to be deleted in the Rules list.

4.

Click on the Delete button.
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This will delete the rule – and accordingly remove it from all cells it was defined for.

B) Removing all conditional formatting from a cell range
There's another method for removing conditional formatting, which removes all conditional formatting from a
particular cell range.
Proceed as follows:
1.

Select the cells of interest.

2.

Invoke the menu command Format > Conditional formatting > Delete rules in selected cells.
(Alternatively you can achieve exactly the same by invoking the menu command Edit > Delete special >
Conditional formatting.)

This will "free" the selected cells from any conditional formatting rules applied to them.
Formatting rules that become superfluous because of that will be deleted automatically.

Input validation
When you apply input validation to a cell, you can achieve the following:
¡ Ensure that only certain types of values (for example, numbers) within certain bounds (for example, between
10 and 20) are considered valid in this cell.
¡ Display an informational text whenever the user goes to this cell (for example, "Please enter only numbers
between 10 and 20.").
¡ Display an error, warning, or alert message window when the user tries to input values that do not pass
validation.
This is useful when you are creating tables that will be filled out by other people and you want to prevent
invalid values from being entered.
For instance, if you would like to limit the input of a certain cell to numeric values between 10 and 20, you
would proceed as follows:
1.

Navigate to the desired cell. Alternatively, you can select multiple cells to change their settings altogether.

2.

Invoke the Format > Input validation menu command.

3.

On the Settings tab, you can specify which types of values are permitted as well as their bounds.
For our example, you would choose the following:
Allow: "Decimal Numbers"
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With Values: "between"
Minimum: 10
Maximum: 20
4.

On the Input message tab, you can enter informational text that is displayed whenever the user goes to the
cell.
For our example, enter here, "Please enter only numbers between 10 and 20." Of course, you can also leave
the input message blank.

5.

On the Error message tab, you can enter text that is displayed in a message box when the user attempts to
input invalid data into the cell.
The icons in the Type area allow you to choose the type of error window that is shown. (See explanation
below.)
Important: The type of the error window also determines whether the user is actually allowed to enter
invalid values. PlanMaker strictly rejects invalid data only when the type Error message (first icon) is
selected!
Furthermore, you can enter the actual text of the message. If nothing is entered, a standard message is given.
For our example, set the type to Error message by clicking the first icon and enter the desired message
(e.g., the title "Invalid entry" and the text "Only numbers between 10 and 20 are allowed here.")

6.

Click OK to confirm.

Now, only values between 10 and 20 will be permitted in the selected cells. Should the user input something
else, an error message is displayed.
Note: Notice that input validation is only active when the user enters values by typing them in. Should the
user paste invalid values into the cell through a copy and paste operation (for example, with the menu
command Edit > Paste), input validation will not intervene!
If you would like to turn input validation off, select the desired cells and choose Edit > Delete special > Input
validation from the menu. Alternatively, you could also invoke Format > Input validation and select "All
values" under Allow.
The dialog box of the Format > Input validation menu command contains the following options:

Settings tab
¡ Allow:
With these options you can specify which types of values are allowed:
Option

Explanation

All values

Allow all types of values (effectively deactivate the input validation)

Integer Numbers

Allow only integer numbers
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Allow only decimal numbers

List entries

Allow only values from a predefined list of permissible values.
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When you use this option, enter a comma-separated list of the allowed values in the
Source field – for example, dog,cat,mouse or 1,2,3,4,5,6.
Alternatively, you can enter an equal sign followed by a range of cells which contains
a list of permissible values. For example, if the cells C1 through C3 hold the values
"dog", "cat" and "mouse" and you enter =C1:C3 in Source, only those three values
will be allowed.
Additional settings are displayed when the Options button is clicked.
Date

Allow only date values

Time

Allow only time values

Text length

Allow only entries whose length falls within the bounds specified here.

User defined

Allow only entries which satisfy the formula given in the Formula field. (For more
information on this, see the end of this section.)

¡ With Values
Here you can further narrow the bounds for allowable values. For instance, if you choose the Between
option, you can specify minimum and maximum values, which the input value must lie between.
¡ Minimum, Maximum etc.
Here you can specify the bounds of the entries. If you enter 10 as the Minimum and 20 as the Maximum,
only values within 10 and 20 are accepted.
You may also use calculations here. If you enter C1 as the Minimum, the contents of the cell must be
greater than or equal to the cell contents of cell C1. Should you enter SUM(D2:D8), the contents of the cell
must be greater than or equal to the sum of cells D2 through D8.
¡ Use dropdown
Only available when List entries is selected under Allow. When this option is selected, an arrow appears on
the right edge of the cell when the user goes to it. When clicked, a dropdown list appears, which contains all
available values for that cell, and from which the user can choose.
¡ Ignore empty cells
If this option is checked, input validation is ignored for empty cells. If the user deletes the contents of a cell,
the cell does not run any input validation until the user enters another value.

Input message tab
On this tab, you can enter informational text that pertains to the cell being filled out – for example, "Please
enter only numbers between 10 and 20." This information is displayed when the user goes to the cell.
This tab has the following options:
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¡ Show input message when cell is selected
Determines whether the input message should be shown or not.
¡ Title
Here you can specify the title of the message.
¡ Message
Here you can enter the text of the message.

Error message tab
On this tab, you can specify the error, warning, or information message, which appears when the user input
does not pass validation.
You are presented with the following options:
¡ Show error message after invalid data is entered
Determines whether the message should be shown or not.
Note: Normally, you should leave this option checked, since input validation is of little use if the user isn't
immediately notified of an invalid entry.
¡ Type
Here you can specify the type of the message. Simply click the desired symbol.
Important: The type of the error window also determines whether the user is actually allowed to enter
invalid values. PlanMaker strictly rejects invalid data only when the type Error message (first icon) is
selected!
Types available:
Error Message (first icon): PlanMaker displays an error message. The user is forced to enter a valid value;
invalid values will not be accepted.
Warning Message (second icon): PlanMaker displays a warning message. The user can decide whether
they proceed with the invalid entry anyway.
Information Message (third icon): PlanMaker only displays an information message. The user must only
acknowledge this message and the invalid data is accepted (as long as the user does not click Cancel).
¡ Title
Here you can specify a title for the message.
If you enter nothing here, a standard text is used as the title.
¡ Message
Here you can enter the text of the message.
If you enter nothing here, a standard text is used as the message.
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Tip: If you would like to have the specified minimum and maximum values displayed in the message,
simply use the placeholders %min and %max. Example: "Error – Only values between %min and %max
are allowed here."

Examples
Some examples of use:
¡ Allow only values within the specified range
On the Settings tab choose first the desired type of value. If only dates are to be allowed, set the option
Allow to "Date". If only numbers are to be allowed, set the option to "Decimal numbers", etc.
After that, you can set the bounds using the with values options. For instance, if only values greater than
one should be allowed, choose the "greater than" option and enter 1 as the Minimum.
¡ Allow only values with a certain length
If you would like to prevent the user from entering values with lengths greater than 40, choose the following
options:
Allow: "Text length"
With values: "smaller or equal"
Maximum: 40.
Note: Characters such as numerals, periods, commas, symbols, etc. count here just as much as characters
such as letters.
¡ Using your own formula for input validation
Advanced users can also choose "User defined" under Allow, and then give a formula for use in the input
validation.
To do this, use a formula that returns a logical value (i.e., TRUE or FALSE). If the result of the formula is
TRUE, the input is treated as valid; if not, it is treated as invalid.
An Example: If you use the formula SUM($A$1:$C$3) > 42, the inputted data is only treated as valid if the
sum of A1:C3 is greater than 42.
Note: Notice that not only absolute cell references, as above, can be used, but also relative cell references:
Absolute cell references, like $A$1, always refer to the cell A1.
Relative cell references, like A1, on the other hand, refer to the cell in the upper left corner of the selected
cells. If you use input validation on only one cell, A1 refers to this cell. If, beforehand, you had marked a
range of cells, A1 refers to the cell in the upper left corner, A2 to the cell below this cell, etc.
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Transfer formatting
To transfer the character format and cell format from one cell to other cells, use the Format > Transfer
formatting menu command as follows:
1.

Click the cell whose format you want to transfer to other cells.

2.

Invoke the menu command Format > Transfer formatting.
The mouse pointer will change to a little brush:

3.

Drag the mouse pointer over the desired cells while pressing and holding the left mouse button.

4.

If you want to apply the format to additional cells, repeat step 3 as often as required.

5.

When finished, invoke the Transfer formatting command once more or simply press the Esc key.

The character format (font, font style, etc.) and cell format (number format, alignment, etc.) will be applied to
the selected cells.

Transferring the format of entire cell ranges
To transfer the format of an entire cell range, select the desired cells and proceed as described above.

Page setup
The page setup dialog allows you to set print options for the worksheet. This includes settings for paper size
and orientation, margins, headers and footers, etc.
Covered in this section:
¡ Page format
Use the menu command File > Page setup to change paper size, orientation, and margins.
¡ Additional page setup options
The Options tab in the File > Page setup dialog provides extended page setup options for controlling page
numbers, print order, etc.
¡ Headers and footers
The Headers and footers tab in the File > Page setup dialog lets you add headers and footers to your
worksheet. Headers are printed above the worksheet; footers are printed below.
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¡ Page breaks
PlanMaker automatically inserts page breaks as needed. If desired, you can insert "hard" page breaks to
override them, using the Insert > Page break menu command.
See the following pages for detailed information.

Page format
Choose the menu command File > Page setup and switch to the Page format tab to modify the page format
(paper size, orientation, margins) of the current worksheet.
Note: You can set up a different page format for each worksheet in a document. For example, within one
document, the page orientation can be set to portrait in one worksheet, and landscape in another.
Options available:

Orientation
Click Portrait for a top-to-bottom page orientation (long edge vertical); click Landscape for a side-to-side
page orientation (long edge horizontal).

Paper size
Lets you select a paper size. Letter size (8.5 by 11 inches) is the default. To use a custom paper size, enter the
appropriate values in the Width and Height boxes.

Margins
Lets you enter values for the page margins.

Distance to edge
Lets you modify the distance between headers/footers and the top/bottom edge of the page.
Note: Headers/footers are printed inside the top/bottom margins. If they do not appear on the printout, check if
a) the Distance to edge is too large, or b) the top/bottom margin is too small.

Paper bins
Available under Windows only: If your printer has multiple paper trays, you can select here which one(s) the
printer should use.
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Tip: If you right-click at the bottom on a worksheet tab, you can use the Copy Page Setup context menu
command to copy all made page settings from one worksheet to another. See also the Managing worksheets
section.

Additional page setup options
Choose the menu command File > Page setup and switch to the Options tab to modify extended page setup
options for the current worksheet.
Options available:

Repeated rows/Repeated columns
Lets you set up rows/columns to be repeated on each page.
Use the following notation: FirstRow:LastRow (or FirstColumn:LastColumn, respectively)
For example, if you have created a table containing a large list of data, with a heading placed in the first row,
enter 1:1 in the Repeated rows box to have this row repeated on every page of the printout.

Print
Check any of these options to include the following table components in the printout:
¡ Row and column headers (Row headers are located left of the table, labeled 1, 2, 3, etc. Column headers
are located above the table, labeled A, B, C, etc.)
¡ Grid (gridlines between the cells)
¡ Comments (comments applied to cells with the Insert > Comment menu command)
Additionally, you can use the Colors option to specify if the printout should be rendered in color:
¡ Original colors: The printout is rendered in its original colors.
¡ Grayscale: Colored text is rendered in black/white, colored objects (pictures, charts, etc.) are converted to
shades of gray.
¡ Outlines only: Colored text is rendered in black/white, colored objects are reduced to their outline in
black/white.

Centering options
If Center horizontally is checked, the worksheet's content will be horizontally centered on the page when
printed.
If Center vertically is checked, the worksheet's content will be vertically centered on the page when printed.
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Page number
Allows you to modify the starting number for page numbers:
Auto: Pages are numbered starting with 1.
Value: Pages are numbered starting with the specified value.
Hint: To add page numbers to a worksheet, insert a Page Number field into the header or footer (see next
section).

Print order
Lets you specify in which order worksheets larger than a page will be printed:
¡ Left to right
Print from left to right, then from top to bottom.
¡ Top to bottom
Print from top to bottom, then from left to right.

Print range
Here you can define a print range for the current worksheet.
When a print range is defined, only the cells inside this cell range will appear when the worksheet is output on a
printer. The rest of the sheet will be omitted.
By default, this input field is empty, meaning that no print range is defined – so the entire worksheet will be
printed. When you type in a cell range (or the name of a named cell range), from now on only this range will
appear in the output when you print the worksheet.
A print range can be defined individually for each worksheet of the document.
Important: When you save a document, this setting will be stored in the document permanently. Thus, when
you open and print this document once more in the future, the output will still be restricted to the specified
print range. To have the entire worksheet printed, simply empty the Print area input field in this dialog. This
will remove the print range.
Hint: There's an alternative and more comfortable way to work with print ranges: You can define the print
range for a worksheet by selecting the desired cell range and invoking the File > Print range > Define print
range menu command. To remove the print range from a worksheet, use the File > Print range > Remove
print range menu command.

Scaling options
These options enable you to scale printouts of the document up or down.
By default, a fixed scaling factor of 100% is set (i.e. the original size is used).
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To change the scaling, first select a Scaling mode, then set the desired value, as follows:
¡ Use fixed scaling factor: Here you can set the scaling factor manually (in percent). Only values between 20
and 200 percent are valid. For example, if you set the scaling factor to 50%, the printout will be scaled down
to half its original size. If you set it to 200%, the printout will be doubled in size.
In the other 4 scaling modes, the scaling factor is calculated automatically according to your settings:
¡ Specify height in pages: Here you specify the desired height of the printout (in pages). PlanMaker will
determine the suitable scaling factor automatically.
¡ Specify width in pages: Here you specify the desired width of the printout.
¡ Specify height and width in pages: Here you specify the maximum height and width of the printout.
¡ Specify number of pages in total: Here you specify how many pages the printout should have in total.
Note: PlanMaker does not allow the automatically determined scaling factor to fall below a value of 20%.
If this limit is under-run, PlanMaker uses a scaling factor of 20%. The same goes for the maximum value
of 200%.

Headers and footers
If desired, you can add headers and/or footers to a worksheet.
Headers/footers are repeated on the top/bottom of each printed page of a worksheet. They are useful for
containing fields such as page number, file name, print date, etc.
Note: Each worksheet of a document can have its own headers/footers.
To modify, for example, the header of the current worksheet:
1.

Choose the menu command File > Page setup and switch to the Headers and footers tab.
Alternatively, use the Insert > Header and footer menu command, which is doing exactly the same.
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To apply one of the predefined headers, choose it from the dropdown list box in the upper half of the dialog.
To modify the header individually, click the Edit button (see also section "Editing headers and footers"
below).
To change the format of the header, click the Format button (see also section "Formatting headers and
footers" below).

3.

Click OK to confirm.

The header is changed accordingly.
Editing footers can be performed in the same manner as headers (using the controls in the lower half of the
dialog).
Note: Headers/footers are not displayed in the worksheet on the screen – they appear in the printout only. To
preview how the headers/footers will appear when printed, use the File > Print preview menu command.

Editing headers and footers
When you click on the Edit button in the dialog described above, you can modify the worksheet's headers and
footers as desired.
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Some notes:
¡ Headers/footers can contain up to three sections
The edit controls for entering headers/footers are split into three parts. This is due to the fact that
headers/footers can consist of up to three sections: a left section (left-aligned), a middle section (centered),
and a right section (right-aligned).
This allows you to display, for example, the date on the left, the filename in the middle, and the page
number in the right section of the header/footer.
Of course, you can alternatively fill out only one of the three sections, in case you want to have e.g. only the
filename displayed on the left.
¡ Using fields for page numbers, file name, etc.
To insert fields into headers/footers, click the Fields button in the dialog.
Fields are placeholders for information such as current date, document name, page number, etc. PlanMaker
will automatically update them – i.e., when a document is printed, the Print Date field will reflect the current
date.
Fields available:
Field name

Result

Document Name

File name of the document (e.g. "My Table.pmdx")

Document Name and Path

File name of the document (e.g. "C:\Tables\My Table.pmdx")

Worksheet Name

Name of the current worksheet

Page Number

Page number

Number of Pages

Total number of pages

Print Date

Current date (date of printing)
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Print Time

Current time (time of printing)

Date of Last Change

Date the document was last changed (and saved)

Creation Date

Date the document was created

To insert one of these fields, click the Fields button, then click a field.
¡ Changing the character format
To change the character format (typeface, font size, etc.) of text in the header/footer, use the controls located
at the top of the dialog.
Important: Please note that you have to select the text that you want to format beforehand.

Formatting headers and footers
Apart from changing the character format of headers/footers (see above) you can also apply border lines and
shades or change the alignment and margins. For this purpose, click on the Format button in the main dialog of
the Insert > Header and footer menu command.
A dialog window containing the following tabs will appear:
¡ Shading tab
Lets you add a colored shade or a pattern to the headers/footers. The controls in this dialog are identical to
those described in section Shading.
¡ Borders tab
Lets you add a border or single border lines to the headers/footers. The controls in this dialog are identical to
those described in section Borders and lines.
¡ Alignment tab
Lets you modify the inner margins and the vertical alignment of the headers/footers.
Hint: To change the distance between headers/footers and the top/bottom edge of the page, invoke the File >
Page setup menu command and switch to the Page format tab.

Disabling headers/footers temporarily
If you want to print a document without its headers or footers, invoke the Insert > Header and footer menu
command and deactivate the Print option in the dialog. The headers or footers will then no longer appear in
printouts.
If you want the headers/footers to be printed again, simply reactivate the Print option.
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Page breaks
Based on the selected paper size and margins, PlanMaker automatically inserts page breaks in a document.
When printing, a new page will be started at each page break. If you take a closer look at a worksheet, you will
notice that some of the gridlines between cells are darker. These lines indicate where PlanMaker has inserted
automatic page breaks.
To manually control where PlanMaker starts a new page, insert "hard" page breaks. Hard page breaks override
PlanMaker's automatic page breaks.
To insert a hard page break, choose the Insert > Page break menu command. A sub-menu with the following
commands will open:
¡ Insert before row inserts a horizontal page break above the current row.
¡ Delete before row deletes such a page break. Navigate to a cell located directly below the page break before
selecting this command.
¡ Insert before column inserts a vertical page break left of the current column.
¡ Delete before column deletes such a page break. Navigate to a cell located directly to the right of the page
break before selecting this command.
¡ Delete all page breaks removes all manually inserted page breaks again.
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Search & replace
This chapter covers information on searching (and replacing) in tables:
¡ Search and Replace
Use PlanMaker's search commands to search for a specific term – and, as needed, replace it with another
value.
¡ Jumping to specific cell addresses
Use the Go to … command to jump to a specific cell, cell range, or named cell range.
¡ Jumping to specific contents of a table
Use the three buttons in the lower right corner of the document window to jump to a specific content of a
table (for example, to the next cell with an error value or a comment)
See the following pages for detailed information.

Search
Use the Edit > Search menu command to search for a specific term in a document.
Proceed as follows:
1.

If you want to limit the search to a specific cell range, select the cell range first. If nothing is selected, the
entire worksheet will be searched.

2.

Invoke the Edit > Search menu command.

3.

Under Search for, enter the search term.

4.

As necessary, check the options for the search (see section Search and replace options).

5.

Click on the Search button to begin the search.

PlanMaker scans the document for the search term and highlights the first cell that contains it.
To continue, choose one of the following options:
A)Click the Search again button to find the next occurrence.
B)Click the Close button to end the search.
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Replace
Use the Edit > Replace menu command to find and replace values in a document.
Proceed as follows:
1.

If you want to limit the search to a specific cell range, select the cell range first. If nothing is selected, the
entire worksheet will be searched.

2.

Invoke the Edit > Replace menu command.

3.

Under Search for, enter the search term.

4.

Under Replace with, enter the term that is to replace the search term.

5.

As necessary, check the options for the search (see section Search and replace options).

6.

Click on the Search button to start the search.

PlanMaker scans the document for the search term and highlights the first cell that contains it.
To continue, choose one of the following options:
A)Click the Replace button to replace the selected occurrence of the search term and continue the search.
B)Click the Search again button to jump to the next occurrence of the search term – without replacing the
selected occurrence.
C)Click the Replace All button to replace all occurrences of the search term.
D)Click the Close button to end the search.

Search again & replace again
Choose the menu command Edit > Search again or Edit > Replace again or press the F3 key to repeat the last
Search or Replace command.
PlanMaker searches for the next occurrence of the last search request.

Search and replace options
When you click on the Enlarge button in the dialog of the menu command Edit > Search or Edit > Replace,
the dialog expands to offer additional options.
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When you click on Reduce the dialog contracts and the additional options are hidden. Thus you can specify the
appearance of the dialog according to your preference for having the most options at your disposal or for having
as much of the text as possible visible while you are searching.
The expanded search/replace dialog offers the following additional options:

"Search in" group box
Here, you can specify how to scan the document:
¡ Search in
Use this dropdown list to choose which parts of the table to scan: cells, comments, or object frames (text
frames and drawings containing text).
¡ Formulas
Scan formulas as if they were just text strings.
For example, when you search for "sum", all cells using the SUM function will be found.
¡ Results
Scan the results of formulas.
For example, when you search for "4", cells containing the calculation =2+2 will also be found.
(Only available for the search command, not for the replace command.)
¡ Values
Scan all fixed values (e.g., numbers and text strings typed in manually).
¡ Whole document
If this option is checked, all worksheets in the document will be scanned.
If it is not checked, only the current worksheet will be scanned (or, respectively, all worksheets that are
currently selected in the worksheet register.)
¡ Search by column
If this option is checked, the table will be scanned column by column.
If it is not checked, the table is scanned row by row.

"Options" group box
Here, you can specify the following options:
¡ Case-sensitive
By default, the search command is not case-sensitive. If you enter "Miller" in the Search for box, it will
locate "MILLER", "miller", or any other upper/lower case combination of the term.
If you check the Case sensitive option, only "Miller" will be found.
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¡ Whole cell match
By default, the search command finds all cells that contain the search text at any position. If you enter "win"
in the Search for box, PlanMaker will also find cells containing "windows" or "sales, winter 2018".
If you check the Whole cell match option, only cells that contain the term "win" – and nothing else – will
be found.

"Special" button
The Special button allows you to use the following wildcard characters in your search terms:
¡ Single arbitrary character (^?) – represents a single arbitrary character. For example, when you search for
"fo^?d", PlanMaker finds occurrences of "fold", "fond", "food", etc.
¡ Multiple arbitrary characters (^*) – represents any number of arbitrary characters. For example, when
you search for "f*r", PlanMaker finds occurrences of "fair", "flyer", "freighter", etc.
¡ Caret (^^) – searches for the character "^" (caret).
¡ Line break (^a) – searches for manual line breaks (inserted with Ctrl+¿).
To insert a wildcard character into the search term, click on the Special button and select the desired entry with
a mouse click.
You can repeat and combine wildcards at will within the same search term. Of course, you can also use them
together with normal text.

"Search all" button
You can click the Search all button to receive a list of all occurrences of the search term. When you click one
of its entries, PlanMaker jumps to the corresponding occurrence in the document.
Note: This button is only available when the Search in option is set to Cells.

Jumping to specific cell addresses
Use the Edit > Go to menu command to jump to a specific cell, cell range, or named cell range.
To do this, invoke the Edit > Go to menu command and type in the desired cell address. You can enter the
address of a single cell (like D5), a cell range (like D2:D4), or the name of a named cell range (see Worksheet
> Names menu command).
Click OK to jump to the specified cell(s).

Hint:
The control displaying the current cell address at the very left of the Edit toolbar works exactly like the edit box
in the dialog of the Edit > Go to menu command.
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To use this control to jump to a specific cell address, click inside this control, enter the cell address, and press
the Enter ¿ key. You can enter a single cell address, a cell range, or the name of a named range.
Hint: Clicking on the small arrow right of the control opens a dropdown list of all named ranges.

Jumping to specific contents of a table
The three buttons in the lower right corner of the document window enable you to jump to specific contents of
a table (for example, to the next cell containing an error value or a comment).

You use these buttons as follows:
¡ Click on the button with the red dot to bring up a small menu. Then select the type of target you want to
jump to from the menu (see below).
¡ Click on the button with the up arrow to jump to the target prior to the current position. For example, if
"Error Value" was selected as the target type, clicking on this button will result in a jump to the previous
cell with an error value.
¡ Click on the button with the down arrow to jump to the target following the current position – to the next
cell with an error value, for example.
Target types available:
Target Type

Explanation

Formula

Jump to cells that contain a formula

Array Formula

Jump to cells that contain an array formula

Constant

Jump to cells that contain a fixed value

Error Value

Jump to cells that contain an error value (see section Error values)

Faulty Cell

Jump to cells that have been imported incorrectly – for example, cells using an Excel
arithmetic function that PlanMaker doesn't support.

Comment

Jump to cells that contain a comment

Conditional Format

Jump to cells that use conditional formatting
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Input Validation

Jump to cells that use input validation

Search all worksheets

If this option is checked, PlanMaker searches all worksheets instead of just the current
one.

Objects (pictures, drawings, etc.)

Objects (pictures, drawings, etc.)
The Object menu contains commands for inserting and manipulating objects such as charts, pictures, text
frames, and drawings.
This chapter covers information on working with objects in PlanMaker:
¡ Objects – basic procedures
Discusses basic procedures for working with objects (e.g., inserting, selecting, and modifying objects).
¡ Objects – advanced procedures
Discusses advanced procedures (e.g., hiding and grouping objects).
Following these sections, the different object types are introduced in detail:
¡ Charts
¡ Text frames
¡ Pictures
¡ OLE objects
¡ Drawings

Objects – basic procedures
This section discusses basic procedures for working with objects:
¡ Inserting objects
¡ Selecting objects
¡ Object mode
¡ Changing position and size of objects
¡ Rotating and flipping objects
¡ Aligning and distributing objects
¡ Duplicating objects
¡ Changing the properties of objects
More advanced procedures will follow later on, in section Objects – advanced procedures.
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Inserting objects
For example, to insert a picture into the current worksheet:
1.

Choose the menu command Object > New picture frame.

2.

A dialog box appears, allowing you to select the picture to be inserted. Choose a picture file and confirm
with OK.

3.

The picture is inserted.
In case you want to modify its position or size, do the following:
To change the position, click on the picture frame and (while still holding the mouse button down) drag it to
the desired position.
To adjust its size, drag on one of the round handles surrounding the frame.

The process for inserting other types of objects is similar. For more information on the different types of
objects, see sections Charts, Text frames, etc.

Selecting objects
If you want to modify an object, you must select it first. For most types of objects this can be achieved by
clicking the object with the mouse. A selection frame will be displayed around the object, once it is selected.
Hint: Text frames can not be selected by clicking them. To select a text frame, click the surrounding border.
Alternatively, switch to Object mode (see next section). In Object mode, text frames can be selected by
clicking them.
Note: When an object is selected, table cells cannot be edited. To edit cells, click on any cell.

Object mode
Working with objects is a lot easier when you enable Object mode.
By default, PlanMaker runs in Edit mode. In this mode, table cells can be edited, formatted, etc.
When you switch to Object mode, table cells are no longer editable. Rather, various useful functions for object
editing become available. For instance, in Object mode, you can select all types of objects with a simple mouse
click.
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Important: While in Object mode, only commands related to inserting and modifying objects are available.
Cells can no longer be modified, and menu commands not related to objects are grayed out.

Toggling between Edit mode and Object mode
To toggle between Edit mode and Object mode, use one of the following procedures:
¡ Choose the View > Object mode menu command to switch to Object mode. Choose again to return to Edit
mode.
¡ Click the

icon in the Formatting toolbar to switch to Object mode. Click again to return to Edit mode.

¡ Right-click on any cell to open the context menu. Choose the Object mode command to switch to Object
mode. Choose the Exit Object mode command to return to Edit mode.
¡ For the fastest method: Point to any cell and double-click using the right mouse button to switch between
Object and Edit mode.
¡ Also, when in Object mode, you can return to Edit mode quickly by double-clicking on any position in your
document where no object is located.

The Object toolbar
When in Object mode, the Formatting toolbar is automatically replaced by the Object toolbar.

The Object toolbar

This toolbar provides icons for working with objects. From left to right:
¡ Toggle between Object and Edit mode
¡
¡
¡
¡
¡
¡
¡

Insert text frame
Insert picture frame
Insert chart frame
Insert OLE object frame (available under Windows only)
Insert OLE object frame with an SoftMaker Equation Editor* object
Insert OLE object frame with a TextMaker object
Insert OLE object frame with a Presentations object

¡
¡
¡
¡
¡
¡

Insert line or curve
Insert rectangle
Insert rounded rectangle
Insert ellipse
Insert AutoShape
Insert TextArt object

¡ Group selected objects
¡ Modify object properties
¡ Object list (a dropdown list of all objects in the slide, see below)
* Not all versions of PlanMaker have this feature.

Hint: Move the mouse pointer over any of these icons, and a short explanation of its function is displayed.
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Object list: At the right of the Object toolbar, a dropdown list containing all objects existing in the current
document is displayed. Open this list and click on the name of an object; the corresponding object will be
selected.

Selecting objects in object mode
In Object mode, all types of objects can be selected with a single mouse click.
Note: This is especially useful for objects with a transparent filling (e.g. text frames). In Edit mode, such
objects can only be selected by clicking on their borders. In Object mode, they can be selected by simply
clicking anywhere inside the object.
To select multiple objects, draw a frame around these objects with the mouse – or press and hold the Shiftñ key
and click each object you want to select.

Jumping from object to object
In Object mode, you can jump from object to object by using the following keys:
Key

Result

Tab

Select next object

Shift+Tab

Select previous object

For example, use of the Tab key will select the next object.

Changing position and size of objects
To change the position or size of an object, proceed as follows:

Changing the position of objects
To change the position of an object, select it and either move it using the arrow keys on the keyboard or drag it
to another position using the mouse.
Note: By default, objects are anchored to the cell beneath their upper left corner. You can move objects at
will, but when an object is dropped at its new position, it will again automatically be anchored to the cell
beneath its upper left corner.
As a result, an object will move down if additional rows are inserted above it, and move up, if rows above are
deleted.
If you do not want the object to behave like this, choose the menu command Object > Properties, switch to the
Format tab and change the Position option. For example, if you choose Independent of cell position and size,
the object will no longer move down when you insert new rows above. For more information on this option, see
section Object properties, Format tab.
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Changing the size of objects
To change the size of an object, select it and drag on one of the round handles appearing around the object.

Rotating and flipping objects
Note: Rotation and flipping can be performed only on drawings and pictures.
When you select an object that can be rotated, an additional green handle will appear on the selection frame
surrounding it. To rotate the object, drag this handle with the mouse.

Alternatively, you can set the angle of rotation manually. For this purpose, select the object, invoke the Object
> Properties menu command, switch to the Format tab and enter the desired angle under the Rotation option.
You can also rotate and flip (mirror) objects by invoking the Object > Rotate or flip menu command and
choosing one of the commands offered in its submenu.

Aligning and distributing objects
To align or distribute objects, select them and invoke the menu command Object > Align or distribute.
A sub-menu appears, from which you can select the desired alignment or distribution:
¡
¡
¡
¡
¡
¡

Align left
Align center
Align right
Align top
Align middle
Align bottom
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¡ Distribute horizontally
¡ Distribute vertically
The last two commands work only when at least three objects are selected. These commands are used to
distribute the selected objects evenly within the area they occupy, so that the spacings between them are equal.

Duplicating objects
To obtain a copy of an object, you would normally copy it to the clipboard and paste it from there.
Alternatively, use the Edit > Duplicate menu command to create a copy of an object.
Hint: You can also duplicate objects with your mouse: Press and hold the Ctrl key, and drag a new object
out of the object that you want to duplicate.

Changing the properties of objects
An object's properties include its size, fill style, line style, etc. The Object > Properties menu command
provides one place to access all properties for editing or viewing.
To modify the properties of an object, first select the object with a mouse click (text frames can be selected by
clicking on the object's border only). Then invoke the Object > Properties menu command to bring up the
associated dialog.
Tip: For most types of objects, double-clicking on the object (or its border) provides a quick alternative way
to invoke this command.
The dialog contains several tabs. On the next pages, you will find detailed information on each tab and the
options it contains.

Object properties, Format tab
Use the Format tab to modify the size/positioning of objects, rotate objects, or flip objects.
Options available:
¡ Size and Scaling group boxes
Used to alter the size of the object. Either enter the Width and Height of the object, or use the Horz.
scaling and Vert. scaling boxes to enter the scaling factor as percentages.
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If the Keep aspect ratio option is checked, modifying the object's height adjusts its width automatically,
keeping the object proportional (and vice versa when modifying the object's width).
For OLE objects, an additional option named Keep scaling is available. When enabled, any changes made
to the object's size inside its source application are automatically adopted by the object in your PlanMaker
document. When it is disabled, the object in PlanMaker won't change its size. (Note: Not all OLE servers
support this feature.)
¡ Position group box
Here you can choose to what extent the object's position and size is dependent on the cells it covers. Options
available:
Depends on cell position and size: The object behaves like its upper left corner was anchored to the cell
beneath. For example, when you insert additional rows above this cell, the object moves down accordingly.
Furthermore, the object's size depends on the height and width of the cells it covers. For example, if you
increase the width of some of these cells, the object grows accordingly.
Depends only on cell position: The object behaves like its upper left corner was anchored to the cell
beneath as well, but it does not change its size, when you modify the size of the cells it covers.
Independent of cell position and size: The object always keeps its original position and size, independent
of the cells it covers.
¡ Rotation group box
Available only for drawings and pictures.
Here you can rotate the object. To do this, enter the angle about which the object is to be rotated (positive
values correspond to clockwise rotation).
¡ Flip group box
Available only for drawings and pictures.
Here you can flip the object vertically or horizontally.

Object properties, Filling tab
Note: This tab is available only for certain types of objects. When applied to pictures, the filling will be visible
only in pictures that contain transparent areas.
Use the Filling tab to modify the filling of objects as follows:
First, select the desired type of filling in the Fill type list. Based on the fill type selected, a series of options
will be displayed. You can then change those settings for the chosen fill type, as desired.
The following fill types and settings are available:
¡ No Filling
If you select the first fill type in the list, the object is not filled and thus remains transparent.
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¡ Color
Fills the object using a uniform color shade. To change the color, select it in the Colors list.
If none of the existing colors suits you, you can always compose your own colors. To do this, click on the
More colors button and proceed as described in the section Document properties, Colors tab.
If desired, you can also change the Transparency of the fill. You can enter any value between 0% (no
transparency) and 100% (full transparency). For example, if you set the Transparency value to 25, the
filling will have 25% transparency.
¡ Pattern
Fills the object using a pattern. To specify the pattern, select the type of pattern from the Patterns list. Then,
select the desired colors for foreground and background.
If desired, you can also change the Transparency of the fill. Values between 0% (no transparency) and
100% (full transparency) are permitted.
¡ Picture
Fills the object using a picture file. To select the picture file to be used, click the Open button to bring up a
file selection dialog. Tip: The most recently used picture files are presented in the Images list and can be
selected with a single mouse click.
Additional options:
Rotate with object: If you activate this option, the image will be rotated as well whenever you rotate the
object to be filled.
Mirror: Allows you to mirror the picture horizontally or vertically.
Transparency: If desired, you can also change the transparency of the fill. Values between 0% (no
transparency) and 100% (full transparency) are permitted.
Tile as texture: If this option is enabled, multiple copies of the picture are arranged like tiles to fill the
object.
The options in the Tile options section then allow you to change the size and position of the tiles: X scale
and Y scale change the size (in percent), while X offset and Y offset change the position. The Alignment
option can be used to determine to which edge of the object the tiles should be aligned.
If the Tile as texture option is not enabled, only Offsets (relative to the edges of the object) can be set for
the image.
Save: You can use this button to export the currently selected picture, that is, to save a copy of it on your
hard disk.
¡ Linear Gradient, Rectangular Gradient etc.
The lowermost five fill types in the list allow you to fill the object using a gradient. First, open the Fill type
list and select the desired type of gradient. Then, select one of the subtypes in the Variants list.
In the Options section, the following additional settings can be made:
X offset and Y offset can be used to move the center of the gradient. Angle rotates the gradient.
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Hint: You can also modify these settings by moving or rotating the cross-hair displayed in the Sample
field using the mouse.
If you check the Double gradient option, for example, a black-white gradient will become a black-whiteblack gradient.
In the Colors section, the colors can be adjusted as follows:
If you want to change the gradient colors, click one of the triangles below the bar representing the gradient.
Then, select a color from the Color list.

Use the triangle on the left to change the start color and the triangle on the right to change the end color.
If desired, you can also change the Transparency of the selected color. Values between 0% (no
transparency) and 100% (full transparency) are permitted.
Additional colors can be added to the gradient by double-clicking on the desired position in the bar and
selecting a color. To remove a color, double-click the triangle representing that color.

Object properties, Lines tab
Note: This tab is available only for certain types of objects.
Use the Lines tab to modify the lines that encompass the object or its border lines.
When applied to drawings, these settings affect the lines used to paint the object itself. When applied to other
types of objects, the border lines surrounding the object are affected.
Options available:
¡ Line variants
Offers some predefined line styles to choose from.
The entries in the list are merely samples. If required, you can specify the appearance of the lines more
precisely with the options listed below.
¡ Color
Lets you change the color of the lines.
¡ Dashed
Lets you determine if solid or dashed lines will be used.
¡ Thickness
Lets you change the width of the lines (in points).

Objects (pictures, drawings, etc.)

230

¡ Transparency
If desired, you can also change the Transparency of the lines. You can enter any value between 0% (no
transparency) and 100% (full transparency). For example, if you set the Transparency value to 25, the lines
will have 25% transparency.
¡ Begin and End
Available only for lines, curves and connectors.
If you select one of the symbols displayed here, it will be painted at the starting point or end point of the
line. For example, if you select an arrow symbol for the end point, the line will look like an arrow. Width
and Height settings are used for changing the width and/or height of the symbol.

Object properties, Shadow tab
Note: This tab is available only for certain types of objects.
Use the Shadow tab to add a shadow to the object.
Options available:
¡ Shadow variants
Offers a variety of predefined shadow styles to choose from.
The entries in the list are merely samples. If required, you can specify the way the shadow will appear more
precisely with the options listed below.
¡ Scaling
Lets you change the size of the shadow (relative to the size of the object).
¡ Offset
Lets you change the position of the shadow (relative to the object).
¡ Perspective
Lets you change the Skew angle of the shadow.
For certain types of perspective shadows, you can also change the distance of the Horizon. Note: If Horizon
is a positive value, the shadow will be painted in front of the object, and if it is negative, the shadow will be
painted behind the object.
¡ Color
Lets you change the color of the shadow.
¡ Blur
If you enter a value greater than zero here, a blur effect is added to the shadow. The larger the value, the
softer the edges of the shadow are painted.
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¡ Transparency
Allows you to change the Transparency of the shadow. You can enter any value between 0% (no
transparency) and 100% (full transparency). For example, if you set the Transparency value to 25, the
shadow will have 25% transparency.

Object properties, 3D tab
Note: This tab is available only for text frames and drawings.
Use the 3D tab to add a three dimensional effect to the object.
Options available:
¡ 3D effect variants
Offers a variety of predefined 3D effect settings to choose from.
The entries in the list are merely samples. If required, you can specify the way the effect appears more
precisely with the options listed below.
¡ Options group box
Lets you modify the depth of the 3D object and the angles about which it is rotated on the horizontal and
vertical axes.
¡ 3D surface group box
Side faces: By default, the color used for the side faces of the object is determined automatically. To use a
different color, activate the Side faces option and select the desired color from the list.
Affect front side: If this option is checked, the front side of the object will also be lightened or darkened
according to the lighting of the 3D effect. To change the lighting, click the More button.
Wire frame: If you check this option, the object is rendered as a wire frame model.
¡ More button
Click the More button to change the lighting of the 3D effect. An additional dialog box will appear. To
change the position of the light source, click the corresponding position in the Lighting field. The other two
options let you change the Intensity of the light source and the type of Surface to be simulated.

Object properties, Effects tab
Note: This tab is available only for certain types of objects.
On the Effects tab, you can add various effects to the object.
The following effects and settings are available:
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¡ Reflection
When you check the Use reflection effect option, the object is rendered as if it was standing on a reflecting
surface.
Options:
Visible part of object: Specifies how many percent of the object will be visible in the reflection.
Starting transparency: The reflection is smoothly faded out towards its bottom. This value specifies how
transparent the reflection will be at its top (in percent).
Y offset: Moves the reflection upwards or downwards.
¡ Soft edges
When you check the Use soft edges effect option, the borders of the object will be rendered with a blur
effect.
Options:
Width: Specifies the width of the blur effect.
¡ Glow
When you check the Use glow effect option, the borders of the object will be surrounded by a glow effect.
Options:
Width: Specifies the width of the glow effect.
Color: Specifies the color of the glow effect.

Object properties, Properties tab
The Properties tab can be used to modify common object settings.
Options available:
¡ Name
PlanMaker automatically assigns a unique name to every object in a document. Rectangles, for example,
might be named Rectangle1, Rectangle2, Rectangle3, etc.
If you wish, you can give the object a different name by entering it here.
¡ Visible
This option is checked by default. If you deactivate it, the object will no longer be visible on the screen. See
also section Hiding objects.
¡ Printable
This option is checked by default. If you deactivate it, the object will no longer print. See also section
Hiding objects.
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¡ Locked
This option is checked by default. If enabled, users will not be able to change the object's position, size, or
any other object property when worksheet protection is activated. See also section Sheet protection.
¡ Text locked
Available only for objects that contain text (e.g. text frames).
This option is checked by default. If enabled, users will not be able to change the text inside the object when
worksheet protection is activated. See also section Sheet protection.
¡ Link
Lets you apply a link to the object (e.g., a link to a website). For this purpose, click the Select button, select
the type of link, and enter the target address. For more information on links, see section Working with links.
Additionally, for pictures, some information on the picture is displayed in the right half of the dialog
(resolution, color depth, etc.).

Additional tabs
With some object types, the dialog of the Object > Properties menu command displays additional tabs
containing more options. To learn more about these tabs, see the sections referring to each particular object
type.

Changing the default settings for objects
You can change the default settings for objects (drawings, images, etc.) anytime.
For example, if you don't like the default setting for the line width of drawings, simply set it to a different value.
You can also alter other default settings – e.g. the default filling for drawings as well as the settings for
shadows and 3D effects.
Note: Changes to the default settings solely affect objects that you will insert later on. Existing objects
remain untouched.
To modify the default settings for objects, use the Default button in the dialog of the Object > Properties
menu command.
For example, to change the default line width for drawings, proceed as follows:
1.

Insert a new drawing (or click on an existing drawing).

2.

Invoke the Object > Properties menu command.

3.

Adjust the settings to your liking. For example, to change the default setting for the line width, switch to the
Lines tab and simply choose the desired value in the Thickness field.
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4.

Now comes the distinctive step: Instead of clicking on OK, click on the Default button.

5.

Another dialog pops up, allowing you to control exactly which settings to adopt as new default settings.
Normally, there is no need to change anything in this dialog.

6.

When you confirm with OK, the settings you just specified in the properties dialog will from now on be
used as the default settings for new drawings.

7.

To exit the dialog, click on OK once more.

When you insert a new drawing now, it will be painted in the given line width.
Note: The default settings for objects are stored inside the document, allowing you to specify different
settings for each individual document.

Objects – advanced procedures
This section present some less commonly needed functions for working with objects. The following topics are
covered:
¡ Hiding objects
¡ Changing the order of objects
¡ Grouping objects

Hiding objects
PlanMaker provides an option to hide objects. Hidden objects will not appear on screen and/or print.
To hide an object, select it, then choose the menu command Object > Properties, switch to the Properties tab,
and use the following options:
¡ If you deactivate the Visible option, the object will not be displayed on screen.
¡ If you deactivate the Printable option, the object will not print.
Hint: If you have made an object invisible accidentally, choose the menu command File > Properties, switch
to the Options tab, and activate the Show hidden objects option. This will make all invisible objects reappear,
allowing you to select them and reactivate their Visible option (as described above).
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Changing the order of objects
When two or more objects overlap, you can change the display order of these objects (which of the objects to
display in the foreground, which in the background, etc.).
This can be accomplished as follows:
1.

Select the desired object.

2.

Invoke the Object > Order menu command and choose an option from its sub-menu:
Bring to front: Brings the object in front of all other objects.
Send to back: Sends the object behind all other objects.
Bring forward one level: Brings the object forward by one level.
Send backward one level: Sends the object back by one level.

Grouping objects
When you group objects, they will behave like a single object, allowing you to modify them altogether.
For example, when you select an object that is part of a group of objects, the whole group will be selected.
When you move this object, the whole group will move.
To group objects:
1.

Select the objects you want to group.
Hint: To select multiple objects, either click on individual objects while holding down the Shiftñ key, or
switch to Object mode and drag a frame around multiple objects.

2.

Click the

icon in the Object toolbar or choose the menu command Object > Group.

Ungrouping grouped objects
To ungroup objects that have been grouped:
1.

Select the group by clicking on one of the grouped objects.

2.

Choose the menu command Object > Ungroup.

This closes the common section about working with objects. In the next sections, all available types of objects
will be described in detail:
¡ Charts (see chapter Charts)
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¡ Text frames
¡ Pictures
¡ OLE objects
¡ Drawings

Charts
In spreadsheets consisting of nothing but long columns of numbers, it is often hard to interpret their meaning.
PlanMaker provides easy ways to turn raw numbers into charts that get the point across.
Charts are discussed in a separate chapter, so if you want to learn more about charts, see chapter Charts.

Text frames
Use text frames to insert text boxes into a document. Within text frames, you can enter, edit, and format text as
desired.
In this section, you will find detailed information on working with text frames. The following topics are
covered:
¡ Inserting text frames
¡ Changing the properties of text frames
See the next pages for details.

Inserting text frames
To insert a text frame:
1.

Choose the menu command Object > New text frame or click the
only in Object mode).

2.

The text frame is inserted.

icon in the Object toolbar (available

In case you want to modify its position or size, do the following:
Important: To change the position, click on the border of the text frame and then (while still holding the
mouse button down) drag the frame to the desired position.
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To adjust its size, drag on one of the round handles surrounding the frame.
To edit text in a text frame, click inside the text frame. To edit table cells again, click on any cell.
Note: If the text frame is too small to hold the entered text, PlanMaker will display a red bar at its bottom. To
fix this, enlarge the text frame, reduce the amount of text, or choose a smaller font size.

Changing the properties of text frames
To modify the properties of a text frame, first select the frame by clicking on the border that surrounds it. Then
invoke the Object > Properties menu command to bring up the associated dialog.
Hint: This command can also be invoked by double-clicking on the border of the text frame.
The following settings can be made in this dialog:

Format, Filling, Lines, etc. tabs
The tabs listed below are present for almost all object types. They allow you to modify the following settings:
¡ Format: For changing the size and positioning of the object. See section Object properties, Format tab.
¡ Filling: For changing the filling of the object. See section Object properties, Filling tab.
¡ Lines: For adding border lines. See section Object properties, Lines tab.
¡ Shadow: For adding a shadow. See section Object properties, Shadow tab.
¡ 3D: For adding a 3D effect. See section Object properties, 3D tab.
¡ Effects: For adding various types of effects. See section Object properties, Effects tab.
¡ Properties: For modifying common object settings. See section Object properties, Properties tab.
For text frames, there are additional tabs with further options:

Inner text tab
Use this tab to change settings affecting the text in the text frame.
Options available:
¡ Inner margins group box
Lets you modify the margins between text frame and inner text. If you check the Automatic option,
PlanMaker will calculate suitable settings automatically.
¡ Overlapping objects group box
These settings determine what happens when the text frame overlaps another object.
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With the default setting Ignore object, PlanMaker does nothing. Thus, in the region of overlap, the contents
of both frames are rendered on top of one another.
If, on the other hand, you check the Wrap text option, PlanMaker automatically reformats the text in this
frame so that it flows around the area of overlap.
¡ Rotate by... group box
Lets you rotate the inner text in 90 degrees increments.
¡ Vertical alignment group box
Lets you change the vertical alignment of the inner text as follows:
Option

Result

Top

Align inner text at the top of the frame

Centered

Vertically center text between top and bottom of the frame

Bottom

Align inner text at the bottom of the frame

Justified

Vertically justify text (so that it is evenly distributed between top and bottom of the frame)

AutoShapes tab
A text frame is actually an AutoShape that has been filled with text. AutoShapes are drawings with a predefined
shape (for example, rectangles, ellipses, arrows, banners, callouts, etc.).
By default, the AutoShape used for text frames is a simple rectangle. To use a different shape, select it on the
AutoShapes tab.
To learn more about AutoShapes, see section Drawings.

Pictures
In this section, you will find detailed information on working with pictures. The following topics are covered:
¡ Inserting pictures
¡ Scanning pictures
¡ Inserting pictures from the gallery/camera (Android)
¡ Changing the properties of picture frames
See the next pages for details.
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Inserting pictures
To insert a picture into the current worksheet:
1.

Choose the menu command Object > New picture frame or click the
(available only in Object mode).

icon in the Object toolbar

2.

A dialog box appears, allowing you to select the picture that you want to be displayed in the frame. Choose a
picture file and confirm with OK.

3.

The picture is inserted.
In case you want to modify its position or size, do the following:
To change the position, click on the picture frame and (while still holding the mouse button down) drag it to
the desired position.
To adjust its size, drag on one of the round handles surrounding the frame.

Dialog options
Options available in the dialog of the Object > New picture frame menu command:
¡ Save within document
Check this option if you want the picture file to be saved within the document. If you do not check this
option, just a link is preserved to it, and you will need to make sure the picture file is available the next time
you open the document. Note: Saving pictures with the document can significantly increase the size of the
document.
¡ Copy to document's folder
If this option is checked, PlanMaker will create a copy of the picture file (in the folder where the document
is stored) and use this copy instead of the original file.
This option is not available if the document has not yet been saved.

Scanning pictures
Note: Scanning pictures directly into a document is possible only with the Windows version of PlanMaker.
With PlanMaker for Windows, you can scan originals directly into a document. You must have connected a
scanner to your computer and installed the corresponding software.
To scan something into the current document, complete the following steps:
1.

Power up the scanner and insert the original to scan.
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Choose the menu command File > Acquire.

PlanMaker now activates your scanner's software. Make the desired settings and start the scanning process (see
scanner manual). When it is finished, the scanned result will appear as a new picture frame in your PlanMaker
document.

Selecting another source
If multiple scan devices are connected to your computer, the menu command File > Select source lets you
select from which of these you want to acquire documents when using the File > Acquire command.

Inserting pictures from the gallery/camera (Android)
Note: This feature is available only in the Android version.
With the Android version you can also insert pictures using the Gallery or Camera application on your device.
Proceed as follows:

Inserting a picture from the gallery
1.

Invoke the Object > New picture frame from gallery menu command.

2.

Your Android device opens its Gallery app. Choose the image to insert by tapping on it.

The picture is now inserted into the text.

Inserting a picture from the camera
1.

Invoke the Object > New picture frame from camera menu command.

2.

Your Android device opens its Camera app. Take a picture.

The picture is now inserted into the text.

Changing the properties of picture frames
To modify the properties of a picture frame, first select it with a mouse click. Then invoke the Object >
Properties menu command to bring up the associated dialog.
Hint: This command can also be invoked by double-clicking on the picture.
The following settings can be made in this dialog:
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Format, Filling, Lines, etc. tabs
The tabs listed below are present for almost all object types. They allow you to modify the following settings:
¡ Format: For changing the size and positioning of the object. See section Object properties, Format tab.
¡ Filling: For changing the filling of the object. Only visible in pictures that have transparent areas. See section
Object properties, Filling tab.
¡ Lines: For adding border lines. See section Object properties, Lines tab.
¡ Shadow: For adding a shadow. See section Object properties, Shadow tab.
¡ Effects: For adding various types of effects. See section Object properties, Effects tab.
¡ Properties: For modifying common object settings. Also displays some information on the picture. See
section Object properties, Properties tab.
For pictures, there is an additional tab with further options:

Picture tab
On the Picture tab, you can change settings that are specific to pictures.
Tip: Some of these setting can also be modified using the Picture toolbar that appears automatically when
you select a picture. See section Using the Picture toolbar.
Options available on this tab:
¡ Variants
In this list, a number of predefined variations of the picture are presented – for example different color
modes (grayscaled, black & white, etc.) as well as colorized variants of the image.
To choose one of these variants, simply click on it, and the options in the dialog will be adjusted
accordingly.
¡ Settings group box
Here you can change brightness, contrast, saturation and gamma (color balance, with an effect on
brightness).
¡ More button
This button opens a dialog with the following additional options:
When you activate the Mix with color option and choose a color below, the picture will be colorized
accordingly.
The options in the Cropping group box can be used to crop the picture. This is useful when you need only a
segment of the picture. For example, if you want to cut off the upper forth of the picture, first select Use
relative values and enter "25" (percent) at Top.
If you select Use absolute values, the entries are cut off in absolute length units and not as a percentage. If
you enter negative values, the areas of your picture are not cut off, but it is extended with a frame.
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¡ Transparency group box
Lets you modify the transparency settings of the image. Options available:
Detect automatically: Reads the transparency settings stored in the picture file and displays the image
accordingly. Note: Only files in GIF or PNG format can contain transparency settings.
No transparency: Ignores the transparency settings stored in the picture file. Even pictures containing
transparent areas will not be displayed transparently.
Color: Lets you choose the color to be displayed transparently. For example, if you select white, all white
areas of the picture will become transparent.
¡ File button
To use a different picture file, click this button and choose a new file.
¡ Export button
Available only for pictures that are saved in the document.
You can use this button to export the picture, that is, to save a copy of it on your hard disk.
If you check the Create link to file option in the Export dialog, PlanMaker first copies the picture from the
document to a file and then removes the picture from the document, replacing it with a reference to the new
file. Thus, the picture is no longer saved in the document.

Using the Picture toolbar
Some of the properties of pictures can also be changed using the Picture toolbar.

The Picture toolbar

This toolbar appears automatically when you select a picture in the document. From left to right, its icons
represent the following functions:
¡ Invoke the Object > Properties menu command for this image
¡ Add a photo frame effect to the image
¡ Use the original colors of the image
¡ Reduce the colors to shades of gray
¡ Reduce the colors to black and white
¡ Increase brightness
¡ Decrease brightness
¡ Increase contrast
¡ Decrease contrast
¡ Increase gamma
¡ Decrease gamma
¡ Rotate 90 degrees clockwise
¡ Rotate 90 degrees counter-clockwise
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¡ Revert all changes made with this toolbar
¡ Enter/exit Crop mode. In this mode, additional handles are displayed on the borders of the picture. Drag these handles around to crop
the picture.

Note: These settings can also be changed using the dialog of the Object > Properties menu command. See
section Changing the properties of picture frames.

OLE objects
Note: The use of OLE objects is possible only with the Windows version of PlanMaker.
With PlanMaker for Windows, you can embed objects created with other applications (drawings, pictures, etc.)
in your document.
An example: From PlanMaker, you can use the menu command Object > New OLE object frame to start
Windows' Paint program and then draw something. When you exit Paint, the drawing appears in the PlanMaker
document. It is now embedded in the document.
Advantage: To edit the drawing in the PlanMaker document all you have to do is double-click on it – Paint is
then restarted automatically. When you have finished editing and closed Paint, your changes are imported by
PlanMaker.
For this to work, the application invoked from PlanMaker must support OLE. OLE stands for "Object Linking
and Embedding". The object that is imported from the other application into PlanMaker is called an OLE
object.
In this section, you will learn everything you need to know about OLE objects. It covers the following topics:
¡ Inserting OLE objects
¡ Editing OLE objects
¡ Editing links to OLE objects
¡ Changing the properties of OLE objects
¡ Using the SoftMaker Equation Editor
See the next pages for details.

Inserting OLE objects
Note: The use of OLE objects is possible only with the Windows version of PlanMaker.
The Object > New OLE object frame menu command allows you to embed an OLE object into the document.
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The command opens a dialog box containing a list of all applications that are able to create OLE objects. The
entries displayed in the list depend on the OLE-capable programs installed on your system.
Selecting "Paintbrush Picture", for example, will open Windows' Paint program (called Paintbrush in older
versions of Windows). There you can create a picture. Simply exit Paint, and the picture will be embedded into
your document. It is displayed in the spreadsheet, and you can edit the picture whenever you wish. To do so,
simply double-click on the picture.
Step by step, the procedure for embedding an OLE object is as follows:
1.

Choose the menu command Object > New OLE object frame.

2.

A dialog box appears. From the Object type list displayed in this window, select the type of OLE object that
PlanMaker should embed.

3.

When you confirm with OK, PlanMaker starts the application that is appropriate to the type of object
selected.

4.

Create the object in the application.

5.

Exit the application.

6.

At this point, it is possible that the application will ask you if you want to insert the object into the
PlanMaker document. Confirm with "Yes".

7.

The OLE object is inserted.
In case you want to modify its position or size, do the following:
To change the position, click on the OLE object and (while still holding the mouse button down) drag it to
the desired position.
To adjust its size, drag on one of the round handles surrounding the object.

The OLE object created in the other application is now embedded in the PlanMaker document.

Acquiring an OLE object from a file
If you don't want to create a new OLE object, but want to embed as an OLE object a document that already
exists in the form of a file created previously in another application, you still invoke the menu command Object
> New OLE object frame command, but in this case, instead of choosing the option Create new in the dialog,
you select the Create from file option.
With this selection, the look of the dialog changes: Instead of the Object type list, a File entry field is
displayed. Here, enter the full file name of the document file, or click on the Browse button to bring up a dialog
box that will enable you to search your hard disk for the file.
When you have specified a file and confirmed with OK, the file is inserted as an OLE object.
When the OLE object is being inserted, Windows checks the file name extension to see if it is associated with a
program that can be started. If the file name extension is not registered, the embedded file is merely represented
by a symbol. On the other hand, if Windows can relate the file name extension to an OLE-capable program, the
content of the embedded file is displayed.
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Creating a link to the original file
The dialog box described above provides an additional option that allows you to specify whether the object to
be inserted from the file should be embedded in or linked to the document. If you leave the Link option
unchecked, PlanMaker inserts a copy of the file into the document as an OLE object and saves this copy in the
document – thus, the object is embedded in the usual way.
On the other hand, if you check the Link option, PlanMaker inserts the OLE object in the form of a link to the
original file. In this case, if you should ever modify the original file with another application and then reopen
the PlanMaker document that contains the link to this file, the OLE object will appear modified accordingly –
thus, the OLE object remains linked to the original file.

Editing OLE objects
OLE objects can be modified as follows:
Tip: To edit an OLE object, simply double-click on it. The object will be opened immediately in its native
application, where it can be edited.
Alternatively, you can use the menu to edit an OLE object. Proceed as follows:
1.

Click on the OLE object to select it.

2.

Open the Edit menu. At the bottom of the menu, you will find an item that refers to the object by name (for
example, Bitmap object). Selecting this menu item opens a sub-menu containing all the OLE commands
that are available for this object. There is an Edit command for editing the object. Invoke this command.

3.

The application associated with the OLE object now starts. Make the desired changes there.

To return to PlanMaker, simply exit the object's source application.
When exiting some applications, you will be asked if you want to update the object in the PlanMaker document.
Answer "Yes" – otherwise your changes will be discarded.

Editing links to OLE objects
If you acquire an OLE object from a file with the Link option checked, you can edit the resulting link to the
source file with the Edit > Link menu command.
When you invoke this command, a dialog box appears and displays a list of all the existing links in the current
document. When you select a link from the list, the name and type of the source file to which the link refers are
displayed in the lower part of the dialog box.
The dialog's buttons allow you to perform the following functions:
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Button

Function

Update now

Updates the OLE object. Use this button if the source file has been modified by another program
and the changes are not visible in the PlanMaker document.

Open source

Starts the application associated with the OLE object, allowing you to edit the object in the
application. Tip: Double-clicking on the object has the same effect.

Change source

Lets you select a different file as the source of the OLE object.

Cancel link

Cuts the link to the source file. As a result, the object is embedded permanently in the PlanMaker
document. Changes to the source file no longer have any effect on the document. However, the
object can still be edited by double-clicking on it.

Changing the properties of OLE objects
To modify the properties of an OLE object frame, first select it with a mouse click. Then invoke the Object >
Properties menu command to bring up the associated dialog.
The following settings can be made in this dialog:

Format, Filling, Lines, etc. tabs
The tabs listed below are present for almost all object types. They allow you to modify the following settings:
¡ Format: For changing the size and positioning of the object. See section Object properties, Format tab.
¡ Filling: For changing the filling of the object. Not supported by all OLE applications. See section Object
properties, Filling tab.
¡ Lines: For adding border lines. See section Object properties, Lines tab.
¡ Shadow: For adding a shadow. See section Object properties, Shadow tab.
¡ Effects: For adding various types of effects. See section Object properties, Effects tab.
¡ Properties: For modifying common object settings. See section Object properties, Properties tab.
For OLE objects, there is an additional tab with further options:

Picture tab
On the Picture tab, you can change settings that affect the graphical representation of the OLE object.
Note: Depending on the application associated with the OLE object, some of the options may be not
supported.
Options available:
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¡ Variants
In this list, a number of predefined variations of the object are presented – for example different color modes
(grayscaled, black & white, etc.) as well as colorized variants of the object.
To choose one of these variants, simply click on it, and the options in the dialog will be adjusted
accordingly.
¡ Settings group box
Here you can change brightness, contrast, saturation and gamma (color balance, with an effect on
brightness).
¡ More button
This button opens a dialog with the following additional options:
When you activate the Mix with color option and choose a color below, the object will be colorized
accordingly.
The options in the Cropping group box can be used to crop the object. This is useful when you need only a
segment of the object. For example, if you want to cut off the upper forth of the object, first select Use
relative values and enter "25" (percent) at Top.
If you select Use absolute values, the entries are cut off in absolute length units and not as a percentage. If
you enter negative values, the areas of your object are not cut off, but it is extended with a frame.
¡ Export button
You can use this button to export a copy of the graphical representation of the object, that is, to save an
image of the object on your hard disk.

Using the SoftMaker Equation Editor
Note: The SoftMaker Equation Editor is available only for Windows and is not included in all versions of
PlanMaker.
The SoftMaker Equation Editor allows you to display mathematical formulas in graphical form.
PlanMaker communicates with the Equation Editor via OLE, as described in the previous sections. Thus, to add
a graphical representation of a formula to your document, you insert an OLE object, and choose the Equation
Editor as the source application.
To do this, proceed as follows:
1.

Invoke the Object > New OLE object frame menu command.

2.

Select the SoftMaker Equation Editor entry from the Object type list.

3.

Confirm with OK to start the Equation Editor.

4.

Create the desired formula.

Objects (pictures, drawings, etc.)

5.

248

When you have finished building the formula, simply exit the Equation Editor.

The formula is immediately embedded in the PlanMaker document as an OLE object.
You can edit objects created with the Equation Editor by double-clicking on them. Following a double-click,
the Equation Editor is restarted and the formula object is opened in it. After you make the desired changes,
simply close the Equation Editor again.
Moreover, you can change the properties of an Equation Editor object by selecting the object with a (single!)
mouse click and then invoking the Object > Properties menu command.

Information from the creators of the Equation Editor
The SoftMaker Equation Editor is a special version of the MathType program from Design Science. If you make frequent use of formulas in your
documents, you might find that MathType itself is even better suited to your needs than the SoftMaker Equation Editor. While just as easy to use as the
Equation Editor, MathType has a number of additional functions that can help you be more productive and create more complex formulas.
MathType is available in English, French, German, and other languages. You can obtain information about the purchase of MathType from your software
distributor or directly from Design Science.
Design Science, Inc.
140 Pine Avenue, 4th Floor
Long Beach, CA 90802
USA
Phone (USA):

+1 (562) 432-2920 (for international customers)
+1 (800) 827-0685 (for customers within the USA and Canada)

Fax (USA):

+1 (562) 432-2857

E-mail (English):
Internet:

sales@dessci.com
www.dessci.com

Drawings
PlanMaker provides tools to create drawings in your documents. The following types of drawings are available:
¡
¡
¡
¡

Lines and curves (lines, arrows, connectors, curves)
Rectangles and ellipses
AutoShapes (predefined shapes)
TextArt objects (text effects)

In this section, you will find detailed information on working with drawings. The following topics are covered:
¡ Inserting drawings
¡ Adding text to AutoShapes
¡ Changing the properties of drawings
See the next pages for details.
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Inserting drawings
To insert a drawing, for example, a rectangle, proceed as follows:
1.

Invoke the Object > New drawing menu command. A sub-menu opens. From the sub-menu, select a
drawing tool – in this case the Rectangle tool.
If you have activated Object mode, you have the alternative of clicking on the corresponding icon in the
Object toolbar.

2.

With some of the drawing tools, additional action is required (see below). However, this is not the case with
rectangles.

3.

The drawing is inserted.
In case you want to modify its position or size, do the following:
To change the position, click on the drawing and (while still holding the mouse button down) drag it to the
desired position.
To adjust its size, drag on one of the round handles surrounding the drawing.

The method of producing a drawing object varies according to the drawing tool used. Accordingly, all the
available types of drawing objects are listed below together with tips for manipulating them:

Lines and curves
Use the Line tool

in the Object toolbar to draw lines and curves.

When you click on this icon, a list of available line and curve tools opens. Select a tool by clicking on it, then
proceed as follows:
¡ Lines
The first category in the list offers tools for drawing straight lines and arrows.
To use one of these tools, select it, then press and hold the left mouse button and simply draw a line in the
document.
Tip: When you hold down the Shiftñ key while drawing, the direction of the line is variable only in
increments of 45 degrees.
Note: Arrows are simply lines with an arrowhead chosen for the Start and/or End option in the object
properties, Lines tab.
¡ Connectors (straight, elbow and curved)
The tools in the next three categories allow you to draw connecting lines between two objects. You can see
the differences among these three kinds of connectors in the following illustration:
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To use one of these tools, select it and then drag the mouse pointer from one object to another, holding down
the mouse button.
Tip: When you move the mouse pointer over an object, small blue boxes appear at various points on the
object. These boxes indicate where the connector line can "dock" to the object.
¡ Curves
Use the tools in this category to draw curves, as follows:
The Curve tool

allows you to draw Bezier curves.

To draw a curve, click on the position where you want to have its starting point; then click on as many
other points as you like. The curve will automatically follow your clicks.
To quit drawing, you can either a) click on the curve's starting point (which will automatically make it a
closed curve) or b) double-click on any other position to set it's end point there (which will make it an
open curve).
The Freehand form tool
pencil.

allows you to draw irregular curves as you would be able to do by hand with a

To draw freehand, move the mouse to the desired starting point, press and hold the left mouse button, and
start drawing as if using a pencil. To draw a straight line, release the mouse button and click on the
desired position.
To quit drawing, you can either a) click on the curve's starting point (which will automatically make it a
closed curve) or b) double-click on any other position to set it's end point there (which will make it an
open curve).

Rectangles, rounded rectangles, and ellipses
Use one of the tools

to insert rectangles, rounded rectangles, or ellipses.

Every time you click on one of these tools, the corresponding drawing object is inserted in a standard size. You
can change its position by dragging it with your mouse. To change its size, drag one of the round handles on its
corners.
In the case of rounded rectangles, you can additionally change the rounding of the corners. To do this, select the
rectangle. A yellow handle will then appear at one of its corners. By dragging this handle you can change the
rounding accordingly.
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AutoShapes
Use the AutoShape tool
to insert AutoShapes. AutoShapes are drawings with a predefined shape (e.g.,
rectangles, ellipses, arrows, banners, callouts, etc.).
As soon as you choose the desired AutoShape, it is inserted in a standard size. If necessary, you can change its
position by dragging it with your mouse. To adjust its size, drag one of the round handles on its corners.
Note: With some types of AutoShapes, yellow handles appear on the object when it is selected. If you drag on
one of these handles, a parameter controlling the shape of the object is changed. For example, stars have
handles that let you change the size of their tines.
Hint: You can even add text to AutoShapes. It will be displayed inside the shape – just like in a text frame. To
learn more about this feature, see section Adding text to AutoShapes.

TextArt objects
Use the TextArt tool

to insert TextArt objects. TextArt objects are used to create text effects.

When you activate this tool a dialog appears. Enter your text in the dialog's Text field and then click on
Variants to choose one of the ready-made effects to be applied to the text. Confirm with OK to leave the
dialog.

Adding text to AutoShapes
You can add text to an AutoShape if you wish. The text is then displayed inside the AutoShape – exactly as it
would be in a text frame.
To add text to an AutoShape, complete the following steps:
1.

Select the desired AutoShape.

2.

Right-click on it to open its context menu.

3.

Choose the Add Text command.

You can now type text inside the AutoShape.
Hint: There's a faster way to add text to an AutoShape: First select the AutoShape with a mouse click, then
simply start typing.
If you want to change the formatting of the text, use the menu commands Format > Character and Format >
Paragraph as usual.
To finish editing the text, click outside the AutoShape. To continue editing the text later, click inside the
AutoShape or choose the Edit Text command from the context menu.
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Note: If the AutoShape object is too small to hold the entered text, PlanMaker will display a red bar at its
bottom. To fix this, enlarge the object, reduce the amount of text, or choose a smaller font size.
Hint: Text frames are basically AutoShapes (rectangles, in this case) with text added. To learn more about text
frames, see chapter Text frames.

Changing the properties of drawings
To modify the properties of a drawing, first select it with a mouse click. Then invoke the Object > Properties
menu command to bring up the associated dialog.
Hint: This command can also be invoked by double-clicking on the drawing.
The following settings can be made in this dialog:

Format, Filling, Lines, etc. tabs
The tabs listed below are present for almost all object types. They allow you to modify the following settings:
¡ Format: For changing the size and positioning of the object. See section Object properties, Format tab.
¡ Filling: For changing the filling of the object. See section Object properties, Filling tab.
¡ Lines: For modifying the lines used to draw the object. See section "Object properties, Lines tab".
¡ Shadow: For adding a shadow. See section Object properties, Shadow tab.
¡ 3D: For adding a 3D effect. See section Object properties, 3D tab.
¡ Effects: For adding various types of effects. See section Object properties, Effects tab.
¡ Properties: For modifying common object settings. See section Object properties, Properties tab.
For certain types of drawings additional tabs will appear on the dialog, giving you access to more options (as
described on the following pages).

AutoShapes tab (available only for AutoShapes)
Note: This tab appears only for AutoShapes.
The AutoShapes tab allows you to change the shape of an AutoShape. For example, you can turn a rectangle
into a speech balloon or any other shape you like.
To change the shape, simply click on the desired AutoShape in the list.
For more information on AutoShapes, see the chapter Inserting drawings.
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Inner text tab (available for AutoShapes with text added)
Note: This tab appears only for AutoShapes containing text (see the section Adding text to AutoShapes) and for
Text frames.
Use the Inner Text tab to change settings affecting the text inside the AutoShape.
Options available:
¡ Inner margins group box
Lets you modify the margins between AutoShape and inner text. If you check the Automatic option,
PlanMaker will calculate suitable settings automatically.
¡ Overlapping objects group box
These settings determine what happens when the object overlaps another object.
With the default setting Ignore object PlanMaker does nothing. Thus, in the region of overlap, the contents
of both objects are rendered on top of one another.
If, on the other hand, you check the Wrap text option, PlanMaker automatically reformats the text in this
object so that it flows around the area of overlap.
¡ Rotate by ... group box
Lets you rotate the inner text in 90 degrees increments.
¡ Vertical alignment group box
Lets you change the vertical alignment of the inner text as follows:
Option

Result

Top

Align inner text at the top of the object

Centered

Vertically center text between top and bottom of the object

Bottom

Align inner text at the bottom of the object

Justified

Vertically justify text (so that it is evenly distributed between top and bottom of the object)

Text tab (available only for TextArt objects)
Note: This tab appears only for TextArt objects.
Use the Text tab to select the desired TextArt effect and to edit or format the text to be displayed.
Options available:
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¡ Text
Here you can edit the text to be displayed.
¡ Variants
Here you can choose which TextArt effect to apply.
¡ Font group box
Here you can change the font and apply the text styles Bold and Italic.
If you check the Same height option, all letters (including lower case letters) will be stretched to a uniform
height.
¡ Spacing group box
The Character option affects the spacing between characters. Values below 100% produce spacings that are
closer together than normal, values above 100% produce spacings that are wider apart.
The Line option affects the spacing between lines. This setting is effective only for text that consists of
multiple lines.
¡ Alignment group box
Here you can change the alignment of the text. This setting is effective only for text that consists of multiple
lines.
¡ Placement group box
If you check the Vertical text option, the letters will be rotated by 90 degrees.

Deformation tab (available only for TextArt objects)
Note: This tab appears only for TextArt objects.
Use the Deformation tab to change the type of shaping effect to be applied to the characters. To do this, click
the desired type of deformation.
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Charts
In spreadsheets containing nothing but long columns of numbers, it is often hard to interpret their meaning.
PlanMaker offers easy ways to turn raw numbers into charts that get the point across.

In this chapter, you will learn everything you need to know about charts. Topics covered:
¡ Inserting charts
The first section describes how to insert a chart: Select the cells containing the data to be displayed, choose
the menu command Object > New chart frame, select a chart type.
¡ Editing charts
This section contains information on editing charts, for example, changing chart type, arrangement of the
data series, working with chart elements (data series, axes, legends, etc.), editing chart properties, and so on.
¡ Updating charts
By default, charts are automatically updated when you change the content of any of the cells they are based
on. If desired, this feature can be turned off, requiring that charts be updated manually.
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¡ Moving charts to another worksheet
The menu command Object > Chart > Change chart location allows you to move a chart to a different
worksheet – or even create a dedicated chart worksheet for it. A chart worksheet contains no table cells but
solely the chart in its full size.
¡ Saving charts as images
The menu command Object > Chart > Save as image allows you to save an image of a chart in a picture
file.

Inserting charts
To insert a chart into the current worksheet:
1.

Select the cells containing the values to be displayed in a chart.
Hint: If the selection contains row and/or column headings, these headings can be used to automatically
label the axes and the legend.

2.

Choose the menu command Object > New chart frame or click the
only in Object mode).

icon in the Object toolbar (available

3.

In the resulting dialog box, click the desired Chart type and Subtype to specify how the chart will look.
(For more information about chart types, see section Changing the chart type.)

4.

Click OK to confirm.

5.

The chart is inserted.
In case you want to modify its position or size, do the following:
To change the position, click on the chart and (while still holding the mouse button down) drag it to the
desired position.
To adjust its size, drag on one of the round handles surrounding the chart.

Editing charts
On the next pages you will learn how to edit charts. The following topics are covered:
¡ Changing the chart type
¡ Changing the arrangement of data series
¡ Working with chart elements
¡ Changing common chart properties
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Note: Basic procedures for editing objects are discussed in the chapter Objects (pictures, drawings, etc.).

Tip: Using the Chart toolbar
When you select a chart, a toolbar named Chart toolbar will automatically appear.

The Chart toolbar

This toolbar provides icons helpful for working with charts. From left to right:
¡
¡
¡
¡
¡
¡
¡
¡
¡
¡
¡

Change chart type
Change chart subtype
Dropdown list of all chart elements (open it and click an element to select it for editing)
Edit properties of the current chart element
Edit common chart properties
Data series are in columns
Data series are in rows
Add trend line
Legend on/off
Vertical gridlines on/off
Horizontal gridlines on/off

Hint: Move the mouse pointer over any of these icons, and a short explanation of its function is displayed.
For detailed information on each icon, read the following pages.

Changing the chart type
The chart type determines how data will be displayed in a chart – for example, as columns, as bars, as lines, etc.
To change the type of a chart:
1.

Select the chart by clicking it.

2.

Choose the menu command Object > Properties.

3.

Switch to the Chart Type tab.

4.

Choose the desired chart type and chart subtype.

Hint: Alternatively, use the first two icons in the Chart toolbar to change the type of a chart: The first icon
represents the chart type; the second icon represents the subtype (if available).
Chart types available:
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Column chart
Column charts display values as columns. The higher the value, the taller the corresponding column. Column
charts are often used to compare values.

Bar chart
Bar charts are horizontally oriented versions of column charts. The data is displayed as horizontal bars instead
of vertical columns.

Line chart
Line charts display values as points and/or connecting lines.

Area chart
Area charts are identical to line charts, except that the area below the lines is filled with color.

XY scatter chart
XY scatter charts display values as points and/or lines. Unlike line charts, the data area must contain both the
x and the y coordinate of the data points.

Bubble chart
Bubble charts display values as filled circles ("bubbles"). Bubble charts are usually based on data series
containing three values: x coordinate, y coordinate, and bubble size.

Radar chart
Radar charts display values along spokes that radiate from the center point.

Surface chart
Surface charts display values as a three-dimensional shape. Areas plotted in the same color indicate similar
values.
The values to be displayed should have the following structure:
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(Z values determine the height.)

Pie chart
Pie charts display values as pie slices. Pie charts are often used to conceptualize how values contribute to a
whole.
Hint: You can highlight values by selecting them with the mouse and dragging them out of the pie.

Doughnut chart
Doughnut charts display values as ring segments. They are similar to pie charts, except that they are able to
display multiple data series (= rings).

Cylinder, Cone, and Pyramid chart
Cylinder, cone, and pyramid charts are identical to column and bar charts, except that they display values as
cylinders, cones, or pyramids.

Stock chart
Stock charts (a.k.a. high-low charts) are often used for illustrating the development of stock prices. They are
able to display e.g. the highest, the lowest, and the closing price at the same time.
The following subtypes are available:
¡ Stock chart (High, Low, Close)
Displays the following values:
Highest price, lowest price, closing price
Requires 3 data series in the quoted order.
An example for the structure of the data (with the date added in column A):
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¡ Stock chart (Open, High, Low, Close)
Displays the following values:
Opening price, highest price, lowest price, closing price
Requires 4 data series in the quoted order.
¡ Stock chart (Volume, High, Low, Close)
Displays the following values:
Volume traded, highest price, lowest price, closing price
Requires 4 data series in the quoted order.
The volume traded is displayed as an additional column (which has its own value axis).
¡ Stock chart (Volume, Open, High, Low, Close)
Displays the following values:
Volume traded, opening price, highest price, lowest price, closing price
Requires 5 data series in the quoted order.
The volume traded is displayed as an additional column (which has its own value axis).

Box plot chart
Box plots (or box and whisker plots) can be used for data analysis in statistics. Detailed explanations on the
application of box plots would go beyond the scope of this manual. You can find elaborate information on this
in the Internet search engine of your choice.
There are two subtypes: Horizontal and Vertical.
Depending on the number of data series passed to the chart, a different type of box plot will be rendered, as
follows:
(Note: The values listed below are just examples; you can display any types of values in a box plot.)
¡ 3 point box plot
Displays, for example, the following values:
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Lower quartile (lower border of the box)
Median (position of the bar inside the box)
Upper quartile (upper border of the box)
Requires exactly 3 data series in the quoted order.
¡ 5 point box plot
Displays, for example, the following values:
Lower whisker (line below the box)
Lower quartile (lower border of the box)
Median (position of the bar inside the box)
Upper quartile (upper border of the box)
Upper whisker (line above the box)
Requires exactly 5 data series in the quoted order.
¡ 7 point box plot
Displays, for example, the following values:
Minimum (as a single marker)
Lower whisker (line below the box)
Lower quartile (lower border of the box)
Median (position of the bar inside the box)
Upper quartile (upper border of the box)
Upper whisker (line above the box)
Maximum (as a single marker)
Requires exactly 7 data series in the quoted order.

Changing the arrangement of data series
The two
icons in the Chart toolbar determine how the selected data will be arranged in the chart: by
columns or by rows.
¡ By columns
By default, the first icon is selected, meaning that the data is evaluated column by column: The values in the
first column will be the first data series, the values in the second column will be the second data series, etc.
¡ By rows
If you click the second icon, the data will be evaluated row by row: The values in the first row will be the
first data series, the values in the second row will be the second data series, etc.
Alternatively, this setting can be switched by choosing the menu command Object > Chart > Data in columns
or Data in rows, respectively.
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Working with chart elements
Charts consist of various components (data series, axes, legends, etc.), referred to as chart elements.
The picture below illustrates all chart elements:

Series 1, Series 2, etc. represent the chart's data series.
Three-dimensional charts types contain some additional chart elements (walls, floor, etc.), which will also be
discussed on the following pages.
Each of these chart elements can be selected and modified.

Selecting chart elements
To select a chart element, first click on the chart itself to select it (if it isn't already selected). Then, click on the
desired chart element.
Note: To select a single value within a data series, first click on the data series to select the entire series, and
then click on the desired value.
Hint: Alternatively, open the chart elements dropdown list in the middle of the Chart toolbar and select the
desired element.
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Changing position and size of chart elements
Some chart elements can be moved or resized – for example, the legend. To move an element, select it and drag
it to the desired position. To change its size, drag one of the round handles appearing around the element (when
it is selected).

Modifying chart elements properties
As described in the section Changing common chart properties later on, charts have common properties that you
can modify whenever needed. Apart from those common properties, you can also change the properties of
single chart elements.
For example, to change the properties of the legend displayed in a chart, proceed as follows:
1.

Select the legend by clicking on it.

2.

Right-click on the legend to open its context menu.
Android: In the Android version, you can also open the context menu with your finger: Just tap on the screen
and hold your finger there for about a second.

3.

In the context menu, choose the Legend: Properties command (not the Chart: Properties command).

This command will open a dialog containing legend-specific properties.
Hint: Clicking the
icon in the Chart toolbar or double-clicking a chart element will also access the
element's properties dialog.
A different dialog appears for each type of chart element. The following sections provide detailed information
on each individual chart element, including their properties, as follows.
¡ Chart area
¡ Plot area
¡ Walls (three-dimensional charts only)
¡ Floor (three-dimensional charts only)
¡ Corners (three-dimensional charts only)
¡ Data series and data points
¡ Trend lines
¡ Category axis (x axis)
¡ Value axis (y axis)
¡ Series axis (z axis)
¡ Gridlines
¡ Legend
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Chart area
The chart area is the complete area covered by the chart frame.
Modifying properties: To change the properties of the chart area, select it, right-click it, and choose the Chart
area: Properties command from the context menu.
Hint: Alternatively, select the chart area and either click the
chart area.

icon in the Chart toolbar, or double-click the

Options available:

Format tab
Use this tab to modify the following settings:
¡ Border group box
Lets you add border lines in the selected line style to the chart.
If the Shadow option is checked, a drop shadow effect will be added to the border. The Adjust button can
be used to customize the appearance of the shadow.
¡ Filling group box
Lets you change the filling of the chart area.
To use complex fill types (gradients, bitmaps, etc.), select the Effects option and click the Customize
button. For more information on fill types, see section Object properties, Filling tab.

Font tab
Use this tab to change the default character format (font, font size, font styles, etc.) of the chart.
Important: Changing the font settings for the chart area will also change the font settings for all other chart
elements.

Plot area
The plot area of a chart is the area where data series, axes, and gridlines are painted.
Modifying properties: To change the properties of the plot area, select it, right-click it, and choose the Plot area:
Properties command from the context menu.
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Hint: Alternatively, select the plot area and either click the
plot area to access its properties dialog.

icon in the Chart toolbar, or double-click the

Options available:

Format tab
Use this tab to modify the following settings:
¡ Border group box
Lets you add border lines in the selected line style to the plot area.
¡ Filling group box
Lets you change the filling of the plot area.
To use complex fill types (gradients, bitmaps, etc.), select the Effects option and click the Customize
button. For more information on fill types, see section Object properties, Filling tab.

Walls (three-dimensional charts only)
Walls exist in three-dimensional charts only.
Modifying properties: To change the properties of the walls, select one of the walls, right-click it, and choose the
Walls: Properties command from the context menu.
Hint: Alternatively, select a wall and either click the
access its properties dialog.

icon in the Chart toolbar, or double-click a wall to

Options available:

Format tab
Use this tab to modify the following settings:
¡ Border group box
Lets you modify the line style used to draw the walls.
¡ Filling group box
Lets you change the filling of the walls.
To use complex fill types (gradients, bitmaps, etc.), select the Effects option and click the Customize
button. For more information on fill types, see section Object properties, Filling tab.
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3D View tab
Use this tab to modify the 3D settings for the entire chart. For more information, see section Chart properties,
3D View tab.

Floor (three-dimensional charts only)
Floors exist in three-dimensional charts only.
Modifying properties: To change the properties of the floor, select it, right-click it, and choose the Floor:
Properties command from the context menu.
Hint: Alternatively, select the floor and either click the
floor to access its properties dialog.

icon in the Chart toolbar, or double-click the

Options available:

Format tab
Use this tab to modify the following settings:
¡ Border group box
Lets you modify the line style used to draw the floor.
¡ Filling group box
Lets you change the filling of the floor.
To use complex fill types (gradients, bitmaps, etc.), select the Effects option and click the Customize
button. For more information on fill types, see section Object properties, Filling tab.

3D View tab
Use this tab to modify the 3D settings for the entire chart. For more information, see section Chart properties,
3D View tab.

Corners (three-dimensional charts only)
Corners exist in three-dimensional charts only.
Modifying properties: To change the properties of the corners, select one of them, right-click it, and choose the
Corners: Properties command from the context menu.
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icon in the Chart toolbar, or double-click a corner

Options available:

3D View tab
Use this tab to modify the 3D settings for the entire chart. For more information, see section Chart properties,
3D View tab.

Data series and data points
Data series are the most important chart elements. They represent the data to be displayed in a chart. For
example, in a column chart, the height of each column stands for the size of the corresponding value.
A data series is the graphical representation of one row (or column) of the cells the chart is based on. Every
data series consists of multiple data points, i.e., the graphical representation of one cell.
Modifying properties: To change the properties of data series or single data points:
¡ When you click on any of the data points of a data series, the entire data series will be selected. To edit its
properties, right-click it to display its context menu and choose the Series: Properties command.
¡ When you click the same data point once again, only this single data point will be selected. To edit its
properties, right-click it and choose the Point: Properties command.
Options available (for both data series and data points):

Format tab
Use this tab to modify the following settings:
¡ Border group box (or Line group box)
Lets you modify the line style used to draw the graph.
¡ Filling group box
Lets you change the filling used to draw the graph.
To use complex fill types (gradients, bitmaps, etc.), select the Effects option and click the Customize
button. For more information on fill types, see section Object properties, Filling tab.
¡ Marker group box (available only for certain chart types)
Some chart types (e.g. certain types of line charts) draw markers for each data point. Here, you can modify
the appearance of such markers. For this purpose, choose the Custom option and select the desired style,
size, color, etc.
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3D Format tab
Note: The options on this tab are available only for certain chart types.
Use this tab to add a light effect or bevels to the data points to be displayed.
¡ Material
Lets you specify what type of material will be simulated to display the data points.
¡ Light
Lets you specify what type of light to simulate.
¡ Angle
Lets you change the angle of the light source.
Hint: The above effects usually look better when you additionally add bevels to the data points (see the
next option).
¡ Bevel group box
Lets you add a bevel effect to graphical representation of the data points. For example, in a bar chart, you
can use these options to round the edges of the bars. The larger the value, the rounder the edges will be
displayed.

Data labels tab
Use this tab to add labels to the selected data points. This is useful, for example, if you want to have the exact
values displayed for each data point.
¡ Display group box
Lets you specify what type of label will be displayed. By default, Don't show is selected (meaning that no
label will be displayed). If, for example, you choose Show value, the value in the cell represented by the
data point will be displayed.
¡ Display legend key in label
If this option is checked, the legend key is displayed in each label. The legend key is a small square shaded
in the color used to paint the data point.
¡ Placement group box
Lets you modify the placement of the labels (relative to the corresponding data points).
Note: Labels can be modified like any other kind of chart element. For example, to change their properties,
select one of them, right-click it, and choose the Data label: Properties command from the context menu.
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Error bar Y tab
Note: This tab is available only for certain chart types (including column, bar, and line charts).
Use this tab to add error bars to the data points of the selected data series. Error bars display the
possible/tolerable error of the values in the form of lines ending with short dashes at their ends.

A chart using both "Plus" and "Minus" error bars

To add error bars, select the desired type of error bar in the Display group box: Plus only displays a positive
error bar, Minus only displays a negative error bar, Plus and minus displays both error bars.
The Show as group box lets you modify the appearance of the error bars: with or without end dashes.
The Value group box lets you determine the length of error bars: If you choose Fixed, the error bars will have a
fixed length; if you choose Percent, the length will be determined by the specified percentage of each value,
and so on.

Error bar X tab
Note: This tab is available only for certain chart types (including column, bar, and line charts).
This tab is identical to the Error bar Y tab (see above), except that it displays error bars for the x values
instead of the y values.

Helper Lines tab
Note: This tab is available only for certain chart types (including two-dimensional column, bar, and line
charts).
Use this tab to add "helper lines" representing statistical information to the selected data series. For example, if
you choose the Average option, a dashed line indicating the average of the selected data series will be
displayed in the chart.
Options available: Average, Minimum/Maximum, Standard deviation, and Linear approximation (displays
a trend line calculated using linear regression).
Hint: Alternatively, you can add a large variety of other types of trend lines using the Object > Chart > Add
trendline menu command. See section Trend lines.
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Options tab
This tab contains several additional options for the selected chart type.

Trend lines
Note: Trend lines are available only for certain chart types (including two-dimensional column, bar, and line
charts).
If desired, you can add trend lines to the data series of a chart.
Trend lines can be used to graphically display the trend of a data series (i.e., to what extent the data series
rises/falls on average). Trend lines can also be extended beyond the given data points, so that they display a
forecast for future values.
A statistical technique called regression analysis is used to calculate trend lines.
Adding trend lines: To add a trend line to a data series, select the data series, right-click it, and choose the Add
trendline command from the context menu.
Hint: Alternatively, select the data series and either click the
Object > Chart > Add trendline menu command.

icon in the Chart toolbar or choose the

Removing trend lines: To remove a trend line, select it and press the Del key.
Modifying properties: To change the properties of a trend line, select it, right-click it, and choose the Trendline:
Properties command from the context menu.
Hint: Alternatively, select the trend line and either click the
trend line to access its properties dialog.

icon in the Chart toolbar, or double-click the

Options available:

Format tab
Use this tab to modify the following settings:
¡ Line group box
Lets you modify the line style used to draw the trend line.

Trendline tab
¡ Type group box
Lets you determine the type of trend line (linear trend, exponential trend, etc.).
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The available types of trend lines are based on the following formulas:
Linear:

y = ax + b

Polynomial:

y = b + c1x + c2x2 + c3x3 + ... + c6x6

Exponential:

y = cebx (e = Euler's number)

Logarithmic:

y = c ln(x) + b

Potential:

y = cxb

Moving average:

f(xi) = (xi + xi-1 + xi-2 + ... + xi-n+1) / n

¡ Based on series
Lets you choose the data series for which the trend line is displayed.
¡ Forecast group box
Lets you extend the trend line beyond the given data points.
Example: If 3 data points are given (e.g., the sales figures of the 1st, 2nd, and 3rd year) and you enter 1 in
the Forward box, the trend line will be extended by one unit (= data point), so that it displays a forecast for
the sales in the 4th year.
¡ Crossing point
To force the trend line to intersect the y axis at a specific y coordinate, check this option and enter the
desired y coordinate. Available for certain types of trend lines only.
¡ Show formula in chart
If this option is checked, the formula used to calculate the trend line will be displayed in the chart.
¡ Show correlation in chart
If this option is checked, the correlation coefficient R2 of the data series will be displayed in the chart.
¡ Name group box
Lets you modify the name of the trend line (displayed in the legend). Select the Custom option and enter the
desired name.

Category axis (x axis)
The x axis of a chart is also called category axis.
Showing/hiding axes: To show/hide axes, select the chart, choose the menu command Object > Properties, and
switch to the Elements tab. Check the axes to be displayed. For example, if you check the X axis option, the x
axis (category axis) will be displayed.
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Modifying properties: To change the properties of the category axis, select it, right-click it, and choose the
Category Axis: Properties command from the context menu.
Hint: Alternatively, select the axis and either click the
to access its properties dialog.

icon in the Chart toolbar, or double-click the axis

Options available:

Format tab
Use this tab to modify the following settings:
¡ Line group box
Lets you modify the line style used to draw the axis.
¡ Major ticks and Minor ticks group boxes
Lets you modify the placement of the tick marks displayed on the axis.
¡ Tick labels group box
Lets you modify the placement of the tick labels displayed at the tick marks.

Scale tab
Use this tab to change the scaling of the axis.
Annotation: The first, second, third, etc., data point of all data series is called a category.
¡ Axis ends group box
Lets you determine where to end the visible part of the axis: In categories or Between categories.
¡ Number of categories between group box
By default, PlanMaker draws a tick mark on the axis at every category and adds a tick label to every tick
mark. To alter these settings:
The Tick marks option determines the frequency tick marks are set. Enter 1, and a tick mark is set for every
category. Enter 2, and a tick mark is set for every second category, etc.
The Tick labels option determines the frequency tick marks are labeled. Enter 1, and every tick mark is
labeled. Enter 2, and every second tick mark is labeled, etc.
¡ Intersection between X and Y axis group box
Use this option to determine where the x axis (category axis) will cross the y axis (value axis): At low end
(where the axis begins), At high end (where the axis ends), or at the specified category number.
¡ Invert axis direction
If this option is checked, the direction of the axis is reversed.
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Font tab
Use this tab to change the character format (font, font size, font styles, etc.) of the axis labels.
Note: If desired, the axis labels can be rotated by choosing the Custom option and selecting the desired angle
under Rotation.

Value axis (y axis)
The y axis of a chart is also called value axis.
Showing/hiding axes: To show/hide axes, select the chart, choose the menu command Object > Properties, and
switch to the Elements tab. Check the axes to be displayed. For example, if you check the Y axis option, the y
axis (value axis) will be displayed.
Modifying properties: To change the properties of the value axis, select it, right-click it, and choose the Value
Axis: Properties command from the context menu.
Hint: Alternatively, select the axis and either click the
to access its properties dialog.

icon in the Chart toolbar, or double-click the axis

Options available:

Format tab
Use this tab to modify the following settings:
¡ Line group box
Lets you modify the line style used to draw the axis.
¡ Major ticks and Minor ticks group boxes
Lets you modify the placement of the tick marks displayed on the axis.
¡ Tick labels group box
Lets you modify the placement of the tick labels displayed at the tick marks.

Scale tab
Use this tab to change the scaling of the axis.
¡ Lowest value and Highest value group boxes
These options determine where the axis will begin and end. Auto chooses a suitable value automatically. To
use a different value, select Custom and enter the desired value.
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¡ Intersection between X and Y axis group box
Use this option to determine where the x axis (category axis) will cross the y axis (value axis): Auto chooses
a suitable value automatically, Maximum value places the x axis at the end of the y axis, and Custom uses
a user-defined value.
¡ Major step value group box
Lets you modify the interval between major tick marks on the axis.
¡ Minor step value group box
Lets you modify the interval between minor tick marks on the axis.
¡ Invert axis direction
If this option is checked, the direction of the axis is reversed.
¡ Logarithmic scale
If this option is checked, the axis will use a logarithmic scale (e.g., 10, 100, 1000, etc.) rather than a linear
scale.

Font tab
Use this tab to change the character format (font, font size, font styles, etc.) of the axis labels.
Note: If desired, the axis labels can be rotated by choosing the Custom option and selecting the desired angle
under Rotation.

Series axis (z axis)
The z axis of a chart is also called series axis. It is only available for certain three-dimensional charts.
Showing/hiding axes: To show/hide axes, select the chart, choose the menu command Object > Properties, and
switch to the Elements tab. Check the axes to be displayed. For example, if you check the Z axis option, the z
axis (series axis) will be displayed.
Modifying properties: To change the properties of the series axis, select it, right-click it, and choose the Series
Axis: Properties command from the context menu.
Hint: Alternatively, select the axis and either click the
to access its properties dialog.
Options available:

Format tab
Use this tab to modify the following settings:

icon in the Chart toolbar, or double-click the axis
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¡ Line group box
Lets you modify the line style used to draw the axis.
¡ Major ticks and Minor ticks group boxes
Lets you modify the placement of the tick marks displayed on the axis.
¡ Tick labels group box
Lets you modify the placement of the tick labels displayed at the tick marks.

Scale tab
Use this tab to change the scaling of the axis.
¡ Number of series between group box
By default, PlanMaker draws a tick mark on the axis at every data series and adds a tick label to every tick
mark. To alter these settings:
The Tick marks option determines the frequency at which tick marks are set. Enter 1, and a tick mark is set
for every data series. Enter 2, and a tick mark is set for every second data series, etc.
The Tick labels option determines the frequency at which tick marks are labeled. Enter 1, and every tick
mark is labeled. Enter 2, and every second tick mark is labeled, etc.
¡ Invert axis direction
If this option is checked, the direction of the axis is reversed.

Font tab
Use this tab to change the character format (font, font size, font styles, etc.) of the axis labels.
Note: If desired, the axis labels can be rotated by choosing the Custom option and selecting the desired angle
under Rotation.

Gridlines
Adding gridlines to a chart can improve its readability.
Two types of gridlines are available:
¡ Major gridlines are painted at every major tick mark on the axis.
¡ Minor gridlines subdivide the major grid into a finer grid.
Showing/hiding gridlines: Gridlines can be enabled for each axis. To determine which gridlines to display, select
the chart, choose the menu command Object > Properties, switch to the Elements tab, and check all major or
minor grids you want to be plotted.
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Hint: Alternatively, use the two
icons in the Chart toolbar, or choose the menu command Object >
Chart > Show vertical grid lines or Show horizontal grid lines to activate grid lines.
Modifying properties: To change the properties of, e.g., the major grid of the value axis, select one of its
gridlines, right-click it, and choose the Value Axis Major Gridlines: Properties command from the context
menu.
Hint: Alternatively, select one of the lines and either click the
one of the lines to access the properties dialog.

icon in the Chart toolbar, or double-click

Options available:

Format tab
Use this tab to modify the following settings:
¡ Line group box
Lets you modify the line style used to draw the gridlines.

Changing the scaling of gridlines
To change the scaling of gridlines, modify the properties of the corresponding axis (Scaling tab).

Legend
If desired, you can add a legend to a chart. A legend is a small box indicating which colors/patterns are assigned
to the data series displayed in the chart.
Showing/hiding the legend: To show/hide the legend, select the chart, choose the menu command Object >
Properties, and switch to the Elements tab. Open the Legend dropdown list, and choose the desired location.
If you choose Custom, the legend can be moved to any position (using the mouse). If you choose None, the
legend will not be displayed.
Hint: Alternatively, use the
icon in the Chart toolbar or the Object > Chart > Show Legend menu
command to show/hide the legend.
Modifying properties: To change the properties of the legend, select it, right-click it, and choose the Legend:
Properties command from the context menu.
Hint: Alternatively, select the legend and either click the
legend to access its properties dialog.
Options available:

icon in the Chart toolbar, or double-click the
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Format tab
Use this tab to modify the following settings:
¡ Border group box
Lets you add border lines in the selected line style to the legend.
If the Shadow option is checked, a drop shadow effect will be added to the border. The Adjust button can
be used to customize the appearance of the shadow.
¡ Filling group box
Lets you change the filling of the legend.
To use complex fill types (gradients, bitmaps, etc.), select the Effects option and click the Customize
button. For more information on fill types, see section Object properties, Filling tab.

Font tab
Use this tab to change the character format (font, font size, font styles, etc.) of the legend entries.

Legend tab
Use this tab to change the placement of the legend.
If you choose Custom, the legend can be moved to any position (using the mouse). If you choose None, the
legend will not be displayed.

Changing common chart properties
The previous sections discussed how to change the properties of specific chart elements. The following section
details the common chart properties. This includes layout options, the chart type, settings related to the data
series, etc.
To modify the common properties of a chart, select the chart and choose the Object > Properties menu
command.
Hint: Clicking the

icon in the Chart toolbar will also access the Object Properties dialog.

The options available in this dialog are covered on the pages that follow.
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Chart properties, Format tab
Use the Format tab to change size and positioning of the chart. For details, see section Object properties,
Format tab.

Chart properties, Properties tab
Use the Properties tab to modify common object settings. For details, see section Object properties, Properties
tab.

Chart properties, Chart Type tab
Use the Chart Type tab to change the chart type. For details on chart types, see section Changing the chart
type.

Chart properties, Data Source tab
Use the Data Source tab to modify settings related to the chart's data source area (i.e., the cells containing the
data the chart is based on).
Options available:
¡ Data source area
Lets you specify the cell range containing the data the chart is based on. By default, the cells selected when
the chart was created are used.
¡ Data series are in group box
Lets you specify how the data source area will be arranged in the chart: by columns or by rows. See also
section Changing the arrangement of data series.
¡ Data source area contains group box
Lets you specify what kind of data the data source area consists of.
Hint: If the first row of the data source area contains headings for the data listed below, check the Names
option. PlanMaker will automatically label the data series with the corresponding headings.
¡ Include hidden cells
When the data source area contains cells that have been hidden, PlanMaker usually does not display them in
the chart. Check this option if you want hidden cells to be displayed as well.
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Chart properties, Series tab
Data series are the most important chart elements. They represent the data to be displayed in a chart. For
example, in a column chart, the height of each column stands for the size of the corresponding value.
The Series tab allows you to modify settings related to the data series of a chart.
Before making any changes, make sure you have selected the desired data series in the Series list.
Options available:
¡ Series
The Series list contains a list of all data series defined in the current chart.
The arrow buttons change the order of data series.
The Add and Delete buttons add/delete a series.
¡ Data sources group box
Allows you to specify which cells' contents are used to build up the selected data series.
The fields in this section are filled in automatically (using the cells selected when the chart was created), and
there is usually no need to change them.
Fields in this section:
Name: Lets you modify the name of the data series. Either enter the cell containing the name or type in a
text string directly, or, leave this box empty, and PlanMaker will automatically assign a name (Series 1,
Series 2, etc.).
Y values: Lets you choose a different cell range for the y values of the data series.
Annotation: With most chart types, the y values represent the data to be displayed in the chart. For
example, in a column chart, the y values determine the height of the columns.
X values: Lets you choose a different cell range for the x values of the data series.
Annotation: With most chart types, the x values are irrelevant and therefore set to "Auto" (= automatic).
All they do is providing labels for the category axis (x axis). Exception: E.g. in XY scatter charts and
bubble charts, the x and y values determine the coordinates of the data points.
Bubble size: Lets you choose a different cell range for the bubble sizes of the data points (only available in
bubble charts). If omitted, all bubbles will have the same size.
¡ Display this series as group box
Allows you to modify the way the selected data series is displayed in the chart. For example, in a column
chart, you can change the appearance of one or more data series to lines instead of columns.
¡ Use secondary axis for this series
If you check this option, the selected data series will be displayed using a secondary value axis (y axis).
Secondary axes can have a different scale than primary axes.
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Annotation: Using a secondary axis is helpful if one or more data series require a completely different
scale on the axis because they contain values many times larger or smaller than the other data series.

Chart properties, Elements tab
Use the Elements tab to show/hide certain chart elements or to add captions to them.
Options available:
¡ Chart title
Lets you enter a title for the chart. The title will be displayed above the chart.
¡ Primary Axes group box
Allows you to configure the primary axes:
The checkbox in front of the axis determines if it will be displayed in the chart.
The text box to the right lets you enter a caption for the axis.
The options Major grid and Minor grid determine if a grid will be displayed in the background of the
chart. For more details on gridlines, see section Gridlines.
¡ Secondary Axes group box
Allows you to configure the secondary axes (only available for charts that contain a secondary axis).
¡ Legend
Allows you to change the position of the legend. A legend is a small box indicating which colors/patterns
are assigned to the data series displayed in the chart. For more details, see section Legend.

Chart properties, 3D View tab
Note: This tab is only available for three-dimensional chart types.
Use the 3D View tab to modify the 3D effect settings for the chart.
Options available:
¡ Rotation angle and Elevation angle
Lets you modify the viewing position. Rotation angle rotates the chart around the vertical axis; Elevation
angle changes the height of the viewing position.
¡ Perspective
To display the chart with perspective distortion, check this option and choose the amount of distortion (0 to
100 percent).
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¡ Height and Depth
Lets you modify the height and depth of the chart (as a percentage of its original size).

Chart properties, Radar tab
Note: This tab is only available for Radar charts.
Use the Radar tab to modify settings specific to Radar charts.
Options available:
¡ Starting angle
Rotates the chart by the specified angle.
¡ Orientation
Specifies if the data points are arranged clockwise or counterclockwise.
¡ Round chart
If this option is checked, circle segments are drawn between the axes instead of lines.
¡ Polar coordinates
If this option is checked, polar coordinates are used instead of Cartesian coordinates. Only available if
Round chart is checked.
If Angle between axes is set to x, an axis is plotted every x degrees.
If Angle between axis descriptions is set to x, an axis label is plotted every x degrees.
¡ Limit plot area to radar
If this option is checked, only the area inside the radar will be filled. If it is not checked, the rectangle
surrounding the radar will be filled as well.

Updating charts
By default, charts are automatically updated when the content of one of the cells it is based on changes. If
desired, this feature can be disabled, requiring charts to be updated manually.

Deactivating automatic update
To deactivate the automatic update of charts, choose the menu command File > Properties, switch to the
Calculate tab, and uncheck the Update automatically option in the Charts group box.
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As a result, charts will only be updated when the Tools > Update charts menu command is invoked.

Moving charts to another worksheet
When you create a new chart, it will always be inserted into the current worksheet. Of course you can change
its position whenever needed:
To move a chart to another place within the current worksheet, just select it with a mouse click and drag to the
desired location.
In case you want to move a chart to a different worksheet, proceed as follows:
1.

Select the chart of interest.

2.

Invoke the menu command Object > Chart > Change chart location.

3.

Choose the desired option (see below) and click on OK.

The chart is moved accordingly.
Options available:
¡ As new sheet
When you choose this option, the chart will be transferred to its own chart sheet. PlanMaker removes the
chart from the current sheet, creates a new chart sheet for it, and places the chart there.
A "chart sheet" is a special type of worksheet: It doesn't contain any table cells, but solely the chart in its full
size. Note: On such sheets, only commands related to editing charts are available.
¡ As object in ...
When you choose this option, the chart is placed as an object in the specified worksheet, as usual.

Saving charts as images
Whenever needed, you can save an image of a chart as a picture file. This makes it easier, for example, to share
the chart with others or to insert it into a web page or any other document.
Proceed as follows:
1.

Select the chart of interest.

2.

Invoke the menu command Object > Chart > Save as picture.

3.

In the Save as type list, choose the desired image format. (PNG format is recommended.)
Tip: The PNG format is always a good choice here, since it offers a fairly good and at the same time lossless compression.
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4.

Enter a filename for the image file and confirm with OK.

5.

Another dialog appears where you can select an image resolution or enter your own values for width and
height. Confirm with OK.

PlanMaker creates the specified picture file and stores an image of the chart in it.

Forms

Forms
You can insert form objects into your tables and, in this way, create forms.

The following types of form objects are available:
¡ Checkboxes for checking
¡ Radio buttons for selection among multiple alternatives
¡ Dropdowns for selection from an expanding list
¡ Listboxes for selection from a list
¡ Pushbuttons for clicking
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¡ Spinners for increasing/decreasing values by mouse click
¡ Scrollbars for increasing/decreasing values by mouse click
¡ Labels for static descriptions
¡ Groupboxes for visually grouping related items
Form objects always have a Result cell. This is the cell, which holds the value that the form object returns.
Each form object can be assigned to a different result cell.
If, for instance, you insert a listbox with several entries in it, 1 is displayed in the result cell when the first entry
is clicked, 2 when the second entry is clicked, etc.
In this chapter, you will find detailed information on forms. It contains the following sections:
¡ Working with form objects
The first section covers general information on working with form objects. You will learn how to insert,
edit, operate, and evaluate form objects.
¡ Form objects in detail
The second section contains detailed information on each individual type of form object.

Working with form objects
In the following sections, you will find general information regarding the use and application of form objects:
¡ Inserting form objects
¡ Editing form objects
¡ Operating and evaluating form objects
¡ Form objects and Excel macros and scripts
Then, in the section Form objects in detail, we will cover the individual types of form objects in detail.

Inserting form objects
Inserting form objects is not much different from inserting other kinds of objects. For more information about
that, see the chapter Objects (pictures, drawings, etc.).
To insert a form object, proceed as follows:
1.

Select the Object > New form object menu command.

2.

A sub-menu opens; choose the desired type of form object from it.
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The form object is inserted.
In case you want to modify its position or size, do the following:
To change the position, click on the object and (while still holding the mouse button down) drag it to the
desired position.
To adjust its size, drag on one of the round handles surrounding the object.

You will find detailed information about each individual type of form object in the section Form objects in
detail.

Using the Forms toolbar
You can also use the Forms toolbar to insert form objects. To activate or deactivate this toolbar, invoke the
View > Toolbars menu command and click on the checkbox in front of Forms.

The icons in this toolbar represent the following functions (from left to right):
¡
¡
¡
¡
¡
¡
¡
¡
¡
¡

Insert text frame
Insert checkbox
Insert radio button
Insert dropdown
Insert listbox
Insert button
Insert spinner
Insert scrollbar
Insert label
Insert groupbox

¡ Toggle cell protection (see the section Sheet protection)
¡ Toggle sheet protection (see the section Sheet protection)

Hint: Move the mouse pointer over any of these icons, and a short explanation of its function is displayed.

Editing form objects
Editing form objects is not very different from editing other types of objects. See the chapter Objects (pictures,
drawings, etc.).
There is, however, one important difference:
Important: Form objects cannot be selected with a left-click by the mouse. To select a form object, click on
it with the right mouse button.
Alternatively, you can switch to Object mode (for example, by invoking the menu command View > Object
mode), where you can select form objects with a left click.
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When you have selected a form object, you can edit it just as any other type of object; for example, move it
with the mouse, change its dimensions, modify its properties with the Object > Properties menu command,
etc.
Information about the properties of the individual types of form objects can be found in the section Form
objects in detail.

Operating and evaluating form objects
Using form objects is very much like using control elements in dialog windows. For instance, checkboxes can
by checked or unchecked with a mouse click, a listbox entry can be selected by clicking on it, etc.

Evaluation of form objects
Form objects are evaluated through the result cell of the object. This is the cell to which the result of the form
object is returned.
The location of the result cell can be determined individually for each form object. To do this, select the form
object and invoke the Object > Properties menu command. In the dialog, switch to the Form object tab and
enter the desired cell address in the Result cell field.
For example: You have given a list the result cell D4. If you click the first entry in the list, 1 will be displayed
in D4. If you click the fifth entry, 5 will be displayed, etc.
The relationship between a form object and its result cell is also two-way: If you enter 3 into the result cell, the
third entry in the list is selected.

Form objects and Excel macros and scripts
Microsoft Excel files can contain macros and VBA scripts that can be used by form objects. In PlanMaker, this
isn't possible, however:
Important: If you open an Excel file that has macros or scripts, you won't be able to run them; however, they
do remain in the file. So, if you open and edit such an Excel file in PlanMaker and then save it, the macros
and scripts will not be lost.

Form objects in detail
In this section we describe in detail the individual types of form objects. The following objects are covered:
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¡ Checkboxes
¡ Radio buttons
¡ Dropdowns
¡ Listboxes
¡ Pushbuttons
¡ Spinners
¡ Scrollbars
¡ Labels and groupboxes

Checkboxes
To insert a checkbox, use the Object > New form object > Checkbox menu command.
Checkboxes can be used for yes/no questions in forms. A checked checkbox stands for Yes, an unchecked one
stands for No.

Operating checkboxes
Click the box to check it. If you click it again, it will become unchecked.

Changing the properties of checkboxes
To modify the properties of a checkbox, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.
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Form Object tab
On this tab, you can make settings that are specific to checkboxes:
¡ Text
Here you can enter the text that is displayed to the right of the box.
¡ Value
Here you can specify the initial state of the checkbox, whether it should appear checked or unchecked in the
document.
¡ Result cell
Here you specify to which cell the result of the form object should be returned.
One of the following values will appear in this cell:
TRUE, when the checkbox is checked.
FALSE, when the checkbox is unchecked.
The error value #N/A, when the state of the checkbox is ambiguous.
¡ Appearance group box
Here you can specify the font styles (font face, size, color, etc.) for the text.
¡ 3D effect
If you check this option, the checkbox is drawn with a 3D effect.

Radio buttons
To insert a radio button, use the Object > New form object > Radio button menu command.
Radio buttons can be used in forms to select a single option from multiple options.

Using groupboxes to combine radio buttons
Important: Radio buttons must always be used in groups of at least two.
To indicate that a group of radio buttons belongs together, enclose them in a groupbox.
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First, insert the radio buttons that belong together into the document (one under the other, for example), then
wrap a group box around them with the menu command Object > New form object > Groupbox.

Operating radio buttons
Click one of the radio buttons to select it. Only one radio button within a group can be selected at a time.

Changing the properties of radio buttons
To modify the properties of a radio button, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.

Form Object tab
On this tab, you can make settings that are specific to radio buttons:
¡ Text
Here you can enter the text that is displayed to the right of the radio button.
¡ Value
Here you can specify the initial state of the radio button, whether it should appear selected or unselected in
the document.
¡ Result cell
Here you specify to which cell the result of the form object should be returned.
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As mentioned previously, radio buttons must always be used in groups of at least two. The result cell
displays which among the radio buttons is selected. When the first is selected, 1 is displayed, when the
second is selected, 2 is displayed, etc.
¡ Appearance group box
Here you can specify the font styles (font face, size, color, etc.) for the text.
¡ 3D effect
If you check this option, the radio button is drawn with a 3D effect.

Dropdowns
To insert an expandable dropdown list, use the Object > New form object > Dropdown menu command.
Dropdown lists figure prominently in many dialog windows. When you expand a dropdown, a list of available
options is shown. Naturally, this is ideal for forms, as it saves typing and eliminates the possibility of typos.

Operating dropdowns
Click the arrow at the right of the list to open the dropdown. Then you can select an entry by clicking on it.

Changing the properties of dropdowns
To modify the properties of a dropdown, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.

Form Object tab
On this tab, you can make settings that are specific to dropdown lists:
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¡ Lines (max.)
Here you can specify the maximum number of lines to be displayed when the list is opened.
¡ List area
Here you specify the cell range that contains the items to be displayed in the dropdown list.
If, for example, you fill the cells F5 through F7 with the values "dog", "cat" and "mouse" and enter F5:F7 in
the list area, those three values will appear in the list.
¡ Result cell
Here you specify to which cell the result of the form object should be returned.
The result cell displays which entry in the list is selected. When the first entry is selected, 1 appears. When
the second entry is selected, 2 appears, etc.
¡ Appearance group box
Here you can specify the font styles (font face, size, color, etc.) for the text.
¡ 3D effect
If you check this option, the list is drawn with a 3D effect.

Listboxes
To insert a listbox, use the Object > New form object > Listbox menu command.
Listboxes figure prominently in many dialog windows. They display several entries which the user can choose
by clicking on them. Naturally, this is ideal for forms, as it saves typing and eliminates the possibility of typos.

Changing the properties of listboxes
To modify the properties of a listbox, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.

Forms

293

Form Object tab
On this tab, you can make settings that are specific to listboxes:
¡ Selection Type
You should always use the Single option here.
The other options Multi and Extended allow multiple items to be selected in the list box, but return nothing
to the result cell. They are only there for compatibility with Excel.
¡ List area
Here you specify the cell range that contains the items to be displayed in the listbox.
If, for example, you fill the cells F5 through F7 with the values "dog", "cat" and "mouse" and enter F5:F7 in
the list area, those three values will appear in the list.
¡ Result cell
Here you specify to which cell the result of the form object should be returned.
The result cell displays which entry in the list is selected. When the first entry is selected, 1 appears. When
the second entry is selected, 2 appears, etc
¡ Appearance group box
Here you can specify the font styles (font face, size, color, etc.) for the text.
¡ 3D effect
If you check this option, the list is drawn with a 3D effect.

Pushbuttons
To insert a pushbutton, use the Object > New form object > Pushbutton menu command.
Note: In PlanMaker, pushbuttons cannot be used to execute macros or VBA scripts; they are merely present for
compatibility with Excel.

Changing the properties of pushbuttons
To modify the properties of a pushbutton, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:
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Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.

Form Object tab
On this tab, you can make settings that are specific to pushbuttons:
¡ Text
Here you can specify the text that should appear on the button.
¡ Appearance group box
Here you can specify the font styles (font face, size, color, etc.) for the text.

Spinners
To insert a spinner, use the Object > New form object > Spinner menu command.
Spinners allow you to increment or decrement a value by mouse click. Clicking the upward pointing arrow
increments the value, clicking on the downward pointing arrow decrements it.

Changing the properties of spinners
To modify the properties of a spinner, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.
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Form Object tab
On this tab, you can make settings that are specific to spinners:
¡ Parameters group box
Here you can specify the following parameters:
Current value: The current value (corresponding to the value in the result cell).
Minimum value: The lowest value allowed.
Maximum value: The highest value allowed.
Incremental change: The value that will be added/subtracted to the current value when one of the two
arrows is clicked.
¡ Result cell
Here you specify to which cell the result of the form object should be returned.
¡ 3D effect
If you check this option, the spinners are drawn with a 3D effect.

Scrollbars
To insert a scrollbar, use the Object > New form object > Scrollbar menu command.
With scrollbars, values can be incremented or decremented by mouse click. Clicking the upward pointing arrow
increments the value by the specified incremental value, while clicking the downward pointing arrow
decrements it.
Furthermore, you can make larger changes by moving the slider on the scrollbar with the mouse.

Changing the properties of scrollbars
To modify the properties of a scrollbar, first select it (for example, by right-clicking on it). Then invoke the
Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.
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Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.

Form Object tab
On this tab, you can make settings that are specific to scrollbars:
¡ Parameters group box
Here you can specify the following parameters:
Current value: The current value (corresponding to the value in the result cell).
Minimum value: The lowest value allowed.
Maximum value: The highest value allowed.
Incremental change: The value that will be added/subtracted to the current value when you click on one of
the two arrows in the scrollbar.
Page change: The value that will be added/subtracted when you click somewhere between the scrollbar's
slider and one of the arrow buttons.
¡ Result cell
Here you specify to which cell the result of the form object should be returned.
¡ 3D effect
If you check this option, the scrollbar is drawn with a 3D effect.

Labels and groupboxes
Aside from the aforementioned form objects there are two more types of form objects that cannot be filled out,
but are instead intended for labeling and grouping:
Labels
In a label you can enter any text that you want to be displayed in a form.
Groupboxes
Groupboxes are rectangles that have a text label in their upper left corner. They can be used to visually
group form elements together.
To insert a label or a groupbox, use the menu command Object > New form object > Label or, respectively,
the menu command Object > New form object > Groupbox.
The corresponding form object is inserted in a standard size. If necessary, you can change its position by
dragging it with your mouse. To adjust its size, drag one of the round handles appearing around the object.
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Changing the properties of labels and groupboxes
To modify the properties of a label or a groupbox, first select it (for example, by right-clicking on it). Then
invoke the Object > Properties menu command.
A dialog window with the following options will appear:

Format tab
On this tab, you can modify the size and positioning of the object. See the section Object properties, Format
tab.

Properties tab
On this tab, you can modify common object settings. See the section Object properties, Properties tab.

Form Object tab
On this tab, you can make settings that are specific to labels/groupboxes:
¡ Text groupbox
Here you specify the text to be displayed.
¡ Appearance group box
Here you can specify the font styles (font face, size, color, etc.) for the text.
¡ 3D effect
If you check this option, the object is drawn with a 3D effect.
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Language tools
PlanMaker comes with an integrated spell checker, allowing you to check the spelling of text. Additionally,
multiline text can be hyphenated automatically.
This chapter provides information on working with this tool, as follows:
¡ Setting up the language
The language for spell checker and hyphenator can be set with the menu command Tools > Options
(Language tab).
¡ Spell checking
The spell checker examines the text in your document for spelling mistakes. When it finds mistakes, it
suggests corrections.
¡ Hyphenation
The hyphenator automatically hyphenates long words at the ends of lines. By default, it is active only in text
frames, but you can also activate hyphenation for multiline text in table cells.
¡ SmartText
With PlanMaker's SmartText feature, you can have your "favorite" typing errors corrected automatically and
create short-cuts for frequently needed phrases, such as "sd" for "sales department."

Setting up the language
If you have installed several languages, you can change the language for the spell checker, hyphenator and
thesaurus, as needed.
To do this, proceed as follows:
1.

Invoke the Tools > Options menu command.

2.

Switch to the Language tab.

3.

Select the desired language from the Language list.
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Spell checking
The spell checker examines the text in your document for spelling mistakes. When it finds mistakes, it suggests
corrections.
This section describes the different spell checking tools in detail. It covers the following topics:
¡ Manual spell checking
The manual spell checker lets you check and correct the spelling of the entire text in a worksheet, word by
word.
¡ Spell checking as you type
The on-the-fly spell checker checks each word you type immediately. When a typing mistake is detected, a
dialog box that lets you correct the word pops up.
¡ Editing user dictionaries
When you teach the spell checker new words, they are added to your user dictionary. You can edit this
dictionary at any time in order to, for example, delete incorrect entries.
See the following pages for detailed information.

Manual spell checking
Note: Cells containing calculations are skipped by the spell checker.
You activate the manual spell checker with the Tools > Check spelling menu command.
This checks the text word for word for spelling errors. If an unrecognized word is found, the spell checker stops
and displays the word in a dialog box.
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You can then choose to correct the word, add it to the dictionary, or simply ignore the supposed error.
Additionally, in the list under Change to, some suggestions for the correct spelling of the word are presented
(if any are found).
Use the dialog buttons to specify what to do with the unknown word, as follows:
Button

Explanation

Change

Lets you correct the word. Before you use this button, type the correct spelling in the Change to
input field or select one of the suggested words from the list.

Change all

Works like the Change button, but changes all further instances of the word (from here to the end
of the document).

Ignore

Ignores the supposed spelling error and continues with the spelling check.

Ignore All

Ignores all further instances of this word.
Note: Use Ignore or Ignore All only for words that are correctly written but are not to be added to
the dictionary. When you exit PlanMaker, it forgets the list of ignored words.

Add

Advises PlanMaker to add the word to the user dictionary and in this way to enlarge its
vocabulary.
Note: Use this option for correctly spelled words that PlanMaker does not yet know. PlanMaker
remembers these words permanently.

If you want to exit the spell checker before it reaches the end of the document, click on Close.
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Spell checking as you type
If the Check spelling as you type option is activated, spelling is checked as the text is typed, and the spell
check dialog box will open automatically when an unknown word is typed.
Note: When you enter a calculation into a cell, its spelling will not be checked.
To activate the on-the-fly spell checker, choose the menu command Tools > Options, switch to the Language
tab, and activate the Check spelling as you type option.
Now, every time you type a word, PlanMaker quickly looks up that word in its dictionaries. As long as you type
words that the spell checker knows, nothing visible happens. But if you type an unknown word, the spell
checker displays a dialog box.
This dialog box is like the one for manual spell checker that was presented in the preceding section. You can
read there about how to use this dialog.
You will notice that there is also a SmartText button in the dialog box. This is for creating a SmartText entry
from the word. You will learn more about this feature in section SmartText.

Editing user dictionaries
When you teach the spell checker new words, they are added to your user dictionary. You can edit this
dictionary at any time in order to, for example, delete incorrect entries.
To do this, invoke the menu command Tools > Edit user dictionaries. A dialog opens, providing the following
controls:
¡ Language
Every language has its own user dictionary. You can select the user dictionary to be edited from the
Language dropdown list.
¡ Entries
This list contains all words that have been added to your user dictionary (for the selected language).
¡ "Close" button
This button closes the dialog.
¡ "Add" button
This button enables you to add a word to your user dictionary manually. A dialog appears, allowing you to
enter the word.
Words added this way are treated exactly the same way as words that have been added using the Add button
in the spell checker.
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¡ "Change" button
Use this button to edit the word that is currently selected in the list. This is useful for misspelled words that
you have added to your user dictionary accidentally. Clicking on the button opens a dialog that allows you to
correct the spelling of the word.
¡ "Delete" button
This button removes the selected word from your user dictionary – thus, the spell checker will now view this
word as incorrectly spelled, as it did before the word was added.

Hyphenation
The hyphenator automatically hyphenates long words at the ends of lines. Hyphenation is performed
completely automatically and takes effect as you type.
However, the hyphenator is available only in the following cases:
¡ Hyphenation in text frames
In text frames, the hyphenator is active by default.
¡ Hyphenation in table cells
In table cells, the hyphenator is not active by default, but it can be activated by the user (for cells that
contain multiple lines of text).
For detailed information, see the pages that follow.
Important: For the hyphenator to function properly, make sure that you have selected the correct language in
the program preferences (typically, your native language). To set the language, invoke the menu command
Tools > Options, switch to the Language tab, and choose a language from the Language list.

Hyphenation in text frames
Whenever you enter text in a text frame, PlanMaker will automatically hyphenate it. This is performed fully
automatically in the background, as you type.
All you have to do is to make sure that the correct language is set in PlanMaker's preferences (see section
Setting up the language).

Setting the hyphenation frequency
If desired, you can specify how often the hyphenator should break words – or you can turn the hyphenator off.
You can do this separately for each individual paragraph as follows:
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Select the paragraph(s) of interest, invoke the menu command Format > Paragraph, and select an option in
the Hyphenation dropdown list.
The following options are available:
Option

Result

None

No hyphenation is performed.

Always

Hyphenation is attempted in successive lines without limit. This is the default setting.

Every 2 lines

Hyphenation is attempted only in every second line.

Every 3 lines

Hyphenation is attempted only in every third line.

Thus, with None you turn hyphenation off completely for the selected paragraph. With Always, on the other
hand, you allow hyphenation to be performed whenever possible on any line of the paragraph.
In some cases, it is not always a good idea to hyphenate at every point possible, and this is where the other two
options come in handy. For example, text that is in narrow columns could lead to a broken word at the end of
almost every line and, consequently, to a reduction of the document's legibility. Therefore, instead, you may
want to use the Every 2 Lines or Every 3 Lines option to direct PlanMaker to attempt hyphenation only in
every second or third line.

Hyphenation in table cells
In table cells, the hyphenator is not active by default, but it can be activated by the user. When you do so,
hyphenation will also be performed in table cells – but only in cells that contain multiple lines of text.
Accordingly, in order to get text in table cells hyphenated, two steps are required:

Step 1: Activating hyphenation in cells
By default, hyphenation in cells is turned off. To activate it, proceed as follows:
1.

Invoke the File > Properties menu command.

2.

Switch to the Options tab.

3.

Activate the Hyphenation option.

From now on, automatic hyphenation will also be performed in table cells.
Note: This option is a document option, so you can turn it on or off for each document individually.

Step 2: Activating the Wrap Text option for cells
Hyphenations will be performed only in table cells that have the Wrap Text option turned on. When you
activate this option, the cell content will automatically be wrapped to multiple lines if it doesn't fit into a single
line.
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To turn the Wrap Text option on, proceed as follows:
1.

Select the cells of interest.

2.

Invoke the Format > Cell menu command.

3.

Switch to the Alignment tab.

4.

Activate the Wrap Text option.

Text entered in these cells will from now on be wrapped to multiple lines automatically, and automatic
hyphenation will be performed where necessary.

SmartText
PlanMaker's SmartText feature can save you a lot of work: you can define SmartText entries for frequently
needed phrases and then call them out in your text quickly and easily.
For example, you can define a SmartText entry named "sd" containing "sales department". Now you can call
out this SmartText entry at any time. Simply type "sd" and then press the space bar, the Enter ¿ key, or a
punctuation character key. Immediately, "sd" is replaced with "sales department".
In this way, you can use PlanMaker to put together a personal "computer shorthand" and save significant typing
time.
In this section, you will learn details about PlanMaker's SmartText feature, including the following:
¡ Creating SmartText entries
SmartText entries can be created either with the Insert > SmartText menu command or the on-the-fly spell
checker. You give the SmartText entry a name (e.g., "sd") and then enter the desired content (e.g., "sales
department").
¡ Inserting SmartText entries
To call up a SmartText entry, simply type its name and then press the space bar, the Enter ¿ key, or a
punctuation character. The name will be immediately replaced by the content of the SmartText entry.
Alternatively, SmartText entries can be inserted manually using the menu command Insert > SmartText.
¡ Editing SmartText entries
You can create new SmartText entries with the menu command Insert > SmartText, and you can also edit,
rename, and delete existing entries.
Detailed information is provided on the following pages.
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Creating SmartText entries
To create a new SmartText entry, choose one of the following methods:

A) Using the Insert > SmartText dialog
To create, for example, a SmartText entry with the name "sd" containing "sales department", proceed as
follows:
1.

Invoke the menu command Insert > SmartText.

2.

Click on the New button to create a new SmartText entry.

3.

Give the SmartText entry a name ("sd" in our example).
Later, the SmartText entry can be called up by using the specified name.

4.

Confirm with OK, which takes you back to the main dialog.

5.

Type the text of the SmartText entry in the large input field ("sales department" in our example).

6.

Click on Save to save your new SmartText entry.

7.

Exit the dialog by clicking on the Close button.

The SmartText entry has now been created. In the next section (Inserting SmartText entries), you will learn how
to use your new SmartText entry.

B) Using the "Check spelling as you type" option
Alternatively, SmartText entries can be created using the on-the-fly spell checker (activated by the Check
spelling as you type option).
Note: This procedure is faster only if you have the Check spelling as you type option turned on permanently.
Otherwise, the previous procedure is more efficient.
To create a SmartText entry named "sd" containing the text "sales department":
1.

Make sure the Check spelling as you type option in the dialog of the Tools > Options menu command
(Language tab) is activated.

2.

Type "sd" and press the space bar.

3.

The on-the-fly spell checker displays a dialog indicating that the word "sd" is unknown.

4.

Click the SmartText button.

5.

Type "sales department".

6.

Confirm with OK.

The result is the same: the SmartText entry "sd" has now been created.
To learn more about the on-the-fly spell checker, see the section Spell checking as you type.
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Inserting SmartText entries
Once you define a SmartText entry, you can use it anytime as you compose your documents.
Type the name of the SmartText entry (e.g., "sd" in our example) in the text, and then press either the space bar,
the Enter ¿ key, or a punctuation character. PlanMaker immediately replaces "sd" with the content of the
SmartText entry, in our example, "sales department".
Note: If this does not work, the Expand SmartText entries option might be disabled. If so, invoke the menu
command Tools > Options, switch to the Language tab, and turn on this option.
Alternatively, you can use a dialog to insert SmartText entries in the text by invoking the menu command
Insert > SmartText, choosing the desired entry, and then clicking the Insert button.

Editing SmartText entries
You can edit SmartText entries that you have previously defined with the menu command Insert > SmartText
as follows:
¡ Creating a new SmartText entry
To create a new SmartText entry, click the New button (see section Creating SmartText entries).
¡ Deleting a SmartText entry
To delete an entry, select it from the SmartText entries list and then click on the Delete button.
¡ Renaming a SmartText entry
If you want to change the name of an entry, select it from the list and click on the Rename button. A dialog
box appears, and you can enter the new name there.
¡ Editing a SmartText entry
To edit an entry, select it from the list and then click in the large input field. Now you can modify the
content of the SmartText entry.
When you have made the desired changes, click on the Save button.
¡ Inserting a SmartText entry
To insert a SmartText entry into the text, select it from the list and click on the Insert button (see also the
section Inserting SmartText entries).
To exit the dialog, click the Close button. If the active SmartText entry has been changed and not yet saved,
PlanMaker will ask automatically if it should save the changes.
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Managing documents
PlanMaker provides the following functions for efficiently managing and accessing documents:
¡ Quick paths
You can set up quick paths to change immediately to folders that are frequently used to save or retrieve files.
¡ Document summary
Every document can have a document summary that you can display and edit using the Summary tab in the
dialog of the File > Properties menu command. You can specify the document's title, subject and author,
enter keywords for the file manager's search function, and compose a brief description of the document's
contents.
¡ The file manager
The integrated file manager provides a convenient way to access your documents. It allows you to see at a
glance the names and summaries of your documents, and to examine, open, print or delete them with the
press of a key. With the search function, you can look for documents not only by filename, but also by
subject, title, author, etc.
¡ Backup copies
Whenever you save a document, PlanMaker can automatically create a backup copy containing its previous
version. There is even an option to keep multiple generations of backup copies for each document.
You will find detailed information for each of these functions on the following pages.

Quick paths
PlanMaker gives you the capability to define up to twenty quick paths and use them to change to specific
folders where you open or save files frequently.
A quick path is a symbolic statement like "Taxes" that stands for a specific folder on the hard disk (for
example, the folder c:\Accounting\Taxes).
When you want to open a file in this folder, all you need to do is click on the Quick path button in the dialog
of the File > Open menu command and select its quick path. The dialog changes immediately to the c:
\Accounting\Taxes folder.
Quick paths are available not only in the File > Open dialog, but also in all other dialog boxes that have to do
with opening or saving files.
See the next pages for details.
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Defining quick paths
To define a new quick path, complete the following steps:
1.

Open any type of file dialog, for example, by invoking the File > Open menu command.

2.

Click the Quick path button.

3.

A menu opens below the button. Select the Create new quick path command from it.

4.

At Name of quick path enter a meaningful name for the quick path – for example, "Taxes".

5.

At Path enter the desired folder – for example, c:\Accounting\Taxes.
Tip: Alternatively, click on the button with the three dots next to this text field. This opens a dialog where
you can browse to the folder of interest.

6.

Confirm with OK.

From now on, PlanMaker will change to the folder c:\Accounting\Taxes when the quick path "Taxes" is
invoked.
Quick paths with search patterns: Quick paths can also include search patterns for file names. For example, you
can define a quick path as c:\Accounting\Taxes\2018*.*, which tells PlanMaker to change to the folder c:
\Accounting\Taxes and display only those files whose names begin with "2018".
Keyboard shortcut: The & sign can be used in a quick path name to give the name a keyboard shortcut. For
example, if you enter "&Taxes" as the name, the quick path of this name can be invoked by pressing the T key
whenever the list of quick paths is opened.

Using quick paths
Quick paths are available in all file dialogs – for example in the dialogs of the File > Open and the Object >
New picture menu command.
To invoke a quick path, do the following:
1.

Click on the Quick path button in a file dialog.

2.

A menu of all the previously defined quick paths opens. Select the desired quick path.

PlanMaker now changes to the folder specified for the quick path.
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Editing and deleting quick paths
To modify or delete an existing quick path, do the following:
1.

Click on the Quick path button in a file dialog.

2.

A menu opens. Select the Change quick paths command from it.

3.

A dialog box appears. Select the desired quick path from the list box.

4.

Click on Change to edit the name or path, or on Delete to remove the quick path.

Document summary
You can use the menu command File > Properties not only to make document specific settings, but also to
enter summary information about the document.
The summary contains additional information (subject, author, keywords, etc.) about a document. To view or
edit it, invoke the menu command File > Properties and switch to the Summary tab. Enter your modifications,
and confirm with OK.
Tip: Using the file manager (see the next section), you can search for documents based on the contents of
their summaries. For example, you can have the file manager find all documents from a specific author.
Automatic prompt for summary information when saving: At your option, you can have PlanMaker prompt you to
fill in the document summary whenever you save a newly created document. To enable this function, invoke the
menu command Tools > Options, switch to the Files tab, and enable the Prompt for summary information
when saving option. Now, each time you save a new document for the first time, the dialog box for the entry of
summary information will appear.

The file manager
The file manager displays a list of documents from one or more folders and lets you open, print, delete or view
any document with a click of the mouse.
To start the file manager, use the menu command File > File manager.
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Using your mouse, you can resize the File manager window or move it to a different position anytime. The
widths of the columns can be changed by dragging the lines that separate the column headers.
By clicking on one of the column headers, you can sort the files according to the contents of the column under
that header.
You can use the Search button to change to another folder. Apart from that, this button also provides access to
search functions that work with document summary information, so that you can search for specific titles,
subjects, authors, keywords, etc.
You can select a file and then invoke a function to be performed on the file by clicking on one of the buttons.
The functions associated with these buttons are described in the next section.

The file manager’s buttons
The buttons in the file manager have the following functions:
¡ Open
When you click on this button, PlanMaker opens the selected file.
Tip: You can also open a file by double-clicking on its filename.
¡ Close
Use this button to exit the file manager.
¡ Search
You can click on this button to search for specific files or simply to select a new folder for display in the file
manager. For more information on this topic, see the next section (entitled Searching with the file manager).
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¡ Output
Use this button to print or e-mail the selected file. When you click on the button, a menu opens with the
following functions (depending on the operating system):
E-mail: send document via e-mail
Print: print the document
¡ Rename
Click on this button if you want to change the name of the selected file.
¡ Delete
If you click on this button, the selected file will be deleted (after confirmation).
¡ Preview
Click on this button to preview the selected file.
A preview window appears. To open the document displayed in the preview window, click Open. To close
the preview, click Cancel.

Searching with the file manager
With the help of the file manager's Search button, you can have PlanMaker look for specific files or simply
choose the folder to be displayed in the file manager.

You can search for files that meet criteria of the following types: filename, folder, file type, as well as the items
in the document summary (title, subject, author, keywords, and description).
Moreover, you can combine several search criteria. For example, if you only specify a particular folder in the
search dialog, PlanMaker will display all the documents in this folder. But if you also enter a search term in the
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Title field, PlanMaker will find only those documents that are both in the selected folder and contain the given
search term in the Title field of their summaries.
The search dialog has the following functions:
¡ File name
Allows you to search for a specific file or a filename pattern.
With the default setting, the search function will find all documents of the chosen file type in the chosen
folder.
If you specify a unique filename like MyReport.pmdx, only files with exactly this name will be found.
If you specify a filename pattern like My*.pmdx, all documents whose filenames begin with "My" will be
found.
¡ File type
From this list, you can choose the type of the files to be targeted in the search. For example, if you want to
search for files in Excel Format, select this format from the File type list.
¡ Title, Subject, Author, etc.
By making entries in these fields, you can target your search to the contents of the summaries that are
included in your documents (see the section Document summary).
If you fill in several fields, the file manager will search for documents that meet all of your specified
conditions. For example, if you enter "tax" in the Keywords field and "Smith" in the Author field, only
documents whose summaries contain corresponding entries for both fields will be found.
You will get different search results depending on the precision with which you specify the search terms.
For example, if you typed "tax" as the search term in the Keywords field, your search would also turn up
documents whose keywords contain "tax increase" and "my income tax", etc. – that is, all the documents in
which "tax" was contained anywhere in the keywords.
Case is of no significance in search terms. If the search term is entered as "tax", the search will also find
documents whose keywords contain "Tax".
¡ Folders
Here you can select the folder in which the file manager is to carry out the search.
¡ Include subfolders
If this option is enabled, the file manager searches not only the selected folder, but also all folders below the
selected folder.
¡ "New list" button
Starts a new search using the current settings.
¡ "Add to list" button
Also starts a new search; however, any previous search results remain in the list rather than being cleared
from the list.

Managing documents

313

Backup copies
Note: This feature is not available in the Android version. On Android, only an option for simple (single)
backups is available: the option Create backup files in the preferences.
Whenever you save a document, PlanMaker can automatically create a backup copy containing its previous
version. There is even an option to keep multiple generations of backup copies for each document.
You will find the related settings in the dialog of the Tools > Options menu command, Files tab. The
dropdown list in the Backup section allows you to specify if and how backup copies will be generated. Options
available:
¡ No backup
When you choose this option, no backup copy is created when you save a document. (Not recommended.)
¡ Simple backup
Here, exactly one backup copy is created when you save a document. This copy contains the previous (i.e.
last saved) version of the document. It is saved as a file with the name extension .bak, stored in the same
folder as the document.
For example, when you save the document test.pmdx, the existing test.pmdx file is first renamed
test.bak, and then the edited document is saved under the name test.pmdx.
(This option is identical to the Create backup files option in previous versions of SoftMaker Office.)
¡ Advanced backup
With this option, multiple generations of backup copies are kept for each document. All of these copies are
stored in a special Backup folder.
Tip: When this option is selected, also the File > Revert to previous version menu command becomes
available. It provides a comfortable means of returning to a previous version of the current document (see
below).
Additional options:
Folder for backup files: Here you can change the location of the Backup folder in which all backup copies
are stored.
Number of backup files per document: Here you can specify the maximum number of backup copies (=
generations) to be kept for each document.
"Clean Up" button: Offers the following two commands for deleting backup copies:
Delete orphaned backup files: Removes any backup file that has lost its original file (for example,
because the original file has been deleted).
Delete all backup files: Removes all backup files that reside in the folder for backup files.
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How to use the "File > Return to previous version" command
When you have the selected the Advanced Backup option (see above), all backup copies are stored in a special
Backup folder. This folder is maintained automatically by the application. It is not recommended to move or
rename the files in this folder manually.
To restore a previous version of a document, you don't have to worry about this folder anyway. PlanMaker has
a special menu command for this: the menu command File > Revert to previous version.
You can use this command to revert to a previous version of a document as follows:
1.

Open the document of interest (in case it isn't opened already).

2.

Invoke the menu command File > Revert to previous version.

3.

A dialog opens, listing all backup copies available for the current document along with their creation date.
Select the version that you want to revert to.
Hint: The Preview button opens a preview of the selected version.

4.

Click on Restore to revert the document in the current window to the selected previous version.
Note: Please note that this action will replace the current document with a previous version. Accordingly,
when you save it now, its current version is overwritten by an older version!
Alternatively, a button named Open as Copy is available. When you click this button, the backup copy will
open in a new window instead (rather than replacing the document in the current window). This is useful
when you want to compare the current version with an older version.

But what to do when the original file is no longer available?
The procedure described above only works as long as the original document is still available. But what to do
when the original file has been lost, for example, because it was accidentally deleted?
Even in that case you can still access the backup copies of this document (unless they have been deleted as
well, naturally). Simply open the backup copy itself.
To find out where the backup copies are located, have a look at the dialog of the Tools > Options menu
command. The folder is listed as the Folder for backup files on the Files tab. By default, a folder named
Backup is used, located in the SoftMaker folder in your documents folder.
The backup copies in this folder can be opened in PlanMaker directly, using e.g. the following procedure:
1.

In Windows Explorer, navigate to the Backup folder (location: see above).

2.

Browse this folder for file names that start with the name of the original document. For example, a backup
copy of the file Test.pmdx might be called Test.pmdx.135.pmbak. (As you can see, a running number
and the extension .pmbak are added to the original file's name.)
Hint: The higher the number, the more recent the version of the backup copy is.

3.

In Windows Explorer, double-click on the backup file that you want to open.

4.

PlanMaker detects that you are trying to open a backup copy and asks you how to proceed. It displays a
dialog with the following options:
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Open the backup file: Opens the backup copy.
Invoke the version manager: Invokes the menu command File > Revert to previous version that displays a
dialog with all available previous versions of the original document. For more details on this command, see
above.
Open the original file: Opens the original file for this backup copy. (Of course this only works as long as the
original file still exists.)
5.

Make your choice, and then click on OK.

Once again, please note that PlanMaker creates and manages the files in the Backup folder automatically. It is
not recommended to e.g. manually rename or move files in this folder.
In case you want to clean up your drive to gain more space, you can always delete the files in this folder.
However, you will of course loose all backup files for all your documents by doing that.
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Outliner
The Outliner allows you to create an outline for a worksheet. In outlined worksheets, you can easily decide
whether just the summarized data should be displayed, or the detail data should appear as well.
The process of creating an outline is about grouping consecutive cell rows that contain related detail data. For
example, if a table contains sales figures for the last few years, with the monthly sales listed below each year,
group each list of monthly figures. After that, you can hide/unhide (or, collapse/expand) the monthly sales for
each year with a single mouse click.
Outlines can contain various outline levels, allowing you to nest the data to be displayed as desired.

Using the Outline pane
In worksheets containing an outline, a pane named Outline pane is displayed to the left of the document
window.

Use the Outline pane to hide/unhide grouped cells:

Outliner
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and Minus

signs to hide/unhide groups of cells.

¡ Click the
buttons on top of the Outline pane to determine which outline levels to display. For
example, if you click the "2" button, all cells with an outline level between 1 and 2 will be displayed.
Note: Worksheets can be outlined by row, or by column. In a column outline, columns are grouped instead of
rows, and the Outline pane is displayed above the table instead of to the left of the table.

Using the Outline toolbar
In addition to the Outline pane, a toolbar called the Outline toolbar is displayed in every document that contains
an outline.

This toolbar provides icons for creating and modifying the outline of the document. From left to right:
¡ Show/hide Outline pane (only available in documents containing an outline)
¡ Group the selected cells
¡ Ungroup the selected cells
¡ Clear outline of the selected cells
¡ Show details (equivalent to clicking on the Plus icon in the Outline pane)
¡ Hide details (equivalent to clicking on the Minus icon in the Outline pane)
For more information on working with outlines, read the following pages.

Grouping cells
To create an outline, group the rows (or columns) containing detail data. After that, you can hide/unhide such
groups with a single click.
To group cells:
1.

Select the rows (or columns) to be grouped.

2.

Choose the menu command Worksheet > Outliner > Group.
Alternatively, click the

icon in the Outline toolbar.

The cells are now grouped.
Note: Ungrouped cells have an outline level of 1. When you group cells, their outline level is set to 2. You can
even group a subset of cells within a group of cells, thereby increasing the outline level to 3, etc. Outlines can
contain up to 8 outline levels.
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Ungrouping grouped cells
To ungroup grouped cells:
1.

Select the rows (or columns) to be ungrouped.

2.

Choose the menu command Worksheet > Outliner > Ungroup.
Alternatively, click the

icon in the Outline toolbar.

The cells are now ungrouped. To be precise, their outline level is reduced by 1. This means, that if you ungroup
cells with an outline level of 3, they will not be completely ungrouped, but their outline level will be reduced to
2.

Completely removing the outline of grouped cells
To completely remove the outline of cells:
1.

Select the rows (or columns) whose outline you want to remove. Note: If you do not select any cells, the
outline of the entire worksheet will be removed.

2.

Choose the menu command Worksheet > Outliner > Clear outline.
Alternatively, click the

icon in the Outline toolbar.

The outline is removed; all cells now have outline level 1.

Showing/hiding grouped cells
After creating an outline for a worksheet (as described in the previous section), you can hide/unhide detail data
(i.e., grouped cells) as desired.
To hide/unhide grouped cells, use the Outline pane displayed to the left of (or above) the worksheet. If the
Outline pane is not displayed, verify that the Worksheet > Outliner > Automatically show outline pane
menu command is activated.
To hide/unhide grouped cells:
¡ If a bar with a minus sign
¡ A plus sign

is displayed, the cells are grouped. To hide them, click the minus sign.

indicates grouped cells that are currently hidden. To unhide them, click the plus sign.

¡ The
buttons on top of the Outline pane allow you to determine which outline levels to display. For
example, if you click the "2" button, all cells with an outline level between 1 and 2 will be displayed.
Note: When you hide cells, the cells are not only hidden on the screen, but also ignored by charts evaluating
these cells.
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Outliner options
The Worksheet > Outliner > Options menu command allows you to modify options related to the outline of
the current worksheet:
¡ Title below group rows
Check this option if the cell groups have a title (a row containing, for example, a heading or summary)
below the data rather than above the data.
This option only affects the placement of the minus sign displayed in the Outline pane. If enabled, the minus
sign will be displayed below the cells; if disabled, it will be displayed above the cells.
¡ Title right of the group columns
Similar to above, except this option only affects worksheets with a column outline. If enabled, the minus
sign will be displayed to the right of the cells; if disabled, it will be displayed to the left of the cells.
¡ Automatically show Outline pane
If this option is enabled, the Outline pane will be displayed automatically if the worksheet contains grouped
cells. If disabled, the Outline pane will not be displayed.
Hint: This option can also be toggled using the Worksheet > Outliner > Automatically show outline
pane menu command.
¡ Protect outline
If this option is enabled, the outline will be protected if sheet protection is activated for the worksheet (see
also section Sheet protection).
The current state of the outline will then be frozen. Users will not be able to group/ungroup cells or
hide/unhide grouped cells.
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Internet functions
This chapter introduces some of PlanMaker's Internet functions:
¡ Working with links
You can create hyperlinks in PlanMaker documents (e.g., to an Internet address or to another PlanMaker
document).
¡ Saving HTML documents
You can save documents in HTML format using the File > Save as menu command.
See the following pages for detailed information.

Working with links
You can put hyperlinks in your PlanMaker documents and then follow them by clicking with the mouse.
For example, you can place a link to a web page in a document. When the user clicks on it, the web browser
starts automatically and presents the page.

Creating a link
To create a link, proceed as follows:
1.

Select the text that is to be made into a link.

2.

Invoke the menu command Format > Link.

3.

Enter the target of the link in the URL or file name box; that is, enter the path and name of the internet
resource or file to which the selected text is to refer.
Links to web pages must be entered as "http://" followed by the address of the page – for example,
"http://www.example.com/index.htm".

4.

Below, in the Bookmark field, you can specify, if desired, a position in the target document to be opened
(see below). However, this field is normally left empty.

5.

Confirm with OK.

The link is now created. You recognize this by a change in the color of the text, which indicates the presence of
a link.
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Hint: Alternatively, hyperlinks can also be added using the HYPERLINK function (which is much more
flexible)

Jumping to specific bookmarks or cell references
Using hyperlinks, you can not only specify the target URL or file name, but also specify a bookmark (for
HTML documents) or cell reference (for PlanMaker documents) for the link to jump to.
For example: If you set URL or file name to "Sales.pmdx" and under Jump target enter "D42", the link will
open the file Sales.pmdx and jump to cell D42.

Using placeholders in links
Hint: In hyperlinks, you can use an asterisk (*) as a placeholder for the cell content.
For example: In an empty cell, choose Format > Link and enter http://* in the URL or file name box. After
that, if you enter e.g. www.example.com in that cell, the link will point to the internet address
http://www.example.com.
This also works with other protocols – for example mailto:* can be used to create a link to the e-mail address in
a cell.

Following links
To follow a link, position the text cursor at any character within the link text. Then invoke the menu command
Edit > Go to link. PlanMaker responds by opening the linked document.
Tip: You can also follow links by clicking on the link text with the mouse.

Editing or removing a link
To edit an existing hyperlink, first select the link text. Then invoke the menu command Format > Link. A
dialog box like the one described above then appears. Here you can edit the target of the link.
To remove a link, proceed as follows:
¡ Removing a link by deleting the link text
When you delete text that has been formatted as a link, the link is removed with the text.
¡ Removing only the link
If you want to remove only the link and leave the text in place, select the text and invoke the menu command
Format > Remove link.
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Saving HTML documents
To save the current document in HTML format, proceed as follows:
1.

Invoke the menu command File > Save as.

2.

Choose the HTML format from the Save as Type list.

3.

Enter the filename under which the file is to be saved and confirm with OK.

The document is now saved in HTML format. All formatting not supported in HTML format is automatically
removed.
Tip: After saving the document, open it with your web browser to check its appearance.
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Outputting documents
In this chapter, you will find detailed information about outputting documents (printing, e-mailing, etc.).
The following topics are covered:
¡ Print preview
The first section covers the use of the File > Print preview menu command which displays a preview of the
printed document on the screen.
¡ Printing
The next section introduces the File > Print menu command which actually prints a document.
¡ Exporting to a PDF file
Using the File > Export as PDF menu command, you can export a document to a PDF file. Such files can
be viewed on virtually any computer, provided that it has a PDF viewer installed.
¡ Sending a document by e-mail
When you would like to send a document by e-mail, you can use the menu command File > Send.
Detailed explanations are presented in the following pages.

Print preview
The print preview displays a preview of the printed document on the screen. Using this feature can help you
avoid wasting paper on test prints.
To open the print preview, choose the File > Print preview menu command.
To close it, click on the Close button or press the Esc key.

Using the print preview toolbar
The print preview window provides a toolbar with the following controls (from left to right):

Use these controls to jump from page to page.
The first/last button jumps to the first/last page.
The buttons labeled with a left/right arrow jump to the previous/next page.
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The edit field in the middle lets you jump to a specific page. Type in the desired page number and press the
Enter ¿ key.

The next three buttons have the following functions:
¡ The left button invokes the File > Page setup menu command to modify the page format (paper size,
orientation, margins, headers and footers, etc.). See also section Page format.
¡ The middle button invokes the File > Print menu command which prints the document. See also section
Printing.
¡ The right button invokes the File > Export as PDF file menu command which generates a PDF file from the
document. See also section Exporting to a PDF file.

These controls can be used to change the zoom level. Either type in a zoom level in the Zoom box and press the
Enter ¿ key, or click the arrows to gradually decrease/increase the zoom level.
The three buttons at the right let you switch to a predefined zoom level:
¡ Actual document size (zoom level 100%)
¡ Fit page in window
¡ Fit margins in window
To close the print preview window, click the Close button.

Printing
To print the current document, choose the menu command File > Print.
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A dialog box appears, allowing you to make the following settings:

Printer
Lets you choose the desired printer.
The Setup button opens a window with options to set up and configure the connected printer(s).
Linux users can also specify the command to be used for printing here.

Print
Lets you choose which parts of the document to print:
¡ Whole document
Print the entire document (all worksheets).
¡ Only selected cells
Print only those cells that are currently selected on the current worksheet.
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¡ Current worksheet
Print only the current worksheet.
¡ Only selected worksheets
Print only those worksheets that are currently selected in the worksheet register.
¡ Only the following worksheets
Print only the selected worksheets. To specify which sheets to print, check the desired worksheets in the list
displayed below this option.

Ignore print range
When you activate this option, any print ranges defined in the document will be ignored.
Background information: You can define a print range for each worksheet in a document. When a print range is
defined, only the cells inside this cell range will appear in printouts. The rest of the sheet will be omitted.
You can temporarily disable this feature anytime by activating this option.
More information on print ranges can be found in the section Additional page setup options.

Pages
Lets you choose which pages to print:
¡ All
Print all pages.
¡ Pages:
Print only the specified pages. Enter the desired page number(s) in the input box. For example:
12

Prints page 12 only

12-15

Prints pages 12 to 15

12-

Print page 12 and all pages following

-12

Print pages 1 through 12

You can enter as many page ranges as you like provided you separate them with commas, for example:
2-5, 12

Prints pages 2 through 5 and page 12

¡ In addition, you can specify with the Pages to print option, whether all pages or only the odd or even
numbered pages in the given range are to be printed.
¡ Furthermore, the Pages per sheet option allows you to print more than just one page on each sheet of paper.
For example, when you select Four Pages, each sheet of the printout will contain four pages (scaled down
accordingly).
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Options
This part of the dialog contains additional printing options:
¡ Copies
Here you can specify the number of copies of the document to be printed.
¡ Collate copies
When you print multiple copies of a document, this option determines if the printout will be sorted after
page numbers.
If you check this option and print multiple copies of a document with e.g. three pages, the pages will be
output in the following order: 1-2-3, 1-2-3, 1-2-3, ...
If it is not checked, the order will be: 1-1-1..., 2-2-2..., 3-3-3...
Note: Not all printers support this feature.
¡ Print to file
Redirects the print output to a file instead of a physical printer.
¡ Drop pictures
Skips over all pictures and drawings when printing (useful for fast test printing).
¡ Reverse order
Prints the pages from last to first.
To start printing, click OK.
Hint: Before actually printing a document, you can preview the printout using the File > Print preview
menu command.

Exporting to a PDF file
You can export documents to a PDF file.
PDF files can be viewed on virtually any computer, provided that it has a PDF viewer installed (for example,
the "Adobe Reader"). Text formatting and objects (pictures, drawings, etc.) are retained exactly as in the
original file.
To export a document to a PDF file, proceed as follows:
1.

Choose the File > Export as PDF menu command.

2.

A dialog window appears where you can change the settings described below. After that, confirm with OK.
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Another dialog window appears where you can specify the filename and location of the PDF file to create.
After that, confirm with OK.

The PDF file will then be created. To view it, open the PDF file in a PDF viewer of your choice.
Hint: If your device does not have a PDF viewer installed, you can find suitable programs in the Internet by
performing a search for "PDF viewer" in your web browser.
The dialog mentioned above provides the following options:

General tab
On this tab, you can specify which parts of the document to export, and change several other settings. The
options available are mostly identical to the ones provided in the dialog of the File > Print menu command,
which is described in the section Printing.
Apart from that, the following additional options are available:
¡ Create a bookmark for each worksheet
If this option is checked, PlanMaker will store a bookmark in the PDF file for each worksheet that your
document contains.
Your PDF viewer will then display these bookmarks in a pane left of the document. You can utilize this
pane as an interactive table of contents: just click on a bookmark to jump to the corresponding worksheet.
Hint: If your PDF viewer does not display a bookmark pane, search for a command to display bookmarks
and activate it.
¡ Create tagged PDF
If this option is checked, information about the logical structure of the document will be included in the PDF
file.
This information is required in order to produce barrier-free PDF files that, for example, can also be used
with screen readers or PDF viewers that are able to read the text in a PDF out loud.

Preferences tab
This tab contains options for modifying the output quality, including the following:
¡ AutoShape options
Sets the quality (resolution) in which AutoShapes and all other types of drawings are exported. The higher
the setting, the larger the resulting file will be.
¡ Image options
Lets you choose if images should be stored using a lossless compression method or the (lossy) JPEG
compression method. If you choose the latter option, the JPEG quality option becomes available and lets
you modify the quality level of the compression.
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Hint: Lossless compression provides perfect image quality. However, if your document contains a large
number of images (especially photographs), the resulting file can become rather large. If this is the case,
you may want to switch to JPEG compression, which provides a much higher compression rate for
photographic images.
The option Use alpha channel for transparencies determines whether an "alpha channel" should be used
when rendering transparencies in images or drawings. Usually, these look best when this option is enabled.
However, some PDF viewers are unable to render alpha channels flawlessly, so we included an option to
deactivate this feature.
¡ Other options
Include PlanMaker document: Stores a copy of your PlanMaker document inside the PDF file. This
enables users to open the resulting PDF file directly in PlanMaker. The program will then extract the
original PlanMaker document from the PDF file and display it.
Open file in PDF viewer after exporting: Launches your PDF viewer and displays the PDF file after it has
been exported (provided that you have a PDF viewer installed on your computer).
Use relative paths for file links: Automatically converts any hyperlink to a file into a relative path (instead
of an absolute path). For example, when you have inserted a link to the file c:\Documents\Lists\test.txt and
export the PDF document to the folder c:\Documents, the file path for this link will be changed to
"Lists\text.txt".
¡ Font options
The Font embedding options let you choose if the fonts used in the document should be included in the
PDF file.
If font embedding is enabled, the resulting PDF file can be viewed in its original fonts on any computer –
even if this computer does not have the fonts installed. If it is disabled, text will be rendered using some
replacement fonts selected automatically by the system.
If the Embed only used characters option is enabled, only those characters of a font will be embedded that
actually occur in the document. Advantage: The resulting PDF file is smaller in size.

View tab
This tab contains advanced options for the display of the PDF file in a PDF viewer, including the following:
¡ Navigation pane
Use this option to specify what to display in the navigation pane of the PDF viewer. (The navigation pane is
a panel displayed left of the PDF document.)
Options available:
Default: Use the PDF viewer's default setting.
Empty: Do not display anything in the navigation pane.
Bookmarks: Display the document's bookmarks in the navigation pane.
Page thumbnails: Display miniatures of the document's pages in the navigation pane.

Outputting documents

330

¡ Zoom
Use this option to set the default zoom level of the PDF file, as follows:
Default: Use the PDF viewer's default setting.
Full page: Select the zoom level at which the entire page fits in the window.
Fit width: Select the zoom level at which the page width fits in the window.
Fit height: Select the zoom level at which the page height fits in the window.
Custom: Set the zoom level to a custom value (in percent).
¡ Page layout
Use this option to specify the page layout to display, as follows:
Default: Use the PDF viewer's default setting.
Single pages: Display as single pages.
Two pages - odd pages left: Display as two facing pages (odd pages on the left).
Two pages - odd pages right: Display as two facing pages (odd pages on the right).
¡ Additional options
This section provides the following additional options:
Display document title: Display the document's title in the title bar of the PDF viewer (instead of its file
name). Hint: You can change the title of a document on the Summary tab in the dialog of the File >
Properties menu command.
Center viewer on screen: Automatically center the program window of the PDF viewer on the screen when
the PDF file is opened.
Full-screen mode: Automatically switch the PDF viewer to full-screen mode when the PDF file is opened.
Hide menu bar: Hide the menu bar of the PDF viewer.
Hide toolbars: Hide all toolbars of the PDF viewer.
Hide navigation pane controls: Hide all controls of the navigation pane.

Security tab
This tab provides options that allow you to encrypt the resulting PDF file and to set up passwords that protect
the file against opening or changing it.
¡ Encryption type
Here you can select if the PDF file should be encrypted. You can choose between 40 bit encryption (low
level of security) and 128 bit encryption (high level of security).
Note: The other options on this tab are not available until you have chosen an encryption method.
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¡ Password to open the document
If you enter a password here, the PDF viewer will ask for this password when users try to open the PDF file.
If they don't enter the correct password, the viewer will refuse to display the file.
If you leave this field empty, any user can open the file without having to enter a password.
¡ Password to set permissions
Additionally, you can restrict the access rights for the PDF file. To do this, first enter a password required to
change the access rights. Then, use the options in the Permission section of the dialog to specify which
permissions should be granted.
Background information: In some PDF viewers, a command for changing the access rights is available. If
users try to invoke this command, they will be asked for the password you have entered here.
¡ Permissions
Here you can specify which types of actions should be permitted. Only available when you have specified a
password to set permissions (see above).

Sending a document by e-mail
Provided an appropriate e-mail program is installed on your device, you can send documents by e-mail directly
from PlanMaker.
To do this, proceed as follows:
1.

Create or open the document that is to be e-mailed.

2.

Invoke the menu command File > Send.

3.

Select the format in which the document is to be sent.
Note: If you choose the PlanMaker document format, the recipient receives an e-mail with the PlanMaker document as an attachment. In order to
read the attachment, the recipient needs to have PlanMaker installed.

Your default e-mail application is invoked and a blank e-mail message is generated, with the document as an
attachment. You can specify the recipients and type in a subject and message, if desired, and then send the email.
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Protecting cells and documents
PlanMaker provides options for protecting documents or specific document contents. For example, cells can be
protected from unintentional changes, or entire documents can be password-protected.
The following options are available:
¡ Sheet protection
Use sheet protection to protect individual cells against changes, and/or to hide their content on screen or in
printouts.
¡ Workbook protection
Use workbook protection to prevent users from adding, deleting, or hiding/unhiding worksheets.
¡ Document protection
Use document protection to password-protect the current document against reading and/or writing. Note: If
read protection is enabled, PlanMaker will additionally encrypt the document.
See the following pages for detailed information.

Sheet protection
Use sheet protection to protect individual cells against changes, and/or to hide their content on screen or in
printouts.
Protecting cells requires two steps:
¡ Step 1: Setting up protection settings for cells
¡ Step 2: Activating sheet protection
See the following pages for detailed information.

Step 1: Setting up protection settings for cells
To protect cells, first determine which cells to protect by changing the cells' protection settings:
1.

Select the cells whose protection settings you want to modify.

2.

Choose the menu command Format > Cell.
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3.

Switch to the Protection tab.

4.

Choose the desired protection settings (see below).

5.

Click OK to confirm.
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Protection settings available:
¡ Protect cell
Protect cell against changes, if sheet protection is activated.
Use this option to prevent users from changing the content or the format of the cell.
Important: By default, this option is enabled for all cells in the worksheet. To allow users to alter specific
cells when sheet protection is activated, select those cells, and disable the Protect cell option.
¡ Hide formula
Do not display the formula used to calculate the cell content, but only show the result, if sheet protection is
activated.
¡ Hide cell
Hide the cell content on screen, if sheet protection is activated.
¡ Do not print cell
Hide the cell content in printouts, if sheet protection is activated.

Step 2: Activating sheet protection
After having specified the protection settings for cells (as described in Step 1 "Setting up protection settings for
cells"), activate sheet protection to enable settings.
Note: Activating sheet protection affects the current worksheet only.
To activate sheet protection:
1.

Choose the menu command Tools > Sheet protection.

2.

If desired, enter a password required to deactivate sheet protection. Leave blank if you do not want to assign
a password.

3.

Click OK to confirm.

Sheet protection is now activated.
After that, only cells not flagged with the Protect cell option can be modified. Note: These cells are displayed
with a green triangle in their lower right corner.
Hint: If sheet protection is active, you can use the Tab key to jump from one editable cell to the next.
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In addition, if sheet protection is activated, the following restrictions apply:
¡ Most menu commands for editing the worksheet are unavailable.
¡ Size, position and all other properties of objects cannot be changed anymore (except for objects where you
have deactivated the Locked property)
¡ Text in text frames cannot be changed anymore (except for objects where you have deactivated the Text
locked property)
¡ New objects can no longer be inserted into the worksheet.

Deactivating sheet protection
To deactivate sheet protection, choose the menu command Tools > Disable sheet protection.
Once deactivated, all cells will be editable and displayable again, no matter what protection settings they have.
Hint: The current state of sheet protection is saved within the document. If a password has been assigned,
users will be required to enter the password to disable sheet protection.

Workbook protection
If you activate workbook protectionfor a document, PlanMaker disables the Worksheet > Worksheet menu
command as well as the context menu of the worksheet register.
As a result:
¡ Users can't add worksheets anymore.
¡ Users can't copy, delete, or rename worksheets anymore.
¡ Users can't hide/unhide worksheets anymore.
To activate workbook protection, choose the menu command Tools > Workbook protection. To turn if off,
invoke the same command once more.
See the following pages for more information.

Activating workbook protection
To activate workbook protection for the current document:
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1.

Choose the menu command Tools > Workbook protection.

2.

If desired, enter a password required to deactivate workbook protection. Leave blank if you do not want to
assign a password.

3.

Click OK to confirm.

Workbook protection is now activated. Users are no longer able to add, delete, rename, or hide/unhide
worksheets etc.
In addition, most of the options in the dialog of the File > Properties menu command unavailable.

Deactivating workbook protection
To deactivate workbook protection for the current document, choose the menu command Tools > Disable
workbook protection.
As a result, users will be allowed to add, delete, rename, and hide/unhide worksheets again.
Hint: The current state of workbook protection is saved within the document. And: If a password has been
assigned, users will be required to enter the password to disable workbook protection.

Document protection
You can protect your documents from being read or saved by unauthorized persons by applying document
protection – or, to be more precise, read and/or write protection – to them. For example, you can require the
entry of a password to open or save a protected document.
To protect the current document, invoke the menu command File > Properties, switch to the Protection tab
and select the kind of protection you want. Then enter whatever password you like for reading and/or writing.
The following types of protection are available:
¡ No protection
¡ Write protection (the document can be opened, but saving is only possible if the correct password is given)
¡ Read protection (the document can be opened only if the correct password is given)
¡ Protection depending on password (a combination of read and write protection)
Detailed information about enabling and disabling document protection is given on the following pages.
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Enabling document protection
You can protect your documents from being read or saved by unauthorized persons by applying document
protection – or, to be more precise, read and/or write protection – to them. For example, you can require the
entry of a password to open or save a protected document.
When a document is read protected it is also encrypted, so that it cannot be examined with the use of programs
other than PlanMaker.
To protect a document, do the following:
1.

Invoke the menu command File > Properties.

2.

Switch to the Protection tab.

3.

Select the kind of document protection desired (see below).

4.

Enter the read and/or write password (at least 4, and no more than 15 characters).
Important: If you forget a password you can no longer open, or save, the document. Therefore, it is
advisable to write down the password, paying attention to the cases of letters!

5.

Confirm with OK.

6.

A dialog appears and requires you to verify the read and/or write password by reentering it.

7.

Confirm with OK.

8.

Exit the dialog box with OK.

9.

Save the document to make the changes effective.

From now on anyone who attempts to open this document will be asked automatically for the password. If the
correct password is entered, the protection will be lifted for the duration of the edit session.
Using the above described dialog, you can select any of the following types of protection:
¡ No protection
The document is not protected. This is the default setting.
¡ Write protection
When the document is opened, the user is given the opportunity to enter the write password. The document
can be saved only when the correct write password has been entered.
If the user enters a false password, or no password at all, the document is opened write protected and cannot
be saved – not even under another name.
¡ Read protection
When the user tries to open the document, he is prompted to enter the read password. If he enters a false
password, or no password at all, the document is not opened.
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Furthermore, the document is saved in an encrypted form, so that it cannot be examined with programs other
than PlanMaker.
¡ Protection depending on password
Here, two dialogs prompting for a password appear successively when the document is opened. The fist one
asks for the read password, the second one asks for the write password.
If the user enters the read password, he is permitted to open the document but not to save it.
If he also enters the write password, he has full access. Thus, he can both read and save the document.
If he enters a false password, or nothing at all, access to the document is denied.

Encryption method: "Most compatible" or "Most secure"?
For documents with read protection or protection depending on password, you can also choose the
Encryption method to be used.
Note: This setting primarily concerns the creation of new documents. When you open an existing encrypted
document, the encryption method used in the document is determined automatically and this option is set
accordingly.
Choosing an encryption method is of importance especially for documents in Excel format (.xls and .xlsx),
since some older versions of Microsoft Office are unable to read documents using the new encryption method
("Most secure").
The following two encryption methods are available:
¡ Most compatible
When the document is saved, an old encryption method is used that can be read by all versions of Microsoft
Office. However, this method is less secure than the other method.
¡ Most secure
Here, a more modern and more secure encryption method is used. However, some older versions of
Microsoft Office may not be able to read documents encrypted with this method.
Detailed information about the currently selected encryption method is displayed at the bottom of the dialog.

Disabling document protection
When you succeed in opening a read or write protected document by entering the correct password, protection
is disabled – but only temporarily. When you close the document, protection is again "armed" and the query for
the password reappears the next time someone makes an attempt to open the document.
To disable the protection on a document permanently, do the following:
1.

Open the document.

2.

Invoke the menu command File > Properties.
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3.

Switch to the Protection tab.

4.

Select the No protection option.

5.

Confirm with OK.

6.

Save the document, so that the changes will take effect.
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Document protection is now permanently disabled.
The next time someone opens the document, no password query will interfere. All users can now open and save
it.

Working with other file formats

339

Working with other file formats
Normally, PlanMaker saves a document in its native file format, namely, the "PlanMaker document" format.
PlanMaker documents can be recognized easily by the filename extension .pmdx. When you save a document,
PlanMaker automatically appends this extension to the name you give it. For example, if you save a document
under the name "Taxes", its complete filename will be taxes.pmdx.
You can save a file in various other file formats as well, which is useful, for example, when you want to do
additional work on a document using another program. And you can also open documents in PlanMaker that
have been created with other applications.
In this chapter you will learn how to work with other file formats. It covers the following topics:
¡ Saving and opening files in other file formats
The first section describes how to save or open a document in a different file format. You simply invoke the
File > Save as menu command (or, the File > Open menu command respectively) and choose the file format
in the Save as type list.
¡ Working with text files
When you open or save plain text files, a dialog box providing additional options appears. This section
contains information on these options.
¡ Working with Excel files
The last section provides information on working with Microsoft Excel files.
See the following pages for detailed information.

Saving and opening files in other file formats
This section provides information on saving and opening documents in a different file format.

Saving a document in a different file format
To save the active document in a different file format, invoke the menu command File > Save as and open the
dropdown list Save as Type. Choose the desired format, enter a new filename if desired, and confirm by
clicking on OK.

Opening a document stored in a different file format
To open a document stored in a different file format, invoke the menu command File > Open, open the file
types list box, and select the format of the file to be opened. Then select the file and confirm with OK.
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Supported file formats
The list of available file types in Open and Save dialogs contains (among others) the following file formats:
¡ PlanMaker document
The native file format and default for PlanMaker documents. This is the format in which you will typically
save your documents (name extension: .pmdx).
¡ PlanMaker template
Document template for PlanMaker documents (name extension: .pmvx). See also section Document
templates
¡ Microsoft Excel document
You can also open and save documents in Microsoft Excel file format. Supports .xls files (Excel 5.0 through
2003) as well as .xlsx files (Excel 2007 or later).
For detailed information on this format, see section Working with Excel files.
¡ Microsoft Excel template
Template for Microsoft Excel documents.
¡ PlanMaker 2012 document
For storing documents in the file format of PlanMaker 2012, an older version of PlanMaker (name
extension: .pmd).
¡ TextMaker document (export only)
For exporting PlanMaker files to SoftMaker's word processor TextMaker.
¡ dBase
dBase database file format, either with DOS, Windows or Unicode character set. An additional dialog,
where you can choose the character set, will appear before the file is opened.
Note: Most dBase databases are stored in dBase/DOS file format rather than dBase/Windows file format –
even if they were created with a Windows application.
¡ Text file
Plain text file format, for example, with the cell values separated by tabs or commas. For detailed
information, see the section Working with text files.

Working with text files
As described in the previous section, you can also open and save plain text files (including e.g. CSV files) with
PlanMaker:
¡ To open a text file, invoke the menu command File > Open, select the desired text file, and click on Open.
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¡ To save a document as a text file, invoke the menu command File > Save as, open the Files of type list, and
choose the entry Text file. Then, enter a file name and confirm with Save.
In both cases, a dialog where you can specify the format of the text file appears.
The dialog provides the following options:

Options available when saving text files
When you save a document as a text file, the following settings can be made in the dialog:
¡ Character set
Here you can specify which character set to use when the text file is saved.
Note: PlanMaker automatically suggests a suitable character set. Usually, there is no need to change this
setting.
¡ Data format
Here you can specify in which way the cell contents should be stored in the text file. The following two
options are available:
Separators between fields: If you choose this option, the cell contents will be separated by a certain
character (for example, a semicolon or a tab).
Example:
Peter;Miller;24;Main Street
Elizabeth;Jones-Nightingdale;1733;University Drive

Fixed field widths: If you choose this option, the cell contents will be distributed over columns with a fixed
width. Gaps will be filled with spaces.
Example:
Peter
Elizabeth

Miller
Jones-Nightingdale

24
1733

Main Street
University Drive

¡ Separator
Here you can choose which character should be used to separate the individual cell contents from each other
(e.g., semicolons or tabs).
Note: The character used as a separator should not occur within cell contents. Otherwise, PlanMaker
would split such cells into two entries.
¡ Text marker
If desired, PlanMaker can surround the content of all cells that contain text with a certain character (e.g.
quotation marks).
If you want this, choose the desired character here.
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¡ Encoding of newlines
Here you can specify the control characters that are added at the end of lines (in order to indicate the
beginning of a new line).
Note: PlanMaker suggests suitable control characters automatically. Usually, there is no need to change this
setting.
Available options:
CR+LF: This is the recommended setting for Windows.
LF: This is the recommended setting for Linux and Mac.
CR: This control character used to be common on older Apple Mac systems (prior to Mac OS X).

Options available when opening text files
When you open a text file, the same options are available as for saving. Use them to specify the format of the
text file you want to open.
There's one additional option when opening files:
¡ Number of header lines
If the first few lines of your text file contain headings (or, lines with some explanatory text, etc.), enter the
number of these lines here. This will instruct PlanMaker not to split these lines into columns. They will be
left unchanged and stored into just one cell per line.
The default value is 0 (i.e., no header lines).

Working with Excel files
The following pages provide information on working with Microsoft Excel files in PlanMaker.

Opening and saving Excel files
As described in the section Saving and opening files in other file formats, PlanMaker is able to open and save
documents in Microsoft Excel format.
However, some arithmetic functions are either incompatible, or not supported by PlanMaker or Excel. This
section provides help resolving these issues:
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Warning message issued when opening an Excel file
When you open an Excel file containing arithmetic functions that are not compatible with PlanMaker, the
following warning message is displayed:

To resolve, proceed as follows:
1.

Choose the View > Syntax highlighting menu command to activate syntax highlighting.

2.

All cells containing formulas where the conversion failed will be highlighted with a colored background.
These cells must be revised individually. Compare their content with the content of the corresponding cells
in the Excel document, and replace incompatible arithmetic functions with PlanMaker functions. For
detailed descriptions of all arithmetic functions supported by PlanMaker, see section Functions from A to Z.

3.

When all cells are revised, deactivate syntax highlighting.

Save the document (in PlanMaker format) to finalize changes.

Warning message issued when saving a document in Excel format
When you save a PlanMaker document in Excel format, if the document contains formulas that are not Excelcompatible, the following warning message is displayed:

To resolve, proceed as follows:
1.

Choose the View > Syntax highlighting menu command to activate syntax highlighting.

2.

All cells containing formulas that are not Excel-compatible will be highlighted with a colored background.
These cells must be revised individually. Replace all Excel incompatible arithmetic functions with Excel
functions. For help, see function description of the affected function in this manual.
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When all cells are revised, deactivate syntax highlighting.

Save the document in Excel format again. If no further warning messages are displayed, all incompatibilities
have been eliminated.

Differences between PlanMaker and Excel
This section provides a list of the most significant differences between PlanMaker and Excel:

General
¡ PlanMaker is not able to execute macros and VBA scripts stored in Excel documents. When an Excel file is
opened that contains macros or scripts, they will be ignored. However, PlanMaker will not remove them – if
the file is saved in Excel format, the macros and scripts will remain functional.

Arithmetic functions
¡ Some of PlanMaker's arithmetic functions are not supported by Excel (and vice versa). If you open or save
a document in Excel format, a warning message will be displayed if the file contains incompatible arithmetic
functions. For more information, see section Opening and saving Excel files.
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Working with Arabic text
In this chapter, you will learn everything you need to know about editing text in Arabic script in your
documents. The following topics are covered:
¡ Activating extended support for Arabic text
¡ Changing the text direction in table cells
¡ Changing the text direction in text frames
¡ Changing the direction of worksheets
See the next pages for details.
Important: The features described in this chapter are only available when you have activated the Extended
support for Arabic text option in the program settings (see next section).

Activating extended support for Arabic text
PlanMaker includes an "Extended Support for Arabic Text" option that provides some additional features for
editing text in Arabic script.
To activate this option, proceed as follows:
1.

Invoke the Tools > Options menu command.

2.

Switch to the General tab.

3.

Activate the Extended support for Arabic text option.

Important: The features described in this chapter are only available when this option is activated.

Changing the text direction in table cells
When the Extended support for Arabic text option is enabled, you can change the text direction in any given
table cell whenever needed.
To do so, proceed as follows:
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1.

Invoke the Format > Cell menu command.

2.

Switch to the Alignment tab.

3.

Under Text direction, choose the desired option: context sensitive, left-to-right, or right-to-left.
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Tip: With the default setting Context sensitive, PlanMaker automatically chooses the appropriate text
direction: When you enter text in Arabic into a cell, the text direction is set to right-to-left, otherwise, it is set to
left-to-right.

Changing the text direction in text frames
In text frames, when the Extended support for Arabic text option is enabled, you can change the text
direction of a paragraph whenever needed.
To do so, proceed as follows:
1.

Place the text cursor in the desired paragraph within the text frame.

2.

Invoke the Format > Paragraph menu command.

3.

Switch to the Paragraph tab.

4.

Under Text direction, activate the option Right to left to change the text direction to right-to-left.
To set the text direction to left-to-right, deactivate the option.

Tip: Using the keyboard
A much quicker way to change the text direction of a paragraph in a text frame is provided with the following
keyboard shortcuts:
¡ When you press Ctrl and the left Shiftñ key simultaneously, the text direction changes to left-to-right.
¡ When you press Ctrl and the right Shiftñ key simultaneously, the text direction changes to right-to-left.
Mac/Linux: On some systems (including macOS and several Linux distributions), these keyboard shortcuts
might be not available. In this case, you can alternatively use the keyboard shortcuts Ctrl+Shift+A (for left-toright) and Ctrl+Shift+D (for right-to-left).

Changing the direction of worksheets
When the Extended support for Arabic text option is enabled, you can change the direction of a worksheet
whenever needed.
To do so, proceed as follows:

Working with Arabic text

1.

Invoke the Worksheet > Properties menu command in the desired worksheet.

2.

Under Text direction, activate the option Right to left to change the direction to right-to-left.
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To set the direction to left-to-right, deactivate the option.
The direction of the worksheet changes accordingly.
Thus, when you change the direction of a worksheet to right-to-left, the column on the very right becomes the
first column (instead of the column at the very left).
In other words, the horizontal direction of the table is reversed – as follows:

Left: Table direction set to left-to-right
Right: Table direction set to right-to-left

Note: Of course you can still change the writing direction of each table cell individually (as described in the
section Changing the text direction in table cells).
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Scripts (BasicMaker)
Note: BasicMaker is not included in some versions of SoftMaker Office. Available only under Windows.
BasicMaker is a tool that allows you to compose and execute scripts written in the programming language
SoftMaker Basic. SoftMaker Basic is modeled after the industry standard Visual Basic for Applications (VBA)
from Microsoft.
Scripts can be used to automate tasks in the word processor TextMaker and the spreadsheet application
PlanMaker.

Invoking BasicMaker
To start BasicMaker, or to execute a BasicMaker script, use one of the following procedures:
¡ Starting BasicMaker from the Start menu
You can start BasicMaker by clicking on Start > Programs > SoftMaker Office > Utilities > BasicMaker
in the Start menu.
¡ Starting BasicMaker from within TextMaker/PlanMaker
Alternatively, you can start BasicMaker from within TextMaker or PlanMaker. From the main menu in
TextMaker/PlanMaker, choose the menu command Tools > Edit script.
¡ Running a script directly from within TextMaker/PlanMaker
To execute a script, invoke the menu command Tools > Start script in TextMaker/PlanMaker. A file dialog
appears. Choose a script, confirm with OK, and the script will be executed immediately.
For more information on BasicMaker and details on "programming" TextMaker and PlanMaker, see the
BasicMaker online documentation (which is available in BasicMaker's Help menu).
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Working with multiple documents
You can have multiple documents open at any time – to compare them, edit them at the same time, exchange
data between them, etc.
You work with multiple documents as follows:
¡ Opening multiple documents in the same program window
You can open any number of documents at the same time in the current program window.
There are many ways to switch between these documents, including a bar that contains document tabs for
each currently open document (displayed above the current document):

¡ Opening documents in a new program window
You can also open documents in a new program window. This allows you, for example, to place documents
side by side on the monitor.
To do so, switch on the option New program window in the dialog window of the menu command File >
New or File > Open when you create/open the document. (Note: This option is not available in the Android
version.)
These two methods can be combined as desired. You can open as many program windows as you like and open
any number of documents in each of these windows. Or you can open all documents in just one program
window. Or you can let the software create a separate program window for each document. Any way you like it.
In this chapter you will learn everything you need to know about working with multiple documents at the same
time. See the next pages for details.

Creating or opening a document
To create a new document, or to open a document, proceed as follows:
¡ Select the menu command File > New to create a new document.
¡ Select the menu command File > Open to open an existing document.
These two commands are described in detail in the chapter PlanMaker basics.
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"New program window" option
The option New program window in the dialog box for these two commands has the following meaning: If it
is switched on, the document will appear in a new program window. If it is switched off, the document will
appear in the existing program window with an additional tab. (Note: This option is not available in the
Android version.)

Switching between open documents
When working with multiple documents open at the same time, you have the following options for switching to
a specific document – and thus making it the active document:
¡ Menu: "Window" menu
In the Window menu you will find a list of all currently open documents. Select the entry for the document
you want to switch to.
¡ Ribbon: "Windows" icon
In the ribbon you will find an icon named Windows on the View tab, which works in a similar way: When
you click on it, a list of all open documents appears, allowing you to choose the document of interest.
¡ Mouse: Clicking on a document tab
Under the toolbars or ribbon you will find a bar containing document tabs for each currently open document.
Click on the tab for the document you want to switch to.

¡ Mouse: Clicking into the program window containing the document
If you have opened documents in more than one program window (see previous section), you can of course
also simply click into the program window containing the desired document.
¡ Keyboard: Pressing Ctrl+F6
You can also use the keyboard to switch between the currently open documents: Ctrl+F6 switches to the
next document and Ctrl+Shift+F6 switches to the previous one.
Mac: On a Mac, the key combinations Cmd+F6 and Cmd+Shift+F6 have to be used instead.

Closing a document
If you want to conclude your work on a document, you can close it at any time. You have the following options:
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¡ Menu: Choose the File > Close menu command to close the current document.
Tip: You can close all currently open documents in one step with the menu command Window > Close
all.
¡ Ribbon: The File tab contains a Close icon that closes the current document.
¡ Document tabs: Under the toolbars or ribbon, you will see a bar with document tabs for each currently open
document. When you click on one of these tabs with the middle mouse button, the corresponding document
is closed.

Alternatively, you can close a document by left-clicking on the x icon displayed on the right of its tab.
And when you right-click on a tab, a small menu appears. It contains commands for closing the current
document (Close tab) or all other open documents (Close all other tabs).
¡ Keyboard: You can also use the keyboard shortcut Ctrl+F4 or alternatively Ctrl+W to close the current
document.
Mac: On a Mac, the key combination Cmd+F4 or Cmd+W has to be used instead.
Whenever you close a document that has been modified since it was last saved, the program automatically asks
you if you want to save the document first.

Arranging documents on the screen
Android: The View side by side feature is not available in the Android version.
If you have documents open in multiple program windows, you can arrange them on the screen as follows:
¡ Of course you can move the individual program windows manually and change their size – just as it is
possible with all kinds of program windows.
¡ If you select Window > View side by side, the current program window and another (already opened)
program window are arranged next to each other on the screen. If more than two program windows are
currently open, the program first asks which other window should be used.
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Customizing PlanMaker
PlanMaker gives you control over numerous program settings, allowing you to adapt the program to your
personal working style.
This chapter covers all the details. It is divided into the following sections:
¡ Preferences
To modify PlanMaker's global preferences, use the Tools > Options menu command. These settings apply
to the program as a whole, and thus to all documents.
¡ Document properties
To modify the properties of a document, use the File > Properties menu command. These settings affect the
current document only.
¡ Worksheet properties
To modify the properties of a worksheet, use the Worksheet > Properties menu command. These settings
affect the current worksheet only.
¡ Customizing the document display
This section describes how to adjust the way a document is displayed on the screen. Most of the necessary
commands are found in the View menu.
¡ Customizing toolbars
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use "classic menus and toolbars".
You will learn here how to configure the program's toolbars (Standard toolbar, Formatting toolbar, etc.)
using the View > Toolbars menu command and how to customize the icons displayed on them using the
Tools > Customize command.
¡ Customizing the ribbon
"Ribbons" only: This section is relevant only for users who have configured the program to use the
"ribbon" interface.
You will learn here how to configure and customize the ribbon.
¡ Creating user-defined toolbar/ribbon icons
You can create user-defined icons and add them to a toolbar or to the ribbon. Such icons can be used to start
other programs of your choosing.
¡ Customizing keyboard shortcuts
The dialog box of the Tools > Customize menu command also allows you to customize the keyboard
shortcuts for commands.
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¡ Customizing AutoFill lists
To customize the lists used to automatically fill cells with the Edit > Fill command, use the Tools > Edit
lists menu command.
¡ Installing additional dictionaries
This section contains instructions on installing additional dictionaries (for example, Hunspell dictionaries).
See the following pages for detailed information.

Preferences
To modify PlanMaker's global preferences, use the Tools > Options menu command. These settings apply to
all documents.
The dialog box associated with this command contains several tabs, each of which presents options relating to a
different topic area. If you click on the Files tab, for example, you will be able to make settings that control the
opening and saving of files.
On the next pages, you will find detailed information on each of the individual options available.

Preferences, View tab
The View tab in the dialog of the Tools > Options menu command contains settings related to the display of
tables:

Markers
The options in this section allow you to modify the appearance of the little triangles that are displayed in cells
that contain a comment and cells that are protected.
¡ Color of comment markers
Here you can change the color of the little triangle that is displayed inside cells that contain a comment.
¡ Color of protection markers
Here you can change the color of the little triangle that is displayed inside cells that are not protected (when
sheet protection is enabled).
¡ Size
This option allows you to change the size of these markers.
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Snapping
Allows you to configure the available aids for positioning objects (text frames, picture frames, etc.) with your
mouse:
¡ Snap to cells
Normally, this option is disabled, meaning that you can move objects arbitrarily with your mouse.
When you enable this option and try to change the position of an object with your mouse, the object jumps
from one table cell to the next.
¡ Snap to other objects
When this option is enabled, the software automatically creates "magic" guides for the edges of each object
in the current worksheet. These guides make it a lot easier to place objects perfectly aligned or distributed.
"Magic" guides are usually invisible. They become visible only when you move an object to a position close
to any of these guides with your mouse. As soon as the guide appears, the object automatically snaps to it.
The same happens when you change the size of an object with your mouse.
Some examples for "magic" guides:
When you drag an object to a position where it is roughly left-aligned with another object, a guide will
appear representing the left edge of the other object. If you let your object snap to it, it will be exactly
left-aligned with the existing object.
The same applies for the right edge of objects.
When you drag an object to a place where it is roughly centered with another object, a guide will appear
representing the center of the object. If you let your object snap to it, it will be aligned exactly centered
with the other object.
When you drag an object to a position below two other objects, you will also see a horizontal guide at the
position where this third object would have exactly the same relative distance as the two other objects.
(The three objects would then be distributed evenly.)
All of the above works in both directions (horizontally and vertically) – for example, there are also magic
guides for the top edge and the bottom edge of each object.
¡ Snap tolerance
Here you can specify the tolerance for the Snap to other objects option described above. The higher the
value, the earlier an object that you resize/move will snap to one of the "magical" guides for existing objects.
The default value is a distance of 8 pixels.

Paint grid behind cells
When you activate this option, the gray gridlines displayed between the table cells are no longer painted in front
of the cells but behind the cells. As a result, the gridlines will no longer be visible for cell ranges that have a
colored background.
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Cell marker
Here you can change the color and line width of the cell frame (the dark frame that indicates the currently
active cell in a worksheet).

Worksheet tabs
The worksheet register at the bottom of the document window displays tabs for each worksheet in the
document.
This option allows you to change the font size used to display the worksheet name on each tab.

Preferences, General tab
The General tab in the dialog of the Tools > Options menu command contains common program settings:

Maximum number of undo steps
Here you can specify the number of actions that can be reversed with the Edit > Undo menu command. You
can increase this number up to a maximum of 999 undo operations.
Note: On devices with little main memory, it is not recommended to increase this value.

Button "User info"
Click one this button to open a dialog where you can enter your personal information such as name, address,
phone number, etc.
To insert this information in documents, use the USERFIELD function

Extended support for Asian fonts
Note: This option affects only text frames, not table cells.
When this option is enabled, in text frames, the dialog box for the Format > Character menu command
presents lists for typeface, font size, style and language under not only a single category, but under three:
¡ For Latin scripts (e.g. English)
¡ For East Asian scripts (Chinese, Japanese, and Korean)
¡ For complex scripts (e.g. Arabic)
Thus, in text frames you can specify the settings for each kind of script separately.
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For example, if you specify "Arial" as the typeface for Latin characters and "SimHei" as the typeface for Asian
characters, all the Latin characters that you type will appear in Arial, and all the Asian characters you type will
appear in SimHei.
Note: PlanMaker recognizes automatically whether given characters are part of the Latin, Asian, or complex
scripts.

Extended support for Arabic text
When you activate this option, additional features for editing text in Arabic script will become available. See
the chapter Working with Arabic text for details.

Show warning when loading OLE objects
Mac, Linux, and Android only: When this option is enabled, the program displays a warning that OLE objects
cannot be displayed when you open a document containing such objects. (OLE objects can be displayed only
under Windows.)

Preferences, Edit tab
The Edit tab in the dialog of the Tools > Options menu command contains settings related to editing cells:

Move selection after input
Determines where to move the selection after the user has entered data in a cell and pressed the Enter ¿ key.
For example, if you choose "Down", the selection will move down to the cell below the current cell.

In-cell editing
If this option is checked, cells can be edited directly in the worksheet. If it is unchecked, cells can only be
edited using the Edit toolbar (displayed above the spreadsheet).

Automatic percent input
Determines how PlanMaker reacts when you type numbers into a cell that contains a percent value or that is
formatted with the "Percent" number format. If enabled, a percent sign is automatically added to your input.

Autocomplete cells
When you enter text in a cell with this option enabled, PlanMaker automatically makes suggestions from the
existing text entries found in the cells above and below this cell.
Example: You have entered the values "New York", "Rio" and "Tokyo" into a column. If you type the letter
"N" in the cell below these entries now, the program automatically suggests "New York". If you type the letter
"T", "Tokyo" is suggested, etc.
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To accept the suggestion, press the Enter ¿ key. To reject it, simply continue typing or press the Del key.
If you do not want PlanMaker to make such suggestions while you are typing, you can always turn this option
off.

Left arrow key never exists cell editing
Use this option to specify what should happen when you navigate to a cell, type in a value and press the left
arrow key ß:
¡ On: The text cursor is moved to the left (within your input).
¡ Off: The cell frame is moved to the left. In other words, your input is accepted, and the cell left of the
current cell is made the active cell.

Warning if a formula contains errors
If you enter a formula that contains an error (e.g., missing a closing parenthesis), PlanMaker issues an error
message when you press Enter. If you do not want an error message to be displayed, uncheck this option.
Note: Independent from this option, erroneous formulas are generally replaced by the text #NULL! when you
save the document.

Formula tooltips
If this option is enabled, whenever you enter an arithmetic function in a cell, a tooltip providing information
about the required function parameters appears below the cell.

Apply character formatting to entire words
Enabling this option has the following effect:
When the text cursor is inside a word and you change the character formatting (i.e. choose a different font or
activate boldface), the entire word will be affected.
This allows you to format single words more quickly (without having to select them first).

Insert frames and drawings immediately
Here you can specify what should happen when you insert a frame or a drawing into a document (Text frame,
Picture frame, AutoShape, etc.) – for example, using the menu command Object > New text frame:
¡ Always: The corresponding object is inserted immediately. Its position and size are fixed without further
action.
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(Of course you can always change the object's position after that, by simply dragging it to a different place
with the mouse. And you can also modify its size, by dragging on one of the round handles that appear
around the object.)
¡ Never: Before the object is actually inserted, the mouse cursor changes to a cross-hair. To proceed, draw a
rectangle in the document with your mouse, in order to determine the exact position and size of the object.
After that, the object will be inserted accordingly.
¡ Auto: An intelligent combination of the two options above that is already preset in PlanMaker for each
specific object type. The AutoShape and Text frame objects are inserted directly (as with Always), all other
objects are inserted via mouse cursor control (as with Never).

Expand tables automatically
As described in the section Tables in worksheets, the menu command Worksheet > New table allows you to
create "Tables in worksheets".
This option has the following effect on such tables:
¡ On: When you enter something into one of the cells directly to the right of the table, the table is
automatically expanded by another column. The same goes with rows: When you type something directly
below the table, another row is added automatically.
¡ Off: The table is not expanded automatically.

Middle mouse button
Mac and Linux only: Here you can specify what should happen when you click somewhere using the middle
mouse button. Options available:
¡ No function: The middle mouse button doesn't have any function.
¡ Paste selected content: A click with the middle mouse button inserts the content of the selection (e. g. the
currently selected text) at the corresponding position.

Expand SmartText entries
As described in the section SmartText, you can create SmartText entries (e.g. "sd" for "sales department") with
PlanMaker.
When this option is enabled, your SmartText entries can be expanded right in the text. All you have to do is
type the abbreviation for the SmartText entry (e.g., "sd") and then press the space bar, Enter key or a
punctuation key in order to signal PlanMaker to replace the abbreviation with the content of the SmartText
entry.
If this option is disabled, SmartText entries can be called out only with the Insert > SmartText menu
command.

Use left Alt as shortcut key
Mac only: This option determines which function the left Alt key on your keyboard should have:
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¡ Off: The left Alt key does the same as the right Alt key: It inserts symbols into the text.
Alt+E, for example, gives you a Euro sign.
¡ On: The left Alt key can be used to open menus in the classic menu. (Note: This only works if you use the
program with classic menus instead of the ribbon.)
Here, Alt+E no longer returns a Euro sign, but opens the Edit menu instead.

Number separators
Here you can change which characters to use as decimal separator and as thousands separator for numbers.
¡ If you choose System default, PlanMaker determines the decimal separator and thousands separator from
your current system settings automatically. (This is the default setting.)
¡ If you switch to Custom, PlanMaker lets you to specify a custom decimal separator and thousands separator.
Warning: If you specify custom settings that are incorrect, calculations may return invalid or wrong
results!

Calculation in status bar
When you select multiple cells, their sum is automatically displayed in the status bar. To have a different
calculation displayed there, select the desired type of calculation.

Preferences, Appearance tab
The Appearance tab in the dialog of the Tools > Options menu command allows you to customize the
appearance of the program's user interface.

Dialog language
Here you can select the language to be used for the user interface (menus, dialog boxes, etc).

User interface
When you click on the User interface button, a dialog box appears in which you can select the type of user
interface that the applications in SoftMaker Office should use:
¡ Ribbon (upper row)
When you select one of the items from the top row, the programs will use a ribbon interface. The differences
between the individual entries are only in the color scheme used.
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¡ Classic menus and toolbars (lower row)
When you select one of the entries from the bottom row, the programs will use classic menus and toolbars.
Also for this, different color variants are offered.
In addition, the following settings can be made in the dialog box:
¡ Quick Access Toolbar
Ribbons only: Determines where the Quick Access Toolbar, which contains icons for some of the most
frequently used commands, should be displayed: to the left of the document tabs – or in a separate toolbar
directly below the ribbon.
¡ Touch mode
If you activate this option, all icons in the ribbon or in menus/toolbars are enlarged a bit. This is useful when
operating the software with your finger (for example, on a tablet).
Tip: In addition to this option, you can also switch touch mode on/off with the following commands:
Menu: command View > Touch mode
Quick Access Toolbar: command Touch mode
Android: If you are using the Android version, you do not have a button with a dialog box for the User
interface settings, but a dropdown list. The options Quick Access Toolbar and Touch mode (for larger icons
and menu entries) can be found separately elsewhere on this Appearance tab and have the same effect as
described above.

Show status bar in ribbon mode
Applies for ribbon mode only: Here you can enable/disable the display of the status bar. To change the display
of the status bar for the classic menu, see section Displaying and hiding toolbars.

Show fonts in font list
When this option is enabled, PlanMaker renders the names of fonts that appear in lists (such as the font list in
the Formatting toolbar) using their corresponding fonts. This lets you see at a glance how each font looks like.

Show tooltips
Lets you specify whether or not tooltips should be displayed.
Tooltips are little text boxes that are displayed next to the mouse pointer when you position the pointer over
certain screen elements, for example a button on a toolbar.

Beep on errors
When this option is enabled, a sound plays when PlanMaker displays an error or warning message.
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Live preview
Enable/disables a live preview for the dropdown lists in the Formatting toolbar.
When this option is enabled, you can e.g. select some text, open the font dropdown in the Formatting toolbar
and hover over the fonts with your mouse. While you do that, the selected text is updated "live" to give you an
impression how it would look like in the corresponding font.
To actually apply the font, simply click on it. To discard the change, click anywhere outside the list or press the
Esc key.

Use system menus
Mac only: This option determines whether or not the program should display its main menu in the menu bar at
the very top of the screen (as is customary for Mac applications).
Depending on the type of user interface you have chosen ("Ribbon" or "Classic menus and toolbars"), this
option has the following effect:
¡ Off: The main menu is not displayed in the menu bar at the top of the screen.
Details:
Classic menus and toolbars: With the classic user interface, the main menu is no longer displayed at the
top of the screen, but in its own bar (below the title bar).
Ribbon: If you have chosen the "Ribbon" user interface, only the "hamburger menu button" (i.e. the
icon in the Quick Access Bar) is available to you if you want to access the classic main menu.
¡ On: The main menu is displayed in the menu bar at the top of the screen.
Details:
Classic menus and toolbars: The main menu is now displayed in the menu bar at the top of the screen,
not in its own bar below the title bar.
Ribbon: Ribbon users now have access not only to the Ribbon user interface but can additionally use the
classic menu in the menu bar whenever desired.

Use system file dialogs
Windows, Mac, and Linux only: This option controls the type of dialogs that appear when commands to open
and save files are issued. The options are:
¡ Off: PlanMaker uses its own file dialogs.
¡ On: PlanMaker uses the file dialogs provided by the operating system.
The former are easier to use; the latter offer more options.
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Smooth edges of screen fonts
When this option is enabled, PlanMaker uses a technology called "anti-aliasing" to smooth the edges of fonts
and improve their appearance on the screen.
The options available vary according to the operating system.

Workspace color
This option allows you to change the background color of document windows.

User interface size
Mac, Linux, and Android only: This button opens a dialog where you can decrease or increase the scaling of
the application's user interface (menu, toolbars, dialogs, etc.).
Choosing a smaller setting will scale all user interface elements down, allowing you to can see more elements at
a time. A larger setting, on the other hand, increases the legibility.
While the Controls size option changes the scaling in large steps, the Font size adjustment option can be used
to perform some fine-tuning in smaller steps.
The Sample field is there to help you find a decent setting: It gives you a preview of how a checkbox in a
dialog will look like when you apply your changes.
Note: With inappropriate settings, the user interface might become far too small or too large, especially on
devices with a rather low resolution. In case this happens, you can always click on the Reset to default
button in the lower left of this dialog to return to the original settings.

Document scaling (DPI)
Mac, Linux, and Android only: You can scale the document higher or lower for a larger/smaller view. To do
this, select Custom and enter the preferred value.

Measurement
Mac, Linux, and Android only: Here you can specify the units of measure PlanMaker should use by default:
Metric (centimeter) or U.S. (inch).
(Under Windows, this option is not necessary, since the program automatically uses the setting chosen in the
"Regional and Language" options of Windows' Control Panel.)
Tip: You can always override this setting and enter a value into a dialog field in another unit of measure by
typing one of the following unit abbreviations after the value:
Unit

Explanation

cm

centimeter
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inch – 1 in equals 2.54 cm.

pt

point – 72 pt equals 1 in.

pi

Pica (for characters)
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For example if you typed "5.08 cm" for the left margin, PlanMaker would set the margin to 5.08 cm (= 2 in).

Use ribbon animations
Android only: The sections of the ribbon tabs can be expanded and collapsed when you tap them with your
finger (only in ribbon mode). If you enable this option, expanding and collapsing will be performed in animated
mode.

Preferences, Language tab
The Language tab in the dialog of the Tools > Options menu command contains settings that are related to the
program's language tools (spell checker, hyphenator, etc.).

Language
Here you can select the language to be used for spell checking and hyphenation. To choose your setting, open
the dropdown list and select the desired language from the available options.

Spell-checking
In this section you can configure the spell-checker. Settings available:
¡ Check spelling as you type
If you activate this option, PlanMaker will check the spelling of text as you type. As soon as you make a
mistake, a dialog box will appear to facilitate a correction. See section Spell checking as you type.
Note: When this option is turned off, you can still check the spelling in a document using the manual spellchecker. To launch it, use the Tools > Check spelling menu command. See section Manual spell checking.
¡ Beep on errors: When this option is enabled, PlanMaker issues a warning tone when it encounters an
unknown word while checking spelling as you type.
¡ Ignore words that start with a number
Check this option if you would like the spell checker to ignore all words that start with a number (for
example, "42nd").
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¡ Hunspell dictionaries
As an alternative to its own dictionaries, SoftMaker Office also supports the use of Hunspell dictionaries.
These dictionaries are available as free downloads. Most of them were created by private users or non-profit
organizations.
The Hunspell dictionaries button allows you to a) install Hunspell dictionaries that you have downloaded
and b) specify which languages should use a Hunspell dictionary.
For details, see section Installing additional dictionaries.

Preferences, Files tab
The Files tab in the dialog of the Tools > Options menu command contains settings related to opening and
saving files:

Template folder
Here you can specify the folder in which the templates for PlanMaker documents are stored. The dialog that
appears when you invoke the menu command File > New presents templates for your selection that are found in
this folder.
Note: Normally, this setting should not be changed. Change it only in the event that you have actually moved
the template folder to another place.

Default file format
Here you can select the file format that PlanMaker will use by default to save newly created documents.
The available choices include PlanMaker's own file format and the Microsoft Excel file format in several
versions.
Important: The Excel format is not able to accommodate features specific to PlanMaker. If you save a
PlanMaker document in Excel format, certain formatting options and other features could be lost.
Accordingly, it is recommended to use the default setting "PlanMaker".

Saving group box
Here you can make settings related to saving documents:
¡ Create backup files
Android only: If this option is enabled, whenever you save a document, the application will first create a
backup copy of the last saved version in a file with the name extension .bak.
(In SoftMaker Office for Windows, Mac, and Linux, more advanced options are available for backup copies
– see section Backup below.)
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¡ Prompt for summary information when saving
When you enable this option, a dialog box will appear automatically the first time you save a new document
to enable you to enter some additional information about it (for more information, see the section Document
summary).
¡ Auto recovery: Save state every ... minutes
When this option is enabled, PlanMaker automatically makes a temporary backup copy of every open
document on a periodic basis. You can enter a period of 1 to 100 minutes.
Note: These temporary backup copies are totally independent of the regular backup copies that you can set
up in the Backup section on this tab (see below).
When you exit PlanMaker in the normal manner, these temporary backup copies are automatically deleted.
However, if PlanMaker is abruptly shut down by a power failure, for example, while you are working on
open documents, these copies become available when the program is restarted. PlanMaker recognizes that
there has been a failure and offers to open the backup copies of all the documents that had been modified but
not saved just prior to the failure.
You can then check each of the restored documents to determine if any of the most recently made changes
have actually been lost, and then save them.

Opening group box
Here you can make settings that affect the way documents are opened:
¡ Recently used files
PlanMaker displays a list of the files most recently opened in it in the File menu. If you select an item on the
list, the corresponding file will be opened immediately. Using the Recently used files option you can
specify the number of files to be displayed in the list.

Backup group box
Note: This feature is not available in the Android version. On Android, only an option for simple (single)
backups is available: the option Create backup files (described above).
Here you can specify if the program should, whenever you save a document, automatically create a backup
copy containing its previous version.
The dropdown list in this section offers the following options:
¡ No backup
When you choose this option, no backup copy is created when you save a document. (Not recommended.)
¡ Simple backup
Here, exactly one backup copy is created when you save a document. This copy contains the previous (i.e.
last saved) version of the document. It is saved as a file with the name extension .bak, stored in the same
folder as the document.
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¡ Advanced backup
With this option, multiple generations of backup copies are kept for each document. All of these copies are
stored in a special Backup folder.
Tip: When this option is selected, also the File > Revert to previous version menu command becomes
available. It provides a comfortable means of returning to a previous version of the current document.
Additional options:
Folder for backup files: Here you can change the location of the Backup folder in which all backup copies
are stored.
Number of backup files per document: Here you can specify the maximum number of backup copies (=
generations) to be kept for each document.
"Clean Up" button: Offers the following two commands for deleting backup copies:
Delete orphaned backup files: Removes each backup file for which the corresponding original file no
longer exists.
Delete all backup files: Removes all backup files that reside in the folder for backup files.
More detailed information on the usage of backup copies can be found in the section Backup copies.

Preferences, System tab
The System tab in the dialog of the Tools > Options menu command contains the following system settings:

Compress pictures in memory
If this option is enabled, pictures inserted into documents will be stored (losslessly) compressed in memory.
Advantage: Documents containing many pictures consume significantly less main memory. Disadvantage: The
compression of course consumes some CPU time.
As a general rule, you should leave this option enabled.
Note: Changes to this setting become effective only after PlanMaker is restarted.

Limit internal picture cache
PlanMaker uses an internal picture cache to speed up the display of images in a document. If this option is
enabled, the size of this cache is restricted to a maximum of 20% of your main memory.
As a general rule, you should leave this option enabled.
If you frequently work with documents containing many high-resolution pictures, you may consider
deactivating this option. Pictures will then usually be displayed faster throughout the document; however, it can
occur that PlanMaker consumes a large amount of main memory.
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Smooth edges of pictures
When this option is enabled, PlanMaker uses anti-aliasing to smooth edges and lines in images. Advantage: The
display quality of scaled images is improved. Disadvantage: This of course consumes some CPU time.

Check for updates
Windows, Mac, and Linux only: Here you can specify if (and how often) the software should check if updates
for SoftMaker Office are available. Updates provide bug fixes and feature improvements.
Note: Checking for updates is possible only when your device has Internet access.
In case you want to disable the automatic update check (not recommended), choose the Never option from the
list. In that case you have to check for updates manually (by clicking on the Check Now button.)
Tip: Subscribe to our free newsletter at www.softmaker.com to get an e-mail automatically whenever
updates are available. The newsletter will also provide you with other useful information and special offers
related to SoftMaker Office.
Android: When you have installed an application via Google Play Store, your device will inform you about
software updates automatically (unless you have deactivated automatic updates in the Play Store settings).

Associate file types
Windows only: This button opens a dialog where you can associate certain file types with PlanMaker. This
will make PlanMaker the default application for the corresponding file types.
For example, when you associate the file type "Microsoft Excel documents" with PlanMaker, from now on,
files of this type will always be opened in PlanMaker when you double-click on such a file in Windows
Explorer.

Show/hide keyboard automatically
Android only: When checked, the on-screen keyboard will pop up automatically whenever you are given an
opportunity to enter text (for example, when you double-tap on a cell, or when you tap into an input field in a
dialog).

Change keyboard layout automatically
Android only: When checked, the layout of the on-screen keyboard will automatically adapt to the current
situation. For example, in a dialog, when you tap into an input field that accepts only numbers, the keyboard
will automatically be switched into numeric mode.
Additionally, when you enter data into table cells, PlanMaker will lock the current input mode of the keyboard
when this option is enabled. If it is disabled, the keyboard will be reset to its standard mode (alpha-numeric)
with every cell you enter.
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Use OpenGL engine
Linux only: When this option is enabled, the software utilizes the OpenGL graphics library. This will increase
the responsiveness of the display, so you usually want to keep this option turned on.
Note: On systems with an outdated or faulty OpenGL installation, you may experience rendering issues within
the application. This depends on your individual system configuration and especially the graphics driver used.
In this case, turn this option off and restart the application.
Also, the application checks for OpenGL support at startup and will automatically deactivate this option if any
problems are detected.

Use SHM extensions
Linux only: This option is only available if the Use OpenGL engine option has been turned off (not
recommended).
When the SHM extensions are turned on, the application tries to use shared memory to speed up the
responsiveness of the display.

Use XIM
Linux only: When this option is enabled, PlanMaker supports the composition of accented characters (à, ô, é,
etc.) using "XIM".
For example, with a German keyboard, you can insert the character "ô" by first pressing the ^ key and then
pressing the O key.
If you disable this option, composing characters like this is no longer possible.
Note: On some systems, disabling this option improves the responsiveness of the display when you are typing
text fast.

Show hidden files and folders
Mac, Linux only: When this option is enabled, file lists in file dialogs (e.g. the File > Open menu command)
will also display hidden files and folders.

Mouse wheel
Mac, Linux only: If your mouse has a mouse wheel, you can set the scrolling increment for a turn of the wheel
either by page (one complete page) or by a certain number of lines.

External applications
Mac, Linux only: This button opens a dialog where you can specify which external applications to start on
certain actions. For example, when a PDF file is created, the application specified in the PDF Viewer field will
be launched to display the result.
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Note: You don't have to fill out these fields. For all fields that are left empty, your system's default application
for the corresponding action will be used. Make changes to this dialog only when you want applications
different from the default applications to be used. To do so, enter the file name of the corresponding executable
(including the entire file path, if necessary).

User-defined font paths
Mac, Linux, and Android only: Here you can specify paths to supplementary fonts for PlanMaker. To do this,
enter the subdirectory in which the font files reside. If you want to enter multiple directories, separate them
with colons.
PlanMaker can then use these fonts in addition to the fonts available to it from the operating system.
Note: Changes to this setting become effective only after the program is restarted.

Preferences, Fonts tab
The Fonts tab in the dialog of the Tools > Options menu command allows you to specify which fonts to
display in font lists (e.g. in the dialog of the Format > Character menu command).
The tab presents a list of all fonts installed on your system. To activate or deactivate a font in the list, click on
the checkbox in front of its name. Fonts where you have removed the checkmark are no longer displayed in font
lists.
Background information: The fonts installed on your system by default contain several fonts that you will
probably never need – for example, fonts that contain solely glyphs for foreign languages that you don't use. If
you like, you can hide such fonts as described above.

Use font filtering of the operating system
Windows only: Windows users will additionally find an option named Use font filtering of the operating
system on this tab. When activated, Windows will automatically hide all fonts that contain solely glyphs for
foreign languages in font lists.

Document properties
With the File > Properties menu command you can make settings that apply only to the current document and
are saved with it. These settings are called document properties.
The settable document properties are grouped by topic and each group is presented on one of several tabs. For
example, if you click on the Summary tab, you can enter summary information about the document.
On the next pages, you will find detailed information on each of the individual document properties available.

Customizing PlanMaker

370

Document properties, Summary tab
The Summary tab in the dialog of the File > Properties menu command allows you to enter summary
information about the current document.
The summary information can include descriptive entries about the document (subject, author, keywords, etc.)
that the file manager can use in searches.
For more information, see section Document summary.

Document properties, Colors tab
The Colors tab in the dialog of the File > Properties menu command allows you to add and edit custom colors
for the current document.
When you open a color list – for example, the color list in the Formatting toolbar – you see only a small subset
of the more than 16 million colors that are available. This subset is called the color palette of the document.
You can modify this color palette at any time. You can add new colors and modify colors you have added.
However, the first 24 colors in the palette are default colors than cannot be changed.
Important: Changes in the color palette are saved in the document. Thus, you can compose a different color
palette for every document.

Adding a color
To add a color to the palette of the current document, do the following:
1.

Invoke the menu command File > Properties and switch to the Colors tab.
Tip: Alternatively, you can gain access to this dialog from any other dialog box that contains a color list.
To do this, select the Define color... entry in the color list (the last entry).

2.

Set the desired color (see the section "Working with the color controls" below).

3.

Click on the New button.

4.

Give the new color whatever name you like and confirm with OK.

5.

Exit the dialog with OK.

PlanMaker now adds the new color to the document's color palette. From now on, it will be available in all
dialog boxes that permit color selection.
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Changing a color
Note: You can change only those colors that you have added. The first 24 colors in the palette are default
colors that cannot be changed.
To change a color, do the following:
1.

Invoke the menu command File > Properties and switch to the Colors tab.
Or: Select the Define color... entry in any color list.

2.

Select the color to be changed from the Color palette list.

3.

Make the desired changes (see the section "Working with the color controls" below).

4.

Click on Change.

The color is now changed for the current document.

Deleting or renaming a color
You can delete or rename user-defined colors at any time. To do this, invoke the colors dialog, select a color
from the Color palette list, and click the Delete or Rename button.

Working with the color controls
The controls in the colors dialog allow you to set colors in a number of different ways. All these ways lead to
the same results – just choose the method that suits you the best:
¡ Using the color field and luminance slider
Setting colors is easiest when you use the large color field and the luminance slider to its right. The color
field presents all the available hues in all available saturations, while the luminance slider next to it provides
a means of varying the luminance.
To set a color, first click on the desired color in the large color field. Then click on the desired luminance in
the luminance slider.
¡ Using the hue, saturation and luminance controls
Alternatively you can set colors with the controls labeled Hue, Sat (saturation) and Lum (luminance).
Values between 0 and 240 are allowed for each.
¡ Using the Red, Green and Blue controls
Colors can also be specified by their red, green and blue components. The controls labeled Red, Green and
Blue are provided for this purpose. Here, values between 0 and 255 are allowed.
¡ Entering the hex code of a color
Additionally, you can specify a color by entering its hex code (like in the HTML code for web pages) into
the edit control labeled with a # sign.
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The hex code for colors consists of 3 two-digit hexadecimal values, standing for red, green, and blue
(RRGGBB). For example, 00FF00 represents pure green.

Document properties, Statistics tab
The Statistics tab in the dialog of the File > Properties menu command displays statistical information about
the current document:
¡ The Cells section displays how many cells are filled with text, numbers, formulas, etc.
¡ The General section displays the number of worksheets and the number of pages.
¡ The Objects section displays the number of objects (charts, pictures, etc.) in the current documents.
¡ The Actions section displays when the document has been created, saved, and printed.

Document properties, Options tab
The Options tab in the dialog of the File > Properties menu command contains common settings for the
current document:

"Text frames" group box
¡ Tab width
Determines the tab width for text entered in text frames.

"Cell contents" group box
¡ Syntax highlighting
If this option is checked, cells will be colorized according to their content.
Equivalent to the View > Syntax highlighting menu command (see section Syntax highlighting).
¡ Show formulas
If this option is checked, cells containing a calculation will display the formula instead of the result.
Equivalent to the View > Show formulas menu command (see section Displaying formulas instead of
results).
¡ Protection indicator
If this option is checked, a green triangle will be displayed in all unprotected cells when sheet protection is
activated. See also section Sheet protection.
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¡ Hyphenation
If this option is checked, cells where the option Wrap text is activated (using the Format > Cell menu
command) will be hyphenated. See also section Hyphenation.

"Comments" group box
¡ Show indicators
If this option is checked, a yellow triangle is displayed in cells that contain a comment. See also section
Inserting comments.
¡ Always show comments
Normally, comments are displayed only when you point with your mouse to a cell that contains a comment.
If you check this option, all comments in the current document will be displayed permanently.

"Decimal point after input" group box
¡ Move by ... decimals
If this option is checked, numbers entered in cells will be shifted by the specified number of decimal places.
This is helpful if, for example, many numbers with two decimal places have to be entered. If this option is
set to 2 and the number 42 is entered, it will be converted to 0.42. If 234 is entered, it will be converted to
2.34. The decimal points do not have to be entered manually.

"Window" group box
¡ Vertical scrollbar
If this option is checked, a vertical scrollbar is displayed in the document window.
¡ Horizontal scrollbar
If this option is checked, a horizontal scrollbar is displayed in the document window.
¡ Sheet tabs
If this option is checked, the worksheet register with tabs for each worksheet is displayed below the
document. These tabs can be used for switching between worksheets and creating/managing worksheets.

"Objects" group box
¡ Guidelines for text frames
If this option is checked, non-printing border lines are displayed around text frames. These lines make it
easier to determine and change the position/size of text frames.
¡ Show hidden objects
As described in the section Hiding objects, you can make inserted objects invisible on the screen.
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If you enable this option, any object whose Visible property has been disabled becomes visible on the screen
again.

Default currency
Use this option to change the default currency of the current document.
Note: Normally, this option should be set to System default. This will cause PlanMaker to use your system's
default currency.
Setting this option to a different currency has the following consequence:
Whenever PlanMaker automatically applies the Currency number format to a cell (for example, because it uses
an arithmetic function that returns a monetary value), the currency chosen here will be used instead of the
system's default currency.

"Compatibility" button
This button provides access to settings that affect functions internal to the program, in order to improve
compatibility with documents created in older versions of PlanMaker or in Microsoft Excel. These options are
set automatically when such a document is opened and normally should not be changed.

Document properties, Calculate tab
The Calculate tab in the dialog of the File > Properties menu command contains document-specific settings
related to calculations:

"Recalculation" group box
Determines if the calculations in the current document should be kept up-to-date automatically:
¡ Recalc automatically
If this option is enabled, calculations are updated automatically when the content of a cell is changed.
This is the default setting. It guarantees that all calculations are up-to-date.
¡ Recalc only before ...
If this option is enabled, calculations will be updated only when saving or printing the document, or when
copying or cutting cells.
If all of the above options are deactivated, calculations will no longer be updated.
Hint: You can instruct PlanMaker to update all calculations by choosing the Tools > Recalculate menu
command at any time.
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"External references" group box
These options are related to external cell references (i.e. cell references that refer to cells in a different file). For
details, see the section External cell references.
Options available:
¡ Update data on opening
Lets you choose if all external cell references in a document should be updated (once) when the document is
opened. Options available:
Always: When the document is opened, update its external references.
Never: When the document is opened, do not update its external references.
Ask user: When the document is opened, ask the user if external references should be updated.
¡ Save external data in document
If this option is activated, PlanMaker saves a copy of all values returned by external cell references in the
document. If the file for an external reference is missing when the external reference is updated, the value
last stored will still be displayed.
If you turn this option off, PlanMaker instead displays an error value when you update an external reference
while the corresponding file cannot be accessed.

"Rounding" group box
Checking these options increases the accuracy of calculations.
Since computers use a different numeral system than humans, some calculations may, in very rare cases, lead to
very small rounding errors. This issue is not PlanMaker-specific but affects practically all computer
applications.
However, PlanMaker has two options that, when activated, almost eliminate such rounding problems:
¡ If Round final result is checked, PlanMaker automatically rounds the final result of each calculation to 15
decimal places.
¡ If Round intermediate results is checked, PlanMaker also rounds any intermediate result within a
calculation to 15 places.
The first option reduces the probability of receiving a rounding error significantly; the second option
reduces it even more. However, the disadvantage of checking these options is that the time required to
recalculate the document increases.
A classical example for such rounding errors:
If these options are deactivated, the formula (0.1+0.2-0.3)=0 returns FALSE, though TRUE would be the
correct result. If both options are activated, the calculation returns the correct result.
¡ A third option is Precision as displayed: If you activate this option, all values are taken over as they are
displayed to you after rounding to decimal places. The entered values are reduced to the decimal places set in
the cell options for the number format.
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An example:
You have the sum of 2.3 + 2.4. The exact result is 4.7, but you decide not to display the decimal places
after the decimal point. Therefore, you set the decimal places in the cell options to 0. The table shows 2 +
2 now.
Without activating the option Precision as displayed: You get the result 5 (because the values 2.3 + 2.4
still exist in the background and are rounded to 5). You can also continue to calculate with the exact
result 4.7.
By activating the option Precision as displayed: You get the result 4 (because only the values 2 + 2 exist,
exactly as they are displayed in the cell). However, the exact result 4.7 has been lost for further
calculation.
Note on the Precision as displayed option: For longer decimal numbers than the decimal places that you
have set for the number format in the cell options, the original, more accurate values are permanently lost.
You should therefore be sure that you want to use this option in your calculation.

"Charts" group box
Like calculations, charts are updated automatically when the content of any cell changes. To disable this
feature, uncheck the Update automatically option.
Hint: You can instruct PlanMaker to update all charts in the current document by choosing the Tools > Update
charts menu command at any time.

"Iterations" group box
This option affects only cells containing a circular reference. For example, if cell A1 contains the formula
=A1*2, this is called a circular reference, because the calculation in cell A1 refers to cell A1 itself.
If the Use iterations option is checked, such calculations are repeated until a) the number of Maximum
iterations is exceeded, or b) the difference between the current result and the previous result of the iteration is
less than Maximum change.
By default, this option is not checked.
Note: Unless you actually use circular references in calculations on purpose, this option should not be
checked, since it significantly increases the time required to recalculate the document.

Document properties, Protection tab
The Protection tab in the dialog of the File > Properties menu command allows you to apply document
protection to the current document.
Opening and/or saving a protected document is possible only following the entry of a correct password.
Documents with read protection are also encrypted, so that they cannot be examined with programs other than
PlanMaker.
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You will find information about this topic in chapter Document protection.

Document properties, Fonts tab
The Fonts tab in the dialog of the File > Properties menu command displays a list of all fonts used in the
current document.
The list is divided into fonts that are available on the current device – and fonts that are not available (i.e. not
installed).

Worksheet properties
To modify the worksheet properties, use the Worksheet > Properties menu command. These settings affect
the current worksheet only.
Options available:
¡ Row headers
Determines whether row headers are displayed in the worksheet.
Row headers are buttons labeled with the row number, displayed to the left of the worksheet.
¡ Column headers
Determines whether column headers are displayed in the worksheet.
Column headers are buttons labeled with the column number, displayed above the worksheet.
Hint: Alternatively, row and column headers can be turned on/off using the View > Row & column
headers menu command.
¡ Page breaks
Determines whether dark gray lines indicating the location of page breaks are displayed in the spreadsheet.
¡ Show zero values
A cell contains a zero value when it contains either the number 0 (zero) or a calculation that returns zero.
If this option is enabled, the number "0" will be displayed in such cells as usual. If you disable it, nothing
will be displayed there.
¡ Gridlines
Determines whether gridlines are displayed between cells on-screen. Also, you can change the color of these
lines as desired.
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Hint: By default, gridlines do not appear in printouts. To include gridlines in a printout, choose the menu
command File > Page setup, switch to the Options tab, and check the Gridlines option.
¡ Sheet tab
The worksheet register at the bottom of the document window displays tabs for each worksheet in the
document.
With this option, you can change the color of the tab for the current worksheet.
¡ Background
When you activate the Alternating shade option, alternating shading is applied to the lines of the table: Odd
lines are shaded as specified with the Shading 1 button, even lines are shaded as specified with the Shading
2 button.
¡ Sheet direction
For tables in Arabic script, you can change the direction of the worksheet to right-to-left here.
Doing this will reverse the horizontal direction of the worksheet – so that the cell A1 is no longer in the top
left corner but in the top right corner.
See also chapter Working with Arabic text.

Customizing the document display
This section provides information on how to adjust the way the document appears on the screen:
¡ Zoom level
There are several zoom commands that allow you to change the zoom level of a worksheet.
¡ Full screen view
In full screen view mode, PlanMaker maximizes its program window and hides all toolbars in order to
display as much of the document as possible. To enter this mode, use the View > Full screen menu
command.
See the following pages for detailed information.

Zoom level
The zoom level can be set individually for each worksheet.
Choose the menu command View > Actual size to display the worksheet in its original size.
Choose the menu command View > Zoom level to set any other zoom level:
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Explanation

Fit to selection

Zooms in to the current selection as far as possible

Previous zoom

Restores the previous zoom level

50%, 75%, etc.

Sets the zoom level to the desired level
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Alternatively, custom values can be entered into the input box (50 to 400 percent).

Tip: Using the zoom slider
You can also use the zoom slider at the bottom right of the screen to modify the zoom level.

To change the zoom level, either drag the slider with your mouse, or click on the minus icon or the plus icon.
Tip: And when you click on the percent value displayed to the right of the slider, the dialog of the View >
Zoom level command mentioned above will open.

Full screen view
In full screen view mode, PlanMaker maximizes its program window and hides all toolbars in order to display
as much of the document content as possible.
To enter this mode, use the View > Full screen menu command.
To exit it, choose the View > Full Screen menu command again or press the Esc key.

Using the toolbar of the full screen view
When you activate the full screen view mode, an additional toolbar appears on the screen.

The "Fullscreen" toolbar

The icons in this toolbar have the following functions (from left to right):
¡ Show/hide menu bar
¡ Show/hide side bar
¡ Enter/exit "Drag sheet" mode
If this mode is activated, you can scroll your document using the mouse. Simply click into the document and
drag the mouse pointer into the desired direction (with the mouse button still held down).
Note: Selecting cells, text or objects is not possible in this mode.

Customizing PlanMaker

380

To exit the "Drag sheet" mode, click this button once again.
¡ A click on the Close button leaves full screen mode.

Customizing toolbars
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use classic menus and toolbars. (Information on customizing the ribbon can be found in the
section Customizing the ribbon.)
Hint: You can switch the user interface between ribbon and classic menus and toolbars at any time. To do
this, invoke the menu command Tools > Options (or, in the ribbon, the command File > Options). In the
dialog, switch to the Appearance tab and click on the User Interface button. A dialog box appears in which
you can select the type of user interface you prefer.
In this section you will learn how to configure the program's toolbars (Standard toolbar, Formatting toolbar,
etc.) using the View > Toolbars menu command and how to customize the icons displayed on them using the
Tools > Customize command.

A toolbar (here: the Standard toolbar)

Topics covered in this section:
¡ Displaying and hiding toolbars
¡ Positioning toolbars on the screen
¡ Managing toolbars (creating, deleting, renaming, or resetting toolbars)
¡ Customizing toolbar icons (adding, removing or repositioning icons)
¡ Using the toolbar menu (for quick access to the features listed above)
See the following pages for details.

Displaying and hiding toolbars
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use classic menus and toolbars. (Information on customizing the ribbon can be found in the
section Customizing the ribbon.)
You can enable or disable individual toolbars at any time.
Proceed as follows:
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1.

Invoke the View > Toolbars menu command.

2.

Click on the checkbox in front of a toolbar's name to enable or disable it.

3.

Exit the dialog box with Close.
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The toolbars you have checked or unchecked are now enabled or disabled.
Tip: There is a faster way to do this: When you click on any toolbar with the right mouse button, a list of all
available toolbars is displayed. To enable or disable a toolbar, click on the corresponding list entry.

Visible in mode ...
Some toolbars are visible only in particular situations. The Picture toolbar, for example, appears only when you
select a picture.
The Visible in mode option controls this behavior. With it, you can specify when a toolbar will be visible, for
example:
Option

Meaning

All modes

The selected toolbar is always visible (provided that it is not disabled).

Edit mode

The toolbar is visible only in normal Edit mode, and not in Object mode (see also section Object
mode). Example: the Formatting toolbar

Object mode

The toolbar is visible only in Object mode and not in normal Edit mode (see also section Object
mode). Example: the Object toolbar

Chart

The toolbar appears only when a chart is selected. Example: the Chart toolbar

Outline

The toolbar appears only if the current worksheet contains an outline (also see section Outliner).
Example: the Outline toolbar

Picture

The toolbar appears only when a picture is selected. Example: the Picture toolbar

To change the setting for one of the toolbars, invoke the menu command View > Toolbars, select the toolbar in
the list, and choose the desired option for Visible in mode.
Note: Normally, it does not make sense to change this setting for any of the default toolbars (Standard
toolbar, Formatting toolbar, etc.). These options are primarily meant for user-defined toolbars.

Positioning toolbars on the screen
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use classic menus and toolbars. (Information on customizing the ribbon can be found in the
section Customizing the ribbon.)
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You change the position of toolbars to your liking. To do this, use one of the following procedures:

Changing the position with the View > Toolbars command
The position of a toolbar can be changed with the help of the View > Toolbars menu command. Proceed as
follows:
1.

Invoke the View > Toolbars menu command.

2.

Select the toolbar you want to move in the Toolbars list.

3.

Select the desired position for the toolbar in the Position list.

Note: If you choose the Floating option, the toolbar icons are displayed in a window that can be moved or sized
just like an application window.

Changing the position with the mouse
Some toolbars can also be repositioned with the mouse. Proceed as follows:
1.

Position the mouse pointer over an empty area of the toolbar.

2.

Press and hold the left mouse button.

3.

While still holding the mouse button down, drag the toolbar to the desired position.

4.

Release the mouse button to place the toolbar at the new position.

Note: By default, most toolbars are locked against moving with the mouse, in order to protect them from
being moved accidentally. To remove the lock, invoke the menu command View > Toolbars, select the
toolbar of interest, and disable the Locked option.
Hint: A positioning aid is active while dragging a toolbar: When you drag the toolbar near one of the edges of
the program window, it jumps automatically to that edge. If you leave the toolbar at the top edge of the window,
for example, the result is the same as if you selected the Top position in the dialog box of the View > Toolbars
menu command.

Managing toolbars
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use classic menus and toolbars. (Information on customizing the ribbon can be found in the
section Customizing the ribbon.)
You can create new toolbars, delete, and rename existing toolbars, etc. To perform these tasks, use the buttons
in the dialog box for the View > Toolbars menu command.
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Creating new toolbars
You can create your own toolbars whenever you wish.
For example, if you frequently need to use commands in the Windows menu that are not present in the
Standard toolbar, it might be worthwhile for you to set up your own toolbar for them.
You create a new toolbar as follows:
1.

Click the New button (in the dialog box of the View > Toolbars menu command).

2.

A dialog box appears and prompts you to enter a name for the new toolbar – "My toolbar" for example.
Enter a name and confirm with OK.

3.

The new toolbar is set up. Close the dialog box or click on the Customize button to add icons to the toolbar.
You can read more about this in the section entitled Customizing toolbar icons.

Customizing the icons on a toolbar
You can edit the icons on toolbars with the Customize button. Information about this is provided in the next
section.

Deleting toolbars
The Delete button allows you to delete a user-created toolbar, as follows:
1.

Select the toolbar to be deleted in the list.

2.

Click on the Delete button.

Note: You can delete only toolbars that you have created yourself. The default toolbars (Standard toolbar,
Formatting toolbar, etc.) cannot be removed.
However, you can always disable toolbars that you do not need at the moment (see section Displaying and
hiding toolbars).

Renaming toolbars
The Rename button can be used to rename a user-created toolbar, as follows:
1.

Select the toolbar of interest in the list.

2.

Click on the Rename button.

3.

Type in a new name and confirm with OK.

Note: You can rename only toolbars that you have created yourself. The default toolbars (Standard toolbar,
Formatting toolbar, etc.) cannot be renamed.
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Resetting toolbars
You can undo any changes you have made to one of the default toolbars by selecting the toolbar in the View >
Toolbars dialog box and clicking Reset.
When you do that, the toolbar is reset to its default icons. In addition, the default settings for Visible in mode
and Position are restored.
Note: This command is applicable only to the default toolbars (Standard toolbar, Formatting toolbar, etc.), and
not to user-created toolbars.

Resetting all toolbars
To reset all toolbars at once, click on the Reset All button.
Note: This command only resets the default toolbars. User-created toolbars will not be touched.

Customizing toolbar icons
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use classic menus and toolbars. (Information on customizing the ribbon can be found in the
section Customizing the ribbon.)
The Tools > Customize menu command allows you to customize the icons contained in a toolbar. Among other
things, you can add, remove and reposition icons.
Proceed as follows:
1.

Invoke the Tools > Customize menu command.

2.

Use one of the procedures described below to add, remove, or reposition icons.

3.

Exit the dialog with Close.

Tip: This command can also be invoked by double-clicking on an empty area in any of the toolbars.
When you invoke this command, a dialog box appears.
This dialog contains two list boxes:
¡ Left list: all available commands
The left list shows all commands available in the program.
Tip: You can use the Categories dropdown list (displayed above the list) to filter the list for a specific
category (for example, show only commands of the "File" category).
You can also search the list by typing something in the Quicksearch field.
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¡ Right list: icons contained in the currently selected toolbar
The right list displays the icons contained in the currently selected toolbar.
You can choose which toolbar to display here using the Customize dropdown list (displayed above the right
list).
The following actions can be performed in this dialog box:

Adding an icon
To add an icon to a toolbar, follow these steps (in the Tools > Customize dialog box):
1.

Select the toolbar to which you want to add an icon in the Customize dropdown list (displayed above the
right list).
The right list now displays all icons that are currently contained in the selected toolbar.

2.

Optional: In the right list, select the icon after which the new icon is to be inserted.

3.

Select the icon to be added from the left list.

4.

Click on the >> button (displayed between the lists).

The icon is now added to the toolbar.
Tip: Alternatively, you can add an icon to a toolbar as follows: Invoke the Tools > Customize command.
With your mouse, simply drag the icon out of the dialog window and drop it at the desired position in the
toolbar. (Do this in the toolbar itself, not in the dialog!) Of course this procedure only works when the
toolbar is currently visible on the screen.

Removing an icon
To remove an icon from a toolbar, follow these steps (in the dialog box):
1.

Select the toolbar of interest in the Customize dropdown list (displayed above the right list).

2.

Select the icon to be removed from the right list.

3.

Click on the << button (displayed between the lists).

The icon is now removed from the toolbar.
Tip: Alternatively, you can remove an icon from a toolbar as follows: Invoke the Tools > Customize
command. Then simply drag the icon out of the toolbar with your mouse and drop it somewhere outside the
toolbar, for example in the document. (Do this in the toolbar itself, not in the dialog!)

Moving an icon
To move a toolbar icon to a different position, follow these steps (in the dialog box):
1.

Select the toolbar of interest in the Customize dropdown list.
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2.

Select the icon to be moved from the right list.

3.

Use the up or down arrow buttons (displayed left of the list) to change the icon's position within the toolbar.
Note: If you want to move an icon to a different toolbar, you must first remove it from its current toolbar and
then add it to the other toolbar.

Tip 1: Alternatively, you can move an icon as follows: Invoke the Tools > Customize command. Then drag
the icon to the desired position with your mouse (in the toolbar itself, not in the dialog!). With this method,
you can even move an icon from one toolbar to another.
Tip 2: By the way, moving icons works even if this dialog box is not open: When you hold down the Alt key,
you can move a toolbar icon by clicking on it and then (with the mouse button still pressed) dragging it to the
desired position.

Inserting a separator line
To add a separator line to the left of a toolbar icon, follow these steps:
1.

Select the toolbar of interest in the Customize dropdown list.

2.

In the right list, select the icon in front of which the separator line is to be inserted.

3.

Click the New Separator button (displayed below the right list).

The separator line is now inserted.
Tip: Alternatively, you can also use the following procedure: Invoke the Tools > Customize command.
Then, in order to insert a separator to the left of a toolbar icon, simply drag this icon a small distance to the
right using your mouse. (Do this in the toolbar itself, not in the dialog!)

Removing a separator line
To remove a separator line from a toolbar, follow these steps (in the dialog box):
1.

Select the toolbar of interest in the Customize dropdown list.

2.

Select the separator line to be removed from the right list.

3.

Click on the << button (displayed between the lists).

The separator line is now removed from the toolbar.
Tip: Alternatively, you can remove an icon from a toolbar as follows: Invoke the Tools > Customize
command. If you now drag the icon that is to the immediate right of the separator a little bit to the left, the
separator will be removed. (Do this in the toolbar itself, not in the dialog!)

Assigning keyboard shortcuts
When you click on the Shortcut keys button in the dialog, the dialog box expands to include an additional
section called Shortcut. This section can be used to edit the keyboard shortcuts for commands.
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In short: You can assign a keyboard shortcut of your choice to any command here: Select the command in either
of the two lists, click into the Please press accelerator field and then press the key combination with which
you want to call this command in the future.
For details, refer to the section Customizing keyboard shortcuts.

Managing toolbars
The dialog box for the Tools > Customize command also provides buttons for managing toolbars, as follows:
¡ New
Creates a new, empty toolbar.
¡ Rename
Renames the toolbar selected in the Customize list (only available for user-created toolbars).
¡ Reset
Resets the toolbar selected in the Customize list back to its factory defaults.
¡ Delete
Deletes the toolbar selected in the Customize list (only available for user-created toolbars).
¡ Reset all (displayed below the right list)
Resets all toolbars back to their factory defaults.
Further options for managing and configuring toolbars are available in the dialog box of the View > Toolbars
menu command (see section Managing toolbars).

Using the toolbar menu
"Classic menus and toolbars" only: This section is relevant only for users who have configured the
program to use classic menus and toolbars. (Information on customizing the ribbon can be found in the
section Customizing the ribbon.)
Some toolbars end with a double arrow », as shown in the following picture:

When you click on this double arrow, the toolbar menu will open.
This menu gives you quick access to all the toolbar related commands mentioned in the previous sections. In
detail, the toolbar menu includes the following commands:
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¡ Add/remove buttons
This command opens a list of all icons available for the toolbar. When you click on one of its entries, the
corresponding icon will instantaneously be activated or deactivated in the toolbar.
(Note: This command is meant for quickly turning icons on or off. If you want to perform further
customizations to the icons displayed in a toolbar, follow the instructions given in the section Customizing
toolbar icons.)
¡ Position
Use this command to change the position of a toolbar. Available options: top, bottom, left, right, or floating
(in a little window that can be moved and resized with the mouse).
¡ Toolbars
Invokes the View > Toolbars menu command that allows you to activate or deactivate, configure, and
manage toolbars.
See section Customizing toolbars.
¡ Customize
Invokes the Tools > Customize menu command that allows you to edit the icons on a toolbar (add, remove,
move icons).
See section Customizing toolbar icons.
¡ Reset this toolbar
Resets the toolbar. All customizations made to the toolbar's icons and settings will be reverted.

Customizing the ribbon
"Ribbons" only: This section is relevant only for users who have configured the program to use the ribbon
interface. (Information on customizing the classic menus and toolbars can be found in the section
Customizing toolbars.)
Hint: You can switch the user interface between ribbon and classic menus and toolbars at any time. To do
this, invoke the menu command Tools > Options (or, in the ribbon, the command File > Options). In the
dialog, switch to the Appearance tab and click on the User Interface button. A dialog box appears in which
you can select the type of user interface you prefer.
In this section you will learn how to configure and customize the ribbon (e.g. by adding additional icons).
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The ribbon and the Quick Access Toolbar (at the bottom)

Topics covered in this section:
¡ Showing and hiding the ribbon
¡ Changing the position of the Quick Access Toolbar
¡ Customizing icons on the ribbon
¡ Customizing icons on the Quick Access Toolbar
See the following pages for details.

Showing and hiding the ribbon
"Ribbons" only: This section is relevant only for users who have configured the program to use the ribbon
interface. (Information on customizing the classic menus and toolbars can be found in the section
Customizing toolbars.)
The ribbon is usually fully visible, as in the following picture:

The ribbon and the Quick Access Toolbar (at the bottom)

However, you can hide the ribbon at any time by minimizing it. This is useful if you want to save as much space
on the screen as possible for displaying the document.
Proceed as follows:
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1.

In the ribbon, click the Customize icon on the File tab.

2.

A menu opens. There you will find an option called Minimized ribbon, which can be turned on or off by
clicking on it. (A tick appears in front of the option if it is currently on.)

When you enable this option, the ribbon is minimized – only its tabs will still be visible.
Tip: Alternatively, you can minimize the ribbon by clicking on the
icon in the upper right corner of the
program window. Click on the icon again to bring the ribbon back in its full size.
In addition, the key combination Ctrl+F1 (Mac: Cmd+F1) is available for minimizing/restoring the ribbon.

Working with the ribbon minimized
When the ribbon is minimized, you can operate it as follows:
¡ When you click on one of the tabs of the minimized ribbon, the ribbon will temporarily become fully visible
again and display the corresponding tab. As soon as you trigger a command (e. g. click on the icon for a
command) the ribbon will be minimized again.
¡ When you double-click on one of the tabs, the ribbon will be permanently visible again.
¡ As mentioned above, you can also use the
enable/disable minimizing the ribbon.

icon in the upper right corner of the program window to

Changing the position of the Quick Access Toolbar
"Ribbons" only: This section is relevant only for users who have configured the program to use the ribbon
interface. (Information on customizing the classic menus and toolbars can be found in the section
Customizing toolbars.)
The Quick Access Toolbar is displayed below the ribbon. It provides a selection of the most frequently used
commands.

The ribbon and the Quick Access Toolbar (at the bottom)
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The Quick Access Toolbar can either share the space with the documents tabs – or reside in its own toolbar. To
change this, proceed as follows:
1.

In the ribbon, click the Customize icon in the File tab.

2.

A menu opens which contains either of the following two commands:
Show Quick Access Toolbar as separate toolbar: By default, the Quick Access Toolbar is displayed in the
bar that also contains the document tabs. When you invoke this command, the Quick Access Toolbar moves
to its own toolbar instead.
Show Quick Access Toolbar beside the document tabs: This command does exactly the opposite: If the
Quick Access Toolbar is currently displayed as a separate toolbar, invoking this command causes the Quick
Access Toolbar to move back to the bar containing the document tabs.

Customizing icons on the ribbon
"Ribbons" only: This section is relevant only for users who have configured the program to use the ribbon
interface. (Information on customizing the classic menus and toolbars can be found in the section
Customizing toolbars.)
The ribbon command File > Customize > Customize Ribbon allows you to customize the ribbon to a certain
extent. Primarily this command is intended to add additional icons, sections or even complete tabs to the
ribbon.
Important: The icons in the predefined sections on the ribbon can not be modified. In the existing sections,
you can neither add icons nor remove icons nor change their order. Only adding icons in a new section at the
end of a ribbon tab (or alternatively in a completely new tab) is allowed.
To customize the ribbon, proceed as follows:
1.

Invoke the ribbon command File > Customize > Customize ribbon.

2.

Use one of the procedures described below to edit the icons on a ribbon tab.

3.

Exit the dialog with Close.

Tip: This command can also be invoked by double-clicking on any empty area inside the ribbon.
When you invoke this command, a dialog box appears.
This dialog contains two list boxes:
¡ Left list: all available commands
The left list shows all commands available in the program.
Tip: You can use the Categories dropdown list (displayed above the list) to filter the list for a specific
category (for example, show only commands of the "File" category).
You can also search the list by typing something in the Quicksearch field.
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¡ Right list: icons contained in the currently ribbon tab
The right list displays the icons contained in the currently selected tab of the ribbon.
You can choose which tab to display here using the Customize dropdown list (displayed above the right
list).
The following actions can be performed in the dialog box:

Adding an icon
Note: You can add icons only in sections that you created yourself (or on a completely new tab). It is not
possible to insert an icon within the predefined sections.
To add an icon to a ribbon tab, follow these steps (in the dialog box of the ribbon command File > Customize >
Customize ribbon):
1.

Select the ribbon tab to which you want to add an icon in the Customize dropdown list (displayed above the
right list).
The right list now displays all icons that are currently contained in the selected tab.

2.

Select the icon to be added from the left list.

3.

Click on the >> button (displayed between the lists).

The icon is now added to the selected ribbon tab. If necessary, the program automatically creates a new section
at the end of the tab.

Removing an icon
Note: You can only remove icons that you added to the ribbon yourself. It is not possible to delete any of the
predefined icons.
To remove an icon from a ribbon tab, follow these steps (in the dialog box):
1.

Select the ribbon tab of interest in the Customize dropdown list.

2.

Select the icon to be removed from the right list.

3.

Click on the << button (displayed between the lists).

The icon is now removed from the ribbon tab.

Moving an icon
Note: You can only move icons that you added to the ribbon yourself. It is not possible to change the
position of any of the predefined icons.
To move an icon within a ribbon tab, follow these steps (in the dialog box):
1.

Select the ribbon tab of interest in the Customize dropdown list.
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2.

Select the icon to be moved from the right list.

3.

Use the up or down arrow buttons (displayed left of the list) to change the icon's position within the ribbon
tab.
Note: If you want to move an icon to a different ribbon tab, you must first remove it from its current tab and
then add it to the other tab.

Adding a new section
Note: New sections can be added only after the predefined sections. It is not possible to insert a section
between the predefined sections.
To add a new section to a ribbon tab, follow these steps (in the dialog box):
1.

Select the ribbon tab of interest in the Customize dropdown list.

2.

Click on the New section button (displayed below the right list).

The new section is now added (appended) to the ribbon tab.

Renaming a section
Note: You can only rename sections that you added yourself. It is not possible to rename any of the
predefined sections.
To rename a user-created section on a ribbon tab, follow these steps (in the dialog box):
1.

Select the ribbon tab of interest in the Customize dropdown list.

2.

Select the section to be renamed in the right list.

3.

Click on the Rename button (displayed below the right list).

4.

Type in a new name and confirm.

The section is now renamed accordingly.

Removing a section
Note: You can only remove sections that you added yourself. It is not possible to delete any of the predefined
sections.
To delete a user-created section on a ribbon tab, follow these steps (in the dialog box):
1.

Select the ribbon tab of interest in the Customize dropdown list.

2.

Select the section to be removed in the right list.

3.

Click on the << button (displayed between the lists).

The section is now removed from the ribbon tab.
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Assigning keyboard shortcuts
When you click on the Shortcut keys button in the dialog, the dialog box expands to include an additional
section called Shortcut. This section can be used to edit the keyboard shortcuts for commands.
In short: You can assign a keyboard shortcut of your choice to any command here: Select the command in either
of the two lists, click into the Please press accelerator field and then press the key combination with which
you want to call this command in the future.
For details, refer to the section Customizing keyboard shortcuts.

Managing ribbon tabs
The dialog box for this command also provides buttons for managing ribbon tabs, as follows:
¡ New
Creates a new, empty ribbon tab.
¡ Rename
Renames the tab selected in the Customize list (only available for user-created tabs).
¡ Reset
Resets the tab selected in the Customize list back to its factory defaults.
¡ Delete
Deletes the tab selected in the Customize list (only available for user-created tab).
¡ Reset all (displayed below the right list)
Resets all tabs back to their factory defaults.

Customizing icons on the Quick Access Toolbar
"Ribbons" only: This section is relevant only for users who have configured the program to use the ribbon
interface. (Information on customizing the classic menus and toolbars can be found in the section
Customizing toolbars.)
The Quick Access Toolbar is displayed below the ribbon. It provides a selection of the most frequently used
commands.
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The ribbon and the Quick Access Toolbar (at the bottom)

If you wish, you can customize the icons on the Quick Access Toolbar at any time, for example, you can add,
remove, and reposition icons.
To do this, invoke the ribbon command File > Customize > Customize Quick Access Toolbar. A dialog box
for customizing toolbars will appear in which you can make the desired changes.
The Quick Access Toolbar behaves exactly like a classic toolbar. To customize its icons, you can proceed
exactly as described in the section Customizing toolbar icons. All explanations given there also apply to the
Quick Access Toolbar – except for the section "Managing toolbars".

Creating user-defined toolbar/ribbon icons
You can create user-defined icons and add them to a toolbar or to the ribbon. Such icons can be used to start
other programs of your choosing.
To set up a user-defined icon, for example, an icon for starting Windows' Notepad application, proceed as
follows:
1.

Invoke the following command in the menu or ribbon:
Menu: Tools > Customize
Ribbon: File > Customize > Customize Ribbon

2.

In the Categories dropdown list, choose the User category.

3.

Select one of the icons from the Commands list.
The first three icons are already assigned to the Windows Calculator, the Windows Character Map, and the
Windows Control Panel to serve as examples. Select e.g. the fourth icon for this exercise.

4.

Click on the Edit button displayed below the list. Another dialog box appears.

5.

Enter a short description of the program to be started in the Description field. In this example, you could
enter "Notepad".

6.

Enter the complete path and filename for the program to be started in the Command line field, for example,
c:\windows\notepad.exe.
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Optional: If the program's own icon is not the one you want to use, you can enter the path and name of a
different icon file in the Icon file field.
Note, however, that toolbars icons are a bit smaller than standard Windows icons.

As soon as you confirm with OK, the icon is created.
If you want to add your custom icon to a toolbar or ribbon tab right now, proceed as described in one of the
following sections:
¡ Toolbars: section Customizing toolbar icons
¡ Ribbon: section Customizing icons on the ribbon

Customizing keyboard shortcuts
The most commonly used commands in a program have keyboard shortcuts. For example, the command for
saving the current document can be invoked very quickly by pressing the key combination Ctrl+S.
The predefined keyboard shortcuts can be customized in the dialog box of the menu command Tools >
Customize. There, you can assign keyboard shortcuts to commands and also change or remove existing
shortcuts.
Proceed as follows:

Adding keyboard shortcuts
To assign a keyboard shortcut to a command, perform the following steps:
1.

Invoke the following command in the menu or ribbon:
Menu: Tools > Customize
Ribbon: File > Customize > Customize Ribbon

2.

Click on the Shortcut keys button.
The dialog box now expands to include an additional section called Shortcut. This section can be used to
edit the keyboard shortcuts for commands.

3.

Select the command to which you want to assign a keyboard shortcut from either the left list or the right list.
The left list shows all commands available in the program. (Hint: The Categories dropdown list allows you
to filter the list by category, and the Quicksearch field can be used to search the list).
The right list shows only those icons that are contained in the currently selected toolbar or ribbon tab.

4.

Once you have selected the desired command, click into the Please press accelerator field and press the
key combination with which you want to call this command in the future.
Hint: If you make a typing mistake, you can always press the BackspaceÕ key to remove the keyboard
shortcut you entered.
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6.

Exit the dialog with Close.

397

From now on, you can execute the selected command with the specified key combination.

Editing keyboard shortcuts (remove, change, etc.)
You can edit existing keyboard shortcuts for commands (for example, delete or change them) at any time.
Proceed as follows:
1.

Invoke the following command in the menu or ribbon:
Menu: Tools > Customize
Ribbon: File > Customize > Customize Ribbon

2.

Click on the Shortcut keys button.
The dialog box now expands to include an additional section called Shortcut. This section can be used to
edit the keyboard shortcuts for commands.

3.

Select the command whose keyboard shortcut you want to edit from either the left or the right list.

4.

Perform one of the following actions:
Removing shortcuts: The Current shortcut keys listbox displays all keyboard shortcuts currently assigned to
the selected command. To remove a shortcut, select it from the list and click on Remove.
Changing shortcuts: To change the keyboard shortcut for a command, first remove it (as just described) and
then assign it a new shortcut (as described at the beginning of this section).
Resetting shortcuts: To reset all keyboard shortcuts for the entire program to their default values, click the
Reset all accelerators button and confirm. Any changes made to the default keyboard shortcuts are then
discarded.
Display a list of all shortcuts: When you click on the Export button, a table listing all currently assigned
keyboard shortcuts is displayed. The buttons placed next to the table allow you to copy it to the clipboard,
for example.

Available keyboard shortcuts
Notice that some of the keystroke combinations that are possible on your keyboard are not allowed as keyboard
shortcuts.
As a rule, you should use alphabetic keys, numeric keys or function keys for shortcuts. You can combine
them with Ctrl, Alt and/or the Shiftñ key.
You can easily check to see if the key combination you want to use is allowed. Click in the Please press
accelerator field, and then try to enter your key combination. If it does not appear in the field, it is not allowed.
Some examples of valid keyboard shortcuts include:
¡ Ctrl+A
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¡ Alt+A (However, key combinations including the Alt key are not recommended, since they are usually
occupied by the main menu entries).
¡ Ctrl+Alt+A
¡ Ctrl+Shift+A
¡ Ctrl+Alt+Shift+A
¡ Ctrl+F2
¡ etc.
Note: Alphabetic keys by themselves are of course not allowed. Thus, you cannot use A or Shift+A as a
shortcut.
Shortcut already assigned: If you press a shortcut that is already assigned, the current assignment will be shown
just below the entry field. You should press the BackspaceÕ key to delete your shortcut and try a different
shortcut. Otherwise, you will overwrite the existing assignment for the shortcut.
Two part shortcuts: You can also use two part shortcuts (in accordance with the WordStar standard), for
example, Ctrl+K+X. Please note that only shortcuts of the form "Ctrl + letter + letter" are allowed here.

Customizing AutoFill lists
As described in section Filling cells automatically, the Edit > Fill menu command can be used to fill a cell
range with a repeating values or a sequence of values.
The Tools > Edit lists menu command allows you to create custom lists for the Fill command.
For example, if you create a list with the content "Red", "Green", and "Blue" and later start a fill operation from
a cell that contains the text "Red", PlanMaker will continue the series and fill with Green, Blue, Red, Green,
Blue, etc.
To create or modify an AutoFill list, choose the menu command Tools > Edit lists and use one of buttons
available in the dialog:
¡ New button: Create a new list
¡ Edit button: Edit a list
¡ Delete button: Delete a list
¡ Import button: Generate a new list from the currently selected cells
See the following pages for detailed information.
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Creating a new AutoFill list
To create a new AutoFill list for the Edit > Fill menu command:
1.

Choose the menu command Tools > Edit lists.

2.

Click the New button.

3.

Another dialog appears. Use it to enter the desired list entries. Press the Enter ¿ key after each entry to start
a new line.

4.

Click OK to confirm.

Editing AutoFill lists
To edit a user-defined AutoFill list created with the Edit > Fill menu command:
1.

Choose the menu command Tools > Edit lists.

2.

Select the desired list.
Note: The predefined sample lists cannot be edited.

3.

Click the Edit button.

4.

Use the resulting dialog to edit the list entries.

5.

Click OK to confirm.

Deleting AutoFill lists
To delete a user-defined AutoFill list created with the Edit > Fill menu command:
1.

Choose the menu command Tools > Edit lists.

2.

Select the desired list.
Note: The predefined sample lists cannot be deleted.

3.

Click the Delete button.
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Importing AutoFill list from cells
If a PlanMaker document contains a cell range whose contents you want to save as an AutoFill list:
1.

Select the desired cells.

2.

Choose the menu command Tools > Edit lists.

3.

Click the Import button.

PlanMaker reads the contents of the selected cells and creates a new AutoFill list from them. Each cell becomes
a list entry.

Installing additional dictionaries
You can install additional dictionaries for the spell-checker whenever needed. Just follow the instructions given
in the following sections:
¡ Installing additional SoftMaker dictionaries
This section explains how to add additional SoftMaker dictionaries to your installation.
Note: This is only relevant for the Android version. When you install SoftMaker Office for Windows, Mac,
or Linux, all available SoftMaker dictionaries are included already.
¡ Installing Hunspell dictionaries
Apart from SoftMaker dictionaries, SoftMaker Office additionally supports the use of Hunspell dictionaries.
Read this section to learn more.
¡ Choosing a different dictionary for a language
In case you have installed more than one dictionary for a certain language (e.g. a SoftMaker dictionary and a
Hunspell dictionary), you can switch between these dictionaries anytime. Read this section for details.
More information on these topics can be found on the next pages.

Installing additional SoftMaker dictionaries
SoftMaker Office comes with high-quality dictionaries for numerous languages. This section explains how to
install dictionaries that are not currently installed:
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Windows, Mac and Linux
When you install SoftMaker Office for Windows, Mac, or Linux, all available SoftMaker dictionaries are
included already – so there is no need to add additional SoftMaker dictionaries later.

Android
This is different with the Android version: It allows you to download and automatically install SoftMaker
dictionaries that are currently not installed from our server whenever needed, free of charge.
Proceed as follows:
1.

Launch any of the apps (TextMaker, PlanMaker, or Presentations) on your Android device.

2.

Invoke the Tools > Options menu command and switch to the Language tab.

3.

Tap on the Get more dictionaries button.

4.

A dialog with a list of all available languages opens. To download and install a language, tap on the
corresponding download button displayed at its right.

When the download has finished, the dictionary is installed and from now on available in any SoftMaker Office
application.

Installing Hunspell dictionaries
Apart from SoftMaker's own dictionaries, SoftMaker Office also supports the use of Hunspell dictionaries.
These dictionaries are available as free downloads. Most of them were created by private users or non-profit
organizations.
Hunspell dictionaries are available for very many languages. In case you don't find a SoftMaker dictionary for a
certain language, it might be worth checking if a Hunspell dictionary is available for that language.
For a list of all Hunspell dictionaries supported by SoftMaker Office, visit the "Downloads" area of our website
www.softmaker.com. You can also download the dictionaries there, free of charge.
To download and install a Hunspell dictionary, proceed as follows:
1.

With your web browser, navigate to our homepage www.softmaker.com

2.

In the menu of the web page, choose "Downloads", then choose "Dictionaries".

3.

Your browser now displays a page presenting a list of all Hunspell dictionaries that SoftMaker Office
supports. Download the dictionary of interest.

4.

Launch any SoftMaker Office application (TextMaker, PlanMaker, or Presentations).

5.

Invoke the Tools > Options menu command and switch to the Language tab.

6.

Click on the Hunspell dictionaries button.
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7.

A dialog showing a list of all languages/dictionaries installed appears. Click on the Add Hunspell
dictionary button.

8.

A file dialog is displayed. Use it to browse to the folder where the downloaded dictionary has been stored.

9.

Select the dictionary file from the files list and click on Open.

The dictionary will be installed and is from now on available in any SoftMaker Office application.

Choosing a different dictionary for a language
In case you have installed more than one dictionary for a certain language (e.g. a SoftMaker dictionary and a
Hunspell dictionary), you can switch between these dictionaries anytime. Proceed as follows:
1.

Invoke the Tools > Options menu command and switch to the Language tab.

2.

Click on the Hunspell dictionaries button.

3.

A dialog showing a list of all languages/dictionaries installed appears. First, select the language of interest
in that list.

4.

Then, select the dictionary to use for the chosen language in the Dictionary dropdown list. The list can have
the following entries:
SoftMaker: The SoftMaker dictionary shipped with SoftMaker Office.
Hunspell: A Hunspell dictionary (free dictionary, see previous section)

5.

Confirm with OK.

From now on, the spell-checker will use the selected dictionary for the specified language.
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Formulas and functions
This chapter provides instructions on working with formulas, including comprehensive descriptions of
PlanMaker's arithmetic functions:
¡ Formula basics
The first section provides basic information on formulas.
¡ Entering formulas
This section provides information on entering formulas in cells.
¡ Relative vs. absolute cell references
This section explains the difference between relative cell references (like =A1) and absolute cell references
(like =$A$1) in formulas.
¡ External cell references
The next section is about external cell references in formulas (i.e. cell references that refer to cells in a
different file).
¡ Error values
If a formula results in an error, an error value is displayed instead of the result. This section provides
information on error values.
¡ Working with arrays
This section provides instructions on working with arrays and array formulas.
¡ Working with database functions
This section provides information on database functions such as DCount, DSum, etc.
¡ Functions from A to Z
This section contains comprehensive descriptions of PlanMaker's arithmetic functions.
Hint: A short introduction to working with formulas is also provided in chapter "The PlanMaker Tour".

Formula basics
Formulas can be composed of the following components:
¡ Fixed values (e.g., numbers or text)
¡ Cell references (e.g., A1 or D2:D3)
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¡ Arrays (see section Working with arrays)
¡ Arithmetic operators (e.g., + or -, see section Operators in formulas)
¡ Arithmetic functions (e.g., SUM)
For example, a formula can look as follows:
= 67 + (A3 * Sum(B1:C5))

Operators in formulas
Formulas can contain any of the operators listed below.
Please note that operators follow a strict order of precedence, which defines the evaluation order of expressions
containing operators: Operators with higher precedence are evaluated before operators with lower precedence.
Parentheses can be used to override the order of precedence and force parts of a formula to be evaluated before
other parts. For example, 1+2*2 returns 5, since multiplication has precedence over addition. If the formula
(1+2)*2 is used instead, the result will be 6, since the parentheses override the order of precedence.
Operators available, listed in order of precedence (top = highest):
1st

Spacebar

Intersection (see also INTERSECTION function)

2nd

%

Percentage

3rd

+

Positive sign (not addition!)

–

Negative sign (negation)* (not subtraction!)

4th

^

Exponentiation*

5th

*

Multiplication

/

Division

+

Addition

–

Subtraction

7th

&

Concatenation (For example, "Plan" & "Maker" returns "PlanMaker")

8th

=

Is equal

<>

Is not equal

<

Is less

>

Is greater

<=

Is less or equal

>=

Is greater or equal

6th

* Note: To ensure compatibility with Microsoft Excel, the order of precedence for the exponentiation operator (^) and the negation operator (-) is
changed, but mathematically incorrect. For example, the correct mathematical order (first exponentiation, then sign) for the formula -2^2 would lead to
the mathematically correct result -4. However, the actual result in PlanMaker (and in Excel) is 4.
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Entering formulas
Hint: A short introduction to entering formulas is also provided in the chapter The PlanMaker Tour.
To enter a formula in a cell, use one of the following procedures:

Entering formulas manually
Important: Formulas have to begin with an equal sign (=). For example, to calculate 2+2, enter =2+2.
To enter formulas manually, type them in starting with an equal sign. Then, press the Enter ¿ key to confirm,
or the Esc key to abort.
Alternatively, use the following buttons of the Edit toolbar:
¡ To accept the input, click the

button (identical to pressing the Enter ¿ key).

¡ To cancel the input, click the

button (identical to pressing the Esc key).

To edit a formula later, navigate to the cell containing the formula and press the F2 key. Alternatively, doubleclick the cell.

Using the mouse to enter formulas
When entering a formula, you can use the mouse to select a single cell or a cell range, and have its address
pasted into the formula.
For example, to enter the formula =SUM(B2:D4), proceed as follows:
1.

Enter =SUM(

2.

With the mouse, select cells B2 to D4 by dragging a rectangle from B2 to D4 with the left mouse button
pressed.

3.

When you release the mouse button, the cell address is automatically pasted into the formula. The formula
now displays: =SUM(B2:D4

4.

Enter the closing parenthesis ) and press the Enter ¿ key to complete the formula.

The cell will now contain the formula =SUM(B2:D4).

Using the Insert > Function command
To utilize arithmetic functions in formulas, either just type in the function name manually or use the lists
provided in the dialog box for the Insert > Function menu command.
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Components of the Insert > Function dialog box:
¡ Formula input box
Lets you edit the formula.
¡ Category
Determines which type of functions to display in the Function list box.
In the Named ranges category at the end of the list, you can access your existing named cell ranges to insert
them into formulas (see section Putting named ranges to use).
¡ Function
Displays all functions of the selected category. To copy a function to the Formula input box, double-click
it.
Tip: If you select a function, a short description is automatically displayed in the lower part of the dialog.
In the Windows version of PlanMaker, you can also call up a help page for each function by clicking on it
and then pressing the F1 key.
¡ Operator group box
Contains buttons for common arithmetic operators. To copy an operator to the Formula input box, click the
corresponding button.
¡ Insert button
To finish editing the formula in the Formula input box, click Insert. The dialog will close, and the formula
will be inserted in the current cell.
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¡ Close button
To close the dialog without inserting the formula, click Close.

Relative vs. absolute cell references
Cell references in calculations can be entered either as relative cell references (like =A1) or as absolute cell
references (like =$A$1).
This section explains the difference between relative and absolute cell addressing:

Relative cell references
When you enter a reference to another cell into a formula, normally relative cell addressing is used.
You see that when you enter the formula =B1+B2 in cell B3, and copy or move B3 to C3 afterwards. The
formula will automatically adapt and change to =C1+C2.

Absolute cell references
If you do not want formulas to automatically adapt when they are copied or moved, use absolute cell addressing
instead of relative cell addressing. To make a relative cell reference absolute, type a dollar sign ($) in front of
the column number and row number.
For example, if you enter =$B$1+$B$2 in cell B3, and move B3 to C3 afterwards, the formula will not adapt. It
will still add the cells B1 and B2.
Note: If desired, you can also make just one component of a cell reference absolute by typing a dollar sign only
in front of the column number (e.g., $B1) or the row number (e.g., B$1).

Tip: Using the F4 key to change cell addressing
When you enter a cell reference in a formula, you can use the F4 key to switch the type of addressing.
For example, after having typed =A4,
=$A4 will be displayed, when you press F4,
=A$4 will be displayed, when you press F4 once again,
=$A$4 will be displayed, when you press F4 once again.
If you press F4 once again, the old entry =A4 will be displayed again.
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External cell references
In calculations, you can use cell references that refer to cells located in a different PlanMaker or Excel
document. Such references are called external cell references.
In this section, you will learn everything you need to know about this. The following topics are covered:
¡ Entering external cell references
¡ Updating and managing external cell references
See the next pages for details.

Entering external cell references
Cell references that refer to cells in a different document have to be entered in calculations as follows:
='C:\My Folder\[My Workbook.pmdx]Sheet1'!A1
This example returns a cell reference to the cell A1 in the worksheet "Sheet1" in the PlanMaker document "My
Workbook.pmdx" in the folder "C:\My Folder".
As you can see, external cell references must consist of the following components:
¡ Quotation mark
External cell references should always start with a quotation mark. You can use either single quotes (') or
double quotes (").
¡ Folder
Next, enter the entire path to the folder where the external file is located – for example: C:\My Folder\
Hint: If the external file is in the same folder as your document, you can omit the path.
¡ File name in square brackets
Next comes the file name, enclosed in square brackets. Only PlanMaker and Excel files are allowed.
¡ Sheet name
The next component is the name of the worksheet that holds the desired cell.
¡ Quotation mark
Next comes another quotation mark.
¡ Exclamation mark
Then an exclamation mark.
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¡ Cell reference
The last component is the address of the cell that you want to refer to.
To complete your input, press the Enter ¿ key. PlanMaker will now read the content of the cell in the specified
external file.
For information on updating and managing external cell references, see the next pages.

Notes
¡ If PlanMaker is unable to find the specified file, a dialog where you can select the file will appear when you
press the Enter ¿ key.
Tip: If you don't want to type in the entire path and file name manually, you can use the following trick: In
the cell reference, simply enter [x.pmdx] instead of the path and file name – for example: [x.pmdx]
Sheet1!A1. This will "force" PlanMaker to display a file dialog where you can comfortably choose the file
you want to refer to.
¡ If PlanMaker is unable to find the specified worksheet, a dialog where you can select the worksheet from the
specified file will appear when you press Enter.
¡ Normally, PlanMaker remembers the entire (absolute) path of the external file. However, if the external file
is located in the same folder as your document (or one of its subfolders), PlanMaker stores only the relative
path.
This means in practice: If your document and the external file reside in the same folder, references to this
external file will stay intact even when you move both files to a different folder.
¡ Tip: There's an alternative way to create external references, where you don't have to type in anything
manually:
1.

Open the document containing the cell you want to refer to.

2.

Copy this cell to the clipboard.

3.

Switch back to the current document.

4.

Navigate to the cell where you want the reference to be inserted.

5.

Invoke the Edit > Paste special menu command.

6.

Click on the Create references button.

PlanMaker now creates an external reference to this cell.

Updating and managing external cell references
Use the Worksheet > External references menu command to update and manage external cell references in a
document.
Invoking this command opens a dialog that lists all files the current document refers to.
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The buttons in this dialog allow you to perform the following actions:
¡ Update
Updates only those external cell references that refer to the file currently selected in the list.
(Also see the notes on updating below.)
¡ Update all
Updates all external references in the entire document.
Hint: There's an alternative way to trigger the Update All command: the Tools > Update external
references menu command.
¡ Open
Opens the external file currently selected in the list.
¡ Change
Lets you choose a different file for the external file currently selected in the list. All references to this file in
your document will be adopted accordingly.
¡ Previous
Jumps to the previous cell that contains a reference to the file selected in the list.
¡ Next
Jumps to the next cell that contains a reference to the file selected in the list.
The Close button closes the dialog.

Notes on updating external cell references
Note: The values returned by external cell references are not updated automatically every time the worksheet
is recalculated.
External cell references are updated only in the following cases:
¡ When you open a document, all external cell references it contains are updated automatically (once).
If required, you can turn this automatic update off – see the options described below.
¡ After that, you can update external references manually whenever needed.
To do so, choose the menu command Worksheet > External references and use the Update or Update all
buttons as described above.
Alternatively, you can invoke the Tools > Update external references menu command which does the
same as the Update all button.
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Options for updating external cell references
There are some options related to updating external references in the document properties.
To change them, choose the menu command File > Properties and switch to the Calculate tab. There, the
following options are available in the External references section:
¡ Update data on opening
Lets you choose if all external cell references in a document should be updated (once) when the document is
opened. Options available:
Always: When the document is opened, update its external references.
Never: When the document is opened, do not update its external references.
Ask user: When the document is opened, ask the user if its external references should be updated.
¡ Save external data in document
If this option is activated, PlanMaker saves a copy of all values returned by external cell references in the
document. If the file for an external reference is missing when the external reference is updated, the value
last stored will still be displayed.
If you turn this option off, PlanMaker instead displays an error value when you update an external reference
while the corresponding file cannot be accessed.
Note: The above options aren't global settings but document properties. This means that you can set them up
individually for each document.

Error values
If a formula results in an error, an error value is displayed instead of the result.
For example, if a cell contains the formula =1/A1 and a zero is entered in cell A1, the error value #DIV/0! will
be displayed in the cell, because numbers cannot be divided by zero.
The following error values exist:
Error value

Explanation

#REF!

Invalid cell reference. Displayed when a formula contains a cell reference that is invalid or
nonexistent.

#DIV/0!

Division by zero. Displayed when a formula contains a division by zero (which is undefined for any
number).

#NULL!

Invalid formula. Displayed when a formula contains syntax errors (for example, a missing parenthesis
or missing arguments).
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#NAME?

Invalid name. Displayed when a formula refers to a table name or named range that is nonexistent.

#N/A

Not available. Displayed when a cell contains a) a #N/A error value, or b) a formula referring to a cell
containing a #N/A error value. See NA (error value #N/A) for details.

#VALUE!

Invalid value. Displayed when a function is used with an inappropriate parameter type (for example, if
a number is passed to a function that is expecting a text string).

#NUM!

Invalid number. Displayed when a function is used with a number that is out of range (for example,
too large, or negative instead of positive)

Hint: To test if a cell returns an error value, use the functions ISERROR and ISERR
Tip: Additionally, you can use the Tools > Formula auditing menu command to find and analyze cells that
contain an error value. See the section Analyzing tables for details.

Working with arrays
PlanMaker allows you to enter arrays (also known as matrices) in spreadsheets and perform calculations with
them.
An array is a rectangular table of numbers, structured as follows:

The entries a11 through amn are called the elements of array A.
An array consisting of m rows and n columns is called an m by n array (or m x n array).

Entering arrays into cells
To enter an array in PlanMaker, distribute the array's rows and columns over the spreadsheet's rows and
columns.
For example, the following array ...

... has to be entered as follows:
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As you can see, for PlanMaker arrays are nothing but rectangular cell ranges.

Entering array formulas
PlanMaker provides array functions that allow you to perform calculations with arrays. A formula containing
an array function is called an array formula.
Since most array formulas return an entire array of values rather than a single value, entering array formulas
differs from entering other formulas.
For example, to calculate the inverse of the 3x3 array shown above, proceed as follows:
1.

Select a cell range for the resulting array
Before entering the formula, you have to select the cell range where the resulting array should be placed.
The inverse of a 3x3 array also has 3x3 elements. Therefore, you have to select a range of 3 by 3 cells – for
example E10:G12.

2.

Enter the array formula
After that, enter the array formula, for example =MINVERSE(E6:G8).

3.

Press Ctrl+Shift+Enter
Important: To finalize the formula, do not press just Enter, but press the key combination Ctrl+Shift+¿.

The cells E10:G12 now contain the resulting array, i.e., the inverse of the array in E6:G8:

Notes:
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¡ If you have selected a cell range larger than the resulting array, the error value #N/A ("not available") will
be displayed in the superfluous cells. Important: If the selected cell range is too small, parts of the array will
not be displayed.
¡ There are array functions that return just a single value rather than an entire array – for example, the
MDETERM function (that returns the determinant of an array). In that case the procedure described above is
not necessary, and the formula can be entered just like any other formula.
¡ To edit an existing array formula: Select all cells covered by the resulting array, edit the formula, and press
Ctrl+Shift+¿. If you press just the Enter ¿ key instead, PlanMaker issues a warning and asks you if you
want to overwrite the array by a single value.
¡ Hint: To select all cells covered by an array formula, click any of the involved cells and press Ctrl+7.

Entering array constants in formulas
If desired, arrays can be entered as constants instead of cell references. For this purpose, surround the array by
braces { }, and separate columns by commas and rows by semicolons.
For example, the following array ...

... can be entered as follows:
={1,2,3; 3,-1,1; 2,2,4}
Notes:
¡ The notation described above is suitable for fixed values only; formulas and cell references are not allowed.
¡ You can also enter vectors in the notation described above. For a horizontal vector enter, e.g., {1,2,3}; for a
vertical vector enter {1;2;3}.

Working with database functions
PlanMaker provides database functions that allow you to query and evaluate a cell range that is structured like a
database.
Database functions expect the following syntax:
FUNCTION_NAME(DatabaseArea, Column, CriteriaArea)
For example, the DSUM function returns the sum of all cells in the DatabaseArea cell range that are in the
specified Column and match the conditions defined in the CriteriaArea cell range.
To utilize database functions, proceed as follows:
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Creating a database area
A database area can be any cell range containing data to evaluate.
It has to be structured as follows:
¡ Its first row must contain labels for the database columns (e.g., Amount, Price, etc.).
¡ The data has to be arranged row by row (one row for each record).
The rows of the database area represent what is called a record in database applications, with the cells being the
fields of the database.

Creating a criteria area
The criteria area is a cell range containing conditions that the database records have to match.
It has to be structured as follows:
¡ Important: The criteria area has to be located above the database area.
¡ The criteria area must not overlap the database area.
¡ Like the database area, the first row of the criteria area must also contain labels for the columns below (e.g.,
Amount, Price, etc.).
¡ Below the labels, conditions can be entered. You can enter either single values or comparisons like ">42" or
"<=10".
¡ If multiple conditions have been entered in the same row, the database contents have to match the conditions
in column 1 and column 2 and column 3, etc.
¡ If multiple rows with conditions have been entered, the database contents have to match the conditions in
row 1 or row 2 or row 3, etc.

Utilizing database functions
After having filled out database area and criteria area, you are ready to apply database functions.
Some examples, assuming that the following spreadsheet has been created:
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In this spreadsheet, for example, the following calculations can be performed:
DCOUNT(A11:C16, , A2:A3) returns 2. This formula counts the number of records matching the condition
Color = blue.
DCOUNT(A11:C16, , A6:B7) returns 3. This formula counts the number of records matching the condition
(Amount > 25 and Amount < 75).
DCOUNT(A11:C16, , A6:C8) returns 4. This formula counts the number of records matching the condition
(Amount > 25 and Amount < 75) or (Color = red).
DSUM(A11:C16, "Amount", A2:A3) returns 150. This formula calculates the sum of the values in the
"Amount" column for all records matching the condition Color = blue.
DSUM(A11:C16, 1, A2:A3) returns 150. Same as above, except that the column was specified by its relative
number instead of its label.

Functions from A to Z
This section provides an alphabetical list of PlanMaker's arithmetic functions, including comprehensive
descriptions of each function.
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ABS (absolute value)
Syntax:

ABS(Number)
Description:

Returns the absolute value of a number, i.e., removes its sign.
Example:

ABS(42) returns 42
ABS(0) returns 0
ABS(-42) returns 42
See also:

SIGN, NEG

ACOS (arccosine)
Syntax:

ACOS(Number)
Description:

Returns the arccosine of Number, i.e., the angle whose cosine is Number.
Number must be in the range -1 to 1.
Example:

ACOS(1) returns 0
ACOS(COS(0.1234)) returns 0.1234
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Tip:

You can use the DEGREES function to convert the result from radians to degrees.
See also:

COS, ASIN, ATAN

ACOSH (inverse hyperbolic cosine)
Syntax:

ACOSH(Number)
Description:

Returns the inverse hyperbolic cosine of Number, i.e., the value whose hyperbolic cosine is Number.
Example:

ACOSH(1.1) returns 0.44357
ACOSH(COSH(0.1234)) returns 0.1234
See also:

COSH

ACOT (arccotangent)
Syntax:

ACOT(Number)
Description:

Returns the arccotangent of Number, i.e., the angle whose cotangent is Number.
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Example:

ACOT(1) returns 0.7854 (45°)
ACOT(COT(0.1234)) returns 0.1234
Tip:

You can use the DEGREES function to convert the result from radians to degrees.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
See also:

COT

ACOTH (inverse arccotangent)
Syntax:

ACOTH(Number)
Description:

Returns the inverse arccotangent of Number, i.e., the value whose hyperbolic tangent is Number.
Example:

ACOTH(2) returns 0.54931
ACOTH(COTH(0.1234)) returns 0.1234
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
See also:

COTH
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ADDRESS (cell address as text)
Syntax:

ADDRESS(Row, Column [, Abs] [, Mode] [, SheetName])
Description:

Returns a text string containing the address of the cell in the specified Row and Column.
Row is the row number of the cell.
Column is the column number of the cell.
The optional argument Abs specifies the type of reference to be returned:
1 or omitted: Absolute row and column
2: Absolute row, relative column
3: Relative row, absolute column
4: Relative row and column
The optional argument Mode specifies the format of the cell address returned:
TRUE or omitted: Normal cell address (e.g. A1)
FALSE: Cell address in R1C1 format (an alternative type of cell addressing, supported by Microsoft Excel
only)
The optional argument SheetName lets you specify a worksheet name. If specified, it will be placed before the
resulting cell reference. In other words:
If it is not specified, only the cell address will be returned.
If it is specified, SheetName!Address will be returned (see example).
Example:

ADDRESS(1, 5) returns $E$1
ADDRESS(1, 5, 4) returns E1
ADDRESS(1, 5, 4, , "MySheet1") returns MySheet1!E1
See also:

INDIRECT, OFFSET, COLUMN, ROW
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AND (logical AND function)
Syntax:

AND(Value1 [, Value2, Value3 ...])
Description:

Returns the logical value TRUE if all of the given arguments are TRUE, otherwise returns FALSE.
Example:

AND(TRUE, TRUE) returns TRUE
AND(TRUE, FALSE) returns FALSE
AND(FALSE, FALSE) returns FALSE
AND(A1>0, A1<1) returns TRUE, if A1 is greater than zero and less than one.
See also:

OR, XOR, NOT

AREAS (number of areas)
Syntax:

AREAS(Reference)
Description:

Returns the number of contiguous cell ranges the specified cell reference consists of.
Example:

AREAS(A1:B2) returns 1
AREAS((A1:B2, E5:G7)) returns 2
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See also:

INDEX, COLUMNS, ROWS

ASIN (arcsine)
Syntax:

ASIN(Number)
Description:

Returns the arcsine of Number, i.e., the angle whose sine is Number.
Number must be in the range -1 to 1.
Example:

ASIN(1) returns 1.5708... (90°)
ASIN(SIN(0.1234)) returns 0.1234
Tip:

You can use the DEGREES function to convert the result from radians to degrees.
See also:

SIN, ACOS, ATAN

ASINH (inverse hyperbolic sine)
Syntax:

ASINH(Number)
Description:

Returns the inverse hyperbolic sine of Number, i.e., the value whose hyperbolic sine is Number.
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Example:

ASINH(1.1) returns 0.9503
ASINH(SINH(0.1234)) returns 0.1234
See also:

SINH

ATAN (arctangent)
Syntax:

ATAN(Number)
Description:

Returns the arctangent of Number, i.e., the angle whose tangent is Number.
Example:

ATAN(1) returns 0.7854 (45°)
ATAN(TAN(0.1234)) returns 0.1234
Tip:

You can use the DEGREES function to convert the result from radians to degrees.
See also:

ATAN2, TAN, ACOS, ASIN

ATAN2 (arctangent 2)
Syntax:

ATAN2(x, y)
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Description:

Returns the arctangent of the given coordinates, i.e., the angle between the x axis and a line from the origin (0,
0) to a point with the coordinates (x, y).
Example:

ATAN2(1, 1) returns 0.7854 (45°)
Tip:

You can use the DEGREES function to convert the result from radians to degrees.
See also:

ATAN, TAN

ATANH (inverse hyperbolic tangent)
Syntax:

ATANH(Number)
Description:

Returns the inverse hyperbolic tangent of Number, i.e., the value whose hyperbolic tangent is Number.
Number must be > -1 and < 1.
Example:

ATANH(0.5) returns 0.54931
ATANH(TANH(0.1234)) returns 0.1234
See also:

TANH
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AVEDEV (average deviation)
Syntax:

AVEDEV(Number1 [, Number2, Number3 ...])
Description:

Returns the average deviation of the given numbers from their mean.
Number1, Number2, etc., are the numbers to be evaluated. Empty cells, text, and logical values are ignored.
Example:

AVEDEV(2, 2, 2, 2) returns 0
AVEDEV(2, 2, 2, 3) returns 0.375
See also:

DEVSQ, STDEV.S/STDEV, VAR.S/VAR

AVERAGE (arithmetic mean)
Syntax:

AVERAGE(Number1 [, Number2, Number3 ...])
Description:

Returns the arithmetic mean of the given numbers (i.e., their sum divided by their number).
Number1, Number2, etc., are the numbers to be evaluated. Empty cells, text, and logical values are ignored.
Example:

AVERAGE(1, 2, 6) equals (1+2+6) / 3, which is 3.
See also:

AVERAGEA, GEOMEAN, HARMEAN, TRIMMEAN, MEDIAN
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AVERAGEA (arithmetic mean)
Syntax:

AVERAGEA(Value1 [, Value2, Value3 ...])
Description:

Returns the arithmetic mean of the given values (i.e., their sum divided by their number), including logical
values and text.
Value1, Value2, etc., are the values to be evaluated. Empty cells are ignored.
Note:

Unlike the AVERAGE function, AVERAGEA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Example:

AVERAGEA(1, 2, 6) equals (1+2+6) / 3, which is 3.
If the cells A1:A4 contain the values 0, 1, 4, and TRUE:
AVERAGEA(A1:A4) equals (0+1+4+1) / 4, which is 1.5.
See also:

AVERAGE

AVERAGEIF (average if condition is true)
Syntax:

AVERAGEIF(Range, Criterion [, AverageRange])
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Description:

Returns the arithmetic mean of those values in a cell range that fulfill the specified criterion.
Range is the cell range to be evaluated.
Criterion is the criterion that the values in Range have to fulfill to be included.
Use numbers or text (like "42" or "bolts") to obtain the average of all cells that contain that value.
Use conditions (like ">10" or "<=5") to obtain the average of all cells that match the specified condition (see
examples below).
Note: Criteria always have to be surrounded by double quotation marks (").
AverageRange (optional) lets you specify the cell range containing the values to be used for calculating the
average. If omitted, the values in Range will be used.
Compatibility notes:

This function is not supported by the .xls file format (used in Microsoft Excel 2003 and earlier). If you save a
document in this format, all calculations using this function will be replaced by their last result as a fixed value.
Accordingly, if you use this function, you should not save your document in the "Microsoft Excel 97-2003
(.xls)" file format, but choose one of the following formats instead:
¡ "PlanMaker document (.pmdx or .pmd)"
¡ or: "Microsoft Excel 2007-2016 (.xlsx)"
Example:

If the cells A1:A5 contain 1, 2, 3, 2, 1:
AVERAGEIF(A1:A5, "2") returns 2
AVERAGEIF(A1:A5, ">=2") returns (2+3+2)/3, which gives 2.33333
See also:

AVERAGE, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS

AVERAGEIFS (average if conditions are true)
Syntax:

AVERAGEIFS(AverageRange, Range1, Criterion1 [, Range2, Criterion2 ...])
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Description:

Returns the arithmetic mean of those values in a cell range that fulfill all of the specified criteria.
This function is similar to the AVERAGEIF function, but allows you to specify more than just one
range/criterion to be searched
Apart from that, the order of the parameters is different: In AVERAGEIF, AverageRange is the last parameter
– in AVERAGEIFS, it is the first.
AverageRange is the cell range containing the values to be used for calculating the average.
Range1 is the first cell range to be checked for the specified criterion. This range must have the same
dimensions as AverageRange.
Criterion1 is the criterion that the values in Range1 have to fulfill to be included.
Use numbers or text (like "42" or "bolts") to obtain the average of all cells that contain that value.
Use conditions (like ">10" or "<=5") to obtain the average of all cells that match the specified condition (see
examples below).
Note: Criteria always have to be surrounded by double quotation marks (").
Unlike the AVERAGEIF function, AVERAGEIFS allows you to specify more than just one cell range and
criterion to be checked. If you do so, only occurrences where all criteria are fulfilled are included in the
calculation of the average.
Compatibility notes:

This function is not supported by the .xls file format (used in Microsoft Excel 2003 and earlier). If you save a
document in this format, all calculations using this function will be replaced by their last result as a fixed value.
Accordingly, if you use this function, you should not save your document in the "Microsoft Excel 97-2003
(.xls)" file format, but choose one of the following formats instead:
¡ "PlanMaker document (.pmdx or .pmd)"
¡ or: "Microsoft Excel 2007-2016 (.xlsx)"
Example:

AVERAGEIFS(A1:A10, C1:C10, ">1", C1:C10, "<2")
This formula returns the average of only those cells in the cell range A1:A10 where the corresponding cell in
the range C1:C10 is greater than 1 and less than 2.
See also:

AVERAGE, AVERAGEIF, COUNTIF, COUNTIFS, SUMIF, SUMIFS
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B (Compatibility function)
Syntax:

B(n, p, k1 [, k2])
Description:

Returns the probability to get a) exactly k1 successes, or b) between k1 and k2 successes in a binomial
experiment with n independent trials.
n is the number of independent trial runs.
p is the probability of a success for each trial run. Must be > 0 and < 1.
k1 is the lower limit for the number of successes.
k2 (optional) is the upper limit for the number of successes.
Note:

This function was retained only for compatibility with PlanMaker 97. Use of the following Excel-compatible
function is recommended instead:
B(n, p, k1) equals BINOMDIST(k1, n, p, FALSE) or BINOM.DIST(k1, n, p, FALSE)
B(n, p, k1, k2) equals BINOM.DIST.RANGE(n, p, k1, k2)
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
In Excel 2013, a function identical to the B function was introduced: BINOM.DIST.RANGE. PlanMaker
supports this function as well. However, please keep in mind that older versions of Excel (and PlanMaker) do
not know this function.
See also:

BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST
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BASE (convert decimal number to another base)
Syntax:

BASE(Number, Base [, Digits])
Description:

Converts the given decimal number (base 10) to a number with a different base – for example a binary number
(base 2) or a hexadecimal number (base 16).
Note: Please note that the result of this function is a text string – not a number.
Number is the number to be converted. Only positive numbers are allowed.
Base is the target base. Only integers between 2 and 32 are allowed.
The optional argument Digits lets you specify the minimum number of places to be displayed. If omitted,
PlanMaker determines the number of required places automatically. Digits must be a positive integer.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
Example:

BASE(42, 2) returns 101010 (decimal number 42 displayed as binary number)
BASE(42, 2, 8) returns 00101010 (ditto, with the minimum places set to 8)
See also:

DECIMAL, DEC2BIN, DEC2HEX, DEC2OCT

BESSELI (modified Bessel function In(x))
Syntax:

BESSELI(x, n)
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Description:

Returns the modified Bessel function In(x).
x is the value to be evaluated.
n is the order of the Bessel function. Must be > 0.
See also:

BESSELJ, BESSELK, BESSELY

BESSELJ (Bessel function Jn(x))
Syntax:

BESSELJ(x, n)
Description:

Returns the Bessel function Jn(x).
x is the value to be evaluated.
n is the order of the Bessel function. Must be > 0.
See also:

BESSELI, BESSELK, BESSELY

BESSELK (modified Bessel function Kn(x))
Syntax:

BESSELK(x, n)
Description:

Returns the modified Bessel function Kn(x).
x is the value to be evaluated.
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n is the order of the Bessel function. Must be > 0.
See also:

BESSELI, BESSELJ, BESSELY

BESSELY (Bessel function Yn(x))
Syntax:

BESSELY(x, n)
Description:

Returns the Bessel function Yn(x) (also known as the Weber function or the Neumann function).
x is the value to be evaluated.
n is the order of the Bessel function. Must be > 0.
See also:

BESSELI, BESSELJ, BESSELK

BETADIST (beta distribution)
Note: BETADIST is supplemented by the new function BETA.DIST with additional functionality, which is
available in newer versions of Microsoft Excel (2010 or later).

Syntax:

BETADIST(X, Alpha, Beta [, A, B])
Description:

Returns the beta cumulative distribution function.
X is the value to be evaluated. Must be in the range A to B.
Alpha and Beta are shape parameters of the function. They both have to be > 0.
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A and B (optional) are the lower and upper bound to the interval of X. If they are omitted, A is set to 0 and B is
set to 1 (thus leading to a standard cumulative beta distribution).
X must be in the range A to B.
See also:

BETA.DIST, BETA.INV/BETAINV

BETA.DIST (beta distribution)
Syntax:

BETA.DIST(X, Alpha, Beta, Cumulative [, A, B])
Description:

Returns the (cumulative) beta distribution function.
X is the value to be evaluated. Must be in the range A to B.
Alpha and Beta are shape parameters of the function. They both have to be > 0.
Cumulative determines the type of function as a switch: If you enter the value TRUE, the cumulative
distribution function of the beta distribution is calculated. By entering the value FALSE, the density function of
the beta distribution is calculated.
A and B (optional) are the lower and upper bound to the interval of X. If they are omitted, A is set to 0 and B is
set to 1 (thus leading to a standard cumulative beta distribution).
X must be in the range A to B.
Note:

The BETA.DIST function supplements the previous BETADIST function with the additional argument
Cumulative.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

The inverse function is BETA.INV.
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See also:

BETADIST, BETA.INV/BETAINV

BETAINV (percentiles of the beta distribution)
Note: BETAINV is supplemented by the new identical function BETA.INV, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

BETAINV(Probability, Alpha, Beta [, A, B])
Description:

Returns the inverse of the beta cumulative distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be > 0 and £ 1.
Alpha and Beta are shape parameters of the function. They both have to be greater than zero.
A and B (optional) are the lower and upper bound to the interval of X. If they are omitted, A is set to 0 and B is
set to 1 (thus leading to a standard cumulative beta distribution).
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
See also:

BETA.INV, BETA.DIST/BETADIST

BETA.INV (percentiles of the beta distribution)
Syntax:

BETA.INV(Probability, Alpha, Beta [, A, B])
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Description:

Returns the inverse of the beta cumulative distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be > 0 and £ 1.
Alpha and Beta are shape parameters of the function. They both have to be greater than zero.
A and B (optional) are the lower and upper bound to the interval of X. If they are omitted, A is set to 0 and B is
set to 1 (thus leading to a standard cumulative beta distribution).
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

BETA.INV is the inverse function of BETA.DIST.
See also:

BETAINV, BETA.DIST/BETADIST

BIN2DEC (binary number to decimal number)
Syntax:

BIN2DEC(Number)
Description:

Converts the given binary number (base 2) to a decimal number (base 10).
Number is the number to be converted. It must not contain more than 32 places. Negative numbers have to be
transformed to two's complement notation (see last example).
Example:

BIN2DEC("101010") returns 42
BIN2DEC("00101010") returns 42 as well
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BIN2DEC("11111111111111111111111111010110") returns -42
See also:

DEC2BIN, BIN2HEX, BIN2OCT, DECIMAL

BIN2HEX (binary number to hexadecimal number)
Syntax:

BIN2HEX(Number [, Digits])
Description:

Converts the given binary number (base 2) to a hexadecimal number (base 16).
Number is the number to be converted. It must not contain more than 32 places. Negative numbers have to be
transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

BIN2HEX("101010") returns 2A
BIN2HEX("00101010") returns 2A as well
BIN2HEX("11111111111111111111111111010110") returns FFFFFFD6 (negative value)
See also:

HEX2BIN, BIN2DEC, BIN2OCT
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BIN2OCT (binary number to octal number)
Syntax:

BIN2OCT(Number [, Digits])
Description:

Converts the given binary number (base 2) to an octal number (base 8).
Number is the number to be converted. It must not contain more than 32 places. Negative numbers have to be
transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

BIN2OCT("101010") returns 52
BIN2OCT("00101010") returns 52 as well
BIN2OCT("11111111111111111111111111010110") returns 37777777726 (negative value)
See also:

OCT2BIN, BIN2DEC, BIN2HEX

BINOMDIST (binomial distribution)
Note: BINOMDIST is supplemented by the new identical function BINOM.DIST and the completely new
function BINOM.DIST.RANGE which are available in newer versions of Microsoft Excel (2010 or later).

Syntax:

BINOMDIST(k, n, p, Cumulative)
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Description:

Returns the binomial distribution function.
The binomial distribution can be used to determine the probability to get k successes in an experiment with n
independent trials with only two possible outcomes (success or failure) with a fixed probability of p for each
trial.
For example, a coin flip experiment is a binomial experiment (see example below).
k is the number of successes. Must be in the range 0 to n.
n is the number of independent trial runs.
n and k should be integers, digits right of the decimal point were ignored by PlanMaker.
p is the probability of a success for each trial run. Must be in the range 0 to 1.
The logical value Cumulative lets you specify which type of function will be used:
FALSE: BINOMDIST uses the probability density function, which returns the probability that there are exactly
k successes.
TRUE: BINOMDIST uses the cumulative distribution function, which returns the probability that there are at
most k successes.
Example:

When you flip a coin 10 times (n=10), what is the probability that it lands on "heads" (p=50%) exactly 4 times?
BINOMDIST(4, 10, 50%, FALSE) returns 0.20508

=20.5%

What is the probability that it lands on "heads" at most 4 times?
BINOMDIST(4, 10, 50%, TRUE) returns 0.37695.

=37.7%

See also:

BINOM.DIST/BINOM.DIST.RANGE, BINOM.INV/CRITBINOM, B, COMBIN,
NEGBINOM.DIST/NEGBINOMDIST, POISSON.DIST/POISSON

BINOM.DIST (binomial distribution)
Syntax:

BINOM.DIST(k, n, p, Cumulative)
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Description:

Returns the binomial distribution function.
The binomial distribution can be used to determine the probability to get k successes in an experiment with n
independent trials with only two possible outcomes (success or failure) with a fixed probability of p for each
trial.
For example, a coin flip experiment is a binomial experiment (see example below).
k is the number of successes. Must be in the range 0 to n.
n is the number of independent trial runs.
n and k should be integers, digits right of the decimal point were ignored by PlanMaker.
p is the probability of a success for each trial run. Must be in the range 0 to 1.
The logical value Cumulative lets you specify which type of function will be used:
FALSE: BINOM.DIST uses the probability density function, which returns the probability that there are exactly
k successes.
TRUE: BINOM.DIST uses the cumulative distribution function, which returns the probability that there are at
most k successes.
Example:

When you flip a coin 10 times (n=10), what is the probability that it lands on "heads" (p=50%) exactly 4 times?
BINOM.DIST(4, 10, 50%, FALSE) returns 0.20508

=20.5%

What is the probability that it lands on "heads" at most 4 times?
BINOM.DIST(4, 10, 50%, TRUE) returns 0.37695.

=37.7%

Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

BINOMDIST/BINOM.DIST.RANGE, BINOM.INV/CRITBINOM, B, COMBIN,
NEGBINOM.DIST/NEGBINOMDIST, POISSON.DIST/POISSON
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BINOM.DIST.RANGE (binomial distribution)
Syntax:

BINOM.DIST.RANGE(n, p, k1 [,k2])
Description:

Returns the probability of success for a number of trials using a binomial distribution.
n is the number of independent trial runs. Must be > 0
p is the probability of a success for each trial run. Must be in the range 0 to 1. (0=0% ; 1=100%)
k1 is the number of successes. Must be in the range 0 to n.
k2 is optional and returns the probability that the number of successes will fall between k1 and k2. k2 Must be
in the range k1 to n.
n and k1,k2 should be integers, digits right of the decimal point were ignored by PlanMaker.
Annotation:

If the optional argument k2 is omitted, the probability of the exact number of successes is calculated.
Example:

When you flip a coin 10 times (n=10), what is the probability that it lands on "heads" (p=50%) exactly 4 times?
BINOM.DIST.RANGE(10, 50%, 4) returns 0.20508

=20.5%

What is the probability that it lands on "heads" between 4 and 8 times?
BINOM.DIST.RANGE(10, 50%, 4, 8) returns 0.81738 =81.7%
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
See also:

BINOMDIST/BINOM.DIST, BINOM.INV/CRITBINOM, B, COMBIN,
NEGBINOM.DIST/NEGBINOMDIST, POISSON.DIST/POISSON
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BINOM.INV (binomial distribution)
Syntax:

BINOM.INV(n, p, Alpha)
Description:

Returns the smallest value for which the cumulative binomial distribution is greater than or equal to the
criterion value Alpha.
This function is applicable to binomial distributions only (i.e., experiments with only two possible outcomes:
"success" or "failure").
n is the number of independent trial runs.
p is the probability of a success for each trial run. Must be in the range 0 to 1.
Alpha is the criterion value. Must be in the range 0 to 1.
Example:

BINOM.INV(100, 7%, 1%) returns 2
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

CRITBINOM, BINOM.DIST/BINOM.DIST.RANGE/BINOMDIST

CEILING (round up to a multiple of base)
Syntax:

CEILING(Number, Base)
Description:

Rounds Number up (away from zero) to the nearest multiple of Base.
Positive numbers are rounded to the nearest multiple of Base that is larger than Number.
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Negative numbers are rounded to the nearest multiple of Base that is smaller than Number.
Number and Base must have the same sign, otherwise the function returns a #NUM! error value.
Example:

CEILING(42.5, 1) returns 43
CEILING(-42.5, -1) returns -43
CEILING(21, 5) returns 25
CEILING(12.3456, 0.01) returns 12.35
See also:

FLOOR, MROUND, ROUND, TRUNC

CELL (information about a cell)
Syntax:

CELL(Type [, Reference])
Description:

Returns various types of information about a cell.
Type specifies the type of information to return. Type can be one of the following text strings:
Type

Description

"address"

Returns the address of the cell (as a text string).

"col"

Returns the column number of the cell (as a number).

"color"

Returns 1 if the cell uses the number format option Negative numbers in red, or 0 if not.

"contents"

Returns the value stored in the cell.

"filename"

Returns the full path and filename of the document that contains the cell.

"format"

(Not supported. Returns a #N/A error value.)

"parentheses"

(Not supported. Returns a #N/A error value.)

"prefix"

Returns one of the following text strings:
' if the cell contains left-aligned text
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^ if the cell contains centered text
" if the cell contains right-aligned text
\ if the cell contains fill-aligned text
"" if the cell contains anything else
"protect"

Returns 1 if the cell is protected, or 0 if not.

"row"

Returns the row number of the cell.

"type"

Returns one of the following text strings:
b (for blank) if the cell is empty
l (for label) if the cell contains text
v (for value) if the cell contains anything else

"width"

(Not supported. Returns a #N/A error value.)

Reference (optional) is the address of the cell to be evaluated.
If Reference is a range of cells, only the top left cell will be evaluated.
If Reference is omitted, the current cell will be evaluated. (Excel behaves differently, see the note below.)
Compatibility notes:

This function is not fully identical to Microsoft Excel's CELL function. The following restrictions apply:
1. Some types of information are not supported by PlanMaker (see the table above).
2. When the parameter Reference is omitted, PlanMaker evaluates the current cell, whereas Excel evaluates the
cell that was last changed.
Example:

=CELL("row", B5) returns the row number of the cell B5, i.e. 5.
See also:

FILENAME, COLUMN, ROW

CHAR (character from ANSI code)
Syntax:

CHAR(Number)
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Description:

Returns a single character with the specified ANSI code.
Number must be at least 10.
Example:

CHAR(65) returns A
CHAR(32) returns a blank
CHAR(CODE("X") returns X
See also:

CODE

CHIDIST (chi-square distribution)
Note: CHIDIST is supplemented by the new identical function CHISQ.DIST.RT, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

CHIDIST(X, DegreesFreedom)
Description:

Returns the one-tailed probability of the chi-square distribution.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1 and < 10^10.
See also:

CHISQ.DIST.RT, CHISQ.INV.RT/CHIINV, CHISQ.TEST/CHITEST
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CHIINV (percentiles of the chi-square distribution)
Note: CHIINV is supplemented by the new identical function CHISQ.INV.RT, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

CHIINV(Probability, DegreesFreedom)
Description:

Returns the inverse of the right-tailed probability of the chi-square distribution function (i.e., percentiles of
this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1 and < 10^10.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
See also:

CHISQ.INV.RT, CHISQ.DIST.RT/CHIDIST, CHISQ.TEST/CHITEST

CHISQ.DIST.RT (chi-square distribution)
Syntax:

CHISQ.DIST.RT(X, DegreesFreedom)
Description:

Returns the right-tailed probability of the chi-square distribution.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1 and < 10^10.
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Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

CHIDIST, CHISQ.INV.RT/CHIINV, CHISQ.TEST/CHITEST

CHISQ.INV.RT (percentiles of the chi-square distribution)
Syntax:

CHISQ.INV.RT(Probability, DegreesFreedom)
Description:

Returns the inverse of the right-tailed probability of the chi-square distribution function (i.e., percentiles of
this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1 and < 10^10.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

CHIINV, CHISQ.DIST.RT/CHIDIST, CHISQ.TEST/CHITEST
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CHISQ.TEST (chi-square test for independence)
Syntax:

CHISQ.TEST(ObservedValues, ExpectedValues)
Description:

Returns the chi-square test for independence.
ObservedValues are the observed values to be tested against the expected values.
ExpectedValues are the expected values.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

CHITEST, CHISQ.DIST.RT/CHIDIST, CHISQ.INV.RT/CHIINV

CHITEST (chi-square test for independence)
Note: CHITEST is supplemented by the new identical function CHISQ.TEST, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

CHITEST(ObservedValues, ExpectedValues)
Description:

Returns the chi-square test for independence.
ObservedValues are the observed values to be tested against the expected values.
ExpectedValues are the expected values.
See also:

CHISQ.TEST, CHISQ.DIST.RT/CHIDIST, CHISQ.INV.RT/CHIINV
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CHOICE (x>0, x=0, x<0?)
Syntax:

CHOICE(Number, IfGreater [, IfZero, IfLess])
Description:

Returns one of the following values:
IfGreater, if Number is greater than zero.
IfZero, if Number equals zero.
IfLess, if Number is less than zero.
The last two arguments are optional.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

CHOICE(42, "Greater", "Zero", "Smaller") returns Greater
CHOICE(0, "Greater", "Zero", "Smaller") returns Zero
CHOICE(-42, "Greater", "Zero", "Smaller") returns Smaller
See also:

IF

CHOOSE (choose value from list)
Syntax:

CHOOSE(Index, Value1 [, Value2, Value3 ...])
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Description:

Returns the value with the specified index from a list of values.
Index specifies the value to be returned. If Index is 1, the first value will be returned, if Index is 2, the second
value will be returned, and so on.
If Index is smaller than 1 or greater than the total number of values, the function returns a #VALUE! error
value.
Example:

CHOOSE(2, "One", "Two", "Three") returns Two
See also:

INDEX, VLOOKUP, HLOOKUP

CLEAN (remove unprintable characters)
Syntax:

CLEAN(Text)
Description:

Removes all unprintable characters (characters with an ANSI code below 32) from the specified text string.
See also:

TRIM

CODE (ANSI code of a character)
Syntax:

CODE(Text)
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Description:

Returns the ANSI code of the first character in the specified text string.
Example:

CODE("A") returns 65
CODE("Arthur") returns 65 as well
CODE(CHAR(123)) returns 123
CODE("") returns 0
See also:

CHAR

COLUMN (column number of a reference)
Syntax:

COLUMN([Reference])
Description:

Returns the column number(s) of a cell reference:
If Reference is a single cell, the column number of this cell is returned.
If Reference is a range of cells, their column numbers are returned as a horizontal array. Note: In this case, the
formula has to be entered as an array formula (see section Working with arrays).
If Reference is omitted, the column number of the cell that invokes this function is returned.
Example:

COLUMN(D2) returns 4
COLUMN(D2:F4) returns {4,5,6}
COLUMN() returns 3 when you use this calculation in cell C5
See also:

ROW, COLUMNS, CELL, ADDRESS, OFFSET, INDIRECT
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COLUMNS (number of columns in a range)
Syntax:

COLUMNS(Range)
Description:

Returns the number of columns in the specified cell range.
Example:

COLUMNS(A1:D5) returns 4
See also:

ROWS, COLUMN, AREAS

COMBIN (combinations)
Syntax:

COMBIN(n, k)
Description:

Returns the number of combinations of size k in a population of size n.
n is the total number of items. Must be > k.
k is the number of items in each combination. Must be > 0 and < n.
n and k should be integers, digits right of the decimal point are ignored.
Example:

In a lottery called "6 out of 49", 6 balls are picked out of 49 numbered balls. How many combinations are
possible?
COMBIN(49, 6) returns 13983816
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See also:

PERMUT, BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST

COMPLEX (create complex number)
Syntax:

COMPLEX(Real, Imag [, Suffix])
Description:

Creates a complex number x + yi or x + yj out of the given real and imaginary coefficients.
Real is the real coefficient.
Imag is the imaginary coefficient.
Suffix (optional) is the suffix used for the imaginary component:
i or omitted: A complex number of the form x + yi is returned.
j: A complex number of the form x + yj is returned.
Hint:

To enter complex numbers in cells, you can either make use of the COMPLEX function or simply type them in.
For example, the complex number 2+4i can be entered either as =COMPLEX(2, 4) or simply as 2+4i.
The same applies for formulas – except for the fact that complex numbers have to be surrounded by double
quotation marks ("). For example, instead of typing =IMPOWER(COMPLEX(2, 4)), you could also type
=IMPOWER("2+4i").
Example:

COMPLEX(2, 4) returns 2+4i
COMPLEX(2, 4, "i") returns 2+4i as well
COMPLEX(2, 4, "j") returns 2+4j
See also:

IMAGINARY, IMREAL

Formulas and functions

453

CONCATENATE (concatenate text strings)
Syntax:

CONCATENATE(Text1 [, Text2, Text3 ...])
Description:

Combines two or more text strings into one text string.
Annotation:

The & operator does exactly the same: CONCATENATE("Text1", "Text2") is equivalent to "Text1" &
"Text2".
Example:

CONCATENATE("Good ", "Morning") returns Good Morning
CONCATENATE(2, " slices", " of ", "bread") returns 2 slices of bread

CONFIDENCE (confidence interval)
Note: CONFIDENCE is supplemented by the new identical function CONFIDENCE.NORM, which is
available in newer versions of Microsoft Excel (2010 or later).

Syntax:

CONFIDENCE(Alpha, Sigma, n)
Description:

Returns a value that allows you to determine the 1-alpha confidence interval for the population mean of a
distribution.
The 1-alpha confidence interval is a range of values around the sample mean x covering the interval from (x CONFIDENCE) to (x + CONFIDENCE). The probability that this interval contains the population mean is 1Alpha.
Alpha is the significance level to compute the confidence level. Must be in the range 0 to 1.
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For example, if Alpha is 5%, the probability that the population mean is outside the confidence interval is 5%.
The probability that it is inside is 1-Alpha, i.e., 95%. Therefore, 1-alpha is also called the "confidence level".
Sigma is the population standard deviation. Must be > 0.
n is the size of the sample. Must be > 0.
Example:

CONFIDENCE(0.05, 1.6, 65) returns 0.38897
See also:

CONFIDENCE.NORM

CONFIDENCE.NORM (confidence interval)
Syntax:

CONFIDENCE.NORM(Alpha, Sigma, n)
Description:

Returns a value that allows you to determine the 1-alpha confidence interval for the population mean of a
distribution.
The 1-alpha confidence interval is a range of values around the sample mean x covering the interval from (x CONFIDENCE) to (x + CONFIDENCE). The probability that this interval contains the population mean is 1Alpha.
Alpha is the significance level to compute the confidence level. Must be in the range 0 to 1.
For example, if Alpha is 5%, the probability that the population mean is outside the confidence interval is 5%.
The probability that it is inside is 1-Alpha, i.e., 95%. Therefore, 1-alpha is also called the "confidence level".
Sigma is the population standard deviation. Must be > 0.
n is the size of the sample. Must be > 0.
Example:

CONFIDENCE.NORM(0.05, 1.6, 65) returns 0.38897
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.

Formulas and functions

455

See also:

CONFIDENCE

CONVERT (unit conversion)
Syntax:

CONVERT(Number, From, To)
Description:

Converts a number between different measurement systems.
Number is the number to be converted.
From is the unit of Number (see table below).
To is the target unit (see table below).
Both units have to be in the same category. For example, you can convert meters to miles, but of course not to
minutes.
A #N/A error value is displayed if a) From and To are not from the same category, or b) invalid unit codes.
Note: Unit codes are case-sensitive!
The following unit codes are available:
Mass

Code

Gram

g

Slug

sg

Pound (avoirdupois)

lbm

u (atom mass)

u

Ounce (avoirdupois)

ozm

Distance

Code

Meter

m

Statute mile

mi

Nautical mile

Nmi

Inch

in
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Foot

ft

Yard

yd

Ångström

ang

Pica

Pica

Light year*

ly

Parsec (parallax second)*

parsec

* These units are not supported by Microsoft Excel.

Time

Code

Second

sec

Minute

mn

Hour

hr

Day

day

Year**

yr

Fortnight*

ftn

* This unit is not supported by Microsoft Excel.
** Based on a year with 365.25 days

Liquid measure

Code

Liter

l (lower case "L")

Teaspoon

tsp

Tablespoon

tbs

Fluid Ounce

oz

Cup

cup

Pint (U.S.)

pt

Pint (U.K.)

uk_pt

Quart

qt

Gallon

gal

Force

Code

Newton

N

Dyne

dyn

Pound-force

lbf
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Power

Code

Watt

W

HP (Horsepower)

HP

Magnetism

Code

Tesla

T

Gauss

ga

Energy

Code

Joule

J

Erg

e

Thermodynamic calorie

c

IT calorie

cal

Electron volt

eV

Horsepower-hour

HPh

Watt-hour

Wh

Foot-pound force

flb

BTU (British Thermal Unit)

BTU

Pressure

Code

Pascal

Pa

Atmosphere

atm

mm of Mercury

mmHg

Temperature

Code

Degree Fahrenheit

F

Degree Celsius

C

Degree Kelvin

K

Additionally, prefixes can be added to metric units, "mg", for instance, stands for milligrams.
The following prefixes are available:
Prefix (and factor)

Code
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Exa (10^18)

E

Peta (10^15)

P

Tera (10^12)

T

Giga (10^9)

G

Mega (10^6)

M

Kilo (1000)

k

Hecto (100)

h

Deka (10)

e

Deci (0.1)

d

Centi (0.01)

c

Milli (0.001)

m

Micro (10^-6)

u

Nano (10^-9)

n

Pico (10^-12)

p

Femto (10^-15)

f

Atto (10^-18)

a

Example:

CONVERT(1, "day", "sec") returns 86400 (days -> seconds)
CONVERT(1, "mi", "km") returns 1.60934 (miles -> kilometers)
CONVERT(100, "kW", "HP") returns 134.10201 (100 kW -> HP)
CONVERT(1, "aparsec", "cm") returns 3.08568 (Attoparsec -> cm)

CORREL (correlation coefficient)
Syntax:

CORREL(Range1, Range2)
Description:

Returns the correlation coefficient of two data sets.
The correlation coefficient is a measure of the relationship between two data sets.
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Range1 and Range2 are references to the two cell ranges containing the two data sets. Empty cells and logical
values are ignored.
Range1 and Range2 must have the same number of values, otherwise the function returns a #N/A error value.
Example:

If A1:A3 contains the values 2, 5, 3 and B1:B3 contains 2, 7, 4:
CORREL(A1:A3, B1:B3) returns 0.99718
See also:

FISHER, FISHERINV, COVARIANCE.P/COVARIANCE.S/COVAR

COS (cosine)
Syntax:

COS(Number)
Description:

Returns the cosine of Number.
Tip:

You can use the RADIANS function to convert an angle given in degrees into radians.
Example:

COS(PI()) returns -1
COS(RADIANS(180)) returns -1
See also:

ACOS, SIN, TAN
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COSH (hyperbolic cosine)
Syntax:

COSH(Number)
Description:

Returns the hyperbolic cosine of Number.
Example:

COSH(0.1) returns 1.005
See also:

ACOSH, SINH, TANH

COT (cotangent)
Syntax:

COT(Number)
Description:

Returns the cotangent of Number.
Tip:

You can use the RADIANS function to convert an angle given in degrees into radians.
Example:

COT(PI()/4) returns 1
COT(RADIANS(45)) returns 1
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Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
See also:

TAN, ACOT

COTH (hyperbolic cotangent)
Syntax:

COTH(Number)
Description:

Returns the hyperbolic cotangent of Number.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
Example:

COTH(0.45) returns 2.37024
See also:

ACOTH, TANH

COUNT (number of cells filled with numbers)
Syntax:

COUNT(Range1 [, Range2, Range3 ...])
Description:

Counts the number of cells containing numbers.
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This functions counts only cells with numbers (including dates) and text representing a number. To count cells
with any content, use the COUNTA function instead
Example:

If the cells A1:A3 contain 42, "Test", and TRUE and cell A4 is empty:
COUNT(A1:A4) returns 1
See also:

COUNTA, COUNTBLANK, COUNTP, FREQUENCY, ISBLANK, ISNUMBER, COUNTIF, COUNTIFS

COUNTA (number of cells filled)
Syntax:

COUNTA(Range1 [, Range2, Range3 ...])
Description:

Counts the number of cells containing any kind of value (i.e., cells that are not empty).
Example:

If the cells A1:A3 contain 42, "Test", and TRUE and cell A4 is empty:
COUNTA(A1:A4) returns 3
Hint:

The COUNT function works similarly, but only counts cells with numbers.
See also:

COUNT, ISBLANK
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COUNTBLANK (number of empty cells)
Syntax:

COUNTBLANK(Range)
Description:

Counts the number of cells in a cell range that are empty.
Example:

If the cells A1:A3 contain 42, "Test", and TRUE and cell A4 is empty:
COUNTBLANK(A1:A4) returns 1
See also:

ISBLANK, COUNT

COUNTIF (count if condition is true)
Syntax:

COUNTIF(Range, Criterion)
Description:

Counts those cells in a cell range that fulfill the specified criterion.
Range is the cell range to be evaluated.
Criterion is the criterion that the values in Range have to fulfill to be included.
Use numbers or text (like "42" or "bolts") to count all cells that contain that value.
Hint: To count all non-empty cells, use "*" as criterion. For example COUNTIF(D2:D4, "*") counts all cells in
the specified area that are not empty.
Use conditions (like ">10" or "<=5") to count all cells that match the specified condition (see examples below).
Note: Criteria always have to be surrounded by double quotation marks (").
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Example:

If the cells A1:A5 contain 1, 2, 3, 2, 1:
COUNTIF(A1:A5, "2") returns 2
COUNTIF(A1:A5, ">=2") returns 3
See also:

AVERAGEIF, AVERAGEIFS, COUNT, COUNTIFS, SUMIF, SUMIFS

COUNTIFS (count if conditions are true)
Syntax:

COUNTIFS(Range1, Criterion1 [, Range2, Criterion2 ...])
Description:

Applies criteria to the cells in the specified cell ranges and counts how often all of these criteria are fulfilled.
This function is similar to the COUNTIF function, but allows you to specify more than just one range/criterion
to be searched
Range1 is the first cell range to be checked for a criterion. Please note that all of the cell ranges specified must
have the same dimensions.
Criterion1 is the criterion that the values in Range1 have to fulfill.
Use numbers or text (like "42" or "bolts") to check if the cell contains a certain value.
Use conditions (like ">10" or "<=5") to check if the cell matches a certain condition.
Note: Criteria always have to be surrounded by double quotation marks (").
Unlike the COUNTIF function, COUNTIFS allows you to specify more than just one cell range and criterion to
be checked. If you do so, the function counts only occurrences where all criteria are fulfilled.
Compatibility notes:

This function is not supported by the .xls file format (used in Microsoft Excel 2003 and earlier). If you save a
document in this format, all calculations using this function will be replaced by their last result as a fixed value.
Accordingly, if you use this function, you should not save your document in the "Microsoft Excel 97-2003
(.xls)" file format, but choose one of the following formats instead:
¡ "PlanMaker document (.pmdx or .pmd)"
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¡ or: "Microsoft Excel 2007-2016 (.xlsx)"
Example:

COUNTIFS(C1:C10, ">1", C1:C10, "<2")
This formula counts how many cells in the cell range C1:C10 are greater than 1 and less than 2.
COUNTIFS(A1:D4, "tuna", G10:K14, ">500")
This formula counts how often the following conditions are met: The cell in A1:D4 contains "tuna" and the
corresponding cell in G10:K14 contains a value greater than 500.
See also:

AVERAGEIF, AVERAGEIFS, COUNT, COUNTIF, SUMIF, SUMIFS

COUNTP (PlanMaker 97 compatibility function)
Syntax:

COUNTP(Range1 [, Range2, Range3 ...])
Description:

Counts the number of cells containing numbers or logical values.
Note:

This function was retained only for compatibility with PlanMaker 97. Using the Excel-compatible functions
COUNT or COUNTA is recommended instead.
The difference between these three functions is:
COUNTA counts all cells that are not empty.
COUNT counts only cells that contain numbers.
COUNTP counts only cells that contain numbers or logical values.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
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Example:

If the cells A1:A3 contain 42, "Test", and TRUE and cell A4 is empty:
COUNTA(A1:A4) returns 3
COUNT(A1:A4) returns 1
COUNTP(A1:A4) returns 2
See also:

COUNT, COUNTA

COVAR (Covariance population)
Note: COVAR is supplemented by the new identical function COVARIANCE.P (population covariance) and
the completely new function COVARIANCE.S (sample covariance), which are available in newer versions
of Microsoft Excel (2010 or later).

Syntax:

COVAR(Range1, Range2)
Description:

Returns the population covariance of two data sets.
The covariance is the average of the products of the deviations for each pair of values. It can be used to
determine the extent to which two data sets vary ("co-vary").
Range1 and Range2 are references to the two cell ranges containing the two data sets. Empty cells, text, and
logical values are ignored.
Range1 and Range2 must have the same number of values, otherwise the function returns a #N/A error value.
Example:

If A1:A3 contains the values 2, 5, 3 and B1:B3 contains 2, 7, 4:
COVAR(A1:A3, B1:B3) returns 2.55556
See also:

COVARIANCE.P/COVARIANCE.S, CORREL, FISHER, FISHERINV
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COVARIANCE.P (Covariance population)
Syntax:

COVARIANCE.P(Range1, Range2)
Description:

Returns the population covariance of two data sets.
The covariance is the average of the products of the deviations for each pair of values. It can be used to
determine the extent to which two data sets vary ("co-vary").
Range1 and Range2 are references to the two cell ranges containing the two data sets. Empty cells, text, and
logical values are ignored.
Range1 and Range2 must have the same number of values, otherwise the function returns a #N/A error value.
Example:

If A1:A3 contains the values 2, 5, 3 and B1:B3 contains 2, 7, 4:
COVARIANCE.P(A1:A3, B1:B3) returns 2.55556
Note:

The COVARIANCE.P function supplements together with COVARIANCE.S the previous COVAR function,
whereby COVARIANCE.P, just like COVAR, returns the population covariance and COVARIANCE.S the
sample covariance.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

COVARIANCE.S/COVAR, CORREL, FISHER, FISHERINV
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COVARIANCE.S (Covariance sample)
Syntax:

COVARIANCE.S(Range1, Range2)
Description:

Returns the sample covariance of two data sets.
The covariance is the average of the products of the deviations for each pair of values. It can be used to
determine the extent to which two data sets vary ("co-vary").
Range1 and Range2 are references to the two cell ranges containing the two data sets. Empty cells, text, and
logical values are ignored.
Range1 and Range2 must have the same number of values, otherwise the function returns a #N/A error value.
Example:

If A1:A3 contains the values 2, 5, 3 and B1:B3 contains 2, 7, 4:
COVARIANCE.S(A1:A3, B1:B3) returns 3.83333
Note:

The COVARIANCE.S function supplements together with COVARIANCE.P the previous COVAR function,
whereby COVARIANCE.S returns the sample covariance and COVARIANCE.P, just like KOVAR, the
population covariance.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

COVARIANCE.P/COVAR, CORREL, FISHER, FISHERINV
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CREATEDATE (date the document was created)
Syntax:

CREATEDATE()
Description:

Returns the date/time the current document was created.
Example:

In a document created on the 24th of August, 2018 at 9:03 AM:
CREATEDATE() returns 08/24/18 9:03 AM
Note: To change the format of the resulting date, choose the Format > Cell menu command and select the
desired date format (e.g., date only, date and time, or time only).
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

NOW, TODAY

CRITBINOM (binomial distribution)
Note: CRITBINOM is supplemented by the new identical function BINOM.INV, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

CRITBINOM(n, p, Alpha)
Description:

Returns the smallest value for which the cumulative binomial distribution is greater than or equal to the
criterion value Alpha.
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This function is applicable to binomial distributions only (i.e., experiments with only two possible outcomes:
"success" or "failure").
n is the number of independent trial runs.
p is the probability of a success for each trial run. Must be in the range 0 to 1.
Alpha is the criterion value. Must be in the range 0 to 1.
Example:

CRITBINOM(100, 7%, 1%) returns 2
See also:

BINOM.INV, BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST

CUMIPMT (cumulative interest)
Syntax:

CUMIPMT(Rate, NPer, PV, P1, P2, Type)
Description:

Returns the cumulative interest payments between period P1 and period P2. This function is applicable to loans
with periodic constant payments, and a constant interest rate.
Rate is the interest rate (per payment period).
NPer is the total number of payment periods.
PV is the present value (the loan amount).
P1 and P2 define the time interval to be evaluated. P1 is the first period, and P2 is the last.
Type is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
Example:

Loan terms: $100,000 at 10% per year, to be repaid over 72 months with monthly payments at the end of each
month.
How much interest has to be paid in the periods (= months) 24 through 36?
CUMIPMT(10%/12, 6*12, 100000, 24, 36, 0) returns -7219.88.
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Note that all values have to use the same time unit, months in this case, since the payments are made monthly.
Therefore, in the above formula, the yearly interest rate had to be divided by 12 to get the monthly interest rate.
See also:

CUMPRINC, PPMT, IPMT, PMT

CUMPRINC (cumulative principal)
Syntax:

CUMPRINC(Rate, NPer, PV, P1, P2, Type)
Description:

Returns the cumulative principal payments between period P1 and period P2. This function is applicable to
loans with periodic constant payments, and a constant interest rate.
Rate is the interest rate (per payment period).
NPer is the total number of payment periods.
PV is the present value (the loan amount).
P1 and P2 define the time interval to be evaluated. P1 is the first period, and P2 is the last.
Type is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
Example:

Loan terms: $100,000 at 10% per year, to be repaid over 72 months with monthly payments at the end of each
month.
How much principal has to be paid in the periods (= months) 24 through 36?
CUMPRINC(10%/12, 6*12, 100000, 24, 36, 0) returns -16863.71.
Note that all values have to use the same time unit, months in this case, since the payments are made monthly.
Therefore, in the above formula, the yearly interest rate had to be divided by 12 to get the monthly interest rate.
See also:

CUMIPMT, PPMT, IPMT, PMT
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CURRENCY (format number as currency)
Syntax:

CURRENCY(Number [, n])
Description:

Returns a text string containing Number formatted in currency format and rounded to n decimal places.
The currency symbol applied depends on your computer's language settings. For example, in the U.S. a dollar
sign $ is applied, in Germany, a euro sign € is applied, etc.
Number is the number to be converted.
n (optional) is the number of decimal places. If n is omitted, Number is rounded to two places.
If n is a negative value, Number is rounded to the left of the decimal point. For example, if n is -2, Number is
rounded to the nearest multiple of hundred (see last example).
Annotation:

Please keep in mind that the result of this function is a text string. To round a number without converting it to a
text string, use one of the round functions (e.g., ROUND) instead
Alternatively, you can let PlanMaker display a number rounded and formatted as a currency by applying one of
the currency formats to the number (using the Format > Cell menu command).
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

CURRENCY(123.456) returns the text string $123.46
CURRENCY(123.456, 2) returns the text string $123.46
CURRENCY(123.456, -2) returns the text string $100
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DATE (create a date value)
Syntax:

DATE(Year, Month, Day)
Description:

Returns a date created out of the specified Year, Month, and Day.
Example:

DATE(2018, 9, 25) returns the date 09/25/2018
See also:

DATEVALUE, TIME, TIMEVALUE

DATEDIF (date difference)
Syntax:

DATEDIF(StartDate, EndDate, Mode)
Description:

Returns the number of days, months, or years between two dates.
StartDate and EndDate are the two dates to be evaluated. StartDate must be less (i.e., earlier) than EndDate.
Mode lets you specify the kind of value to be returned:
"y"

Number of years between StartDate and EndDate

"m"

Number of months between StartDate and EndDate

"d"

Number of days between StartDate and EndDate

"ym"

Number of months, excluding years (as if StartDate and EndDate were in the same year)

"yd"

Number of days, excluding years (as if StartDate and EndDate were in the same year)
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Number of months, excluding month and years (as if StartDate and EndDate were in the same month and year)

Note:

This function is an undocumented Excel function. It still exists in Microsoft Excel, but has been removed from
Excel's help file and therefore seems to be no longer officially supported.
Example:

To calculate the age of a person, enter the date of birth in cell A1 (e.g. 4/3/1970). In A2, enter the current date
(e.g. 6/8/2012). Then, use any of the following calculations:
Age in years:
DATEDIF(A1, A2, "y") returns 42 (years)
Age in months:
DATEDIF(A1, A2, "m") returns 506 (months)
Age in days:
DATEDIF(A1, A2, "d") returns 15407 (days)
Age in years, months and days:
DATEDIF(A1, A2, "y") returns 42 (years)
DATEDIF(A1, A2, "ym") returns 2 (months)
DATEDIF(A1, A2, "md") returns 5 (days)
(Accordingly, the person's age is 42 years, 2 months, and 5 days.)
See also:

NOW, NETWORKDAYS, DAYS/DAYSP

DATEVALUE (convert text into date value)
Syntax:

DATEVALUE(Text)
Description:

Converts a text string representing a date to a serial date value.
Note:

This function was retained only for compatibility with older spreadsheet applications. It is no longer commonly
used, as current spreadsheet applications (including PlanMaker) automatically convert text representing a date
to a serial date value, where necessary.
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Example:

DATEVALUE("09/25/2013") returns 41542.
See also:

TIMEVALUE, DATE, TIME

DAVERAGE (database function)
Syntax:

DAVERAGE(DatabaseArea, Column, CriteriaArea)
Description:

Returns the average of those values in a column of a database area that match the conditions specified in the
criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

AVERAGE, DPRODUCT, DSUM

DAY (day of a date)
Syntax:

DAY(Date)
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Description:

Returns the day of a date.
Example:

DAY("09/25/2018") returns 25
See also:

WEEKDAY, ISOWEEK, ISOWEEKNUM, WEEKNUM, MONTH, YEAR

DAYS (days between two dates)
Syntax:

DAYS(EndDate, StartDate)
Description:

Returns the number of days between two dates.
Please note the order of the parameters: The end date has to be specified first, the start date second.
Note:

This function was revised in PlanMaker 2016: The order of its two parameters was swapped.
Background information: The DAYS function has been available in PlanMaker since a long time, whereas
Excel did not have it implemented. In Excel 2013, a function with the same name was added. It returns exactly
the same results – however, the order of its parameters is different: first the end date, then the start date. In
order to be compatible with Excel, the parameter order was swapped in PlanMaker 2016.
The previous version of the function was renamed to DAYSP Thus, the functions DAYS and DAYSP are
identical, only the order of their parameters differs:
DAYS(EndDate, StartDate) equals
DAYSP(StartDate, EndDate)
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
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Example:

DAYS("01/14/2018", "01/01/2018") returns 13
See also:

DAYSP, DATEDIF, NETWORKDAYS, DAYS360, TIMEDIFF

DAYS360 (days between two dates)
Syntax:

DAYS360(StartDate, EndDate [, Mode])
Description:

Returns the number of days between two dates – based on a year with 360 days (12 months with 30 days each).
StartDate and EndDate are the two dates to be evaluated.
Mode (optional) is a logical value that lets you specify how dates occurring on the 31st of a month should be
evaluated:
FALSE or omitted: The U.S. (NASD) method is used: If StartDate is the 31st of a month, the 30th of the same
month will be used instead. If EndDate is the 31st of a month, the 1st of the following month will be used
instead. Exception: If StartDate and EndDate are the 31st of a month, the 30th of the same month will be used
instead (for both dates).
TRUE: The European method is used: If StartDate or EndDate is the 31st of a month, the 30th of the same
month will be used instead.
Example:

DAYS360("01/01/2018", "02/01/2018") returns 30
DAYS360("02/01/2018", "03/01/2018") returns 30
DAYS360("01/01/2012", "01/01/2013") returns 360
See also:

DATEDIF, NETWORKDAYS, DAYS/DAYSP, TIMEDIFF
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DAYSP (compatibility function)
Syntax:

DAYSP(StartDate, EndDate)
Description:

Compatibility function for older PlanMaker documents.
This function has been replaced by the DAYS function (Please note that DAYS expects its parameters in
reversed order)
See the notes below.
Note:

DAYSP is merely a compatibility function. When you open a document created with PlanMaker 2012 or
earlier, all occurrences of the DAYS function are automatically converted into DAYSP. Reason: In PlanMaker
2016, the parameter order of the DAYS function was swapped.
For new documents, it is recommended to use the Excel 2013 compatible function DAYS instead, which is
identical – except for the order of its parameters:
DAYS(EndDate, StartDate) equals
DAYSP(StartDate, EndDate)
For more details, see the DAYS function.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

DAYSP("01/01/2018", "01/14/2018") returns 13
See also:

DAYS, DATEDIF, NETWORKDAYS, DAYS360, TIMEDIFF
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DAYSPERMONTH (days per month)
Syntax:

DAYSPERMONTH(Date)
Description:

Returns the number of days in the specified month.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

DAYSPERMONTH("09/25/2018") returns 30
DAYSPERMONTH("10/25/2018") returns 31
See also:

DAYSPERYEAR, YEAR, DAYS/DAYSP, DAYS360

DAYSPERYEAR (days per year)
Syntax:

DAYSPERYEAR(Date)
Description:

Returns the number of days in the specified year.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
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Example:

DAYSPERYEAR("01/01/2012") returns 366 (2012 was a leap year)
DAYSPERYEAR("01/01/2013") returns 365 (2013 was not a leap year)
See also:

YEAR, DAYSPERMONTH, DAYS/DAYSP, DAYS360

DB (fixed-declining balance depreciation)
Syntax:

DB(Cost, Salvage, Life, Per [, Months])
Description:

Returns the depreciation of an asset for the specified period, using the fixed-declining balance method.
Cost = Initial cost of asset
Salvage = Salvage value (value at the end of the depreciation)
Life = Life of asset (in number of periods)
Per = Period to evaluate (in the same time unit as Life)
Months (optional) = Number of Months in the first year (12 if omitted)
Example:

Asset parameters: initial cost = 100000, salvage value = 20000, life = 10 years
DB(100000, 20000, 10, 1) returns 14900.00 (depreciation in year 1)
DB(100000, 20000, 10, 2) returns 12679.90 (depreciation in year 2)
etc.
See also:

DDB, SYD, SLN
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DCOUNT (database function)
Syntax:

DCOUNT(DatabaseArea, Column, CriteriaArea)
Description:

Returns the number of those values in a column of a database area that match the conditions specified in the
criteria area.
Only cells containing numbers (including dates) are counted, cells with text or logical values are ignored.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

DCOUNTA

DCOUNTA (database function)
Syntax:

DCOUNTA(DatabaseArea, Column, CriteriaArea)
Description:

Returns the number of those values in a column of a database area that match the conditions specified in the
criteria area.
Unlike the DCOUNT function, DCOUNTA not only counts cells containing numbers but also counts cells with
text or logical values.
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Detailed instructions on the use of database-related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

DCOUNT

DDB (double-declining balance depreciation)
Syntax:

DDB(Cost, Salvage, Life, Per [, Factor])
Description:

Returns the depreciation of an asset for the specified period, using the double-declining balance method (or a
variable-declining balance method, if Factor is specified).
Cost = Initial cost of asset
Salvage = Salvage value (value at the end of the depreciation)
Life = Life of asset (in number of periods)
Per = Period to evaluate (in the same time unit as Life)
Factor (optional) = Rate at which the balance declines (2 if omitted)
Example:

Asset parameters: initial cost = 100000, salvage value = 20000, life = 10 years
DDB(100000, 20000, 10, 1) returns 20000 (depreciation in year 1)
DDB(100000, 20000, 10, 2) returns 16000 (depreciation in year 2)
etc.
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See also:

DB, SYD, SLN

DEC2BIN (decimal number to binary number)
Syntax:

DEC2BIN(Number [, Digits])
Description:

Converts the given decimal number (base 10) to a binary number (base 2).
Note: Please note that the result of this function is a text string – not a number.
Number is the number to be converted. It must be in the range -(2^31) to (2^31)-1. Negative numbers have to
be transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

DEC2BIN(42) returns 101010
DEC2BIN(42, 8) returns 00101010
DEC2BIN(42, 4) returns the error value #NUM! because the number 42 cannot be represented with fewer than
6 binary digits
DEC2BIN(-42) returns 11111111111111111111111111010110
See also:

BIN2DEC, DEC2HEX, DEC2OCT, BASE
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DEC2HEX (decimal number to hexadecimal number)
Syntax:

DEC2HEX(Number [, Digits])
Description:

Converts the given decimal number (base 10) to a hexadecimal number (base 16).
Note: Please note that the result of this function is a text string – not a number.
Number is the number to be converted. It must be in the range -(2^31) to (2^31)-1. Negative numbers have to
be transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

DEC2HEX(42) returns 2A
DEC2HEX(42, 8) returns 0000002A
DEC2HEX(42, 1) returns the error value #NUM! because the number 42 cannot be represented with fewer than
2 hexadecimal digits
DEC2HEX(-42) returns FFFFFFD6
See also:

HEX2DEC, DEC2BIN, DEC2OCT, BASE

DEC2OCT (decimal number to octal number)
Syntax:

DEC2OCT(Number [, Digits])
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Description:

Converts the given decimal number (base 10) to an octal number (base 8).
Note: Please note that the result of this function is a text string – not a number.
Number is the number to be converted. It must be in the range -(2^31) to (2^31)-1. Negative numbers have to
be transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

DEC2OCT(42) returns 52
DEC2OCT(42, 8) returns 00000052
DEC2OCT(42, 1) returns the error value #NUM! because the number 42 cannot be represented with fewer than
2 octal digits
DEC2OCT(-42) returns 37777777726
See also:

OCT2DEC, DEC2BIN, DEC2HEX, BASE

DECIBEL (decibel value of two quantities)
Syntax:

DECIBEL(P2 [, P1])
Description:

Returns the decibel value (dB) for the ratio of two quantities.
The calculation is based on the following formula:
DECIBEL(P2, P1) = 10 * LOG10(P2/P1)
Note the order of the two parameters: The dividend P2 of the quotient has to be specified first, the divisor P1
second – not vice versa.
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P2 and P1 have to be numbers. Their quotient has to be greater than zero.
The parameter P1 is optional. If it is not specified, PlanMaker sets it to 1 (one) automatically.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

DECIBEL(1000, 10) returns 20

DECIMAL (convert number from any base to decimal)
Syntax:

DECIMAL(Number, Base)
Description:

Converts a number from any base to decimal (base 10) – for example a binary number (base 2) or a
hexadecimal number (base 16).
Number is the number to be converted.
Base is the base of the number. Only integers between 2 and 32 are allowed.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
Example:

DECIMAL("00101010", 2) returns 42
DECIMAL("FF", 16) returns 255
See also:

BASE, BIN2DEC, HEX2DEC, OCT2DEC

Formulas and functions

487

DECIMALS (fractional part of a number)
Syntax:

DECIMALS(Number)
Description:

Returns the fractional part of the given number (i.e., the digits to the right of the decimal point).
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

DECIMALS(5.779) returns 0.779
Hint:

To obtain the places before the decimal point use the TRUNC function.
See also:

TRUNC

DEGREES (convert radians to degrees)
Syntax:

DEGREES(Number)
Description:

Converts radians into degrees.
The following conversion formula is used:
DEGREES(x) = x * 180 / PI()
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Example:

DEGREES(PI()) returns 180
See also:

RADIANS

DELTA (test for equality)
Syntax:

DELTA(Number1, Number2)
Description:

Tests if two values are equal. If they are, 1 is returned, otherwise 0 is returned.
Number1 and Number2 have to be numbers or text strings representing numbers, otherwise a #VALUE! error
value is returned.
Example:

DELTA(1, 2) returns 0
DELTA(2, 2) returns 1
DELTA(2, "2") returns 1
DELTA("Text", "Text") returns a #VALUE! error value
See also:

EXACT

DEVSQ (average square deviation)
Syntax:

DEVSQ(Number1 [, Number2, Number3 ...])
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Description:

Returns the sum of squares of deviations of the specified numbers from their sample mean.
Empty cells, text strings, and logical values are ignored.
Example:

DEVSQ(2, 2, 2, 3) returns 0.75
See also:

AVEDEV, STDEV.S/STDEV, SUM, VAR.S/VAR

DGET (database function)
Syntax:

DGET(DatabaseArea, Column, CriteriaArea)
Description:

Returns the value in a column of a database area that matches the given criteria.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
Note:

If more than one value matches the specified criteria, the function returns a #NUM! error value.
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DMAX (database function)
Syntax:

DMAX(DatabaseArea, Column, CriteriaArea)
Description:

Returns the largest of those values in a column of a database area that match the conditions specified in the
criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

MAX, DMIN

DMIN (database function)
Syntax:

DMIN(DatabaseArea, Column, CriteriaArea)
Description:

Returns the smallest of those values in a column of a database area that match the conditions specified in the
criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
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Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

MIN, DMAX

DOLLARDE (dollar price, decimal)
Syntax:

DOLLARDE(Value, Divisor)
Description:

Converts a dollar price, expressed as a fraction, into a decimal dollar price.
Value is the number to be converted.
Divisor is the denominator of the fraction. It must be greater than or equal to 1. Divisor should be an integer,
digits right of the decimal point are ignored.
Example:

DOLLARDE(27.4, 8) converts the fraction 27 4/8 into the decimal value 27.5.
See also:

DOLLARFR

DOLLARFR (dollar price, fraction)
Syntax:

DOLLARFR(Value, Divisor)

Formulas and functions

492

Description:

Converts a decimal dollar price into a dollar price expressed as a fraction.
Value is the number to be converted.
Divisor is the denominator of the fraction. It must be greater than or equal to 1. Divisor should be an integer,
digits right of the decimal point are ignored.
Example:

DOLLARFR(27.5, 8) returns 27.4 (since 27.5 equals the fraction 27 4/8)
See also:

DOLLARDE

DPRODUCT (database function)
Syntax:

DPRODUCT(DatabaseArea, Column, CriteriaArea)
Description:

Returns the product of those values in a column of a database area that match the conditions specified in the
criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

PRODUCT, DAVERAGE, DSUM
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DSTDEV (database function)
Syntax:

DSTDEV(DatabaseArea, Column, CriteriaArea)
Description:

Estimates the standard deviation of a population based on a sample, using those values in a column of a
database area that match the conditions specified in the criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

STDEV.P/STDEVP, DSTDEVP

DSTDEVP (database function)
Syntax:

DSTDEVP(DatabaseArea, Column, CriteriaArea)
Description:

Calculates the standard deviation of a population based on the entire population, using those values in a column
of a database area that match the conditions specified in the criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
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Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

STDEV.S/STDEV, DSTDEV

DSUM (database function)
Syntax:

DSUM(DatabaseArea, Column, CriteriaArea)
Description:

Returns the sum of those values in a column of a database area that match the conditions specified in the
criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (Amount, Price, etc.).
See also:

SUM, DAVERAGE, DSUM

DVAR (database function)
Syntax:

DVAR(DatabaseArea, Column, CriteriaArea)
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Description:

Estimates the variance of a population based on a sample, using those values in a column of a database area that
match the conditions specified in the criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (e.g., Amount, Price, etc.).
See also:

VAR.S/VAR, DVARP

DVARP (database function)
Syntax:

DVARP(DatabaseArea, Column, CriteriaArea)
Description:

Calculates the variance of a population based on the entire population, using those values in a column of a
database area that match the conditions specified in the criteria area.
Detailed instructions on the use of database related functions are available in section Working with database
functions.
DatabaseArea is a cell range containing the database to be evaluated. The first row of DatabaseArea must
contain labels for the database columns (e.g., Amount, Price, etc.).
Column is the desired column of the database area. You can specify Column by its relative column number or
by its column label in double quotation marks (e.g., "Amount", "Price", etc.).
CriteriaArea is a cell range containing one or more conditions that have to be fulfilled. The first row of
CriteriaArea has to contain column labels (Amount, Price, etc.).
See also:

VAR.P/VARP, DVAR
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EDATE (date before/after n months)
Syntax:

EDATE(StartDate, m)
Description:

Returns the date that is m months before/after StartDate.
StartDate is the start date.
m is the number of months.
If m is positive, a date in the future will be returned.
If m is negative, a date in the past will be returned.
Example:

EDATE("03/30/2018", 1) returns 04/30/2018
EDATE("03/31/2018", 1) returns 04/30/2018 as well, because April has just 30 days.
See also:

EOMONTH

EFFECT (effective interest rate)
Syntax:

EFFECT(NomRate, NPerYear)
Description:

Returns the effective annual interest rate, given the nominal annual interest rate and the number of
compounding periods per year.
NomRate is the nominal annual interest rate.
NPerYear is the number of compounding periods per year.
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Example:

To calculate the effective annual interest rate of an investment with a nominal annual interest rate of 5%,
compounded quarterly:
EFFECT(5%, 4) returns approx. 5.09%
See also:

NOMINAL

EOMONTH (end of month in n months)
Syntax:

EOMONTH(StartDate, m)
Description:

Returns the last day of the month that is m months before/after StartDate.
StartDate is the start date.
m is the number of months.
If m is positive, a date in the future will be returned.
If m is negative, a date in the past will be returned.
If m is zero, the last day of the current month will be returned.
Example:

EOMONTH("09/25/2018", 0) returns 09/30/2018
EOMONTH("09/25/2018", 1) returns 10/31/2018
EOMONTH("09/25/2018", -1) returns 08/31/2018
See also:

EDATE
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ERF (Gaussian error function)
Syntax:

ERF(LowerLimit [, UpperLimit])
Description:

Return the Gaussian error function.
LowerLimit is the lower bound for the integral.
UpperLimit (optional) is the upper bound for the integral. If omitted, the integral between zero and
LowerLimit will be returned.
See also:

ERFC

ERFC (complement of Gaussian error function)
Syntax:

ERFC(LowerLimit)
Description:

Return the complement to the Gaussian error function.
LowerLimit is the lower bound of the integral. Must be ³ 0.
See also:

ERF

498

Formulas and functions

499

ERROR.TYPE (error type)
Syntax:

ERROR.TYPE(Reference)
Description:

Returns a number representing the type of error value in a cell.
Reference is a reference to a single cell.
Possible results of this function:
Error value in cell

Result

No error value

#N/A

#NULL!

1

#DIV/0!

2

#VALUE!

3

#REF!

4

#NAME?

5

#NUM!

6

#N/A

7

For more details about error values, see section Error values.
Example:

If A1 contains 1/0 and A2 contains 1/1:
ERROR.TYPE(A1) returns 2 (i.e., #DIV/0!)
ERROR.TYPE(A2) returns #N/A (i.e., no error)
The calculation below returns "Error!" if any kind of error occurs in cell A1, otherwise it returns the contents of
A1:
IF(ISNA(ERROR.TYPE(A1)), A1, "Error!")
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See also:

IFERROR, ISERR, ISERROR, ISNA, NA(), TYPE, section Error values

EUROCONVERT (convert EU currencies)
Syntax:

EUROCONVERT(Number, From, To)
Description:

Converts a number from one EU currency to another. Applicable only to currencies of countries that are
members of the EU (European Union) and have adopted the European currency Euro.
This function can perform three types of conversions:
a) Convert a number from one of these currencies to Euros, e.g., French francs to euros.
b) Convert a number from Euros to one of these currencies, e.g. euros to French francs.
c) Convert a number from one of these currencies to another by first converting it to euros and then to the
other currency (a method called "triangulation"), e.g., French francs -> euros -> Spanish pesetas. Note: This
method can lead to rounding errors of up to 0.01.
Number is the number to be converted.
From and To are codes representing the source and target currency (see table below). Use either PM codes or
ISO codes.
Note: Microsoft Excel only supports ISO codes. If you want to keep your calculations Excel-compatible, make
sure you solely use ISO codes (right column) with this function.
Country

PM code

ISO code

All euro countries (euro)

€

EUR

Austria (schilling)

öS

ATS

Belgium (franc)

BF

BEF

Estonia (kroon)

kr

EEK

Finland (markka)

mk

FIM

France (franc)

F

FRF

Germany (mark)

DM

DEM

Greece (drachma)

Dr

GRD

Ireland (pound)

IR£

IEP
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Italy (lira)

L

ITL

Latvia (lats)

Ls

LVL

Lithuania (litas)

Lt

LTL

Luxembourg (franc)

LF

LUF

Malta (lira)

Lm

MTL

Netherlands (guilder)

fl

NLG

Portugal (escudo)

esc

PTE

Slovakia (koruna)

Sk

SKK

Slovenia (tolar)

SIT

SIT

Spain (peseta)

pts

ESP

Example:

EUROCONVERT (100, "DM", "€") converts 100 German marks to euros. The result is 51.13 (euro).
EUROCONVERT (100, "DEM", "EUR") does the same, but uses ISO codes. The result is of course identical:
51.13 (euro).
EUROCONVERT (100, "DEM", "ATS") returns 703.55 (Austrian schillings).

EVEN (round up to next even number)
Syntax:

EVEN(Number)
Description:

Rounds Number up (away from zero) to the nearest even integer.
Example:

EVEN(42) returns 42
EVEN(43) returns 44
EVEN(-43) returns -44
See also:

ODD, ROUND, ROUNDUP, MROUND, FIXED, INT, TRUNC, CEILING, FLOOR
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EXACT (compare texts)
Syntax:

EXACT(Text1, Text2)
Description:

Returns TRUE if Text1 and Text2 are exactly the same. This function is case-sensitive.
Example:

EXACT("aaa", "aaa") returns TRUE
EXACT("aaa", "Aaa") returns FALSE
EXACT(UPPER("aaa"), UPPER("Aaa")) returns TRUE
See also:

FIND, SEARCH, DELTA

EXP (power of e)
Syntax:

EXP(Number)
Description:

Returns e raised to the power of Number.
The constant e (2.71828...) is the base of the natural logarithm (LN).
Number is the exponent.
Example:

EXP(5) returns 148.4132
EXP(LN(0.1234)) returns 0.1234
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Hint:

The inverse function is LN.
See also:

LN, LOG, LOG10, POWER

EXPONDIST (exponential distribution)
Note: EXPONDIST is supplemented by the new identical function EXPON.DIST, which is available in
newer versions of Microsoft Excel (2010 or later).

Syntax:

EXPONDIST(x, Lambda, Cumulative)
Description:

Returns the exponential distribution function.
An exponential distribution can be used to model time intervals like the time between phone calls or the time
customers have to wait at a counter.
x is the value to be evaluated. Must be ³ 0.
Lambda (l) is the average number of successes per time interval. Must be > 0.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.
See also:

EXPON.DIST, POISSON.DIST/POISSON, WEIBULL.DIST/WEIBULL
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EXPON.DIST (exponential distribution)
Syntax:

EXPON.DIST(x, Lambda, Cumulative)
Description:

Returns the exponential distribution function.
An exponential distribution can be used to model time intervals like the time between phone calls or the time
customers have to wait at a counter.
x is the value to be evaluated. Must be ³ 0.
Lambda (l) is the average number of successes per time interval. Must be > 0.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

EXPONDIST, POISSON.DIST/POISSON, WEIBULL.DIST/WEIBULL

FACT (factorial)
Syntax:

FACT(Number)
Description:

Returns the factorial of the specified number.
The factorial of a number is the product of all positive integers in the range from 1 to Number, i.e.,
1*2*3*...*Number.
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Number must be ³ 0.
Example:

FACT(9) equals 1*2*3*4*5*6*7*8*9, which is 362880.
See also:

FACTDOUBLE, MULTINOMIAL, POLYNOMIAL

FACTDOUBLE (double factorial)
Syntax:

FACTDOUBLE(Number)
Description:

Returns the double factorial of the specified number.
The double factorial is calculated as follows:
If Number is even, its double factorial is 2*4*6*...*Number.
If Number is odd, its double factorial is 1*3*5*...*Number.
Number must be ³ 0.
Example:

FACTDOUBLE(10) equals 2*4*6*8*10, which equals 3840.
FACTDOUBLE(11) equals 1*3*5*7*9*11, which equals 10395.
See also:

FACT
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FALSE (logical value FALSE)
Syntax:

FALSE()
Description:

Returns the logical value FALSE.
See also:

TRUE

FDIST (F distribution)
Note: FDIST is supplemented by the new identical function F.DIST.RT, which is available in newer versions
of Microsoft Excel (2010 or later).

Syntax:

FDIST(X, DegreesFreedom1, DegreesFreedom2)
Description:

Returns the right-tailed F probability distribution function.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom1 is the numerator degrees of freedom.
DegreesFreedom2 is the denominator degrees of freedom.
Both degrees of freedom must be ³ 1 and < 10^10.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
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See also:

F.DIST.RT, F.INV.RT/FINV, F.TEST/FTEST

F.DIST.RT (F distribution)
Syntax:

F.DIST.RT(X, DegreesFreedom1, DegreesFreedom2)
Description:

Returns the right-tailed F probability distribution function.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom1 is the numerator degrees of freedom.
DegreesFreedom2 is the denominator degrees of freedom.
Both degrees of freedom must be ³ 1 and < 10^10.
See also:

FDIST, F.INV.RT/FINV, F.TEST/FTEST

FILENAME (file name of the document)
Syntax:

FILENAME([IncludePath])
Description:

Returns the file name of the current document.
IncludePath (optional) determines if the path (drive and folder) should be included:
FALSE or omitted: don't include path
TRUE: include path
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Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

If you save a document as Balance.pmdx in folder c:\Documents:
FILENAME() returns Balance.pmdx
FILENAME(TRUE) returns c:\Documents\Balance.pmdx
See also:

USERFIELD, SHEET, SHEETNAME, CELL

FIND (search for text)
Syntax:

FIND(SearchedText, Text [, StartPos])
Description:

Returns the position of the text string SearchedText within the text string Text.
StartPos (optional) lets you specify the position (= character) at which to start the search. If omitted, the search
starts at the first character.
The FIND function is case-sensitive. To perform a non case-sensitive search, use the SEARCH function instead
Example:

FIND("a", "Banana") returns 2
FIND("A", "Banana") returns the error value #VALUE!, since the text string does not contain an upper case
"A".
FIND("a", "Banana", 3) returns 4
See also:

SEARCH, REPLACE, SUBSTITUTE, EXACT, MID
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FINV (percentiles of the F distribution)
Note: FINV is supplemented by the new identical function F.INV.RT, which is available in newer versions
of Microsoft Excel (2010 or later).

Syntax:

FINV(Probability, DegreesFreedom1, DegreesFreedom2)
Description:

Returns the inverse of the right-tailed F probability distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom1 is the numerator degrees of freedom.
DegreesFreedom2 is the denominator degrees of freedom.
Both degrees of freedom must be ³ 1 and < 10^10.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
See also:

F.INV.RT, F.TEST/FTEST, F.DIST.RT/FDIST

F.INV.RT (percentiles of the F distribution)
Syntax:

F.INV.RT(Probability, DegreesFreedom1, DegreesFreedom2)
Description:

Returns the inverse of the right-tailed F probability distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom1 is the numerator degrees of freedom.
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DegreesFreedom2 is the denominator degrees of freedom.
Both degrees of freedom must be ³ 1 and < 10^10.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

FINV, F.TEST/FTEST, F.DIST.RT/FDIST

FISHER (Fisher transformation)
Syntax:

FISHER(Number)
Description:

Returns the Fisher transformation.
Number must be > -1 and < 1.
Hint:

The inverse function is FISHERINV.
See also:

FISHERINV, CORREL, COVARIANCE.P/COVARIANCE.S/COVAR
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FISHERINV (inverse of the Fisher transformation)
Syntax:

FISHERINV(Number)
Description:

Returns the inverse of the FISHER transformation.
See also:

FISHER, CORREL, COVARIANCE.P/COVARIANCE.S/COVAR

FIXED (format number as text with fixed decimals)
Syntax:

FIXED(Number [, n] [, NoThousandsSep])
Description:

Returns a text string containing Number rounded to n decimal places.
Number is the number to be converted.
n (optional) is the number of decimal places. If n is omitted, Number is rounded to two places.
If n is a negative value, Number is rounded to the left of the decimal point. For example, if n is -2, Number is
rounded to the nearest multiple of hundred (see last example).
NoThousandsSep (optional) is a logical value that lets you specify if the resulting text string should contain
thousands separators:
FALSE or omitted: Add thousands separators
TRUE: Do not add thousands separators
Annotation:

Please keep in mind that the result of this function is a text string. To round a number without converting it to a
text string, use one of the round functions (e.g., ROUND) instead

Formulas and functions

512

Alternatively, you can let PlanMaker display a number rounded by applying one of the number formats to the
number (using the Format > Cell menu command).
Example:

FIXED(1234.5678, 2) returns the text string 1,234.57
FIXED(1234.5678, 2, TRUE) returns the text string 1234.57 (without thousands separators)
FIXED(1234.5678, -2) returns the text string 1,200
See also:

ROUND, ROUNDDOWN, ROUNDUP, TRUNC, TEXT, INT

FLOOR (round down to a multiple of base)
Syntax:

FLOOR(Number, Base)
Description:

Rounds Number down (towards zero) to the nearest multiple of Base.
Positive numbers are rounded to the nearest multiple of Base that is smaller than Number.
Negative numbers are rounded to the nearest multiple of Base that is larger than Number.
Number and Base must have the same sign, otherwise the function returns a #NUM! error value.
Example:

FLOOR(42.5, 1) returns 42
FLOOR(-42.5, -1) returns -42
FLOOR(21, 5) returns 20
FLOOR(12.3456, 0.01) returns 12.34
See also:

CEILING, ROUNDDOWN, ROUNDUP, ROUND, MROUND, TRUNC
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FORECAST (forecast using linear regression)
Syntax:

FORECAST(x, y_values, x_values)
Description:

Returns the y coordinate for the given x coordinate on a best-fit line based on the given values.
A best-fit line is the result of a linear regression, a statistical technique that adapts a line to a set of data points
(for example, the results of a series of measurements).
This function can be used, for example, to predict the resistance of a temperature-sensitive resistor at a specific
temperature after having measured the resistance at several other temperatures.
x is the x value for which a prediction is desired.
y_values are the known y values (e.g., the resistance).
x_values are the known x values (e.g., the temperature).
Example:

The resistance of a temperature-sensitive resistor has been measured at several temperatures.
Cells A1:A4 contain the temperatures measured: 8, 20, 25, 28
Cells B1:B4 contain the resistances measured: 261, 508, 608, 680
The following calculation returns an estimate for the resistance at 15 degrees:
FORECAST(15, B1:B4, A1:A4) returns 405.21805 (Ohm)
See also:

INTERCEPT, SLOPE, SKEW, STEYX, TREND

FORMULATEXT (display the formula a cell contains)
Syntax:

FORMULATEXT(Cell)
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Description:

Displays the formula that the specified cell contains.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
Example:

If the cell A1 contains the formula =SUM(D2:D4), then FORMULATEXT(A1) will return the text
"=SUM(D2:D4)".
See also:

ISFORMULA

FREQUENCY (frequency)
Syntax:

FREQUENCY(Values, Bounds)
Description:

Returns a frequency distribution for the given set of values. Use this function to count how many values are part
of the specified intervals.
The result of this function is a vertical array (see notes below).
Values is a cell range or an array containing the values to be evaluated. Blank cells and text strings are ignored.
Bounds is a cell range or an array containing the bounds for the intervals. For example, if Bounds is the array
{10; 15; 42}, the function returns an array with the following values:
1. The number of values that are <=10.
2. The number of values that are >10 and <=15.
3. The number of values that are >15 and <=42.
4. The number of values that are >42.
Both Values and Bounds have to be vertical arrays (i.e., must not consist of more than one column).
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Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Please note that the array returned by this function contains one element more than the number of values in
Bounds.
See also:

COUNT

FTEST (F-test)
Note: FTEST is supplemented by the new identical function F.TEST, which is available in newer versions of
Microsoft Excel (2010 or later).

Syntax:

FTEST(Array1, Array2)
Description:

Returns the result of an F-test, i.e., the one-tailed probability that the variances in the two given data sets are not
significantly different.
Array1 and Array2 are the two arrays to be evaluated.
They both have to consist of at least 2 values.
If the variance of Array1 or Array2 is zero, the function returns a #DIV/0! error value.
See also:

F.TEST, F.INV.RT/FINV, F.DIST.RT/FDIST

F.TEST (F-test)
Syntax:

F.TEST(Array1, Array2)
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Description:

Returns the result of an F-test, i.e., the one-tailed probability that the variances in the two given data sets are not
significantly different.
Array1 and Array2 are the two arrays to be evaluated.
They both have to consist of at least 2 values.
If the variance of Array1 or Array2 is zero, the function returns a #DIV/0! error value.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

FTEST, F.INV.RT/FINV, F.DIST.RT/FDIST

FV (future value)
Syntax:

FV(Rate, NPer, Pmt [, PV] [, Type])
Description:

Returns the future value of an investment based on periodic constant payments, and a constant interest rate.
Rate is the interest rate (per payment period).
NPer is the total number of payment periods.
Pmt is the payment made for each period.
PV (optional) is the present value. If omitted, it will be set to zero.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
See also:

FVSCHEDULE, IPMT, NPER, PMT, PPMT, PV, RATE
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FVSCHEDULE (future value)
Syntax:

FVSCHEDULE(PV, Rates)
Description:

Returns the future value of an initial principal after applying a series of variable compound interest rates.
The function expects the following arguments:
PV is the present value (the initial principal).
Rates is a cell range or an array containing the different interest rates (in their actual order, namely, rate for the
first period, rate for the second period, etc.)
Example:

To calculate the future value of an investment of $10,000 that pays 5% interest in the first, 5.2% in the second,
5.5% in the third, and 5.9% in the fourth year, you enter the four interest rates (in the correct order) in cells A1
to A4 and then employ the following formula:
FVSCHEDULE(10000, A1:A4) returns 12341.09
The different interest rates can also be entered directly using the following form:
FVSCHEDULE(10000, {5%, 5.2%, 5.5%, 5.9%})
See also:

FV

GAMMA (gamma function)
Syntax:

GAMMA(Number)
Description:

Calculates the gamma function for the given number.
Number must be > 0.
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Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
See also:

GAMMALN, GAMMA.DIST/GAMMADIST, GAMMA.INV/GAMMAINV

GAMMADIST (gamma distribution)
Note: GAMMADIST is supplemented by the new identical function GAMMA.DIST, which is available in
newer versions of Microsoft Excel (2010 or later).

Syntax:

GAMMADIST(X, Alpha, Beta, Cumulative)
Description:

Returns the gamma distribution.
X is the value to be evaluated. Must be ³ 0.
Alpha and Beta are shape parameters of the function. They both have to be greater than zero.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.
See also:

GAMMA.DIST, GAMMA.INV/GAMMAINV, GAMMA, GAMMALN

GAMMA.DIST (gamma distribution)
Syntax:

GAMMA.DIST(X, Alpha, Beta, Cumulative)
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Description:

Returns the gamma distribution.
X is the value to be evaluated. Must be ³ 0.
Alpha and Beta are shape parameters of the function. They both have to be greater than zero.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

The inverse function is GAMMA.INV.
See also:

GAMMADIST, GAMMA.INV/GAMMAINV, GAMMA, GAMMALN

GAMMAINV (percentiles of the gamma distribution)
Note: GAMMAINV is supplemented by the new identical function GAMMA.INV, which is available in
newer versions of Microsoft Excel (2010 or later).

Syntax:

GAMMAINV(Probability, Alpha, Beta)
Description:

Returns the inverse of the gamma cumulative distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Alpha and Beta are shape parameters of the function. They both have to be greater than zero.
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Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
See also:

GAMMA.INV, GAMMA.DIST/GAMMADIST, GAMMA, GAMMALN

GAMMA.INV (percentiles of the gamma distribution)
Syntax:

GAMMA.INV(Probability, Alpha, Beta)
Description:

Returns the inverse of the gamma cumulative distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Alpha and Beta are shape parameters of the function. They both have to be greater than zero.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

GAMMA.INV is the inverse function of GAMMA.DIST.
See also:

GAMMAINV, GAMMA.DIST/GAMMADIST, GAMMA, GAMMALN

Formulas and functions

521

GAMMALN (logarithm of the gamma function)
Syntax:

GAMMALN(Number)
Description:

Returns the natural logarithm of the gamma function.
Number is the value to be evaluated. Must be > 0.
See also:

GAMMA, GAMMA.DIST/GAMMADIST, GAMMA.INV/GAMMAINV

GAUSS (standard normal distribution)
Syntax:

GAUSS(x)
Description:

Returns the integral of the PHI function (standard normal distribution) minus 0.5.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
It is therefore recommended to use the function NORMSDIST instead, since it is compatible with all versions
of Excel:
GAUSS(x) equals NORMSDIST(x) - 0.5
See also:

PHI, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST
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GCD (greatest common divisor)
Syntax:

GCD(Number1 [, Number2, Number3 ...])
Description:

Returns the GCD (greatest common divisor) of the specified integers. The GCD is the largest integer that will
divide all of the given integers without a remainder.
Number1, Number2, etc., are the numbers to be evaluated. All of them should be integers, digits right of the
decimal point are ignored.
Example:

GCD(25, 100, 250) returns 25
GCD(25, 105, 250) returns 5
If cells A1 to A3 contain the values 4, 8, and 6, respectively:
GCD(A1:A3) returns 2
See also:

LCM

GEOMEAN (geometric mean)
Syntax:

GEOMEAN(Number1 [, Number2, Number3...])
Description:

Returns the geometric mean of the specified numbers.
The geometric mean is the n-th root of the product of the given values (n is the total number of values).
Number1, Number2, etc., are the numbers to be evaluated. All of them have to be greater than zero. Empty
cells, text strings, and logical values are ignored.
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Example:

GEOMEAN(1, 2, 6) returns 2.28943
See also:

HARMEAN, TRIMMEAN, AVERAGE

GESTEP (greater or equal to threshold value?)
Syntax:

GESTEP(Number, Step)
Description:

Returns 1 if Number ³ Step, else returns 0.
Example:

GESTEP(41, 42) returns 0
GESTEP(42, 42) returns 1
GESTEP(42.1, 42) returns 1
See also:

DELTA

GETPIVOTDATA
Syntax:

GETPIVOTDATA(ValueField, PivotRange [, Field1, Label1, Field2. Label2,...])
Description:

Returns the values of an existing pivot table by retrieving certain fields from the pivot table structure.
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Value field: The name of the field that you have placed in the Values area of the pivot table and whose data
you want to retrieve. The argument must be entered with double quotes.
PivotRange: The referenced pivot table. Just address any cell of the pivot table target range to specify it. The
argument is entered without quotes.
Field1, Label1, Field2, Label2,...: You can narrow the output of the values by retrieving a specific field in
conjunction with an element from this field. It is possible to add several combinations. The argument must be
entered with double quotes.
ValueField and PivotRange are required as arguments, Fields/Labels are optional.
Annotation:

For the PivotRange you can also enter a Named range here, but you first have to give the cell range of the pivot
table report a name. To do this, select a cell in the pivot table report (you do not have to select the entire range)
and follow the description in the Naming cell ranges section.
You cannot use the name automatically generated by PlanMaker (e.g. "Pivot table 1") as the Named Range.
Only names created using the menu command Worksheet > Names > Edit can actually be assigned as names
for the PivotRange.
Example:

Here are example data from the Pivot tables section. Assuming your pivot table report is in cell range F1:G12
and the "Amount" field is in the Values area, the "Employee" and "Order" fields are in the Row labels area:

GETPIVOTDATA("AMOUNT", F1) returns 200, because the grand total for all values of Amount is displayed.
GETPIVOTDATA("AMOUNT", F1, "Employee", "Anna") returns 123, since the result of Amount is restricted
to the Person field containing the item Anna.
GETPIVOTDATA("AMOUNT", F1, "Employee", "Anna", "Order", "Coffee") returns 75, since the result of
Amount is restricted to the field Employee/item Anna in combination with the field Order/item Coffee.
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GROWTH (values of an exponential regression)
Syntax:

GROWTH(y_values [, x_values] [, New_x_values] [, Constant])
Description:

Returns the values of an exponential regression.
Exponential regression is a statistical technique that adapts an exponential curve to a set of data points (for
example, the results of a series of measurements).
The GROWTH function returns an array with the y values of a best-fit exponential curve based on the given y
values and x values.
y_values are the known y values. All of them must be positive, otherwise a #NUM! error value is returned.
x_values (optional) are the known x values. If omitted, the values 1, 2, 3, ... will be used.
New_x_values (optional) are the x values for which you want to determine the corresponding y values on the
curve. If omitted, the values in x_values will be used.
Constant (optional) is a logical value that lets you specify if the constant b should be calculated automatically
or forced to equal one:
TRUE or omitted: b will be calculated from the given data.
FALSE: b is forced to equal 1 (one), the m values are adjusted accordingly.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
See also:

LINEST, LOGEST, TREND

HARMEAN (harmonic mean)
Syntax:

HARMEAN(Number1 [, Number2, Number3 ...])
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Description:

Returns the harmonic mean of the specified numbers.
The harmonic mean is obtained by dividing n by the sum of reciprocals of the given values (n is the total
number of values).
Number1, Number2, etc., are the numbers to be evaluated. All of them must be > 0. Empty cells, text strings,
and logical values are ignored.
Example:

HARMEAN(1, 2, 6) returns 1.8
See also:

GEOMEAN, TRIMMEAN, AVERAGE

HEX2BIN (hexadecimal number to binary number)
Syntax:

HEX2BIN(Number [, Digits])
Description:

Converts the given hexadecimal number (base 16) to a binary number (base 2).
Number is the number to be converted.
The number must be in the range 80000000 to 7FFFFFFF. Negative numbers have to be transformed to two's
complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

HEX2BIN("2A") returns 101010
HEX2BIN("2A", 8) returns 00101010
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HEX2BIN("2A", 2) returns the error value #NUM!, because this number cannot be represented with fewer than
5 binary digits
HEX2BIN("FFFFFFD6") returns 11111111111111111111111111010110 (negative value)
See also:

BIN2HEX, HEX2DEC, HEX2OCT

HEX2DEC (hexadecimal number to decimal number)
Syntax:

HEX2DEC(Number)
Description:

Converts the given hexadecimal number (base 16) to a decimal number (base 10).
Number is the number to be converted.
The number must be in the range 80000000 to 7FFFFFFF. Negative numbers have to be transformed to two's
complement notation (see last example).
Example:

HEX2DEC("2A") returns 42
HEX2DEC("FFFFFFD6") returns -42
See also:

DEC2HEX, HEX2BIN, HEX2OCT, DECIMAL

HEX2OCT (hexadecimal number to octal number)
Syntax:

HEX2OCT(Number [, Digits])
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Description:

Converts the given hexadecimal number (base 16) to an octal number (base 8).
Number is the number to be converted.
The number must be in the range 80000000 to 7FFFFFFF. Negative numbers have to be transformed to two's
complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

HEX2OCT("2A") returns 52
HEX2OCT("2A", 4) returns 0052
HEX2OCT("2A", 1) returns the error value #NUM!, because this number cannot be represented with fewer
than 2 octal digits
HEX2OCT("FFFFFFD6") returns 37777777726 (negative value)
See also:

OCT2HEX, HEX2BIN, HEX2DEC

HLOOKUP (look up row-wise)
Syntax:

HLOOKUP(Crit, Range, n [, Sorted])
Description:

Scans the first row of Range for a value. If found, the function returns the content of the cell located in the
same column and n-th row of Range.
If no exact match is found, the next smallest value will be taken. If no smaller value exists, a #N/A error value
is returned.
Note: HLOOKUP can search horizontally only. To search vertically, use VLOOKUP instead
Crit is the value to be searched for (case insensitive).
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Range is the cell range or array to be evaluated. Its first row should contain the values to be scanned.
n is the relative row number in Range from which a value will be returned.
If n is less than 1, a #VALUE! error value is returned. If n is greater than the total number of rows in Range, a
#REF! error value is returned.
Sorted is a logical value determining whether the values in the first row of Range are in sorted order:
TRUE or omitted: Values have to be sorted in ascending order.
FALSE: Values do not have to be sorted.
See also:

VLOOKUP, LOOKUP, INDEX, MATCH, TRUE

HOLIDAY (dates of movable Christian holidays)
Syntax:

HOLIDAY(Year, Type)
Description:

Returns the date of the specified movable Christian holiday in the given year.
Year is an integer number that specifies the year to evaluate.
Type is an integer number that specifies which holiday to calculate, as follows:
0: Good Friday
1: Easter Sunday
2: Easter Monday
3: Ascension Day
4: Whitsunday (Pentecost)
5: Whitmonday
6: (Feast of) Corpus Christi
7: Ash Wednesday
8: Repentance Day (Germany)
9: 1st Sunday of Advent
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Example:

HOLIDAY(2014, 1) returns 04/20/2014 (Easter Sunday in 2014)
HOLIDAY(YEAR(TODAY(), 1) returns the date of Easter Sunday in the current year
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

WORKDAY, NETWORKDAYS

HOUR (hour)
Syntax:

HOUR(Time)
Description:

Returns the hour of a time value.
Example:

HOUR("12:34:56 AM") returns 12
See also:

MINUTE, SECOND, MILLISECONDS

HYPERLINK (hyperlink)
Syntax:

HYPERLINK(TargetAddress [, Text])
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Description:

Displays a hyperlink to the specified target address in the cell. The text displayed is either the target address or
the text specified in the optional parameter Text.
For example, you can place a link to a web page in a cell. When the user clicks on it, the web browser starts and
presents the page.
Links to other PlanMaker documents are possible as well. When clicked, PlanMaker opens the specified
document.
TargetAddress is the address you want the link to point to. You can use a fixed text string, a calculation, or a
reference to a cell that contains the target address. See the examples below.
Text (optional) is the text to be displayed in the cell. If it is not specified, the target address will be displayed
instead.
Example:

=HYPERLINK("http://www.softmaker.com")
The above hyperlink opens the web page www.softmaker.com in the web browser.
=HYPERLINK("http://www.softmaker.com", "Our Homepage")
Ditto, but instead of the target address, the text "Our Homepage" is displayed as link text.
=HYPERLINK("http://www.softmaker.com#MyAnchor")
The above link opens the web page www.softmaker.com in the browser and jumps to the anchor (target) named
"MyAnchor". Alternatively, you could also use the syntax =HYPERLINK("[http://www.softmaker.com]
MyAnchor") for this.
=HYPERLINK("c:\My Folder\Filename.pmdx")
The above link opens the file c:\My Folder\Filename.pmdx in PlanMaker.
Note: You can not only open PlanMaker files with this function, but practically any kind of document (provided
that it is associated with an application that will open it).
=HYPERLINK("[c:\My Folder\Filename.pmdx]Sheet1!A5")
The above link opens the file c:\My Folder\Filename.pmdx in PlanMaker and jumps to the cell A5 on the
worksheet "Sheet1". Note: The entire file path and name has to be enclosed in brackets. Behind the file name,
add the name of the worksheet, an exclamation mark, and the address of the target cell.
=HYPERLINK("[c:\My Folder\Filename.pmdx]Sheet1!MyRange")
The above link opens the file c:\My Folder\Filename.pmdx in PlanMaker and jumps to the top left corner of the
named range "MyRange" on the worksheet "Sheet1".
=HYPERLINK(E1, E2)
The above link opens the target address given in the cell E1. As a link text, the text given in cell E2 is
displayed.
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See also:

Links can also be created using the procedure described in section Working with links. However, the
HYPERLINK function is more flexible.

HYPGEOMDIST (hypergeometric distribution)
Note: HYPGEOMDIST is supplemented by the new function HYPGEOM.DIST with additional
functionality, which is available in newer versions of Microsoft Excel (2010 or later).

Syntax:

HYPGEOMDIST(k, n, K, N)
Description:

Returns the hypergeometric distribution.
The hypergeometric distribution can be used to calculate the probability to, for example, obtain k red balls
when randomly drawing n balls (without replacement) from an urn containing N balls, with K of them red balls.
k is the number of successes in the sample (success = drawing a red ball).
n is the size of the sample (the number of balls to be drawn)
K is the total number of successes in the population (the total number of red balls).
N is the size of the population (the total number of balls).
All of these values should be integers, digits right of the decimal point are ignored.
Example:

An urn contains 10 balls (N=10) with 2 of them red (K=2). To determine the probability to obtain exactly 1 red
ball (k=1) when drawing 5 balls (n=5), use the following calculation:
HYPGEOMDIST(1, 5, 2, 10) returns 0.55556
See also:

HYPGEOM.DIST, NEGBINOM.DIST/NEGBINOMDIST
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HYPGEOM.DIST (hypergeometric distribution)
Syntax:

HYPGEOM.DIST(k, n, K, N, Cumulative)
Description:

Returns the hypergeometric distribution.
The hypergeometric distribution can be used to calculate the probability to, for example, obtain k red balls
when randomly drawing n balls (without replacement) from an urn containing N balls, with K of them red balls.
k is the number of successes in the sample (success = drawing a red ball).
n is the size of the sample (the number of balls to be drawn)
K is the total number of successes in the population (the total number of red balls).
N is the size of the population (the total number of balls).
Cumulative determines the type of function as a switch: If you enter the value TRUE, the cumulative
distribution function of the hypergeometric distribution is calculated. By entering the value FALSE, the density
function of the hypergeometric distribution is calculated.
All of these values should be integers, digits right of the decimal point are ignored.
Example:

An urn contains 10 balls (N=10) with 2 of them red (K=2). To determine the probability to obtain exactly or at
most 1 red ball (k=1) when drawing 5 balls (n=5), use the following calculation:
HYPGEOM.DIST(1, 5, 2, 10, FALSE) returns 0.55556
HYPGEOM.DIST(1, 5, 2, 10, TRUE) returns 0.77778
The probability of obtaining exactly 1 red ball is 55.6% (density function). The probability of obtaining at most
1 red ball is 77.8% (cumulative distribution function).
Note:

The HYPGEOM.DIST function supplements the previous HYPGEOMDIST function with the additional
argument Cumulative.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
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See also:

HYPGEOMDIST, NEGBINOM.DIST/NEGBINOMDIST

IF (if-then-else condition)
Syntax:

IF(Condition, IfTrue [, IfFalse])
Description:

Returns IfTrue, if the specified condition is TRUE, else returns IfFalse (if given).
Condition can be any kind of value or expression that returns TRUE or FALSE.
IfTrue and IfFalse can be any kind of value or expression (including formulas).
Example:

IF(A1<5, "Order!", "ok") returns "Order!" if A1<5, otherwise it returns "ok".
See also:

CHOICE, IFERROR

IFERROR (return a value on errors)
Syntax:

IFERROR(Value, ValueIfError)
Description:

Normally returns Value. However, if Value contains any type of error value, returns the defined ValueIfError
instead.
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Compatibility notes:

This function is not supported by the .xls file format (used in Microsoft Excel 2003 and earlier). If you save a
document in this format, all calculations using this function will be replaced by their last result as a fixed value.
Accordingly, if you use this function, you should not save your document in the "Microsoft Excel 97-2003
(.xls)" file format, but choose one of the following formats instead:
¡ "PlanMaker document (.pmdx or .pmd)"
¡ or: "Microsoft Excel 2007-2016 (.xlsx)"
Example:

IFERROR(A1, "Error!") returns the value in cell A1, as long as A1 doesn't contain an error value. If it does, the
text string "Error!" is returned instead.
See also:

ISERR, ISERROR, ISNA, ERRORTYPE, section Error values

IMABS (absolute value of a complex number)
Syntax:

IMABS(ComplexNumber)
Description:

Returns the absolute value (modulus) of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMABS("2+4i") returns 4.47214
See also:

COMPLEX, IMARGUMENT, IMEXP, IMCONJUGATE
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IMAGINARY (imaginary coefficient of a complex number)
Syntax:

IMAGINARY(ComplexNumber)
Description:

Returns the imaginary coefficient of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMAGINARY("2+4i") returns 4
See also:

COMPLEX, IMREAL

IMARGUMENT (angle of a complex number)
Syntax:

IMARGUMENT(ComplexNumber)
Description:

Returns the angle (in radians) from the real axis to the representation of a complex number in polar coordinates.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMARGUMENT("2+4i") returns 1.10715
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See also:

COMPLEX, IMABS, IMEXP, IMCONJUGATE

IMCONJUGATE (conjugate complex number)
Syntax:

IMCONJUGATE(ComplexNumber)
Description:

Returns the complex conjugate of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMCONJUGATE("2+4i") returns 2-4i
See also:

COMPLEX, IMABS, IMARGUMENT, IMEXP

IMCOS (cosine of a complex number)
Syntax:

IMCOS(ComplexNumber)
Description:

Returns the cosine of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
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Example:

IMCOS("2+4i") returns -11.3642347064011 - 24.8146514856342i
See also:

COMPLEX, IMSIN

IMDIV (division of complex numbers)
Syntax:

IMDIV(ComplexNumber1, ComplexNumber2)
Description:

Returns the quotient of two complex numbers, i.e., divides ComplexNumber1 by ComplexNumber2.
ComplexNumber1 and ComplexNumber2 must be complex numbers in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMDIV("4+12i", "2+4i") returns 2.8+0.4i
See also:

COMPLEX, IMPRODUCT, IMSUB, IMSUM

IMEXP (exponential of a complex number)
Syntax:

IMEXP(ComplexNumber)
Description:

Returns the exponential of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
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Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMEXP("2+4i") returns -4.82980938326939 - 5.59205609364098i
See also:

COMPLEX, IMABS, IMARGUMENT, IMCONJUGATE, IMLN

IMLN (natural logarithm of a complex number)
Syntax:

IMLN(ComplexNumber)
Description:

Returns the natural logarithm (base e) of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMLN("2+4i") returns 1.497866136777 + 1.10714871779409i
See also:

COMPLEX, IMEXP, IMLOG10, IMLOG2

IMLOG10 (base-10 logarithm of a complex number)
Syntax:

IMLOG10(ComplexNumber)
Description:

Returns the base-10 logarithm of a complex number.
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ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMLOG10("2+4i") returns 0.650514997831991 + 0.480828578784234i
See also:

COMPLEX, IMLN, IMLOG2

IMLOG2 (base-2 logarithm of a complex number)
Syntax:

IMLOG2(ComplexNumber)
Description:

Returns the base-2 logarithm of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMLOG2("2+4i") returns 2.16096404744368 + 1.59727796468811i
See also:

COMPLEX, IMLN, IMLOG10

IMNEG (negative value of a complex number)
Syntax:

IMNEG(ComplexNumber)
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Description:

Returns the negative of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMNEG("2+4i") returns -2-4i
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Hint: As an alternative to IMNEG(A1) the following calculation can be used:
COMPLEX(-IMREAL(A1), -IMAGINARY(A1))
See also:

COMPLEX

IMPOWER (power of a complex number)
Syntax:

IMPOWER(ComplexNumber, Exponent)
Description:

Returns a complex number raised to a power.
ComplexNumber must be a complex number in x+yi or x+yj format.
Exponent is the power the complex number will be raised to.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMPOWER("2+4i", 2) returns -12+16i
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See also:

COMPLEX, IMSQRT

IMPRODUCT (product of complex numbers)
Syntax:

IMPRODUCT(ComplexNum1 [, ComplexNum2, ComplexNum3 ...])
Description:

Returns the product of the given complex numbers.
ComplexNum1, ComplexNum2, etc., must be complex numbers in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMPRODUCT("2+4i", "1+2i") returns -6+8i
See also:

COMPLEX, IMDIV, IMSUB, IMSUM

IMREAL (real coefficient of a complex number)
Syntax:

IMREAL(ComplexNumber)
Description:

Returns the real coefficient of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
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Example:

IMREAL("2+4i") returns 2
See also:

COMPLEX, IMAGINARY

IMSIN (sine of a complex number)
Syntax:

IMSIN(ComplexNumber)
Description:

Returns the sine of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMSIN("2+4i") returns 24.8313058489464 - 11.3566127112182i
See also:

COMPLEX, IMCOS

IMSQRT (square root of a complex number)
Syntax:

IMSQRT(ComplexNumber)
Description:

Returns the square root of a complex number.
ComplexNumber must be a complex number in x+yi or x+yj format.
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Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMSQRT("2+4i") returns 1.79890743994787 + 1.11178594050284i
See also:

COMPLEX, IMPOWER

IMSUB (difference of complex numbers)
Syntax:

IMSUB(ComplexNumber1, ComplexNumber2)
Description:

Returns the difference of two complex numbers, i.e., subtracts ComplexNumber2 from ComplexNumber1.
ComplexNumber1 and ComplexNumber2 must be complex numbers in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMSUB("2+4i", "1+2i") returns 1+2i
See also:

COMPLEX, IMDIV, IMPRODUCT, IMSUM

IMSUM (sum of complex numbers)
Syntax:

IMSUM(ComplexNum1 [, ComplexNum2, ComplexNum3 ...])
Description:

Returns the sum of the given complex numbers.
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ComplexNum1, ComplexNum2, etc., must be complex numbers in x+yi or x+yj format.
Annotation: Complex numbers can be created with the COMPLEX function
Example:

IMSUM("2+4i", "1+2i") returns 3+6i
See also:

COMPLEX, IMDIV, IMPRODUCT, IMSUB

INDEX (cell in a particular row/column of a range)
Syntax:

INDEX(Range, Row, Column [, PartRange])
Description:

Returns a reference to the cell at the intersection of the specified row and column in Range.
Range is the cell range from which to return a reference.
Row is the relative number of the row in Range.
Column is the relative number of the column in Range.
If Row or Column refers to a cell outside Range, a #REF! error value is returned.
The optional argument PartRange is just a placeholder (for compatibility with Microsoft Excel). It will not be
evaluated.
Compatibility notes:

This function is not fully identical to Microsoft Excel's INDEX function. The following restrictions apply:
1. The argument Range must consist of exactly one contiguous cell range. Nonadjacent ranges are not
supported.
2. The optional argument PartRange is ignored.
Example:

INDEX(B2:D4, 2, 2) returns a reference to cell C3
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See also:

MATCH, VLOOKUP, HLOOKUP

INDIRECT (create reference from text)
Syntax:

INDIRECT(Text [, Mode])
Description:

Returns a cell reference from the specified text string.
Text is a text string containing a cell address like "A1", "$A$1", etc., or a named range.
The optional argument Mode specifies the format of the cell address to be evaluated:
TRUE or omitted: Normal cell address (e.g. A1)
FALSE: Cell address in R1C1 format (an alternative type of cell addressing, supported by Microsoft Excel
only)
Example:

INDIRECT("A1") returns a reference to cell A1.
If cell D2 contains the text string "E5", INDIRECT(D2) returns a reference to cell E5.
See also:

ADDRESS, OFFSET, COLUMN, ROW

INT (round down to nearest integer)
Syntax:

INT(Number)
Description:

Rounds Number down to the nearest integer.
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Example:

INT(5.9) returns 5
INT(-5.1) returns -6
See also:

TRUNC, ROUNDDOWN, ROUNDUP, ROUND, MROUND, FIXED, EVEN, ODD, CEILING, FLOOR

INTERCEPT (intercept point of a linear trend)
Syntax:

INTERCEPT(y_values, x_values)
Description:

Returns the y coordinate of the point where a best-fit line based on the given values intersects the y axis.
A best-fit line is the result of a linear regression, a statistical technique that adapts a line to a set of data points
(for example, the results of a series of measurements).
This function can be used to predict, for example, the resistance of a temperature-sensitive resistor at 0° after
having measured the resistance at several other temperatures.
y_values are the known y values (e.g., the resistance).
x_values are the known x values (e.g., the temperature).
Example:

The resistance of a temperature-sensitive resistor has been measured at several temperatures.
Cells A1:A4 contain the temperatures measured: 8, 20, 25, 28
Cells B1:B4 contain the resistances measured: 261, 508, 608, 680
The following calculation returns an estimate for the resistance at 0 degrees:
INTERCEPT(B1:B4, A1:A4) returns 93.69817 (Ohm)
Annotation:

INTERCEPT(y_values, x_values) equals FORECAST(0, y_values, x_values).
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See also:

FORECAST, SKEW, SLOPE, STEYX, PEARSON

INTERSECTION (intersection of two ranges)
Syntax:

INTERSECTION(Range1, Range2)
Description:

Returns a reference to the intersection of Range1 and Range2 (i.e. the cell range where Range1 and Range2
overlap).
Annotation:

Alternatively, you can use the spacebar operator to obtain the intersection of two ranges. For example:
SUM(INTERSECTION(A1:D4, C3:E6))
is identical to:
SUM(A1:D4 C3:E6).
Compatibility notes:

This function is not supported by Microsoft Excel. When you save a document in Excel format, PlanMaker will
automatically replace all occurrences of this function by spacebar operators (see annotation above).
Example:

INTERSECTION(A1:D4, C3:E6) returns a reference to the range C3:D4

IPMT (interest payment)
Syntax:

IPMT(Rate, Per, NPer, PV [, FV] [, Type])
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Description:

Returns the interest due in the specified period of an investment based on periodic constant payments, and a
constant interest rate.
Rate is the interest rate (per payment period).
Per is the payment period to be evaluated.
NPer is the total number of payment periods.
PV is the present value.
FV (optional) is the future value. If omitted, it will be set to zero.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
Example:

Loan terms: $100,000 at 10% per year, to be repaid over 72 months with monthly payments at the end of each
month.
How much interest has to be paid in the 32nd period (i.e., the 32nd month)?
IPMT(10%/12, 32, 72, 100000) returns -534
Note that all values have to use the same time unit, months in this case, since the payments are made monthly.
Therefore, in the above formula, the yearly interest rate had to be divided by 12 to get the monthly interest rate.
See also:

CUMPRINC, CUMIPMT, FV, ISPMT, NPER, PMT, PPMT, PV, RATE

IRR (internal rate of return)
Syntax:

IRR(Values [, Guess])
Description:

Returns an estimate for the internal rate of return for a series of cash flows.
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The calculation is based on the cash flows specified in the Values argument. Payments have to be entered as
negative values, incomes as positive values. The cash flows do not have to be even but they must occur in
regular intervals (e.g., monthly).
Values is a cell range or array containing the cash flows (in their actual order, namely cash flow for the first
period, cash flow for the second period, etc.). At least one payment and one income have to be given.
Guess (optional) lets you specify an estimate for the result (see note below).
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
20 iterations, a #NUM error value is returned. If this occurs, try altering the Guess parameter.
See also:

NPV, MIRR, RATE, XIRR

ISBLANK (is empty?)
Syntax:

ISBLANK(Reference)
Description:

Returns TRUE if the specified cell is empty.
Example:

If A1 contains any kind of value, C7 is empty:
ISBLANK(A1) returns FALSE
ISBLANK(C7) returns TRUE
See also:

ISNA, COUNT, COUNTA
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ISERR (is an error value except #N/A?)
Syntax:

ISERR(Reference)
Description:

Returns TRUE if the specified cell contains any kind of error value except #N/A.
Example:

ISERR(A1) returns TRUE if A1 contains an error, e.g., a division by zero.
ISERR(A1) returns FALSE if A1 contains the error value #N/A or any kind of value that is not leading to an
error value.
See also:

ISERROR, ISNA, NA(), ERRORTYPE, IFERROR, section Error values

ISERROR (is an error value?)
Syntax:

ISERROR(Reference)
Description:

Returns TRUE if the specified cell contains any kind of error value.
Example:

ISERROR(A1) returns TRUE if A1 contains an error, e.g., a division by zero.
See also:

ISERR, ISNA, NA(), ERRORTYPE, IFERROR, ISREF, section Error values
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ISEVEN (is an even number?)
Syntax:

ISEVEN(Number)
Description:

Returns TRUE if the specified value is even, FALSE if it is odd.
Number should be an integer, digits right of the decimal point are ignored.
Example:

ISEVEN(2) returns TRUE
ISEVEN(2.75) returns TRUE
ISEVEN(3) returns FALSE
ISEVEN(3.75) returns FALSE
See also:

ISODD

ISFORMULA (is a formula?)
Syntax:

ISFORMULA(Reference)
Description:

Returns TRUE if the specified cell contains a formula.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
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Example:

If A1 contains a formula, and C7 contains a fixed number or text string, then:
ISFORMULA(A1) returns TRUE
ISFORMULA(C7) returns FALSE
See also:

ISREF, FORMULATEXT

ISLOGICAL (is a logical value?)
Syntax:

ISLOGICAL(Reference)
Description:

Returns TRUE if the specified cell contains a logical value (i.e., TRUE or FALSE).
Example:

If A1 contains TRUE, and C7 contains a text string, then:
ISLOGICAL(A1) returns TRUE
ISLOGICAL(C7) returns FALSE
See also:

ISTEXT, ISNUMBER, ISREF, ISNONTEXT

ISNA (is not available?)
Syntax:

ISNA(Reference)
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Description:

Returns TRUE if the specified cell contains a #N/A error value.
Cells contain a #N/A error value if they contain a) the formula =NA(), or b) a calculation resulting in a #N/A
error. More details about the usage of #N/A error values can be found in section NA (error value #N/A).
Example:

If A1 contains a #N/A error value, then:
ISNA(A1) returns TRUE
See also:

NA(), ERRORTYPE, IFERROR, ISERR, ISERROR, section Error values

ISNONTEXT (is no text?)
Syntax:

ISNONTEXT(Value)
Description:

Returns TRUE if the specified value is not text.
Example:

If A1 contains a text string, C7 contains a number, then:
ISNONTEXT(A1) returns FALSE
ISNONTEXT(C7) returns TRUE
See also:

ISTEXT, ISLOGICAL, ISNUMBER
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ISNUMBER (is numeric?)
Syntax:

ISNUMBER(Value)
Description:

Returns TRUE if the specified value is a number.
Dates are considered as numbers as well, whereas logical values are not.
Example:

If the cells A1 to A4 contain the values:
"Text", 42, 09/25/2018, and TRUE, respectively, then:
ISNUMBER(A1) returns FALSE
ISNUMBER(A2) returns TRUE
ISNUMBER(A3) returns TRUE
ISNUMBER(A4) returns FALSE
See also:

ISNUMBERP, ISLOGICAL, ISTEXT, ISNONTEXT, ISREF, COUNT

ISNUMBERP (PlanMaker 97 compatibility function)
Syntax:

ISNUMBERP(Value)
Description:

Returns TRUE if the specified value is a number or a logical value.
Dates are considered as numbers as well.
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Note:

This function was retained only for compatibility with PlanMaker 97. Using the Excel-compatible function
ISNUMBER is recommended instead.
The difference between these two functions is that ISNUMBERP treats logical values as numbers, whereas
ISNUMBER does not.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

If the cells A1 to A4 contain the following values:
"Text", 42, 09/25/2018, and TRUE, respectively, then:
ISNUMBERP(A1) returns FALSE
ISNUMBERP(A2) returns TRUE
ISNUMBERP(A3) returns TRUE
ISNUMBERP(A4) returns TRUE (!)
See also:

ISNUMBER

ISODD (is an odd number?)
Syntax:

ISODD(Number)
Description:

Returns TRUE if the specified number is odd, FALSE if it is even.
Number should be an integer, digits right of the decimal point are ignored.
Example:

ISODD(1) returns TRUE
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ISODD(1.75) returns TRUE
ISODD(2) returns FALSE
ISODD(2.75) returns FALSE
See also:

ISEVEN

ISOWEEK (ISO week number)
Syntax:

ISOWEEK(Date [, ReturnYear])
Description:

Returns the ISO week number of a date (i.e. the week number according to the ISO 8601 standard).
Unlike the WEEKNUM function, this function follows the rules defined in the ISO 8601 standard (used e.g. in
Germany, Austria, Switzerland), including:
1. Weeks start on Monday (not Sunday).
2. The first week of a year is defined as the week that contains January 4th.
Note:

This may lead to situations where December 29, 30, and 31 are considered part of the first week of the next
year – or where January 1, 2, and 3 are considered part of the last week of the previous year.
For this reason, ISOWEEK can be invoked with an additional parameter named ReturnYear which leads to the
following results:
If set to 0 or omitted, the function returns the week number.
If set to 1, the function instead returns the year to which the week belongs to (according to ISO 8601 standard).
See examples below.
Example:

ISOWEEK("01/01/2014") returns 1.
ISOWEEK("01/01/2011") returns 52 (since this day was a Saturday).
ISOWEEK("01/01/2011", 1) accordingly returns 2010 – not 2011.
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Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Hint: There's an Excel-compatible alternative to this function: the ISOWEEKNUM function It returns exactly
the same results, but does not have the optional parameter for displaying the year
See also:

ISOWEEKNUM, WEEKNUM, YEAR, MONTH, DAY, WEEKDAY

ISOWEEKNUM (ISO week number)
Syntax:

ISOWEEKNUM(Date)
Description:

Returns the ISO week number of a date (i.e. the week number according to the ISO 8601 standard).
Unlike the WEEKNUM function, this function follows the rules defined in the ISO 8601 standard (used eg in
Germany, Austria, Switzerland), including:
1. Weeks start on Monday (not Sunday).
2. The first week of a year is defined as the week that contains January 4th.
Annotation:

This may lead to situations where December 29, 30, and 31 are considered part of the first week of the next
year – or where January 1, 2, and 3 are considered part of the last week of the previous year. See examples.
Hint: For this reason, PlanMaker provides an alternative (not Excel-compatible) function named ISOWEEK It
returns the same results, but is also additionally to return the year to which the week belongs to (according to
ISO 8601 standard) instead
Example:

ISOWEEKNUM("01/01/2014") returns 1.
ISOWEEKNUM("01/01/2011") returns 52 (since this day was a Saturday).
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
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See also:

ISOWEEK, WEEKNUM, YEAR, MONTH, DAY, WEEKDAY

ISPMT (interest payment)
Syntax:

ISPMT(Rate, Per, NPer, PV)
Description:

Returns the interest due in the specified period of an investment.
Rate is the interest rate (per payment period).
Per is the payment period to be evaluated.
NPer is the total number of payment periods.
PV is the present value.
See also:

IPMT, PMT, PPMT

ISREF (is a valid reference?)
Syntax:

ISREF(Reference)
Description:

Returns TRUE if the specified value is a valid reference.
Example:

ISREF(A1) returns TRUE
ISREF($A$1) returns TRUE

559

Formulas and functions

560

ISREF(A1:C7) returns TRUE
ISREF("some text") returns FALSE
ISREF(FirstQuarter) returns FALSE, as long as the name "FirstQuarter" does not exist. As soon as you assign
the name "FirstQuarter" to a range of cells, the calculation will return TRUE.
See also:

ISFORMULA, ISERROR, ISLOGICAL, ISNUMBER, ISTEXT

ISTEXT (is text?)
Syntax:

ISTEXT(Value)
Description:

Returns TRUE if the specified value is text.
Example:

If A1 contains a text string, and C7 contains a number, then:
ISTEXT(A1) returns TRUE
ISTEXT(C7) returns FALSE
See also:

ISNONTEXT, ISLOGICAL, ISNUMBER, ISREF

KURT (kurtosis)
Syntax:

KURT(Number1, Number2, Number3, Number4 [, Number5 ...])
or
KURT(Range1 [, Range2, Range3 ...])
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Description:

Returns the Kurtosis of a probability distribution.
The Kurtosis is a measure of the "peakedness" of a distribution compared to a normal distribution (see
NORM.DIST/NORMDIST function)
A normal distribution has a kurtosis of zero. A more peaked distribution has a positive kurtosis, a more flat
distribution has a negative kurtosis.
Number1, Number2, etc., are the values to be evaluated. Empty cells, text strings, and logical values are
ignored.
At least four values have to be given, otherwise, the function returns a #DIV/0! error value.
Note:

This function does not accept value pairs (x value and y value) as arguments, but only the values of the
distribution. If the same values appear multiple times, they must be repeated in the argument list accordingly
(see example).
Example:

Measuring the height of several test persons led to the following results: 1 x 1.60m, 2 x 1.65m, 4 x 1.70m, 2 x
1.75m, and 1x1.80m.
To calculate the kurtosis of this distribution, the following formula can be used:
KURT(1.60, 1.65, 1.65, 1.70, 1.70, 1.70, 1.70, 1.75, 1.75, 1.80) returns 0.08036.
See also:

SKEW, NORM.DIST/NORMDIST

LARGE (k-th largest number)
Syntax:

LARGE(Range, k)
Description:

Returns the k-th largest value in a data set.
Range is the cell range or array to be evaluated.
k determines which number to return. If k=1, the largest value will be returned, if k=2, the second largest value
will be returned, etc.
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k must not be smaller than 1 or greater than the total number of values in Range. Otherwise, the function
returns a #NUM! error value.
Example:

If the cells A1:A5 are filled with the numbers 4, 2, 6, 5, and 9:
LARGE(A1:A5, 1) returns 9
LARGE(A1:A5, 2) returns 6
LARGE(A1:A5, 3) returns 5
etc.
See also:

SMALL, MAX, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, RANK.AVG/RANK.EQ/RANK

LASTPRINTED (date last printed)
Syntax:

LASTPRINTED()
Description:

Returns the date the current document was last printed.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

LASTSAVED
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LASTSAVED (date last saved)
Syntax:

LASTSAVED()
Description:

Returns the date the current document was last saved.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

LASTPRINTED

LCM (least common multiple)
Syntax:

LCM(Number1 [, Number2, Number3 ...])
Description:

Returns the LCM (least common multiple) of the specified integers. The LCM is the smallest positive integer
that is a multiple of the given integers.
Number1, Number2, etc., are the numbers to be evaluated. All of them must be ³ 1. Additionally, all of them
should be integers, digits right of the decimal point are ignored.
Example:

LCM(5, 10, 15) returns 30
If cells A1 to A3 contain the values 4, 8, and 6:
LCM(A1:A3) returns 24
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See also:

GCD

LEFT (left part of a text string)
Syntax:

LEFT(Text [, n])
Description:

Returns the first n characters of Text.
If n is omitted, only the first character is returned.
Example:

LEFT("peanut", 3) returns pea
LEFT("peanut") returns p
See also:

RIGHT, MID, REPLACE, LEN

LEN (length)
Syntax:

LEN(Value)
Description:

Returns the number of characters in a text string.
Value is the value to be evaluated, usually a text string. If Value is a number, a date, or a logical value, it will
be converted to a text string automatically.
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Example:

LEN("Text") returns 4
LEN(42) returns 2
LEN(-42) returns 3
LEN(42.5) returns 4
LEN(TRUE) returns 4
See also:

LEFT, RIGHT, MID

LINEST (statistics of a linear regression)
Syntax:

LINEST(y_values [, x_values] [, Constant] [, Stats])
Description:

Returns statistics of a linear regression.
Linear regression is a statistical technique that adapts a line (called "trend line" or "best-fit line") to a set of
data points (for example, the results of a series of measurements).
The LINEST function calculates a trend line from the given y values and x values, and then returns an array in
the form {m,b}. The coefficient m is the slope of the trend line, the constant b is the y-intercept point (the point
where the trend line intersects the y axis).
The equation for trend lines is:
y = m*x + b
If more than one range of x-values is given, the equation is:
y = (m1*x1) + (m2*x2) + ... + (mn*xn) + b
In this case, LINEST returns an array in the form {mn, mn-1, ..., m2, m1, b}.
Additionally, if the optional argument Stats is used, several statistics of the regression (standard error,
coefficient of determination, etc.) are appended to the resulting array.
y_values are the known y values.
x_values (optional) are the known x values. If omitted, the values 1, 2, 3, ... will be used.
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Constant (optional) is a logical value that lets you specify if the constant b (the y-intercept point) should be
calculated automatically or forced to equal zero:
TRUE or omitted: b will be calculated from the given data.
FALSE: b is forced to equal 0 (zero), the m coefficient(s) are adjusted accordingly.
Stats (optional) is a logical value that lets you specify if additional regression statistics should be returned:
FALSE or omitted: Do not return additional statistics.
TRUE: Return additional regression statistics. In this case, a matrix in the following form will be returned:
{mn, mn-1, ..., m2, m1, b; smn, smn-1, ..., sm2, sm1, sb; R2, sey; F, df; ssreg, ssresid}
A graphical representation of this array would look like this:

The abbreviations used in this illustration represent the following values:
Abbreviation

Description

sm1, sm2, etc.

Standard error for the coefficients m1, m2, etc.

sb

Standard error for constant b

R2

Square of the Pearson product moment correlation coefficient

sey

Standard error for y

F

F statistic

df

Degrees of freedom

ssreg

Regression sum of squares

ssresid

Residual sum of squares

Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
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Example:

LINEST({4;5;6}) returns the matrix {1,3}, which indicates that the coefficient m equals 1 and the constant b
equals 3.
See also:

LOGEST, TREND, GROWTH

LN (natural logarithm)
Syntax:

LN(Number)
Description:

Returns the natural logarithm (base e) of Number.
Number must be > 0.
Example:

LN(0.7) returns -0.3567
LN(EXP(1.234)) returns 1.234
Hint:

The inverse function is EXP.
See also:

EXP, LOG, LOG10, POWER

LOG (logarithm)
Syntax:

LOG(Number [, Base])
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Description:

Returns the logarithm of Number to the specified base.
Number must be > 0.
If Base is omitted, base 10 is used.
Example:

LOG(100) equals log 10 (100), and returns 2
LOG(10 ^ 0.1234) returns 0.1234
LOG(8, 2) equals log 2 (8), and returns 3
See also:

LOG10, LN, EXP, POWER

LOG10 (base-10 logarithm)
Syntax:

LOG10(Number)
Description:

Returns the base-10 logarithm of Number.
Number must be > 0.
Example:

LOG10(100) returns 2
LOG10(10 ^ 0.1234) returns 0.1234
See also:

LOG, LN, EXP
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LOGEST (statistics of an exponential regression)
Syntax:

LOGEST(y_values [, x_values] [, Constant] [, Stats])
Description:

Returns statistics of an exponential regression.
Exponential regression is a statistical technique that adapts an exponential curve to a set of data points (for
example, the results of a series of measurements).
The equation for this exponential curve is:
y = b*m^x
If more than one range of x-values is given, the equation is:
y = b * (m1^x1) * (m2^x2) * ... * (mn^xn)
The LOGEST function calculates this exponential line from the given y values and x values, and then returns an
array in the form {mn, mn-1, ..., m2, m1, b}.
y_values are the known y values.
x_values (optional) are the known x values. If omitted, the values 1, 2, 3, ... will be used.
Constant (optional) is a logical value that lets you specify if the constant b should be calculated automatically
or forced to equal one:
TRUE or omitted: b will be calculated from the given data.
FALSE: b is forced to equal 1 (one), the m values are adjusted accordingly.
Statistics (optional) is a logical value that lets you specify if additional regression statistics should be returned:
FALSE or omitted: Do not return additional statistics.
TRUE: Return additional regression statistics. In this case, a matrix in the following form will be returned:
{mn, mn-1, ..., m2, m1, b; smn, smn-1, ..., sm2, sm1, sb; R2, sey; F, df; ssreg, ssresid}
A graphical representation of this array would look like this:
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The abbreviations used in this illustration represent the following values:
Abbreviation

Description

sm1, sm2, etc.

Standard error for the coefficients m1, m2, etc.

sb

Standard error for constant b

R2

Square of the Pearson product moment correlation coefficient

sey

Standard error for y

F

F statistic

df

Degrees of freedom

ssreg

Regression sum of squares

ssresid

Residual sum of squares

Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
See also:

LINEST, TREND, GROWTH

LOGINV (percentiles of the gamma distribution)
Note: LOGINV is supplemented by the new identical function LOGNORM.INV, which is available in newer
versions of Microsoft Excel (2010 or later).
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Syntax:

LOGINV(Probability, Mean, StdDev)
Description:

Returns the inverse of the lognormal cumulative distribution function (i.e., percentiles of this distribution)
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Mean is the mean of LN(x).
StdDev is the standard deviation of LN(x). Must be > 0.
See also:

LOGNORM.INV, LN, LOGNORM.DIST/LOGNORMDIST, NORM.DIST/NORMDIST,
NORM.S.DIST/NORMSDIST

LOGNORMDIST (lognormal distribution)
Note: LOGNORMDIST is supplemented by the new function LOGNORM.DIST with additional
functionality, which is available in newer versions of Microsoft Excel (2010 or later).

Syntax:

LOGNORMDIST(x, Mean, StdDev)
Description:

Returns the lognormal cumulative distribution.
x is the value to be evaluated. Must be > 0.
Mean is the mean of LN(x).
StdDev is the standard deviation of LN(x). Must be > 0.
See also:

LOGNORM.DIST, LN, LOGNORM.INV/LOGINV, NORM.DIST/NORMDIST,
NORM.S.DIST/NORMSDIST
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LOGNORM.DIST (lognormal distribution)
Syntax:

LOGNORM.DIST(x, Mean, StdDev, Cumulative)
Description:

Returns the lognormal (cumulative) distribution.
x is the value to be evaluated. Must be > 0.
Mean is the mean of LN(x).
StdDev is the standard deviation of LN(x). Must be > 0.
Cumulative determines the type of function as a switch: If you enter the value TRUE, the cumulative normal
distribution function is calculated. By entering the value FALSE, the normal probability density function is
calculated.
Note:

The LOGNORM.DIST function supplements the previous LOGNORMDIST function with the additional
argument Cumulative.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

The inverse function is LOGNORM.INV.
See also:

LOGNORMDIST, LN, LOGNORM.INV/LOGINV, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST

LOGNORM.INV (percentiles of the gamma distribution)
Syntax:

LOGNORM.INV(Probability, Mean, StdDev)
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Description:

Returns the inverse of the lognormal cumulative distribution function (i.e., percentiles of this distribution)
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Mean is the mean of LN(x).
StdDev is the standard deviation of LN(x). Must be > 0.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

LOGNORM.INV is the inverse function of LOGNORM.DIST.
See also:

LOGINV, LN, LOGNORM.DIST/LOGNORMDIST, NORM.DIST/NORMDIST,
NORM.S.DIST/NORMSDIST

LOOKUP (search cell range)
Annotation:

The LOOKUP function scans a cell range for the specified value and then returns another cell located at a
matching position (e.g., in the same row, but a different column). Important: The data to be searched in has to
be sorted in ascending order.
Hint: There are two alternatives to this function that can also search unsorted data and are more flexible in
general: VLOOKUP and HLOOKUP
The LOOKUP function can be used in two different ways:
Usage with two one-dimensional ranges: Scans a vector (i.e., a one-dimensional cell range) for the specified
value and returns the corresponding cell in another vector.
Usage with one two-dimensional range: Scans the first row (or column) of a range for the specified value and
returns the corresponding cell in another column (or row, respectively) of the same range.
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Usage with two one-dimensional ranges
Syntax:

LOOKUP(Crit, LookupVector, ResultVector)
Description:

This variant of LOOKUP scans LookupVector for the specified value. If found, the function returns the
content of the cell located in the same row (or column) of the ResultVector.
If no exact match is found, the next smallest value will be taken. If no smaller value exists, a #N/A error value
is returned.
Crit is the value to search for (case insensitive).
LookupVector is the cell range or array to search in. It must be a vector, which is a range of either just one row
or one column.
Important: The data in LookupVector must be sorted in ascending order, otherwise this function might return
wrong results. If the values are not sorted, use VLOOKUP or HLOOKUP instead of LOOKUP
ResultVector is the cell range or array with the values to pick the result from. It also has to be a vector.
Additionally, its size and its orientation (horizontal or vertical) must be identical to LookupVector.
Example:

In the following table ...

... LOOKUP returns the following results:
LOOKUP(1, A1:A3, B1:B3) returns Result_1
LOOKUP(2, A1:A3, B1:B3) returns Result_2
LOOKUP(3, A1:A3, B1:B3) returns Result_3
LOOKUP(2.5, A1:A3, B1:B3) returns Result_2 (because it is the next smallest value)
LOOKUP(10, A1:A3, B1:B3) returns Result_3 (because it is the next smallest value)
LOOKUP(0, A1:A3, B1:B3) returns #N/A
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See also:

VLOOKUP, HLOOKUP, INDEX, MATCH

Usage with one two-dimensional range
Syntax:

LOOKUP(Crit, Range)
Description:

This variant of LOOKUP scans the first column (or row) of Range for the specified value. If found, the
function returns the content of the cell located at the same position in the last column (or row, respectively) of
Range.
If no exact match is found, the next smallest value will be taken. If no smaller value exists, a #N/A error value
is returned.
Crit is the value to search for (case insensitive).
Range is the cell range or array to search in.
The dimensions of Range determine in which direction it will be scanned:
If Range has more columns than rows, the first row is scanned.
If Range has more rows than columns, the first column is scanned.
Important: The scanned data in the first row (or column) of Range must be sorted in ascending order,
otherwise this function might return wrong results. If the values are not sorted, use VLOOKUP or HLOOKUP
instead of LOOKUP
Example:

In the following table ...

... LOOKUP returns the following results:
LOOKUP(1, A1:B3) returns Result_1
LOOKUP(2, A1:B3) returns Result_2
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LOOKUP(3, A1:B3) returns Result_3
LOOKUP(2.5, A1:B3) returns Result_2 (because it is the next smallest value)
LOOKUP(10, A1:B3) returns Result_3 (because it is the next smallest value)
LOOKUP(0, A1:B3) returns #N/A
See also:

VLOOKUP, HLOOKUP, INDEX, MATCH

LOWER (convert text to lower case)
Syntax:

LOWER(Text)
Description:

Converts all characters in a text string to lower case letters.
Example:

LOWER("PlanMaker") returns planmaker
See also:

UPPER, PROPER

MATCH (relative position in a range)
Syntax:

MATCH(Crit, Vector [, Mode])
Description:

Returns the relative position of Crit in Vector. For example, if Crit is the third element of Vector, the function
returns 3.
Crit is the value to be searched for. Crit can be any kind of value or a cell reference.
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Vector is the cell range or array to be evaluated. Vector must be a vector, which is an array or a cell range of
either just one row or one column.
Mode specifies the type of search to be performed:
1 or omitted: Find the largest value that is equal to or smaller than Crit. Important: In this mode, the elements
in Vector have to be sorted in ascending order. Otherwise, erroneous results might be returned.
0: Find the first value that is equal to Crit. In this mode, the elements in Vector do not have to be in sorted
order.
-1: Find the smallest value that is equal to or larger than Crit. Important: In this mode, the elements in Vector
have to be sorted in descending order. Otherwise, erroneous results might be returned.
Annotation: If you use mode 0 and Crit is a text string, wildcard characters can be used in Crit: A question
mark (?) stands for any single character, an asterisk (*) stands for any sequence of characters.
Example:

MATCH("b", {"a";"b";"c";"d"}, 0) returns 2, because "b" is the second element of the given vector.
See also:

INDEX, LOOKUP, HLOOKUP, VLOOKUP

MAX (maximum)
Syntax:

MAX(Number1 [, Number2, Number3 ...])
Description:

Returns the largest value in the given numbers.
Number1, Number2, etc., are the numbers to be evaluated. Empty cells, text strings, and logical values are
ignored.
Example:

MAX(5, 7, 4, 9) returns 9
If the cells A1:A3 contain -1, -2, and TRUE:
MAX(A1:A3) returns -1 (the logical value TRUE is ignored)
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See also:

MAXA, MIN, LARGE

MAXA (maximum)
Syntax:

MAXA(Value1 [, Value2, Value3 ...])
Description:

Returns the largest value in the given values.
Value1, Value2, etc., are the values to be evaluated. Empty cells are ignored.
Note:

Unlike MAX, MAXA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Example:

MAXA(5, 7, 4, 9) returns 9
If the cells A1:A3 contain -1, -2, and TRUE:
MAXA(A1:A3) returns 1 (since TRUE evaluates as 1)
See also:

MAX
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MDETERM (matrix determinant)
Syntax:

MDETERM(Array)
Description:

Returns the determinant of a matrix.
Array is a cell range or array containing the matrix to be evaluated. It must contain numeric values only. Its
number of rows has to equal its number of columns.
Example:

MDETERM({9,8,8; 2,4,6; 1,2,1}) returns -40
See also:

Section Working with arrays, MINVERSE, MMULT, MSOLVE, TRANSPOSE

MEDIAN
Syntax:

MEDIAN(Number1 [, Number2, Number3 ...])
Description:

Returns the median of the given set of numbers.
The median is the number in the middle of a set of numbers – half of the numbers are smaller than the median,
half of them are greater.
Number1, Number2, etc., are the numbers to be evaluated. Empty cells, text strings, and logical values are
ignored.
Note:

If the total number of values is odd, MEDIAN returns the number in the middle of the set of numbers.
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If the total number of values is even, MEDIAN returns the average of the two numbers in the middle (see
second example).
Example:

MEDIAN(1, 2, 3, 4, 5) returns 3
MEDIAN(1, 2, 3, 4, 5, 1000) returns 3.5
See also:

AVERAGE, MODE.SNGL/MODE, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE

MID (part of a text string)
Syntax:

MID(Text, Start, Count)
Description:

Returns the section of a text string that starts at character Start and is Count characters long.
Example:

MID("peanut", 2, 3) returns ean
MID("peanut", 2, 5) returns eanut
MID("peanut", 2, 100) returns eanut as well
MID("peanut", 100, 100) returns an empty text string
See also:

LEFT, RIGHT, REPLACE, FIND, SEARCH, LEN

MILLISECONDS (milliseconds)
Syntax:

MILLISECONDS(Time)
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Description:

Returns the milliseconds of a time value.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

MILLISECONDS("12:34:56.555") returns 555
See also:

HOUR, MINUTE, SECOND

MIN (minimum)
Syntax:

MIN(Number1 [, Number2, Number3 ...])
Description:

Returns the smallest value in the given numbers.
Number1, Number2, etc., are the numbers to be evaluated. Empty cells, text strings, and logical values are
ignored.
Example:

MIN(5, 7, 4, 9) returns 4
If the cells A1:A3 contain 5, 2, and TRUE:
MIN(A1:A3) returns 2 (the logical value TRUE is ignored)
See also:

MINA, MAX, SMALL
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MINA (minimum)
Syntax:

MINA(Value1 [, Value2, Value3 ...])
Description:

Returns the smallest value in the given values.
Value1, Value2, etc., are the values to be evaluated. Empty cells are ignored.
Note:

Unlike MIN, MINA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Example:

MINA(5, 7, 4, 9) returns 4
If the cells A1:A3 contain 5, 2, and TRUE:
MINA(A1:A3) returns 1 (since TRUE evaluates as 1)
See also:

MIN

MINUTE (minute)
Syntax:

MINUTE(Time)
Description:

Returns the minutes of a time value.

582

Formulas and functions

583

Example:

MINUTE("12:34:56 AM") returns 34
MINUTE("09/25/2018 10:30:56 AM") returns 30
See also:

HOUR, SECOND, MILLISECONDS

MINVERSE (inverse matrix)
Syntax:

MINVERSE(Array)
Description:

Return the inverse of a matrix.
The inverse A-1 of a matrix A is the matrix that A has to be multiplied by to receive the identity matrix 1.
Array is a cell range or array containing the matrix to be evaluated. It must contain numeric values only. Its
number of rows has to equal its number of columns.
Matrices whose determinant is zero cannot be inverted. In this case, the function returns a #NUM! error value.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Example:

MINVERSE({9,8,8;2,4,6;1,2,1}) returns:
{0.2,-0.2,-0.4;-0.1,-0.025,0.95;0,0.25,-0.5}
See also:

Section Working with arrays, MDETERM, MMULT, MSOLVE, TRANSPOSE
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MIRR (modified internal rate of return)
Syntax:

MIRR(Values, FinanceRate, ReinvestRate)
Description:

Returns the modified internal rate of return for a series of cash flows. Unlike the IRR function, MIRR considers
the finance rate (for investments) and the reinvest rate (for reinvestments).
The calculation is based on the cash flows specified in the Values argument. Payments have to be entered as
negative values, incomes as positive values. The cash flows do not have to be even but they must occur in
regular intervals (e.g., monthly).
Values is a cell range or an array containing the cash flows (in their actual order, namely, cash flow for the first
period, cash flow for the second period, etc.). At least one payment and one income have to be given.
FinanceRate is the interest rate paid for investments.
ReinvestRate is the interest rate received for reinvestments.
See also:

IRR, NPV, RATE, XIRR

MMULT (product of matrices)
Syntax:

MMULT(Array1, Array2)
Description:

Returns the product of two matrices.
Array1 and Array2 are cell ranges or arrays containing the matrices to be evaluated. They must contain
numeric values only.
Please note: The number of columns in Array1 must equal the number of rows in Array2, otherwise,
multiplication is not possible.
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Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Example:

MMULT({1,2;3,4}, {5,6;7,8}) returns {19,22;43,50}
See also:

Section Working with arrays, MDETERM, MINVERSE, MSOLVE, TRANSPOSE

MOD (remainder of a division, Excel method)
Syntax:

MOD(x, y)
Description:

Returns the remainder of the division of x by y, using the erroneous "Excel method".
Important: This function returns wrong results in some cases (see annotation below)!
Example:

MOD(5, 3) returns 2
MOD(5, 0) returns a #DIV/0! error value
MOD(5, -3) returns -1 (which is wrong – see below!)
Annotation:

Microsoft Excel returns wrong results when you use the MOD function with a negative numerator or
denominator.
PlanMaker also returns wrong results in this case (for compatibility reasons), but additionally offers a function
named MODP that returns correct results
The following table shows the differences between MOD and MODP (the results highlighted in green color are
wrong):
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Compatibility notes:

Note: The MODP function is not supported by Microsoft Excel. If you save a document in Excel format, all
calculations using this function will be replaced by their last result as a fixed value.
See also:

MODP, QUOTIENT

MODE (most frequently occurring value)
Note: MODE is supplemented by the new identical function MODE.SNGL, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

MODE(Number1 [, Number2, Number3 ...])
Description:

Returns the mode of a data set.
The mode is the value occurring most frequently in a set of numbers.
Number1, Number2, etc., are the numbers to be evaluated.
If the given numbers contain more than one mode, their smallest mode will be returned.
If the given numbers do not contain any value occurring more than once, a #N/A error value will be returned.
Example:

MODE(1, 2, 4, 4, 4, 2, 1) returns 4
MODE(1, 2, 4, 4, 2, 1) returns 1 (if there are multiple modes, the smallest one is returned)
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MODE(1, 4, 2) returns #N/A because no value occurs more than once.
See also:

MODE.SNGL, MEDIAN, NORM.DIST/NORMDIST

MODE.SNGL (most frequently occurring value)
Syntax:

MODE.SNGL(Number1 [, Number2, Number3 ...])
Description:

Returns the mode of a data set.
The mode is the value occurring most frequently in a set of numbers.
Number1, Number2, etc., are the numbers to be evaluated.
If the given numbers contain more than one mode, their smallest mode will be returned.
If the given numbers do not contain any value occurring more than once, a #N/A error value will be returned.
Example:

MODE.SNGL(1, 2, 4, 4, 4, 2, 1) returns 4
MODE.SNGL(1, 2, 4, 4, 2, 1) returns 1 (if there are multiple modes, the smallest one is returned)
MODE.SNGL(1, 4, 2) returns #N/A because no value occurs more than once.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

MODE, MEDIAN, NORM.DIST/NORMDIST
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MODP (remainder of a division, PlanMaker method)
Syntax:

MODP(x, y)
Description:

Returns the remainder of the division of x by y, using the "PlanMaker method" (see annotation below).
Example:

MODP(5, 3) returns 2
MODP(5, 0) returns a #DIV/0! error value
MODP(5, -3) returns 2 (see below)
Annotation:

Microsoft Excel returns wrong results when you use the MOD function with a negative numerator or
denominator
PlanMaker also returns wrong results in this case (for compatibility reasons), but additionally offers the MODP
function described here that returns correct results.
The following table shows the differences between MOD and MODP (the results highlighted in green color are
wrong):

Compatibility notes:

Note: The MODP function is not supported by Microsoft Excel. If you save a document in Excel format, all
calculations using this function will be replaced by their last result as a fixed value.
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See also:

MOD, QUOTIENT

MONTH (month of a date)
Syntax:

MONTH(Date)
Description:

Returns the month of a date.
Example:

MONTH("09/25/2018") returns 9
See also:

YEAR, ISOWEEK, WEEKNUM, DAY, WEEKDAY

MROUND (round to a multiple of base)
Syntax:

MROUND(Number, Base)
Description:

Rounds Number to the nearest multiple of Base.
Base must be > 0.
If the remainder of the division of Number by Base is smaller than half the value of Base, MROUND rounds
down. If it is greater than or equal to half the value of Base, MROUND rounds up (see examples below).
Example:

MROUND(1234.5678, 1) returns 1235
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MROUND(1234.5678, 0.01) returns 1234.57
MROUND(22, 5) returns 20
MROUND(23, 5) returns 25
MROUND(22.5, 5) returns 25
See also:

FLOOR, CEILING, ROUNDDOWN, ROUNDUP, ROUND, TRUNC, INT

MSOLVE (solution of matrix equation Ax=B)
Syntax:

MSOLVE(ArrayA, VectorB)
Description:

Returns the solution to a linear system of equations by solving the matrix equation Ax=B.
ArrayA is the cell range or array containing matrix A. It must contain numeric values only. Its number of rows
has to equal its number of columns.
The determinant of this matrix must not be zero, otherwise, the equation cannot be solved.
VectorB is the cell range or array containing vector B. VectorB must be a vector, which is an array or a cell
range of just one column.
The result of this function is a vector with the solutions.
Please note: The MSOLVE function only calculates correctly if the vector with the solutions is arranged as a
column. To arrange the vector with the solutions in a row, you also need to use the TRANSPOSE function with
the following syntax:
TRANSPOSE(MSOLVE(ArrayA, VectorB))
Annotation:

The result of this function is calculated using singular value decomposition. When applied to large matrices
(more than 10, 20 rows), significant rounding errors can occur.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
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Example:

To solve the following linear system of equations ...
2x + 3y = 4
2x + 2y = 8
... use the following formula:
MSOLVE({2,3;2,2}, {4,8})
The result is the vector {8;-4}, which means that x=8 and y=-4.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

Section Working with arrays, MDETERM, MINVERSE, MMULT, TRANSPOSE

MULTINOMIAL (multinomial coefficient)
Syntax:

MULTINOMIAL(Number1 [, Number2, Number3 ...])
Description:

Returns the multinomial coefficient ("polynomial coefficient") of a set of numbers.
Number1, Number2, etc., are the numbers to be evaluated. All of them have to be ³ 1.
Example:

MULTINOMIAL(1, 2, 3, 4, 5) returns 37837800
Note:

The functions MULTINOMIAL and POLYNOMIAL are completely identical.
See also:

POLYNOMIAL, FACT
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N (convert value into number)
Syntax:

N(Value)
Description:

Converts a value to a number.
Note:

This function was retained only for compatibility with older spreadsheet applications. It is no longer commonly
used, as current spreadsheet applications (including PlanMaker) automatically convert values into numbers,
where necessary.
Example:

N("Text") returns 0
N("42") returns 0
N(42) returns 42
N(TRUE) returns 1
If A1 contains the date 09/25/2014:
N(A1) returns 41907 (the serial number of that date)
See also:

T, VALUE, TEXT

NA (error value #N/A)
Syntax:

NA()
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Description:

Returns the error value #N/A ("not available"). Entering =NA() in a cell indicates that the value in this cell is
currently not available.
Use this function in a cell that is empty, but definitely has to be filled out later in order to receive correct results
in calculations made with this cell. As a result, all calculations referring to this cell will also return a #N/A error
value (instead of an incorrect result).
If, for example, you calculate the sum of your assets in a balance sheet, but some of the required values are still
missing, enter =NA() in these empty cells. As a result, the sum will be a #N/A error value instead of an
incomplete value.
Annotation:

Instead of entering =NA() into a cell you can also type #N/A, which will lead to the same result.
See also:

ISNA, ISERR, ISERROR, ERRORTYPE, section Error values

NEG (negative value)
Syntax:

NEG(Number)
Description:

Return the negative value of Number.
Example:

NEG(42) returns -42
NEG(-42) returns 42
NEG(0) returns 0
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Instead of using NEG, you can simply multiply the value by -1:
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NEG(x) equals (-1) * x.
See also:

ABS, SIGN

NEGBINOMDIST (negative binomial distribution)
Note: NEGBINOMDIST is supplemented by the new function NEGBINOM.DIST with additional
functionality, which is available in newer versions of Microsoft Excel (2010 or later).

Syntax:

NEGBINOMDIST(k, r, p)
Description:

Returns the negative binomial distribution (also known as Pascal distribution).
The negative binomial distribution can be used to calculate the probability to receive k failures before the r-th
success in an experiment with independent trials and only two possible outcomes (success or failure) with a
fixed probability of p for each trial.
k is the number of failures. Must be ³ 0.
r is the number of successes. Must be ³ 0.
p is the probability of a success for each trial run. Must be in the range 0 to 1.
Example:

In an urn there are 1 red and 5 black balls. What is the probability (with the balls being returned) to draw
exactly 10 black balls (=failures) before the 2nd red ball (=success) is drawn?
NEGBINOMDIST(10, 2, 1/6) returns 0.04935.
See also:

NEGBINOM.DIST, BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST, HYPGEOM.DIST/HYPGEOMDIST
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NEGBINOM.DIST (negative binomial distribution)
Syntax:

NEGBINOM.DIST(k, r, p, Cumulative)
Description:

Returns the negative binomial distribution (also known as Pascal distribution).
The negative binomial distribution can be used to calculate the probability to receive k failures before the r-th
success in an experiment with independent trials and only two possible outcomes (success or failure) with a
fixed probability of p for each trial.
k is the number of failures. Must be ³ 0.
r is the number of successes. Must be ³ 0.
p is the probability of a success for each trial run. Must be in the range 0 to 1.
Cumulative determines the type of function as a switch: If you enter the value TRUE, the cumulative
distribution function of the negative binomial distribution is calculated. By entering the value FALSE, the
probability mass function of the negative binomial distribution is calculated.
Example:

In an urn there are 1 red and 5 black balls. What is the probability (with the balls being returned) to draw
exactly or at most 10 black balls (=failures) before the 2nd red ball (=success) is drawn?
NEGBINOM.DIST(10, 2, 1/6, FALSE) returns 0.04935
NEGBINOM.DIST(10, 2, 1/6, TRUE) returns 0.61867
The probability of having to draw exactly 10 black balls is 4.9% (probability mass function). The probability of
having to draw at most 10 black balls is 61.9% (cumulative distribution function).
Note:

The NEGBINOM.DIST function supplements the previous NEGBINOMDIST function with the additional
argument Cumulative.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

NEGBINOMDIST, BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST, HYPGEOM.DIST/HYPGEOMDIST
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NETWORKDAYS (number of workdays)
Syntax:

NETWORKDAYS(StartDate, EndDate [, Holidays])
Description:

Returns the number of workdays between StartDate and EndDate.
The function counts workdays only, Saturdays and Sundays are skipped. Optionally, you can specify a list of
holidays to be skipped as well (see Holidays parameter).
StartDate and EndDate are the first and the last day of the time interval to be evaluated.
Holidays (optional) is a cell range or an array containing a list of dates to be skipped (e.g. holidays).
Example:

NETWORKDAYS("01/01/2010", "01/31/2010") returns 22.
See also:

WORKDAY, DAYS/DAYSP, DAYS360, DATEDIF, HOLIDAY

NOMINAL (nominal interest rate)
Syntax:

NOMINAL(EffRate, NPerYear)
Description:

Returns the nominal annual interest rate, given the effective annual interest rate and the number of
compounding periods per year.
EffRate is the effective annual interest rate.
NPerYear is the number of compounding periods per year.
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Example:

To calculate the nominal annual interest rate of an investment with an effective annual interest rate of 5%,
compounded quarterly:
NOMINAL(5%, 4) returns approx. 4.91%
See also:

EFFECT

NORMDIST (normal distribution)
Note: NORMDIST is supplemented by the new identical function NORM.DIST, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

NORMDIST(x, Mean, StdDev, Cumulative)
Description:

Returns the normal distribution (also known as Gaussian distribution).
The normal distribution is one of the most important distributions in statistics, since many distributions follow
it.
X is the value to be evaluated.
Mean is the arithmetic mean of the distribution.
StdDev is the standard deviation of the distribution. Must be > 0.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.

Left: density function ("bell curve"), right: distribution function
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See also:

NORM.DIST, NORM.INV/NORMINV, NORM.S.DIST/NORMSDIST, NORM.S.INV/NORMSINV

NORM.DIST (normal distribution)
Syntax:

NORM.DIST(x, Mean, StdDev, Cumulative)
Description:

Returns the normal distribution (also known as Gaussian distribution).
The normal distribution is one of the most important distributions in statistics, since many distributions follow
it.
X is the value to be evaluated.
Mean is the arithmetic mean of the distribution.
StdDev is the standard deviation of the distribution. Must be > 0.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.

Left: density function ("bell curve"), right: distribution function

Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

NORMDIST, NORM.INV/NORMINV, NORM.S.DIST/NORMSDIST, NORM.S.INV/NORMSINV
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NORMINV (percentiles of the normal distribution)
Note: NORMINV is supplemented by the new identical function NORM.INV, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

NORMINV(Probability, Mean, StdDev)
Description:

Returns the inverse of the normal cumulative distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Mean is the arithmetic mean of the distribution.
StdDev is the standard deviation of the distribution. Must be > 0.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
See also:

NORM.INV, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST, NORM.S.INV/NORMSINV

NORM.INV (percentiles of the normal distribution)
Syntax:

NORM.INV(Probability, Mean, StdDev)
Description:

Returns the inverse of the normal cumulative distribution function (i.e., percentiles of this distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Mean is the arithmetic mean of the distribution.
StdDev is the standard deviation of the distribution. Must be > 0.
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Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

NORM.INV is the inverse function of NORM.DIST.
See also:

NORMINV, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST, NORM.S.INV/NORMSINV

NORMSDIST (standard normal distribution)
Note: NORMSDIST is supplemented by the new function NORM.S.DIST with additional functionality,
which is available in newer versions of Microsoft Excel (2010 or later).

Syntax:

NORMSDIST(x)
Description:

Returns the standard normal cumulative distribution function.
The standard normal distribution is a normal distribution (see NORM.DIST/NORMDIST function) with a mean
of zero and a standard deviation of one
x is the value to be evaluated.
See also:

NORM.S.DIST, NORM.INV/NORMINV, NORM.S.INV/NORMSINV, STANDARDIZE, GAUSS,
LOGNORM.INV/LOGINV, LOGNORM.DIST/LOGNORMDIST
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NORM.S.DIST (standard normal distribution)
Syntax:

NORM.S.DIST(x, cumulative)
Description:

Returns the standard normal (cumulative) distribution function.
The standard normal distribution is a normal distribution (see NORM.DIST/NORMDIST function) with a mean
of zero and a standard deviation of one
x is the value to be evaluated.
Cumulative determines the type of function as a switch: If you enter the value TRUE, the cumulative
distribution function of the standard normal distribution is calculated. By entering the value FALSE, the density
function of the standard normal distribution is calculated.
Note:

The NORM.S.DIST function supplements the previous NORMSDIST function with the additional argument
Cumulative.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
Hint:

The inverse function is NORM.S.INV.
See also:

NORMSDIST, NORM.INV/NORMINV, NORM.S.INV/NORMSINV, STANDARDIZE, GAUSS,
LOGNORM.INV/LOGINV, LOGNORM.DIST/LOGNORMDIST

NORMSINV (percentiles of the standard distribution)
Note: NORMSINV is supplemented by the new identical function NORM.S.INV, which is available in
newer versions of Microsoft Excel (2010 or later).
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Syntax:

NORMSINV(Probability)
Description:

Returns the inverse of the standard normal cumulative distribution function (i.e., percentiles of this
distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
See also:

NORM.S.INV, NORM.INV/NORMINV, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST

NORM.S.INV (percentiles of the standard distribution)
Syntax:

NORM.S.INV(Probability)
Description:

Returns the inverse of the standard normal cumulative distribution function (i.e., percentiles of this
distribution).
Probability is the probability to be evaluated. Must be in the range 0 to 1.
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
100 iterations, a #N/A error value is returned.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
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NORM.S.INV is the inverse function of NORM.S.DIST.
See also:

NORMSINV, NORM.INV/NORMINV, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST

NOT (logical NOT function)
Syntax:

NOT(Value)
Description:

Performs a logical negation.
Value must be a logical value or a calculation returning a logical value.
Example:

NOT(TRUE) returns FALSE
NOT(FALSE) returns TRUE
NOT(A1=0) returns TRUE, if A1 contains a value different from zero.
See also:

OR, AND, XOR

NOW (current date and time)
Syntax:

NOW()
Description:

Returns the current date and time.

603

Formulas and functions

604

Note:

The result is a serial date number. PlanMaker automatically formats it in time format so that it will be displayed
as a time. To select a different date/time format (e.g., to have date and time displayed), use the Format > Cell
menu command.
See also:

TODAY, CREATEDATE

NPER (number of periods)
Syntax:

NPER(Rate, Pmt, PV [, FV] [, Type])
Description:

Returns the number of payment periods of an investment based on periodic constant payments, and a constant
interest rate.
Rate is the interest rate (per payment period).
Pmt is the payment made for each period.
PV is the present value.
FV (optional) is the future value. If omitted, it will be set to zero.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
See also:

FV, IPMT, PMT, PPMT, PV, RATE
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NPV (net present value)
Syntax:

NPV(Rate, Value1 [, Value2, Value3 ...])
Description:

Returns the net present value of an investment based on regular cash flows and a fixed discount rate.
Rate is the discount rate (per payment period).
Value1, Value2 are the cash flows. You can specify either single values or a cell range. Important: All cash
flows have to occur at the end of each period.
Payments have to be entered as negative values, incomes as positive values. The cash flows do not have to be
even but they must occur in regular intervals (at the end of each period) and be entered in their actual order,
namely, cash flow for the first period, cash flow for the second period, etc.
A zero has to be entered for periods where no cash flow occurred.
Differences to the PV function:
1. Cash flows do not have to be even.
2. Cash flows must occur at the end of each period.
Example:

NPV(6.5%, 4000, 5000) returns 8164.16
See also:

PV, XNPV, IRR

OCT2BIN (octal number to binary number)
Syntax:

OCT2BIN(Number [, Digits])
Description:

Converts the given octal number (base 8) to a binary number (base 2).
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Number is the number to be converted. It must be in the range 20000000000 to 17777777777. Negative
numbers have to be transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

OCT2BIN("52") returns 101010
OCT2BIN("52", 8) returns 00101010
OCT2BIN("52", 2) returns the error value #NUM!, because this number cannot be represented with fewer than
6 binary digits
OCT2BIN("37777777726") returns 11111111111111111111111111010110 (negative value)
See also:

BIN2OCT, OCT2DEC, OCT2HEX

OCT2DEC (octal number to decimal number)
Syntax:

OCT2DEC(Number)
Description:

Converts the given octal number (base 8) to a decimal number (base 10).
Number is the number to be converted. It must be in the range 20000000000 to 17777777777. Negative
numbers have to be transformed to two's complement notation (see last example).
Example:

OCT2DEC("52") returns 42
OCT2DEC("0052") returns 42 as well
OCT2DEC("37777777726") returns -42

Formulas and functions

607

See also:

DEC2OCT, OCT2BIN, OCT2HEX, DECIMAL

OCT2HEX (octal number to hexadecimal number)
Syntax:

OCT2HEX(Number [, Digits])
Description:

Converts the given octal number (base 8) to a hexadecimal number (base 16).
Number is the number to be converted. It must be in the range 20000000000 to 17777777777. Negative
numbers have to be transformed to two's complement notation (see last example).
The optional argument Digits lets you specify the number of places to be displayed. If omitted, PlanMaker
determines the number of required places automatically.
Digits has to be greater than zero. If Digits is smaller than the minimum number of places required to display
the number, the function returns a #NUM error value.
Digits will be ignored if Number is negative.
Example:

OCT2HEX("52") returns 2A
OCT2HEX("0052") returns 2A as well
OCT2HEX("52", 1) returns the error value #NUM!, because this number cannot be represented with fewer than
2 hexadecimal digits
OCT2HEX("37777777726") returns FFFFFFD6 (negative value)
See also:

HEX2OCT, OCT2BIN, OCT2DEC
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ODD (round up to next odd number)
Syntax:

ODD(Number)
Description:

Rounds Number up (away from zero) to the nearest odd integer.
Example:

ODD(41) returns 41
ODD(42) returns 43
ODD(-42) returns -43
See also:

EVEN, ROUNDDOWN, ROUNDUP, ROUND, MROUND

OFFSET (shifted reference)
Syntax:

OFFSET(Reference, Rows, Columns [, Height] [, Width])
Description:

Returns a cell reference shifted by the specified number of rows and columns. Additionally, the size of the
reference can be modified.
Reference is the cell reference to be evaluated.
Rows is the number of rows Reference will be shifted. Positive values shift downwards, negative values shift
upwards.
Columns is the number of columns Reference will be shifted. Positive values shift to the right, negative values
shift to the left.
Height (optional) changes the height of Reference to the specified number of rows. Height must be a positive
value.
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Width (optional) changes the width of Reference to the specified number of columns. Width must be a
positive value.
Example:

OFFSET(A1, 2, 0) returns a reference to A3
OFFSET(A1:C3, 1, 1) returns a reference to B2:D4
OFFSET(A1:C3, 1, 1, 5, 3) returns a reference to B2:D6
SUM(OFFSET(A1:C3, 1, 1, 5, 3)) returns the sum of the values in B2:D6
See also:

ADDRESS, INDIRECT, COLUMN, ROW

OR (logical OR function)
Syntax:

OR(Value1 [, Value2, Value3 ...])
Description:

OR returns the logical value TRUE if at least one of the given arguments is TRUE, otherwise it returns FALSE.
You can use this function to verify that at least one of multiple conditions is fulfilled.
Example:

OR(TRUE, TRUE) returns TRUE
OR(TRUE, FALSE) returns TRUE
OR(FALSE, FALSE) returns FALSE
OR(A1=0, A1>10) returns TRUE, if A1 is either zero or greater than ten.
See also:

XOR, AND, NOT
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PEARSON (Pearson correlation coefficient)
Syntax:

PEARSON(Range1, Range2)
Description:

Returns the Pearson product-moment correlation coefficient r.
This coefficient is a measure of the strength of the linear relationship between two data sets.
The result of the PEARSON function is in the range -1 to 1:
1 indicates a perfect linear relationship.
-1 indicates a perfect inverse linear relationship (the values in Range2 decrease as the values in Range1
increase).
0 indicates that there is no linear relationship at all.
Range1 is the cell range or array containing the independent values. Empty cells, text and logical values are
ignored.
Range2 is the cell range or array containing the dependent values. Empty cells, text and logical values are
ignored.
Range1 and Range2 must have the same number of values, otherwise the function returns a #N/A error value.
Example:

If A1:A3 contains the values 1, 2, 3 and B1:B3 contains 2, 3, 4:
PEARSON(A1:A3, B1:B3) returns 1
If A1:A3 contains the values 1, 2, 3 and B1:B3 contains 4, 3, 2:
PEARSON(A1:A3, B1:B3) returns -1
See also:

RSQ, SLOPE, INTERCEPT
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PERCENTILE (percentiles of a data set)
Note: PERCENTILE is supplemented by the new identical function PERCENTILE.INC and the completely
new function PERCENTILE.EXC, which are available in newer versions of Microsoft Excel (2010 or later).

Syntax:

PERCENTILE(Range, k)
Description:

Returns the k-th percentile of a data set.
For example, if k is 0.5, the 0.5 percentile (i.e., the median) will be returned.
Range is the cell range containing the values to be evaluated.
k is the percentile to be returned. Must be in the range 0 to 1 (inclusive) with 0=0% and 1=100%.
Example:

If A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
PERCENTILE(A1:A9, 0.75) returns 7
See also:

PERCENTILE.INC/PERCENTILE.EXC, QUARTILE.EXC/QUARTILE.INC/QUARTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, MEDIAN, MODE.SNGL/MODE,
RANK.AVG/RANK.EQ/RANK

PERCENTILE.EXC (percentiles of a data set)
Syntax:

PERCENTILE.EXC(Range, k)
Description:

Returns the k-th percentile of a data set.
For example, if k is 0.5, the 0.5 percentile (i.e., the median) will be returned.
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Range is the cell range containing the values to be evaluated.
k is the percentile to be returned. Must be in the range 0 to 1 (exclusive) with 0=0% and 1=100%.
Example:

If A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
PERCENTILE.EXC(A1:A9, 0.75) returns 7.5
Note:

The PERCENTILE.EXC function supplements together with PERCENTILE.INC the previous PERCENTILE
function.
PERCENTILE.INC returns the same result as PERCENTILE (values 0 to 1 inclusive).
PERCENTILE.EXC (values 0 to 1 exclusive) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

PERCENTILE.INC/PERCENTILE, QUARTILE.EXC/QUARTILE.INC/QUARTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, MEDIAN, MODE.SNGL/MODE,
RANK.AVG/RANK.EQ/RANK

PERCENTILE.INC (percentiles of a data set)
Syntax:

PERCENTILE.INC(Range, k)
Description:

Returns the k-th percentile of a data set.
For example, if k is 0.5, the 0.5 percentile (i.e., the median) will be returned.
Range is the cell range containing the values to be evaluated.
k is the percentile to be returned. Must be in the range 0 to 1 (inclusive) with 0=0% and 1=100%.

Formulas and functions

613

Example:

If A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
PERCENTILE.INC(A1:A9, 0.75) returns 7
Note:

The PERCENTILE.INC function supplements together with PERCENTILE.EXC the previous PERCENTILE
function.
PERCENTILE.INC returns the same result as PERCENTILE (values 0 to 1 inclusive).
PERCENTILE.EXC (values 0 to 1 exclusive) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

PERCENTILE.EXC/PERCENTILE, QUARTILE.EXC/QUARTILE.INC/QUARTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, MEDIAN, MODE.SNGL/MODE,
RANK.AVG/RANK.EQ/RANK

PERCENTRANK (percent rank in a data set)
Note: PERCENTRANK is supplemented by the new identical function PERCENTRANK.INC and the
completely new function PERCENTRANK.EXC, which are available in newer versions of Microsoft Excel
(2010 or later).

Syntax:

PERCENTRANK(Range, Number [, Digits])
Description:

Returns the percentile rank (between 0 and 1 inclusive) of a value in a data set.
Range is a cell range containing the values to be evaluated.
Number is the value whose rank you want to determine. If Number is not included in the given values,
interpolation will be used.
Digits (optional) is the number of significant digits for the returned value. Must be ³ 1. If omitted, 3 digits will
be used.
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Example:

If A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
PERCENTRANK(A1:A9, 5) returns 0.5 (=50%) middle of the given values; median
PERCENTRANK(A1:A9; 1) returns 0

(=0%) minimum value

PERCENTRANK(A1:A9; 9) returns 1

(=100%) maximum value

See also:

PERCENTRANK.INC/PERCENTRANK.EXC, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
QUARTILE.EXC/QUARTILE.INC/QUARTILE, RANK.AVG/RANK.EQ/RANK

PERCENTRANK.EXC (percent rank in a data set)
Syntax:

PERCENTRANK.EXC(Range, Number [, Digits])
Description:

Returns the percentile rank (between 0 and 1 exclusive) of a value in a data set.
Range is a cell range containing the values to be evaluated.
Number is the value whose rank you want to determine. If Number is not included in the given values,
interpolation will be used.
Digits (optional) is the number of significant digits for the returned value. Must be ³ 1. If omitted, 3 digits will
be used.
Example:

If A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
PERCENTRANK.EXC(A1:A9, 5) returns 0.5

(=50%) middle of the given values; median

PERCENTRANK.EXC(A1:A9, 1) returns 0.1

(=10%) minimum value

PERCENTRANK.EXC(A1:A9, 9) returns 0.9

(=90%) maximum value

Note:

The PERCENTRANK.EXC function supplements together with PERCENTRANK.INC the previous
PERCENTRANK function.
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PERCENTRANK.INC returns the same result as PERCENTRANK (values 0 to 1 inclusive).
PERCENTRANK.EXC (values 0 to 1 exclusive) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

PERCENTRANK/PERCENTRANK.INC, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
QUARTILE.EXC/QUARTILE.INC/QUARTILE, RANK.AVG/RANK.EQ/RANK

PERCENTRANK.INC (percent rank in a data set)
Syntax:

PERCENTRANK.INC(Range, Number [, Digits])
Description:

Returns the percentile rank (between 0 and 1 inclusive) of a value in a data set.
Range is a cell range containing the values to be evaluated.
Number is the value whose rank you want to determine. If Number is not included in the given values,
interpolation will be used.
Digits (optional) is the number of significant digits for the returned value. Must be ³ 1. If omitted, 3 digits will
be used.
Example:

If A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
PERCENTRANK.INC(A1:A9, 5) returns 0.5

(=50%) middle of the given values; median

PERCENTRANK.INC(A1:A9, 1) returns 0

(=0%) minimum value

PERCENTRANK.INC(A1:A9, 9) returns 1

(=100%) maximum value

Note:

The PERCENTRANK.INC function supplements together with PERCENTRANK.EXC the previous
PERCENTRANK function.
PERCENTRANK.INC returns the same result as PERCENTRANK (values 0 to 1 inclusive).
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PERCENTRANK.EXC (values 0 to 1 exclusive) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

PERCENTRANK/PERCENTRANK.EXC, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
QUARTILE.EXC/QUARTILE.INC/QUARTILE, RANK.AVG/RANK.EQ/RANK

PERIOD (duration of fixed-interest investments)
Syntax:

PERIOD(Rate, PV, FV)
Description:

Returns the duration (i.e., the number of periods) required to obtain a specific future value in a fixed-interest
investment. This function is applicable to investments with just one payment (made at the beginning) and a
fixed interest rate.
Rate is the interest rate (per period).
PV is the present value.
FV is the future value.
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Example:

To obtain $5000 with a fixed-interest investment of $3000 and a yearly interest rate of 6%:
PERIOD(6%, 3000, 5000) returns 8.76669 periods (i.e., years)
See also:

RRI
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PERMUT (permutations)
Syntax:

PERMUT(n, k)
Description:

Returns the number of permutations of size k in a population of size n.
Use this function to find out in how many ways n distinct objects can be arranged in groups of k elements,
without repetition, and with the order being important.
Permutations are similar to combinations (see COMBIN function), except that the order of the objects is
important
n is the total number of items. Must be > k.
k is the number of items in each permutation. Must be > 0 and < n.
n and k should be integers, digits right of the decimal point are ignored.
Example:

To calculate how many different three-letter words can be built out of an alphabet with 26 letters:
PERMUT(26, 3) returns 15600
See also:

COMBIN

PHI (standard normal distribution)
Syntax:

PHI(x)
Description:

Returns the standard normal distribution.
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Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
It is therefore recommended to use the function NORMDIST instead, since it is compatible with all versions of
Excel:
PHI(x) equals NORMDIST(x, 0, 1, FALSE)
See also:

NORM.DIST/NORMDIST, GAUSS

PI (pi)
Syntax:

PI()
Description:

Returns the mathematical constant p (pi), which expresses the ratio of a circle's circumference (2rp) to its
diameter (2r).
Example:

PI() returns 3.14159265...

PMT (payment)
Syntax:

PMT(Rate, NPer, PV [, FV] [, Type])
Description:

Returns the payment (principal plus interest) in the given period. This function is applicable to loans with
periodic constant payments, and a constant interest rate.
Rate is the interest rate (per payment period).

Formulas and functions

619

NPer is the total number of payment periods.
PV is the present value.
FV (optional) is the future value. If omitted, it will be set to zero.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
Example:

PMT(6.5%, 10, 1000) returns -139.10
See also:

FV, IPMT, ISPMT, NPER, PPMT, CUMIPMT, CUMPRINC, PV, RATE

POISSON (Poisson distribution)
Note: POISSON is supplemented by the new identical function POISSON.DIST, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

POISSON(x, Lambda, Cumulative)
Description:

Returns the Poisson distribution.
The Poisson distribution describes the occurrence of rare events in a large number of independent trials. It can
simulate the binomial distribution for small values of p (probability) and large values of n (number of trials).
X is the value to be evaluated. Must be ³ 0.
Lambda is the expected (average) value. Must be ³ 0.
Example:

In a multi-story building, an average of 4 light bulbs become defective per week.
To determine the probability that just 3 light bulbs become defective in one week:
POISSON(3, 4, FALSE) returns 0.195366815 (i.e., about 19.5%)
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To determine the probability that at most 3 light bulbs become defective in one week:
POISSON(3, 4, TRUE) returns 0.43347 (i.e., about 43.3%)
See also:

POISSON.DIST, BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST, EXPON.DIST/EXPONDIST

POISSON.DIST (Poisson distribution)
Syntax:

POISSON.DIST(x, Lambda, Cumulative)
Description:

Returns the Poisson distribution.
The Poisson distribution describes the occurrence of rare events in a large number of independent trials. It can
simulate the binomial distribution for small values of p (probability) and large values of n (number of trials).
X is the value to be evaluated. Must be ³ 0.
Lambda is the expected (average) value. Must be ³ 0.
Example:

In a multi-story building, an average of 4 light bulbs become defective per week.
To determine the probability that just 3 light bulbs become defective in one week:
POISSON.DIST(3, 4, FALSE) returns 0.195366815 (i.e., about 19.5%)
To determine the probability that at most 3 light bulbs become defective in one week:
POISSON.DIST(3, 4, TRUE) returns 0.43347 (i.e., about 43.3%)
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

POISSON, BINOM.DIST.RANGE/BINOM.DIST/BINOMDIST, EXPON.DIST/EXPONDIST
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POLYNOMIAL (multinomial coefficient)
Syntax:

POLYNOMIAL(Number1 [, Number2, Number3 ...])
Description:

Returns the polynomial coefficient ("multinomial coefficient") of a set of numbers.
Number1, Number2, etc., are the numbers to be evaluated. All of them have to be ³ 1.
Example:

POLYNOMIAL(1, 2, 3, 4, 5) returns 37837800
Note:

The functions POLYNOMIAL and MULTINOMIAL are completely identical.
See also:

MULTINOMIAL, FACT

POWER (power)
Syntax:

POWER(x, y)
Description:

Returns x raised to the y-th power.
x is the base.
y is the exponent.
Annotation:

The ^ operator does exactly the same:
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POWER(x, y) is equivalent to x^y.
Example:

POWER(2, 4) equals 2^4, which equals 16
See also:

LOG, LN, EXP, SQRT, ROOTN, SERIESSUM, section Operators in formulas

PPMT (payment on the principal)
Syntax:

PPMT(Rate, Per, NPer, PV [, FV] [, Type])
Description:

Returns the principal due in the given period of an investment based on periodic constant payments, and a
constant interest rate.
Rate is the interest rate (per payment period).
Per is the payment period to be evaluated.
NPer is the total number of payment periods.
PV is the present value.
FV (optional) is the future value. If omitted, it will be set to zero.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
Example:

Loan terms: $100,000 at 10% per year, to be repaid over 72 months with monthly payments at the end of each
month.
How much is the principal in the 32nd period (i.e., the 32nd month)?
PPMT(10%/12, 32, 72, 100000) returns -1.318.
Note that all values have to use the same time unit, months in this case, since the payments are made monthly.
Therefore, in the above formula, the yearly interest rate had to be divided by 12 to get the monthly interest rate.
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See also:

IPMT, ISPMT, PMT, CUMIPMT, CUMPRINC, FV, NPER, PV, RATE

PROB (probability)
Syntax:

PROB(Values, Probabilities, k1 [, k2])
Description:

Returns the probability that a value is inside the specified interval of values, when the individual probabilities
for each value are given.
Values are the given values.
Probabilities are the probabilities associated with these values. All of them have to be in the range 0 to 1. Their
sum has to be 1.
Values and Probabilities must have the same number of values, otherwise the function returns a #N/A error
value.
k1 and k2 are the bounds of the interval whose cumulative probabilities you want to calculate. If k2 is omitted,
just the probability of k1 will be returned.
Example:

Cells A1:A3 contain the values 1, 2, 3. Cells B1:B3 contain the probabilities associated with these values: 17%,
33%, 50%.
To calculate the probability that a value is between 2 and 3:
PROB(A1:A3, B1:B3, 2, 3) returns 33% + 50%, which equals 83%

PRODUCT (product)
Syntax:

PRODUCT(Number1 [, Number2, Number3 ...])
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Description:

Returns the product of the given numbers.
Number1, Number2, etc., are the numbers to be multiplied.
Annotation:

When you use this function with cell references or arrays, text strings and logical values are ignored.
But when you use this function with fixed values, both text strings that represent a number and logical values
(TRUE=1, FALSE=0) are counted.
Example:

PRODUCT(2, 3, 4) equals 2*3*4, which equals 24
See also:

SUM

PROPER (convert text to upper/lower case)
Syntax:

PROPER(Text)
Description:

Converts all characters in a text string as follows: The first letter of each word is converted to an uppercase
letter, all other letters are converted to lowercase letters.
Example:

PROPER("good morning") returns Good Morning
PROPER("Good Morning") returns Good Morning
PROPER("GoOd MoRnInG") returns Good Morning
See also:

UPPER, LOWER
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PV (present value)
Syntax:

PV(Rate, NPer, Pmt [, FV] [, Type])
Description:

Returns the present value of an investment based on periodic constant payments, and a constant interest rate.
Rate is the interest rate (per payment period).
NPer is the total number of payment periods.
Pmt is the payment made for each period.
FV (optional) is the future value.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
See also:

FV, IPMT, NPER, NPV, PMT, PPMT, RATE

QUARTILE (quartiles of a data set)
Note: QUARTILE is supplemented by the new identical function QUARTILE.INC and the completely new
function QUARTILE.EXC, which are available in newer versions of Microsoft Excel (2010 or later).

Syntax:

QUARTILE(Range, n)
Description:

Returns one of the quartiles of a data set, based on a percentile range between 0 to 1 (inclusive).
Range is the cell range or array to be evaluated.
n determines which quartile to return:
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0: The minimum
1: The 1st quartile (25th percentile)
2: The 2nd quartile (50th percentile or median)
3: The 3rd quartile (75th percentile)
4: The maximum
If n is < 0 or > 4, a #NUM! error value will be returned.
Example:

If cells A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
QUARTILE(A1:A9, 3) is equivalent to PERCENTILE(A1:A9, 0.75), which returns 7
See also:

QUARTILE.INC/QUARTILE.EXC, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, MEDIAN, MODE.SNGL/MODE

QUARTILE.EXC (quartiles of a data set)
Syntax:

QUARTILE.EXC(Range, n)
Description:

Returns one of the quartiles of a data set, based on a percentile range between 0 to 1 (exclusive).
Range is the cell range or array to be evaluated.
n determines which quartile to return:
0: The minimum
1: The 1st quartile (25th percentile)
2: The 2nd quartile (50th percentile or median)
3: The 3rd quartile (75th percentile)
4: The maximum
If n is < 0 or > 4, a #NUM! error value will be returned.
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Example:

If cells A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
QUARTILE.EXC(A1:A9, 3) is equivalent to PERCENTILE.EXC(A1:A9, 0.75), which returns 7.5
Note:

The QUARTILE.EXC function supplements together with QUARTILE.INC the previous QUARTILE function.
QUARTILE.INC returns the same result as QUARTILE (values 0 to 1 inclusive).
PERCENTRANK.EXC (values 0 to 1 exclusive) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

QUARTILE /QUARTILE.INC, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, MEDIAN, MODE.SNGL/MODE

QUARTILE.INC (quartiles of a data set)
Syntax:

QUARTILE.INC(Range, n)
Description:

Returns one of the quartiles of a data set, based on a percentile range between 0 to 1 (inclusive).
Range is the cell range or array to be evaluated.
n determines which quartile to return:
0: The minimum
1: The 1st quartile (25th percentile)
2: The 2nd quartile (50th percentile or median)
3: The 3rd quartile (75th percentile)
4: The maximum
If n is < 0 or > 4, a #NUM! error value will be returned.
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Example:

If cells A1:A9 contain the values 1, 2, 3, 4, 5, 6, 7, 8, 9:
QUARTILE.INC(A1:A9, 3) is equivalent to PERCENTILE.INC(A1:A9, 0.75), which returns 7
Note:

The QUARTILE.INC function supplements together with QUARTILE.EXC the previous QUARTILE function.
QUARTILE.INC returns the same result as QUARTILE (values 0 to 1 inclusive).
PERCENTRANK.EXC (values 0 to 1 exclusive) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

QUARTILE/QUARTILE.EXC, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, MEDIAN, MODE.SNGL/MODE

QUOTIENT (quotient of a division)
Syntax:

QUOTIENT(x, y)
Description:

Returns the integer part of the division of x by y.
Example:

QUOTIENT(6, 4) returns 1
See also:

MOD, MODP
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RADIANS (convert degrees to radians)
Syntax:

RADIANS(Number)
Description:

Converts degrees to radians.
Example:

RADIANS(180) returns 3.14159...
See also:

DEGREES

RAND (random value)
Syntax:

RAND()
Description:

Returns a random number ³ 0 and < 1.
A new random number will be generated every time the document is recalculated.
Hint: To manually recalculate a document, use the Tools > Recalculate menu command.
Example:

RAND() returns a random number.
See also:

RANDBETWEEN
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RANDBETWEEN (random value)
Syntax:

RANDBETWEEN(LowerLimit, UpperLimit)
Description:

Returns an integer random number ³ LowerLimit and £ UpperLimit.
A new random number will be generated every time the document is recalculated.
Hint: To manually recalculate a document, use the Tools > Recalculate menu command.
Example:

RANDBETWEEN(1, 6) returns a random integer number in the range of 1 through 6, thereby simulating a dice
roll.
See also:

RAND

RANK (rank in a data set)
Note: RANK is supplemented by the new identical function RANK.EQ and the completely new function
RANK.AVG, which are available in newer versions of Microsoft Excel (2010 or later).

Syntax:

RANK(Number, Range [, Ascending])
Description:

Returns the rank of a number in a data set. The largest number's rank is 1, the 2nd largest number's rank is 2,
etc.
Number is the number whose rank you want to determine. If number does not occur in Range, a #N/A error
value is returned.
Range is a cell range or array containing the given numbers.
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Ascending (optional) is a logical value that lets you specify whether to use ascending or descending order:
FALSE or omitted: Use descending order (the largest number's rank is 1).
TRUE: Use ascending order (the smallest number's rank is 1).
Example:

If the cells A1:A6 contain 3, 2, 7, 5, 9, 7:
RANK(9, A1:A6) returns 1
RANK(9, A1:A6, TRUE) returns 6
RANK(5, A1:A6) returns 4
RANK(7, A1:A6) returns 2
See also:

RANK.EQ/RANK.AVG, SMALL, LARGE, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK

RANK.AVG (rank in a data set)
Syntax:

RANK.AVG(Number, Range [, Ascending])
Description:

Returns the rank of a number in a data set. The largest number's rank is 1, the 2nd largest number's rank is 2,
etc. If there are duplicate values in the list, these are given the average rank.
Number is the number whose rank you want to determine. If number does not occur in Range, a #N/A error
value is returned.
Range is a cell range or array containing the given numbers.
Ascending (optional) is a logical value that lets you specify whether to use ascending or descending order:
FALSE or omitted: Use descending order (the largest number's rank is 1).
TRUE: Use ascending order (the smallest number's rank is 1).
Example:

If the cells A1:A6 contain 3, 2, 7, 5, 9, 7:
RANK.AVG(9, A1:A6) returns 1
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RANK.AVG(9, A1:A6, TRUE) returns 6
RANK.AVG(3, A1:A6) returns 5
RANK.AVG(7, A1:A6) returns 2.5
Note:

The RANK.AVG function supplements together with RANK.EQ the previous RANK function.
RANK.EQ returns the same result as RANK (for duplicate values in the list higher rank).
The RANK.AVG (for duplicate values in the list average rank) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

RANK/RANK.EQ, SMALL, LARGE, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK

RANK.EQ (rank in a data set)
Syntax:

RANK.EQ(Number, Range [, Ascending])
Description:

Returns the rank of a number in a data set. The largest number's rank is 1, the 2nd largest number's rank is 2,
etc. If there are duplicate values in the list, these are given the higher rank.
Number is the number whose rank you want to determine. If number does not occur in Range, a #N/A error
value is returned.
Range is a cell range or array containing the given numbers.
Ascending (optional) is a logical value that lets you specify whether to use ascending or descending order:
FALSE or omitted: Use descending order (the largest number's rank is 1).
TRUE: Use ascending order (the smallest number's rank is 1).
Example:

If the cells A1:A6 contain 3, 2, 7, 5, 9, 7:
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RANK.EQ(9, A1:A6) returns 1
RANK.EQ(9, A1:A6, TRUE) returns 6
RANK.EQ(5, A1:A6) returns 4
RANK.EQ(7, A1:A6) returns 2
Note:

The RANK.EQ function supplements together with RANK.AVG the previous RANK function.
RANK.EQ returns the same result as RANK (for duplicate values in the list higher rank).
The RANK.AVG (for duplicate values in the list average rank) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

RANK/RANK.AVG, SMALL, LARGE, PERCENTILE.EXC/PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK

RATE (rate per period)
Syntax:

RATE(NPer, Pmt, PV [, FV] [, Type] [, Guess])
Description:

Returns an estimate for the interest rate per period of an annuity.
NPer is the total number of payment periods.
Pmt is the payment made for each period.
PV is the present value.
FV (optional) is the future value (the total value after the last payment). If omitted, it will be set to zero.
Type (optional) is the timing of the payments:
0 or omitted: Payment at the end of each period.
1: Payment at the beginning of each period.
Guess (optional) lets you specify an estimate for the result (see note below).
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Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
20 iterations, a #NUM error value is returned. If this occurs, try altering the Guess parameter.
See also:

FV, IPMT, NPER, PMT, PPMT, PV, RRI, IRR, MIRR, XIRR

REPLACE (replace text in a text string)
Syntax:

REPLACE(Text, Start, Count, NewText)
Description:

Replaces the specified part of a text string with other text.
Text is the given text string.
Start is the position of the first character to be replaced.
Count is the number of characters to be replaced.
NewText is the replacement text.
Example:

REPLACE("aaaaaa", 3, 2, "bb") returns aabbaa
REPLACE("aaaaaa", 3, 4, "bb") returns aabb
REPLACE("cccccc", 3, 2, "dddddddd") returns ccddcc
REPLACE("cccccc", 3, 4, "dddddddd") returns ccdddd
REPLACE("cccccc", 3, 6, "dddddddd") returns ccdddddd
See also:

FIND, SEARCH, MID, SUBSTITUTE, LEFT, RIGHT, REPT
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REPT (repeat text string)
Syntax:

REPT(Text, n)
Description:

Repeats the specified text string n times.
n should be an integer, digits right of the decimal point are ignored.
Example:

REPT("Text", 3) returns TextTextText
See also:

REPLACE, SUBSTITUTE

RIGHT (right part of a text string)
Syntax:

RIGHT(Text [, n])
Description:

Returns the last n characters of Text.
If n is omitted, only the last character is returned.
Example:

RIGHT("peanut", 3) returns nut
RIGHT("peanut") returns t
See also:

LEFT, MID, REPLACE, LEN
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ROMAN (Roman numeral)
Syntax:

ROMAN(Number [, Format])
Description:

Converts an Arabic numeral into a Roman numeral (as a text string).
Number is the number to be converted. Must be ³ 0 and < 4000. Number should be an integer, digits right of
the decimal point are ignored.
If Number equals zero, an empty text string will be returned.
If the optional argument Format is used, PlanMaker tries to create a shorter form of the Roman numeral.
Format can be any integer from 0 (do not shorten) through 4 (shorten as much as possible).
Example:

ROMAN(1999) returns MCMXCIX
ROMAN(1999, 0) returns MCMXCIX as well
ROMAN(1999, 1) returns MLMIL
ROMAN(1999, 2) returns MXMIX
ROMAN(1999, 3) returns MVMIV
ROMAN(1999, 4) returns MIM

ROOTN (n-th root)
Syntax:

ROOTN(Number [, n])
Description:

Returns the n-th root of a number. If n is omitted, the square root is returned (n=2).
n should be an integer, digits right of the decimal point are ignored.
If n is even, Number must be ³ 0.
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Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Hint: Alternatively, the n-th root of a number can be calculated using the following Excel compatible function:
ROOTN(Number, n) equals POWER(Number, 1/n)
Example:

ROOTN(25) returns 5
ROOTN(-25) returns a #NUM! error value
ROOTN(125, 3) returns 5
ROOTN(-125, 3) returns -5
See also:

SQRT, POWER

ROUND (round)
Syntax:

ROUND(Number, n)
Description:

Rounds Number to n decimal places.
n is the number of decimal places.
If n is omitted, Number is rounded to the nearest integer.
If n is a negative value, Number is rounded to the left of the decimal point. For example, if n is -2, Number is
rounded to the nearest multiple of hundred (see last example).
Example:

ROUND(1.234, 2) returns 1.23
ROUND(1.235, 2) returns 1.24
ROUND(444.222, 0) returns 444
ROUND(444.222, -2) returns 400
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See also:

ROUNDDOWN, ROUNDUP, MROUND, TRUNC, FIXED, INT, EVEN, ODD, CEILING, FLOOR

ROUNDDOWN (round down)
Syntax:

ROUNDDOWN(Number, n)
Description:

Rounds Number down (towards zero) to n decimal places.
n is the number of decimal places.
If n is omitted, Number is rounded to the nearest integer.
If n is a negative value, Number is rounded to the left of the decimal point. For example, if n is -2, Number is
rounded to the nearest multiple of hundred (see last example).
Example:

ROUNDDOWN(1.234, 2) returns 1.23
ROUNDDOWN(1.235, 2) returns 1.23
ROUNDDOWN(888.999, 0) returns 888
ROUNDDOWN(888.999, -2) returns 800
See also:

ROUNDUP, ROUND, MROUND, TRUNC, FIXED, INT, EVEN, ODD, CEILING, FLOOR

ROUNDUP (round up)
Syntax:

ROUNDUP(Number, n)
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Description:

Rounds Number up (away from zero) to n decimal places.
n is the number of decimal places.
If n is omitted, Number is rounded to the nearest integer.
If n is a negative value, Number is rounded to the left of the decimal point. For example, if n is -2, Number is
rounded to the nearest multiple of hundred (see last example).
Example:

ROUNDUP(1.234, 2) returns 1.24
ROUNDUP(1.235, 2) returns 1.24
ROUNDUP(444.222, 0) returns 445
ROUNDUP(444.222, -2) returns 500
See also:

ROUNDDOWN, ROUND, MROUND, TRUNC, FIXED, INT, EVEN, ODD, CEILING, FLOOR

ROW (row number of a reference)
Syntax:

ROW([Reference])
Description:

Returns the row number(s) of a cell reference:
If Reference is a single cell, the row number of this cell is returned.
If Reference is a range of cells, their row numbers are returned as a vertical array. Note: In this case, the
formula has to be entered as an array formula (see section Working with arrays).
If Reference is omitted, the row number of the cell that invokes this function is returned.
Example:

ROW(D2) returns 2
ROW(D2:F4) returns {2;3;4}
ROW() returns 5 when you use this calculation in cell A5
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See also:

COLUMN, ROWS, CELL, ADDRESS, INDIRECT, OFFSET

ROWS (number of rows in a range)
Syntax:

ROWS(Range)
Description:

Returns the number of rows in the specified cell range.
Example:

ROWS(A1:D5) returns 5
See also:

ROW, COLUMNS, AREAS

RRI (interest for fixed-interest investments)
Syntax:

RRI(Per, PV, FV)
Description:

Returns the interest rate required to obtain a specific future value after a specific period. This function is
applicable to investments with just one payment (made at the beginning) and a fixed interest rate.
Per is the number of periods.
PV is the present value.
FV is the future value.
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Example:

To obtain $5000 with a fixed-interest investment of $3000 after 10 years, the yearly interest rate has to be:
RRI(10, 3000, 5000) returns 0.05241 (i.e., about 5.24%)
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
In older versions of PlanMaker this function was called PCF.
See also:

PERIOD, RATE

RSQ (square of Pearson)
Syntax:

RSQ(Range1, Range2)
Description:

Returns the square of Pearson's product moment correlation coefficient r.
This coefficient is a measure of the strength of the linear relationship between two data sets. For more
information, see PEARSON function
Range1 is the cell range or array containing the independent values. Empty cells, text and logical values are
ignored.
Range2 is the cell range or array containing the dependent values. Empty cells, text and logical values are
ignored.
Range1 and Range2 must have the same number of values, otherwise the function returns a #N/A error value.
Example:

If A1:A3 contains the values 2, 5, 3 and B1:B3 contains 2, 7, 4:
RSQ(A1:A3, B1:B3) returns 0.99436
See also:

PEARSON
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SEARCH (search for text)
Syntax:

SEARCH(Text, SearchedText [, StartPos])
Description:

Returns the position of the text string SearchedText within the text string Text.
StartPos (optional) lets you specify the position (= character) at which to start the search. If omitted, the search
starts at the first character.
The SEARCH function is not case-sensitive, i.e., it will not distinguish between uppercase and lowercase
letters. To perform a case-sensitive search, use the FIND function instead
Example:

SEARCH("a", "Banana") returns 2
SEARCH("A", "Banana") returns 2
SEARCH("a", "Banana", 3) returns 4
SEARCH("x", "Banana") returns a #VALUE! error value, since "x" does not occur in "Banana".
See also:

FIND, REPLACE, SUBSTITUTE, EXACT, MID

SECOND (second)
Syntax:

SECOND(Time)
Description:

Returns the seconds of a time value.
Example:

SECOND("12:34:56 AM") returns 56
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See also:

HOUR, MINUTE, MILLISECONDS

SERIESSUM (sum of a power series)
Syntax:

SERIESSUM(x, n, m, Coefficients)
Description:

Returns a power series based on the following formula:
SERIESSUM(x,n,m,a) =
a1*x^n + a2*x^(n+m) + a3*x^(n+2m) + a4*x^(n+3m) + ...
x is the base.
n is the exponent for the first element in the series.
m is the increment for n.
Coefficients is a one-dimensional cell range or array containing the coefficients that the series elements will be
multiplied by.
The number of coefficients also determines the number of elements the power series will consist of. For
example, if 10 coefficients are given, the series will consist of 10 elements.
Example:

SERIESSUM(2, 2, 1, {1; 2; 3; 4; 5}) returns 516
See also:

POWER

SHEET (index of a worksheet)
Syntax:

SHEET([SheetName])
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Description:

Returns the index of a worksheet in the current document. The first worksheet in a document returns 1, the
second sheet returns 2, etc.
If the optional argument SheetName is given, the index of the worksheet with the specified name is returned.
Otherwise, the index of the current worksheet is returned.
Note:

The SHEET function replaces the (almost) identical SHEETNUMBER function
Background information: The SHEETNUMBER function formerly was available in PlanMaker, but not in
Excel. In Excel 2013, Microsoft introduced the same function – but with a different name: SHEET.
There is only one little difference: When the specified parameter is a cell reference, SHEET will return the
index of the worksheet that contains this reference. SHEETNUMBER, on the other hand, will read the content
of the corresponding cell and return the index of the worksheet carrying that name.
Example:

On the third worksheet in a document, SHEET() returns 3.
SHEET("Expenses") returns the index of the worksheet named "Expenses".
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
See also:

SHEETNUMBER, SHEETNAME, FILENAME

SHEETNAME (name of a worksheet)
Syntax:

SHEETNAME([n])
Description:

Returns the name of a worksheet.
n is the number of the worksheet whose name you want to determine. The first worksheet in the workbook is
number 1, the second is number 2, etc. If n is omitted, the current worksheet is used.
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Example:

If a document contains four worksheets named "Spring", "Summer", "Autumn", and "Winter" (in this order),
and "Autumn" is the current worksheet:
SHEETNAME() returns Autumn
SHEETNAME(1) returns Spring
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

FILENAME, SHEET

SHEETNUMBER (compatibility function)
Syntax:

SHEETNUMBER([SheetName])
Description:

Compatibility function for older PlanMaker documents.
This function has been replaced by the (almost) identical SHEET function
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Hint: Instead of this function, use the Excel 2013-compatible function SHEET.
See also:

SHEET, SHEETNAME
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SIGN (sign of a number)
Syntax:

SIGN(Number)
Description:

Returns a value representing the sign of a number:
1, if Number is positive,
-1, if Number is negative,
0, if Number is zero.
Example:

SIGN(-5) returns -1
See also:

ABS, NEG

SIN (sine)
Syntax:

SIN(Number)
Description:

Returns the sine of Number.
Tip:

You can use the RADIANS function to convert an angle given in degrees into radians.
Example:

SIN(PI()/2) returns 1
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SIN(RADIANS(90)) returns 1
See also:

ASIN, COS, TAN

SINH (hyperbolic sine)
Syntax:

SINH(Number)
Description:

Returns the hyperbolic sine of Number.
Example:

SINH(0.45) returns 0.4653
See also:

ASINH, COSH, TANH

SKEW (skewness of a distribution)
Syntax:

SKEW(Number1, Number2, Number3 [, Number4 ...])
or
SKEW(Range1 [, Range2, Range3 ...])
Description:

Returns the skewness of a probability distribution.
The skewness is a measure of the asymmetry of a distribution.
If the skewness is zero, the distribution is symmetric. If it is positive, the positive tail is larger; if negative, the
negative tail is larger.
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Number1, Number2, etc., are the values to be evaluated. Empty cells, text strings, and logical values are
ignored.
At least three values have to be given, otherwise the function returns a #DIV/0! error value.
Example:

Measuring the height of several test persons led to the following results: 1 x 1.60m, 2 x 1.65m, 4 x 1.70m, 2 x
1.75m, and 1x1.80m.
To calculate the skewness of this distribution, use the following formula:
SKEW(1.60, 1.65, 1.65, 1.70, 1.70, 1.70, 1.70, 1.75, 1.75, 1.80) returns 4.66562E-15.
See also:

INTERCEPT, FORECAST, KURT, NORM.DIST/NORMDIST

SLN (straight-line depreciation)
Syntax:

SLN(Cost, Salvage, Life)
Description:

Returns the depreciation per period of an asset, using the straight-line depreciation method.
Cost = Initial cost of asset
Salvage = Salvage value (value at the end of the depreciation)
Life = Life of asset (in number of periods)
Example:

Asset parameters: initial cost = 6000, salvage value = 3000, life = 5 years
SLN(6000, 3000, 5) returns 600 (per year)
See also:

SYD, DDB, DB
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SLOPE (slope of a linear trend)
Syntax:

SLOPE(y_values, x_values)
Description:

Returns the slope of a best-fit line for the given values. The slope of a line is the value the y value grows when
the x value is raised by 1.
A best-fit line is the result of a linear regression, a statistical technique that adapts a line to a set of data points
(for example, the results of a series of measurements).
y_values are the known y values.
x_values are the known x values.
Example:

The resistance of a temperature-sensitive resistor has been measured at several temperatures.
Cells A1:A4 contain the temperatures measured: 8, 20, 25, 28
Cells B1:B4 contain the resistances measured: 261, 508, 608, 680
The following calculation returns the slope of a best-fit line based on these values:
SLOPE(B1:B4, A1:A4) returns 20.76799
See also:

INTERCEPT, FORECAST, PEARSON, STEYX

SMALL (k-th smallest number)
Syntax:

SMALL(Range, k)
Description:

Returns the k-th smallest value in a data set.
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Range is the range of data to be evaluated.
k determines which number to return. If k=1, the smallest value will be returned, if k=2, the second smallest
value will be returned, etc.
k must not be smaller than 1 or greater than the total number of values in Range. Otherwise, the function
returns a #NUM! error value.
Example:

If the cells A1:A5 are filled with the numbers 4, 2, 6, 5, and 9:
SMALL(A1:A5, 1) returns 2
SMALL(A1:A5, 2) returns 4
SMALL(A1:A5, 3) returns 5
etc.
See also:

LARGE, MIN, PERCENTILE.INC/PERCENTILE,
PERCENTRANK.EXC/PERCENTRANK.INC/PERCENTRANK, RANK.AVG/RANK.EQ/RANK

SORTM (sort)
Syntax:

SORTM(Range, Key [, Mode] [, Columnwise] [, Column])
Description:

Returns an array containing the values of the given cell range, sorted by one or more sort keys.
Range is the cell range or array containing the data to be sorted.
Key is a two-row cell range or array containing the sort key(s):
Its first row must contain the relative row numbers of the rows to be sorted by. If, for example, you enter {1,3},
the cell range is sorted by the first and by the third row of Range.
Its second row (optional) can contain logical values that specify the sort order:
FALSE or omitted: Ascending order
TRUE: Descending order
For example, if you use {1,3; true,false} as the sort key, the cell range is sorted by the first row in descending
order and by the third row in ascending order.
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Mode (optional) is a logical value that lets you specify if PlanMaker should distinguish between uppercase and
lowercase letters:
FALSE or omitted: Ignore case of letters
TRUE: Distinguish between uppercase and lowercase letters, i.e., place text strings starting with a lowercase
letter above text strings starting with an uppercase letter.
Columnwise (optional) is a logical value that lets you specify if the data should be sorted row-wise or columnwise:
FALSE or omitted: Sort row-wise
TRUE: Sort column-wise
Column (optional) is the number of the column to be returned:
If omitted, all columns are returned.
If set to n, only the n-th column is returned.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Example:

SORTM({4;2;3}, {1}) returns {2;3;4}
SORTM({4;2;3}, {1;TRUE}) returns {4;3;2} (descending order)
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

SORTV, section Sorting cells

SORTV (sort)
Syntax:

SORTV(Range [, Descending] [, Mode] [, Data])
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Description:

Returns a vector containing the values of the given one-dimensional cell range, in sorted order.
Note:

Unlike the SORTM function, SORTV is applicable to one-dimensional cell ranges (vectors) only.
Range is the cell range or array containing the data to be sorted. It must be a vector (a range of either just one
row or one column).
Descending (optional) lets you specify the sort order:
FALSE or omitted: Ascending order
TRUE: Descending order
Mode (optional) is a logical value that lets you specify if PlanMaker should distinguish between uppercase and
lowercase letters:
FALSE or omitted: Ignore case of letters
TRUE: Distinguish between uppercase and lowercase letters, i.e., place text strings starting with a lowercase
letter above text strings starting with an uppercase letter.
Data (optional) is the cell range or array containing the values to be returned. Data must be of exactly the same
size as Range.
If it is omitted, the data in Range is returned.
If it set to another cell range, the data from this cell range will be returned – in the same order as Range (after it
was sorted).
Example: If you have created a table with the names and grades of students, you can set Range to the cell range
with their grades, but set Data to the cell range with their names. The result will be a list of their names, sorted
by grade.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Example:

SORTV({4;2;3}) returns {2;3;4}
SORTV({4;2;3}, TRUE) returns {4;3;2}
SORTV({4,2,3}) returns {2,3,4}
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
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See also:

SORTM, section Sorting cells

SQRT (square root)
Syntax:

SQRT(Number)
Description:

Returns the square root of a number.
Number must be ³ 0.
Example:

SQRT(25) returns 5
SQRT(-25) returns a #NUM! error value
See also:

POWER, ROOTN

SQRTPI (square root of x*Pi)
Syntax:

SQRTPI(Number)
Description:

Returns the square root of (Number * pi).
Number must be ³ 0.
Example:

SQRTPI(42) equals SQRT(42*PI()), which is 11.48681381
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See also:

PI, ROOTN, SQRT

STANDARDIZE (standardized value)
Syntax:

STANDARDIZE(x, Mean, StdDev)
Description:

Returns the normalized value of x for a distribution given by mean and standard deviation.
x is the value to be normalized.
Mean is the arithmetic mean of the distribution.
StdDev is the standard deviation of the distribution.
Example:

STANDARDIZE(5, 4, 1.25) returns 0.8
See also:

AVERAGE, STDEV.S/STDEV, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST

STDEV (standard deviation of a sample)
Note: STDEV is supplemented by the new identical function STDEV.S, which is available in newer versions
of Microsoft Excel (2010 or later).

Syntax:

STDEV(Number1, Number2 [, Number3 ...])
Description:

Estimates the standard deviation of a population based on a sample.
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Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated.
Empty cells, text strings, and logical values are ignored.
Annotation:

The standard deviation is calculated using the "unbiased" or "n-1" method.
Example:

STDEV(2, 2, 3, 4, 1) returns 1.14018
See also:

STDEV.S, STDEVA, STDEV.P/STDEVP, VAR.P/VARP, VAR.S/VAR, AVEDEV, DEVSQ,
STANDARDIZE

STDEVA (standard deviation of a sample)
Syntax:

STDEVA(Value1, Value2 [, Value3 ...])
Description:

Estimates the standard deviation of a population based on a sample, including logical values and text.
Value1, Value2, etc., are single values, cell ranges, or arrays containing the values to be evaluated.
Empty cells are ignored.
Note:

Unlike the STDEV function, STDEVA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Annotation:

The standard deviation is calculated using the "unbiased" or "n-1" method.
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Example:

STDEVA(2, 2, 3, 4, 1) returns 1.14018
See also:

STDEV.S/STDEV, STDEVPA

STDEVP (standard deviation of entire population)
Note: STDEVP is supplemented by the new identical function STDEV.P, which is available in newer
versions of Microsoft Excel (2010 or later).

Syntax:

STDEVP(Number1, Number2 [, Number3 ...])
Description:

Returns the standard deviation of an entire population.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated. Please
note that all values of the entire population have to be given. To calculate the standard deviation of a sample,
use the STDEV.S/STDEV function instead.
Empty cells, text strings, and logical values are ignored.
Annotation:

The standard deviation is calculated using the "biased" or "n" method.
Example:

STDEVP(2, 2, 3, 4, 1) returns 1.0198
See also:

STDEV.P, STDEVPA, STDEV.S/STDEV, VAR.P/VARP, VAR.S/VAR
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STDEV.P (standard deviation of entire population)
Syntax:

STDEV.P(Number1, Number2 [, Number3 ...])
Description:

Returns the standard deviation of an entire population.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated. Please
note that all values of the entire population have to be given. To calculate the standard deviation of a sample,
use the STDEV.S/STDEV function instead.
Empty cells, text strings, and logical values are ignored.
Annotation:

The standard deviation is calculated using the "biased" or "n" method.
Example:

STDEV.P(2, 2, 3, 4, 1) returns 1.0198
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

STDEVP, STDEVPA, STDEV.S/STDEV, VAR.P/VARP, VAR.S/VAR

STDEVPA (standard deviation of entire population)
Syntax:

STDEVPA(Value1, Value2 [, Value3 ...])
Description:

Returns the standard deviation of an entire population, including logical values and text.
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Value1, Value2, etc., are single values, cell ranges, or arrays containing the values to be evaluated. Please note
that all values of the entire population have to be given. To calculate the standard deviation of a sample, use the
STDEVA function instead
Empty cells are ignored.
Note:

Unlike the STDEVP function, STDEVPA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Annotation:

The standard deviation is calculated using the "biased" or "n" method.
Example:

STDEVPA(2, 2, 3, 4, 1) returns 1.0198
See also:

STDEV.P/STDEVP

STEYX (standard error of a linear regression)
Syntax:

STEYX(y_values, x_values)
Description:

Returns the standard error of a linear regression.
y_values are the known y values.
x_values are the known x values.
Example:

The resistance of a temperature-sensitive resistor has been measured at several temperatures.
Cells A1:A4 contain the temperatures measured: 8, 20, 25, 28
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Cells B1:B4 contain the resistances measured: 261, 508, 608, 680
The following calculation returns the standard error of the resistances predicted by linear regression:
STEYX(B1:B4, A1:A4) returns 4.97351
See also:

INTERCEPT, SLOPE, FORECAST

STDEV.S (standard deviation of a sample)
Syntax:

STDEV.S(Number1, Number2 [, Number3 ...])
Description:

Estimates the standard deviation of a population based on a sample.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated.
Empty cells, text strings, and logical values are ignored.
Annotation:

The standard deviation is calculated using the "unbiased" or "n-1" method.
Example:

STDEV.S(2, 2, 3, 4, 1) returns 1.14018
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

STDEV, STDEV.P/STDEVP, VAR.P/VARP, VAR.S/VAR
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SUBSTITUTE (replace text in a text string)
Syntax:

SUBSTITUTE(Text, OldText, NewText [, n])
Description:

Searches for OldText in a text string. If found, OldText will be replaced by NewText.
Text is the text string in which you want to replace text.
OldText is the text to be replaced. Note: This function is case-sensitive, i.e. it distinguishes between uppercase
and lowercase letters.
NewText is the replacement text.
n (optional) lets you specify which occurrence of OldText to replace. If omitted, all occurrences will be
replaced.
Example:

SUBSTITUTE("aabbaabb", "aa", "xx") returns xxbbxxbb
SUBSTITUTE("aabbaabb", "aa", "xx", 2) returns aabbxxbb
SUBSTITUTE("aabbaabb", "AA", "xx") returns aabbaabb
See also:

FIND, SEARCH, REPLACE, REPT

SUBTOTAL (calculations ignoring hidden cells)
Syntax:

SUBTOTAL(FunctionID, Range1 [, Range2, Range3 ...])
Description:

Applies one of the arithmetic functions listed below to the specified cell range(s), ignoring all cells that are
currently hidden.
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In details: When you apply a filter to a cell range (using the Worksheet > Filter menu command) and then
perform arithmetic calculations on this range, cells that have been filtered out are still included. If, however,
you use the SUBTOTAL function, filtered cells will be ignored.
Range1, Range2, etc. are the cell ranges you want to evaluate.
FunctionID is a number between 1 and 11 that specifies which arithmetic function to apply:
Value

Function

Explanation

1:

AVERAGE

(arithmetic mean)

2:

COUNT

(number of cells filled with numbers)

3:

COUNTA

(number of cells not empty)

4:

MAX

(maximum)

5:

MIN

(minimum)

6:

PRODUCT

(product)

7:

STDEV

(standard deviation of a sample)

8:

STDEVP

(standard deviation of entire population)

9:

SUM

(sum)

10:

VAR

(variance of a sample)

11:

VARP

(variance of entire population)

For example, if you set FunctionID to 9, SUBTOTAL returns the sum of the specified cell range(s) – ignoring
all cells that have been filtered out by the Worksheet > Filter menu command.
Ignoring manually hidden cells as well:
There's a second variant of this function. It additionally ignores all cells that have been hidden manually (using
e.g. the menu command Worksheet > Row > Hide or Worksheet > Outliner > Group). To use this variant,
simply set the FunctionID to a value between 101 and 111 instead of a value between 1 and 11, as shown in the
following table:
Value

Function

Explanation

101:

AVERAGE

(arithmetic mean)

102:

COUNT

(number of cells filled with numbers)

103:

COUNTA

(number of cells not empty)

104:

MAX

(maximum)

105:

MIN

(minimum)

106:

PRODUCT

(product)

107:

STDEV

(standard deviation of a sample)

108:

STDEVP

(standard deviation of entire population)

109:

SUM

(sum)
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110:

VAR

(variance of a sample)

111:

VARP

(variance of entire population)
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For example, if you set FunctionID to 109, SUBTOTAL returns the sum of the specified cell range(s) –
ignoring all cells that have been filtered out by the Worksheet > Filter menu command. Additionally, it ignores
all cells that have been hidden manually (using Worksheet > Row > Hide or Worksheet > Outliner >
Group).
Please note: Only hidden rows will be ignored, hidden columns are still included in the calculations.
Example:

SUBTOTAL(9, A1:A10) returns the sum of the values in A1:A10, ignoring all cells filtered by the Worksheet
> Filter menu command.
See also:

For information on filters, see section Filtering cells by their contents

SUM (Sum)
Syntax:

SUM(Number1 [, Number2, Number3 ...])
Description:

Returns the sum of the given numbers.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be summed.
If you use this function with cell references, text strings and logical values occurring in the referenced cells are
ignored.
If you use this function with fixed values that you typed in directly, text strings and logical values evaluate as
follows:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text representations of numbers (for example, "42") evaluate like numbers.
See examples below.
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Example:

SUM(1, 2, 3, 4) equals 10
If the cells A1:A4 contains the values 1, 2, 3, and 4:
SUM(A1:A4) equals 10
Please note:
If the cells A1:A3 contain 1, "2", and TRUE:
SUM(A1:A3) returns 1, since the text string and the logical value are ignored. They are counted only if they
were typed in directly:
SUM(1, "2", TRUE) returns 1+2+1, which is 4
Hint:

You can also use the AutoSum icon

in the standard toolbar to calculate the SUM of cell contents:

When you click this icon in a cell directly below a group of cells containing numbers, it will insert the SUM
function for this cell range there.
When you first select a range of cells containing numbers, it will insert the sum of this cell range directly below
these cells.
You can use this icon with several other arithmetic functions as well. When you click on the arrow to the right
of this icon, a dropdown list containing all available functions will open (for example, Count, Product, Average,
etc.). Select the desired function and proceed as described above.
See also:

PRODUCT, SUMPRODUCT, SUMIF, SUMIFS, SUMXMY2, SUMX2MY2, SUMX2PY2

SUMIF (sum if condition is true)
Syntax:

SUMIF(Range, Criterion [, SumRange])
Description:

Returns the sum of those values in a cell range that fulfill the specified criterion.
Range is the cell range to be evaluated.
Criterion is the criterion that the values in Range have to fulfill to be included.
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Use numbers or text (like "42" or "bolts") to sum all cells that contain that value.
Use conditions (like ">10" or "<=5") to sum all cells that match the specified condition (see examples below).
Note: Criteria always have to be surrounded by double quotation marks (").
SumRange (optional) lets you specify the cell range containing the values to be summed. If omitted, the values
in Range will be summed.
Example:

If the cells A1:A5 contain the values 1, 2, 3, 2, 1:
SUMIF(A1:A5, "2") returns 2+2, which is 4
SUMIF(A1:A5, ">=2") returns 2+3+2, which is 7
See also:

AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUM, SUMIFS

SUMIFS (sum if conditions are true)
Syntax:

SUMIFS(SumRange, Range1, Criterion1 [, Range2, Criterion2 ...])
Description:

Returns the sum of those values in a cell range that fulfill all of the specified criteria.
This function is similar to the SUMIF function, but allows you to specify more than just one range/criterion to
be searched
Apart from that, the order of the parameters is different: In SUMIF, SumRange is the last parameter – in
SUMIFS, it is the first.
SumRange is the cell range containing the values to be summed.
Range1 is the first cell range to be checked for the specified criterion. This range must have the same
dimensions as SumRange.
Criterion1 is the criterion that the values in Range1 have to fulfill to be included.
Use numbers or text (like "42" or "bolts") to obtain the sum of all cells that contain that value.
Use conditions (like ">10" or "<=5") to obtain the sum of all cells that match the specified condition (see
examples below).
Note: Criteria always have to be surrounded by double quotation marks (").
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Unlike the SUMIF function, SUMIFS allows you to specify more than just one cell range and criterion to be
checked. If you do so, only occurrences where all criteria are fulfilled are included in the calculation of the
sum.
Compatibility notes:

This function is not supported by the .xls file format (used in Microsoft Excel 2003 and earlier). If you save a
document in this format, all calculations using this function will be replaced by their last result as a fixed value.
Accordingly, if you use this function, you should not save your document in the "Microsoft Excel 97-2003
(.xls)" file format, but choose one of the following formats instead:
¡ "PlanMaker document (.pmdx or .pmd)"
¡ or: "Microsoft Excel 2007-2016 (.xlsx)"
Example:

SUMIFS(A1:A10, C1:C10, ">1", C1:C10, "<2")
This formula returns the sum of only those cells in the cell range A1:A10 where the corresponding cell in the
range C1:C10 is greater than 1 and less than 2.
See also:

AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUM, SUMIF

SUMPRODUCT (sum of products)
Syntax:

SUMPRODUCT(Range1 [, Range2, Range3 ...])
Description:

Multiplies the corresponding elements of two or more arrays, and returns the sum of these products.
Range1, Range2, etc., are cell ranges or arrays containing the values to be evaluated.
All ranges must have the same dimensions (height and width). If not, the function returns a #N/A error value.
Empty cells, text strings, and logical values evaluate as zero.
Example:

If A1:A3 contains the values 1, 2, 3, and B1:B3 contains 20, 30, 40:
SUMPRODUCT(A1:A3, B1:B3) equals 1*20 + 2*30 + 3*40, which is 200.
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See also:

SUM, SUMSQ, SUMXMY2, SUMX2MY2, SUMX2PY2

SUMSQ (sum of squares)
Syntax:

SUMSQ(Number1 [, Number2, Number3 ...])
Description:

Returns the sum of the squares of the given numbers.
Example:

SUMSQ(1, 2, 3) equal 1^2 + 2^2 + 3^2, which is 14.
See also:

SUM, SUMPRODUCT, SUMXMY2, SUMX2MY2, SUMX2PY2

SUMX2MY2 (sum of x^2 - y^2)
Syntax:

SUMX2MY2(Range1, Range2)
Description:

Returns the sum of the difference of squares of corresponding values in two arrays.
The equation for this function is:
SUMX2MY2 = å(x^2 - y^2)
Range1 and Range2 are cell ranges or arrays containing the values to be evaluated.
Both ranges must have the same dimensions (height and width). If not, the function returns a #N/A error value.
Pairs of values where at least one value is an empty cell or a non-numerical value (text string or logical value)
are ignored.
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Example:

If A1:A3 contains the values 9, 4, 7, and B1:B3 contains 1, 0, 5:
SUMX2MY2(A1:A3, B1:B3) equals (9^2) - (1^2) + (4^2) - (0^2) + (7^2) - (5^2), which is 120.
See also:

SUM, SUMPRODUCT, SUMX2PY2, SUMXMY2, SUMSQ

SUMX2PY2 (sum of x^2 + y^2)
Syntax:

SUMX2PY2(Range1, Range2)
Description:

Returns the sum of the sum of squares of corresponding values in two arrays.
The equation for this function is:
SUMX2PY2 = å(x^2 + y^2)
Range1 and Range2 are cell ranges or arrays containing the values to be evaluated.
Both ranges must have the same dimensions (height and width). If not, the function returns a #N/A error value.
Pairs of values where at least one value is an empty cell or a non-numerical value (text string or logical value)
are ignored.
Example:

If A1:A3 contains the values 9, 4, 7, and B1:B3 contains 1, 0, 5:
SUMX2PY2(A1:A3, B1:B3) equals (9^2) + (1^2) + (4^2) + (0^2) + (7^2) + (5^2), which is 172.
See also:

SUM, SUMPRODUCT, SUMX2MY2, SUMXMY2, SUMSQ
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SUMXMY2 (sum of (x - y)^2)
Syntax:

SUMXMY2(Range1, Range2)
Description:

Returns the sum of squares of differences of corresponding values in two arrays.
The equation for this function is:
SUMXMY2 = å(x - y)^2
Range1 and Range2 are cell ranges or arrays containing the values to be evaluated.
Both ranges must have the same dimensions (height and width). If not, the function returns a #N/A error value.
Pairs of values where at least one value is an empty cell or a non-numerical value (text string or logical value)
are ignored.
Example:

If A1:A3 contains the values 9, 4, 7, and B1:B3 contains 1, 0, 5:
SUMXMY2(A1:A3, B1:B3) equals (9-1)^2 + (4-0)^2 + (7-5)^2, which is 84.
See also:

SUM, SUMPRODUCT, SUMX2MY2, SUMX2PY2, SUMSQ

SYD (sum-of-years’ digits depreciation)
Syntax:

SYD(Cost, Salvage, Life, Per)
Description:

Returns the depreciation of an asset for the specified period, using the sum-of-years' digits method.
Cost = Initial cost of asset
Salvage = Salvage value (value at the end of the depreciation)
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Life = Life of asset (in number of periods)
Per = Period to evaluate (in the same time unit as Life)
Example:

Asset parameters: initial cost = 200000, salvage value = 10000, life = 10 years
SYD(200000, 10000, 10, 1) returns 34545.45 (depreciation in year 1)
See also:

DDB, DB, SLN

T (convert value into text string)
Syntax:

T(Value)
Description:

Converts a value to a text string.
Value is the value to be converted. If Value is not a text string, an empty text string is returned.
Note:

This function was retained only for compatibility with older spreadsheet applications. It is no longer commonly
used, as current spreadsheet applications (including PlanMaker) automatically convert values into text strings,
where necessary.
Example:

T("Text") returns Text
T("42") returns 42
T(42) returns an empty text string
T(TRUE) returns an empty text string
See also:

N, VALUE, TEXT
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TAN (tangent)
Syntax:

TAN(Number)
Description:

Returns the tangent of Number.
Tip:

You can use the RADIANS function to convert an angle given in degrees into radians.
Example:

TAN(PI()/4) returns 1
TAN(RADIANS(45)) returns 1
See also:

ATAN, ATAN2, COT, SIN, COS

TANH (hyperbolic tangent)
Syntax:

TANH(Number)
Description:

Returns the hyperbolic tangent of Number.
Example:

TANH(0.45) returns 0.4219
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See also:

ATANH, COSH, SINH

TDIST (t-distribution)
Note: TDIST is supplemented by the new functions T.DIST.2T, T.DIST.RT and T.DIST with additional
functionalities, which are available in newer versions of Microsoft Excel (2010 or later).

Syntax:

TDIST(X, DegreesFreedom, Tails)
Description:

Returns the probability of the Student's t-distribution.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1. Integer numbers are expected; if this is not
the case, PlanMaker automatically truncates the decimal digits after the point.
Tails is the number of distribution tails:
1: One-tailed distribution
2: Two-tailed distribution
See also:

T.DIST.2T/T.DIST.RT/T.DIST, T.INV.2T/T.INV/TINV, T.TEST/TTEST

T.DIST (t-distribution)
Syntax:

T.DIST(X, DegreesFreedom, Cumulative)
Description:

Returns the probability of the Student's t-distribution.
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X is the value to be evaluated. Must be ³ 0.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1. Integer numbers are expected; if this is not
the case, PlanMaker automatically truncates the decimal digits after the point.
Cumulative determines the type of function as a switch: If you enter the value TRUE, the cumulative
distribution function of the left-tailed Student's t-distribution is calculated. By entering the value FALSE, the
probability density function of the Student's t-distribution is calculated.
Note:

The T.DIST function supplements together with T.DIST.2T and T.DIST.RT the previous TDIST function,
whereby T.DIST has the additional argument Cumulative.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

T.DIST.2T/T.DIST.RT/TDIST, T.INV.2T/T.INV/TINV, T.TEST/TTEST

T.DIST.2T (t-distribution two-tailed)
Syntax:

T.DIST.2T(X, DegreesFreedom)
Description:

Returns the probability of the two-tailed Student's t-distribution.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1. Integer numbers are expected; if this is not
the case, PlanMaker automatically truncates the decimal digits after the point.
Note:

The T.DIST.2T function supplements together with T.DIST.RT and T.DIST the previous TDIST function,
whereby T.DIST.2T returns the same result as TDIST with the argument Tails=2.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
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See also:

T.DIST.RT/T.DIST/TDIST, T.INV.2T/T.INV/TINV, T.TEST/TTEST

T.DIST.RT (t-distribution right-tailed)
Syntax:

T.DIST.RT(X, DegreesFreedom)
Description:

Returns the probability of the right-tailed Student's t-distribution.
X is the value to be evaluated. Must be ³ 0.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1. Integer numbers are expected; if this is not
the case, PlanMaker automatically truncates the decimal digits after the point.
Note:

The T.DIST.RT function supplements together with T.DIST.2T and T.DIST the previous TDIST function,
whereby T.DIST.RT returns the same result as TDIST with the argument Tails=1.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

T.DIST.2T/T.DIST/TDIST, T.INV.2T/T.INV/TINV, T.TEST/TTEST

TEXT (convert number into text string)
Syntax:

TEXT(Number, Format)
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Description:

Converts a number to a text string in the specified number format.
Number is the number to convert.
Format is a text string specifying the desired format. It has to be built like a format string for user-defined
number formats (see section Structure of a user-defined format).
Annotation:

To change the format of numbers without having to convert them to a text string, choose the Format > Cell
menu command and select the desired number format.
Example:

TEXT(2.715, "0.00 ""USD""") returns 2.72 USD (as a text string)
See also:

VALUE, T, N, FIXED

TIME (create time)
Syntax:

TIME(Hour, Minute, Second)
Description:

Returns a serial date value based on the specified Hour, Minute, and Second.
Example:

TIME(0, 20, 0) returns 0.01389, the serial date value for the corresponding time. PlanMaker automatically
applies the number format "Date/Time" to it (e.g., 00:20:00 is displayed).
See also:

TIMEVALUE, DATE, DATEVALUE
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TIMEDIFF (time difference)
Syntax:

TIMEDIFF(StartTime, EndTime)
Description:

Returns the time elapsed between two time values.
StartTime is the start time.
EndTime is the end time.
Both can be either time values or date values including a time. Please note that in the latter case, both
StartTime and EndTime have to include a date, otherwise a #VALUE! error value is returned.
Note:

Compared to simply subtracting time values, this function has the following advantage when EndTime is
smaller than StartTime:
An employee starts his shift, for example, at 10:00 pm and leaves at 6:00 am. If calculating his hours of work
by subtracting 10:00 pm from 6:00 am, the result would be -16 hours. If the TIMEDIFF function is used, the
correct result (8 hours) is returned.
Example:

TIMEDIFF("8:00 AM", "4:00 PM") returns 8:00
TIMEDIFF("10:00 PM", "6:00 AM") returns 8:00
TIMEDIFF("10/01/2018 10:00 PM", "10/02/2018 6:00 AM") returns 8:00
Compatibility notes:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
See also:

TIME, TIMEVALUE, DAYS/DAYSP, DAYS360
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TIMEVALUE (convert text into time)
Syntax:

TIMEVALUE(Text)
Description:

Converts a text string representing a date to a serial time value.
Note:

This function was retained only for compatibility with older spreadsheet applications. It is no longer commonly
used, as current spreadsheet applications (including PlanMaker) automatically convert values into date/time
values, where necessary.
Example:

TIMEVALUE("10:30:00 am") returns 0.4375.
See also:

DATEVALUE, DATE, TIME

TINV (percentiles of the t-distribution)
Note: TINV is supplemented by the new identical function T.INV.2T and the completely new function
T.INV, which are available in newer versions of Microsoft Excel (2010 or later).

Syntax:

TINV(Probability, DegreesFreedom)
Description:

Returns the inverse of the two-tailed Student's t-distribution function (i.e., percentiles of this distribution).
Probability is the two-tailed probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1.
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Please note: The result of this function is calculated using an iterative search technique. If the search does not
converge after 100 iterations, a #N/A error value is returned.
See also:

T.INV.2T/T.INV, T.TEST/TTEST, T.DIST.2T/T.DIST.RT/T.DIST/TDIST

T.INV (percentiles of the t-distribution left-tailed)
Syntax:

T.INV(Probability, DegreesFreedom)
Description:

Returns the inverse of the left-tailed Student's t-distribution function (i.e., percentiles of this distribution).
Probability is the two-tailed probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1.
Please note: The result of this function is calculated using an iterative search technique. If the search does not
converge after 100 iterations, a #N/A error value is returned.
Note:

The T.INV function supplements together with T.INV.2T the previous TINV function.
T.INV.2T returns the same result as TINV (two-tailed percentiles).
T.INV (left-tailed percentiles) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

TINV/T.INV.2T, T.TEST/TTEST, T.DIST.2T/T.DIST.RT/T.DIST/TDIST
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T.INV.2T (percentiles of the t-distribution two-tailed)
Syntax:

T.INV.2T(Probability, DegreesFreedom)
Description:

Returns the inverse of the two-tailed Student's t-distribution function (i.e., percentiles of this distribution).
Probability is the two-tailed probability to be evaluated. Must be in the range 0 to 1.
DegreesFreedom is the number of degrees of freedom. Must be ³ 1.
Please note: The result of this function is calculated using an iterative search technique. If the search does not
converge after 100 iterations, a #N/A error value is returned.
Note:

The T.INV.2T function supplements together with T.INV the previous TINV function.
T.INV.2T returns the same result as TINV (two-tailed percentiles).
T.INV (left-tailed percentiles) is completely new.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

TINV/T.INV, T.TEST/TTEST, T.DIST.2T/T.DIST.RT/T.DIST/TDIST

TODAY (current date)
Syntax:

TODAY()
Description:

Returns the current date (without time).
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Note:

The result is a serial date number. PlanMaker automatically formats it in date format so that it will be displayed
as a date. To select a different date format, use the Format > Cell menu command.
See also:

NOW, CREATEDATE

TRANSPOSE (transposed matrix)
Syntax:

TRANSPOSE(Array)
Description:

Returns the transpose of a matrix, i.e., swaps its columns with its rows. When you transpose, for example, a 2x4
matrix, the result is a 4x2 matrix.
Array is the cell range or array containing the matrix to be evaluated. The matrix must contain numeric values
only.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Important: Please note that the range you have to select before entering the formula must have the correct
dimensions. If the matrix consists of x rows and y columns, the resulting range must have y rows and x
columns.
Example:

TRANSPOSE({1,2,3;4,5,6}) returns {1,4;2,5;3,6}
See also:

Section Working with arrays, MDETERM, MINVERSE, MMULT, MSOLVE
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TREND (values of a linear regression)
Syntax:

TREND(y_values [, x_values] [, New_x_values] [, Constant])
Description:

Returns the values of a linear regression.
Linear regression is a statistical technique that adapts a line (called "trend line" or "best-fit line") to a set of
data points (for example, the results of a series of measurements).
The TREND function returns an array with the y values of a trend line calculated from the given y values and x
values.
y_values are the known y values.
x_values (optional) are the known x values. If omitted, the values 1, 2, 3, ... will be used.
New_x_values (optional) are the x values for which you want to determine the corresponding y values on the
curve. If omitted, the values in x_values will be used.
Constant (optional) is a logical value that lets you specify if the constant b (the y-intercept point) should be
calculated automatically or forced to equal zero:
TRUE or omitted: b will be calculated from the given data.
FALSE: b is forced to equal 0 (zero), the m values are adjusted accordingly.
Note:

Formulas using this function have to be entered as an array formula (see section Working with arrays).
Example:

The resistance of a temperature-sensitive resistor has been measured at several temperatures.
Cells A1:A4 contain the temperatures measured: 8, 20, 25, 28
Cells B1:B4 contain the resistances measured: 261, 508, 608, 680
The following calculation returns an array with the y coordinates of a best-fit line calculated from these values:
TREND(B1:B4, A1:A4)
See also:

LINEST, LOGEST, GROWTH, FORECAST
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TRIM (remove spaces from text)
Syntax:

TRIM(Text)
Description:

Removes all spaces from the beginning and the end of the specified text string.
Example:

TRIM(" Text ") returns Text
See also:

CLEAN

TRIMMEAN (mean ignoring marginal values)
Syntax:

TRIMMEAN(Area, Percentage)
Description:

Returns the mean of the values in the middle of a data set (by excluding the specified percentage of top and
bottom values).
For example, TRIMMEAN(A1:A42, 10%) averages the middle 90% of the data points in A1:A42.
Area is the cell range or array to evaluate.
Percentage is the percentage of values to be excluded.
If, for example, 100 values are given and Percentage is set to 10%, 10 values will be excluded: 5 from the
bottom and 5 from the top.
Note: For symmetry, the number of excluded values will automatically be rounded down to a multiple of 2. For
example, if 30 values are given and Percentage is set to 10%, only 2 values will be excluded instead of 3.
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Example:

Cells A1:A10 contain the following values:
43, 45, 42, 0, 44, 45, 42, 1234, 40, 41
As you can see, two values are exceptionally low/high (e.g., because of a measuring error): 0 and 1234. Thus,
using the AVERAGE function would return an unusable result:
AVERAGE(A1:A10) returns 159.2
If using TRIMMEAN instead, the top and bottom values are ignored:
TRIMMEAN(A1:A10, 20%) returns 42.75
In this case, 20% of the values (i.e., 2 values) were excluded: 0 at the bottom and 1234 at the top.
See also:

AVERAGE, GEOMEAN, HARMEAN

TRUE (logical value TRUE)
Syntax:

TRUE()
Description:

Returns the logical value TRUE.
See also:

FALSE

TRUNC (truncate a number)
Syntax:

TRUNC(Number [, n])
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Description:

Returns the given number truncated to n digits after the decimal point.
n (optional) is the number of decimal places.
If n is omitted, Number is truncated to an integer.
If n is a negative value, Number is truncated to the left of the decimal point. For example, if n is -2, Number is
truncated to the nearest multiple of hundred (see last example).
Example:

TRUNC(5.779) returns 5
TRUNC(5.779, 2) returns 5.77
TRUNC(1234, -2) returns 1200
Hint:

To obtain the decimal places use the DECIMALS function.
See also:

ROUNDDOWN, ROUNDUP, DECIMALS, ROUND

TTEST (t-test)
Note: TTEST is supplemented by the new identical function T.TEST, which is available in newer versions of
Microsoft Excel (2010 or later).

Syntax:

TTEST(Array1, Array2, Tails, Type)
Description:

Returns the result of a Student's t-test.
The t-Test is typically used to test the difference of the means of two samples.
Array1 and Array2 are the two arrays to be evaluated.
Tails is the number of distribution tails:
1: One-tailed distribution
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2: Two-tailed distribution
Type is the type of t-test:
1: dependent samples ("paired")
2: independent samples, equal variances ("homoscedastic")
3: independent samples, different variances ("heteroscedastic")
See also:

T.TEST, T.INV.2T/T.INV/TINV, T.DIST.2T/T.DIST.RT/T.DIST/TDIST

T.TEST (t-test)
Syntax:

T.TEST(Array1, Array2, Tails, Type)
Description:

Returns the result of a Student's t-test.
The t-Test is typically used to test the difference of the means of two samples.
Array1 and Array2 are the two arrays to be evaluated.
Tails is the number of distribution tails:
1: One-tailed distribution
2: Two-tailed distribution
Type is the type of t-test:
1: dependent samples ("paired")
2: independent samples, equal variances ("homoscedastic")
3: independent samples, different variances ("heteroscedastic")
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

TTEST, T.INV.2T/T.INV/TINV, T.DIST.2T/T.DIST.RT/T.DIST/TDIST
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TYPE (type of a value)
Syntax:

TYPE(Value)
Description:

Returns the type of the specified value.
The result is one the following numbers:
Value is a ...

Result

Number or empty cell

1

Text string

2

Logical value

4

Error value

16

Array

64

Example:

TYPE(42) returns 1
If A1 contains the text string "Text":
TYPE(A1) returns 2
See also:

ERRORTYPE

UPPER (convert text to upper case)
Syntax:

UPPER(Text)

685
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Description:

Converts all characters in a text string to upper case letters.
Example:

UPPER("PlanMaker") returns PLANMAKER
See also:

PROPER, LOWER

USERFIELD (user field)
Syntax:

USERFIELD(FieldName)
Description:

Returns the content of one of the fields with your user information (name, address, etc.) entered in PlanMaker's
preferences dialog.
Note: To edit the content of these fields, choose the Tools > Options menu command, switch to the General
tab, and click on the User info button.
FieldName is the name of the field to be returned (see table below).
Uppercase and lowercase letters can be mixed. But please note that, if entered directly, FieldName has to be
surrounded by double quotation marks (") – as in USERFIELD("User.City").
FieldName can be one of the following text strings:
User info field

FieldName

Title

User.Title

Name

User.Name

Initials

User.Initials

Company

User.Company

Department

User.Department

Address 1

User.Address 1

Address 2

User.Address 2

State, ZIP

User.ZIP
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City

User.City

Phone 1

User.Phone 1

Phone 2

User.Phone 2

Phone 3

User.Phone 3

Fax

User.Fax

E-mail 1

User.E-mail 1

E-mail 2

User.E-mail 2

E-mail 3

User.E-mail 3

Web site

User.Website

687

Compatibility note 1:

This function is not supported by Microsoft Excel. If you save a document in Excel format, all calculations
using this function will be replaced by their last result as a fixed value.
Compatibility note 2:

In PlanMaker 2016 and older, there were two sets of user data: "User (home)" and "User (business)". This was
reduced to one set in PlanMaker 2018. When you open an old document that uses this function, its parameters
are automatically converted accordingly.
Example:

USERFIELD("User.Website") returns www.softmaker.com

VALUE (convert text into a number)
Syntax:

VALUE(Text)
Description:

Converts a text string representing a number into a number.
Text is the text string to convert. It must contain the text representation of a number, otherwise a #VALUE!
error value is returned.
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Note:

This function was retained only for compatibility with older spreadsheet applications. It is no longer commonly
used, as current spreadsheet applications (including PlanMaker) automatically convert text strings into
numbers, where necessary.
Example:

VALUE("42") returns 42
VALUE("42 DM") returns 42, since "DM" is a valid currency unit.
VALUE("42 bolts") returns a #VALUE! error value.
VALUE("TRUE") returns 1
VALUE("09/25/2008") returns 39716, the serial date value for the date 09/25/2008.
See also:

TEXT, T, N

VAR (variance of a sample)
Note: VAR is supplemented by the new identical function VAR.S, which is available in newer versions of
Microsoft Excel (2010 or later).

Syntax:

VAR(Number1, Number2 [, Number3 ...])
Description:

Estimates the variance of a population based on a sample.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated.
Empty cells, text strings, and logical values are ignored.
Example:

VAR(2, 2, 3, 4, 1) returns 1.3
See also:

VAR.S, VARA, VARPA, VAR.P/VARP, STDEV.S/STDEV, STDEV.P/STDEVP
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VARA (variance of a sample)
Syntax:

VARA(Value1, Value2 [, Value3 ...])
Description:

Estimates the variance of a population based on a sample, including logical values and text.
Value1, Value2, etc., are single values, cell ranges, or arrays containing the values to be evaluated.
Empty cells are ignored.
Note:

Unlike the VAR function, VARA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Example:

VARA(2, 2, 3, 4, 1) returns 1.3
See also:

VAR.S/VAR, VARPA

VARP (variance of entire population)
Note: VARP is supplemented by the new identical function VAR.P, which is available in newer versions of
Microsoft Excel (2010 or later).

Syntax:

VARP(Number1, Number2 [, Number3 ...])
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Description:

Returns the variance of an entire population.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated. Please
note that all values of the entire population have to be given. To calculate the variance of a sample, use the
VAR.S/VAR function instead
Empty cells, text strings, and logical values are ignored.
Example:

VARP(2, 2, 3, 4, 1) returns 1.04
See also:

VAR.P, VAR.S/VAR, STDEV.S/STDEV, STDEV.P/STDEVP

VAR.P (variance of entire population)
Syntax:

VAR.P(Number1, Number2 [, Number3 ...])
Description:

Returns the variance of an entire population.
Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated. Please
note that all values of the entire population have to be given. To calculate the variance of a sample, use the
VAR.S/VAR function instead
Empty cells, text strings, and logical values are ignored.
Example:

VAR.P(2, 2, 3, 4, 1) returns 1.04
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

VARP, VAR.S/VAR, STDEV.S/STDEV, STDEV.P/STDEVP
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VARPA (variance of entire population)
Syntax:

VARPA(Value1, Value2 [, Value3 ...])
Description:

Returns the variance of an entire population, including logical values and text.
Value1, Value2, etc., are single values, cell ranges, or arrays containing the values to be evaluated. Please note
that all values of the entire population have to be given. To calculate the variance of a sample, use the VARA
function instead
Empty cells are ignored.
Note:

Unlike the VARP function, VARPA also evaluates logical values and text:
FALSE evaluates as 0.
TRUE evaluates as 1.
Text evaluates as 0.
Example:

VARPA(2, 2, 3, 4, 1) returns 1.04
See also:

VAR.P/VARP, VAR.S/VAR, VARA

VAR.S (variance of a sample)
Syntax:

VAR.S(Number1, Number2 [, Number3 ...])
Description:

Estimates the variance of a population based on a sample.
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Number1, Number2, etc., are single values, cell ranges, or arrays containing the values to be evaluated.
Empty cells, text strings, and logical values are ignored.
Example:

VAR.S(2, 2, 3, 4, 1) returns 1.3
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

VAR, VARA, VAR.P/VARP, VARPA, STDEV.S/STDEV, STDEV.P/STDEVP

VLOOKUP (look up column-wise)
Syntax:

VLOOKUP(Crit, Range, n [, Sorted])
Description:

Scans the first column of Range for the given value. If found, the function returns the content of the cell located
in the same row and n-th column of Range.
If no exact match is found, the next smallest value will be taken. If no smaller value exists, a #N/A error value
is returned.
Note: VLOOKUP can search vertically only. To search horizontally, use HLOOKUP instead
Crit is the value to be searched for (case insensitive).
Range is the cell range or array to be evaluated. Its first column should contain the values to be scanned.
n is the relative column number in Range from which a value will be returned.
If n is less than 1, a #VALUE! error value is returned. If n is greater than the total number of columns in
Range, a #REF! error value is returned.
Sorted is a logical value determining whether the values in the first column of Range are in sorted order:
TRUE or omitted: Values have to be sorted in ascending order.
FALSE: Values do not have to be sorted.
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See also:

HLOOKUP, LOOKUP, CHOOSE, INDEX, MATCH

WEEKDAY (weekday)
Syntax:

WEEKDAY(Date [, Mode])
Description:

Returns the day of the week of a date as a number.
Date is the date to be evaluated.
Mode (optional) lets you change the type of values to be returned:
1 or omitted: Numbers from 1 (Sunday) to 7 (Saturday) are returned.
2: Numbers from 1 (Monday) to 7 (Sunday) are returned.
3: Numbers from 0 (Monday) to 6 (Sunday) are returned.
Example:

WEEKDAY("09/25/1966") returns 1 (i.e., Sunday)
WEEKDAY("09/25/1966", 2) returns 7 (i.e., Sunday)
See also:

ISOWEEK, ISOWEEKNUM, WEEKNUM, YEAR, MONTH, DAY

WEEKNUM (week number)
Syntax:

WEEKNUM(Date [, WeekStartsOn])
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Description:

Returns the week number of a date.
Date is the date to be evaluated.
WeekStartsOn (optional) lets you specify on which day a week begins:
1 or omitted: Week begins on Sunday.
2: Week begins on Monday.
Example:

On Sunday, the 5th of January, 2014:
WEEKNUM("01/05/2014", 1) returns 2
WEEKNUM("01/05/2014", 2) returns 1
See also:

ISOWEEKNUM, ISOWEEK, YEAR, MONTH, DAY, WEEKDAY

WEIBULL (Weibull distribution)
Note: WEIBULL is supplemented by the new identical function WEIBULL.DIST, which is available in
newer versions of Microsoft Excel (2010 or later).

Syntax:

WEIBULL(x, Alpha, Beta, Cumulative)
Description:

Returns the Weibull distribution function.
x is the value to be evaluated. Must be ³ 0.
Alpha is a shape parameter of the function. It has to be greater than zero. Note: If Alpha = 1, the Weibull
distribution equals an exponential distribution with Lambda = 1/Beta.
Beta is the scale parameter of the function. It has to be greater than zero.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
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TRUE: The cumulative distribution function is returned.
Example:

WEIBULL(42, 2, 100, TRUE) returns 0.16172
WEIBULL(42, 2, 100, FALSE) returns 0.00704
See also:

WEIBULL.DIST, EXPON.DIST/EXPONDIST, POISSON.DIST/POISSON

WEIBULL.DIST (Weibull distribution)
Syntax:

WEIBULL.DIST(x, Alpha, Beta, Cumulative)
Description:

Returns the Weibull distribution function.
x is the value to be evaluated. Must be ³ 0.
Alpha is a shape parameter of the function. It has to be greater than zero. Note: If Alpha = 1, the Weibull
distribution equals an exponential distribution with Lambda = 1/Beta.
Beta is the scale parameter of the function. It has to be greater than zero.
The logical value Cumulative lets you specify which type of function will be returned:
FALSE: The probability density function is returned.
TRUE: The cumulative distribution function is returned.
Example:

WEIBULL.DIST(42, 2, 100, TRUE) returns 0.16172
WEIBULL.DIST(42, 2, 100, FALSE) returns 0.00704
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
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See also:

WEIBULL, EXPON.DIST/EXPONDIST, POISSON.DIST/POISSON

WORKDAY (date after x workdays)
Syntax:

WORKDAY(StartDate, Days [, Holidays])
Description:

Returns the date that is the specified number of workdays before/after StartDate.
This function counts workdays only, Saturdays and Sundays are skipped. Optionally, you can specify a list of
holidays to be skipped as well (see Holidays parameter).
StartDate is the start date.
Days is the number of workdays. A positive value will return a date in the future, a negative value will return a
date in the past.
Holidays (optional) is a cell range or an array containing a list of dates to be skipped (e.g. holidays).
Example:

WORKDAY("10/1/2016", 10) returns 10/13/2016.
See also:

HOLIDAY, NETWORKDAYS

XIRR (internal rate of return)
Syntax:

XIRR(Values, Dates [, Guess])
Description:

Returns an estimate for the internal rate of return of an investment with irregular cash flows.

Formulas and functions

697

The calculation is based on the cash flows specified in the Values argument. Payments have to be entered as
negative values, incomes as positive values. The date of each cash flow has to be specified using the Dates
argument.
Values is a cell range or array containing the cash flows. At least one payment and one income have to be
given.
Dates is a cell range or array containing the dates for each cash flow specified in Values.
Guess (optional) lets you specify an estimate for the result (see note below).
Note:

The result of this function is calculated using an iterative search technique. If the search does not converge after
20 iterations, a #NUM error value is returned. If this occurs, try altering the Guess parameter.
See also:

IRR, NPV, MIRR, RATE, XNPV

XNPV (net present value)
Syntax:

XNPV(Rate, Values, Dates)
Description:

Returns the net present value of an investment with irregular cash flows.
The calculation is based on the cash flows specified in the Values argument. Payments have to be entered as
negative values, incomes as positive values. The date of each cash flow has to be specified using the Dates
argument.
Rate is the discount rate to apply to the cash flows.
Values is a cell range or array containing the cash flows. At least one payment and one income have to be
given.
Dates is a cell range or array containing the dates for each cash flow specified in Values.
See also:

NPV, XIRR
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XOR (logical XOR function)
Syntax:

XOR(Value1 [, Value2, Value3 ...])
Description:

XOR ("exclusive or") returns the logical value TRUE if an odd number of the arguments is TRUE, otherwise it
returns FALSE.
Compatibility notes:

Microsoft Excel supports this function only in version 2013 or later. In older versions, the function is unknown.
Example:

XOR(TRUE, TRUE) returns FALSE
XOR(TRUE, FALSE) returns TRUE
XOR(FALSE, TRUE) returns TRUE
XOR(FALSE, FALSE) returns FALSE
See also:

OR, AND, NOT

YEAR (year of a date)
Syntax:

YEAR(Date)
Description:

Returns the year of a date.
Example:

YEAR("09/25/2018") returns 2018
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See also:

ISOWEEK, ISOWEEKNUM, WEEKNUM, MONTH, DAY, DAYSPERYEAR, WEEKDAY

ZTEST (z-test)
Note: ZTEST is supplemented by the new identical function Z.TEST, which is available in newer versions of
Microsoft Excel (2010 or later).

Syntax:

ZTEST(Area, x [, Sigma])
Description:

Returns the one-tailed probability of a z-test.
Area is the cell range or array containing the values x will be tested against.
x is the value to be tested.
Sigma (optional) is the standard deviation of the entire population (if known). If omitted, the standard deviation
of the given sample (i.e., the values in Area) is used.
See also:

Z.TEST, STANDARDIZE, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST

Z.TEST (z-test)
Syntax:

Z.TEST(Area, x [, Sigma])
Description:

Returns the one-tailed probability of a z-test.
Area is the cell range or array containing the values x will be tested against.
x is the value to be tested.
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Sigma (optional) is the standard deviation of the entire population (if known). If omitted, the standard deviation
of the given sample (i.e., the values in Area) is used.
Compatibility notes:

Microsoft Excel supports this function only in version 2010 or later. In older versions, the function is unknown.
See also:

ZTEST, STANDARDIZE, NORM.DIST/NORMDIST, NORM.S.DIST/NORMSDIST
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Addendum
In the addendum, the following information is given:
¡ Menu commands and corresponding ribbon commands
In this section you will find a table of each menu command, together with the corresponding command in the
ribbon.
¡ Keyboard shortcuts
This section provides tables for the most frequently used keyboard shortcuts in the program.

Menu commands and corresponding ribbon commands
In this section you will find a table of each menu command, together with the corresponding command in the
ribbon.
Tip: You can switch the user interface between ribbon and classic menus and toolbars at any time. To do
this, invoke the menu command Tools > Options (or, in the ribbon, the command File > Options). In the
dialog, switch to the Appearance tab and click on the User Interface button. A dialog box appears in which
you can select the type of user interface you prefer.
The table contains the following columns:
¡ Left column: menu command
The left column lists all menu commands in the program, sorted by the order in the main menu.
¡ Right column: corresponding command in the ribbon
In the right column you will find the corresponding command in the ribbon – in the following notation:
Tab > Section > Command
Example:
The command File > Document > Save on the ribbon can be found as follows: File tab, Document section,
Save icon.
With some commands, an additional fourth entry is displayed. Here, you can find the corresponding
command in the list that opens when you click on the specified icon (or the arrow to the right of it).

So here is the announced table:
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Menu

Ribbon

File > New

File > File > New >> More

File > Open

File > File > Open

File > Close

File > File > Close

File > Save

File > Document > Save

File > Save as

File > Document > Save as

File > Save all

File > Document > Save all

File > Revert to previous version

File > File management > Versions

File > Acquire

Insert > Objects > Picture frame >> From scanner

File > Select source

Insert > Objects > Picture frame >> Select source

File > Properties

File > File management > Properties

File > File manager

File > File management > File manager

File > Page setup

File > Print > Page setup

File > Print preview

File > Print > Print preview

File > Print range > Define print range

File > Print > Define print range

File > Print range > Remove print range

File > Print > Define print range >> Remove print range

File > Print

File > Print > Print

File > Export as PDF

File > Document > PDF export

File > Send

File > Document > Send

Edit > Undo

Quick Access Toolbar > Undo
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Menu

Ribbon

Edit > Redo

Quick Access Toolbar > Redo

Edit > Repeat

Quick Access Toolbar > Repeat

Edit > Cut

Home > Edit > Cut

Edit > Copy

Home > Edit > Copy

Edit > Paste

Home > Edit > Paste

Edit > Duplicate

Layout > Objects > Duplicate

Edit > Paste special

Home > Edit > Paste > Paste special

Edit > Select all

Home > Selection > Select all

Edit > Fill

Home > Contents > Fill

Edit > Delete special

Home > Contents > Delete

Edit > Delete special > Formatting

Home > Contents > Delete >> Formatting

Edit > Delete special > Contents

Home > Contents > Delete >> Contents

Edit > Delete special > Comments

Home > Contents > Delete >> Comments

Edit > Delete special > Conditional formatting

Home > Contents > Delete >> Conditional formatting

Edit > Delete special > Input validation

Home > Contents > Delete >> Input validation

Edit > Search

Home > Search > Search

Edit > Replace

Home > Search > Replace

Edit > Search again

Home > Search > Search again

Edit > Go to

Home > Search > Go to

Edit > Link

OLE object > OLE > Edit link
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Menu

Ribbon

Edit > OLE object

OLE object > OLE > OLE object

View > Touch mode

Quick Access Toolbar > Touch mode

View > Freeze

View > Windows > Freeze cells

View > Actual size

View > Zoom > Actual size

View > Zoom level

View > Zoom > Set zoom

View > Object mode

View > Mode > Object mode

View > Show formulas

View > View > Show formulas

View > Syntax highlighting

View > View > Syntax highlighting

View > Row & column headers

View > View > Row and column headers

View > Watch window

Formula > Watch > Show watch list

View > Full screen

View > Windows > Full screen

View > Pivot table sidebar > Show at left

View > Windows > Pivot table sidebar >> Show at left

View > Pivot table sidebar > Show at right

View > Windows > Pivot table sidebar >> Show at right

Format > Cell

Home > Number and Home > Alignment

Format > Character

Home > Character

Format > Standard

Home > Contents > Delete >> Reset character formatting

Format > Paragraph

Home > Alignment

Format > Borders

Home > Format > Borders

Format > Shading

Home > Format > Shading
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Menu

Ribbon

Format > Link

Insert > Links > Hyperlink

Format > Remove link

Home > Contents > Delete >> Remove link

Format > Cell style

Home > Format > Cell styles >> Manage cell styles

Format > Conditional formatting > New rule

Home > Format > Conditional formatting >> New rule

Format > Conditional formatting > Manage rules

Home > Format > Conditional formatting >> Manage rules

Format > Input validation

Review > Input validation > Input validation

Format > Transfer formatting

Home > Edit > Format painter

Insert > Function

Formula > Function > Function

Insert > Comment

Insert > Comments > Comment

Insert > Symbol

Insert > Text > Insert symbol

Insert > SmartText

Insert > Text > SmartText

Insert > Header and footer

Insert > Text > Header / footer

Insert > Page break > Insert before row

Layout > Page setup > Page break >> Insert before row

Insert > Page break > Delete before row

Layout > Page setup > Page break >> Delete before row

Insert > Page break > Insert before column

Layout > Page setup > Page break >> Insert before column

Insert > Page break > Delete before column

Layout > Page setup > Page break >> Delete before column

Worksheet > Column > Width

Layout > Cells > Cell size

Worksheet > Column > Optimum width

Layout > Cells > Optimum width

Worksheet > Column > Show

Home > Cells > Visibility >> Show columns

Worksheet > Column > Hide

Home > Cells > Visibility >> Hide columns
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Menu

Ribbon

Worksheet > Row > Height

Layout > Cells > Cell size

Worksheet > Row > Optimum height

Layout > Cells > Optimum height

Worksheet > Row > Show

Home > Cells > Visibility >> Show rows

Worksheet > Row > Hide

Home > Cells > Visibility >> Hide rows

Worksheet > Worksheet > Insert

Insert > Tables > Sheet >> Insert

Worksheet > Worksheet > Copy

Insert > Tables > Sheet >> Copy

Worksheet > Worksheet > Move

Insert > Tables > Sheet >> Move

Worksheet > Worksheet > Delete

Insert > Tables > Sheet >> Delete

Worksheet > Worksheet > Rename

Insert > Tables > Sheet >> Rename

Worksheet > Worksheet > Show > Show all
Worksheet > Worksheet > Hide

Home > Cells > Visibility >> Hide sheet

Worksheet > Worksheet > Properties

Insert > Tables > Sheet >> Properties

Worksheet > Insert copied cells

Home > Cells > Insert >> Insert copied cells

Worksheet > Insert cells

Home > Cells > Insert

Worksheet > Delete cells

Home > Cells > Delete

Worksheet > Remove > Empty rows

Data > Edit > Remove empty rows

Worksheet > Remove > Duplicate rows

Data > Edit > Remove empty rows >> Remove duplicate
rows

Worksheet > Names > Edit

Formula > Named areas > Edit names

Worksheet > Names > Apply

Formula > Named areas > Apply names

Worksheet > Names > Import

Formula > Named areas > Create names
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Menu

Ribbon

Worksheet > Names > Insert list

Formula > Named areas > Export names

Worksheet > Sort

Home > Contents > Sort and filter >> Sort

Worksheet > Transpose

Data > Edit > Transpose

Worksheet > Filter > AutoFilter

Home > Contents > Sort and filter >> AutoFilter

Worksheet > Filter > Show all

Home > Contents > Sort and filter >> Show all

Worksheet > Filter > Reapply filter

Home > Contents > Sort and filter >> Reapply filter

Worksheet > Filter > Special filter

Home > Contents > Sort and filter >> Special filter

Worksheet > Text to columns

Data > Edit > Text to columns

Worksheet > Outliner > Automatically show outline
pane
Worksheet > Outliner > Group

Data > Outliner > Group

Worksheet > Outliner > Ungroup

Data > Outliner > Ungroup

Worksheet > Outliner > Clear outline

Data > Outliner > Remove all groups

Worksheet > Outliner > Show details

Data > Outliner > Show details

Worksheet > Outliner > Hide details

Data > Outliner > Hide details

Worksheet > Outliner > Options

Data > Outliner

Worksheet > External references

Data > Edit > External references

Worksheet > Data consolidation

Data > Analyze > Data consolidation

Worksheet > Pivot table

Insert > Tables > Pivot table

Worksheet > New table

Insert > Tables > Table
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Menu

Ribbon

Worksheet > Table > Table range

Table > Table > Range

Worksheet > Table > Table settings

Table > Table > Properties

Worksheet > Table > Create pivot table

Table > Table > Summarize as pivot

Worksheet > Table > Convert to range

Table > Table > Convert to range

Worksheet > Table > Delete table

Table > Table > Delete table

Worksheet > Table > Select > Select rows

Table > Selection > Select rows

Worksheet > Table > Select > Select columns

Table > Selection > Select columns

Worksheet > Table > Select > Select table

Table > Selection > Select table

Worksheet > Table > Insert > Insert rows above

Table > Edit > Insert above

Worksheet > Table > Insert > Insert rows below

Table > Edit > Insert below

Worksheet > Table > Insert > Insert columns at left

Table > Edit > Insert left

Worksheet > Table > Insert > Insert columns at
right

Table > Edit > Insert right

Worksheet > Table > Delete > Delete rows

Table > Edit > Delete rows

Worksheet > Table > Delete > Delete columns

Table > Edit > Delete columns

Worksheet > Table > Header row

Table > Style > Header row

Worksheet > Table > Total row

Table > Style > Total row

Object > New chart frame

Insert > Objects > Chart frame

Object > New text frame

Insert > Objects > Text frame

Object > New picture frame

Insert > Objects > Picture frame
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Menu

Ribbon

Object > New OLE object frame

Insert > Objects > OLE object frame

Object > New form object > Checkbox

Insert > Objects > Form object >> Checkbox

Object > New form object > Radio button

Insert > Objects > Form object >> Radio button

Object > New form object > Dropdown

Insert > Objects > Form object >> Dropdown

Object > New form object > Listbox

Insert > Objects > Form object >> Listbox

Object > New form object > Pushbutton

Insert > Objects > Form object >> Pushbutton

Object > New form object > Spinner

Insert > Objects > Form object >> Spinner

Object > New form object > Scrollbar

Insert > Objects > Form object >> Scrollbar

Object > New form object > Label

Insert > Objects > Form object >> Label

Object > New form object > Groupbox

Insert > Objects > Form object >> Groupbox

Object > New drawing > Line

Insert > Objects > Lines

Object > New drawing > Curve

Insert > Objects > Lines

Object > New drawing > Freehand form

Insert > Objects > Lines

Object > New drawing > Straight connector

Insert > Objects > Lines

Object > New drawing > Elbow connector

Insert > Objects > Lines

Object > New drawing > Curved connector

Insert > Objects > Lines

Object > New drawing > Rectangle

Insert > Objects > AutoShape

Object > New drawing > Rounded rectangle

Insert > Objects > AutoShape

Object > New drawing > Ellipse/circle

Insert > Objects > AutoShape
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Menu

Ribbon

Object > New drawing > AutoShape

Insert > Objects > AutoShape

Object > New drawing > TextArt

Insert > Objects > TextArt object

Object > Group

Layout > Objects > Group

Object > Order > Bring to front

Layout > Position > Bring to front

Object > Order > Send to back

Layout > Position > Send to back

Object > Order > Bring forward one level

Layout > Position > Bring to front >> Bring forward one
level

Object > Order > Send backward one level

Layout > Position > Send to back >> Send backward one
level

Object > Rotate or flip > Flip horizontally

Layout > Position > Rotate object >> Flip horizontally

Object > Rotate or flip > Flip vertically

Layout > Position > Rotate object >> Flip vertically

Object > Rotate or flip > Rotate left

Layout > Position > Rotate object >> Rotate left

Object > Rotate or flip > Rotate right

Layout > Position > Rotate object >> Rotate right

Object > Align or distribute > Align left

Layout > Position > Align objects >> Align left

Object > Align or distribute > Align center

Layout > Position > Align objects >> Align center

Object > Align or distribute > Align right

Layout > Position > Align objects >> Align right

Object > Align or distribute > Align top

Layout > Position > Align objects >> Align top

Object > Align or distribute > Align middle

Layout > Position > Align objects >> Align middle

Object > Align or distribute > Align bottom

Layout > Position > Align objects >> Align bottom

Object > Align or distribute > Distribute
horizontally

Layout > Position > Align objects >> Distribute horizontally
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Menu

Ribbon

Object > Align or distribute > Distribute vertically

Layout > Position > Align objects >> Distribute vertically

Object > Chart > Data in columns

Chart > Data > Series in columns

Object > Chart > Data in rows

Chart > Data > Series in rows

Object > Chart > Change chart location

Chart > Position > Chart location

Object > Chart > Save as picture

Chart > Export > Save chart as a picture

Object > Chart > Element properties

Chart > Chart elements > Edit properties

Object > Properties

Object > Format > AutoShape templates >> More

Tools > Check spelling

Review > Spelling > Spell check

Tools > Edit user dictionaries

Review > Spelling > Spell check >> Edit user dictionaries

Tools > Sheet protection

Review > Protection > Sheet protection

Tools > Workbook protection

Review > Protection > Workbook protection

Tools > Start script

File > Scripts > Run script

Tools > Edit script

File > Scripts > Edit script

Tools > Edit lists
Tools > Scenarios

Data > Analyze > Scenario manager

Tools > Goal seek

Data > Analyze > Goal seek

Tools > Comments > Edit comment

Review > Comments > Edit

Tools > Comments > Previous comment

Review > Comments > Previous comment

Tools > Comments > Next comment

Review > Comments > Next comment
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Menu

Ribbon

Tools > Comments > Show this comment

Review > Comments > Comment visibility >> Show this
comment

Tools > Comments > Show all comments

Review > Comments > Comment visibility >> Show all
comments

Tools > Comments > Reset comment position

Review > Comments > Comment visibility >> Restore all
comment positions

Tools > Formula auditing > Trace predecessors

Formula > Traces > Trace predecessors

Tools > Formula auditing > Remove traces to
predecessors

Formula > Traces > Remove all traces >> Remove traces to
predecessors

Tools > Formula auditing > Trace successors

Formula > Traces > Trace successors

Tools > Formula auditing > Remove traces to
successors

Formula > Traces > Remove all traces >> Remove traces to
successors

Tools > Formula auditing > Remove all traces

Formula > Traces > Remove all traces

Tools > Formula auditing > Select predecessors

Formula > Traces > Trace predecessors >> Select
predecessors

Tools > Formula auditing > Select successors

Formula > Traces > Trace successors >> Select successors

Tools > Formula auditing > Trace to error

Formula > Traces > Trace to error

Tools > Formula auditing > Go to previous error

Formula > Traces > Previous error

Tools > Formula auditing > Go to next error

Formula > Traces > Next error

Tools > Formula auditing > Mark invalid data

Data > Validation > Mark invalid data

Tools > Formula auditing > Remove invalid data
marks

Data > Validation > Remove marks

Tools > Formula auditing > Go to previous invalid
cell

Data > Validation > Previous invalid cell

Tools > Formula auditing > Go to next invalid cell

Data > Validation > Next invalid cell

Tools > Recalculate

Formula > Update > Update data >> Update calculations
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Menu

Ribbon

Tools > Update charts

Formula > Update > Update data >> Update charts

Tools > Refresh all pivot tables

Formula > Update > Update data >> Update pivot tables

Tools > Update external references

Formula > Update > Update data >> Update external
references

Tools > Customize

File > Settings > Customize >> Customize ribbon

Tools > Options

File > Settings > Options
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Keyboard shortcuts
The following pages provide tables for the most frequently used keyboard shortcuts in the program:
¡ Keyboards shortcuts in the Windows and the Linux version
¡ Keyboards shortcuts in the Mac version
Tip: You can customize the predefined keyboard shortcuts and create new shortcuts with the menu command
Tools > Customize (see section Customizing keyboard shortcuts).

Keyboards shortcuts in the Windows and the Linux version
In the Windows and the Linux version, the following keyboard shortcuts are available:

Keyboard shortcuts for editing spreadsheets
Command

Keyboard shortcut

Move to the next cell

ß/à/á/â

Move to the next / previous cell horizontally

Tab / Shift+Tab

Move to the next / previous cell vertically

Enter / Shift+Enter

Move to the next filled cell

Ctrl + ß/à/á/â

Move to the first cell in the current column

Ctrl+PgUp

Move to the last cell in the current column

Ctrl+PgDn

Move to the first cell in the current row

Home

Move to the last filled cell in the current row

End

Move to the first cell in the worksheet (A1)

Ctrl+Home

Move to the last filled cell in the worksheet

Ctrl+End

Move to the next circular reference

Shift+F5

Move to the next error

Ctrl+F3

Copy cell above

Ctrl+, (comma)
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Command

Keyboard shortcut

Copy value from cell above

Ctrl+Shift+, (comma)

Enter an array formula

Ctrl+Shift+¿

Select current array formula

Ctrl+7

Select current conditional formatting

Ctrl+6

Open a selection list with the contents of the cells above or below
a cell

Alt+Shift+â

Switch between AUTO and TEXT input mode (see section Status
bar)

Ctrl+Shift+F4

Insert an em dash (—)

Ctrl+Alt+Minus(numeric pad)

Insert a non-breaking space

Ctrl+Shift+Space

Convert a hexadecimal character code into the respective Unicode
character*

Ctrl+Alt+Shift+X

* For example, when you type in 20AC and then press this keyboard shortcut, a euro sign € will appear (since the euro sign's character code is 20AC in
the Unicode character set table).

Keyboard shortcuts for menu commands
Menu command

Keyboard shortcut

File > New

Ctrl+N

File > Open

Ctrl+O

File > Close

Ctrl+W or Ctrl+F4

File > Save

Ctrl+S

File > File manager

F12

File > Print

Ctrl+P

File > Exit

Ctrl+Q or Alt+F4

Edit > Undo

Ctrl+Z

Edit > Redo

Ctrl+Y

Edit > Repeat

Ctrl+Shift+Y

Edit > Cut

Ctrl+X

Edit > Copy

Ctrl+C
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Menu command

Keyboard shortcut

Edit > Paste

Ctrl+V

Edit > Paste special

Ctrl+Alt+V

Edit > Select all

Ctrl+A

Edit > Search

Ctrl+F

Edit > Replace

Ctrl+H

Edit > Search again

F3

Edit > Go to

Ctrl+G or F5

View > Full Screen

F6

Format > Cell

Ctrl+1

Number format: Number

Ctrl+Shift+1

Number format: Scientific

Ctrl+Shift+2

Number format: Currency

Ctrl+Shift+4

Number format: Percentage

Ctrl+Shift+5

Format > Character

Ctrl+2

Select font (in the Formatting toolbar)

Ctrl+D

Boldface on/off

Ctrl+B

Italics on/off

Ctrl+I

Underlining on/off

Ctrl+Shift+U

Superscript

Ctrl+Shift+Plus(numeric pad)

Subscript

Ctrl+Shift+Minus(numeric pad)

Remove super- or subscript

Ctrl+Shift+*(numeric pad)

Alignment: default

Ctrl+T

Alignment: left

Ctrl+L

Alignment: centered

Ctrl+E

Alignment: right

Ctrl+R

Alignment: justified

Ctrl+J

Format > Link

Ctrl+K
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Menu command

Keyboard shortcut

Format > Transfer formatting (step copy)

Ctrl+Shift+C

Format > Transfer formatting (step paste)

Ctrl+Shift+V

Insert > Function

F7

Insert > Comment

Shift+F2

Insert current date

Ctrl+. (period)

Insert current time

Ctrl+Shift+. (period)

Hide current row

Ctrl+9

Show current row

Ctrl+Shift+9

Hide current column

Ctrl+0

Show current column

Ctrl+Shift+0

Worksheet > Insert cells

Ctrl+Plus

Worksheet > Delete cells

Ctrl+Minus

Tools > Recalculate

F9

Recalculate the current worksheet only

Shift+F9

Tools > Update charts

F8

Other useful keyboard shortcuts
Command

Keyboard shortcut

Expand or collapse the ribbon

Ctrl+F1

Move to the next ribbon tab

Ctrl+F12

Move to the previous ribbon tab

Ctrl+Shift+F12

Move to the next worksheet
(with dialogs open: to the next tab)

Ctrl+Tab

Move to the previous worksheet
(with dialogs open: to the previous tab)

Ctrl+Shift+Tab
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Keyboards shortcuts in the Mac version
Note: For most keyboard shortcuts with the Cmd key, you can alternatively use the Ctrl key instead of the
Cmd key. For example, for the shortcut key Cmd+S you can also press Ctrl+S if desired.
In the Mac version, the following keyboard shortcuts are available:

Keyboard shortcuts for editing spreadsheets
Command

Keyboard shortcut

Move to the next cell

ß/à/á/â

Move to the next / previous cell horizontally

Tab / Shift+Tab

Move to the next / previous cell vertically

Enter / Shift+Enter

Move to the next filled cell

Cmd + ß/à/á/â

Move to the first cell in the current column

Cmd+PgUp

Move to the last cell in the current column

Cmd+PgDn

Move to the first cell in the current row

Home

Move to the last filled cell in the current row

End

Move to the first cell in the worksheet (A1)

Cmd+Home

Move to the last filled cell in the worksheet

Cmd+End

Move to the next circular reference

Shift+F5

Move to the next error

Cmd+F3

Copy cell above

Cmd+, (comma)

Copy value from cell above

Cmd+Shift+, (comma)

Enter an array formula

Cmd+Shift+¿

Select current array formula

Cmd+7

Select current conditional formatting

Cmd+6

Open a selection list with the contents of the cells above or below
a cell

Alt+Shift+â
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Command

Keyboard shortcut

Switch between AUTO and TEXT input mode (see section Status
bar)

Cmd+Shift+F4

Insert an em dash (—)

Cmd+Alt+Minus(numeric pad)

Insert a non-breaking space

Cmd+Shift+Space

Convert a hexadecimal character code into the respective Unicode
character*

Cmd+Alt+Shift+X

* For example, when you type in 20AC and then press this keyboard shortcut, a euro sign € will appear (since the euro sign's character code is 20AC in
the Unicode character set table).

Keyboard shortcuts for menu commands
Menu command

Keyboard shortcut

File > New

Cmd+N

File > Open

Cmd+O

File > Close

Cmd+W or Cmd+F4

File > Save

Cmd+S

File > File manager

F12

File > Print

Cmd+P

File > Exit

Cmd+Q or Alt+F4

Edit > Undo

Cmd+Z

Edit > Redo

Cmd+Y

Edit > Repeat

Cmd+Shift+Y

Edit > Cut

Cmd+X

Edit > Copy

Cmd+C

Edit > Paste

Cmd+V

Edit > Paste special

Cmd+Alt+V

Edit > Select all

Cmd+A

Edit > Search

Cmd+F

Edit > Replace

Cmd+H

Edit > Search again

F3
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Menu command

Keyboard shortcut

Edit > Go to

Cmd+G or F5

View > Full screen

F6

Format > Cell

Cmd+1

Number format: Number

Cmd+Shift+1

Number format: Scientific

Cmd+Shift+2

Number format: Currency

Cmd+Shift+4

Number format: Percentage

Cmd+Shift+5

Format > Character

Cmd+2

Select font (in the Formatting toolbar)

Cmd+D

Boldface on/off

Cmd+B

Italics on/off

Cmd+I

Underlining on/off

Cmd+U

Superscript

Cmd+Shift+Plus(numeric pad)

Subscript

Cmd+Shift+Minus(numeric pad)

Remove super- or subscript

Cmd+Shift+*(numeric pad)

Alignment: default

Cmd+T

Alignment: left

Cmd+L

Alignment: centered

Cmd+E

Alignment: right

Cmd+R

Alignment: justified

Cmd+J

Format > Link

Cmd+K

Format > Transfer formatting (step copy)

Cmd+Shift+C

Format > Transfer formatting (step paste)

Cmd+Shift+V

Insert > Function

F7

Insert > Comment

Shift+F2

Insert current date

Cmd+. (period)

Insert current time

Cmd+Shift+. (period)
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Menu command

Keyboard shortcut

Hide current row

Cmd+9

Show current row

Cmd+Shift+9

Hide current column

Cmd+0

Show current column

Cmd+Shift+0

Worksheet > Insert cells

Cmd+Plus

Worksheet > Delete cells

Cmd+Minus

Tools > Recalculate

F9

Recalculate the current worksheet only

Shift+F9

Tools > Update charts

F8

Other useful keyboard shortcuts
Command

Keyboard shortcut

Expand or collapse the ribbon

Cmd+F1

Move to the next ribbon tab

Cmd+F12

Move to the previous ribbon tab

Cmd+Shift+F12

Move to the next worksheet
(with dialogs open: to the next tab)

Cmd+Tab

Move to the previous worksheet
(with dialogs open: to the previous tab)

Cmd+Shift+Tab

Index

#
#DIV/0! 411
#N/A 411, 499, 551, 553, 592
#NAME? 411
#NULL! 411
#NUM! 411
#REF! 411
#VALUE! 411

$
$ sign 407

%
% sign (operator) 404

3
3D effect
for chart frames 280
for objects 231

A
ABS (absolute value) 417
Absolute cell references 407
Absolute value (ABS) 417
Accounting (number format) 161
ACOS (arccosine) 417
ACOSH (inverse hyperbolic cosine) 418
ACOT (arccotangent) 418
ACOTH (inverse arccotangent) 419
Acquire (File) 239
Actual size (View) 378
Addition (operator) 404
ADDRESS (cell address as text) 420
Align or distribute (Objects) 225
Alignment
of cells 173
of text in AutoShapes 253
of text in text frames 237
All caps 178
Always show comments 372
Analyzing tables 90
AND (logical AND function) 421
ANSI code of a character (CODE) 449
Anti-aliasing 359
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Apply character formatting to entire words 356
Arabic script 345, 355
Arccosine (ACOS) 417
Arccotangent (ACOT) 418
Arcsine (ASIN) 422
Arctangent
ATAN 423
ATAN2 423
Area chart 257
AREAS (number of areas) 421
Array functions 412
Arrays
MDETERM (matrix determinant) 579
MINVERSE (inverse matrix) 583
MMULT (product of matrices) 584
MSOLVE (solution) 590
TRANSPOSE (transposed matrix) 679
working with array formulas 412
Asian scripts 355
ASIN (arcsine) 422
ASINH (inverse hyperbolic sine) 422
Associate files types 366
ATAN (arctangent) 423
ATAN2 (arctangent) 423
ATANH (inverse hyperbolic tangent) 424
Auto input mode 32
Auto recovery 364
Autocomplete cells 356
AutoFilter 84
AutoFormat 193
Automatic percent input 356
AutoShapes
adding text 251
drawing 249
properties 252
AutoSum 662
AVEDEV (average deviation) 425
Average
arithmetic mean (AVERAGE) 425
arithmetic mean (AVERAGEA) 426
AVERAGEIF 426
AVERAGEIFS 427
geometric mean (GEOMEAN) 522
harmonic mean (HARMEAN) 525
trimmed mean (TRIMMEAN) 681
AVERAGE (arithmetic mean) 425
Average deviation (AVEDEV) 425
Average square deviation (DEVSQ) 488
AVERAGEA (arithmetic mean) 426
AVERAGEIF (average if condition is true) 426

Index
AVERAGEIFS (average if conditions are true) 427
Axes (in charts) 271, 273, 274

B
B (Compatibility function) 429
Background color
of text 179
of the workspace 359
Backup copy 313, 364
BAK files 313
Banded rows and columns 113
Bar chart 257
BASE (convert decimal number to another base) 430
BasicMaker 348
Basics 34
Beep on errors 359, 363
Bessel 430, 431, 432
BESSELI (modified Bessel function In(x)) 430
BESSELJ (Bessel function Jn(x)) 431
BESSELK (modified Bessel function Kn(x)) 431
BESSELY (Bessel function Yn(x)) 432
Beta distribution
BETA.DIST 433
BETA.INV 434
BETADIST 432
BETAINV 434
BETA.DIST (beta distribution) 433
BETA.INV (percentiles of the beta distribution) 434
BETADIST (beta distribution) 432
BETAINV (percentiles of the beta distribution) 434
BIN2DEC (binary to decimal) 435
BIN2HEX (binary to hexadecimal) 436
BIN2OCT (binary to octal) 437
Binary to decimal (BIN2DEC) 435
Binary to hexadecimal (BIN2HEX) 436
Binary to octal (BIN2OCT) 437
BINOM.DIST (binomial distribution) 438
BINOM.DIST.RANGE (binomial distribution) 440
BINOM.INV (binomial distribution) 441
BINOMDIST (binomial distribution) 437
Binomial distribution
BINOM.DIST 438
BINOM.DIST.RANGE 440
BINOM.INV 441
BINOMDIST 437
CRITBINOM 469
NEGBINOM.DIST 595
NEGBINOMDIST 594
Bold 178
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Boolean (number format) 161
Borders 169
Box plot chart 257
Bring forward one level 235
Bring to front 235
Bubble chart 257

C
Calculation in status bar 356
Category axis (in charts) 271
CEILING (round up to a multiple of base) 441
Cell 173, 191
alignment 173
borders and lines 169
deleting 59
entering data 51
filling automatically 68
grouping (Outliner) 317
inserting 60
merging 173
number format 160, 161, 164
protection 332
rotating 173
selecting 54, 55
shading 172
size 157
sorting 81
CELL (information about a cell) 442
Cell address as text (ADDRESS) 420
Cell frame 35, 353
Cell marker 353
Cell styles 188
"Normal" 191
applying 188
creating 189
modifying 191
CHAR (character from ANSI code) 443
Character 176, 177, 178, 179, 180, 181
Character from ANSI code (CHAR ) 443
Character pitch 180
Character styles 185, 186, 187
Chart area (in charts) 264
Chart toolbar 256
Chart type 257
Charts 255, 261
add trendline 270
arrangement of data series 261, 278
change chart location 282
chart elements 262
chart type 257
data in columns 261

Index
Charts 255, 261
data in rows 261
editing 256
inserting 256
properties 277
save as image 282
show grid lines 275
updating 281
Check for updates 366
Check spelling 299
Check spelling as you type 301, 363
Checkbox (form object) 288
CHIDIST (chi-square distribution) 444
CHIINV (percentiles of the chi-square
distribution) 445
CHISQ.DIST.RT (chi-square distribution) 445
CHISQ.INV.RT (percentiles of the chi-square
distribution) 446
CHISQ.TEST (chi-square test) 447
Chi-square distribution
CHIDIST 444
CHIINV 445
CHISQ.DIST.RT 445
CHISQ.INV.RT 446
Chi-square test
CHISQ.TEST 447
CHITEST 447
CHITEST (chi-square test) 447
CHOICE (x>0, x=0, x&lt;0?) 448
CHOOSE (choose value from list) 448
Circles
drawing 249
properties 252
Circular reference 32, 374
Classic menus and toolbars 359
CLEAN (remove unprintable characters) 449
Close (File) 350
Close all (Window) 350
Close tabs 350
CODE (ANSI code of a character) 449
Color
of cells 172
of objects 227
of text 179
of the workspace 359
Color gradient (for objects) 227
Color palette, modifying 370
Column
deleting 59
hiding 159
inserting 60
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optimum width 158
selecting 55
showing 159
width 157, 158
COLUMN (column number of a reference) 450
Column chart 257
Column headers 55
changing the width of columns 158
printing 208
showing/hiding 377
Column number of a reference (COLUMN) 450
COLUMNS (number of columns in a range) 451
COMBIN (combinations) 451
Combinations (COMBIN) 451
Comment, insert 98
Compare texts (EXACT) 502
Compatibility (document properties) 372
COMPLEX (create complex number) 452
Complex numbers
absolute value (IMABS) 535
angle (IMARGUMENT) 536
COMPLEX (build complex number) 452
conjugate (IMCONJUGATE) 537
cosine (IMCOS) 537
difference (IMSUB) 544
division (IMDIV) 538
exponential (IMEXP) 538
imaginary coefficient (IMAGINARY) 536
logarithm, base 10 (IMLOG10 ) 539
logarithm, base 2 (IMLOG2 ) 540
logarithm, natural (IMLN ) 539
negative value (IMNEG) 540
power (IMPOWER) 541
product (IMPRODUCT) 542
real coefficient (IMREAL) 542
sine (IMSIN) 543
square root (IMSQRT) 543
sum (IMSUM) 544
Complex scripts 355
Compress pictures in memory 366
CONCATENATE (concatenate text strings) 453
Concatenation (operator) 404
Condition
CHOICE 448
IF 534
Conditional formatting 194
Delete rules in selected cells 200
Manage rules 198
New rule 195
Cone chart 257
CONFIDENCE (confidence interval) 453
Confidence interval
CONFIDENCE 453

Index
Confidence interval
CONFIDENCE.NORM 454
CONFIDENCE.NORM (confidence interval) 454
Connectors
drawing 249
properties 252
Consolidating data 104
Context menu 28
CONVERT (unit conversion) 455
Convert decimal number to another base (BASE) 430
Convert EU currencies (EUROCONVERT) 500
Copy 62
Copy to document’s folder (pictures) 239
Corners (in charts) 266
CORREL (correlation coefficient) 458
Correlation coefficient
CORREL 458
PEARSON 610
RSQ 641
COS (cosine) 459
COSH (hyperbolic cosine) 460
Cosine (COS) 459
COT (cotangent) 460
Cotangent (COT) 460
COTH (hyperbolic cotangent) 461
Count
COUNT 461
COUNTA 462
COUNTBLANK 463
COUNTIF 463
COUNTIFS 464
COUNT (number of cells filled with numbers) 461
COUNTA (number of cells filled) 462
COUNTBLANK (number of empty cells) 463
COUNTIF (count if condition is true) 463
COUNTIFS (count if conditions are true) 464
COUNTP (PlanMaker 97 compatibility function) 465
COVAR (Covariance population) 466
Covariance
COVAR (population) 466
COVARIANCE.P (population) 467
COVARIANCE.S (sample) 468
COVARIANCE.P (Covariance population) 467
COVARIANCE.S (Covariance sample) 468
CREATEDATE (date the document was created) 469
Creation date 210
CRITBINOM (binomial distribution) 469
Cropping (of pictures) 240, 242
CSV file format 340
CUMIPMT (cumulative interest) 470
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CUMPRINC (cumulative principal) 471
CURRENCY (format number as currency) 472
Currency (number format) 161
Curves
drawing 249
properties 252
Custom (number format) 161
Customize
creating user-defined icons 395
customizing keyboard shortcuts 396
customizing ribbons 388
customizing toolbars 380, 384
Cut 62
Cylinder chart 257

D
Data consolidation 104, 105, 107, 108
Data points (in charts) 267
Data series (in charts) 267, 278, 279
Data source (of charts) 278, 279
Database functions 414
DAVERAGE 475
DCOUNT 481
DCOUNTA 481
DGET 489
DMAX 490
DMIN 490
DPRODUCT 492
DSTDEV 493
DSTDEVP 493
DSUM 494
DVAR 494
DVARP 495
Date
create a date value (DATE) 473
current (NOW) 603
current (TODAY) 678
entering 51
DATE (create a date value) 473
Date before/after n months (EDATE) 496
Date difference (DATEDIF) 473
Date filters (AutoFilter) 84
Date of last change 210
Date the document was created (CREATEDATE) 469
Date/Time (number format) 161
DATEDIF (date difference) 473
DATEVALUE (convert text into date value) 474
DAVERAGE (database function) 475
DAY (day of a date) 475
DAYS (days between two dates) 476

Index
DAYS360 (days between two dates) 477
DAYSP (compatibility function) 478
DAYSPERMONTH (days per month) 479
DAYSPERYEAR (days per year) 479
DB (fixed-declining balance depreciation) 480
dBase file format 339
DCOUNT (database function) 481
DCOUNTA (database function) 481
DDB (double-declining balance depreciation) 482
DEC2BIN (decimal to binary) 483
DEC2HEX (decimal to hexadecimal) 484
DEC2OCT (decimal to octal) 484
DECIBEL (decibel value of two quantities) 485
DECIMAL (convert number from any base
into decimal) 486
Decimal point after input 372
Decimal to binary (DEC2BIN) 483
Decimal to hexadecimal (DEC2HEX) 484
Decimal to octal (DEC2OCT) 484
DECIMALS (fractional part of a number) 487
Default (number format) 161
Default currency 372
Default file format 364
Default font 187
DEGREES (convert radians to degrees) 487
Degrees to radians (RADIANS) 629
Delete 36, 57, 58
cell contents 58
cells 59
duplicate rows 60
empty rows 60
special 58
DELTA (test for equality) 488
Depreciation
double-declining balance (DDB) 482
fixed-declining balance (DB) 480
straight-line (SLN) 648
sum-of-years’ digits (SYD) 668
Design Science 247
DEVSQ (average square deviation) 488
DGET (database function) 489
Dialog language 359
Dictionaries, installing (for spell checking) 400
Disable sheet protection 334
Disable workbook protection 335
Display the formula a cell contains
(FORMULATEXT) 513
Distance to edge 207
Division (operator) 404
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DMAX (database function) 490
DMIN (database function) 490
Document properties 369
Calculate tab 374
Colors tab 370
Fonts tab 377
Options tab 372
Protection tab 376
Statistics tab 372
Summary tab 370
Document protection 335
Document scaling 359
Document statistics 372
Document summary
entering 309
Document tabs 31, 349, 350
Document templates 192, 193
Document window 349
DOLLARDE (dollar price, decimal) 491
DOLLARFR (dollar price, fraction) 491
Double factorial (FACTDOUBLE) 505
Double-declining balance depreciation (DDB) 482
Doughnut chart 257
DPRODUCT (database function) 492
Drag and Drop 62
Drawings 248
inserting 249
properties 252
rotating 225
Dropdown (form object) 291
DSTDEV (database function) 493
DSTDEVP (database function) 493
DSUM (database function) 494
Duplicate 226
DVAR (database function) 494
DVARP (database function) 495

E
EDATE (date before/after n months) 496
Edit > Copy 62
Edit > Cut 62
Edit > Delete 36, 58
Edit > Delete special 58
Edit > Duplicate 226
Edit > Fill 68
Edit > Go to 218
Edit > Go to link 320
Edit > Link 245
Edit > Paste 62

Index
Edit > Paste special 64
Edit > Redo 37
Edit > Repeat 54
Edit > Replace 216
Edit > Replace again 216
Edit > Search 215, 216
Edit > Search again 216
Edit > Select all 55
Edit > Undo 37
Edit lists 398
Edit mode 222
Edit script 348
Edit toolbar 29
Edit user dictionaries 301
EFFECT (effective interest rate) 496
Effective interest rate (EFFECT) 496
Effects (for objects) 231
Ellipses
drawing 249
properties 252
E-mailing a document 331
Encryption 335
Entering data in cells 51
EOMONTH (end of month in n months) 497
Equality (DELTA) 488
Equation Editor 247
ERF (Gaussian error function) 498
ERFC (complement of Gaussian error function) 498
Error bars (in charts) 267
Error function
ERF 498
ERFC (complement) 498
Error type (ERROR.TYPE) 499
Error values 96, 411, 551
ERROR.TYPE (error type) 499
EUROCONVERT (convert EU currencies) 500
EVEN (round up to next even number) 501
EXACT (compare texts) 502
Excel file format 287, 339, 342, 344
Exclusive or 698
Exit (File) 40
EXP (power of e) 502
Expand SmartText entries 356
Expand tables automatically 356
EXPON.DIST (exponential distribution) 504
EXPONDIST (exponential distribution) 503
Exponential distribution
EXPON.DIST 504
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EXPONDIST 503
Exponential regression
statistics (LOGEST) 569
values (GROWTH) 525
Exponentiation
operator 404
POWER function 621
Export as PDF 327
Exporting documents 339
Extended support for Arabic text 345, 355
Extended support for Asian fonts 355
External cell references 408
External references
entering 408
managing 409
updating 409

F
F distribution
F.DIST.RT 507
F.INV.RT 509
FDIST 506
FINV 509
F.DIST.RT (F distribution) 507
F.INV.RT (percentiles of the F distribution) 509
F.TEST (F-test) 515
FACT (factorial) 504
FACTDOUBLE (double factorial) 505
Factorial
FACT 504
FACTDOUBLE 505
FALSE (logical value FALSE) 506
FDIST (F distribution) 506
Fields (in headers/footers) 210
File > Acquire 239
File > Close 350
File > Exit 40
File > Export as PDF 327
File > File manager 309
File > New 37, 192
File > Open 38, 193, 339
File > Page setup 206, 207, 208, 210
File > Print 39, 324
File > Print preview 323
File > Print range
Define print range 208
Remove print range 208
File > Properties 369
Calculate tab 374
Colors tab 370

Index
File > Properties 369
Fonts tab 377
Options tab 372
Protection tab 336, 376
Statistics tab 372
Summary tab 309, 370
File > Revert to previous version 313
File > Save 40
File > Save all 40
File > Save as 40, 339
File > Select source 239
File > Send 331
File format 339
File manager 309
FILENAME (file name of the document) 507
Filling 68
cells 172
objects 227
Filters 84, 660
AutoFilter 84
Special filter 88
FIND (search for text) 508
FINV (percentiles of the F distribution) 509
First column (emphasized) 113
FISHER (Fisher transformation) 510
Fisher transformation
FISHER 510
FISHERINV 511
FISHERINV (Inverse of the Fisher
transformation) 511
FIXED (format number as text with
fixed decimals) 511
Fixed-declining balance depreciation (DB) 480
Flipping objects 225
Floor (in charts) 266
FLOOR (round down to a multiple of base) 512
Font 176, 177
Font size 176, 177
Footers 210
FORECAST (forecast using linear regression) 513
Format > AutoFormat 193
Format > Borders 169
Format > Cell
Alignment tab 173
Borders tab 169
Number format tab 160, 161, 164
Protection tab 332
Shading tab 172
Format > Cell style 188, 189, 191
Format > Character 176, 177, 178, 179, 180, 181
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Format > Character style 185, 186, 187
Format > Conditional formatting 194
Delete rules in selected cells 200
Manage rules 198
New rule 195
Format > Input validation 96, 201
Format > Link 320
Format > Paragraph 182, 184, 302
Format > Remove link 320
Format > Shading 172
Format > Standard 181
Format > Transfer formatting 206
Formatting toolbar 29, 177, 178
Forms 284
Forms toolbar 285
Formula auditing 93, 94, 95, 96
Formula auditing toolbar 93
Formula tooltips 356
FORMULATEXT (display the formula a cell
contains) 513
Fraction (number format) 161
Freehand forms
drawing 249
properties 252
Freeze (View) 152
FREQUENCY (frequency) 514
F-test
F.TEST 515
FTEST (F-test) 515
F-test (FTEST) 515
Full screen (View) 379
Full screen view 379
Functions
functions from A to Z 416
inserting 405
Future value
FV 516
FVSCHEDULE 517
FV (future value) 516
FVSCHEDULE (future value) 517

G
GAMMA (gamma function) 517
Gamma distribution
GAMMA.DIST 518
GAMMA.INV 520
GAMMADIST 518
GAMMAINV 519
Gamma function

Index
Gamma function
GAMMA 517
GAMMALN 521
GAMMA.DIST (gamma distribution) 518
GAMMA.INV (percentiles of the gamma
distribution) 520
GAMMADIST (gamma distribution) 518
GAMMAINV (percentiles of the gamma
distribution) 519
GAMMALN (logarithm of the gamma function) 521
GAUSS (standard normal distribution) 521
Gaussian distribution (NORM.DIST) 598
Gaussian distribution (NORMDIST) 597
Gaussian error function
ERF 498
ERFC (complement) 498
GCD (greatest common divisor) 522
GEOMEAN (geometric mean) 522
Geometric mean (GEOMEAN) 522
GESTEP (greater or equal to threshold value?) 523
GETPIVOTDATA 523
Glow effect (for objects) 231
Go to 218
Go to link 320
Goal seek 99
Gradient (color gradient) 227
Greatest common divisor (GCD) 522
Gridlines
between table cells 377
in charts 275
Groupbox (form object) 296
Grouping 317
cells (Outliner) 317
objects 235
showing/hiding grouped cells 317
GROWTH (values of an exponential regression) 525
Guidelines for text frames 372

H
HARMEAN (harmonic mean) 525
Harmonic mean (HARMEAN) 525
Header and footer 210
Headers 210
Height of a row 157
HEX2BIN (hexadecimal to binary) 526
HEX2DEC (hexadecimal to decimal) 527
HEX2OCT (hexadecimal to octal) 527
Hexadecimal
to binary (HEX2BIN) 526
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to decimal (HEX2DEC) 527
to octal (HEX2OCT) 527
Hiding
cells 159
cells, using sheet protection 332
cells, using the outliner 316
objects 234
High-Low chart 257
HLOOKUP (look up row-wise) 528
HOLIDAY (dates of movable Christian holidays) 529
Horizontal alignment of cells 173
HOUR (hour) 530
HTML documents 322
Hunspell dictionaries 363, 400
Hyperbolic cosine (COSH) 460
Hyperbolic cotangent (COTH) 461
Hyperbolic sine (SINH) 647
Hyperbolic tangent (TANH) 670
Hypergeometric distribution
HYPGEOM.DIST 533
HYPGEOMDIST 532
HYPERLINK (hyperlink) 530
Hyperlinks
applied to cells 320
applied to objects 232
HYPERLINK function 530
HYPGEOM.DIST (hypergeometric distribution) 533
HYPGEOMDIST (hypergeometric distribution) 532
Hyphenation 302
in table cells 303
in text frames 302
language selection 298

I
IF (if-then-else condition) 534
IFERROR (return a value on errors) 534
Ignore words that start with a number 363
IMABS (absolute value of a complex number) 535
IMAGINARY (imaginary coefficient of a
complex number) 536
IMARGUMENT (angle of a complex number) 536
IMCONJUGATE (conjugate complex number) 537
IMCOS (cosine of a complex number) 537
IMDIV (division of complex numbers) 538
IMEXP (exponential of a complex number) 538
IMLN (natural logarithm of a complex number) 539
IMLOG10 (base-10 logarithm of a complex
number) 539
IMLOG2 (base-2 logarithm of a complex number) 540

Index
IMNEG (negative value of a complex number) 540
Importing documents 339
IMPOWER (power of a complex number) 541
IMPRODUCT (product of complex numbers) 542
IMREAL (real coefficient of a complex number) 542
IMSIN (sine of a complex number) 543
IMSQRT (square root of a complex number) 543
IMSUB (difference of complex numbers) 544
IMSUM (sum of complex numbers) 544
In-cell editing 356
Indents 182
INDEX (cell in a particular row/column) 545
INDIRECT (create reference from text) 546
Information about a cell (CELL) 442
Inner margins
of AutoShapes 253
of cells 173
of text frames 237
Input validation 96, 201
Insert > Comment 98
Insert > Function 405
Insert > Header and footer 210
Insert > Page break 214
Insert > SmartText 305, 306
Insert > Symbol 153
Insert frames and drawings immediately 356
Inserting
cells 60
columns 60
copied cells 61
rows 60
Installation 24
Android 26
Linux 26
macOS 25
Windows 24
INT (round down to nearest integer) 546
INTERCEPT (intercept point of a linear trend) 547
Interest for fixed-interest investments (PCF) 640
Interest for fixed-interest investments (RRI) 640
Interest payment
IPMT 548
ISPMT 559
Interest, cumulative (CUMIPMT) 470
Internal rate of return
IRR 549
MIRR 584
XIRR 696
Internet
HTML documents 322
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links 320
Intersection
INTERSECTION function 548
intersection operator 404
INTERSECTION (intersection of two ranges) 548
Inverse arccotangent (ACOTH) 419
Inverse hyperbolic cosine (ACOSH) 418
Inverse hyperbolic sine (ASINH) 422
Inverse hyperbolic tangent (ATANH) 424
Inverse matrix (MINVERSE) 583
IPMT (interest payment) 548
IRR (internal rate of return) 549
ISBLANK (is empty?) 550
ISERR (is an error value except #N/A?) 411, 551
ISERROR (is an error value?) 411, 551
ISEVEN (is an even number?) 552
ISFORMULA (is a formula?) 552
ISLOGICAL (is a logical value?) 553
ISNA (is not available?) 553
ISNONTEXT (is no text?) 554
ISNUMBER (is numeric?) 555
ISNUMBERP (PlanMaker 97 compatibility
function) 555
ISODD (is an odd number?) 556
ISOWEEK (ISO week number) 557
ISOWEEKNUM (ISO week number) 558
ISPMT (interest payment) 559
ISREF (is a valid reference?) 559
ISTEXT (is text?) 560
Italic 178
Iterations 374

K
Keep aspect ratio 226
Keep scaling 226
Kerning 181
Keyboard shortcuts
customizing 396
default keyboard shortcuts 714
default keyboard shortcuts:Mac 718
default keyboard shortcuts:Windows/Linux 714
for cell styles 189
for character styles 185, 186
for special characters 153
Keyboard, show/hide automatically 366
KURT (kurtosis) 560
Kurtosis (KURT) 560

Index

L
Label (form object) 296
Language
for spell checking and hyphenation 298, 363
user interface 359
LARGE (k-th largest number) 561
Last column (emphasized) 113
LASTPRINTED (date last printed) 562
LASTSAVED (date last saved) 563
LCM (least common multiple) 563
Least common multiple (LCM) 563
LEFT (left part of a text string) 564
Left arrow key never exists cell editing 356
Legend (in charts) 276
LEN (length) 564
Length (LEN) 564
Letter spacing 180
Limit internal picture cache 366
Line chart 257
Line spacing 182
Linear regression
FORECAST 513
intercept point (INTERCEPT) 547
statistics (LINEST) 565
trend lines in charts 270
values (TREND) 680
Lines
drawing 249
of objects 229
properties 252
LINEST (statistics of a linear regression) 565
Links
applied to cells 320
applied to objects 232
HYPERLINK function 530
OLE objects 245
Listbox (form object) 292
Live preview 359
LN (natural logarithm) 567
LOG (logarithm) 567
LOG10 (base-10 logarithm) 568
Logarithm
any base (LOG) 567
base 10 (LOG10) 568
natural (LN) 567
LOGEST (statistics of an exponential regression) 569
LOGINV (percentiles of the gamma distribution) 570
LOGNORM.DIST (lognormal distribution) 572
LOGNORM.INV (percentiles of the gamma
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distribution) 572
Lognormal distribution
LOGINV 570
LOGNORM.DIST 572
LOGNORM.INV 572
LOGNORMDIST 571
LOGNORMDIST (lognormal distribution) 571
LOOKUP (search cell range) 573
LOWER (convert text to lower case) 576
Lower case
LOWER 576
PROPER 624

M
Macros 287, 344
Manual 22
Margins
inner margins of AutoShapes 253
inner margins of cells 173
inner margins of text frames 237
page margins 207
MATCH (relative position in a range) 576
MathType 247
Matrix
MDETERM (determinant) 579
MINVERSE (inverse) 583
MMULT (product of matrices) 584
MSOLVE (solution) 590
TRANSPOSE (transposed matrix) 679
working with array formulas 412
MAX (maximum) 577
MAXA (maximum) 578
Maximum
MAX 577
MAXA 578
Maximum number of undo steps 355
MDETERM (matrix determinant) 579
Mean
arithmetic (AVERAGE) 425
arithmetic (AVERAGEA) 426
geometric (GEOMEAN) 522
harmonic (HARMEAN) 525
ignoring marginal values (TRIMMEAN) 681
Measurement 359
MEDIAN 579
Menu bar 28
Menus/toolbars or ribbon? 359
Merge cells 173
MID (part of a text string) 580
Middle mouse button 356
MILLISECONDS (milliseconds) 580

Index
MIN (minimum) 581
MINA (minimum) 582
Minimum
MIN 581
MINA 582
MINUTE (minute) 582
MINVERSE (inverse matrix) 583
MIRR (modified internal rate of return) 584
Mirror effect (for objects) 231
MMULT (product of matrices) 584
MOD (remainder of a division, Excel method) 585
MODE (most frequently occurring value) 586
MODE.SNGL (most frequently occurring value) 587
MODP (remainder of a division, PlanMaker
method) 588
MONTH (month of a date) 589
Move by ... decimals 372
Move selection after input 356
MROUND (round to a multiple of base) 589
MSOLVE (solution of matrix equation Ax=B) 590
MULTINOMIAL (multinomial coefficient) 591
Multinomial coefficient
MULTINOMIAL 591
POLYNOMIAL 621
Multiplication (operator) 404

N
N (convert value into number) 592
NA (error value #N/A) 592
Name of a worksheet (SHEETNAME) 644
Named ranges 79
Names (cell ranges) 76, 79
Apply 80
Edit 76
Import 78
Insert list 78
NEG (negative value) 593
Negation
NEG function 593
operator 404
Negative binomial distribution
NEGBINOM.DIST 595
NEGBINOMDIST 594
NEGBINOM.DIST (negative binomial
distribution) 595
NEGBINOMDIST (negative binomial
distribution) 594
Net present value
NPV 605, 697
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NETWORKDAYS (number of workdays) 596
Neumann function (BESSELY) 432
New (File) 37, 192
New chart frame 256
New drawing 249
New form object 285
Checkbox 288
Dropdown 291
Groupbox 296
Label 296
Listbox 292
Pushbutton 293
Radio button 289
Scrollbar 295
Spinner 294
New OLE object frame 243
New picture frame 239
New picture frame from the gallery/camera 240
New pivot table 120
New table (Tables in worksheets) 109, 110
New text frame 236
NOMINAL (nominal interest rate) 596
Nominal interest rate (NOMINAL) 596
NORM.DIST (normal distribution) 598
NORM.INV (percentiles of the normal
distribution) 599
NORM.S.DIST (standard normal distribution) 601
NORM.S.INV (percentiles of the standard
distribution) 602
Normal distribution
NORM.DIST 598
NORM.INV 599
NORMDIST 597
NORMINV 599
Normal distribution, logarithmic
LOGINV 570
LOGNORM.DIST 572
LOGNORM.INV 572
LOGNORMDIST 571
Normal.pmvx 193
NORMDIST (normal distribution) 597
NORMINV (percentiles of the normal
distribution) 599
NORMSDIST (standard normal distribution) 600
NORMSINV (percentiles of the standard
distribution) 601
NOT (logical NOT function) 603
NOW (current date and time) 603
NPER (number of periods) 604
NPV (net present value) 605, 697
Number (number format) 161

Index
Number filters (AutoFilter) 84
Number format 160, 164, 165
Number of pages 210
Number of periods (NPER) 604
Number separators 356
Numbers
entering 51
formatting 160

O
Object > Align or distribute 225
Object > Chart
Add trendline 270
Change chart location 282
Data in columns 261
Data in rows 261
Save as image 282
Show grid lines 275
Object > Group 235
Object > New chart frame 256
Object > New drawing 249
Object > New form object 285
Checkbox 288
Dropdown 291
Groupbox 296
Label 296
Listbox 292
Pushbutton 293
Radio button 289
Scrollbar 295
Spinner 294
Object > New OLE object frame 243
Object > New picture frame 239
Object > New picture frame from gallery/camera 240
Object > New text frame 236
Object > Order 235
Object > Properties
changing default settings 233
for chart frames 277
for checkboxes 288
for drawings 252
for dropdowns 291
for groupboxes 297
for labels 297
for listboxes 292
for OLE object frames 246
for picture frames 240
for pushbuttons 293
for radio buttons 290
for scrollbars 295
for spinners 294
for text frames 237
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general properties 226
Object > Rotate or flip 225
Object > Ungroup 235
Object mode 222
Object toolbar 222
Objects 221
aligning and distributing 225
changing default settings 233
duplicating 226
flipping 225
grouping 235
hiding 234
inserting 222
order 235
position 224
properties 226
rotating 225, 226
selecting 222
size 224
OCT2BIN (octal to binary) 605
OCT2DEC (octal to decimal ) 606
OCT2HEX (octal to hexadecimal) 607
Octal to binary (OCT2BIN) 605
Octal to decimal (OCT2DEC) 606
Octal to hexadecimal (OCT2HEX) 607
ODD (round up to next odd number) 608
OFFSET (shifted reference) 608
OLE objects 243
editing 245
inserting 243
links 245
properties 246
Open (File) 38, 193, 339
OpenGL 366
Operators in formulas 404
Optimum height 158
Optimum width 158
Options (PlanMaker) 353
Appearance tab 359
Edit tab 356
Files tab 364
Fonts tab 369
General tab 355
Language tab 363
System tab 366
View tab 353
OR (logical OR function) 609
Order (of objects) 235
Orientation 207
Outline pane 316, 319
Outline toolbar 316
Outliner 316, 317, 318, 319

Index
Outliner 316, 317, 318, 319
automatically show outline pane 318, 319
clear outline 317
grouping cells 317
options 319
protecting outline 319
showing/hiding grouped cells 318
ungroup 317
Overlapping objects 237, 253

P
Page breaks 214
inserting and deleting 214
showing/hiding 377
Page margins 207
Page number 208, 210
Page setup 206, 207, 208, 210
copy to other worksheets 74
Paper bins 207
Paper size 207
Paragraph 182, 184, 302
Pascal distribution
NEGBINOM.DIST 595
NEGBINOMDIST 594
Paste 62
Paste special 64
Payment (PMT) 618
Payment on the principal (PPMT) 622
PCF (interest for fixed-interest investments) 640
PDF export 327
PEARSON (Pearson correlation coefficient) 610
Percent (operator) 404
Percentage (number format) 161
PERCENTILE (percentiles of a data set) 611
PERCENTILE.EXC (percentiles of a data set) 611
PERCENTILE.INC (percentiles of a data set) 612
PERCENTRANK (percent rank in a data set) 613
PERCENTRANK.EXC (percent rank in a data set) 614
PERCENTRANK.INC (percent rank in a data set) 615
PERIOD (duration of fixed-interest investments) 616
PERMUT (permutations) 617
Permutations (PERMUT) 617
PHI (standard normal distribution) 617
PI (pi) 618
Pictures 238
inserting 239
properties 240
rotating 225
scanning 239
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Pie chart 257
Pivot tables 118
changing the source data area 148
column labels 124
copying 150
creating from external data 122
creating from tables in worksheets 120
creating with existing data 121
custom name for fields 130, 131, 135, 140
custom name for pivot table 142
defer layout update 145
deleting 150
field list: areas section 131
field list: configuring the pivot table 134
field list: exercises 125
field list: fields section 130
field list: further options 133
field list: starting screen 124
field settings 135
fields: moving & removing 131
filter labels/filter values 146
filtering 146
form (field settings) 135
GETPIVOTDATA 523
layout (pivot table settings) 142
modifying pivot table areas 148
moving 150
number format 140
outline form 135
pivot table settings 142
refresh when opening the file 142, 148
report filter 124, 146
row labels 124
save source data with file 142
sort A-Z (fields in the field list) 130
sort A-Z (fields in the pivot report) 146
styles for pivot tables 142
subtotals 135
tabular form 135
updating 148
value settings 140
values area 124
PlanMaker file format 339
PlanMaker Tour 41
Plot area (in charts) 264
PMBAK files 313
PMD file format 339
PMDX file format 339
PMT (payment) 618
POISSON (Poisson distribution) 619
Poisson distribution
POISSON 619
POISSON.DIST 620
POISSON.DIST (Poisson distribution) 620

Index
POLYNOMIAL (polynomial coefficient) 621
Polynomial coefficient
MULTINOMIAL 591
POLYNOMIAL 621
Position
of objects 224
Position in a range (MATCH) 576
POWER (power) 621
PPMT (payment on the principal) 622
Precision as displayed (Rounding) 374
Present value (PV) 625
Preview (of files) 38
Primary axes (in charts) 280
Principal, cumulative (CUMPRINC) 471
Print 39, 324
Print date 210
Print order 208
Print preview 323
Print range 208
Define print range 208
Remove print range 208
Print time 210
PROB (probability) 623
Probability (PROB) 623
PRODUCT (product) 623
Product of matrices (MMULT) 584
Prompt for summary information when saving 364
PROPER (convert text to upper/lower case) 624
Properties
Calculate tab 374
Properties (File menu) 369
Colors tab 370
Fonts tab 377
Options tab 372
Protection tab 336, 376
Statistics tab 372
Summary tab 309, 370
Properties (Object menu)
changing default settings 233
for chart frames 277
for checkboxes 288
for drawings 252
for dropdowns 291
for groupboxes 297
for labels 297
for listboxes 292
for OLE object frames 246
for picture frames 240
for pushbuttons 293
for radio buttons 290
for scrollbars 295
for spinners 294
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for text frames 237
general properties 226
Properties (Worksheet menu) 74, 377
Protecting
documents 335
outline 319
workbooks 334
worksheets 332
Protection indicator 372
Pushbutton (form object) 293
PV (present value) 625
Pyramid chart 257

Q
QUARTILE (quartiles of a data set) 625
QUARTILE.EXC (quartiles of a data set) 626
QUARTILE.INC (quartiles of a data set) 627
Quick Access Toolbar 30, 359, 390, 394
Quick paths 307
QUOTIENT (quotient of a division) 628

R
Radar chart 257, 281
RADIANS (convert degrees to radians) 629
Radians to degrees (DEGREES) 487
Radio button (form object) 289
RAND (random value) 629
RANDBETWEEN (random value) 630
Random value
RAND 629
RANDBETWEEN 630
Rank
PERCENTRANK 613
PERCENTRANK.EXC 614
PERCENTRANK.INC 615
RANK 630
RANK.AVG 631
RANK.EQ 632
RANK (rank in a data set) 630
RANK.AVG (rank in a data set) 631
RANK.EQ (rank in a data set) 632
RATE (rate per period) 633
Rate per period (RATE) 633
Recalc automatically 374
Recalc only before ... 374
Recalculate 97, 374
Rectangles
drawing 249
properties 252

Index
Redo (Changes) 37
Reflection effect (for objects) 231
Regression, exponential
statistics (LOGEST) 569
values (GROWTH) 525
Regression, linear
statistics (LINEST) 565
values (TREND) 680
Relative cell references 407
Remainder of a division
MOD (Excel method) 585
MODP (PlanMaker method) 588
Remove
Duplicate rows 60
Empty rows 60
Remove link 320
Repeat (Command) 54
Repeat text string (REPT) 635
Repeated columns 208
Repeated rows 208
Replace 216
REPLACE (replace text in a text string) 634
Replace again 216
Replace text in a text string
REPLACE 634
SUBSTITUTE 660
REPT (repeat text string) 635
Revert to previous version (File) 313
Ribbon 21, 30, 359
customizing 388
Ribbon commands and corresponding menu
commands 701
Ribbon or menus with toolbars? 359
RIGHT (right part of a text string) 635
ROMAN (Roman numeral) 636
Root
n-th root (ROOTN) 636
square root (SQRT) 653
square root of x*Pi (SQRTPI) 653
ROOTN (n-th root) 636
Rotate or flip (Objects) 225
Rotating
axis labels 271, 273, 274
cells 173
objects 225, 226
text in AutoShapes 253
text in text frames 237
ROUND (round) 637
ROUNDDOWN (round down) 638
Rounding
displaying numbers rounded 160
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final result 374
intermediate results 374
precision as displayed 374
Rounding (functions)
CEILING 441
EVEN 501
FIXED 511
FLOOR 512
INT 546
MROUND 589
ODD 608
ROUND 637
ROUNDDOWN 638
ROUNDUP 638
TRUNC 682
ROUNDUP (round up) 638
Row
deleting 59, 60
height 157, 158
hiding 159
inserting 60
optimum height 158
selecting 55
showing 159
Row & column headers 377
ROW (row number of a reference) 639
Row headers 55
changing the height of rows 158
printing 208
showing/hiding 377
Row number of a reference (ROW) 639
ROWS (number of rows in a range) 640
RRI (interest for fixed-interest investments) 640
RSQ (square of Pearson) 641

S
Save (File) 40
Save all (File) 40
Save as (File) 40, 339
Save within document (pictures) 239
Scaling 208
Scanning pictures 239
Scenarios 100
Scientific (number format) 161
Scripts 287, 344, 348
Scrollbar (form object) 295
Scrollbars 372
Search 215, 216
SEARCH (search for text) 642
Searching
files 311

Index
Searching
FIND function 508
HLOOKUP function 528
in cells 215
LOOKUP function 573
SEARCH function 642
VLOOKUP function 692
SECOND (second) 642
Secondary axes (in charts) 279, 280
Select all 55
Select source (File) 239
Selecting
cells 54
objects 222
Send backward one level 235
Send to back 235
Sending a document by e-mail 331
Series axis (in charts) 274
SERIESSUM (sum of a power series) 643
Settings 352
Shades 172
Shading 172
Shadow (of objects) 230
SHEET (index of a worksheet) 643
Sheet protection 332, 333
Sheet tabs 372
SHEETNAME (compatibility function) 645
SHEETNAME (name of a worksheet) 644
SHM extensions 366
Show fonts in font list 359
Show formulas (View) 90
Show hidden files and folders 366
Show hidden objects 372
Show indicators (for comments) 372
Show tooltips 359
Show warning when loading OLE objects 355
Sign (operator) 404
SIGN (sign of a number) 646
SIN (sine) 646
Sine (SIN) 646
SINH (hyperbolic sine) 647
Size
of cells 157
of objects 224
SKEW (skewness of a distribution) 647
Skewness of a distribution (SKEW) 647
SLN (straight-line depreciation) 648
SLOPE (slope of a linear trend) 649
SMALL (k-th smallest number) 649
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Small caps 178
SmartText 304, 305, 306
Smooth edges of pictures 366
Smooth edges of screen fonts 359
Soft edges effect (for objects) 231
SoftMaker 22
SoftMaker Basic 348
SoftMaker Equation Editor 247
Solution of matrix equation (MSOLVE) 590
Sort
cells 81
SORTM function 650
SORTV function 651
SORTM (sort) 650
SORTV (sort) 651
Special characters 153
Special filter 88
Spell checking 298
as you type 301, 363
installing additional dictionaries 400
language selection 298, 363
manually 299
user dictionaries 301
Spinner (form object) 294
SQRT (square root) 653
SQRTPI (square root of x*Pi) 653
Square root (SQRT) 653
Standard (Format menu) 181
Standard deviation
entire population (STDEV.P) 657
entire population (STDEVP) 656
entire population (STDEVPA) 657
sample (STDEV) 654
sample (STDEV.S) 659
sample (STDEVA) 655
Standard error of a linear regression (STEYX) 658
Standard normal distribution
NORM.S.DIST 601
NORM.S.INV 602
NORMSDIST 600
NORMSINV 601
Standard toolbar 28
STANDARDIZE (standardized value) 654
Start script 348
Statistics 372
Statistics of a regression
LINEST (linear) 565
LOGEST (exponential) 569
Status bar 32
displaying/hiding 359
STDEV (standard deviation of a sample) 654

Index
STDEV.P (standard deviation of entire
population) 657
STDEV.S (standard deviation of a sample) 659
STDEVA (standard deviation of a sample) 655
STDEVP (standard deviation of entire population) 656
STDEVPA (standard deviation of entire
population) 657
STEYX (standard error of a linear regression) 658
Stock chart 257
Straight-line depreciation (SLN) 648
Strike out 178
Student’s t-distribution
T.DIST 671
T.DIST.2T (two-tailed) 672
T.DIST.RT (right-tailed) 673
T.INV (left-tailed) 677
T.INV.2T (two-tailed) 678
TDIST 671
TINV 676
Student’s t-test (T.TEST) 684
Student’s t-test (TTEST) 683
Subscript 180
SUBSTITUTE (replace text in a text string) 660
SUBTOTAL (calculations ignoring hidden cells) 660
Subtraction (operator) 404
SUM (Sum) 662
Sum if condition is true (SUMIF) 663
Sum if conditions are true (SUMIF) 664
Sum of a power series (SERIESSUM) 643
Sum of products (SUMPRODUCT) 665
Sum of squares (SUMSQ) 666
SUMIF (sum if condition is true) 663
SUMIFS (sum if conditions are true) 664
Summary 309
Sum-of-years’ digits depreciation (SYD) 668
SUMPRODUCT (sum of products) 665
SUMSQ (sum of squares) 666
SUMX2MY2 (sum of x^2 - y^2) 666
SUMX2PY2 (sum of x^2 + y^2) 667
SUMXMY2 (sum of (x - y)^2) 668
Superscript 180
Support 22
Surface chart 257
SYD (sum-of-years’ digits depreciation) 668
Symbol , insert 153
Syntax highlighting (View) 91
System requirements 23
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T
T (convert value into text string) 669
T.DIST (t-distribution) 671
T.DIST.2T (t-distribution two-tailed) 672
T.DIST.RT (t-distribution right-tailed) 673
T.INV (percentiles of the t-distribution left-tailed) 677
T.INV.2T (percentiles of the t-distribution
two-tailed) 678
T.TEST (t-test) 684
Tab width (in text frames) 372
Tables
cell references 116
Convert to range 111
Delete 112
Delete table 111
Insert 112
Select 112
Table range 112
Table settings 113
Table styles 113
Tables in worksheets 109
total row 115
using names and specifiers 116
TAN (tangent) 670
Tangent (TAN) 670
TANH (hyperbolic tangent) 670
TDIST (t-distribution) 671
t-distribution
T.DIST 671
T.DIST.2T (two-tailed) 672
T.DIST.RT (right-tailed) 673
T.INV (left-tailed) 677
T.INV.2T (two-tailed) 678
TDIST 671
TINV 676
Technical support 22
Template folder 364
Text
entering 51
TEXT (convert number into text string) 673
Text (number format) 161
Text color 179
Text direction 345, 346
Text file format 339, 340
Text filters (AutoFilter) 84
Text frames 236
inserting 236
properties 237
Text input mode 32

Index
Text styles 178
Text to columns 83
TextArt objects
drawing 249
properties 252
TextMaker file format 339
Three-dimensional calculations 75
Threshold value (GESTEP) 523
TIME (create time) 674
Time difference (TIMEDIFF) 675
TIMEDIFF (time difference) 675
TIMEVALUE (convert text into time) 676
TINV (percentiles of the t-distribution) 676
Title bar 27
TODAY (current date) 678
Toolbars 380
creating user-defined icons 395
customizing 380, 384
managing 382
using 28
Tools > Check spelling 299
Tools > Customize
creating user-defined icons 395
customizing keyboard shortcuts 396
customizing toolbars 384
Tools > Disable sheet protection 334
Tools > Disable workbook protection 335
Tools > Edit lists 398
Tools > Edit script 348
Tools > Edit user dictionaries 301
Tools > Formula auditing 93, 94, 95, 96
Tools > Goal seek 99
Tools > Options 353
Appearance tab 359
Edit tab 356
Files tab 364
Fonts tab 369
General tab 355
Language tab 363
System tab 366
View tab 353
Tools > Recalculate 97, 374
Tools > Scenarios 100
Tools > Sheet protection 332, 333
Tools > Start script 348
Tools > Update charts 281, 374
Tools > Update external references 409
Tools > Workbook protection 334
Touch mode 359
Transfer formatting 206
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Transparency (of pictures) 240
TRANSPOSE (transposed matrix) 679
Transpose (Worksheet menu) 82
Transposed matrix (TRANSPOSE) 679
Transposing cells 82
TREND (values of a linear regression) 680
Trend lines (in charts) 270
TRIM (remove spaces from text) 681
TRIMMEAN (mean ignoring marginal values) 681
TRUE (logical value TRUE) 682
TRUNC (Truncate a number) 682
TTEST (t-test) 683
TYPE (type of a value) 685

U
Underline 178
Undo (Changes) 37
Ungroup (Objects) 235
Unit conversion (CONVERT) 455
Units of measure 359
Update charts 281, 374
Updates 366
Updating tables 49, 97
UPPER (convert text to upper case) 685
Upper case
PROPER 624
UPPER 685
Use left Alt as shortcut key 356
Use OpenGL engine 366
Use SHM extensions 366
Use system file dialogs 359
Use system menus 359
Use XIM 366
User field (USERFIELD) 686
User info 355, 686
User interface (ribbon or menus with toolbars?) 359
User interface size 359
User-defined number formats 164, 165
USERFIELD (user field) 686

V
VALUE (convert text into a number) 687
Value axis (in charts) 273
VAR (variance of a sample) 688
VAR.P (variance of entire population) 690
VAR.S (variance of a sample) 691
VARA (variance of a sample) 689

Index
Variance
of a sample (VAR) 688
of a sample (VAR.S) 691
of a sample (VARA) 689
of entire population (VAR.P) 690
of entire population (VARP) 689
of entire population (VARPA) 691
VARP (variance of entire population) 689
VARPA (variance of entire population) 691
VBA 348
VBA scripts 287, 344
Version control 313
Vertical alignment
of cells 173
of text in AutoShapes 253
of text in text frames 237
Vertical text 173
View > Actual size 378
View > Freeze 152
View > Full screen 379
View > Object mode 222
View > Row & column headers 377
View > Show formulas 90
View > Syntax highlighting 91
View > Toolbars 380
View > Touch mode 359
View > Watch window 92
View > Zoom level 378
View side by side (Window) 351
Visual Basic 348
VLOOKUP (look up column-wise) 692

W
Walls (in charts) 265
Warning if a formula contains errors 356
Watch window 92
Weber function (BESSELY) 432
Week number
ISOWEEK 557
ISOWEEKNUM 558
WEEKNUM 693
WEEKDAY (weekday) 693
WEEKNUM (week number) 693
WEIBULL (Weibull distribution) 694
WEIBULL.DIST (Weibull distribution) 695
Width of a column 157
Window > Close all 350
Window > View side by side 351
Workbook properties 369
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Workbook protection 334
Workbooks 72
WORKDAY (date after x workdays) 696
Workdays
count (NETWORKDAYS) 596
date after x workdays (WORKDAY) 696
Worksheet > Column
Hide 159
Optimum width 158
Show 159
Width 158
Worksheet > Data consolidation 104, 105, 107, 108
Worksheet > Delete cells 59
Worksheet > External references 409
Worksheet > Filter
AutoFilter 84
Special filter 88
Worksheet > Insert cells 60
Worksheet > Insert copied cells 61
Worksheet > Modify pivot table areas 148
Worksheet > Names 76, 79
Apply 80
Edit 76
Import 78
Insert list 78
Worksheet > New pivot table 120
Worksheet > New table 109, 110
Worksheet > Outliner
Automatically show outline pane 318, 319
Clear outline 317
Group 317
Options 319
Ungroup 317
Worksheet > Pivot table > Create pivot table 120
Worksheet > Properties 74, 377
Worksheet > Remove
Duplicate rows 60
Empty rows 60
Worksheet > Row
Height 158
Hide 159
Optimum height 158
Show 159
Worksheet > Sort 81
Worksheet > Table
Convert to range 111
Delete 112
Delete table 111
Header row 113
Insert 112
Select 112
Table range 112

Index
Worksheet > Table
Table settings 113
Total row 113
Worksheet > Text to columns 83
Worksheet > Transpose 82
Worksheet > Worksheet 73, 74
Worksheet register 73, 353, 372
Worksheets 72
copying 74
deleting 74
editing 49
formatting 156
hiding 74
inserting 73
moving 74
properties 74, 377
renaming 74
selecting 55
unhiding 74
Workspace color 359
Wrap text 173

X
X axis (in charts) 271
XIM 366
XIRR (internal rate of return) 696
XLS file format 339
XLSX file format 339
XOR (logical XOR function) 698
XY scatter chart 257

Y
Y axis (in charts) 273
YEAR (year of a date) 698

Z
Z axis (in charts) 274
Z.TEST (z-test) 699
Zeros (showing/hiding) 160, 377
Zoom level (View) 378
ZTEST (z-test) 699
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