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Basic text editing
FlexiPDF enables you to edit text in a PDF document as if you were using a regular 
word processor.

Open the PDF to be edited.

In this example there is an ‘r’ missing 
from ‘you’.

From the toolbar select the  
Text tool.

Click the mouse on the text to 
be edited. After a short pause, while 
FlexiPDF prepares the page for editing, 
you can start editing.

Edit the text - in this example the letter “r” 
has been added to “your”. 

The text box automatically grows longer 
in order to accommodate all the words. In 
this case, we do not want this, so we will 
re-shape the box in the next step.

1

2

3

Continued...

ProStandard

Notes
•	 The new ‘r’ is displayed in red because Show changes is enabled in the Preferences 

dialogue. This change highlighting is only visible in FlexiPDF and not in any other 
PDF viewer. 

•	 A text box will automatically grow or shrink until you re-shape the box yourself. After 
which it remains whatever shape you made it and will become ‘overset’ if you try to 
enter too much text.
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Now the box is too small to show all the 
text, you will see a red box in the bottom 
right hand corner indicating the box has 
become ‘overset’.

To reveal the missing text, resize the text 
box again - making it wider.

Drag the left & right resize handles 
outwards to make the box slightly wider.

First drag the bottom re-size handle 
upwards to make the text box shorter 
and stop it from colliding with the line 
beneath.

5

The text now fits on two lines as before.

Save the changes you have made to your 
PDF.

Continued from previous page

4

3

Continued...
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If you have the free version of FlexiPDF 
you will see this dialogue box.

You have the option to save your PDF with 
a watermark added to edited pages. The 
watermarks can be safely removed at a 
later date.

The second option activates your copy 
of FlexiPDF using the activation key 
supplied when you purchase the product. 
After activation watermarks are no longer 
added to PDFs. 

6
ProStandard

Continued from previous page
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Form filling
FlexiPDF can be used to fill-in both interactive and non-interactive forms.

An interactive form is a specially prepared PDF which contains interactive elements 
like text boxes, buttons and lists. You can interact with these, supplying text and 
making selections. You can then save, print or send this filled-in PDF to others via 
email.

Traditional Paper Forms  (Non-interactive forms)
A non-interactive form is simply a PDF version of a traditional paper form. Normally 
this would have to be printed out then filled-in by hand. With FlexiPDF, you can use 
the T+ tool to fill-in text fields and check boxes, speeding up the entire process while 
keeping the form entirely digital and available to email to a third party.

When started in Form Filler mode, FlexiPDF offers simplified menus and toolbars for 
the purpose of filling-in forms. In this mode FlexiPDF does not add watermarks to 
edited documents.

ProStandard

Continued...

Select the Text Plus tool.

As you move the mouse over the 
form, FlexiPDF will try to highlight the 
areas to be filled-in. 

Click on a highlighted area to begin typing 
into it.

Hold the Control key when you click to 
ignore FlexiPDF’s guess and create a 
small, single-line text box.

2
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If FlexiPDF determines that the item 
under the mouse looks like a check-box, it 
changes the cursor to a pointing hand.

Click to mark the box with an X.  
Click again to remove the X.

Hold the Control key and click to ignore 
the check-box and create a small, single-
line text box.

Hold Control+Shift to force FlexiPDF to 
create an X even when it doesn’t recognise 
the area as being a checkbox.

Notes
•	 Use the Text Plus tool to create new text boxes in any kind of PDF not just form-style 

documents.
•	 The Text Plus tool does not edit existing text - only text created by the tool either 

during this session or from when the PDF was last edited.
•	 Since FlexiPDF is making a guess at the shape and location of editable areas, it may 

sometimes arrive at an incorrect decision. In this case, hold down Ctrl as you click to 
ignore the guess. 

•	 Filled-in forms are normal PDFs that can be viewed and printed by any PDF viewing 
application.

Continued from previous page
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OCR corrections
Some scanner applications place scans as images in PDF files, but invisibly add 
their textual content behind the images. This results in the scanned pages keeping 
their original layout, but making them at the same time searchable. You can create 
such a hybrid file with FlexiPDF, too, by choosing a “searchable PDF” when 
performing OCR.

In order to correct errors in this hidden text, you can make the text visible in 
FlexiPDF.

ProStandard

Open the PDF to be corrected then choose 
Document > OCR Corrections > Start.

The example shows a scanned page in 
which the text added by the OCR process 
is hidden.

Since OCR mode could cause a PDF to be 
substantially changed, you will be asked to 
confirm your choice.

Always make sure you have a backup of 
the PDF before you start this mode.

Choose the “Start OCR mode” option to 
begin. 

The hidden text becomes visible, the 
scanned image faded and locked to make 
editing easier.

You can now edit the text whilst making 
reference to the original content in the 
image.

1

2

3
Continued...
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This example shows some corrections 
(shown in red because Show Changed 
Text has been enabled in the Preferences 
dialogue box).

After all corrections have been done, 
choose: Document > OCR Corrections > 
Finish.

The OCR text, including any edits you 
made will become invisible and the 
scanned image restored to its normal 
density.

If you find some unwanted text remains 
visible in your document, choose 
Document > OCR Corrections > Hide all text 
which will make all text invisible even if 
it wasn’t originally invisible. Since this 
operation cannot be undone, please ensure 
you save a copy of your document first.

Notes
•	 If your document happened to contain any non-ocr text added after the scanning 

process, this too will be hidden at the end of the correction process.
•	 Choose View > Text > Boundaries to see the boundaries between different blocks of 

text.
•	 Changing the colour of the OCR text can make it easier to distinguish from the 

background image. This will not affect the finished PDF.
•	 Some OCR packages create many small text blocks that are difficult to edit. Use the 

“Rebuilding text boxes” on page 90 in FlexiPDF Professional to merge disjoint 
blocks of text into a single, editable text block.

4

Continued from previous page
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Activating your software
FlexiPDF Professional and Standard editions add watermarks to saved PDFs unless 
you activate the software using the code supplied when purchased.

Activations codes are usually provided as part of a purchase receipt email. If you 
cannot find your code, please contact sales@softmaker.com

Continued...

Choose Help > Buy/Activate from the 
main menu bar to display the Buy/Activate 
FlexiPDF dialogue box.

If you have your activation key code to 
hand, press Activate.

If you have not yet purchased FlexiPDF, 
press Purchase.

This will attempt to open the FlexiPDF 
web page using your web browser.

Once you have bought a license and 
have an activation key, press the Activate 
button.

On-line Activation

Your code may be a number or sequence 
of numbers and letters or your email 
address.

On-line activation is the quickest method. 

If your computer does not have an internet 
connection, uncheck this box.
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Continued from previous page

Potential Problems
If you computer is behind a fire wall or web access is blocked in some way, 
the activation may not succeed. If this is the case, follow the off-line activation 
instructions below.

Off-line activation
Uncheck the Activate on-line check box to reveal the lower part of the dialogue box.

Continued...

This is the code you should send to 
SoftMaker (your code will be different 
to that pictured). The code changes every 
time you install FlexiPDF.

Press the Copy button to copy the code to 
the clipboard (to avoid copying it by hand)
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Continued from previous page

SoftMaker will use the code you send 
to generate an off-line activation key- 
normally within 24 hours (except at 
weekends)

When you receive your off-line key enter 
it here.

The key will only work on the computer 
you used to generate the code. 

It will not work if you have re-installed 
FlexiPDF on that computer since you 
requested the off-line activation.
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Toolbars
The first three toolbars and the status bar are shown by default, the others are hidden. 

All of the toolbars shown below can be shown or hidden by using the View > Toolbars 
menu. 

Edit toolbar - see page 20

Navigation toolbar

Text formatting toolbar

Drawing toolbar - see page 21

Commenting toolbar - see page 22

Alignment toolbar

Translation toolbar - see “Exporting content for translation” on page 210

Status bar - see “Status bar” on page 23

Work Mode bar - see “Status bar” on page 23
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Hand tool - grab the document and pan around to view hidden areas.

Zoom tool - click to zoom in. Control-click to zoom out. Drag out a box to 
zoom into a region.

Object tool - click to select objects, move and resize by dragging the re-
size handles. Drag our a box to select a group of objects. See page 31.

Rotate tool - only active when objects have been selected with the Object 
tool. Click to change rotation origin. Drag to rotate the selection. See page 
34.

Text tool - click to edit existing text.

Text plus tool - click to add a new text box or edit an existing box added 
with the tool. Drag to create a new, larger text box.

Linked text tool - click on blocks of text to link them together in order. 
Click again to unlink. Text will flow between linked blocks.

Crop tool - click and drag to create a crop box. Resize the crop box then 
press Return to perform the crop. 

Hyperlink tool - drag out a box to create a new hyperlink, table or image 
annotation.

Article tool - drag out a new article box around text. Link article boxes 
together for easier reading and export.

Fill colour - change the fill colour of selected objects.  See page 36. 
(FlexiPDF Standard only.)

Line colour tool - change the outline colour of selected objects. Also 
change the line thickness. (FlexiPDF Standard only.)

Pipette tool - click on an object to copy its fill & stroke colours to the 
currently selected object(s). See page 39

Colour picker - click to change the fill or stroke colours of the selection. Also 
changes the line-width used for stroking. See page 37

FlexiPDF Professional only

Edit toolbar
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Drawing toolbar
Choose View > Toolbars > Drawing to show/hide the toolbar. 

Pencil (Freehand) - create freehand line drawings. 

Rectangle - hold down SHIFT while dragging to create squares.

Pen - connected straight lines. 

Ovals - hold down SHIFT while dragging to create circles.

Single lines - single straight lines. Can have arrows applied to their ends.

End arrows - the size of the applied decoration is related 
to the line width.

Start arrows - apply various types of arrowhead to the 
start of a line or group of connected lines.

Toggle border - place a simple border around the selected object(s). 
Useful for placing a border around images.

Notes
•	 Some of these tools look very similar to those on the commenting toolbar. However, 

these add graphic elements to the page. Commenting tools add similar shaped objects 
to a special layer floating above the page and associate a note window with those 
objects. The appearance of the comments made with commenting tools is left to the 
discretion of the application used to view the PDF. Objects made with the drawing 
tools should look identical in any PDF application.
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Commenting toolbar
Choose View > Toolbars > Commenting to show/hide the toolbar. 

Similar to the drawing tools, these tools allow you to add a comment to each 
annotation. Unlike the drawing tools, the annotations do not form part of the PDF 
page but are placed in a separate layer that floats over the page.

The annotations you create also appear summarised in the Comments catalogue.  
(View > Comments).

Sticky note - Drag out a box to the size of the required sticky note. 

Rectangle note - drag out a rectangle. Hold SHIFT while dragging for 
squares. Double click to edit the attached note.

Circle note - drag to create an oval. Hold SHIFT while dragging to create 
a circle.

Polygon note - create connected straight line shapes. 

Scribble (Freehand) note - create freehand line drawings. 

Line note - create a single line

Text highlight - toggles a highlight on the selected text. Select text with 
the Text tool, then press this button to highlight it.

Stamp tool - add a predefined stamp to a page such as “Confidential”, 
“Draft”, “Sign here”. Also add your signature to a page. 

Right-click the mouse over an annotation 
and choose Properties to access the 
Properties dialogue from where you 
can change the colour and style of the 
annotation.
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Status bar
The status bar (View > Status Bar) provides at-a-glance information and short cuts to 
commonly used functions and dialogue boxes.

Lock icon - visible only when 
the current document has 
security restrictions.

Double-click to open the 
Document Security dialogue 
(Standard and Pro only)

The dimensions of the currently 
selected object(s). 

Only visible when using the 
Object Select tool.

This information and more is 
also available in the Transform 
palette. Object > Transform.

Rendering mode - shows either Preview 
or Outlines depending upon the current 
rendering mode.

Outline is quicker to draw and makes 
editing quicker. It has no permanent 
effect on the PDF, only while viewed in 
FlexiPDF. 

Double click to toggle between modes 
(Standard and Professional only). 

Page label - only present if the 
PDF uses page labels.

Double-click to edit document’s 
page labels. (Pro only)

Dimensions of the 
current page
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Converting PDF to other formats
To convert a PDF into HTML, text or RTF or to export the images within a PDF, use 
the File > Export menu. 

FlexiPDF can export a document on a page-by-page basis or an article-by-article 
bases (FlexiPDF Professional only).

Exporting a range of pages
Choose File > Export > Pages as.

Choose the range you wish to export.

Near the bottom of the dialogue box is a 
summary of the output format that will be 
used for the export. To change the output 
format, press Format. 

The output options available are detailed 
in “General export settings” on page 195.

Exporting by article thread
Choose File > Export > Articles as.

If your document contains no article 
threads you will need to create some. See 
“Adding article threads” on page 179.

Choose to export just the articles 
beginning on the current page, or all 
articles in the document. If no articles 
begin on the current page, only one option 
will be available.

Near the bottom of the dialogue box is a 
summary of the output format that will be 
used for the export. To change the output 
format, press Format. 

The output options available are detailed 
in “General export settings” on page 195.

Pro

ProStandard
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Converting other documents to PDF
To convert any document to PDF, print it using the FlexiPDF Printer.

Open the document in the application you 
normally use to view it. 

In this example, we’re viewing a web page 
in Internet Explorer.

Print the document and choose FlexiPDF as 
the printer to use.

If you do not see FlexiPDF listed as an 
available printer it may be that you did 
not choose to install it when you installed 
FlexiPFD - it is an optional feature.  
See “Re-installing the FlexiPDF Printer” 
on page 26

To change the paper-size used for the final 
PDF, press Preferences then Advanced.

After printing has finished, FlexiPDF will 
open showing the new PDF created.

The new PDF may be edited and saved as 
normal.

1

2

3
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Re-installing the FlexiPDF Printer
Make sure FlexiPDF is not running then 
run the FlexiPDF installer again. 

If you need to download a copy, it will 
be available on the download page of 
SoftMaker’s website:  
http://www.softmaker.com/en/download

Make sure you choose to install the 
FlexiPDF Printer by ticking the checkbox 
on the 5th screen of the installer.
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Joining multiple PDFs
FlexiPDF can quickly join multiple PDF documents into a single document.

Drag & drop any number of PDF files onto an open but empty FlexiPDF window  
or choose File > Join.

Pro

Adding files
Add further files or entire 
folders full of files using 
the Add Files and Add Folder 
buttons. When adding folders, 
any PDF found in the folder or 
its sub-folders will be added 
to the list. There is no limit on 
the number of files that can be 
added.

Re-ordering documents
The order of the files in the list is the order in which they will be joined together. To 
change the order, select a file then press Up or Down to move it higher or lower in the 
list.

Joining
Press Join to begin the process 
of merging the documents 
together. FlexiPDF will prompt 
for a filename for the new 
merged document.

Once the process is complete, 
FlexiPDF will ask if you wish 
to open the new file.

Notes
•	 To add page numbers to a document after merging see “Cloning objects across pages” 

on page 98.
•	 FlexiPDF will reject encrypted PDFs. Remove any passwords and encryption from all 

files before trying to join. See “Security settings” on page 147
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PDF photo albums
Drag & drop any number of images onto FlexiPDF and the software will create a new 
PDF in which each page shows one of the images dropped.

Ensure no documents are open in 
FlexiPDF.

FlexiPDF will construct a new PDF in 
which each page contains one of the 
dropped images.

Drag & drop a selection of JPEG, 
TIFF, PNG or BMP images onto 
FlexiPDF.

1

2

3

ProStandard
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Work Mode
Sometimes you may want to view PDFs without fear of making accidental edits. 
To help avoid this, FlexiPDF can operate in three different modes which limit the 
changes you are able to make to a PDF:

•	 View mode 
All editing, document assembly and commenting is disabled. Only 
functions associated with viewing such as find, layers and bookmarks are 
available. A PDF cannot be altered at all in this mode.

•	 Comment mode 
Add or edit comments (sticky notes, highlights etc.) but nothing more.

•	 Edit mode (default) 
Normal editing mode in which all tools available for the particular flavour 
of FlexiPDF (Standard or Professional) are available.

ProStandard

Notes
•	 FlexiPDF remembers the mode that was in effect the last time the software was used.
•	 If not visible, show the work mode toolbar by choosing View > Toolbars > Work 

Mode.



Editing Graphics & Images

☞☞ Aligning objects
☞☞ Changing colour & line width (CMYK)
☞☞ Changing colour & line width (RGB)
☞☞ Copying colours between objects
☞☞ Grouping objects
☞☞ Hiding objects
☞☞ Inserting new images
☞☞ Layers
☞☞ Layout grid
☞☞ Layout guides
☞☞ Line arrows
☞☞ Locking objects
☞☞ Object borders
☞☞ Redacting Images 
☞☞ Replacing images
☞☞ Re-sampling Images 
☞☞ Rotating objects
☞☞ Scaling objects
☞☞ Selecting objects
☞☞ Stretching objects
☞☞ Swatches catalogue

30
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Select the Object tool from the tool 
bar.

Click on a single object to select it.

If objects overlap, the top-most object is 
selected. 

Ctrl+Shift to select the next object 
underneath the current object. Each time 
you Ctrl+Shift, the next object down is 
selected.

Selecting objects

Drag out a box to select all objects 
touching the box. Objects do not need 
to be completely inside the box, any that 
touch will be selected.

Hold Shift to remove objects from the 
current selection.

Cut/Copy/Paste may be used on single 
objects or groups of objects.

Notes
•	 Press Backspace or Delete on your keyboard to delete selected objects.
•	 Click and drag to move the object or selection of objects to a new position. 
•	 Use the cursor keys to move selected objects by 1 point (1/72 inch). Hold the Shift key as 

well to move by 10 points.
•	 Copy/Paste of graphics between FlexiPDF and other applications is not supported.

Some pages are littered with invisible objects making selections difficult. These 
objects can usually be safely removed without altering the appearance of the page.

To see invisible objects, choose View > Outlines or double-click on the Preview in the 
status bar at the bottom of the main FlexiPDF window.

ProStandard
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Stretching objects
Selected objects can be stretched by dragging the handles on the sides or corners of 
the selection box. Alternatively, choose Object > Scale (FlexiPDF Professional).

Select the object(s) to be stretched 
using the Object tool.

Drag one of the four side-handles or four 
corner-handles to stretch.

To retain the aspect-ratio of the original 
shape(s), hold down the Shift key while 
dragging. Doing so in this example would 
result in a larger circle, not a large oval.

The selected objects will be stretched to fit 
the box you dragged out.

Notice the text has not been stretched.  

Stretching text like this changes the shape 
of the text box causing any text inside to 
reflow into the new shape. It will not alter 
the size of the characters themselves. If 
you need to do that, use Object > Scale.

1

2

Notes
•	 Line widths are not affected when stretching in this way. To scale these too, use  

Object > Scale dialogue box (FlexiPDF Professional only)
•	 Objects and selections may also be scaled using Object > Transform (FlexiPDF 

Professional only)

ProStandard
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Scaling objects
Select the objects to be scaled using 
the Object tool. Then choose Object 
> Scale from the main menu.

Using the Scale dialogue box you can 
scale the selection by a single value or 
different values of the X and Y scales.

You can also specify whether the line-
width of objects being scaled is affected in 
the same way.

Press the Copy button to scale a new copy 
of the selection, leaving the existing 
objects untouched.

1

2

3

Pro

The image on the left shows the effect of a 200% scale which also scaled the line width. 
The image on the right was scaled without affecting line widths.

Notes
•	 Objects and selection may also be scaled using Object > Transform (FlexiPDF 

Professional only)
•	 Scaling in this way affects both graphics and text.
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Rotating objects
Selected objects can be freely rotated by any angle. Alternatively, choose  
Object > Rotate (FlexiPDF Professional only)

Select the object(s) to be rotated 
using the Object tool.

Now choose the Rotate tool.

Drag the selection’s outline to the desired 
orientation.

Hold down the Shift key while dragging to 
constrain rotation to 45˚ angles (0, 45 ,̊ 90 ,̊ 
135˚ etc.)

Stop dragging to complete the rotation.

After rotation, the Object tool will 
become active again. 

1

2

3

Continued...

ProStandard

Notes
•	 Objects and selection may also be rotated (or sheared) using Object > Transform 

(FlexiPDF Professional only)
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Changing rotation origin
Objects can be rotated around an arbitrary point.

Select the object(s) to be rotated 
then select the Rotate tool.

Click the left mouse button to 
reposition the origin. 

Drag the selection’s outline to the desired 
orientation.

Hold down the Shift key while dragging to 
constrain rotation to 45˚ angles (0, 45 ,̊ 90 ,̊ 
135˚ etc.)

Stop dragging to complete the 
rotation.

After rotation, the Object tool will become 
active again. 

Rectangle’s origin has been moved to the 
centre of the circle

1

2

3

Continued from previous page
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Changing colour & line width (RGB)
All objects (except clipping paths and images) can have a line or stroke colour and a 
fill colour. 

You can choose new colours for either or make the line or fill invisible.

Circle has red line colour, yellow fill colour

Text has black fill colour and no line colour (this 
is common for text)

Text has no fill colour and red line colour

To change the colour of the selection press 
the Fill Colour or Line Colour buttons.  
These buttons also display the currently 
selected colour.

1
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3

Standard

The line and fill colour dialogue boxes 
offer a simple way of selecting colours 
from the RGB (red-green-blue) colour 
space.

Click to make the line colour invisible. A 
similar check box exists on the fill-colour 
dialogue box for removing the fill colour.

Control the thickness of the outline by 
specifying a value in points (1/72 inch)

A thickness of 0.0 will be rendered as a 
hairline.
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Changing colour & line width (CMYK)
FlexiPDF Professional lets you change the fill and stroke colours of selected objects. 
Various different selection methods are offered including a CMYK colour picker.

1

2

Line colour

Fill colour - click to 
change

Short cuts for transparent, 
white & black

Press Swatches to see a catalogue of all the 
colours currently in use in the PDF.

“No fill” or “No stroke” colour are 
depicted as white with a red diagonal line.

Swap fill/line colours

Pro

Press the Colour button to open the colour 
picker dialogue box. 

The fill and stroke colours are both 
included on the same toolbar button.

Notes
•	 The simple colour picker used by FlexiPDF Standard and FlexiPDF Form Filler always 

chooses colours from the RGB palette. If the selected objects use a different colour 
space (such as CMYK), FlexiPDF converts the RGB value into CMYK. This can cause 
a slight difference in appearance of the colour which is unavoidable when converting 
between light and ink-based colour spaces.

•	 All versions of FlexiPDF retain the original colour space of an object.
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Swatches catalogue
The Swatches window shows all the colours used in a PDF. It can also be used to 
change the colour of selected objects.

2

Choose View > Swatches to open the 
swatches catalogue.

Alternatively, press the Swatches button 
from within the CMYK colour picker 
dialogue box.

There may be a short delay while the 
catalogue is built.

The catalogue shows the component 
values of each colour and (if available), 
the names of separation colours.

Double-click on a colour to change any 
selected objects.

CMYK, Gray and Separation colour 
values are shown as a percentages from 
0 to 100.

RGB values range from 0 to 255

Choose between fill or line 
colour by clicking on the 
shape. 

Click on the black arrows to 
swap fill & line colours.

Notes
•	 You can restrict the colour available during editing to just those in the PDF or in a 

special hidden resource page. See User Restrictions for more information.
•	 The swatches catalogue is populated only when a PDF is opened.

Pro
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Next choose the Pipette tool from 
the toolbar.

Using the Object tool, select the 
object(s) whose colour you wish to 
change.

Copying colours between objects
Use the Pipette tool to copy the colour from one object to another.

1

2

Click the Pipette on an object whose 
colour you want to copy.

3

The fill colour, line colour and line width 
of the chosen object is copied to the 
selected objects.

Pro
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Aligning objects
Objects may be aligned relative to other. You can also align objects relative to fixed 
guides. See Guides for more details.

Choose the Object tool from the 
toolbar.

Select the objects to be aligned. 

Choose Object > Align > Top to align the 
tops of the objects together. 

All objects in the selection are aligned to 
the top-most object.

Notes
•	 The order in which you select items for alignment is not important.
•	 Aligning text blocks does not affect the paragraph alignment (justification) within the 

text blocks.

ProStandard

All the alignment styles are available from 
the Object Alignment toolbar.

To show this toolbar choose View > 
Toolbars > Object Alignment.
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Replacing images
You can substitute an existing image for another loaded from disc. Supported image 
formats are JPEG, TIFF, PNG, BMP and PDF.

Choose the Object tool from the 
toolbar.

Select the image to be replaced, then 
choose Object > Images > Replace Existing.

You can also click the right mouse button 
to see a similar menu.

In this example a picture of a Volkswagen 
Beetle has replaced the old image.

The new image is placed inside the 
clipping mask (pink outline) used by the 
old image. 

The new image is automatically selected 
after being inserted.

Scale the new image by dragging one of 
the resize handles outwards. 

Hold the Shift key at the same time to 
ensure the aspect ratio is maintained.

2
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Continued...
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The new image needs to be moved to the 
centre of the clip mask.

Drag it to its new position using the mouse 
or nudge it using the cursor keys (and Shift 
for larger steps).

The finished result after scaling and 
repositioning the new image.

5

4

Continued from previous page

Notes
•	 FlexiPDF supports images up to a maximum of 8-bits per colour channel
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Inserting new images
Images can be quickly added to a page using drag & drop.

1

2

Drag & drop multiple image files onto an 
open document in FlexiPDF to insert them 
into the current page.

Or, choose Object > Images > Insert 
then choose a single image from the file 
selector.

Choose from JPEG, PNG, TIFF and BMP 
image formats.

ProStandard

3

New images are pasted into the page on 
top of each other. Use the object tool to 
move and stretch them to the correct size.

Drag & drop multiple 
images onto an open 
document

Notes
•	 FlexiPDF supports images up to a maximum of 8-bits per colour channel
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Object borders
FlexiPDF can add simple borders around objects. This is most effective when used 
around an image. 

Select the objects which are to have 
a border placed around them.

Choose Object > Border > 2 pt.

or press the border button on the 
Drawing toolbar.  
(View > Toolbars > Drawing)

The border width can be changed by 
choose another point size from the: 
Object > Border sub-menu.

Borders can be applied to any object, not 
just images.

To remove the borders, press the border 
button again, or choose Object > Border > 
No Border.

Notes
•	 Borders are always black.

1
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Locking objects
Objects can be locked to inhibit accidental editing.

To Lock:
1.	 Using the Object tool, select the object(s) to be locked.	

2.	 Choose Object > Lock or

3.	 Right-click the mouse and choose Lock Selection

Objects will remain locked even after the PDF is saved and re-opened (provided 
FlexiPDF Layout is preserved in the PDF. See “Store layout info in PDF” on page 
244).

Unlocking Individual Objects:
1.	 Choose the Object tool and move the mouse cursor over the object.	

2.	 Right-click the mouse and choose Unlock Object/s.

The object(s) under the mouse cursor will be unlocked and selected.

Unlocking All Objects
1.	 Choose Object > Unlock All.

Pro
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Hiding objects
To make editing complex artwork easier, objects can be temporarily hidden. 

Hiding:
1.	 Using the Object tool, select the object(s) to be hidden	

2.	 Choose Object > Hide.

Hidden objects will become visible again the next time the PDF is loaded.

Showing:
1.	 Choose Object > Show All.

Pro
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Grouping objects
Objects may be grouped together to make editing easier. 

Grouping:
1.	 Using the Object tool, select the object(s) to be grouped.	

2.	 Choose Object > Group or 

3.	 Right-click the mouse and choose Group Selection.

Groupings remain even after the PDF has been saved and reopened (provided 
FlexiPDF Layout is preserved in the PDF. See “Store layout info in PDF” on page 
244).

Ungrouping:
Select the group(s) to be ungrouped using the Object tool.

4.	 Choose Object > Ungroup or

5.	 Right-click the mouse and choose Ungroup Selection.

Pro
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Layout grid
You can use a grid to help when aligning objects on a page. When displayed, this grid 
makes your pages look like graph paper. You can also make objects ‘snap’ to the lines 
of the grid when you move them.

The distance between grid lines and the snapping behaviour can be controlled by 
you.

Pro

Choose View > Grid & Guides > Show Grid 
to display the grid.

The grid has major (darker) and minor 
(lighter) grid-lines.

To make objects “snap” to the grid lines 
when creating, moving or resizing, choose 
View > Grid & Guides > Snap to Grid.

Choose View > Grid & Guides > Grid 
Spacing.

Spacing is the distance between the major 
(darker) grid lines.

Control the number of minor (lighter) 
grid-lines by specifying a value for Divided 
into.

Grid spacing

Notes
•	 The visibility and spacing of the grid are stored in the PDF and will be used (by 

FlexiPDF only) next time the PDF is opened.
•	 If visible, grids will be included when printing a document.
•	 To change the units used for the grid, choose File > Preferences and click on the 

Editing tab.
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Layout guides
You can create multiple horizontal and vertical guides to help with layout and 
positioning on a page. Objects ‘snap’ to guides when moved close to them making it 
simpler to align objects.

Pro

To create a horizontal guide, click in the 
horizontal ruler at the top of the window 
and drag down to position the resulting 
guide.

To create a vertical guide, click in the 
vertical ruler at the left hand side of the 
window and drag across to position the 
resulting guide.

Vertical ruler bar

Notes
•	 Guides are stored in the PDF (if Store layout in PDF is enabled) for use next 

time the document is edited by FlexiPDF.
•	 Once guides have been created they can be moved and deleted using the Object 

tool as if they were normal objects.
•	 To temporarily hide all guides (or stop them from printing) choose  

View > Grid & Guides > Hide Guides.

Vertical guides

Horizontal guides
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Line arrows
FlexiPDF can add various kinds of arrow heads to either the start or end of lines and 
polygonal shapes.

Pro

Choose View > Toolbars > Drawing to view 
the drawing tools. 

The start and end arrow menus display 
the currently chosen arrow type for the 
selected object(s).

Click on the start/end arrows menus to 
change the arrows of the current selection.

Tear off either menu to convert it into a 
floating toolbar.

Use the Line or Polygon tools to 
draw.

Notes
•	 Lines and their arrows always have the same colour.
•	 The size of the arrow head is proportional to the line width.

Standard
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Layers
FlexiPDF offers a simple way of editing documents which include layers. Using the 
layers panel you can show and hide individual layers in a document to make editing 
easier. You can also move objects between layers.

Choose View > Layers to open the layers 
panel.

Drag the title bar of the layers panel to 
make it into a floating window.

Click on the check box next to each layer 
to  show or hide it from view.

Click on the layer name to rename it. Any 
name change is stored in the PDF when it 
is next saved (FlexiPDF Professional only)

When you click on an object during 
editing, the containing layer is highlighted 
(if the layers panel is open).

Since FlexiPDF ignores objects in hidden 
layers, it can make editing much more 
responsive if you hide all irrelevant 
objects before you begin to edit.

Notes
•	 FlexiPDF cannot create or delete layers.
•	 Changing the visibility of layers affects only the way it is displayed in FlexiPDF. No 

permanent change is made to the PDF.

ProStandard
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Moving objects between layers
To move objects from one layer to 
another, select the objects with the 
selection tool.

The selected text in this example resides 
in ‘Layer 2’.

Select the layer to which you wish to send 
the objects.

Here, ‘Layer 1’ is selected.

Choose Object > Arrange > Send To ‘Layer 
1’.

The object will be marked as belonging 
to the selected layer. This change will be 
stored in the PDF next time it is saved.
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Re-sampling Images 
FlexiPDF can re-sample images to make the overall PDF smaller and quicker to load.

To re-sample all images in the document or across a range of pages choose: 
Object > Images > Resample.

To re-sample specific images, select the images using the object select tool, 
then choose Image > Resample from the right-mouse menu. 

The Resample Images dialogue offers a similar set of options for the three classes of 
images - colour, grey-scale and monochrome.

Converting colour images to grey-scale will reduce the overall size of the PDF file.

JPEG compression is a “lossy” format well suited to colour and grey-scale 
photographs. When choosing JPEG, you can set the quality of the compressed image 
anywhere from 1% (worst quality / smallest image size) to 100% (best quality / 
largest image size).

PNG is a loss-less compression method better suited to colour and grey-scale 
diagrams, charts and line drawings.

Remove all hidden image data 
FlexiPDF is able to remove the hidden parts of images that are painted through a 
clipping mask. Depending upon how the PDF was made, this can reduce the overall 
size of the PDF quite dramatically. 

Pro
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Redacting Images 
FlexiPDF can permanently redact images, removing data that needs to be obscured 
and making it impossible to retrieve the original data whilst leaving the remainder of 
the image in-tact.

For details of how to redact text, see “Redacting text” on page 63.

1. Ensure the Redact toolbar is visible - View > Toolbars > Redact.

Pro

Select the Redact Image tool and 
drag out a rectangular area to be 
redacted. 

Once drawn, the Object tool becomes 
selected.

You do not need to be accurate when you 
initially create the rectangle since you 
can move, resize and rotate it just like any 
other graphic object.

Continue adding further redaction areas in 
the same way to images in your document.

The redaction only becomes permanent 
when the PDF is saved. At this time, 
FlexiPDF modifies the data of any 
image covered by a redaction rectangle, 
permanently obscuring those parts of the 
image.

Redaction rectangles behave like normal 
rectangle objects and can be moved, 

resized, rotated or deleted.

2
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☞☞ Creating new text boxes
☞☞ Editing text across columns & pages 
☞☞ Inserting special characters
☞☞ On-screen display
☞☞ Overset text
☞☞ Performing a spell check
☞☞ Recognising Text (Optical Character Recognition)
☞☞ Redacting text
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On-screen display
1. Select the Text tool from the tool bar.

2. Click on a block of text to begin editing.

The formatting bar and ruler will activate and a text box will be drawn around the 
text block being edited. 

Notes
•	 When you begin editing, spaces, paragraph marks and line-breaks will show up in 

pink. These will become invisible again when you finish editing. Choose View > Text 
> Non Printing Characters to disable this behaviour.	  

•	 See Fonts In PDF for details of how certain fonts can make editing difficult.
•	 Choose View > Text > Boundaries to outline all text boxes during text editing (Pro 

only).	

Ruler & MarginsFormatting toolbar

Space character  
(pink dot)

Paragraph End 
(Return)

Text box with 4 
resize handles

Line-break 
(Shift+Return)

Caret (black bar)  
Text is inserted here
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Using the Text tool
New text can be added at any time by dragging out a new text box of the required 
size.

2

Select the Text tool from the toolbar.

Click and drag to create a new text 
box.

After a short delay, the text box will be 
created ready for editing.

Choose the required font and size from the 
formatting bar before editing.

ProStandard

Using the Text Plus tool
A new, single-line text box can be added at any time.

ProStandard

Select the Text Plus tool from the 
toolbar.

Click to create a new, fixed size 
text box. As you type into this box it will 
stretch.

The box can be resized by dragging on the 
North, South, East, West resize handles as 
normal.

Text boxes created this way will be 
editable in all free versions of FlexiPDF.

1

Creating new text boxes
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Select the Linked text tool from the 
toolbar.

Click the mouse in the middle of 
each column you wish to link together.

The box will highlight and a number will 
be displayed in the middle. This number 
shows the order in which text will flow 
between the boxes.

If you click the same box twice it will be 
removed from the flow and the rest of the 
text boxes renumbered.

Keep adding further boxes by clicking the 
mouse. You can change pages and add text 
from different pages to the flow.

Editing text across columns & pages 
Link multiple text boxes into a chain and reflow the text across the whole chain.

1
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Notes
•	 The text boxes will remain linked together even after you close and re-open the PDF 

provided Store layout in PDF is enabled. See “Store layout info in PDF” on page 244.

When you are ready to begin 
editing select the Text tool from the 
toolbar.

ProStandard
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Overset text
As you are typing, FlexiPDF will enlarge the text box to ensure all your text will fit.

However, as soon as you resize the box yourself (by dragging the resize handles), 
FlexiPDF stops this automatic adjustment and leaves the box at the size you set 
it. From this point on, any that overflows the box will be hidden and a small, red 
‘overset’ box will appear in the bottom right-hand corner of the text box to warn you 
that some text cannot be seen.

To reveal the overset text, make the text box larger or connect it to another text box so 
the text can flow between them.

This text contains overset text. This is 
indicated by the small red square in the 
bottom right of the frame. 

Resize the box to reveal the hidden text.

Alternatively, 
1. click on the overset symbol 
2. drag-out a new text box.

Notes
•	 When saving a PDF, FlexiPDF will check for overset text and report the first instance 

found.
•	 The red boxes are aids only and will not appear when the PDF is viewed in any other 

PDF viewer.

1

ProStandard

The overset text will flow from the old text box into the new one.
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Inserting special characters
Use the Character Palette dialogue to insert characters that are difficult to enter 
directly from the keyboard.

Click on some text to begin editing using the Text tool.

Choose Text > Character Palette.

Use the font menu to choose 
the required font from 
the PDF’s embedded fonts 
and your computer’s system 
fonts. Next/Previous font

Click on a glyph to 
select it. 

Double-click to insert it 
into the PDF.

Poorly formed Type3 
fonts may display 
upside-down. Press 
Invert to rectify this.

Press to re-define 
the meaning of badly 
mapped glyphs.  
See  “Remapping 
fonts” on page 95. 
(Pro only)

Information about the selected glyph:

• name as used in the PDF (not always available) 
• official Unicode description 
• type of the font from which it comes

ProStandard
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Performing a spell check
After editing it is useful to check the spelling of any new text added. You can check 
the spelling of words in three ways:

• check just the words in a text selection 
• check words in active text blocks 
• check the whole document (if there is no active text block)

The spell check dialogue box is accessed from Edit > Check Spelling menu or by 
pressing the F7 function key.

The Spelling dialogue box

Double-click on a suggestion to make the 
change or single-click then press Change 
All.

Misspelled word is shown here.

Type corrections here
Ignore this word and move onto next 
suspect

Ignore this word for the rest of the check.

Adds suspect word to user dictionary 
(See Appendix, “Custom Spelling 
Dictionaries”)

Replace suspect word with correctly 
spelled alternative.

Replace suspect word for correctly 
spelled alternative this time and every 
other time for this checking session.

Language used for spell check. Click on the 
link to change the current language.

Continued...
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Start the spell check by choosing  
Edit > Check Spelling or press F7.

As each suspect word is displayed 
in the dialogue box, FlexiPDF will also 
highlight the word on the page.

You can type a new word into the  
Change To box or select one of the words 
FlexiPDF has suggested then press 
Change.

When the selected text has been checked, 
you will be asked if you wish to check the 
rest of the PDF. 

Notes
•	 See Fonts In PDF for details of how fonts can affect the editing of text.
•	 Be careful when changing text in paragraphs with unusual shapes (such as those that 

flow around graphics). When the paragraphs are reflowed, their layout may be lost. See 
Advanced Editing for methods of dealing with this.

•	 If the words shown in the Suspect window seem garbled or include strange characters 
it indicates that the text cannot be extracted correctly from the PDF. This is caused by 
improper encoding of the PDF’s fonts and cannot be remedied with FlexiPDF.

•	 You can edit the contents of the spelling dictionary - see Custom Spelling 
Dictionaries.

•	 FlexiPDF will warn you if the replacement text cannot be rendered in the font used by 
the misspelled text. In this case, you may have to choose a different font for the text.

•	 Words that include numbers cannot be learnt by the spell checker. You can however, 
skip checking such words using the Ignore All button.

1
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Continued from previous page
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Redacting text
FlexiPDF can be used to reliably redact text of a sensitive nature. A block of text can 
be rendered illegible to the extent that it’s original content no longer forms part of the 
page marking stream.

Any text you redact will also be redacted within the document’s meta-data. This 
includes any bookmarks or text within comments as well as hidden, non-user 
accessible meta-data.

Pro

Using the Text tool, select the span 
of text to be redacted. This can be 
anything from a single word to an 
entire story.

Then choose Text > Redact or press 
Ctrl+Shift+R

The text has been redacted.

You can undo this change whilst editing, 
but once you save the document the 
redaction becomes permanent and can not 
be undone.

Once saved, the text can never be retrieved 
from the PDF. It is not hidden or obscured 
but removed altogether.

1
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To change the colour of future redactions 
or to add a text label choose Text > Redact 
Style.

3
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Recognising Text (Optical Character Recognition)
If you want to edit the text in a PDF that is just a scanned image or vector-based 
artwork then you need to perform OCR on the page(s) first.

FlexiPDF will prompt you to do this if you try to edit text and none exists on the 
page. Alternatively, choose Document > Recognise Text (OCR).

Pro

Choose the range of pages you want to 
process. 

The bottom section of this dialogue is very 
similar to that used for the Create From 
Scanner dialogue. See “Inserting pages 
from a scanner” on page 138 for details.

Because the OCR process removes 
everything but recognised text on a page, 
it will not run on pages which already 
have editable text on them. Otherwise that 
text would be lost.

If you need to do OCR on part of a page, 
copy that part only to a new document 
or page and perform OCR on that. Then 
copy/paste the results back into the 
original page.
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Underline
You can underline a character or words using the Underline button available on the 
formatting toolbar.

Select some text, or move the caret into a 
word and press the underline button on the 
formatting toolbar.

For more control over the width, colour 
and position of the underline choose the 
Text > Style > Underline Options menu 
item.

Using the Underline Options dialogue box, 
you can change the colour of an underline.

Continued...
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Example underline effects
Offset to -20 points

Offset  +6 points on 12 point text

Weight of 0 points (hairline)

Adding a background to text

Notes
• Text is always drawn after its underline decoration.
• Text is always drawn before its strike-through decoration.

Continued from previous page
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Strike-through
Strike-through can be applied to any word or selection of words by choosing:
Text > Style > Strike-through whilst in text editing mode.

Additional options are available to control 
the look of the strike-through decoration. 
To access these choose: 
Text > Style > Strike-through Options.

Example strike-through styles

Offset of -6 points on 12 pt text

Offset of 12 points

Weight of 6 points on 12 pt text

ProStandard

Strike-through

Strike-through

Strike-through
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Margins & indents
You can control the left, right and first-line indents for paragraph text. These indents 
apply to the entire paragraph.

Select the Text tool and click on a block of text to begin editing.

Place the caret inside a paragraph or select a block of text spanning multiple 
paragraphs.

To change a margin, drag the margin 
triangle to the position required. 

The picture shows the “First Line Indent” 
triangle being dragged.

As you drag the margin, a dotted line 
allows you to line-up the margin with 
other objects on the page.

White portions shows width 
of text block

Left margin (triangle shape) 
Drag small rectangle beneath triangle to 
move left & first-line margins together

Right margin

First-line indent

The first-line indent has been changed so 
that the paragraph starts with an indent.

Continued...

ProStandard

1

2

First-line indent

N



	 Formatting Text	 70

Notes
•	 For finer control of indents especially for text that flows around shapes, see Advanced 

Editing.

To create a hanging indent as shown in 
image 2, move the left-margin inward 
without moving the first-line indent.

If you drag the little rectangle underneath 
the left margin arrow, then both the first-
line indent and left margin will move.

Ruler units
You can change the ruler’s unit of measurement. Choose from Centimetres, Inches, 
Points and Picas via the Preferences dialogue box.

Choose File > Preferences then click on the 
Editing tab to change the ruler’s units.

1

2

This paragraph now has a hanging indent.

Continued from previous page

Left margin & hanging indents
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Bold, overprint & italic text
FlexiPDF includes buttons to switch between normal, bold and italic versions of a 
font. These buttons may not operate in the manner you expect since in some cases 
FlexiPDF can simulate the effect required if the appropriate font is not available.

Actual Bold
Using the Text tool, select some text.

Press the Bold button or Ctrl+B.

If the bold version of the font is available, 
FlexiPDF switches fonts.

In this example, the font has changed from 
Times New Roman to Times New Roman 
Bold, both available in the PDF.

Simulated Bold
If the bold versions of the selected 
characters are not available in the 
PDF, FlexiPDF will simulate bold by 
overprinting the characters.

This text, written using Minion-Display 
Regular has no bold equivalent in the PDF 
or on disc.

Pressing Bold causes FlexiPDF to 
overprint the text to simulate the bold 
effect. Notice that the font name has not 
changed in the font drop-down.

Continued...
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Italic
If the italic version of the selected text is 
not available in the PDF or on disc, then 
FlexiPDF will show this warning.

FlexiPDF cannot simulate italic text in the 
way that it can bold text.

Notes
•	 When editing starts, FlexiPDF scans for overprinted text and classifies it as bold. 

This behaviour can be disabled if it is taking too long or wrongly classifying text- see 
“Diagnostic editing mode” on page 242

•	 FlexiPDF does not simulate italic text.
•	 Italics cannot be undone if the non-italic font is not available on disc or in the PDF.
•	 Bold text cannot be undone if the plain font is not available, unless it was previously 

simulated bold.

Continued from previous page
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Background colour
You can specify that a text block has a white, black or transparent background colour. 
This can be useful when you want new text to obscure existing, background text.

In this example we want to obscure the 
name ‘Wilhelm Korte’ on the scanned 
page with a new name ‘Hans Keppler’.

The new text is shown in red due to the 
Show changed text in preference. See 
“Default Editing Tool” on page 240.

When placed on top of the existing 
scanned name, both names are visible.

Choose Text > Text Box > Background 
Colour > White to give the text box a white 
background.

For simplicity FlexiPDF only offers black, 
white or clear backgrounds.

For other colours, create a coloured 
rectangle shape using the drawing tools 
and place it between the new and old text.

1

2
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Line Spacing
Use the Line Spacing dialogue box to set line spacing values other than Single, 1.5 and 
Double.

While in text edit mode, choose  
Text > Spacing > Line from the main menu 
bar. 

The Line Spacing dialogue box offers  
At Least, Exactly & Multiple spacing 
modes.

This paragraph shows the effect of the  
At Least mode in which you tell FlexiPDF 
the minimum gap between lines 
(measured in points).

To stop the “wheels” line (shown left) 
from colliding with the previous line, 
FlexiPDF has automatically increased its 
line spacing.

This paragraph shows the affect of the 
Exactly setting in which you tell FlexiPDF 
the exact gap size between lines (measured 
in points). 

FlexiPDF has used exactly the same 
spacing for each line regardless of whether 
or not they collide.

Continued...
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Use Multiple mode to specify gaps such as 
“2.5 lines” meaning that the gap will be at 
least 2.5 times the line height.

Setting multiples of 1, 1.5 or 2 is the 
same as pressing the single, 1.5 or double 
spacing buttons on the formatting toolbar.

Continued from previous page

Multiple
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Paragraph spacing
You can create a gap between paragraphs in two ways:

1.	 Use the Text tool to insert blank lines between paragraphs

2.	Use the Text tool and the Paragraph Spacing dialogue box available from the  
Text > Spacing > Paragraph.

Using the second method allows you to dictate the exact size of gap in points -  1/72 
inch.

There is no gap between any of the 
paragraphs show left.

Choose Text > Spacing > Paragraph from 
the main menu bar.

Here the value has been changed to 6 
points.

The paragraphs are now 6 points apart.

Select multiple paragraphs to alter the 
spacing of them all at once.

1

2

3
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Letter spacing
The space between individual letters can be controlled to an accuracy of 1/1000 em. 
This is useful for achieving layout effects such as fitting text into a particular area by 
reducing or expanding the spacing.

Letter space & word space
Due to the nature of PDF documents, you can also control the gap between words 
caused by space characters though this is generally not as widely used as letter 
spacing.

1 em

Letter spacing is measured in ‘ems’ with 1 em 
being the width of a capital letter ‘M’ in any 
font.

Letter space Word space

The letter spacing dialogue box uses units 
of 1/1000th em.

You can control the gaps between letters 
and words by entering positive or negative 
values.

The word spacing value is ignored when 
text is fully justified.

Notes
•	 Increase/decrease the letter spacing of selected text using the keyboard short cuts 

Ctrl+Shift+] and Ctrl+Shift+[

ProStandard
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Select the Text tool and begin 
editing a block of text.

Select the characters whose spacing is to 
be changed.

In this example the spacing is being 
changed to 100/1000th em. This will change 
the gap to be 1/10th of the width of the letter 
‘M’ in this font.

The additional spacing is clearly visible 
and the text now covers a wider area.

Starting with the original text, the word 
spacing could be changed instead.

The word spacing is changed to 400/1000th 
em or 0.4 x width of ‘M’.

The new, enlarged gap between the words 
is clearly visible.

Using letter spacing

Using word spacing

2
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Tabstops
Use tabstops to create sophisticated text layouts. Choose from left, centre and right 
justified tabs with or without leader dots.

Creating/deleting tabs
Click on the ruler bar at the position you want to create a new tab.  

Click & drag an existing tab-stop to move it to a new position.

Click & drag an existing tab right off the ruler bar to delete it.

left tab centre tab right tab

Notes
•	 Tabstops are remembered even after closing and re-opening a PDF.
•	 As you add or move an existing tabs their numeric position is shown in the status bar 

at the bottom of the window.
•	 Tabstops may be positioned beyond the left & right margins of the text box.

Tab characters are shown 
as small pink arrows 
during editing

ProStandard
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Creating centre & right tabs
Position the mouse cursor over an existing 
left tab then press the right mouse button 
to see the Tab menu.

Choose Centre or Right to change the type.

Tab leaders
From the Tab Options dialogue box, you can set the leader character or modify the 
way tabs wrap across lines.

Position the mouse cursor over the tabstop 
you want to modify.

Press the right mouse button to display the 
tab menu and choose Tab Options.

To add leader dots to your tabstop, type a 
single ‘.’ (period) into the Leader Character 
text box.

You can type any single character into this 
box for use as a tab leader.

2
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Trailing tab leaders
Use the Tab Options dialogue to control the way tab leaders are drawn for wrapped 
lines.

Position the mouse cursor over the tabstop 
you want to modify.

Press the right mouse button to display the 
tab menu and choose Tab Options.

When Trailing Leaders is checked, 
FlexiPDF will add leader dots to the end 
of a line which wraps because of a tab 
stop.

Can be part of text field is only for use with 
templates destined for processing by Infix 
Server. 

Trailing leaders have been 
added by FlexiPDF.

Notes
•	 Trailing leaders cannot be selected or edited with the text or object select tools. The 

caret will skip over them when moving through text.
•	 Trailing tab leaders extend up to the right edge of the text box.
•	 See “Fields and tabstops” on page 231 for details of the way fields interact with 

tabstops.
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Text Colours
All text has two colours associated with it - the outline colour (stroke) and the interior 
(fill) colour. Either colour may be invisible (but not both).

The colours are set in the same way as for graphics.  
See “Changing colour & line width (RGB)” on page 36

 T
Outlined (stroked) with no fill 

colour
Solid stroke and fill colour



☞☞ Automatic text fitting
☞☞ Clipping mask creation
☞☞ Clipping mask removal
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☞☞ Deleting objects across pages
☞☞ Editing Tabular Data
☞☞ Flowing text around graphics
☞☞ Merging text boxes
☞☞ Numbering pages
☞☞ Rebuilding text boxes
☞☞ Remapping fonts
☞☞ Splitting text boxes
☞☞ Vertical text alignment

Advanced Editing

83



	 Advanced Editing	 84

Vertical text alignment
FlexiPDF Professional can align text inside a text box so that it sits at the top, middle 
or bottom of a text box. It can also make text automatically fit its text box by altering 
various aspects of the text formatting (see Text Box Fitting)

While editing a text box using the 
Text tool then choose: 
Text > Align > Top.

The text shown here is top aligned which 
is the default alignment.

Text > Align > Middle

Text > Align > Bottom

Notes
•	 Alignment reverts to “Top” for linked text boxes.

Pro
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Automatic text fitting
FlexiPDF can alter various aspects of text formatting in order to make text fit inside 
its text box. Even when enabled, some text may be so long that it cannot be made to 
fit. In this case, the text box will be marked as ‘overset’ with a small red box, bottom-
right. See “Overset text” on page 59.

Edit a text box using the Text tool 
then choose: 
Text > Align > Full.

The text shown here is top aligned which 
is the default alignment.

Use the Text Box Fitting Limits dialogue 
box to select the aspects of formatting 
which should be modified and by how 
much.

During fitting, FlexiPDF tries altering the 
enabled aspects of formatting in the order 
they are listed in the dialogue.

The fitting process stops as soon as an 
acceptable result has been achieved even if 
all metrics have not yet been used.

Deactivate fitting metrics by unchecking 
their check boxes.

The first two metrics simply adjust the 
word and letter spacing of text to try to 
achieve a fit.

The adjustment is between the supplied 
limits and is in addition to any spacing 
metrics already in effect on the text.

Continued...
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The Leading Scale metric modifies the  
leading and paragraph spacing of text 
within the percentage limits supplied.

In this example, leading and paragraph 
spacing could be increased from their 
initial values by as much as 200% during 
fitting (or reduced to 75%)

Fitting may be restricted to text that 
overflows its text box (overset text). 

Checking this option ensures fitting will 
not be applied to text that already fits - 
even if there is a lot of empty space.

Continued from previous page

Adjust the gap between paragraphs 
independently of the leading via this 
metric.

Adjustments range between the Min and 
Max point values supplied. If Min is set 
to 0 then paragraph spacing will never 
be reduced. If Max is set to 0, paragraph 
spacing will never be increased.

The final metric adjusts the font size of all 
text in a text box by the same number of 
points in order to obtain best fitting.

Continued...

The alignment to be used on 
underset text (text which 
does not require fitting)
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Notes
•	 Text fitting is time consuming. It is not advisable to edit text with full fitting activated. 

Apply it only once editing is complete.
•	 Text Box alignment is remembered even after closing and re-opening PDFs.
•	 Original formatting (font size, leading & spacing) is restored once full fitting is turned 

off.
•	 Unlike the other alignment modes, full text fitting can be applied across linked text 

boxes.

Default “Top” alignment for two linked text boxes

“Full Alignment” applied across both linked text boxes.

Continued from previous page
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Flowing text around graphics
In order to retain the contour of a paragraph that flows around a graphic the widths of 
lines should be locked during editing. 

Select the Text tool from the tool bar 
and click inside the paragraph to 
begin editing.

Select lines whose shape follows the 
contour of the graphic. Lines that do not 
follow the shape need not be selected.

In this example every line of the paragraph 
needs to be selected.

Choose Text > Fix Line Width from the 
menu bar to lock the selected lines.

“Fixed” lines have an addition border 
showing the shape of the line.

Continued...
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Edit the text as normal.

Although the text will reflow, the shapes 
of the fixed lines will not alter.

You can alter the shape of each line by 
moving the left or right margin for that 
line.

Finish editing as normal.

In this example, each line has been 
reshaped to ensure the new text curves 
around the blue oval.

Note
•	 You cannot use Text > Fix Line Widths on rotated text.

Make sure the alignment is correct. 
FlexiPDF may have chosen the wrong 
alignment due to unusual shape of the 
paragraph.

Continued from previous page
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Rebuilding text boxes
FlexiPDF can grab the text from multiple text blocks within a specific area of the 
page, sort it and build a new text box containing all the grabbed text. This can be 
useful for documents that have many disjoint text blocks making editing difficult.

Owing to the way in which this example 
PDF was produced, FlexiPDF has created 
many overlapping text blocks which make 
editing difficult.

In some cases, lines from two distinct 
columns of text have been grouped into a 
single, extra wide, text block.

(View > Text > Boundaries has been 
enabled to show the outline of each text 
box)

Pro

Choose the Text tool and drag-out 
a new text box large enough to 
enclose all of the text you wish to 
grab. 

Choose Text > Text Box > Rebuild.

Any text enclosed by the new text box will 
be stolen from the existing text boxes.

The stolen text is then sorted using a 
simple x-y sort and placed into the new 
text box.

Original text boxes that become empty as 
a result will be deleted.

Usually the text placed in the new text 
box will have more accurate paragraph 
structure and be easier to edit.
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Merging text boxes
Vertically aligned text boxes may be joined together when you need text to reflow as 
one. 

1

2

3

In this example, FlexiPDF has split the 
text into three boxes. 

This will produce the wrong results when 
the text is reflowed.

While using the Linked text tool 
choose: 
Text > Text Box > Merge Vertically to 
join the three separate boxes into one.

Boxes in the same vertical row will be 
joined into one.

ProStandard

Continued...
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4

Text will now flow as a single column and 
the results should look better.

Continued from previous page

Merging using the Object Tool
You can also join paragraphs by using the Object tool. 

Select the paragraphs in the order in which you want them joined. Click on 
each with the Object tool whilst holding the Shift key. This will add each new text 
block to the selection.

Once you have selected all the boxes you want, choose Text > Text Box > Merge 
Vertically. 

FlexiPDF will only merge text blocks that are aligned in the same column and that 
flow from top to bottom. 

If FlexiPDF doesn’t appear to be merging in the way you want it to, check the order 
in which you have selected the text blocks or try using the Linked text tool instead 
which offers more of a visual cue to the process.
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Splitting text boxes
Text blocks can be split at paragraph boundaries. This can make editing large blocks 
of text faster and helps to avoid reflowing text that does not need it.

1

2

Use the Linked text tool to select the 
text box to be split.

The example shows a large block of 
text with complicating formatting.

To edit just the middle paragraph without 
reflowing any of the other text, the text 
box should be split.

Choose Text > Text Box > Split Paragraphs.

The single box is split so that each 
paragraph becomes a box, not linked to 
any other. 

Although the new text boxes are not 
linked together, for clarity they have been 
linked together in this image to highlight 
the affect of splitting.

Continued...
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3

After splitting, FlexiPDF switches 
to the Text tool ready for editing.

Continued from previous page

Splitting using the Object Tool
You can also split paragraphs by using the Object tool. 

Select the paragraphs to be split in any way - dragging out a selection box, 
Shift-clicking, Edit > Select All etc.

Once you have selected all the boxes you want, choose Text > Text Box > Split 
Paragraphs. 
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Remapping fonts
Every font in PDF includes a mapping from the glyph shapes to their meaning. 
Without this mapping editing would not be possible nor would content export.

In some PDF documents these mappings are incorrect or corrupted. You can train 
FlexiPDF to deal with particular mapping problems as they arise. This training does 
not fix the PDF but does enable editing, content export and translation.

Choose Text > Remap Fonts to open the font mapping dialogue box.

The dialogue box is similar to the Character Palette dialogue (see “Inserting special 
characters” on page 60)

The ‘meaning’ of the selected glyph. 
When editing or exporting, FlexiPDF 
will treat the glyph as if it were 
Unicode 38.

The glyph shape “6”

Pro

Currently maps to ‘&’  
(an incorrect mapping) 

Mapping contained in the PDF. 
(May or may not be correct)

Bad or missing mapping.

User supplied mapping. 
(A remapped glyph)

The mapping for each glyph is shown in 
one of three colours:

Continued...
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Continued from previous page

Editing font mappings
The quickest way to edit or fix a font map is to select the first incorrectly mapped 
glyph in the map, then press the key to which is should map. The mapping will be set 
and the next glyph will be selected. Repeat until all incorrect glyphs are mapped.

In this example. 6 characters have already 
been re-mapped. The selected glyph has 
moved into ‘h’. 

Press ‘h’ on the keyboard to change the 
mapping to ‘h’.

The mapping for ‘h’ has been recorded and 
now, the ‘e’ glyph has been selected.

If the destination character cannot be 
entered from the keyboard such as fi (latin 
small ligature fi) then enter it’s Unicode 
value into one of the edit boxes - FB01 is 
the code for fi  in hexadecimal.

1

2

Notes
•	 Mappings are stored in a mappings file maintained by FlexiPDF. 
•	 Mappings are applied whenever a document with a matching font is opened.
•	 Mappings are used during editing and when exporting PDF to other formats.
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Numbering pages
You can renumber a range of pages by cloning a page number text field on each page 
in the range using the cloning facility. Each time the text field is placed on a page in 
the range, it is incremented by one.

Page number fields do not update when pages are added or removed from a PDF. 
Instead you should re-clone the numbering on the affected pages.

See “Cloning objects across pages” on page 98 for details of cloning objects (not 
just page number fields) across pages.   

In this example we want to have a 
numbered footer at the bottom of each 
page, of the form (Page n).

Using the Text tool, create and edit 
the footer on the first page of the 
range.

Choose Text > Insert Page Number to 
insert the text field where the page number 
should be.

Choose the Numbering Style for the 
number. 

Note that whatever format is chosen, the 
font used must encode all the characters 
that will be required as the number 
changes across the page range.

You can verify this by looking at the font 
using the character palette (choose  
Text > Character Palette).

Finally, specify the Numbering Offset.

In the example shown, a numbering offset 
of -3 has been given which means the first 
page number generated will be 1.

Since it is being inserted on physical 
page 4 of the PDF, with a numbering 
offset of -3, the first page number 
generated will be 1.
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Cloning objects across pages
FlexiPDF can replicate a selection of objects across a range of pages. The objects are 
placed at the same position on each page in the range, on top of any existing contents. 
This facility can be used for adding repeating page furniture such as logos, headers, 
footers and page numbers.

Using the Line tool add a horizontal 
line to the top of the page. Use Copy 
and Paste to place a similar line in 
the footer region.

Both lines are then selected using 
the Object tool (by clicking on each 
line whilst holding Shift to add to 
the selection).

Choose Edit > Clone Across Pages.

This example will show how to add a 
header and footer rule plus a page number 
to a 300+ page book.

New header rule (horizontal line)

New page number 
style, replacing existing 
number.

New footer rule

1
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Continued...
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Next, specify the range of pages to be 
covered. In this case we wish to place the 
borders on all pages from 3 onwards.

You could restrict the range to even or 
odd pages only if you wanted to apply 
different graphics to each set of pages.

Selected Delete existing objects to remove 
any existing lines at this position before 
placing the new lines. 

In this example, we are going to change 
the style of the page numbering - currently 
a simple number.

Selected the existing page number 
using the Text tool and insert “Page” 
in front of the number.

Then delete the original number (“4”) and 
choose Text > Insert Page Number which 
will display the page numbering dialogue.

Choose the numbering scheme for the new 
page number.

You can also provide a Numbering Offset 
that gets added to the page number. Leave 
this as 0 for no offset.

Press OK to insert the page number.

2
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Continued...
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The finished format, showing the page 
number, all centre aligned. 

The number is actually a field which is 
why FlexiPDF shows it highlighted. This 
highlighting does not affect the PDF and 
can be turned off by choosing View > Text 
> Field Shading.

During the clone operation this field will 
update as it is copied to each page in order 
to show the correct page number.

The final change is to change it to an italic 
version of the Constantia font. 

Since the page number field will be cloned 
across a wide range of pages, all numbers 
from 0-9 will eventually be needed. 

We need to ensure the font we choose has 
all numbers otherwise the cloning process 
will fail part way through.

You can check the characters available in a 
font by choosing Text > Character Palette.

Carefully select both lines and text 
using the Object tool, clicking on 
each whilst holding Shift to ensure 
they are added to the selection.

Choose Edit > Clone Across Pages.

Page with top and bottom 
lines plus page number 
selected.

5
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Continued...
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Select the Page range for the operation. 
In this example, we will be cloning from 
page 3 onwards, even though we drew the 
original items on page 4.

Select Delete existing objects to ensure 
that any existing page numbers are 
removed before applying the new version.

Press Clone to begin the process.

FlexiPDF will show the progress of the 
operation as it goes.

Every 100 or so pages, the partially 
complete document will be saved to disc 
(under a new name) and the process will 
resume.

The finished document will also have a 
new name.

Notes
•	 Page number fields are not updated when pages are inserted or deleted in a document. 

To update page numbers, perform the clone operation again ensuring that Delete 
existing objects is selected.

•	 Hyperlinks and annotations are excluded from the cloning process.
•	 If you want a different object for even and odd pages, perform the clone operation 

twice, once with the odd-page header and restrict the page range to odd pages only 
(see step 2 above) then again with the even-page header with the page range restricted 
to even pages only.

8
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Continued from previous page
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Deleting objects across pages
FlexiPDF can automatically delete objects in the same location across a range of 
pages. This is very handy for removing unwanted logos, header, footers or other page 
furniture.

You are strongly advised to make a backup of your document before using this 
facility.

Select the object(s) to be deleted 
using the Object select tool.

In this case, a single logo has been 
selected that repeats across most of the 
document.

Any objects matching or entirely 
contained within the individual bounding 
boxes of objects in the selection, will be 
deleted from the pages you specify next.

Choose Edit > Delete Across Pages.

Choose the page range you wish to affect 
and whether you want to limit the process 
to just even or odd pages.

Press Delete.

You can halt the process part way through 
by pressing Stop.

1
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Converting text into vector outlines
To ensure that a PDF prints correctly and avoid any possibility of font problems at the 
printer, you can convert text to vector outlines. 

Some points to note about the conversion:

• converted text will no longer be editable or searchable by FlexiPDF or any other 
application without the intervention of OCR

• outlined characters will not benefit from font hinting which is used when viewing at 
low resolutions. However, at the kind of resolutions used by printers, font hinting is 
not necessary.

• after conversion, you are guaranteed to avoid all font related printing problems 
since fonts will no longer play a part in the PDF (it will just be pages of line-art).

• the conversion encompasses all text across all pages of the PDF and cannot be 
undone.

To covert text to outlines choose Text > Create Outlines.
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Clipping mask creation
Any object or group of objects can have a clipping mask applied. The mask ensures 
only parts of the object are visible. This is often useful for images where you may 
want to hide the background for example.

3

2

1

In this example, we want to apply a 
clipping mask to the image of the car.

A shape is drawn using the drawing tools.  

This shape will be used to make the 
clipping mask.

Any path may be used as clipping path, 
not simply those created using the built-in 
drawing tools.

With the new shape selected, choose 
Object > Clipping Mask > Convert To Clip.

The shape will then become a pink 
outline.

Now select both the clip path and the 
image and choose  
Object > Clipping Mask > Add To Clip.

Pro

Continued...
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Notes
•	 Any empty clipping masks are automatically removed when a PDF is opened.
•	 Clip paths have no line width, fill or stroke colour
•	 Clip paths can be moved independently of the objects being clipped.
•	 To add multiple objects to the clipping path, group them first using Object > Group.

Continued from previous page

4

The image has now been added to the 
clipping mask. The parts of the image that 
are “outside” the mask are not displayed.

You can still move the mask and objects 
within it independently.
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Clipping mask removal
Clipped objects can be moved independently of their clip masks. Objects can also be 
“popped” from their clip masks revealing the entire object.

Choose the Object tool.

The car image (selected) is clipped 
by the oval clipping mask (shown 
in pink).

To remove the image from its clipping 
mask choose : 
Object > Clipping Mask > Remove From Clip.

The image is now fully visible. 

The clipping mask still exists and is shown 
in pink behind the image.

1

2

Note
•	 Clip masks only become visible (outlined in pink) when the Object Select tool is 

active.

Pro
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Editing Tabular Data
To make it easier to edit text in tables without disturbing layout, mark-up the tabular 
region with a Table Box. See “Exporting tabular information” on page 191 for details 
of how to do this.

For maximum effect, it is best to do the marking-up of tables before you begin your 
first edit on the page.

FlexiPDF will try to make each cell into a separate paragraph. Though this will assist 
with editing, it is not a full table editor but just a collection of text boxes. If you need 
to add or move rows, use the Object tool to select and move columns or rows of text 
boxes. 
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Notes
•	 If you have a word selected when the dialogue box opens, the word will be copied into 

the Find box automatically.
•	 Be careful when changing text in paragraphs with unusual shapes (such as those that 

flow around graphics). When paragraphs are reflowed, their layout may be altered. See 
“Flowing text around graphics” on page 88 for methods of avoiding this.

Find & replace text
Use the Find and Replace dialogue boxes to search for and replace words  
and phrases in a text selection, across a range of pages or throughout an entire PDF.

During text replacement FlexiPDF will reflow the affected text. It is important you 
tell FlexiPDF how you want the text reflowed as, depending upon your document, it 
may drastically alter its layout. See “Text reflow modes” on page 120 for details.

If you need to target text written using a particular font or text style, see “Find & 
replace text styles” on page 113.

Check this box if 
capitalisation is important 

to your search

Press to see 
previous searches 

Unchecked, a search 
for “in” would match 
“running” and 
“ingrowing”

Type the word(s) you 
are searching for 

here.

Click here 
to limit 

searching to 
specific pages

Opens an 
interactive listing 
of all found text

Standard
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Find & replace fonts
FlexiPDF can change the fonts used throughout a document using the Find and 
Replace Font dialogue box. This dialogue offers a simplified interface to the more 
sophisticated facilities of the Find & Replace dialogue in FlexiPDF Professional.

Before doing a font replacement ensure 
that you have a recent backup of 
your document since the operation is 
potentially disruptive.

To begin choose  
Edit > Find & Replace > Replace Font 
or choose Document > Fonts then select a 
particular font and press Replace.

Choose the target font from any of those 
currently used in the document.

Alternatively, you can enter a wildcard 
expression in order to match a family of 
fonts. 

For example, Times* will match all fonts 
whose names start with Times such as 
Time-Roman, Times-Roman Italic etc.

F? would match all two-letter font names 
such as F0, F1 etc.

Continued...

1

2
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Continued from previous page

Choose the replacement font from the 
drop-down list. You may choose any font 
currently used in the document or any 
system font on your computer.

Whatever font you choose, especially if it 
is one currently used in your document, 
be aware that it may not have all the 
characters (glyphs) needed. FlexiPDF will 
warn you during the replacement if this 
occurs.

Click Replace All to begin the operation. 

FlexiPDF will process the entire 
document, examining all text. If you 
want to restrict the process to a specific 
page range, text box or text selection, 
use the advanced features of the Find & 
Replace dialogue available in FlexiPDF 
Professional

Hit the Stop button at any time to abort the 
process.

3

4

Once finished, FlexiPDF will report the 
number of runs of text that were modified.

If more than 100 pages were processed, 
FlexiPDF will have saved the document as 
it went along, renaming it each time. 

Save the finished version now. 

5
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Find & replace text (advanced)
FlexiPDF Professional’s Find & Replace dialogue box is a more sophisticated version 
of that offered by FlexiPDF (see “Find & replace text” on page 109). Not only can 
you search and replace text, you can modify the styles of text and change the contents 
of hyperlink URLs. 

Pro

See “Find & replace text 
styles” on page 113 for 
details of the Find: and 
Replace: check boxes.

Click the hyperlinks to limit 
searches to a particular style 
and to set the style of the 
replacement text

Check to activate wildcard matching.  
Available wildcards are:  
	 *	 to match zero or more characters  
	 +	 to match 1 or more characters 
	 ? 	 to match a single character

When a result is found, the page can be 
zoomed to ensure the text is large enough 
to read. Disable this if you want the page 
zoom to remain fixed.
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Find & replace text styles
You can restrict your target text by font, colour or size. You can also dictate the 
font, size and colour of the replacement text. You can even change the style of text 
without changing the text itself (more flexible than “Find & replace fonts” on page 
110).

Before doing any kind of replacement operation ensure that you have a recent 
backup of your document since automated operations are potentially disruptive.

Minion-Italic, 7 point 

1

2

Choose Edit > Find & Replace > Replace to 
open the Replace dialogue box.

The selected text will appear in the Find 
box.

To change all the character names in a 
Shakespeare play so that they appear in 
blue.

Using the text edit tool, select an 
example of the text to be changed. 

To find all text with the same style, 
uncheck the Find check box. The target 
text will grey-out.

Continued...

Next, click on the Character format 
hyperlink to open the formatting dialogue 
box.

3

Pro
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Whenever a format is active for a search, 
a brief summary of the styles chosen is 
shown next to the Find: text box.

3

Continued from previous page

4

The Find Format dialogue reflects the 
formatting of the text from your initial 
selection, though it remains inactive until 
you press OK.

Press OK to activate the formatting.

Click on the hyperlink next to the Replace 
text box to open the Replace Format 
dialogue box.

5

The Replace Format dialogue box displays 
the formatting of the initial text selection.

Click on Apply Style since we want to 
change the colour of text.

Click on the Fill colour check box to 
enable the colour picker button next to it. 

Click on the colour button to choose a new 
colour.

(In the example image a blue colour has 
already been chosen)

6

Continued...
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7

Continued from previous page

Reflow and alignment changes should 
be kept to a minimum (we only want to 
change text colour).

Ensure that Reflow is New Text Only and 
Alignment is Left.

Then press OK to activate the formatting.

8

Uncheck the box next to Replace. The 
replace text box will grey-out.

This means we do not want the text itself 
changed, only its style.

Press the OK button to activate the format 
settings.

The Replace dialogue box 
should look something like 
this.

Press Replace All to start 
the process which may take 
some time to finish.9

Continued...
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Continued from previous page

Once finished, all character names have 
been changed to blue throughout the PDF.

The same technique can be used to change 
the font, font size or stroke colour of 
specific text.

10

Notes
•	 To remove any Find formatting click the formatting hyperlink next to the Find text box 

and set both Font & Font Size to Any then uncheck both colour check boxes.
•	 Replace formatting can be disabled in the same way as detailed above.
•	 FlexiPDF will save a partial copy of the PDF every 100 or so pages during a long find 

& replace operation.
•	 To cancel a find & replace operation, press Escape or close the dialogue box.
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Find & replace in bookmarks
To search through or replace bookmark titles in the current document:

Ensure the bookmarks panel is visible by 
choosing View > Bookmarks.

Click on the Binoculars icon in the toolbar 
inside the bookmarks panel

If text is selected in the current document (using the Text tool) when the binoculars 
button is pressed, it will be copied into the Find text box ready for searching.

Check to activate wild card matching. 
Available wild cards are:  
	 *	 to match zero or more characters  
	 +	 to match 1 or more characters 
	 ? 	 to match a single character
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Find & replace in comments
To search through or replace comments in the current document:

Ensure the comment panel is visible by 
choosing View > Comments.

Click on the Binoculars icon in the toolbar 
inside the panel.

If text is selected in the current document (using the Text tool) when the binoculars 
button is pressed, it will be copied into the Find text box ready for searching.

Check to activate wild card matching. 
Available wild cards are:  
	 *	 to match zero or more characters  
	 +	 to match 1 or more characters 
	 ? 	 to match a single character



	 Find & Replace	 119

Find & replace in hyperlinks
You can perform find and replace operations on the content of hyperlinks in the 
current document. This can be useful for changing the web address of hyperlinks.

You can also perform hyperlink replacement across files - see “Find & replace in 
files” on page 125.

Pro

Choose Edit > Find & Replace > Find and 
Replace in Hyperlinks.

For example, entering “http:” into the 
Find text box should match all web-based 
hyperlinks in the page range.

Press Find All which will begin the search 
and open the Find Results window.

As the find progresses, results will be 
added to the Find Results window.

Once finished, double-clicking on a result 
will display the hyperlink in the main 
window of FlexiPDF.

1

2

Check to activate wild card matching. 
Available wild cards are:  
	 *	 to match zero or more characters  
	 +	 to match 1 or more characters 
	 ? 	 to match a single character

Click here 
to limit 

searching to 
specific pages
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Text reflow modes
FlexiPDF offers three modes for controlling the 
way text is reflowed during search and replace:

•	 New Text Only
This mode is useful when dealing with tabular 
data, headers, footers or other single lines where 
retaining the original spacing and gaps between words is important. 

The minimum reflow is done. The new text is left, centre or right aligned within the 
space occupied by the text being replaced.

In this mode, you may end up with words printed on top of each other if the 
replacement text is much longer than the original.

•	 Containing Line Only (default mode)
This mode is useful when you wish to cause minimum changes to existing 
paragraphs whilst ensuring changed lines blend in correctly. 

Only the line(s) containing the search text will be reflowed after replacement. Lines 
can be left, centre or right aligned regardless of the alignment of their paragraphs. 

The auto option will use the containing paragraph’s current alignment.

•	 Containing Paragraph
The entire paragraph (and those near it) may be reflowed according to their current 
alignment. You cannot dictate the alignment used in this mode.

If a paragraph grows longer after reflowing, some of the text may become ‘overset’ 
(See “Overset text” on page 59). This is signified by a red square on the bottom-
right edge of the text box. You may need to make the text box bigger to accommodate 
the text once the search and replace is complete.

Reset Letter Spacing
When only the font is changed as a result of a search & replace operation the existing 
letter spacings may not be appropriate for the new font.

Checking Reset Letter Spacing will cause both inter-character and inter-word spacing 
to be set to 0 for every character affected.

Continued...

ProStandard
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Reflow: New Text Only

1

In this example, the header text is to be 
altered whilst retaining the gap between 
the page number and the text.

Choose the Edit > Find & Replace > Replace menu item. 

Fill in the Find and Replace text boxes.  
Press the blue, underlined hyperlink next to the Replace text box. 

To ensure that the new text is right-aligned 
and that the page number is left where it 
is -

Choose New Text Only from the Reflow 
pop-up menu

Choose Right from the Alignment pop-up 
menu

Continued...

2

3

Continued from previous page
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Editing Graphics                 13

	        Editing Graphics 13

        Editing Graphics         13

Align: Left 
New text is aligned with the start of the 
old text. If new text is longer than old, 
it may overflow and collide with page 
number.

Align: Centre 
New text is aligned with the centre of the 
old text. If it becomes longer it will extend 
beyond the original left/right bounds of 
the old text.

Align: Right 
New text is aligned with the end of the 
old text. If new text is longer than old, it 
may extend beyond the left extent of the 
original text.

Editing Graphics 13
Reflow: Containing Paragraph 
The entire line is reflowed and left 
justified. The page number is moved 
during the reflow.

Reflow: New Text Only

Editing Graphics & Images 13Original text

Continued from previous page

Continued...
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To make room, the words have been 
moved closer together on the first line. 

None of the other lines has been altered.

2

“Cigar Club” -> “Old Smoking Society”

There is not enough room for the 
replacement text on the line so words have 
begun to run-in to each other.

This is the same replacement using 
Alignment: Left. 

The text has grown beyond the edge of the 
text box.

Potential Problems

Reflow: Containing Line Only
“Cigar Club” -> “Smoking Society” 

In this example, “Cigar Club” is replaced 
by “Smoking Society”, reflowing only one 
line of the paragraph.

1

Continued from previous page

Notes
•	 Use Reflow: Containing Paragraph option only if you are confident that reflowing the 

paragraph will not destroy any existing indentation or special layout.
•	 When using Reflow: New Text Only the new text may collide with existing text if it is 

longer than the original text.
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Find & replace in long documents
During find & replace in a long PDF (more than 200 pages), FlexiPDF will save the 
partially-complete PDF every 200 pages.

On completion, the finished PDF MyDoc.pdf will be renamed MyDoc-01.pdf. The 
original PDF (before the find & replace) will remain unchanged.

If you perform further search and replace operations on the new document, it will be 
renamed MyDoc-02.pdf and so on.

ProStandard
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Find & replace in files
FlexiPDF Professional can automatically perform a Find & Replace (text or 
hyperlinks) operation on multiple files. 

Choose Edit > Find & Replace > Replace In Files to open the dialogue. There does not 
have to be a document already open in order to access the dialogue.

Upper part of the dialogue 
is like the Replace dialogue 
box. See “Find & replace text 
(advanced)” on page 112 
except that it also includes a 
‘hyperlinks’ check box.

Lower part of the dialogue 
is where you add files to be  
searched.

Click to add files to the list

Continued...

Deletes files from 
the list (does not 
delete them from 
disc)

1

2

Click to add all the 
PDF files in a folder 
(and its sub-folders)

Pro

Click to open and view the 
selected document.  
If already processed, FlexiPDF 
will open the processed 
version
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Continued from previous page

Once your search has been setup and you 
have added some files to the list, press 
Replace All.

The Setup Folders dialogue will open.

Supply a location in which to save the 
processed files. 

If you do not use this option, your original 
files will be over written (a backup will 
not be made). 

You are strongly advised to ensure you 
have a backup of the original files.

You may also give an optional folder for 
error files. 

Errors can occur when there is no suitable 
font for substitution for example.

3

4

5

Continued...

Setup Folders
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During the search, the dialogue shows the 
number of changes made, and current page 
being searched.

When doing Find In Files, pressing Show 
Results will display the results list. This 
list is updated as the search proceeds. 

Once the search has finished, double 
clicking on a result will open the relevant 
PDF and show the text.

Continued from previous page

6

The current PDF being searched is 
highlighted in the list of files.
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Find & redact
FlexiPDF can redact all occurrences of words and phrases throughout a document. 
This redaction is deep and also occurs in bookmarks, comments and any other meta-
data contained within the document.

The redaction becomes permanent only after the document is saved.

Pro

Select the text to be redacted then choose 
Edit > Find & Replace > Redact All or press 
Ctrl+Alt+R

1

2

Press Redact Next to do one 
redaction at a time.

Press Style to alter the colour 
used for redaction or to apply 
a label.

Check to activate wild card matching. 
Available wild cards are:  
	 *	 to match zero or more characters  
	 +	 to match 1 or more characters 
	 ? 	 to match a single character

Apply a colour or label to redacted text. 
The style is applied to new redactions 
only.
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Thumbnail View
All of the page manipulation functions can be found in the Documents > Pages sub-
menu. Many also appear on the thumbnail view’s toolbar. 

Sometimes it may be easier or quicker to use the thumbnail panel rather than the 
main menu to access these functions. For example, deleting a range of pages by 
selecting multiple thumbnails then pressing the delete button.

Delete pages

Replace pages

Extract pages

Insert pages from scanner

Insert pages from another PDF

Create new (blank) pages

Rotate pages

Many of the toolbar buttons can be applied to multiple pages. To select multiple pages 
in the thumbnail panel, click on the first page in your range, then press the Cursor Up 
or Down keys together with the Shift key to extend the selection.

You may only select adjacent pages.

To show the thumbnail panel, choose View 
> Thumbnails.

It may take a moment to render the 
thumbnails for a document. 

The thumbnails represent the state of each 
page when first loaded, not necessarily 
their current state after editing.
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Cropping Pages
Trim the size of a page or range of pages using either the Crop Tool or the Auto-
Crop facility.  Cropping does not remove anything from a PDF, it just limits what is 
displayed by PDF viewers and printers.

Using the Crop Tool
Select the crop tool from the toolbar then drag-out a box to represent the area 
that will remain after cropping. You do not need to drag out exactly the right 
shape since you can resize the box after the initial drag.

When you are happy with the area covered, press Return on the keyboard.

Crops can cover a range of pages. 

You may also restrict cropping to only 
even or only odd pages - handy when 
your pages need different crops for book 
binding.

If the Set Page Media Box check-box is 
checked, this value will be set to match 
the crop. This setting is probably not 
relevant to most PDF users.

Auto-Crop
Choose Document > Pages > Auto-Crop to reduce the size of a range of pages to match 
their contents. For example, if a page contained only a photograph and a caption, then 
after auto-crop, the crop region would be set to the bounding box around those two 
objects.

Relaxing on the beach Relaxing on the beach

Pro
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Inserting new pages
You can insert any number of new pages into any PDF document.

Open a PDF then choose Document > Pages > Insert New  from the main menu bar.

1 432 5

Choose how many new pages you 
want to add (the default is 1).

Choose whether you want to insert 
the new page before or after an 

existing page.

Inserting a new page 
After the First Page

Inserting a new page before 
Last Page

Notes
•	 The size of new pages is determined by the page being viewed when the instruction is 

given.

Choose Use Current Size to make 
the new pages the same size as the 

currently displayed page.

The remaining options are the same 
as those in the New Document 

dialogue box.

ProStandard
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Reordering pages
A page or group of pages may be moved from one part of a PDF to another. You may 
have to alter page numbers printed on the pages after relocating.

You can re-order using the dialogue shown below, or by dragging page thumbnails in 
the Thumbnails pane. Choose View > Thumbnails to make the pane visible. Then select 
or Shift-select (for multiple) pages and drag them to a new point in the thumbnail list. 

213 4 5

5431 2

Open a PDF and choose: 
Document > Pages > Re-order.

Choose the range of pages you wish to 
relocate.

Then choose where you want them to be 
moved to.

Relocating pages 1 
and 2 to page 4.

ProStandard

Using the Re-order Page dialogue

Notes
•	 See “Numbering pages” on page 97 for details of re-numbering moved pages.
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Resizing pages
A page or group of pages can be resized. This scales all objects on the page then 
adjusts the media box (paper-size). 

11.00 in

8.27 in

Open a PDF and choose: 
Document > Pages > Resize.

Choose to scale X & Y axis independently 
or click Constrain Proportions to maintain 
the aspect ratio.

Choose the units for scaling - percent,  
inches, points or centimetres

This illustrations shows a page being 
resized by 50% on both axes.

4.13 in

5.50 in

Uncheck this box to re-size the page only; objects 
on the page will not be altered. This is especially 
useful for re-sizing empty pages.

ProStandard
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Inserting pages from other documents
Pages from one document can be imported into the current PDF. There are two 
methods for doing this:

With your PDF already open, choose 
Document > Pages > Insert From Document 
then choose the PDF you wish to insert 
using the file selection dialogue.

Or

Drag & drop a PDF file onto your open 
document.

After dropping the file, choose: 
Insert the PDF.

1

Continued...

ProStandard

2

3
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1 432 5

4

Finally, specify where you want the new 
document inserted.

Inserting a group of pages 
After the First Page

Inserting a group of 
pages Before the 
Last Page

Continued from previous page
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Placing a page from another document
You can place the contents of an entire page from another PDF into the current page 
of your PDF. There are two ways of doing this:

Method 1:

1

You can drag & drop a PDF file onto your 
open document to place a page.

You will then have the choice of opening 
or inserting the new PDF.

Choose the Place a page option then press 
OK.

With your PDF already open, choose:  
File > Place PDF.

Then choose the PDF you want to place.

If the PDF you are placing has multiple 
pages, choose the page you wish to place 
(if it has only one page, you will not be 
prompted to choose)

1

2

3

Method 2: Drag & drop

Pro
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Inserting pages from a scanner
You can use your scanner to insert pages into an existing PDF or create an entirely 
new PDF by using File > Create From Scanner. The two operations a use very similar 
dialogue boxes.

1

2

With your PDF already open, choose:  
Document > Pages > Insert From Scanner.

Choose your scanner from the Device: list 
of available input devices.

If your device is an automated document 
scanner capable of scanning many pages 
unattended, change Source to Automatic 
Document Feeder.

Next choose where you want to new 
page(s) to be placed. By default they will 
be inserted after the last page.

This section of the dialogue isn’t visible 
when using Create From Scanner.

Pro

3

If Recognise Text (OCR) is enabled, 
FlexiPDF will try to convert any text 
found in the scan into “real” text and not 
just an image of text.

If you only want the image itself, if the 
image is a photograph for example, do not 
check this option.

4

If you want to be able to easily edit the 
recognised text and make use of it again, 
choose Editable Text as the PDF Style.

If instead, you want the PDF to be 
searchable but to look as close to the 
original as possible, choose Searchable 
Image. 

Continued...

*OCR = Optical Character Recognition
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Continued from previous page

Comparing PDF styles when using OCR

In a Searchable Image, only the scanned image 
is displayed. Text that has been recognised in 
the scan is placed out-of-sight, behind the image 
where it cannot be seen, but can still be indexed 
and searched.

Often there will be mistakes made by the 
recognition process which could causes searches 
to be inaccurate. You can correct these mistakes 
using the OCR corrections facility. See “OCR 
corrections” on page 14 for details.

Original Page

scanned...

scanned...

Searchable Image

Editable Text

The OCR process tries to recognised text 
in the scanned image and converts it to 
real, editable text. 

Diagrams and graphics in the original will 
not be preserved. Photos and screen-shots 
may be preserved though not always.

The text can be edited and reused just as 
text in a normal PDF.

✓ Text is easily edited 
✓ Small file size 
✓ Searchable

✘ Original look is lost

✓ Retains original look of document 
✓ Searchable 
✘ Larger file size 
✘ Not easily edited.
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Page margins
FlexiPDF Professional can add margins to a range of pages to make editing easier. 
These margins act as fixed guides. See “Layout guides” on page 49 for an 
explanation of how guides work.

Pro

Choose Document > Pages > Margins.

Enter your required margins in the boxes. 
Checking Tie values together ensures that 
all boxes have the same value. This works 
when you move from one box to the next 
by pressing tab or clicking the mouse.

Notes
•	 To change the units used (cm in this case), close the dialogue and choose  

File > Preferences and click on the Editing tab.
•	 After adding margins, they will become visible on all pages. Choose  

View > Grid & Guides > Hide Guides to hide them.
•	 Margins, like other guides, are retained in the PDF for FlexiPDF to use next time you 

edit the document. They will have no affect on and will not be visible in any other PDF 
viewer.
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Watermarking pages
You can apply a fixed watermark to the foreground or background of the pages in a 
document. The watermark itself is defined in another PDF and can contain anything 
you like such as a logo or text.

With the document to be watermarked 
already open, choose: 
Document > Watermark > Add.

Into From PDF enter the filename of the 
PDF you wish to use as the watermark or 
press the Browse button.

Press Built in to show the selection of 
predefined watermark PDFs that ships 
with the software. 

If the chosen PDF has multiple pages, 
FlexiPDF will use only the first as the 
watermark.

Choose whether you want the watermark 
to appear in front of or behind the existing 
page contents on each page.

You can also choose to resize the 
watermark so that it fits the pages it is 
being applied to. When resizing, FlexiPDF 
scales the watermark so that it’s crop box 
matches the destination page.

1

2

Continued...

When scaling is enabled, 
the crop box of the 
watermark is scaled to 
match the destination 
page.

If scaling were not used in 
these two examples, they 
would both give the same 
result - picture A.

A

Pro
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Finally choose the page range over which 
you wish to apply the watermark then 
press Apply.

You can have different watermarks for 
different parts of your document.

The finished page with a foreground, 
solid,  “Approved” watermark. 

Continued from previous page

4

5

Notes
•	 Watermarks behave like locked objects. If unlocked, a watermark can be edited as a 

normal object.
•	 A page may contain only one watermark at a time. When adding a new watermark to a 

page FlexiPDF first removes any existing watermark.

The watermark can be shown with various 
degrees of transparency from completely 
solid to very faint.

3
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Page labels
A page label is an optional number or phrase displayed along with each page in 
FlexiPDF or other PDF viewers. It is independent of, though often related to, the 
physical page number printed on each page.

FlexiPDF displays page labels in the status bar.

FlexiPDF status bar showing page label Quick Start: 9

Editing page labels

Pro

Choose Document > Pages > Labels or 
double-click the page label in the status 
bar to open the Page Labels dialogue box.

Clicking on an existing label will copy 
its details into the edit boxes beneath the 
table.

Details of selected 
label shown here

Each label has a Start Page, an optional Prefix (such as “Appendix:”) and a Start 
Number. Labels remain in effect until the start page for another label is reached.

Numbering of labelled pages can be done in a number of ways as shown in the pop-
up list next to the Start Number edit box. 

Continued...

1
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Continued from previous page

Once a label has been modified be sure to 
press Add to store the changes back into 
the PDF.

If the Start Number clashes with an 
existing label, the new details will 
overwrite the existing label. Otherwise a 
new label with that Start Number will be 
added to the list.

Creating new page labels
To create a new label, fill-in the details in the lower portion of the dialogue box 
ensuring that the Start Page number isn’t already used in the table above.  
Press Add to store the new label’s details in the PDF.

3
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Full path name of the PDF 
and its size on disc.

Document properties
A summary of the settings, dates, author and other information about the current PDF 
can be viewed by choosing Document > Properties.

Document meta data.

This data is stored in a non-human 
readable form inside the PDF and also 
as plain text within an XML tag named 

<Properties> nested in another named 
<IceniSetup>.

Click on the Modified date to open the 
PDF’s Change Log.

Click on the Security hyperlink to open 
the Document Security dialogue box.

Click on the User Restrictions: hyperlink to view/
modify the settings controlling how users may edit 
this PDF. 

Resource Page: indicates if the PDF has an 
embedded Iceni resource page. This can be useful 
for distributing PDF templates.

ProStandard

Notes
•	 If the current document is part of a Portfolio the Document > Properties dialogue 

will display the properties of the containing PDF. To see the properties of individual 
documents within the Portfolio, click on the Item Properties  icon in the Portfolio 
panel’s toolbar (View > Portfolio). 

•	 When the selected document within a Portfolio is not a PDF, the Item Properties 
dialogue is truncated to show just the basic properties of the file.
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Security settings
Using PDF security settings you can limit what other people can do with your PDF. 
For example, you can stop other people editing or printing your PDF. 

View current settings
To check the security settings for a PDF, choose Document > Security from the main 
menu.

If the document has been secured, the security dialogue box will display with most 
controls inactive. However the controls still show the current security settings such as 
whether or not editing is allowed.

If enabled, click Unlock to 
change security settings.

Inactive controls show the 
current security settings for 
the PDF.

If the PDF has an existing Master 
password, you will have to enter it now.

If you do not know the password, you will 
not be able to alter any of the security 
settings.

1

2
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Document security
Using FlexiPDF you can add or modify security settings on PDFs. FlexiPDF supports 
the following password-based security levels:

• None 
• Acrobat 3 onwards (48 bit) 
• Acrobat 5 onwards (128-bit) 
• Acrobat 6 onwards (128-bit) 
• Acrobat 7 onwards (128-bit AES)

Acrobat 7 AES security is harder to defeat and offers finer control over the operations 
allowed on your PDF. Older style (Acrobat 5 onwards) security is more compatible.

User Password: 
If set, a password must be entered before the 
PDF can be viewed or printed.

The things other people are allowed to do with 
this PDF.

For example, if you want people to be able to 
add sticky notes without being able to change 
the content of the PDF, choose Editing: 
Comments & Form-filling

Notes
•	 If you forget the User password, you will not be able to open the PDF.
•	 If you forget the Master password, you will not be able to alter the security settings in 

future.

If unchecked, users will have to supply the Master 
password to be able to unlock locked objects. This can 
be useful when distributing templates.

ProStandard

Master Password: 
If set, a password must be supplied before 
changes can be made to security settings.
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Tracking changes
FlexiPDF can highlight text that has been modified during previous editing sessions. 
It also records the date, author and page number of all changes made to PDFs (see 
step 3 below).

1

2

3

Choose File > Preferences.

Ensure Show changed text in is enabled.

You can also choose the colour used for 
highlighting.

Text that has been modified in this or 
previous sessions will be highlighted 
using the colour chosen in the preferences 
dialogue box.

To see a complete history of all pages 
modified using FlexiPDF, choose 
Document > Change Log.

Continued...
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Notes
•	 FlexiPDF cannot highlight text that has been deleted. It will however, record that a 

modification has been made to the page that used to contain the text.
•	 Only changes made with FlexiPDF are recorded.

Continued from previous page

User Guy modified the PDF on Thursday, 25th October, 
2007. No particular page was edited (Perhaps security 
settings were modified.)

User warrenstone modified pages 2 to 25 around 11.14am 
on Tuesday 24th August 2010.
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Document font catalogue
FlexiPDF can list all of the fonts used in a PDF plus additional information about the 
nature of each font.

Choose Document > Fonts to view the font catalogue.

Select a font then click Replace to replace all occurrences of the font in the PDF with 
another. See “Find & replace fonts” on page 110. 

Or press Remap to change the characters mappings of the font. See “Remapping 
fonts” on page 95.

Fonts introduced during the current 
editing session will not appear until 
the PDF is saved.

Names prefixed with “XXXXXX+” 
represent subset fonts (embedded 
with only a subset of their full 
character set).

Font types can include any that are 
supported by the PDF standard - 
TrueType, Type1, Type3, OpenType 
etc.

During editing, FlexiPDF can only 
embed TrueType fonts taken from your 
computer’s system.

If the font is embedded in the PDF it will be 
used and labelled embedded. 

If the font is not embedded in the PDF the font 
substitute chosen by FlexiPDF will be shown. 
This may be from FlexiPDF’s built-in fonts or 
from your computer’s system fonts.

“Yes” indicates 
that the font has a 
built-in mapping to 
Unicode 

The number of 
character shapes 
defined by the font.

Notes
•	 When editing text, choose Text > Character Palette to view all of the glyphs 

contained in a font.
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Flight check
FlexiPDF includes a basic flight-checking function. A check for overset text (see 
“Overset text” on page 59) is always made prior to saving a PDF. 

Two additional checks are available for users of FlexiPDF Professional or for those 
editing a PDF with user restrictions (see “User restrictions” on page 225), these are 

	 • a check for images of less than 300dpi resolution 
	 • a check for non CMYK colour spaces 

Choose File > Flightcheck (FlexiPDF Professional only) to open the Flight Check 
Report dialogue box.

Uncheck to skip tests

Shows the numbers of 
problems found for each kind 
of test  
(even if the test is disabled)

Describes each problem found giving the 
kind of object affected and the page.

When saving a PDF, the flight check 
dialogue always checks for overset text 
(FlexiPDF Standard and Professional).

Press Save Anyway to ignore any problems 
and save the PDF.

ProStandard
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Portfolio Creation
A portfolio (in PDF terms) is a convenient way of bundling a collection of related 
documents into a single container document. The documents in a portfolio need not 
be PDFs but can be movies, audio, images, .doc or .txt files.

Portfolios are a fairly recent addition to the PDF specification and are generally only 
supported by the latest PDF viewers.

Pro

Notes
•	 Though you can add non-PDF documents to a portfolio using FlexiPDF, not all 

document types are supported. If there is a document type you feel should be 
supported, please get in touch using Help > Suggestions.

•	 You can change the order of items in an existing portfolio by picking up and dragging 
the thumbnails within the Portfolio panel.

Choose File > New > Portfolio.

The dialogue is similar to the Join Files 
dialogue (see “Joining multiple PDFs” on 
page 27).

You can add any number of individual 
files to the portfolio. You can also add all 
the files in a folder (and its sub-folders) by 
pressing the Add Folder button.

Change the order of the files by selecting 
one then pressing either Up or Down. You 
can also change the document order after 
the portfolio has been created.

To remove a file from the list, select it then 
press Delete.

Click OK then select a filename for the new 
portfolio document.
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Adding items to a portfolio
Add files to existing portfolios by using Drag & Drop. Once added, you can change 
the ordering of the documents by dragging them around within the Portfolio panel.

Drag documents to 
the portfolio panel 
to add to the current 
portfolio.

Ensure the Portfolios panel is visible (View 
> Portfolio).

Drag & drop additional 
documents onto the panel or press 
the Add Document button in the 
panel’s toolbar.

Deleting items from a portfolio
With the Portfolio panel visible (View > Portfolio), click on the item to be 
deleted then either press the Delete key on the keyboard or the Delete Item 
icon in the panel’s toolbar.

Pro

Pro

Extracting items from a portfolio
With the Portfolio panel visible (View > Portfolio), click on the item to be 
extracted then either press Extract Item icon in the panel’s toolbar. You can 
then specify a filename for the copy of the item.

The original item will not be removed from the portfolio.

Pro
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Comments catalogue
FlexiPDF offers a summary of all comments found in a PDF. This catalogue is 
divided into three sections each containing the same information but sorted by:

•	 Page
•	 Comment type
•	 Author.

•	Choose View > Comments to show the 
comments catalogue.

•	Click on a comment’s entry in the 
catalogue to see the page on which it 
occurs.

•	Click on a comment and press Delete to 
remove the comment from the catalogue 
and the document.

When you edit the contents of the pop-up 
note window, the comments catalogue 
updates at the same time.

Drag and dock the comments panel to 
any side of the main FlexiPDF window to 
make it easier to read.

Drag the panel away from the main 
window to convert it into a floating 
window.
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Sticky notes
You can create new or edit existing “sticky note” annotations in PDFs. These are 
small pop-up windows designed to contain short messages such as approval or 
editorial comments.

Anatomy of a sticky note
Stick note icon. 

This can be moved around independently of the sticky 
note window.

Double-click the icon to toggle the main note window 
open or closed.

Close box

Resize box

Title bar - shows name of note 
author, title, date and time of last 
modification.

Message area 
with scroll bar

Notes
•	 If you can not see the sticky-note window after double-clicking on the sticky note icon, 

try scrolling the page or zooming out. It may be off the screen somewhere.
•	 There are a number of alternative icons available - see Stick Note Properties for 

details.
•	 To change the author’s name assigned to new notes, choose File > Preferences from 

the main menu.
•	 Sticky notes are not included when printing PDFs.

ProStandard
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The sticky note tool is available on the 
Commenting toolbar. To show the toolbar 
choose View > Toolbars > Commenting.

Drag-out a box to denote the size of the 
new sticky note. 

Alternatively, single-click the left mouse 
button to create a standard-sized sticky 
note window.

Creating sticky notes

Deleting sticky notes
Sticky notes can be deleted in two ways:

Using the Hand Tool or 
Sticky Note Tool, click on 
the sticky note icon to select 
it.

Then press Backspace or Delete on the 
keyboard.

a selected sticky 
note icon

1

Using the Hand Tool or Sticky Note Tool, 
right-click on the sticky note icon and 
choose Delete.

2

If you have not already set up a user name 
using File > Preferences, FlexiPDF will 
now ask you to supply one.

This user name will be recorded in each 
sticky note (or other comment) you make.

2

1
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Sticky note properties
Various properties of sticky notes can be modified such as the icon and colour can be 
changed using the Sticky Note Properties dialogue box.

1 Select the Hand tool or 
Sticky Note tool from the 
toolbar.

Click the right mouse button over the 
sticky note icon and choose Properties.

2

Use the dialogue box to change icon, 
colour, title and author.

The modification time cannot be altered 
manually.

Comment

Help

Insert

Key

New Paragraph

Note (default)

Paragraph

Sticky Note Icons
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Graphical comments and notes
As well as simple Sticky Notes, FlexiPDF offers a selection of graphical notations. 
These pair a simple shape with a pop-up note and can be used to draw attention to 
particular items on a page.

An example of a graphical 
comment made using the Circle note 
tool.

If the Commenting toolbar is not already 
visible, choose: 
 View > Toolbars > Commenting.

The default colour for a graphical 
comment is red. This can be changed 
by right-clicking the mouse over the 
annotation shape (not the note window) 
and choosing Properties.

A graphical comment has an optional Fill 
colour, Line colour and a Line width (default 
3 points).

You can also vary the Opacity of the 
comment to allow the contents of the page 
underneath to show through.

Circle note tool selected

ProStandard
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Stamps
FlexiPDF offers a selection of predefined stamps - graphical labels - that 
can be placed, resized and coupled with a pop-up note window. You can 
also define your own stamps (see “User-defined stamps” on page 163). 

An example of a Sign Here stamp and its 
associated pop-up note window.

Stamp tool selected

Adding a stamp to a page
1.	 The Stamp tool is available on 

the Commenting toolbar. To show 
the toolbar choose  
View > Toolbars > Commenting

2.	 Click and hold the Stamp tool icon to see 
the menu of available stamps. 

3.	 Select one of the stamp types then click in 
your page to create a standard-size stamp.

4.	 Alternatively, drag-out a box to denote the 
size of the new stamp. 

5.	 Double-click the stamp to open its 
associated note window.

6.	 Right-click on the stamp to choose the 
Properties menu and alter the opacity of 
the stamp.

Continued...
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Continued from previous page

Using the Hand tool, Object tool or any one 
of the commenting tools, right-click over 
the stamp and choose Properties.

You can change the Appearance of the 
stamp as well as alter it’s Opacity - handy 
if you want the pages contents underneath 
the stamp to show through.

The Appearance drop-down menu will 
only show built-in stamps. User defined 
stamps do not appear.

Stamp properties

1

2a

You can also change the appearance of 
a stamp by selecting it with one of the 
commenting tools then holding down right 
mouse button.

The current stamp style will be show with 
a check-mark next to it. Select a different 
style and the stamp will be changed.

2b
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User-defined stamps
You can tell FlexiPDF to load any number of user-defined stamps from a specific 
folder either on your computer or on a network drive (in order to share stamps 
between users).

A stamp is simply a single-page PDF. and can be created in any application that 
produced PDFs including FlexiPDF itself.

The filename given to each stamp you create is used at the menu title in the User-
defined stamps, sub-menu.

 
Create a stamp using any software capable 
of creating a PDF (or use the FlexiPDF 
printer driver to convert it to a PDF).

Here, FlexiPDF itself is being used to 
create a stamp. 

Create a folder for storing of your stamp 
PDF files. In the next step, FlexiPDF will 
load all PDFs it finds in that folder and 
treat them as user-defined stamps.

Choose File > Preferences > Editing and 
specify the folder in which your stamps 
are stored. 

When you press OK, the folder with be 
scanned for PDFs and any found will be 
listed in the: 
Tools > Stamps > User-defined sub-menu 
as well as in the submenu attached to the 
Stamp tool in the Commenting toolbar.

The folder will be re-scanned every time 
the software is started or if the folder 
location is changed.

Notes
•	 Use Drawing tools to create the artwork for stamps, not the annotation/commenting 

tools which look similar. You can’t create a stamp using annotations or other stamps!
•	 You can use the demo version of FlexiPDF to create stamps.

1

2
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Adding a signature to a page
If you have scanned a copy of your signature, it can be quickly stamped onto a 
document - avoiding the need to print the document and sign it. 

In fact you can define any number of different signatures for this purpose, “his and 
hers” for example.

A signature definition can be constructed 
from an image file or from the contents 
of the current selection (using the Object 
select tool).

To define a new signature, choose 
Edit > Signature > Define.

Choose an image file to use as your 
signature. This can be any JPEG, PNG, 
Tiff or BMP image.

FlexiPDF will make a copy of this file and 
use it in future.

Then enter a name for this signature. 
This is the name that will appear in the 
Signature menu.

We want to add a 
signature here

The signature chosen in this 
example is a high-resolution, 

JPEG, grey scale scan 

Continued...
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Defining a signature from a file



	 Articles, Comments & Hyperlinks	 165

Continued from previous page

Your signatures will be available for use in 
the Edit > Signature > Insert submenu.

After initial placement, the signature 
image will need to be resized.

Whilst holding down the Shift key, drag 
one of the resize handles to scale the 
image, retaining its original aspect ratio.

If you do not hold Shift whilst scaling, you 
may stretch the signature out of shape.

The signature function places the image 
so that it’s white background remains 
transparent.

The finished size of the signature image is 
recorded so that next time the signature is 
used, you should not need to resize it.

Choose Edit > Signature > Delete to delete 
signatures from the menu. This does not 
delete any files from your computer.

Notes
•	 Signatures placed in this way are not annotations in the same way as sticky notes etc. 

They do not have associated pop-up note windows, do not appear in the comments 
panel and are always included during printing. They form part of the page unlike 
annotations which float in a layer above the page.
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Text highlighting
Use the text highlight button to add a coloured, semi-transparent highlight around 
selected text. Like other annotations, the highlight has an associated pop-up note 
window.

Using the Text tool select a span of 
text to be highlighted.

Make the Commenting toolbar 
visible by choosing 
View > Toolbars > Commenting.

Press the Text Highlight button to 
highlight the selected text or press  
Ctrl+G.

The text will be highlighted. To open the 
pop-up note window associated with the 
highlighted text, double-click the text.

Notes
•	 Text highlights are annotations that sit on-top of the PDF page like other annotations. 

They do not track the text they apply to which means that if you edit the text on the 
page after highlighting, the text may move with respect to the highlight.

•	 A similar result can be achieved using the underline facility - this will track edited 
text but does not have an associated pop-up note window.  
See “Underline” on page 66

1

2
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3

Choose the link type from the selection 
available. The Crop Box, Image Box and 
Table Box link types are used during the 
conversion of PDF into other formats (See 
“Exporting Content” on page 184)

Changing the Action Type option will 
cause the bottom section of the dialogue 
box to change.

Hyperlinks
Use hyperlink annotations to create interactive boxes which, when activated by the 
reader, will jump to another part of the same PDF, a different PDF or web address 
(using an external HTML browser).

2

Click on the Link tool button in the 
main toolbar.

Drag-out a box to denote the shape of the 
hyperlink region.1

After drawing the hyperlink box, the Link 
Properties dialogue box is displayed.

The bottom half of the dialogue changes to 
suit the type of link chosen in the top half.

Continued...
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Type: Go To View

Continued...

4a

Choose Go To View

Whilst the dialogue is still open, return 
to the main PDF window and navigate 
to the page and position you want 
displayed when someone clicks on the new 
hyperlink.

Back in the dialogue choose the Zoom: for 
the destination view.

Press OK to create the hyperlink.

4b

Type: Open File

Press Browse to choose the file to be 
opened when the hyperlink is activated.

Next, choose how you want the new file 
opened: in a new window, in the same 
window or leave the choice up to the user’s 
preference (dictated by their own PDF 
viewer’s preferences)

Choose Open File

Continued from previous page
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Specify the destination address.

Web addresses should begin with “http://”

4c

Type: World Wide Web Link

Choose World Wide Web Link

Continued from previous page

Image Box & Table Box annotations
These FlexiPDF-specific annotation types can be used to export images and tabular 
information. There use in this way is detailed in “Exporting Content” on page 184.

They can also be used for automating the extraction of tagged data from laboratory 
reports as part of a LIM (Laboratory Information Management) system. 

Notes
•	 Hyperlinks are annotations that float above the page in their own layer. They do not 

track page contents which means that if you edit the text or move the objects on the 
page the position of the hyperlink may then be incorrect and require adjustment.
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Bookmarks
Bookmarks allow readers to quickly navigate to specific places in a PDF and 
are especially helpful in long PDFs. Using FlexiPDF you can automatically add 
bookmarks to a PDF as well as modify and delete existing bookmarks.

On screen display
To see a PDF’s bookmarks choose View > Bookmarks or press the F9 function key.

Notes
•	 Drag a bookmark on the title of another to nest the bookmark within the other.
•	 Drag a bookmark on the icon of another to move without nesting within the other.
•	 *Standard and Pro modes only

Bookmarks toolbar

Add new bookmark

Delete bookmark

Click on a bookmark to view the 
associated page in the PDF.

Click again to begin editing the title of the 
bookmark.

View/Edit font filters*

Automatic bookmarks*
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Automatic bookmarks
FlexiPDF can create bookmarks automatically. This is especially useful for long 
PDFs that have no bookmarks. 

You can optionally limit the process so that only text written using specific fonts is 
eligible for inclusion in the resulting bookmark tree.

Choose View > Bookmarks to make the 
bookmark catalogue visible.

Navigate to the page from where you wish 
bookmark creation to begin. 

For example, if you wanted to omit the 
document’s table of contents from the 
bookmarks, go to the first page after it 
before starting bookmark creation.

Press the magic wand icon on the 
bookmark panel’s toolbar.

If the PDF already has bookmarks, 
FlexiPDF will prompt you to proceed. If 
you do, all existing bookmarks will be 
removed before the new ones are added.

Press Yes to begin bookmark creation.

Depending upon the length and 
complexity of your document, the process 
may take a little while to complete.

You can cancel the process at any time 
by pressing Stop. Though this may leave 
the document’s bookmark catalogue in an 
incomplete state.

1

2

3

Continued...
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Continued from previous page

In this example bookmark creation has 
produced a fair result. 

It can be improved now by deleting 
unwanted items. 

The stage directions such as [Enter 
a Gentleman] are not wanted and too 
numerous to delete by hand. 

This can be avoided by instructing 
FlexiPDF to ignore the fonts in which they 
are written. See “Bookmark font filters” 
on page 173 for details.

Unwanted items. Use the 
Font filter mechanism to 
avoid adding these stage 
directions.

4



	 Articles, Comments & Hyperlinks	 173

Bookmark font filters
To avoid adding unwanted items to the bookmark tree during automatic bookmark 
creation, you can instruct FlexiPDF to consider only text written in specific fonts. 

Using the Text tool, select some text 
of the kind you wish to include in 
the bookmark tree.

In this case ACT III is the kind of 
bookmark we want.

Press the Font filters button on the 
bookmark panel’s toolbar.

The Bookmark Font Filters dialogue shows 
a list of all the fonts that FlexiPDF will 
consider during automatic bookmark 
creation.

Initially the list contains only one entry: 
All fonts

Any font not mentioned in the list will 
be ignored during automatic bookmark 
creation.

Press Add to filters to add the selected 
text’s font to the list.

Continue selecting and adding fonts to the 
list of filters until you have all those you 
wish for your automatic bookmarks.

To delete a font from the list, select it and 
press Delete.

1

2

3
Continued...
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Continued from previous page

This time the bookmarks have been 
created without any of the stage directions 
and look much more useful.

Notes
•	 The list of font filters is not stored by FlexiPDF and will need to be re-created if you 

close the document.

4



	 Articles, Comments & Hyperlinks	 175

Creating bookmarks
A bookmark records the page number, location and zoom setting used to view the 
page at the time the bookmark was created.

Choose View > Bookmarks to ensure that 
the bookmark catalogue is visible. 

Navigate through your PDF to the page 
you want to bookmark, zooming and 
scrolling to the exact position you want to 
record.

Press the New bookmark button on 
the bookmark panel’s toolbar to 
create a new bookmark.

The new bookmark will be created and 
named “New Bookmark”.

See “Renaming bookmarks” on page 
176 for details of how to rename the new 
bookmark.

1
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Renaming bookmarks

Click on an existing bookmark to select it.

After a short delay, click again to start 
renaming. The name of the bookmark will 
become selected, ready for editing.

Deleting bookmarks

Click to select the bookmark item to be 
deleted.

Press the Delete or Backspace key to 
delete.

Note
•	 If you delete a bookmark item that has sub-items (as shown above), the sub-items will 

also be deleted.

1
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Moving bookmarks
You can move bookmarks to different parts of the bookmark tree.

Click to select the bookmark to be moved.

Drag the bookmark and drop it onto 
the icon of the bookmark you want it to 
appear after.

The bookmark will appear after the 
bookmark you dropped it onto and at the 
same nesting level.

Moving to the top
Move the bookmark you intend to be top 
so that it is second in the list (as shown 
above). 

Then select the first item in the list.

Drag the first item and drop it onto the 
icon of the second item (the one you want 
to be top).

The two bookmarks will switch places.

1

2

3
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Nesting bookmarks
Click on the bookmark you wish to nest.

Drag the bookmark onto the title of the 
bookmark in which it will be nested.

The bookmark is nested within the one on 
which it was dropped.

De-nesting Bookmarks
Click on a nested bookmark you wish to 
move to a lower nesting level.

Drag the bookmark and drop it on the icon 
of any bookmark with the nesting level 
you want.

The bookmark’s nesting will be changed 
so it matches the one on which it was 
dropped.

1

2

3

1
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Article threads
Articles are invisible, linked boxes 
used to aid the reader in following 
the flow of a story through a PDF.

When a viewing application such 
as Adobe Reader detects an article 
thread, it is able to present the text 
boxes in turn for easier reading of the 
complete article. 

Some applications can use articles 
to reflow the PDF or convert and 
export stories into other formats such 
as HTML (see “Exporting article 
threads” on page 194).

There is no limit on the number of article threads a document can have.

Pro

Open the page containing the start 
of the story you wish to annotate 
and select the Article tool from the 
toolbar. 

Carefully drag out a box around the first 
column of text in the article. Continue 
dragging out boxes around subsequent 
columns, changing pages as needed to 
follow the story’s flow.

An article box can be moved, resized or 
deleted after drawing as long as the Article 
tool remains selected.

Continued...

Adding article threads
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When the last box has been drawn, press 
the Escape key to finish the article.

Now select one of the new article boxes 
and choose Edit > Article Thread > 
Properties to display the Article Properties 
dialogue box.

You can also display this dialogue by 
double-clicking on an article box.

The information you supply here is used 
by some PDF viewers to present an article 
catalogue to users so they may choose an 
article to read.

FlexiPDF makes use of Title during export 
of Article threads into other formats 
such as HTML (see “Exporting article 
threads” on page 194)

For details of the Duplicate facility, see 
“Duplicating article boxes” on page 182.

If there is enough room, FlexiPDF 
displays the article’s title in each box plus 
then sequence number of the article.

If there isn’t enough room for both, just 
the sequence number is shown.

Continued from previous page
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Extending existing articles
You can add or insert a new article box in an existing thread.

Open the page containing the 
article box you want to link to 
and select the Article tool from the 
toolbar. 

In this example we are going insert a new 
link between link 2 and 3 of the “Cycle 
Parking” article thread.

Click on box 2 to selected it then click 
again on the plus icon in the bottom right 
hand corner of the box.

To link a new article box to an 
existing box, first click on the plus 
icon in the existing box.

Boxes after the new one have been 
renumbered.

Drag out a new article box.

When you finish dragging, the new box 
will be numbered 3 and the box that 
was formally numbered 3 will now be 
numbered 4.

The new box has been inserted between 2 
and 3.
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Duplicating article boxes
FlexiPDF can duplicate an article box across a range of pages. This is useful when 
you need to form a long article spanning multiple, similar pages such as a book.

Using the Article tool, drag-out a 
new article box to fit the size of 
the content on this page and all 
following pages in the range you intend to 
cover.

If you want this new box to be linked to an 
existing thread, first click on the link icon 
in the bottom right hand 
corner of the preceding 
article box before 
drawing this new one.

Choose Edit > Article Thread > Properties 
to display the Article Properties dialogue 
box.

You can also display this dialogue by 
double-clicking on an article box.

Click on Duplicate and enter the end page 
for the new article boxes to be created.

On pressing OK FlexiPDF will clone this 
article box on every page from the current 
page up to and including the end page 
specified, linking all the cloned boxes 
together.

2
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Deleting articles
You can delete an article box, a range of boxes or an entire article thread. This does 
not affect the content of the PDF (the text in the stories themselves is unaffected).

Using the Article tool select the 
article box to be deleted.

Choose: 
Edit > Article Thread > Delete or press the 
Delete key.

The delete dialogue box gives you the 
option of deleting the entire article thread,  
the currently selected article bead (in this 
case bead 1), all beads in a range of IDs or 
all beads across a range of pages.

We have selected the first 
article box (bead) in this article 
thread.

For example, to delete beads 2 and 3 only, 
you could choose Beads with IDs then 
enter 2 to 3 in the edit boxes and press 
OK.
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Exporting pages
FlexiPDF can convert an entire PDF or range of pages to other formats such as 
HTML and ePub. The conversion reformats the text and images, areas marked for 
rendering and tabular regions. You can export by page range or by article thread (see 
“Exporting article threads” on page 194), individual images or tables.

Open the document you intend to export. 
Choose File > Export > Pages As to reveal 
the Export Pages dialogue box.

Specify the range of pages you wish to 
export.

To change the format of the export or to 
choose whether to export text only, images 
only or both press the Format button.

The various options available within the 
format dialogue are described in “General 
export settings” on page 195

This is a summary of the 
export options currently in 
effect.

Notes
•	 FlexiPDF analyses the pages to be exported and ranks fonts by size to work out what 

should correspond to the various levels of heading (H1,H2 etc) available in the output 
format. For the export formats that rely on this ranking, the results can differ if you 
export a subset of pages to when you export the entire document.

• 	 Use the Crop tool prior to export to exclude parts of the page (for example to stop 
headers & footers being exported).

1
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Exporting images & illustrations
FlexiPDF can export images stored in a PDF into various popular image formats. 

Exporting photographs
Select the image using the Object tool and choose Object > Image > Extract to 
file.

You will then be able to save the image at its full resolution as JPEG, PNG, Tiff or 
BMP.

Exporting graphics
When it comes to exporting graphics made from line-drawings, FlexiPDF needs to 
be told which parts of the page form the illustration.

That is because there is no universal means of determining which parts of a page 
are an illustration and which parts are just normal page contents. For example, is 
the rectangle in the header on this page an illustration to be exported or just page 
furniture?

How do you tell graphics from photographs? 
If the quality of the picture appears to degrade or become more blocky and pixelated 
as you zoom in to it, then it is a bitmap and does not need marking - FlexiPDF can 
detect these without any assistance. 

If however, the quality remains high, no matter how far you zoom, it is probably a 
line-art, composed of vector drawing commands. You will need to mark the area in 
order to export it at its best.

Another approach is to switch to outline mode (View > Outlines). In this mode, 
images are not displayed.

Continued...
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Marking up an image

Choose the Hyperlink tool from the 
main toolbar.

Carefully drag out a box around the area 
to be exported.

Everything included within the rectangle 
you make will be rendered by FlexiPDF 
and included in the export.

In this example an illustration 
including text and a light green 
background is to be exported.

1

After marking out the image, the Link 
Properties dialogue box will appear.

Change the Type pop-up to Image Box.

Enter a title for the table in the Label box. 
This is used during export in HTML 
based formats.

You can now choose to repeat this markup 
across a range of pages. This is useful if 
your document contains a similar image, 
repeated across several pages.

Press OK.

2

Continued from previous page

Continued...
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Continued from previous page

The area is displayed by FlexiPDF 
together with its label.

In this example, the illustration is on a 
light green background - part of original 
page design.

To avoid exporting the background as 
well, use the Object tool to select 
the background rectangle and then 
choose Object > Hide. 

Not only is it hidden from view in the 
main viewing window, it will be hidden 
when FlexiPDF renders the marked area 
for export.

The rectangle can be revealed again by 
choosing Object > Show All. 

Continued...
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Continued from previous page

Exporting individual images
Once a picture has been marked up (see previous page), it can be exported 
immediately and in isolation - without exporting the rest of the page or document. 

Select the Hand tool from the main 
toolbar.

Click on the marked image to 
display the Render Image Box dialogue 
box.

The red image rectangle is only visible 
while the Hyperlink tool is selected.

From the Resolution: pop-up menu, choose 
the resolution to be used for rendering the 
area. Higher resolutions result in better 
image quality, longer rendering time and 
larger image files.

As a guide, 300 dpi is usually sufficient for 
most types of colour printing.

From the Format: pop-up, choose the 
file format for the image.  JPEG tends to 
produce the smallest file sizes. PNG and 
TIFF retain the highest quality.

The file format affects the choice of colour 
depth. The JPEG file format cannot be 
used for purely black and white (bi-level) 
images, so these options will be greyed out 
should you choose JPEG.

Continued...
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Continued from previous page

Finally, choose the Colour Depth to be used 
for rendering.

For most purposes RGB will be the best 
option (full colour).

An example of each of the image formats 
is shown below.

RGB (full colour), 
largest file size

Dithered (bi-
level), small file 
size

Bitmap (bi-level), 
smallest file size

Grey scale

4
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Exporting tabular information
To obtain the best results when exporting tabular information, FlexiPDF needs to 
be told which areas to treat as tables. Without this information, table are treated as 
normal paragraphs and columns resulting in poor output.

Marking up a table
Navigate to the table to be marked up. 

Select the Hyperlink tool from the 
main toolbar.

Carefully drag-out a box around the 
table. Exclude any non-tabular data that 
could confuse the analysis process.

After marking out the table, the Link 
Properties dialogue box will appear.

Change the Type pop-up to Table Box.

Enter a title for the table in the Label box. 
This is used during export in HTML 
based formats.

You can now choose to repeat this markup 
across a range of pages. This is useful if 
your document contains a similar table, 
repeated across several pages.

FlexiPDF will look at the appearance of 
the tabular area, including any borders 
used to delineate rows and columns. In 
some cases, it may be best to ignore these 
lines and analyse only the non-graphical 
content in order to discern the structure 
of the table. In this case, check Ignore 
borders.

Press OK.

Continued...
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Continued from previous page

FlexiPDF will then display the table link 
box together with its label (if there is 
room).

When you next export the document, this 
markup-up area will be treated as a table 
which should improve the output.

The blue table boxes are only visible 
in FlexiPDF when the Hyperlink tool is 
selected.

Exporting individual tables
Once a table has been marked up (see previous page), it can be exported immediately 
and in isolation - without exporting the rest of the page or document. This instant 
approach is the only way to export to SYLK format.

1.	 Select the Hand tool from the 
main toolbar.

2.	 Click on the marked-up table.

3.	 Choose a name for the file into which 
the table will be exported.

4.	 Choose the format for the export.

SYLK (an popular format for encoding 
spreadsheet information) is only available 
when exporting in this instant way.

Shown is the table marked-up in the 
previous page, exported as HTML 4.

The HTML generated by FlexiPDF is 
deliberately kept simply so that it can 
easily be edited or included in other 
documents. 

3
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Cropping for export
To exclude parts of a page from exporting then you can use the crop tool to 
temporarily crop a range of pages in your document. Anything outside of the crop 
box will be ignored during the export.

Use the Crop tool to drag out a box. 
In this example, the page header 
and footer remain outside of the 
box to exclude them from the export 
process.

Once the export has been done, the crop 
can be removed by choosing: 
Document > Pages > Remove Crop.

Notes
•	 The Crop Box hyperlink that can be created using the Hyperlink tool is for use with 

the Argus extraction engine. It is used to specify the automatic crop box applied to 
documents as they are processed.
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Exporting article threads
FlexiPDF can use article threads as a guide to the order in which text is exported 
from a document. For example, a story in a newspaper typically consists of many 
columns of text and may even span multiple pages. By marking each of these as parts 
of a single article in the correct order, FlexiPDF can extract the text in reading order.

For details of how to add articles to a PDF see “Adding article threads” on page 179.

when exporting articles from a PDF, FlexiPDF will also attempt to join-up any 
paragraphs broken across article boundaries. When exporting by page, this joining 
does not occur.

If you have a document which does not output in the correct reading order, the 
application of article threads to the problem areas should improve export of both 
articles and pages.

Open the document you wish to export 
then choose File > Export > Articles As.

FlexiPDF will warn you if there are no 
article threads in the document. In this 
case, you will need to add some before you 
try to export again. See “Adding article 
threads” on page 179 for details. 

Press Format to change the format used for 
the export (HTML, ePub, etc).

If the Create file for every page/article 
option in the Text tab of the Export Format 
dialogue is selected (see “Create file 
for every page / article” on page 199), 
FlexiPDF will write each complete article 
to a different file

Furthermore, when using HTML output 
with article mode, FlexiPDF will produce 
a table of contents linking to each article 
output.

This is a summary of the 
export options currently in 
effect.

The Export Format dialogue box

1
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General export settings
Use this panel to select the main text and 
image output options to be used when 
exporting a PDF. It acts as a short cut for 
changing the major features of output, 
keeping the more specific settings hidden 
in other tabs.

Text Output
Check this item to export the text content 
of your PDF. Either Text Output or Image 
Output (or both) must always be enabled.

Text Format Pop-up
FlexiPDF supports a varied range of text 
output formats including a set of XML 
based formats, plain text and RTF for use 
with Microsoft Word and other applications.

FlexiPDF can also export table data in SYLK format but only when clicking on a 
table that has been marked-up with a Table Box annotation (See “Exporting individual 
tables” on page 192).

Each of the available text formats is described below.

•	 Plain Text
ASCII text, readable with any text editor or word processor. When layout is 
retained using this format, spaces are inserted to ensure words and paragraphs are 
placed into the right location.

•	 RTF
Microsoft’s Rich Text Format, readable by virtually every word processor. An ideal 
input format for Microsoft Office. FlexiPDF can embed all document images in a 
single RTF file.

When exporting to RTF with Retain Layout, you may encounter difficulties if your 
original document’s page size is larger then 55cm (width or height). Some versions 
of Microsoft Word cannot deal with such large page sizes.

Continued...
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•	 Simple HTML
HTML using only a few simple tags. This is readable by all web browsers, but 
some formatting may not be preserved. Images are linked from the document 
rather than shown in-line.

A list of document bookmarks will be output at the top of the first page. If Create 
file for every page/article is active a cover page, a bookmarks page and individual 
contents pages will be produced, each hyper linked together.

When Try to preserve layout is active, this format inserts spaces making use of the 
<PRE> tag in HTML to force the browser to honour every space character.

•	 HTML 3.2
More complex HTML allowing for a wider range of styling. In-line images are 
used. Meta-tags are added to the document using the creator, author and title 
information stored in the PDF. Different character sizes are rendered using the tags 
<H1>, <H2> etc. 

If Create file for every page/article is active, a bookmarks page (if bookmark output 
is enabled) and several data pages will be output. When frames are enabled the 
index page uses frames to show the bookmarks on the left while viewing each page 
on the right.

When Try to preserve layout is active, this format uses a complex HTML table for 
each page. Font sizes in layout mode are selected using the FONT SIZE+/- technique 
rather than <H1>, <H2> etc. since this gives better results.

•	 HTML 4
As HTML 3, but CSS (Cascading Style Sheet) tags are used to render fonts and 
sizes. This should be compatible with most modern web browsers.

If Create file for every page/article is active, a separate file is output containing all 
of the CSS style elements used by the rest of the output pages. Edit this style sheet 
file to quickly alter the look of the rest of the document.

When Try to preserve layout is active, this format uses a complex HTML table in 
the same way as HTML 3.2. However, fonts and sizes still use CSS1 mark-up for 
better results.

•	 HTML 4 CSS
Using HTML with Cascading Style Sheets (v2) provides the most accurate 
depiction of PDF content for the web. When preserving layout all fonts and 
positioning are closely replicated. 

When Try to preserve layout is active, a separate CSS file is produced which 

Continued from previous page
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describes the styles of all fonts used. Edit this CSS style sheet if any adjustments 
need to be made to the look of the converted document. 

•	 ePub
Exports a single .epub file with no digital rights management, with or without 
images using basic formatting.

•	 ePub CSS
Similar to ePub except that the formatting is specified in a separate .css file held 
inside the ePub package.

Right-to-left reading order
When enabled, FlexiPDF assumes the contents of the PDF are to be read right-to-left 
(as is the case in Hebrew). It attempts to replicate this reading order in the output 
produced.

Image Output
Check this item to export the image content of your PDF including those marked with 
Image Box annotations. Either Text Output or Image Output (or both) must always be 
enabled.

Image Format
FlexiPDF supports a range of image formats: JPEG, TIFF, BMP and PNG. Each of 
these formats has different properties and is suitable for a different purpose.

TIFF supports CMYK which may give improved colour fidelity when converting 
magazine and newspaper pictures.

TIFF (multi-page) will place all images within the same file. You will need a TIFF 
viewer capable of handling multi-image files in order to view these correctly.

Convert each page into an image
Check this option to render the contents of each page. When checked, text output is 
disabled since the entire contents of each page will be contained in the image file(s) 
produced.

Place images in sub-folders
This option causes images files to be stored in a sub folder named ‘images’. This also 
affects the path used in the IMG tag for HTML output.

Continued from previous page
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Text export settings
Use the settings on this panel to control 
the way text is output in all formats. 
Additional settings which affect only 
HTML output are grouped separately in 
the HTML settings panel.

The options in the this tab are placed 
into two sub-groups named Text Flow and 
Text Appearance. This is simply to make 
the panel a little easier to read.

Identify image captions
Selecting this option will cause FlexiPDF 
to identify image captions and output 
them along with images, rather than in 
the main body of text. If image output is selected and the image format supports it 
(TIFF, JPEG, PNG), captions will also be embedded within the image data.

Try to preserve layout
In all text formats except ePub, this option causes FlexiPDF to position words as 
closely as possible to the original page layout. The way in which the positioning is 
achieved depends upon the output format used.

Plain text with the layout retained should be viewed without line wrapping in a 
mono-spaced font (such as Courier). Most output text documents will be very wide. 
Simple HTML will be formatted as with plain text using letter spacing to position 
page elements.

HTML 3 and 4 use tables to position page elements. HTML 4 CSS uses the absolute 
positioning functionality available with CCS2. This may not be compatible with 
some older browsers.

With all output formats there may be some deviation from the original document 
layout requiring a degree of manual adjustment. 

Render text in vector artwork
When enabled, text will be included in rendered artwork but not in the normal text 
output stream. When not selected, the converse is true. That is, text will not appear in 
rendered artwork but will appear in the text output stream.

If you find that some text you expected to see in your output is missing, check to see 

Continued...



	 Exporting PDF Contents	 199

if this options is enabled. 

Recognize Speech Marks
When Preserve Line Break is off, FlexiPDF attempts to reflow text into paragraphs. 
The process is fairly reliable but may occasionally make mistakes. 

However, when it comes to reported speech of the kind that may be found in a 
conversation in a novel, it is vital that the correct line-breaks are retained; in speech, 
the line-break is the reader’s main indication of a change in speaker.

When this option is on, FlexiPDF pays particular attention to quotation marks, 
especially those at the beginning of a line or paragraph. The result is that it is much 
more successful in retaining these important line breaks.

When processing documents unlikely to contain any reported speech, it is best to 
disable this option. 

Preserve line breaks
Selecting this option will ensure that FlexiPDF honours all line breaks in the original 
document. Furthermore, it will stop FlexiPDF from removing hyphenation.

Enabling this option can make editing the output more difficult since lines of text will 
not re-flow after insertions or deletions. However, it may improve the appearance if 
layout is important. 

De-hyphenate Words
When enabled, FlexiPDF will rejoin words split by a hyphen at the end of a line. 
Words with hard hyphens such as “442-squadron” are not altered.

To help in making the decision to leave or remove hyphens, FlexiPDF consults the 
language dictionary currently selected for spell checking (see “Spelling preferences” 
on page 245). However, should a particular word be unknown in the dictionary or be 
in a different language, it is possible the software may take a wrong decision. 

When disabled, FlexiPDF does not remove any hyphens and words will remain split 
as they are in the original document. 

When Try to preserve layout or Preserve Line Breaks is enabled, word de-hyphenation 
is automatically disabled.

Create file for every page / article
Cause FlexiPDF to output each page to a separate file. When outputting to HTML 

Continued...
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output files will be hyperlinked together. It is not applicable to ePub output which 
always produces a single file.

When outputting article threads, FlexiPDF will place each article in a separate file.

Hyperlinks
If FlexiPDF detects any embedded hypertext links within a PDF, it will try to retain 
these in the output. This is not possible for plain-text output.

Bookmarks
When enabled, FlexiPDF will retain a document’s bookmarks as hypertext 
destinations in all but plain text output modes.

When disabled, no bookmarks will be output.

Page Breaks
When enabled, FlexiPDF will output the given text at the end of each page produced. 
For HTML for example, <HR> may be used as a simple page break.

Continued from previous page
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HTML export settings
This tab contains options for tailoring the 
way FlexiPDF produces HTML output.

Background
This group of options allows a 
background colour or image to be 
specified for each page output in HTML. 

Whatever is entered in the Colour: box is 
included in the <COLOR> attribute of the 
<BODY> tag of each page output. Colour 
could be the word “yellow” or a colour 
definition such as “#FFFFFF”.

The Image: box is used to enter a 
filename of a image. This name is placed 
into the BACKGROUND attribute of the <BODY> tag for each page. Be careful about the 
name entered here since it will be included exactly as typed. 

The image name need not refer to an actual image on your hard disc but may for 
example, refer to an image which is or will be stored on the computer used to host the 
web pages once they are complete.

Header and footer files
The header and footer file boxes are used to specify files on disc whose contents will 
be merged into each page of HTML output by FlexiPDF. For example you may wish 
to add your company’s own corporate graphics to the top and bottom of each page 
output. 

The contents of the header file will be output just after the <BODY> tag of a page 
but before any extracted text or images. Similarly, the contents of the footer file are 
output just before the closing </BODY> tag of each page.

You cannot type into the text boxes directly so instead use the Browse buttons to 
select existing files. 

Page-to-page links
When FlexiPDF is processing in File-Per-Page mode as set in the Text Settings tab, 
each page of a document is stored in a new file and navigation links to the previous, 
first and next pages are placed on each page for convenience.

The controls in this group allow the appearance of these navigation links to be 
Continued...
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changed. Whatever is entered into either of the Previous, First or Next boxes will be 
output instead of the words “Previous”, “First” and “Next”.

This facility may be useful when converting documents for a non-English speaking 
audience or if navigation images are required rather than text.

Image Borders
When enabled, images will have a border around them generated using the border 
attribute of the HTML <IMG> tag

Frames
This setting only takes effect when bookmark output is enabled (see “Bookmarks” on 
page 200).

When enabled, FlexiPDF creates a two-frame frameset definition which places the 
bookmarks frame on the left hand side of the screen and the extracted content on the 
right hand side. Clicking on a bookmark, changes the page in the right hand side.

When disabled, no frameset is created and bookmark destinations do not reference a 
target frame.

Continued from previous page
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Image export settings
When image output is enabled in the 
General format tab, FlexiPDF produces 
copies of all images stored in the PDF. 

The options in this tab are mainly 
concerned with the scaling or size of the 
images output.

FlexiPDF can deal with two types 
of image in PDF: vector illustrations 
consisting of lines, curves, filled areas 
and bitmap images or photographs made 
up of many colored pixels. 

FlexiPDF cannot output vector formats 
directly but will instead convert any 
such illustrations into a bitmap format by 
a process called rasterization.

Auto-identify vector artwork
Many PDF documents may contain vector artwork or line-art. However, due to the 
nature of PDF, it is not always possible for a computer program to determine where 
on a page such artwork occurs since each page is stored as a general mix of text, 
images and line-art.

FlexiPDF is capable to an extent, of identifying such artwork on a page.  Selecting 
this option will cause FlexiPDF to automatically convert vector artwork in the 
original into images in the output format selected. 

If you are not sure whether a document contains vector artwork or bitmaps, zoom in 
on the picture. If it becomes blocky or pixelated then it is a bitmap image. If it stays 
sharp and detailed, it is probably a vector-based drawing.

If you encounter problems with illustrations not being correctly identified, use the 
Hyperlink tool to mark them up with Image Box links. See “Exporting individual 
images” on page 189 for details. 

FlexiPDF can only output images in bitmap formats not vector graphics formats. If 
images do not appear in your final output documents, try turning this option on or 
placing an image box around the missing images.

Use original OPI name if available
If your PDF contains OPI placement information for the images within it, FlexiPDF 
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will use the original filename for images it exports. 

You can check if an image has associated OPI information by selected the image with 
the object tool, then click the right mouse button and choose Image Properties. 

Image Scaling
This set of options allows you to set the output scaling of the images that FlexiPDF 
extracts from a PDF. 

When disabled, images are output as they are found in the PDF. This may give very 
large images since many PDF documents contain high-resolution versions of an 
image which are then scaled by the PDF viewer to the correct size.

Fix image resolution at:
This option scales output images so that they are all at the same resolution in dpi 
(dots per inch). Resolutions available are: 72, 100, 150, 300, 400, 600, 720, 800 and 
1200 dpi.

This setting is particularly important when rendering vector artwork.

Advanced Scaling Pop-up
Three types of advanced scaling can be selected from the drop down menu. For each 
kind of scaling, if either width or height is set to zero, then an image’s aspect ratio is 
maintained.

•	 Set image size
Enables exact image sizes to be specified in pixels. Images will be sub-sampled or 
expanded accordingly.

•	 Maximum size
Enables a maximum image size to be specified. If an image is smaller than the 
width and height values given then the scaling is unchanged. When Max scaling 
occurs, the aspect ratio is maintained. So, for example an image which is 800 by 
400 when output at a Max of 200 by 200 will be rendered as 200 by 100 - the shape 
of the image is maintained.

•	 Scale
Will resize images according to a percentage value.

Colour depth to use when rendering

Continued...
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This pop-up tell FlexiPDF how to render any marked-up regions during export. It 
also controls how pages are rendered if the Convert each page into an image option is 
enabled in the General tab. It has no affect on the export of non-rendered images such 
as photos - these are, in most cases, output with the colour depth at which they are 
stored in the PDF. 

You can determine the colour depth of images stored in a PDF by clicking on an 
image using the object select tool, then choosing Image Properties from then right-
mouse button menu.

Continued from previous page
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Exporting to LIMS
FlexiPDF can be used together with Iceni’s command-line driven PDF converter - 
Argus, as part of a Laboratory Information Management System to automatically 
extract tagged data from machine-generated reports. 

FlexiPDF is used to create a PDF template containing the tagged annotations. 

This template is then automatically applied to incoming PDF reports by Argus. 

As the reports are dropped into Argus’ hot-folder, it uses the template to extract data 
and convert it to other formats such as HTML, XML or ePub.

Creating a LIMS template with FlexiPDF
Open a typical machine-generated PDF 
report in FlexiPDF.

Using the Link tool, draw a box 
around each item you would like to 
extract. 

An item can be a graph or illustration, an 
entire table or a single word or line of text.

After drawing a box around the object, the 
hyperlink dialogue will appear.

Change the Type to either Image Box or 
Table Box. In this example, we are setting 
up the export of a table of results.

The contents of the Label field will be 
output together with the data when the 
PDF is processed by Argus. Enter a 
meaningful name or tag in the field.

Continued...
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Continued from previous page

The table has been marked-up and tagged 
with the label “Peak Results”.

Notice that the blue annotation border 
does not include items outside the table 
(the title in this case). 

Including non-tabular information within 
a table box makes it more difficult for 
FlexiPDF to discover the structure of the 
table itself.

This page has been marked-up with 2 
tables and an graph (render zone).

Once saved, the document can be used to 
form an annotation plan for use by Argus.

Using the PDF template with Argus
Argus needs to scan the PDF, extract the specifications of marked-up regions and 
store this as an annotation plan. To do this, execute:

argus -a lim.plan template.pdf

where lim.plan is the name of the plan file that will be generated and template.pdf is 
the PDF that has had the annotations added to it using FlexiPDF.

The plan file produced in this example is:

[ANNOT PLAN]
 0.Image Box =1 [530.30, 42.48, 283.51, 578.70] 0 “Auto-generated 
Chromatogram”;
 1.Table Box =1 [262.04, 105.92, 169.78, 289.33] 0 “Peak Results”;
 2.Table Box =1 [651.66, 43.15, 551.55, 544.33] 0 “Sample 
Information”;
[-- END --]

Continued...
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The new plan file should be included in the configuration file you intend to use for 
exporting:

ICENI PREFS
OWNER:Argus
VERSION:500

#include charMaps/htmlSimple.cmap
#include spool.cfg 
/* Load the lim annot plan */
#include lim.plan

[Argus Controls]
Built In Fonts Dir =./fonts;
CMAP Path =./cmaps;
...

An example configuration file (lim.cfg) is included in the Argus distribution. To use 
this to process a single PDF report:

argus -t -c lim.cfg report330.pdf

where report330.pdf is the name of the PDF being processed and -t indicates that only 
annotated items are to exported (other page contents are to be ignored). 

A simple HTML-based output file will be generated in docs/report330/

Notice the use of the LABEL macro in the example configuration file lim.cfg:

[PIC]
Start =<TABLE><TR><TD>
         <IMG SRC=”[FILENAME]/image[PAGENUM]-[PIC _ NUM].png” 
              width=[WIDTH] height=[HEIGHT] BORDER=1 
		     ALT=”LABEL:[LABEL]”>
         <CAPTION align=bottom>LABEL:[LABEL] [CAPTION] 
		     </CAPTION>
       </TABLE><HR>;

The facility is of most use when spooling, as in:

argus -c lim.cfg -t -s

which uses the [SPOOLER] settings in the #include spool.cfg to place Argus in spool 
mode. In this mode, the process sleeps until a PDF arrives in the target folder. It is 
then processed and either deleted or moved to a ‘done’ folder.

Continued from previous page
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Exporting content for translation
FlexiPDF can export the text of a document, automatically tagging each paragraph 
with its original location. You can export a range of pages, individual stories or 
specific marked text boxes (see “Marking text blocks for translation” on page 213).

This text can then be translated using any other software (e.g. Trados,  Across TM, 
Déjà Vu, Google) and re-imported back into the document by FlexiPDF. As FlexiPDF 
imports the translated text, it uses tags embedded in the PDF during export to 
determine both the correct location and basic text styles of text being imported.

If translated text is too long to fit into the original text boxes, FlexiPDF can subtly 
adjust its spacing to make it fit. 

It is very important to ensure the current spell-check language matches that of the 
text being exported. If it does not, soft-hyphens will not be correctly removed during 
export.

Pro

Continued...

Open the PDF you want to translate.

Choose: 
Document > Translate > CAT Export.

Choose the extent of the text you want to 
include in the export. You may prefer to 
work on a few pages or a single story at a 
time rather than the entire document.

Check Limit to marked content only to 
export only those text boxes which you 
have already marked for export. See 
“Marking text blocks for translation” on 
page 213.

- Current Story is only available if you 
were editing text when you chose to begin 
the export. If selected, the active text box 
and any linked to it will be exported as a 
single story. 

Use the Text Order tool to link text 
blocks together to form stories, 
prior to beginning the export 
process.

1
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Continued from previous page

Once exported, FlexiPDF will remind you 
to save the document. This is crucial since 
the export process will have added tags 
not only to the text output but to the PDF 
itself. 

You cannot import the translated text 
back into the PDF unless this tagging 
information exists.

Saving a copy of the tagged PDF now 
ensures that you will be able to import the 
translated text back into it in future.

After exporting, the tagged paragraphs are 
highlighted. This will only be visible in 
FlexiPDF and does not affect the PDF.

You can hide this highlighting by 
choosing View > Text > Field Shading.

Tool-tips show the original contents of a 
tagged paragraph even after translation. 
This is visible in FlexiPDF only, and does 
not affect the PDF.

Exported paragraphs are highlighted

3

4

Continued...

Choose the format of the exported text. 

Simple XML is recommended since can 
encapsulate more text style information 
and can be used within most popular CAT 
tool.

2
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Continued from previous page

Notes
•	 A few XML tag definition files can be found in the Translation Support folder in the 

FlexiPDF Professional installation folder. These define the XML tags which should be 
ignored during translation. In most cases they have been created by customers and can 
be used with various popular CAT tools.

<DOC id=’translation test.pdf’> 
<STORY> 
<P id=’2’> 
<span style=’font-family:GaramondLight’><span style=’color:#000000’> 
Adstract automatically fields, reformats and exports text and graphics 
from display ads including recruitment, real-estate and motors ads.  
</span></span> 
</P> 
<P id=’3’> 
<span style=’font-family:GaramondLight’>

Example Simple XML output.

<STORY> indicates the start of a story (text 
block). 

<P id=’2’> means paragraph 2. 

<span> tags are used to record font 
changes.

Tags must nest correctly with the 
appropriate closing tags (such as </span>).

If you think your translation software may 
corrupt the syntax of the XML during 
editing, then it is best to us the Plain text 
export format.

<S>
<P5>
<F12>Designing Wood Schools
<S>
<P6>
<F11>When it comes to designing an educational facility, architects and designers 
must balance the reality of limited financial resources with the desire to provide 
students with an exceptional learning environment that is warm and enriching. As a 
result, many are choosing to use wood as both a structural and finish material. 

Example Plain text output.

<S> indicates the start of a story (text 
block). <P5> means paragraph 5. <F11> 
indicates a font change to font 11. 

The fonts used in an export are listed at 
the end of the text file and should not be 
edited.

There are no closing tags in this format 
(no need for </P> for example). This 
makes the format much more robust in 
the face of syntax errors that may be 
introduced during translation.
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Marking text blocks for translation
Rather than exporting whole pages or stories, you can limit the export to only those 
text boxes that have been marked for export. This maybe useful in a catalogue for 
example where product names can be left out of the export to ensure they do not get 
modified during translation.

Marking-up for export has been designed to offer a very rapid workflow for the 
translator who does not want all of a document to be translated.

All of the following operations require that marking mode is active.

Marking whole text boxes for export

Switch into marking mode, by 
choosing Document > Translate > 
Mark Text Boxes For Export.

On switching into this mode, the 
boundaries of text boxes will become 
visible and the Object tool will be selected, 
though you are free to switch between the 
other tools.

To avoid accidental changes to the 
document during markup, you cannot 
change the position or size of objects when 
in this mode.

Continued...

Drag-out a selection to mark a number of 
boxes at once. Mark text boxes across any 
number of pages.

Click on a text block to mark it for export. 
Click again to unmark it.
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Continued from previous page

Partially marking text boxes
When you want to export only part of a text box, you can rapidly split the text box, 
marking one part and leaving the remainder unmarked.

There are two ways to do this whilst in the markup-up mode:

Method 1: Splitting by rectangle

Use this method when you want to grab 
and mark all the text in a rectangular area.

With the Object tool active, Ctrl+Shift drag 
around the text to be marked.

When you release the mouse button, 
FlexiPDF will rebuild the text boxes 
covered by the drag and then mark the 
resulting box for export.

2

1

Method 2: Splitting by text selection
Use this method when the content to be 
marked cannot be isolated by a rectangle 
but needs an exact character selection.

Using the Object tool, Ctrl+drag the text 
you want to markup.

Continued...
1
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Notes
•	 If you split text boxes, do not make edits to the resulting unmarked text boxes. The 

split may leave gaps were the marked text was located (as in (2) above). Reflowing will 
shuffle-up the remaining text, eliminating these gaps.

•	 The order in which you mark boxes, does not effect the export order.
•	 It may be handy to make the translation toolbar visible - View > Toolbars > Translation.

•	 Changing pages may be a little slower since FlexiPDF has to compute the boundaries 
of text blocks as it displays each page (normally only done when you begin editing).

•	 When saved, FlexiPDF stores the status of each text block ready for the next time the 
PDF is loaded into FlexiPDF.

When you are finally ready to export 
for translation, be sure to check Limit to 
marked content only in the CAT Export 
dialogue box.

Only the selected text will be marked.

It will be removed from it’s original text 
box and placed into a new box.

In this example, the non-marked text has 
been shown in grey to better illustrate the 
extent of the marked text.

Continued from previous page

2

To unmark all text blocks throughout the document, choose: 
Document > Translate > Unmark All Text Boxes.



	 Translation	 216

Continued...

ProImporting translated text
To complete the translation of a PDF, you need to import the new, translated text back 
into the document. FlexiPDF will place each translated paragraph into the correct 
location in the document, reflowing, fitting and substituting fonts as required.

Open the PDF into which you will import 
your new text. This should be one saved 
immediately after your initial export. 
FlexiPDF will have embedded tagging 
information in that PDF which will now 
be used to relocate the text you are about 
to import.

Choose Document > Translate > CAT Import 
to display the import dialogue.

Press Browse to choose the text or XML 
file to be imported.

Make sure the current spell-check 
language matches the text being imported. 
If it does not, press Language to change the 
setting.

When the spell-check language does 
not match, words may not be correctly 
hyphenated during reflow.

Select Automatically fit text where needed 
to have FlexiPDF adjust the new text in 
order to get it to fit in the available space.

This may slow down the import 
considerably since the fitting process is 
quite expensive.

Press Fitting to control the details of how 
FlexiPDF fits the text. See “Automatic text 
fitting” on page 85 for details.

1
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Continued from previous page

Selecting Reset letter spacing will cause 
FlexiPDF to set all word and letter spacing 
to zero on imported text. 

Otherwise imported text will use the 
spacings of the original text.

It is normally recommended that this 
option be selected.

The dialogue indicates the number of Font 
substitutions rules in effect. The first time 
you import this will be 0. 

During the import, you may setup some 
font substitution. If you import again, 
the dialogue will then display a non-zero 
count of the number of substitutions in 
effect. 

Press Fonts to load, examine and modify 
these substitutions rules. See “Managing 
font substitutions” on page 219 for more 
details.

Press OK to begin the import.

The first part of the process checks to see 
if the fonts currently used in the document 
contain all the characters required by the 
new text.

For example, when translating from 
English to French, some of the embedded 
fonts in the PDF may not include the 
necessary accented characters common in 
French.

This phase is described on the next page.

4
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Font problems during import
If the new text requires some characters that are missing from the fonts used for the 
original text, the Font Problems dialogue box will appear.

The problem font (in this case 
FrutigerBold) is shown together with a 
list of required characters. These may 
be missing because the font is a subset, 
embedded in the PDF or it may be that 
the font just does not cater for those 
characters.

As each font problem is presented, 
FlexiPDF will highlight an example usage 
of the font in the main document.

You can choose to substitute another font 
or ignore the problem.

In some case, especially with symbol or 
decorative fonts, it is best to ignore the 
problem by pressing Ignore.

If you do not wish to ignore it, choose an 
alternative font from the Substitute Font 
drop down list.  This list includes all fonts 
in the document plus those loaded from 
your computer.

Should the substitute font not contain all 
the required characters, FlexiPDF will 
prompt you to choose again.

It is usually best to choose a font from 
your computer’s font library rather than 
one from the PDF. These are the ones 
listed after the dividing line in the drop-
down list.

Each time you Ignore or Change a font, 
you will be presented with the next font 
problem.

1
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Continued...
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Once all font issues have been resolved, 
the second phase of the import starts.

FlexiPDF scans the new text for changes 
with respect to the existing content of the 
PDF. When a modified paragraph is found, 
it is imported.

Managing font substitutions
FlexiPDF remembers the font substitutions made during CAT Import and uses them 
for subsequent imports. You can view, edit, export and load the complete set of 
substitutions by choosing Document > Translate > Font Substitutions or by pressing 
the Fonts button in the Import Translation dialogue box.

The dialogue displays all the current font 
substitutions.

These will apply to any document loaded 
and not just the last one on which a CAT 
Import was performed.

To change an existing substitution, select 
it in the list. 

The details of the selected entry are then 
displayed in the two pop-up menus below 
the list.

Choose a different Original Font or 
Replacement Font and then press Change 
to store the new settings back in the list 
above.

Continued from previous page

Continued...
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Continued from previous page

The Load and Save enable you to save a 
permanent copy of the font substitutions 
to disc for use later.

The plain text format file can be edited by 
hand and passed onto others that may need 
the same set of substitutions.

Is is useful to save the current set after 
working on a document so that it can be 
loaded prior to the next time you need 
work with the CAT Import function.

% Font Replacements for PDF “W:\PDF documents\Wood _ Schools-fielded.pdf”
% Generated by FlexiPDF
% This file may be edited by hand and re-used in FlexiPDF
% --------------------------------------------------------

FrutigerBlackItalic -> CenturyGothicBoldItalic
FrutigerBold -> CenturyGothicBold
FrutigerBoldCn -> ArialNarrowBold
FrutigerBoldItalic -> CenturyGothicBoldItalic
FrutigerLight -> CenturyGothic
FrutigerLightCn -> ArialNarrow
FrutigerLightItalic -> CenturyGothicItalic
FrutigerRoman -> CenturyGothic
FrutigerUltraBlack -> CenturyGothicBold

Example substitutions text file generated by FlexiPDF
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Translation Tips
Where text flows across columns 
or pages, connect the text blocks 
together using the Linked text tool.

Once connected, remove any unwanted 
paragraph breaks at the end of each block 
(which will have been added before the 
blocks were connected.)

See “Editing text across columns & 
pages” on page 58.

Reflowing the text during import is slower 
when the text is fully justified.

To avoid this when dealing with long 
stories (such as a chapter of a novel) 
change the text justification to Left 
justified prior to import.

The import will be faster and the 
justification can be changed back once it is 
complete.

For similar reasons, using Auto fit on 
long stories can be slower. Do the auto-
fitting after the import has been done by 
choosing Text > Align > Full whilst editing 
text.

When translating a long document, deal 
with a section/chapter at a time.

Since the export process requires a large 
amount of computer effort and memory, 
keeping exports to no more than 100 
pages at a time will improve throughput 
considerably.

1
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Continued...
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Continued from previous page

1.	 Enable View > Text > Boundaries to make it easier to see the shape of text boxes.

2.	Ensure spelling language is matches the language used in the PDF - this has a big 
effect on hyphenation and thus reflow.

3.	 Some text boxes may need merging. e.g. FlexiPDF may split a column of text into 
separate boxes for headline, body, headline, body etc. 
In this case use the Object tool (blue arrow) to drag a box around these boxes, then 
choose Text > Text Box > Merge Vertically to ensure they become one single box. 

5.	 When you link text boxes you may have some unwanted paragraph breaks.  
Prior to linking, every text box ends with a paragraph break. When you link them 
together, FlexiPDF will look to see if those breaks are necessary or a consequence 
of the text breaking across boxes and remove those it thinks are not required.  
This is only an educated guess so you may find a lingering paragraph break where 
none is needed. After reflow, this paragraph break may end up somewhere in the 
middle of an adjacent text box. Remove them to restore the original flow.

6.	When linking text boxes the text is not immediately reflowed and should look no 
different. However, when you reload a document with linked boxes and begin to 
edit, those boxes are reflowed prior to your first edit. It is at this point that you may 
see reflow issues for the first time.

7.	 Unless you have already reshaped a text box, FlexiPDF will automatically extend 
the final text box in a sequence to avoid losing text. If you reshape that box it will 
remember that new shape and no longer alter it.

8.	FlexiPDF sometimes doesn’t correctly guess paragraph alignment. It may for 
example assume text is left aligned when it should be fully-justified. Unless you 
check by looking at the alignment buttons in the toolbar, this will only become 
apparent after a reflow. Left justification typically uses more space than full-
justification which means such text may overflow.  
To correct this, just click in the paragraph and press the correct alignment button 
on the toolbar.

9.	 The text in a document may be generally squeezed a little to achieve a certain 
layout. Although FlexiPDF attempts to calculate the actually global adjustment 
used, it may not exactly match and the text may tend to overflow. 
To remedy this, click on one of the text boxes in a linked chain using the Text tool 
then choose Text > Align > Full and choose the Medium option.
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Open your PDF.

This example uses a basic envelope design 
produced using FlexiPDF or any other 
design application capable of generating a 
PDF.

Using the Text tool, drag out a 
central text box for the address. 
Ensure it is big enough to 
accommodate most addresses.

Enter some sample text to indicate where 
the user should type.

Choose a font and size for the sample text 
so that users of the template do not need to 
bother. 

Basic templates
FlexiPDF Professional can be used to setup PDFs ready for 
interactive editing with lesser versions of the 
software. 

Individual objects in the PDF can be locked 
and restrictions added to control the way the 
document can be edited in future such as limiting 
the colours that can be used.

FlexiPDF Professional can also create variable 
PDFs for use with Infix Server. These can include 
variable elements for large-volume, automated 
creation of customised PDFs.

Email:        
   sales@softmaker.com

Web:          
   www.softmaker.com

Fax:          
    +49 (0) 911 303 796

Telephone:  +49 (0) 911 936 3860

Address:       Kronacher Str. 7 - 90427 Nuremberg - Germany

TO ADDRESS

Date:

RE:

Dear Sir/Madam,

"Your all-around PDF editor"

RECIPIENT'S ADDRESS HERE

Sender:   SoftMaker               Kronacher Str. 790427 Nuremberg                Germany

1

2

[FIRSTNAME]

[JOBTITLE]

[FAMILYNAME]

email: [EMAIL]

mobile:[MOBILE]

landline: 01603 628289 / x25IDZat

Continued...

Pro
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Continued from previous page

Choose Document > User Restrictions to 
display the User Restrictions dialogue box.

Use this dialogue to limit how users 
interact with the template. For example, 
limiting the fonts they can use when 
editing.

Press OK then save the PDF as normal.

3

User restrictions
Once applied, User Restrictions are effective in all versions of FlexiPDF but can only 
be removed or altered using FlexiPDF Professional.

To view and change the restriction choose Document > User Restrictions or click on 
the Restrictions hyperlink in the Document > Properties dialogue box.

•	 Approval required after editing 
Documents based upon templates will have an ‘Approval Required’ watermark 
added when saved. This can only be removed using FlexiPDF Professional.

•	 Basic flight check on save 
FlexiPDF checks for a minimum of 300dpi resolution on all images in the PDF 
and for CMYK colour spaces. This is in addition to the standard check for overset 
text. 

• 	 Edit using existing fonts only / Edit using existing colours only 
Limits the available fonts and/or colours that can be used to those already in use in 
the PDF. This helps to ensure users do not deviate from the initial design goals or 
corporate identity colour schemes.

When colours are restricted, users are presented with the Swatches dialogue when 
they wish to change the colour of an object.

•	 Disable text scaling 
When scaling objects, text boxes are not be affected.

Pro

Continued...
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•	 Lock left alignment of all objects 
Limits the directions in which objects may be moved. 
Text boxes may be resized to allow for more text for example, but their position 
along their x-axis cannot be altered. This is to help maintain the essence of the 
design’s original layout.

•	 Preserve aspect ratio during scaling 
Ensures that no objects can be stretched out of proportion. Any scaling is applied 
equally to both x & y axes.

Continued from previous page
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Embedded font & colour resources
To ensure portability and ease of editing, templates should include embedded font 
definitions for all the character shapes likely to be used.

For templates with a restricted colour palette (see “User Restrictions” earlier in this 
section) it may be necessary to define optional colours not yet used in the template 
but that may be used in future.

Both of these requirements can be met by including a “resource page” in your 
template.

An example resource page containing two 
fonts and four colours.

The page can be prepared within 
FlexiPDF or using any other editor capable 
of generating PDF.

Choose: 
Document > Resource Page > Add to embed 
the resource page within the currently 
open PDF.

The resource page will not appear as part 
of the document in any PDF viewer and 
will not be output if the PDF is printed.

Checking resource pages
The Document Properties dialogue box will show the existence of a resource page in a 
PDF.

Choose Document > Resource Page > Extract to copy the embedded page to a new file 
and view it in FlexiPDF.

Pro

abcdefghijklmnopqrstuvwxyz 
ABCDEFGHIJKLMNOPQRSTUVWXYZ 
0123456789 !"£$%^&*()[]
{};:'@#~`¬<>,./?-=_+\

Bistream Vera Sans

abcdefghijklmnopqrstuvwxyz 
ABCDEFGHIJKLMNOPQRSTUVWXYZ 
0123456789 !"£$%^&*()[]
{};:'@#~`¬<>,./?-=_+\

Bistream Vera Sans Bold



	 Templates	 228

Dynamic text using tokens
For Infix Server to accurately find the target text you wish to replace in your 
templates, the text should form unique names or tokens.

[FIRSTNAME]

[JOBTITLE]

[FAMILYNAME]

email: [EMAIL]

mobile:[MOBILE]

landline: 01603 628289 / x25IDZat

For this business card, the artwork has 
been produced with tokens specifying the 
location of text to be replaced.

The token text’s font, alignment, margins 
etc. will be retained when it is replaced by 
Infix Server.

Dear [CNAME],

Thank you for purchasing the [PRODUCT] on 
[PDATE].

We would like to take this opportunity to 
remind of our aware-winning after-sales 
care and invite you to sign-up for our free 
newsletter covering all aspects of the 
[PRODUCT]  plus hints and tips for getting 
the most out of it.

Here the tokens have been included within 
the body text. 

When replaced, the body text will be 
reflowed to ensure correct layout.

The [PRODUCT] token is using a different 
font to the rest of the body text.

Notes
•	 To ensure predictable reflow after token replacement in body text, prepare the PDF 

using FlexiPDF, setting text-box sizes and paragraph alignments etc.
•	 Reflow behaviour can be controlled by the name of the tokens themselves. This is 

useful for templates that have not been prepared using FlexiPDF. See the Infix Server 
user manual for more information.

Pro
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Dynamic text using fields
The use of tokens such a [JOBTITLE] in a PDF template where layout or spacing is 
critical is sometimes impractical. In these cases, a block of existing text can be given 
a name without affecting the text itself. This name can then be used as a target for 
replacements via Infix Server.

In this example the box containing “A” is 
too small for a token such as [SECTION].

Using the Text tool, select the “A”.

1

Choose Text > Tag > Properties.

Enter the token name into the Name text 
box. 

This is the name that will be used in the 
Infix Server configuration file.

2

Continued...

You can, optionally, control the way Infix 
Server will reflow the replaced text.

These two pop-ups behave the same way 
as those in the Replace Format Dialogue 
used during Find & Replace.

3

Pro
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Continued from previous page

Choose View > Text > Field Shading to have 
FlexiPDF highlight text fields. 

The colour used for each field is decided 
by FlexiPDF.6

4

The Control option instructs Infix Server 
to delete the field and its containing 
paragraph should it become empty after 
processing.

The content of the Description field will be 
shown in a tool tip window whenever the 
mouse hovers over a text field. 

5
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Fields and tabstops
Tab stops inherit the field-id of the preceding character no matter what that character 
is - visible glyph or control characters such as paragraph mark.

To change this behaviour you need to alter the tabstop in question. 

Here the right-aligned tab before 
Telephone Number field has inherited the 
field id from the previous line - Address 
Line 3.

Instead we want the tab to have no field 
id - it should remain unchanged once data 
has been put in the template.

Right-click the tabstop mark in the ruler to 
reveal the Tab Options dialogue box.

By default Can be part of text field is on. 
Turn it off now and press OK.

The screen will refresh and the field 
shading over the tabstop should disappear. 

When saved and reloaded or used by Infix 
Server, the tabstop will remain un-fielded.

1

2

3

A tabstop is inheriting a field 
id when we do not want it 
to (hence the background 
shading).
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Click on Replace scale mode to alter the 
way in which the image is scaled when 
replaced.

Two scaling modes are available during 
automated image replacement:

• Crop to fit 
• Fit inside

The affect of each mode is illustrated 
below:

2

Dynamic images
Images can be named so that they can be targeted for replacement using Infix Server. 
You can also control the scaling used when the image is replaced.

Choose the Object tool.

Select the image you want to name 
then, using the right-mouse button,  
choose: Tag.

The Tag dialogue box lists all of the 
attributes that can be applied to an image. 

Click on the Image name property and 
enter a new value in the Value field at the 
bottom of the dialogue.1

Fit inside Crop to fit

Pro
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Naming multiple images
FlexiPDF Professional offers a short-cut for naming multiple images for dynamic 
replacement by Infix Server. This also offers a way of checking whether images have 
been named already.

In this example we will attribute a name to 
each image in a real-estate advertisement, 
ready to be used as a template by Infix 
Server.

Choose the Object Tool from the 
toolbar.

Then choose: 
Object > Image > Tag > Ordering from the 
main menu bar.

1

2

Enter a base Image Name for your images 
and set the scaling mode to be used for 
each. See the previous page for details of 
scale modes.

The settings for individual images may be 
altered later by using the method detailed 
on the previous page.

Continued...

Pro

3

Click on each image to name it.

Every time you click an image it will be 
given a name by applying a new suffix to 
the base name you supplied.  
For example Image-1, Image-2, Image-3.

The name will displayed within the 
bounding box of the image.
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An example of an image showing its label 
“Image-4”.

To finish naming images choose: 
Object > Image > Tag > Ordering or change 
to another tool.

Choosing: 
Object > Image > Tag > Ordering at any 
time in the future will show any existing 
image labels.

Continued from previous page

4
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Dynamic line-art & graphics
By grouping objects together with a text field, the entire group can be made to appear 
or disappear depending upon the value of the text field.

This car ad template includes a triangular 
sign for carrying optional messages such 
“SOLD” or “SALE”.

If no substitute text is provided in the Infix 
Server configuration file, the sign can be 
automatically removed.

This approach may also be used together 
with Text Fields. 

Creating optional artwork
1. Use the Object Tool to select the artwork and associated text then group 
them together using the Object > Group menu option.

2. Ensure the text field has the “.d” 
suffix. This tells Infix Server to 
delete the containing paragraph if it 
becomes empty.

If Infix Server does delete the containing 
paragraph, it also deletes the other items in 
the group leaving just the text box and any 
other paragraphs it may include. 

Pro
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Dynamic page size
It can be useful if a template automatically grows to fit the text being flowed into it. 
Infix Server can do this by extending the length of a page and crop box as well as 
stretching and moving any relevant graphics and page furniture. 

Using the Object tool click inside 
the main text box of the ad.

The size of this text box after 
substituting text will be used to re-size the 
entire ad.

Only one text box can be used to control 
overall ad-size.

1

Choose: Text > Tag.

• Set Can Grow to True 
This means that  instead of text overflow 
resulting in an overset text box (and the 
text being invisible), the text box will grow 
downwards to accommodate all the text 
placed in it.

• Set Move Objects Below to True 
All objects below the bottom line of the 
text box will move as the text box grows 
this includes any text, borders and the 
actual page size itself.2

Continued...

Pro
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Continued from previous page

Objects above key text 
box will not be moved or 

stretched.

Between top & bottom of key text 
box, objects will be stretched as 

the text box grows

Objects will be moved down as 
key text box grows

Unchanged

Key text box has been extended. 
Border around ad has been 

stretched in proportion to the text 
box’s growth

Objects moved downwards

Flowing new text into the key text box 
causes the ad to grow (along with the page 
& crop box)

Continued...
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Controlling dynamic page growth
To ensure pages grow in predetermined steps (½ inch steps for example), set the 
Growth Step in the Tag dialogue box to the required point size.

Here the Growth Step has been set to ½ 
inch. This means the entire ad will extend 
downwards in jumps of ½ inch. 

This includes the page’s media box and 
crop box.

Notes
•	 The minimum size of the page is the size before any substitutions have been made. 

That is, the size when preparing the template in FlexiPDF Professional.
•	 Decorative, repeating borders and certain kinds of artwork may not respond well to 

being stretched vertically. Hence this approach may not be suitable for all ad types.

Continued from previous page
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Editing preferences
Access this pane from: 
File > Preferences.

Unit of measurement
Choose from Inches, Centimetres, 
Millimetres, Points and Picas. This 
setting affects the ruler display and the 
units used in most dialogue boxes when a 
distance or size value is required. 

Default Editing Tool
When a document is first opened, 
FlexiPDF switches to the Text Editing tool 
by default. You can change this behaviour 
and have it select another tool instead.

Show changed text in:
When enabled (checked) FlexiPDF will highlight edited text in the chosen colour. 
This highlighting will only be visible when the PDF is viewed or printed from 
FlexiPDF and will not show in any other PDF viewer.

Insert smart quotes
When enabled, FlexiPDF will try to convert plain quotation marks as typed from 
the keyboard into “curly quotes”. This may not be possible if the font used does not 
contain either the opening or closing curly quotation mark.

Paste text with formatting
When pasting text into a PDF from another application FlexiPDF can ignore or take 
notice of the formatting of the text. If this option is checked, FlexiPDF will try to 
replicate the format (font, colour, size) of the text as it is pasted. 

When not checked, text is always pasted using the current selected font, size and 
colour.

User-defined stamps folder
The location of a folder containing user-defined stamps. By default this edit box is 
empty. See “User-defined stamps” on page 163 for details.
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Editing preferences: Advanced Settings

Detect bold / overprint text
Some documents simulate bold text by overprinting text rather than using a bold 
version of a font. Normally FlexiPDF identifies overprinted characters on each page 
and converts those found into single bold characters. 

This check can be disabled to improve speed on complex pages or if FlexiPDF is 
incorrectly identifying overprinted characters.

Detect tabs and Leader dots
Prior to editing, FlexiPDF searches for sequences of dots used as spacers in tabular 
layouts such as the table of contents in a book. These leader-dot sequences are then 
given special treatment by FlexiPDF and converted into a leader tab. This means that 
during editing, the leader dots will grow/shrink correctly.

FlexiPDF also searches for large gaps between words and inserts equivalent tabstops 
instead which also makes it easier to edit tabular data and bullet-lists.

Occasionally this may adversely affect the layout of a page. It may also cause a 
significant initial delay on some more complex pages. 

Detect underlined / strike-through text
Prior to editing, FlexiPDF searches for all text close to a graphic line of similar 
length. It then removes the line and assumes the text was either underlines or strike-
through depending upon the position of the line relative to the text.

Occasionally this may yield undesirable results or cause a significant initial delay and 
may be disabled for this reason.

Include cropped text when editing
When editing begins, FlexiPDF normally grabs all text on a page and converts 
it into a form ready for interactive editing. When this option is enabled, it will grab 
all text, even that hidden from view by a page crop. This is useful for searching text 
that would otherwise be missed.

When disabled, you can use a page crop to limit the amount of text on a page that 
FlexiPDF will ‘see’. This is useful for narrowing the affect of a search and replace or 
for reducing unwanted layout changes at the start of editing.

For example, doing a search and replace on a document’s page headers is difficult if 
the page header uses the same font and size as the rest of the document. How do you 
tell FlexiPDF to only search in the header and ignore the rest of the page contents?
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The answer is to disable this feature, place a crop around the header area using the 
Crop tool ,  then do the search and replace operation.  

FlexiPDF will not only limit the search to text within the crop, it will also leave 
all other text unaltered. After the search has finished, the crop can be removed by 
choosing Document > Pages > Remove Crop to reveal the complete page text.

Diagnostic editing mode
This option is included for diagnostic use only. It stops FlexiPDF from converting 
the text on a page into an editable form. Objects may still be manipulated but no text 
editing can be performed whilst this option is enabled. 

The option is turned off each time FlexiPDF is started.
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Loading preferences
Access this pane from: 
File > Preferences.

Default zoom
This is the zoom level used when a 
document is opened. It does not alter the 
PDF in any way.

Override initial zoom
When enabled, FlexiPDF will ignore 
any initial-zoom suggestion contained 
within the PDF and use the Default Zoom 
specified above. 

Initial View/Zoom/Page
Use these options to affect the way the current PDF is displayed when opened in 
FlexiPDF or any other PDF viewer. You will need to save the PDF again in order for 
any changes made here to become permanent.
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Saving preferences
Access this pane from: 
File > Preferences.

User name
This is the name that will be stored in the 
change log (see “Tracking changes” on 
page 149) generated whenever edits are 
made to a PDF. It is also used to name any 
sticky-notes, stamps or other annotations 
you place on the document.

Make a backup when saving files
When using File > Save FlexiPDF can make an backup of the original file named 
“Backup of myfile.pdf”

This can be disabled for large files or when saving over networks. 

Autosave every:
When active, FlexiPDF saves a recovery backup of the current PDF every few 
minutes. A gap of around 10 minutes is reasonable. You may wish to increase the 
interval or disable auto-save for large files or when saving over slow networks.

If you need to recover changes to a document after a crash, open the document you 
were editing. FlexiPDF will detect any autosave file that exists and ask you if you 
want to open that instead.

Store layout info in PDF
When saving an edited PDF, FlexiPDF stores additional information such as tab-stop 
positions, paragraph alignments, indents and margins etc. This makes it easier to edit 
the PDF using FlexiPDF or Infix Server but also increase the size of the PDF file.

Choose Never if you want to keep the PDF file as small as possible and do not need to 
keep the information.

Choose Always if the increase in file size is less important than ease of editing (or if 
you are making templates for Infix Server)

Choose Sometimes to let FlexiPDF decide. This is the default. 

Continued...
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Spelling preferences
Access this pane from: 
File > Preferences.

Language
This specifies the language to use for 
spell-checking and for hyphenation. 
It is important that this setting always 
matches the language in your PDF 
document. If it does not, the spell-
checker will be ineffective and the reflow 
of your text will not work correctly.

FlexiPDF ships with only UK and USA 
English language spelling dictionaries 
but does include all hyphenation 
dictionaries. If you choose a non-English 
language FlexiPDF will ask you if you 
wish to download the installer from SoftMaker’s website.

Though checked by SoftMaker, these installers are prepared by third parties and 
install the spelling data required by the ASpell system used by FlexiPDF. If you have 
access to more up-to-date spelling dictionaries, then these can be used instead of the 
ones hosted on SoftMaker’s website.

Ignore words in UPPERCASE
Instructs the spell-checker system to skip words consisting of all upper-case letters.

Ignore words with numbers
Instructs the spell-checker system to skip words that contain numbers such as “HT4”

Hyphenate words
To better fit text within its text box, FlexiPDF will hyphenate certain words 
according to language-specific hyphenation rules. This is mainly used on fully-
justified paragraphs but can also affect normally justified text. Disabling this feature 
will have a document-wide effect. 

To disable hyphenation on a per-paragraph basis, press the right-mouse button when 
editing the paragraph and choose Disable hyphenation (Pro only).

User Interface language

Continued from previous page
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The software is available in a number of different languages. If this drop-down 
menu does not list the language you require, please re-install the software. During 
installation, you will be prompted to choose the user interface language to be 
installed.

If you do not have a copy of the installer, please download the latest FlexiPDF demo 
from SoftMaker’s website (www.softmaker.com). 

If you are using an older version of the software, you can download a copy from the 
download page at www.softmaker.com/en/download



☞☞ Custom spelling dictionaries
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☞☞ Fonts in PDF
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Editing non-English text
When editing PDFs written in various different languages please remember the 
following:

•	 hyphenation will only work if the correct language is chosen using the  
File > Preferences menu option. If the correct language is not available, it may 
be better to disable hyphenation.

•	 spell check requires the correct language to be specified using the  
File > Preferences menu.

•	 FlexiPDF only supports editing of text read left-to-right. This means editing of 
Arabic & Hebrew texts is not supported.

Double byte support
FlexiPDF fully supports copy/paste of double-byte characters.

A double-byte character can be typed directly by holding down Alt while entering the 
decimal value of the character using the numeric keypad (ensure that ‘NumLock’ is 
lit on your keyboard). The character will be inserted when you release the Alt key.

For example: Alt+0190 = ¾ 
(you do not need to type the ‘+’ character)

The character codes can be found by using the Character Map utility in most versions 
of Microsoft Windows. 

Display of double-byte Characters
When a PDF does not include a required font, FlexiPDF substitutes one of its built-in 
fonts. These fonts cover the standard Latin character sets plus Hiragana, Katakana 
and a selection of special characters. 

If you install the optional Asian Font Pack (available from www.softmaker.com/en/
download) the built-in fonts can be extended to include a useful selection of Chinese 
and Japanese characters.

Characters for which no substitute exists will appear as squares in FlexiPDF but may 
display correctly in other viewers.
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Fonts in PDF
To be truly portable, a PDF must include all the fonts it needs to display correctly. 
These embedded fonts describe the way in which each character is drawn.

Typically there will be some characters in a font that are not used in a PDF. In this 
case, a font-subset may be embedded to help reduce the size of the PDF.

A PDF may also simply name the fonts it needs rather than include them. Provided 
the viewer’s computer has the named fonts installed, the PDF will display correctly. If 
not, the viewer program will try to use a substitute font that is similar in appearance.

Certain fonts are always available on every computer that can view PDFs. These are 
Courier, Times, Helvetica and Symbol. Consequently these fonts are not commonly 
embedded.

Font considerations 
Editing text written with a font that is embedded does not normally present any 
problems - all of the font’s characters are available.

When just a subset of a font is embedded, FlexiPDF will search for the required font 
within your computer’s system fonts and will automatically load and use it if found.

If no match can be found, you will have to use a different font instead.

For example, a PDF that contains a single headline written in the font “Joseph’s 
Brush”:

may include character definitions for the following letters only:
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Custom spelling dictionaries
When you press the Add button during spell check, FlexiPDF records the word you 
are adding in a custom dictionary file on disc. 

If you add a word by mistake you can edit the custom dictionary by hand using any 
standard text editor (such as Notepad).

If you already have a custom dictionary you want FlexiPDF to use you can add its 
contents to FlexiPDF’s existing dictionary using a text editor.

Locating the custom dictionary
All of the personal word list files (*.pws) for each language are stored in the same 
folder. A *.pws file is only created if you have added words during a spell check,.

On Windows XP, the default installation path would be:  
C:\Documents and Settings\<username>\Application Data\Aspell\personal

On Windows Vista, Windows 7 and 8: 
C:\Users\<username>\AppData\Roaming\Aspell\personal 
or  
C:\Users\<username>\AppData\Local\Aspell\personal

Format of custom dictionary
The *.pws dictionary file is a simple list of words, each on a new line. An example is 
shown below:

personal_ws-1.1 es 7  
Adstract 
Technology 
SoftMaker 
Ltd 
Bushnell 
Norwich 
Guy

The number at the end of the first line is the count of words in the list. The language 
code is prior to that - in this case ‘es’ for Spanish.

Changes to the custom dictionary will take effect the next time FlexiPDF is launched.
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